Homepage

Micro 'n Power

西门子 S7-200 · LOGO! · SITOP 参考

Beta Version 1.9

下载地址：

http://www.ad.siemens.com.cn/download/searchResult.aspx?searchText=A0136

电子邮箱：

support.china.automation@siemens.com

技术资料，仅供参考；由此引起的一切后果，概不负责
保留所有权利


What's New?

V1.9 ... ... 26.10.2017

新增：

S7-200部分

  • 添加关于S7-200CN 和TD400C 产品退市的通知
  • 添加Wincc通过SIMATIC NET与CP243-1通信操作指南
  • 添加远程通信MD720操作指南
  • 添加SIMATIC NET与EM277的 S7连接（TIA平台）操作指南
  • 增加S7-200 RS485 接口使用注意事项？
  • 增加CP243-1使用常见问题

LOGO!部分

  • 添加LOGO! 0BA7和0BA8 版产品订货号
  • LOGO! 0BA7和0BA8 版新特性
  • LOGO !0BA8系列产品硬件替代
  • 添加工作温度和宽温型产品文档介绍
  • 添加 LOGO!Soft Comfort 编程软件 使用介绍
  • 添加软件下载链接 新功能及安装环境
  • 添加如何新建电路程序
  • 添加如何新建网络项目
  • 添加数据记录归档
  • 添加信息文本显示器
  • 添加开关量接线
  • 添加模拟量接线
  • 添加logo面板操作
  • 添加LOGO与TDE连接程序中配置方法
  • 添加LOGO与TDE连接TDE配置方法
  • 添加使用TDE修改参数
  • 添加使用TDE修改字符集
  • 添加0BA7及以上LOGO!下载上传方式
  • 添加LOGO!8以太网通讯概述，主从通信，s7通信，modbustcp通信
  • 添加LOGO!8和s7-200smart 进行s7通信
  • 添加Web访问简介及使用方法

SITOP部分

  • 添加SITOP 电源产品目录2016.06（中文版）
  • 添加CE认证下载附件

更新：

S7-200部分

  • 扩展程序存储区——禁用运行模式编程功能中增加运行模式编程操作方法介绍
  • 数据保持功能中增加从 RAM 建立数据块介绍

LOGO部分

  • 资料手册在线下载
  • 产品认证书在线下载
  • 视频在线学习
  • LOGO!I/O配置
  • 软件安装与升级
  • LOGO的编程容量
  • 指令介绍
  • LOGO!Soft Comfort 相关常问问题
  • 模拟量数值比例换算
  • 模拟量相关常问问题
  • LOGO存储卡功能
  • LOGO的参数保护
  • LOGO菜单访问保护
  • 0BA6及以下LOGO!下载上传方式
  • 密码问题
  • 编程通讯常见问题
  • 为什么LOGO!0BA6不能通过LOGO!Soft Comfort V7.0下载程序

SITOP部分

  • SITOP直流稳压电源产品订货号增加选型样本连接

V1.8 ... ... 5.24.2016

新增：

  • 添加取整指令介绍
  • 添加指数对数指令介绍及例程
  • 添加FOR-NEXT循环指令介绍及例程

更新：

  • 添加间接寻址例程
  • 运动控制关于MAP库介绍
  • 运动控制关于PTO向导配置步骤介绍
  • 添加EM253例程
  • 添加S7-200做主站S7-300 CP341做从站的Modbus RTU通讯链接
  • 添加modbus RTU从站错误代码

V1.7 ... ... 2.1.2016

新增：

  • 添加industry mall 链接
  • 添加EM 231 8 通道模拟量模块输入配置开关表
  • 添加EM231 RTD 2AI DIP开关设置表
  • 添加EM231 RTD 4AI DIP开关设置表

V1.6 ... ... 10.01.2015

新增：

  • S7-200 AS-i 通信
  • S7-200 运动控制
  • 位逻辑，比较，转换，编码指令视频链接
  • 运算指令视频链接
  • 指示灯及CPU、SM诊断信息

更新：

V1.5 ... ... 07.01.2015

新增：

  • PC Adapter USB A2 适配器与S7-200 CPU 的编程通信
  • S7-200 高速计数器常问问题

更新：

  • 系列视频：S7-200跟我学/跟我做 链接
  • 更新电话服务热线信息
  • 添加若干常问问题

V1.4 ... ... 05.15.2015

新增：

  • 在 STEP 7 Micro/WIN 里怎样优化使用定时器?
  • 在 S7-200中如何对于一个项目实例进行间接域寻址
  • 运动控制相关文档链接

更新：

  • S7-200产品认证证书下载链接
  • LOGO! 和 STIOP 电源产品认证证书下载链接

V1.3 ... ... 12.20.2014

新增：

  • 在用户程序中修改CP243-1的IP地址
  • 符号寻址与绝对寻址
  • S7-200与S7-300之间的MPI通信
  • S7-200与S7-300之间的Profibu DP通信
  • S7-200与S7-300之间的以太网通信（CP243-1作为服务器端）
  • S7-200与S7-300之间的以太网通信（CP243-1作为客户端）
  • SIMATIC NET OPC Server与CP243-1的 S7连接
  • S7-200(CN)产地信息
  • S7-200认证书下载网址集合

更新：

  • 文档中的一些链接
  • STEP 7-Micro/Win 兼容性信息

V1.2 ... ... 10.01.2014

更新：

  • CPU224XP 集成模拟量接线
  • 软件包下载链接
  • CPU外形及电源

V1.1 ... ... 10.12.2013

更新：

  • S7-200 定时中断
  • 模拟量比例换算
  • SIMATIC NET OPC Server与S7-200/EM277的 S7连接

新增：

  • 如何查看S7-200 程序的系统扫描周期和子程序的执行时间
  • 添加新一个Modbus主站例子程序
  • 如何将LOGO!Soft Comfort 软件版本升级(更新)到最新版本
  • Soft Comfort V7.0向LOGO!0BA6下载提示更新问题

V1.0 ... ... 16.04.2013

TD200、400 相关FAQ更新：

  1. TD 400C文本显示器是否支持触发报警信息时自动从用户屏幕切换到报警屏幕？
  2. 触发报警信息时，如何不使用功能键切换屏幕查看该报警信息，而在TD 400C文本显示器的同一屏幕上自动显示？
  3. TD 200 V2.1和更早的版本的功能键位使用
  4. TD 400C文本显示器菜单屏幕与TD_CurScreen_0对应关系？
  5. 在TD 400C文本显示向导组态中，对（VW）字（无符号或有符号）类型的数据或（VD）双字（无符号或有符号）类型的数据设置“小数点右侧位数”的用途是什么？
  6. 如何避免屏幕上的数据显示"eeeeeee"或文本字符被数据覆盖?

更新：SITOP电源模块上的A/B开关有什么用？

新增：SIMATIC NET OPC Server与S7-200EM277的 S7连接

V0.98 ... ... 27.12.2012

新增：

  • STEP 7 Micro/WIN 指令库下载网址大全

V0.97 ... ... 09.08.2012

新增：

  • S7-200 自由口通信
  • STEP 7 Micro/WIN 软件帮助无法打开的解决方案
  • 如何实现高速计数器计数值的掉电保持？
  • LOGO！0BA7 通讯总览

更新：

  • LOGO！0BA7 S7 通信
  • 下载链接

V0.96 ... ... 21.12.2011

新增：

  • S7-200 E-Learning 视频教程链接
  • LOGO！0BA7 S7 通信
  • LOGO！0BA7 MS 主从通信

更新：

  • 通过以太网（CP243-1）编程

V0.95 ... ... 03.08.2010

新增：

  • 使用CP5711 对S7-200PLC的PPI通讯口进行编程通信

更新：

  • 软件下载链接

V0.94 ... ... 20.11.2009

新增：

  • S7-200 配方

更新：

  • 软件下载链接

V0.93 ... ... 10.12.2008

新增：

  • S7-200 - STEP 7-Micro/WIN V4.0 SP7 发布
  • LOGO! 0BA6 系列产品发布

更新：

  • 手册下载链接
  • 软件下载链接

V0.92 ... ... 16.02.2008

新增：

  • S7-200 - STEP 7-Micro/WIN V4.0 SP6 发布
  • S7-200 - PC Access V1.0 SP3 升级包发布
  • S7-200 - CPU 224XPsi CN 带漏型输出的新模块发布
  • S7-200 - EM231 8 输入新模块发布
  • S7-200 - EM232 4 输出新模块发布
  • S7-200 - EM231 RTD 4 输入热电阻新模块发布
  • S7-200 - EM231 RTD 8 输入热电偶新模块发布
  • S7-200 - BCD 码（ BCD_DI ， DI_BCD）指令库

更新：

  • S7-200 - 电源需求与计算
  • S7-200 - 最新（2007年9月）英文系统手册下载链接

V0.91x ... ... 02.08.2007

新增：

  • S7-200 - STEP 7-Micro/WIN V4.0 SP5 发布
  • S7-200 - USS 通信协议指令库升级（并增加支持 Port 1 ）
  • S7-200 - Modbus RTU Master （主站）指令库发布（支持 Port 0 和 Port 1）
  • S7-200 - PID 自动/手动控制模式间的无扰动切换
  • S7-200 - 数据记录表格在 Excel 中打开为何汉字是乱码

更新：

  • S7-200 - 模拟量传感器信号输入接线
  • S7-200 - 最大 I/O 配置
  • LOGO! - LOGO!Soft Comfort V5 中文界面更新

V0.90 ... ... 04.01.2007

新增：

  • S7-200 - Arcusfunctions （反三角函数）指令库
  • S7-200 - HMI 人机操作界面与 S7-200 的实时时钟同步
  • S7-200 - 32 DI/32 DO 扩展模块
  • S7-200 - 通过用户程序或 TD 按键控制屏幕显示

  • 网络资源 - 在线技术问题提交网站

V0.89 ... ... 29.09.2006

新增：

  • S7-200 - 与西门子驱动装置的连接
  • S7-200 - 与西门子驱动装置的 USS 通信连接
  • S7-200 - USS 通信的硬件接线
  • S7-200 - Micro/WIN 的 USS 指令库及编程
  • S7-200 - Port 1 上的 USS 通信指令库
  • S7-200 - Modbus RTU 从站指令库例程
  • S7-200 - EM 277 GSD 文件本地下载

  • 网络资源 - MM 4 系列产品操作手册下载链接

更新：

  • S7-200 - 模拟量换算指令库更新以支持双极性输入

V0.88 ... ... 15.08.2006

新增：

  • S7-200 - TD 400C 介绍及配置快速入门
  • S7-200 - 使用 TD Keypad Designer 自定义 TD 400C 功能键和面板图形
  • S7-200 - STEP 7-Micro/WIN V4.0 SP4 介绍及下载链接
  • S7-200 - 新增 SIPLUS 宽温型模块（-40℃ ... +70℃）

  • LOGO! - LOGO!Soft Comfort 中文编程界面公开测试
  • LOGO! - 新增 SIPLUS 宽温型模块（-40℃ ... +70℃）

V0.87i ... ... 30.06.2006

新增：

  • S7-200 - Micro/WIN 编程助记符从 Ix.x/Qx.x/AIWx/AQWx 变为 Ex.x/Ax.x/AEWx/AAWx 怎么办

改动：

  • S7-200 - Modbus RTU Master（主站）指令库升级到 V1.1 版

V0.87 ... ... 01.06.2006

增加：

  • S7-200 - Modbus RTU Master（主站）指令库（测试版）及其使用
  • S7-200 - EEPROM 数据写入指令库
  • S7-200 - Clock_Integer 整数时钟数据读写指令库
  • S7-200 - 高速计数器（HSC）指令配置向导
  • S7-200 - 高速计数器模式 12 支持 CPU 224 XP 的高速脉冲输出
  • S7-200 - STEP 7-Micro/WIN 通过 PC Adapter USB 与 S7-200 通信
  • S7-200 - Modbus RTU 数据地址与功能号的关系
  • S7-200 - 在 STEP 7-Micro/WIN 中找不到 CN CPU 怎么办
  • S7-200 - 用 STEP 7-Micro/WIN 设置 PLC 实时时钟
  • SITOP - SITOP select 诊断模块
  • SITOP - 双冗余模块并联的 LED 指示

改动：

  • 重新整理安排了“网上资源”

V0.86 ... ... 27.02.2006

增加：

  • S7-200 - 卸载 STEP 7-Micro/WIN 的问题
  • S7-200 - 用存储卡在 SIMATIC S7-200 和 S7-200 CN CPU 间传送程序

改动：

  • 中文名称改为《西门子 S7-200 · LOGO! · SITOP 参考》

V0.85 ... ... 23.12.2005

增加：

  • S7-200－S7-200 CN 新产品介绍
  • S7-200－STEP 7-Micro/WIN V4.0 SP3 介绍
  • S7-200－Level 4 密码保护功能
  • LOGO!－LOGO! 0BA5 版新特性
  • S7-200－DI 输入滤波问题
  • 新增最新版手册在线下载链接

V0.84 ... ... 01.08.2005

增加：

  • S7-200－S7-200资源管理器、归档数据自动上载

V0.83 ... ... 19.04.2005

增加：

  • S7-200－Data Log（数据记录）功能
  • S7-200－K-TP 178micro简介
  • S7-200－OP 73micro，TP 177micro简介
  • S7-200－TD 200功能键的对应数据位

修改：

  • S7-200－S7-200及HMI的连接能力
  • LOGO!－LOGO！Soft Comfort编程软件寻找计算机编程口

V0.82 ... ... 28.03.2005

增加：

  • S7-200－PC Access配置和使用
  • S7-200－PC Access通信设置
  • LOGO!－LOGO!编程软件的中文解决方案

修改：

  • LOGO!－LOGO!编程软件的升级/更新

V0.81 ... ... 18.03.2005

增加：

  • S7-200－设置编程通信设备；通过PC/PPI电缆的编程通信
  • S7-200－CPU 224 XP的CPU本体模拟量I/O相关问题

修改：

  • S7-200－TD200配置和菜单设置
  • S7-200－Modbus指令库的使用
  • S7-200－数据格式
  • S7-200－CPU和扩展模块地址分配
  • SITOP－电源冗余、扩容的并联实现

V0.80以前……

无资料


说明

Micro 'n Power 是由西门子技术支持工程师利用业余时间制作的，关于西门子小型自动化（LOGO!、 SIMATIC S7-200）和稳压电源（SITOP）产品的技术参考文档。

读者必须在阅读《S7-200产品目录》、《S7-200系统手册》、《LOGO!手册》、《SITOP电源产品目录》、《SITOP电源操作指南》等的基础上参考本文档。

Micro 'n Power 不能代替或部分代替西门子的任何正式出版物，如产品宣传样本，产品目录，产品手册，随同产品、软件发布的说明性文档和在线帮助文件等等。Micro 'n Power 也无意更改上述正式技术资料的任何内容，或提供勘误。在所有正式场合，一切应以西门子的正式出版物为准。

Micro 'n Power 的内容来自西门子的技术资料，西门子的产品开发、维修、技术支持工程师的知识、经验，用户的知识和经验，以及其他技术资料。

Micro 'n Power 包括对用户经常，甚至是必然遇到的问题、疑问的解答，以及隐含着其他许多问题答案的叙述性文字，还有一些作者认为有助于读者理解、解决问题的背景知识。Micro 'n Power 力争做到精简实用，几乎其中的每个段落、每句话都有一定的针对性。

虽然作者已经尽力保证其正确性，但疏漏难免。读者如欲采纳，风险自担。

使用

Micro 'n Power 是HTML Help格式的文档。

Micro 'n Power 以便于查阅为目的设计，没有一定的阅读顺序。各篇技术资料在Micro 'n Power 窗口左侧的目录中归类。读者可以直接进入树型目录，寻找感兴趣的标题。文章中可能有超级链接，指向其他文章、其他文章的某部分，或者互联网网址。

  • 代表这是一个分类目录，同时其中有文字说明
  • 代表这仅是一个分类目录
  • 鼠标单击目录树的 [image] 可打开下一级目录
  • 文章中没有回退链接，可以用窗口工具栏上的“后退”、“前进”按钮
  • 按住Shift键再用鼠标点击文档中的链接，可在新的浏览器窗口中打开链接
  • 用工具栏“打印”按钮可以打印文章
  • 在窗口左侧的“搜索”标签中，可以进行全文范围内的文本检索

下载

Micro 'n Power 将会根据情况更新。读者可以从西门子（中国）自动化与驱动集团技术支持与服务首页，进入“下载中心”下载。

http://www2.ad.siemens.com.cn/Download/Upload/AS/application/A0136.chm

联系我们

欢迎读者就 Micro 'n Power 的内容、形式提出意见与建议。本文档当然不能涵盖全部的相关技术问题，如果读者认为有缺失的，或者难以理解的地方，尽请指出。

请发 E-mail 到下列电子邮件地址：

support.china.automation@siemens.com


Online - Support

在线技术问题提交网站

西门子技术支持网站最新开通在线提交技术问题链接：

http://www.ad.siemens.com.cn/service/SR

通过访问此链接，您可以：

  • 无需拨打热线电话，在线提交产品技术问题，直接发至技术支持与服务热线邮箱
  • 享用 7 x 24 小时开通的问题提交通道
  • 网站可以在提交问题的过程中第一时间帮您搜索出能够解决您问题的在线文档，支持效率大大提高

请收藏以下网址：

http://www.ad.siemens.com.cn/service/SR

按住 SHIFT 键点击网址将打开新的浏览器窗口。

使用网站的这一高级功能，您还可以获得更多的好处和便利：

  • 使更多的技术支持工程师同时仔细查看您的问题
  • 文字写作要求较为精确和全面的思考，更有助于您分析问题的所在
  • 文字回答使技术支持工程师考虑问题更加充分，更加全面
  • 必要时工程师还可以打电话与您联系，进一步了解情况
  • 便于索取手册、样本等资料，专人直接回复此类邮件将更为快捷

提交问题时请使用您最经常使用的、最可靠的电子邮件地址 。如果您曾经使用过热线电话，使用与您上次登记时相同的邮箱将更加快捷，您的问题会自动进入我们的服务系统。准确的单位地址和联系电话，也将有助于您的问题得到快速响应。

注意：作为免费技术支持电话热线的延伸，网站提交的问题仍然受到工作条件和工作规定的限制。一些特殊的服务要求可能难以获得免费技术支持，包括但不仅限于：

  • 写明工艺要求，希望直接获得编程服务的
  • 要求帮助检查复杂的工艺控制，而非功能测试性程序的
  • 要求帮助确认详细的系统配置的

针对通过网站提供的此类问题，技术支持工程师会尽可能提供意见和建议，供您参考。我们也将提供解决此类问题的其他方法和渠道。

网站支持三部曲

欢迎访问西门子自动化与驱动集团技术支持网站：

http://www.ad.siemens.com.cn/service


网站链接

西门子自动化与驱动集团常用网站地址

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。

选型

Industry Mall -- 西门子自动化与驱动技术产品目录和订购系统
https://mall.industry.siemens.com/goos/WelcomePage.aspx?regionUrl=/CN&language=zh
TIA 选型工具
http://www.automation.siemens.com/mcms/topics/en/simatic/tia-selection-tool/Pages/tab.aspx?tabcardname=Overview

产品主页

产品主页上提供了相关产品的最新信息，以及软件升级、常问问题等链接入口。

SIMATIC S7-200
http://www.siemens.com/s7-200

LOGO!
http://www.siemens.com/logo

SITOP电源
http://www.siemens.com/sitop

中文产品主页入口
http://www.industry.siemens.com.cn/automation/cn/zh/automation-systems/industrial-automation/simatic-controller/Pages/Default.aspx
S7-200 PLC 中文主页
http://www.industry.siemens.com.cn/automation/cn/zh/automation-systems/industrial-automation/simatic-controller/simatic-s7-controller/s7-200/Pages/Default.aspx
LOGO! 中文主页
http://www.industry.siemens.com.cn/automation/cn/zh/automation-systems/industrial-automation/simatic-controller/logic-module-logo/Pages/logo.aspx
SITOP 中文主页
http://www.industry.siemens.com.cn/automation/cn/zh/power-supplies/power-supplysitop/Pages/Default.aspx

技术支持主页

中文技术支持主页
http://www.ad.siemens.com.cn/service

本地下载

中、英文资料、软件本地下载
http://www.ad.siemens.com.cn/download


Online - Online Doc_在线资料与手册

资料手册在线下载

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。

S7-200 CN / SIMATIC S7-200

《S7-200 系统手册》中文版（2008 年 08 月）
http://support.automation.siemens.com/CN/view/zh/1109582
"S7-200 System Manual" 英文版（2008 年 08 月）
http://support.automation.siemens.com/CN/view/en/ 1109582
《S7-200 CN可编程控制器样本》中文版（2013 年 01 月）
http://www.ad.siemens.com.cn/download/searchResult.aspx?searchText=4511
"文本显示器（TD）用户手册" 中文版（2007 年 08 月）
http://support.automation.siemens.com/WW/view/en/1087140/0/zh
"文本显示器（TD）用户手册" 英文版（2007 年 08 月）
http://support.automation.siemens.com/WW/view/en/1087140
"CP243-1 工业以太网通信处理器模块手册" 英文版（2004 年 03 月）
http://support.automation.siemens.com/WW/view/en/18974029
"CP243-1 IT 工业以太网通信处理及 IT 模块手册" 英文版（2004 年 03 月）
http://support.automation.siemens.com/WW/view/en/18975343
"CP243-2 AS-Interface 主站通信模块手册" 英文版（2000 年 07 月）
http://support.automation.siemens.com/WW/view/en/2659515
"S7-200 System Manual CPU21x" 第一代 S7-200 系统手册英文版
http://support.automation.siemens.com/WW/view/en/1109154
“Tips & Tricks” － S7-200 例程集锦（英文注释，初学不宜，无技术支持服务）
http://support.automation.siemens.com/WW/view/en/1232912

LOGO! 控制器

《LOGO! 手册》 中文版（2008 年 07 月）
http://support.automation.siemens.com/WW/view/en/30041319/0/zh
"LOGO! (0BA6)手册" 英文版（2008 年 07 月）
http://support.automation.siemens.com/WW/view/en/30041319
"LOGO!Soft Comfort V5.0 使用手册" 英文版
http://support.automation.siemens.com/WW/view/en/24891816
"LOGO!Soft Comfort V6.0 在线帮助" 中文版
http://support.automation.siemens.com/WW/view/en/30104177/0/zh
"LOGO!Soft Comfort V6.0 在线帮助" 英文版
http://support.automation.siemens.com/WW/view/en/30104177

SITOP 电源

"SITOP 电源产品目录 KT10.1 2009" 英文版
http://www.automation.siemens.com/sitop/html_76/katalog_en.htm
"SITOP 产品操作手册" 多语言版（多种型号）
http://support.automation.siemens.com/WW/view/en/10807212/133300
SITOP 电源产品目录2016.06（中文版）
https://www.industry.siemens.com.cn/automation/cn/zh/power-supplies/power-supplysitop/Documents/8501.5.26.pdf

CAX、ePLAN等产品图片下载

  • 用户可从SIMATIC产品数据库下载：
  • http://www.automation.siemens.com/bilddb/
  • 如果用户有使用上面网站的问题，请参考FAQ《从哪里获得SIMATIC 产品的图像数据》
  • http://www.ad.siemens.com.cn/download/searchResult.aspx?searchText=F0507


Online - Online Download

软件、升级包在线下载

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。

S7-200 最新软件及升级包

STEP 7-Micro/WIN V4.0 SP7 升级版 [image] （须先安装 Micro/WIN V4.0 正式版）
http://support.automation.siemens.com/CN/view/zh/58523240
PC Access V1.0 SP6 升级版 [image] （须先安装 PC Access V1.0 正式版）
http://support.automation.siemens.com/WW/view/en/58495870
Wipeout.exe 文件下载
http://support.automation.siemens.com/WW/view/en/2123168

LOGO! 软件升级包

LOGO!Soft Comfort 从 V1.0/2.0/3.0/4.0/5.0 升级到 V6.0（须先安装 LOGO!Soft Comfort 的正式版）
https://www.automation.siemens.com/logo/html_76/support/01ToolsDownloads/index.html

GSD 文件在线下载

PROFIBUS GSD 文件下载大全
http://support.automation.siemens.com/WW/view/en/113652

EM 277 的 GSD 文件就在上述页面中。


Online - Other Doc

相关产品手册在线下载

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。

西门子 MicroMaster 4 系列产品

MM 440 Operating Instruction - MM 440 操作指南英文版（2005 年 07 月）
http://support.automation.siemens.com/WW/view/en/21742072
MM 430 Operating Instruction - MM 430 操作指南英文版（2005 年 08 月）
http://support.automation.siemens.com/WW/view/en/21983500
MM 420 Operating Instruction - MM 420 操作指南英文版（2005 年 07 月）
http://support.automation.siemens.com/WW/view/en/21743802
Getting Started Guide MICROMASTER 420/430/440 - MM 420/430/440 操作入门中文（2005 年 07 月）
http://support.automation.siemens.com/WW/view/en/21694875/0/zh

西门子 HMI 产品

K-TP 178 micro （WinCC flexible）操作指南（中文版）
http://www.ad.siemens.com.cn/download 网站"自动化系统>>Panel/WinCC flexible/Protool" 下载


Online - Certificates

S 7-200产品认证书在线下载

S7-200 产品包括S7-200 SIMATIC系列和S7-200 CN系列。目前，S7-200 SIMATIC系列已全部停产，该系列产品可由S7-200 CN系列替代。
S7-200 SIMATIC系列具有CE认证，UL认证，CSA认证，船级社认证。
S7-200 CN系列具有CE认证。因为西门子公司的SIMATIC产品一般不需要中国CCC认证，所以S7-200 CN系列，没有CCC认证。

S7-200 产品认证书

S7-200 产品认证书本地下载
http://www.ad.siemens.com.cn/download/
S7-200 产品认证书下载大全
https://support.industry.siemens.com/cs/cn/en/ps/13640/cert

S7-200（SIMATIC和CN）CE认证
https://support.industry.siemens.com/cs/cn/zh/view/16896909
S7-200 （SIMATIC）UL认证
https://support.industry.siemens.com/cs/cn/en/view/18968445
S7-200 （SIPLUS SIMATIC）UL认证
https://support.industry.siemens.com/cs/cn/en/view/23721940

S7-200（SIMATIC）具有以下国家的船级社认证
波兰 Poland
https://support.industry.siemens.com/cs/ww/en/view/16698811
德国 Germany
https://support.industry.siemens.com/cs/ww/en/view/16900129
俄罗斯 Russia
https://support.industry.siemens.com/cs/ww/en/view/22331728
法国 France
https://support.industry.siemens.com/cs/ww/en/view/16895477
美国 USA
https://support.industry.siemens.com/cs/ww/en/view/16898654
挪威 Norway
https://support.industry.siemens.com/cs/ww/en/view/16898544
日本 Japan
https://support.industry.siemens.com/cs/ww/en/view/16895216
英国 Great Britain
https://support.industry.siemens.com/cs/ww/en/view/16897401
意大利 Italy
https://support.industry.siemens.com/cs/ww/en/view/19855694
中国 China
https://support.industry.siemens.com/cs/ww/en/view/42697943

TD 400C 产品认证书

TD 400C为S7-200 PLC和S7-200 SMART PLC专用的新一代文本显示器，具有CE认证，UL认证，FM认证。因为西门子公司的SIMATIC产品一般不需要中国CCC认证，所以TD200、TD400系列，没有CCC认证。
TD 400C CE认证
https://support.industry.siemens.com/cs/cn/zh/view/34792563
TD 400C UL认证
https://support.industry.siemens.com/cs/cn/en/view/18938211
TD 200/200C UL认证
https://support.industry.siemens.com/cs/cn/en/view/103965083
TD 400C FM认证
https://support.industry.siemens.com/cs/ww/en/view/29567488

ISO 9000 认证在线下载

ISO9000质量管理体系是国际标准化组织（ISO）制定的国际标准之一，它不是指一个标准，而是一类标准的统称。其指的不是某个产品是否通过了该认证，而是生产该产品的工厂是否通过了该认证。

我们的管理系统基于西门子公司关于质量、 环境和健康保护的原则。西门子公司满足国际认可的规范和标准，如 ISO 9001、 ISO 14001 及 OSHAS 18001。法定条文以及在某些情况下特定的行业，如电力工程、 汽车、 医药行业的具体要求都考虑在内。目前S7-200 CN生产工厂的ISO9000认证下载可通过以下网址：

ISO9000产品认证下载大全
http://www.industry.siemens.com/topics/global/en/system-certificates/Pages/default.aspx
SEWC（成都）ISO9001认证证书（英文）
http://www.industry.siemens.com/topics/global/en/system-certificates/i-ia-as/Documents/Qualitaetsmanagement-ISO9001-Chengdu-CN.pdf
http://www.industry.siemens.com/topics/global/en/system-certificates/i-ia-as/Documents/Qualitaetsmanagement-ISO9001-Chengdu-EN.pdf
SNC（南京）ISO9001认证证书（中文和英文）
http://www.industry.siemens.com/topics/global/en/system-certificates/df-mc/Documents/Qualitaetsmanagement-ISO9001-Nanjing-CN.pdf
http://www.industry.siemens.com/topics/global/en/system-certificates/df-mc/Documents/Qualitaetsmanagement-ISO9001-Nanjing-EN.pdf

SNC（南京）ISO14001认证证书（中文和英文）
http://www.industry.siemens.com/topics/global/en/system-certificates/df-mc/Documents/Umweltmanagement-ISO14001-Nanjing-CN.pdf
http://www.industry.siemens.com/topics/global/en/system-certificates/df-mc/Documents/Umweltmanagement-ISO14001-Nanjing-EN.pdf

SNC（南京）OHSAS 18001认证证书（中文和英文）
http://www.industry.siemens.com/topics/global/en/system-certificates/df-mc/Documents/Health-and-Safety-OHSAS18001-Nanjing-CN.pdf
http://www.industry.siemens.com/topics/global/en/system-certificates/df-mc/Documents/Health-and-Safety-OHSAS18001-Nanjing-EN.pdf

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。


Online - Certificates

产品认证书在线下载

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。

LOGO! 产品认证书

LOGO! 产品认证书本地下载
http://www.ad.siemens.com.cn/download/
LOGO! 产品认证书下载大全
https://support.industry.siemens.com/cs/cn/en/ps/13617/cert

SITOP 产品认证书

SITOP 产品认证书下载大全
https://support.industry.siemens.com/cs/cn/en/ps/18017/cert

SITOP CE认证点击链接下载证书： CE认证证书


视频教程

S7-200 E-Learning 视频教程：

S7-200在线跟我学/跟我做的视频，从编程基础、基本指令介绍、向导编程介绍、通信和网络功能四方面，理论结合实际操作，全方位的为用户提供简单易学的电子化学习资料， 适用于初次学习S7-200的用户或单个 知识需要详细介绍的用户。

注意：关于s7-200教学视频中断问题，需要设置必须的播放环境。如果使用IE浏览器播放，请下载flash player 7.0 for IE插件。 如果下载后观看，请安装flash player 7.0播放器。

S7-200CN 编程基础：

http://www.ad.siemens.com.cn/products/as/s7_200/elearning/basic.asp

S7-200CN 基本指令：

http://www.ad.siemens.com.cn/products/as/s7_200/elearning/dictate.asp

S7-200CN 向导编程:

http://www.ad.siemens.com.cn/products/as/s7_200/elearning/guide.asp

S7-200CN 通信和网络功能:

http://www.ad.siemens.com.cn/products/as/s7_200/elearning/comm.asp


系列视频：LOGO!在线学习

系列视频：LOGO!在线学习 | http://www.ad.siemens.com.cn/Service/elearning/cn/SerialVideo.aspx?vsid=130
什么是LOGO!？ - LOGO在线学习1/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=718
LOGO! 产品系列概述 - LOGO在线学习2/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=719
LOGO! 产品的安装和接线 - LOGO在线学习3/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=720
LOGO! 软件安装，升级和特点 - LOGO在线学习4/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=721
LOGO! 存储卡和电池卡介绍 - LOGO在线学习5/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=722
LOGO! 编程指令之常量 - LOGO在线学习6/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=723
LOGO! 编程指令之基本函数 - LOGO在线学习7/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=724
LOGO! 编程指令之定时器函数（1） - LOGO在线学习8/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=725
LOGO! 编程指令之定时器函数（2） - LOGO在线学习9/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=726
LOGO! 编程指令之定时器函数（3） - LOGO在线学习10/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=727
LOGO! 编程指令之定时器函数（4） - LOGO在线学习11/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=728
LOGO! 编程指令之计数器函数 - LOGO在线学习12/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=729
LOGO! 编程指令之模拟量函数（1） - LOGO在线学习13/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=730
LOGO! 编程指令之模拟量函数（2 - LOGO在线学习14/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=731
LOGO! 编程指令之模拟量函数（3） - LOGO在线学习15/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=732
LOGO! 编程指令之其他函数 - LOGO在线学习16/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=733
LOGO! TD & 信息文本函数 - LOGO在线学习17/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=734
LOGO! 面板菜单和功能介绍 - LOGO在线学习18/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=735
LOGO! 0BA7 模块介绍 - LOGO在线学习19/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=736
V7.0 软件新功能介绍- 用户自定义函数 - LOGO在线学习20/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=737
V7.0 软件新功能介绍-数据归档 - LOGO在线学习21/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=738
V7.0 软件新功能介绍-新功能块 - LOGO在线学习22/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=739
V7.0 软件新增特色功能 - LOGO在线学习23/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=740
以太网通讯- LOGO! 之间主主通讯 - LOGO在线学习24/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=741
以太网通讯- LOGO! 之间主从通讯 - LOGO在线学习25/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=742
以太网通讯- LOGO! 与S7-200 - LOGO在线学习26/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=743
以太网通讯- LOGO! 与S7-1200 - LOGO在线学习27/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=744
以太网通讯- LOGO! 与S7-300 - LOGO在线学习28/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=745
以太网通讯- LOGO! 与触摸屏 - LOGO在线学习29/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=746
以太网通讯- LOGO! 与 WinCC - LOGO在线学习30/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=747


S7-200热线工程师岗前内部培训

S7-200热线工程师岗前内部培训 硬件及技术参数第一讲--S7-200综述 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=661
S7-200热线工程师岗前内部培训 硬件及技术参数第二讲--CPU主要功能 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=662
S7-200热线工程师岗前内部培训 硬件及技术参数第三讲--扩展模块介绍 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=663
S7-200热线工程师岗前内部培训 硬件及技术参数第四讲--技术参数介绍 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=678
S7-200热线工程师岗前内部培训 STEP7-Micro/win软件使用第一讲--软件简介 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=679
S7-200热线工程师岗前内部培训 STEP7-Micro/win软件使用第二讲--系统块设置 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=680
S7-200热线工程师岗前内部培训 STEP7-Micro/win软件使用第三讲--编程基础 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=687
S7-200热线工程师岗前内部培训 STEP7-Micro/win软件使用第四讲--基本指令使用A部分 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=688
S7-200热线工程师岗前内部培训 STEP7-Micro/win软件使用第四讲--基本指令使用B部分 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=694
S7-200热线工程师岗前内部培训 STEP7-Micro/win软件使用第五讲--指令库使用 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=704
S7-200热线工程师岗前内部培训——串口通信第一讲：自由口通信(1) | http://www.ad.siemens.com.cn/Service/elearning/cn/Course.aspx?CourseID=838
S7-200热线工程师岗前内部培训——串口通信第二讲：自由口通信(2) | http://www.ad.siemens.com.cn/Service/elearning/cn/Course.aspx?CourseID=839
S7-200热线工程师岗前内部培训——串口通信第三讲：PLC Modbus通信 | http://www.ad.siemens.com.cn/Service/elearning/cn/Course.aspx?CourseID=860
S7-200热线工程师岗前内部培训——串口通信第四讲：PLC USS通信 | http://www.ad.siemens.com.cn/Service/elearning/cn/Course.aspx?CourseID=861
S7-200热线工程师岗前内部培训——HMI第一讲：TD文本显示器 | http://www.ad.siemens.com.cn/Service/elearning/cn/Course.aspx?CourseID=879
S7-200热线工程师岗前内部培训——HMI第二讲：PC Access | http://www.ad.siemens.com.cn/Service/elearning/cn/CourseV2.aspx?CourseID=880


系列视频：S7-200跟我学/跟我做

系列视频：S7-200跟我学/跟我做 | http://www.ad.siemens.com.cn/service/elearning/cn/SerialVideo.aspx?vsid=1
S7-200CN: S7-200CN应用案例介绍-跟我学 - 1/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=250
S7-200CN: 软件安装和设置中文界面-跟我学 - 2/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=251
S7-200CN: 软件安装和设置中文界面-跟我做 - 3/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=252
S7-200CN: 概述-基本菜单及软件使用介绍-跟我学 - 4/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=253
S7-200CN: 概述-基本菜单及软件使用介绍-跟我做 - 5/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=254
S7-200CN: 通讯口设置-跟我学 - 6/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=255
S7-200CN: 通讯口设置-跟我做 - 7/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=256
S7-200CN: 输入和编辑程序-跟我学 - 8/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=257
S7-200CN: 输入和编辑程序-跟我做 - 9/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=258
S7-200CN: 编译和下载，运行和调试-跟我学 - 10/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=259
S7-200CN: 编译和下载，运行和调试-跟我做 - 11/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=260
S7-200CN: 存储器的数据类型-跟我学 - 12/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=261
S7-200CN: 存储器的数据类型-跟我做 - 13/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=262
S7-200CN: 存储器的存取方式-跟我学 - 14/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=263
S7-200CN: 存储器的存取方式-跟我做 - 15/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=264
S7-200CN: 输入过程映像寄存器-跟我学 - 16/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=265
S7-200CN: 输入过程映像寄存器-跟我做 - 17/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=266
S7-200CN: 输出过程映像寄存器-跟我学 - 18/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=267
S7-200CN: 输出过程映像寄存器-跟我做 - 19/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=268
S7-200CN: 变量存储区-跟我学 - 20/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=269
S7-200CN: 变量存储区-跟我做 - 21/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=270
S7-200CN: 位存储区-跟我学 - 22/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=271
S7-200CN: 位存储区-跟我做 - 23/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=272
S7-200CN: 定时器-跟我学 - 24/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=273
S7-200CN: 定时器-跟我做 - 25/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=274
S7-200CN: 计数器-跟我学 - 26/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=275
S7-200CN: 计数器-跟我做 - 27/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=276
S7-200CN: 模拟量输入存储区-跟我学 - 28/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=277
S7-200CN: 模拟量输入存储区-跟我做 - 29/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=278
S7-200CN: 模拟量输出存储区-跟我学 - 30/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=279
S7-200CN: 模拟量输出存储区-跟我做 - 31/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=280
S7-200CN: 局部存储区-跟我学 - 32/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=281
S7-200CN: 局部存储区-跟我做 - 33/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=282
S7-200CN: 特殊存储区-跟我学 - 34/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=283
S7-200CN: 特殊存储区-跟我做 - 35/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=284
S7-200CN: S7-200的地址分配-跟我学 - 36/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=285
S7-200CN: S7-200的地址分配-跟我做 - 37/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=286
S7-200CN: 变量符号表-跟我学 - 38/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=287
S7-200CN: 变量符号表-跟我做 - 39/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=288
S7-200CN: 交叉引用-跟我学 - 40/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=289
S7-200CN: 交叉引用-跟我做 - 41/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=290
S7-200CN: 数据块使用的一般规则-跟我学 - 42/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=291
S7-200CN: 数据块使用的一般规则-跟我做 - 43/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=292
S7-200CN: 数据块的编辑-跟我学 - 44/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=293
S7-200CN: 数据块的编辑-跟我做 - 45/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=294
S7-200CN: 数据块的下载-跟我学 - 46/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=295
S7-200CN: 数据块的下载-跟我做 - 47/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=296
S7-200CN: 使用状态表1-跟我学 - 48/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=297
S7-200CN: 使用状态表1-跟我做 - 49/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=298
S7-200CN: 使用状态表2-跟我学 - 50/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=299
S7-200CN: 使用状态表2-跟我做 - 51/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=300
S7-200CN: 标准位逻辑指令-跟我学 - 52/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=301
S7-200CN: 标准位逻辑指令-跟我做 - 53/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=302
S7-200CN: 立即位逻辑指令-跟我学 - 54/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=303
S7-200CN: 立即位逻辑指令-跟我做 - 55/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=304
S7-200CN: 置位复位指令-跟我学 - 56/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=305
S7-200CN: 置位复位指令-跟我做 - 57/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=306
S7-200CN: 其它位逻辑指令-跟我学 - 58/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=307
S7-200CN: 其它位逻辑指令-跟我做 - 59/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=308
S7-200CN: 接通延时定时器-跟我学 - 60/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=309
S7-200CN: 接通延时定时器-跟我做 - 61/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=310
S7-200CN: 断开延时定时器-跟我学 - 62/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=311
S7-200CN: 断开延时定时器-跟我做 - 63/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=312
S7-200CN: 保持型接通延时定时器-跟我学 - 64/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=313
S7-200CN: 保持型接通延时定时器-跟我做 - 65/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=314
S7-200CN: 加计数-跟我学 - 66/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=315
S7-200CN: 加计数-跟我做 - 67/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=316
S7-200CN: 减计数-跟我学 - 68/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=317
S7-200CN: 减计数-跟我做 - 69/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=318
S7-200CN: 加减计数-跟我学 - 70/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=319
S7-200CN: 加减计数-跟我做 - 71/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=320
S7-200CN: 整数比较-跟我学 - 72/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=321
S7-200CN: 整数比较-跟我做 - 73/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=322
S7-200CN: 双整数比较-跟我学 - 74/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=323
S7-200CN: 双整数比较-跟我做 - 75/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=324
S7-200CN: 实数比较-跟我学 - 76/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=325
S7-200CN: 实数比较-跟我做 - 77/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=326
S7-200CN: 字节比较-跟我学 - 78/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=327
S7-200CN: 字节比较-跟我做 - 79/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=328
S7-200CN: BCD码与整数的转换-跟我学 - 80/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=329
S7-200CN: BCD码与整数的转换应用举例-跟我学 - 81/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=330
S7-200CN: BCD码与整数的转换应用举例-跟我做 - 82/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=331
S7-200CN: ASCII码与十六进制数的转换-跟我学 - 83/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=332
S7-200CN: ASCII码与十六进制数的转换-跟我做 - 84/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=333
S7-200CN: ASCII码与整数、双整数、实数的转换-跟我学 - 85/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=334
S7-200CN: ASCII码与整数、双整数、实数的转换-跟我做 - 86/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=335
S7-200CN: ASCII码与十六进制数、整数、双整数、实数的转换应用举例-跟我学 - 87/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=336
S7-200CN: ASCII码与十六进制数、整数、双整数、实数的转换应用举例-跟我做 - 88/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=337
S7-200CN: 字符串转换指令-跟我学 - 89/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=338
S7-200CN: 字符串转换指令-跟我做 - 90/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=339
S7-200CN: 字符串转换指令应用举例-跟我学 - 91/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=340
S7-200CN: 字符串转换指令应用举例-跟我做 - 92/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=341
S7-200CN: 整数、双整数、实数之间的转换-跟我学 - 93/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=342
S7-200CN: 整数、双整数、实数之间的转换-跟我做 - 94/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=343
S7-200CN: 整数、双整数、实数之间的转换应用举例-跟我学 - 95/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=344
S7-200CN: 整数、双整数、实数之间的转换应用举例-跟我做 - 96/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=345
S7-200CN: 编码指令-跟我学 - 97/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=346
S7-200CN: 编码指令-跟我做 - 98/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=347
S7-200CN: 译码指令-跟我学 - 99/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=348
S7-200CN: 译码指令-跟我做 - 100/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=349
S7-200CN: 段码指令-跟我学 - 101/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=350
S7-200CN: 段码指令-跟我做 - 102/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=351
S7-200CN: 单个数据传送指令-跟我学 - 103/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=352
S7-200CN: 单个数据传送指令-跟我做 - 104/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=353
S7-200CN: 块数据传送指令-跟我学 - 105/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=354
S7-200CN: 块数据传送指令-跟我做 - 106/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=355
S7-200CN: 其它传送指令-跟我学 - 107/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=356
S7-200CN: 其它传送指令-跟我做 - 108/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=357
S7-200CN: 移位指令-跟我学 - 109/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=358
S7-200CN: 移位指令-跟我做 - 110/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=359
S7-200CN: 循环移位指令-跟我学 - 111/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=360
S7-200CN: 循环移位指令-跟我做 - 112/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=361
S7-200CN: 整数计算指令-跟我学 - 113/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=362
S7-200CN: 整数计算指令-跟我做 - 114/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=363
S7-200CN: 整数运算指令应用举例-跟我学 - 115/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=364
S7-200CN: 整数运算指令应用举例-跟我做 - 116/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=365
S7-200CN: 基本浮点数计算指令-跟我学 - 117/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=366
S7-200CN: 基本浮点数计算指令-跟我做 - 118/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=367
S7-200CN: 浮点数函数指令-跟我学 - 119/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=368
S7-200CN: 浮点数函数指令-跟我做 - 120/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=369
S7-200CN: 浮点数函数指令应用举例-跟我学 - 121/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=370
S7-200CN: 浮点数函数指令应用举例-跟我做 - 122/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=371
S7-200CN: 逻辑运算指令-跟我学 - 123/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=372
S7-200CN: 逻辑运算指令-跟我做 - 124/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=373
S7-200CN: 逻辑运算指令应用举例-跟我学 - 125/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=374
S7-200CN: 逻辑运算指令应用举例-跟我做 - 126/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=375
S7-200CN: 不带参数子程序-跟我学 - 127/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=376
S7-200CN: 不带参数子程序-跟我做 - 128/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=377
S7-200CN: 局部变量的使用-跟我学 - 129/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=378
S7-200CN: 局部变量的使用-跟我做 - 130/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=379
S7-200CN: 带参数子程序1-跟我学 - 131/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=380
S7-200CN: 带参数子程序1-跟我做 - 132/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=381
S7-200CN: 带参数子程序2-跟我学 - 133/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=382
S7-200CN: 带参数子程序2-跟我做 - 134/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=383
S7-200CN: 指令库的使用-跟我学 - 135/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=384
S7-200CN: 指令库的使用-跟我做 - 136/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=385
S7-200CN: PID向导编程1-跟我学 - 137/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=386
S7-200CN: PID向导编程1-跟我做 - 138/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=387
S7-200CN: PID向导编程2-跟我学 - 139/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=388
S7-200CN: PID向导编程2-跟我做 - 140/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=389
S7-200CN: PID向导编程3-跟我学 - 141/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=390
S7-200CN: PID向导编程3-跟我做 - 142/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=391
S7-200CN: PID向导编程4-跟我学 - 143/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=392
S7-200CN: PID向导编程4-跟我做 - 144/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=393
S7-200CN: PID自整定与调节控制面板1-跟我学 - 145/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=394
S7-200CN: PID自整定与调节控制面板2-跟我学 - 146/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=395
S7-200CN: PID自整定与调节控制面板2-跟我做 - 147/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=396
S7-200CN: S7-200CN中的配方功能-跟我学 - 148/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=397
S7-200CN: 使用配方向导-跟我学 - 149/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=398
S7-200CN: 使用配方向导-跟我做 - 150/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=399
S7-200CN: 配方程序的编写-跟我学 - 151/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=400
S7-200CN: 配方程序的编写-跟我做 - 152/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=401
S7-200CN: 使用数据记录向导-跟我学 - 153/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=402
S7-200CN: 使用数据记录向导-跟我做 - 154/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=403
S7-200CN: 数据归档的上载-跟我学 - 155/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=404
S7-200CN: 数据归档的上载-跟我做 - 156/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=405
S7-200CN: PPI 网络架构-跟我学 - 157/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=406
S7-200CN: PPI 使用通信向导-跟我学 - 158/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=407
S7-200CN: PPI 使用通信向导-跟我做 - 159/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=408
S7-200CN: NETR/W通信主站编程-跟我学 - 160/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=409
S7-200CN: NETR/W通信主站编程-跟我做 - 161/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=410
S7-200CN: NETR/W通信从站编程-跟我学 - 162/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=411
S7-200CN: NETR/W通信从站编程-跟我做 - 163/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=412
S7-200CN: PPI通信效果测试-跟我学 - 164/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=413
S7-200CN: PPI 通信效果测试-跟我做 - 165/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=414
S7-200CN: PROFIBUS DP 网络架构-跟我学 - 166/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=415
S7-200CN: PROFIBUS DP 硬件组态-跟我学 - 167/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=416
S7-200CN: PROFIBUS DP 硬件组态-跟我做 - 168/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=417
S7-200CN: PROFIBUS DP 主站程序的编写-跟我学 - 169/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=418
S7-200CN: PROFIBUS DP 主站程序的编写-跟我做 - 170/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=419
S7-200CN: S7-200 PROFIBUS DP 程序的编写-跟我学 - 171/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=420
S7-200CN: S7-200 PROFIBUS DP 程序的编写-跟我做 - 172/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=421
S7-200CN: PROFIBUS通信效果演示-跟我学 - 173/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=422
S7-200CN: PROFIBUS通信效果演示-跟我做 - 174/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=423
S7-200CN: 以太网网络架构-跟我学 - 175/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=424
S7-200CN: 使用向导配置服务器-跟我学 - 176/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=425
S7-200CN: 使用向导配置服务器-跟我做 - 177/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=426
S7-200CN: 使用向导配置客户机-跟我学 - 178/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=427
S7-200CN: 使用向导配置客户机-跟我做 - 179/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=428
S7-200CN: 服务器程序的编写-跟我学 - 180/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=429
S7-200CN: 服务器程序的编写-跟我做 - 181/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=430
S7-200CN: 客户机程序的编写-跟我学 - 182/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=431
S7-200CN: 客户机程序的编写-跟我做 - 183/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=432
S7-200CN: 通过以太网实现远程编程和诊断-跟我学 - 184/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=433
S7-200CN: 通过以太网实现远程编程和诊断-跟我做 - 185/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=434


位逻辑，比较，转换，编码指令视频链接

位逻辑指令

S7-200CN: 标准位逻辑指令-跟我学 - 52/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=301
S7-200CN: 标准位逻辑指令-跟我做 - 53/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=302
S7-200CN: 立即位逻辑指令-跟我学 - 54/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=303
S7-200CN: 立即位逻辑指令-跟我做 - 55/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=304
S7-200CN: 置位复位指令-跟我学 - 56/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=305
S7-200CN: 置位复位指令-跟我做 - 57/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=306
S7-200CN: 其它位逻辑指令-跟我学 - 58/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=307
S7-200CN: 其它位逻辑指令-跟我做 - 59/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=308

比较指令

S7-200CN: 整数比较-跟我学 - 72/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=321
S7-200CN: 整数比较-跟我做 - 73/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=322
S7-200CN: 双整数比较-跟我学 - 74/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=323
S7-200CN: 双整数比较-跟我做 - 75/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=324
S7-200CN: 实数比较-跟我学 - 76/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=325
S7-200CN: 实数比较-跟我做 - 77/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=326
S7-200CN: 字节比较-跟我学 - 78/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=327
S7-200CN: 字节比较-跟我做 - 79/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=328

转换指令

S7-200CN: BCD码与整数的转换-跟我学 - 80/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=329
S7-200CN: BCD码与整数的转换应用举例-跟我学 - 81/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=330
S7-200CN: BCD码与整数的转换应用举例-跟我做 - 82/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=331
S7-200CN: ASCII码与十六进制数的转换-跟我学 - 83/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=332
S7-200CN: ASCII码与十六进制数的转换-跟我做 - 84/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=333
S7-200CN: ASCII码与整数、双整数、实数的转换-跟我学 - 85/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=334
S7-200CN: ASCII码与整数、双整数、实数的转换-跟我做 - 86/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=335
S7-200CN: ASCII码与十六进制数、整数、双整数、实数的转换应用举例-跟我学 - 87/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=336
S7-200CN: ASCII码与十六进制数、整数、双整数、实数的转换应用举例-跟我做 - 88/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=337
S7-200CN: 整数、双整数、实数之间的转换-跟我学 - 93/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=342
S7-200CN: 整数、双整数、实数之间的转换-跟我做 - 94/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=343
S7-200CN: 整数、双整数、实数之间的转换应用举例-跟我学 - 95/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=344
S7-200CN: 整数、双整数、实数之间的转换应用举例-跟我做 - 96/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=345

编码、译码及段码指令

S7-200CN: 编码指令-跟我学 - 97/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=346
S7-200CN: 编码指令-跟我做 - 98/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=347
S7-200CN: 译码指令-跟我学 - 99/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=348
S7-200CN: 译码指令-跟我做 - 100/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=349
S7-200CN: 段码指令-跟我学 - 101/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=350
S7-200CN: 段码指令-跟我做 - 102/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=351


运算指令视频链接

运算指令

S7-200CN: 整数计算指令-跟我学 - 113/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=362
S7-200CN: 整数计算指令-跟我做 - 114/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=363
S7-200CN: 整数运算指令应用举例-跟我学 - 115/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=364
S7-200CN: 整数运算指令应用举例-跟我做 - 116/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=365
S7-200CN: 基本浮点数计算指令-跟我学 - 117/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=366
S7-200CN: 基本浮点数计算指令-跟我做 - 118/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=367
S7-200CN: 浮点数函数指令-跟我学 - 119/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=368
S7-200CN: 浮点数函数指令-跟我做 - 120/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=369
S7-200CN: 浮点数函数指令应用举例-跟我学 - 121/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=370
S7-200CN: 浮点数函数指令应用举例-跟我做 - 122/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=371
S7-200CN: 逻辑运算指令-跟我学 - 123/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=372
S7-200CN: 逻辑运算指令-跟我做 - 124/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=373
S7-200CN: 逻辑运算指令应用举例-跟我学 - 125/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=374
S7-200CN: 逻辑运算指令应用举例-跟我做 - 126/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=375


资料与手册

免费资料

西门子自动化与驱动集团可以免费提供产品样本、目录等印刷文字资料。请打以下电话索取：

电话： +86 10 6476 5319

工作时间：周一至周五 8:30 - 5:00；按西门子公司规定休假。

产品手册

用户可向西门子的经销商购买产品手册，也可以打下列电话联系手册购买事宜：

电话： +86 10 6497 6939

电话： +86 10 6472 1166 - 2397

在线下载

S7-200 / LOGO! / SITOP 产品资料手册在线下载

“深入浅出”系列图书

西门子自动化与驱动集团推出“深入浅出”系列丛书，以帮助用户尽快熟悉西门子的产品和基本使用。目前已有《深入浅出西门子S7-200 PLC（第2版）》、《深入浅出西门子LOGO!》、《深入浅出西门子S7-300 PLC》、《深入浅出西门子WinCC V6》正式发行。用户可以到书店购买，也可以打电话到出版社邮购：

北京航空航天大学出版社 邮购部
电话/传真：010-82317031
电话：010-82316936


维修信息

产品维修信息

SIMATIC S7-200

S7-200产品可以进行保内和保外维修。客户可以就维修问题致电西门子技术支持与服务热线（声明是维修问题），也可以直接联系西门子的经销商。

第一代S7-200产品没有维修服务。

LOGO!

LOGO!产品只有保内更换业务，没有维修服务。用户可以直接联系西门子的经销商。

SITOP

SITOP产品只有保内更换服务。用户可联系西门子的经销商，或者西门子产品维修服务热线，并声明是SITOP维修问题。

产品维修服务热线

电话： ＋86 10 64719990 / 400 810 4288
传真： ＋86 10 64719991
电邮： support.china.automation@siemens.com / 4008104288.cn@siemens.com

热线工作时间：

周一至周五 8:30 - 17:15；按国家规定休假。


STEP 7 Micro/Win SP7

STEP 7-Micro/WIN V4.0 Service Pack (SP7) 发布

新功能：
  • 支持韩语
  • 自动升级STEP 7-Micro/WIN SIEMENS指令库
  • 自动升级S7-200 Explorer和 TD Keypad Designer
  • 可以使用英文界面下载CN系列CPU200
兼容的操作系统：
  • Microsoft WindowsXP (Home/Profecional), incl. SP3
  • Microsoft Vista Home-Basic, incl. SP1
  • Microsoft Vista Home-Premium, incl. SP1
  • Microsoft Vista Business, incl. SP1
  • Microsoft Vista Ultimate, incl. SP1

您可以由此链接免费下载： 免费下载

注意：
  • STEP 7 Micro/Win SP7 为升级补丁，电脑中需要 更早版本的STEP 7-Micro/WIN V4.0
  • 您需要双击“Rejoin.bat ”文件，解压缩安装软件包
安装步骤：
  1. 双击安装文件“STEP7-MicroWIN_V40_SP7.exe ”，看到卸载提示后推出安装步骤
  2. 从Windows控制面板中卸载之前版本的STEP 7-Micro/WIN V4.0
  3. 冷重启电脑
  4. 再次双击安装文件“STEP7-MicroWIN_V40_SP7.exe ”

上述步骤成功结束后，STEP 7 Micro/Win SP7会被安装到您的电脑中。


LOGO! 0BA6 版新特性

LOGO! 0BA6 　永远是您正确的选择

2008年9月1日，新一代LOGO!智能逻辑控制器LOGO! 0BA6将全面发布，LOGO!Soft Comfort V6.0编程软件同时发布

与0BA5系列的LOGO!产品比较，0BA6有如下改进：
  • 新增专为LOGO!设计的四行文本显示器LOGO! TD
  • 新增USB接口的LOGO!编程电缆
  • 使用三种新型卡：存储卡、电池卡、存储/电池卡
  • 固定安装后防护等级达到IP65
  • 提供200 个程序块用于创建电路程序
  • 提供了新的指令块：脉宽调制（PWM）、模拟量算术及模拟量计算错误检测
  • 消息文本可以包含棒图，可以在两种字符集之间切换，还可以显示在LOGO! 显示屏、LOGO! TD 或这两者上
  • LOGO!12/24 RC/RCo 和LOGO!24/24o的主机集成4路0～10V模拟量输入
  • LOGO!12/24 RC/RCo 和LOGO!24/24o的主机支持5KHz以下的高速计数
  • 新增AM2 AQ模块，支持0/4-20mA 电流输出，且与0BA5系列产品相兼容
  • LOGO!主机主菜单支持德、英、法、意、西班牙、中、土耳其、俄、荷兰九种语言
  • 须使用LOGO! Comfort V6.0版本
  • 在LOGO! Comfort V6.0的支持下，可以实现Teleservice 功能

LOGO! TD

  • 四行文本显示
  • 除6个LOGO!标准按键外，提供4个额外的功能键F1、F2、F3、F4，可用作附加的数字量输入
  • 支持德、英、法、意、西班牙、中、土耳其、俄、荷兰九种语言
  • 消息文本可以包含棒图，可以在两种字符集之间切换
  • 最多可组态50消息文本
  • 每行可显示24个字符
  • 背景灯的点亮时间可调

LOGO! Comfort V6.0

  • 支持德、英、法、意、西班牙、中、土耳其、俄、荷兰九种语言
  • 支持0BA6版本的LOGO!控制器
  • 向下兼容0BA5及其之前版本的LOGO!控制器
  • 支持USB接口LOGO!编程电缆

USB LOGO! Cable

西门子推出新型的USB接口LOGO!编程电缆，电缆驱动程序集成在 LOGO! Comfort V6.0编程软件中。

订货号: 6ED1 057-1AA01-0BA0

LOGO! Cards

西门子推出3款新型卡件：存储卡、电池卡、存储电池卡

  • 新的LOGO! 电池卡为实时时钟提供了长达两年的备用电池
  • 新的LOGO! 存储卡提供了32 Kb 的存储
  • 存储电池卡集和电池卡、存储卡功能于一身


S7-200温度范围

S7-200 CPU 224XPsi 发布

新的带有漏型输出　SIMATIC S7-200 CPU 224XPsi CN已经发布。CPU 224XPsi CN完善了现有的S7-200 CPU 的产品范围。

新的 CPU 由 STEP7 MicroWIN V4.0 Service Pack 6 软件支持。早期版本的 STEP7 MicroWIN V4.0可以通过上载 CPU 的系统块更新到新的 CPU。

CPU 224XPsi CN具有漏型输出，可以驱动具有源型输入的设备。

产品特性

表 1. 新CPU 224XPsi CN规格表

产品 | CPU 224XPsi CN
定货号 | 6ES7 214-2AS23-0XB8
技术数据 | 与 CPU 224XP (6ES7 214-2AD23-0XB8)技术数据相同
输出 | 10个输出点，漏型
电压范围 | 24V DC (5 – 28.8V DC)
逻辑 1 (最小) | 外部电压幅值 – 0.4V ，外部 10K 上拉电阻
逻辑 0 (最大) | 1M +0.4V， 最大负载时

CPU 224XPsi 接线图

图1.CPU 224XPsi 接线图


EM - EM 223 32in/32out

EM 223 扩展模块 32 DI/32 DO 发布

新的 32 输入/32 输出数字量扩展模块已经发布。发布的产品包括 SIMATIC 版本和 CN 版本。它们的订货信息如下：

SIMATIC 产品

  • EM 223 32DI 24 VDC / 32DO 24 VDC

    6ES7223-1BM22-0XA0

  • EM 223 32DI 24 VDC / 32DO relay

    6ES7223-1PM22-0XA0

CN 产品

  • EM 223 CN 32DI 24 VDC / 32DO 24 VDC

    6ES7223-1BM22-0XA8

  • EM 223 CN 32DI 24 VDC / 32DO relay

    6ES7223-1PM22-0XA8

注意： 虽然有了 64 I/O 点的模块，并不意味着多加此种模块可以扩大 S7-200 的最大 I/O 点数。但可以改善因 CPU 连接的扩展模块个数受限而造成的 I/O 点受限的情况，如减少了数字量 I/O 模块的个数，就可以腾出模块位置给模拟量扩展模块。

S7-200 的最大 I/O 限制

主要规格参数

特为大 I/O 点应用而设计，新的 64 I/O 点（32入/32出） EM223 数字量输入/输出模块提供了高密度 I/O 点，其占用的宽度尺寸要比两个 32 点的 EM 223 模块少 30%。另外，还能减少安装和接线的工作。

表 1. 新 EM 223 规格表

EM223 CN 1 | 6ES7223-1BM22-0XA8 | 6ES7223-1PM22-0XA8
尺寸 (宽 x 高 x 深) | 196mm x 80mm x 62mm
电源消耗 + 5 V + 24 V | 240 mA 接通时: 4 mA / 输入点 | 205 mA 接通时: 4 mA / 输入点 9 mA / 输出点
输入
数量 | 32 x 24 VDC
类型 | 漏型/源型 (漏型符合 IEC Type 1)
额定值 | 24 VDC 时 4mA
信号 "1" | 15 VDC 时 2,5mA
信号 "0" | 5 VDC 时 1mA
输出
数量 | 32 x 24 VDC, 0.75A | 32 x relay, 2A
允许范围 | 20.4 to 28.8 VDC | 5 to 30 VDC or 5 to 250 VAC
每组总电流 | 10A | 10A

1. SIMATIC 模块的规格参数同 CN 模块。


S7-200温度范围

8 输入模拟量 EM231 发布

SIMATIC S7-200 新的模拟量模块 8 输入模拟量 EM231最新发布。新模块的尺寸与现有模块 EM231 和 EM235 的尺寸完全相同，8 输入模拟量 EM231模块只占用一个扩展模块的位置，这就使系统可以使用更多的模拟量通道。

新的 8 输入模拟量 EM231模块与现有的4输入EM231模块不同，只有 6 和 7 通道支持电流输入。

技术参数

表 1. 新 EM 231 8 模拟量输入规格表

产品 | EM231, 8 模拟量输入
定货号 | 6ES7 231-0HF22-0XA0
尺寸 (W, H, D) | 71.2mm, 80mm, 62mm
VDC 需求： | +5V DC (背板)：20mA +24V DC：60mA
输入通道数： | 8 个
数据字格式: 双极性 单极性 | -32000 到 +32000 0 到 32000
精度： 双极性 单极性 | 11位 加 1 个符号位 11 位
输入范围： 0 至 5通道： 6 至 7 通道： | +10V, +5V, +/-5V, +/-2,5V +10V, +5V, +/-5V, +/-2,5V和 0-20mA

EM231 8 输入配置开关表

按照下面的表格来配置拨码开关。其中使用开关 3， 4，5 来选择模拟量输入范围，使用开关 1，2 来选择电流输入模式（只有通道 6 和 7 可以用作电流输入）。并且当最后两个通道使用电流信号时，前6个通道的电压测量范围必须是0-5V，而不能使用0-10V的信号。所以，当您需要接入8路电流信号时，只能使用两个EM231的4通道的模块。

8输入的EM231模块只有第6、7两通道可以用做电流输入，使用拨码开关1、2对其进行设置：当开关1为“ON”时，通道6用做电流输入；开关2为“ON”时，通道7用做电流输入。反之，当1、2开关为“OFF”时，6、7通道用做电压输入。

表 2. 新 EM 231 8 模拟量输入配置开关表

接线图

图 1. 新 EM 231 8 模拟量输入接线图


S7-200温度范围

4 输出模拟量模块 EM232 发布

SIMATIC S7-200 新的模拟量模块 4 输出模拟量 EM232 最新发布。新模块的尺寸与现有 2 输出模块 EM232 尺寸完全相同。 4 输出模拟量 EM232 模块只占用一个扩展模块的位置，这就使系统可以使用更多的模拟量通道。

技术参数

表1. 4 输出模拟量模块 EM232 规格表

产品 | EM232, 4 模拟量输出
定货号 | 6ES7 232-0HD22-0XA0
尺寸 (W, H, D) | 71.2mm, 80mm, 62mm
VDC 需求： | +5V DC (背板)：20mA +24V DC：60mA
输出通道数： | 4 个
数据字格式: 双极性 单极性 | -32000 到 +32000 0 到 32000
精度： 双极性 单极性 | 11位 加 1 个符号位 11 位
信号范围： | 电压输出：+10V 电流输出： 0-20mA
误差： | +/- 0.5% (25°C), +/- 2% (55°C)

接线图

图1. 4 输出模拟量模块 EM232 接线图


S7-200温度范围

8 输入 EM231 TC 热电偶模块发布

SIMATIC S7-200 新的模拟量模块 8 输入EM231 TC 热电偶模块最新发布。新模块的尺寸与现有模块 EM231TC 的尺寸完全相同，8 输入模拟量 EM231TC 模块只占用一个扩展模块的位置，这就使系统可以使用更多的模拟量通道。

新的模块不能用在S7-200 CPU 的 21x 系列上。

技术参数

表1. 8 输入 EM231 TC 热电偶模块规格表

产品 | EM231 TC, 8 模拟量输入
定货号 | 6ES7 231-7PF22-0XA0
尺寸 (W, H, D) | 71.2mm, 80mm, 62mm
VDC 需求： | +5V DC (背板)：87mA +24V DC：60mA
输入通道数： | 8 个
输入范围： | 支持的热电偶型号：S, T, R, E, N, K, J, 电压测量+/- 80mV
精度： | 0.1 °C 或 0.1°F 15 位加符号位
误差： | 0.1% FS (电压测量 ) 0.05% FS

拨码开关设置与 EM231 TC, 4 模拟量输入模块相同

接线图

图1. 8 输入 EM231 TC 热电偶模块接线图


S7-200 CN 简介

S7-200 CN —— 德国品质，中国制造

不断创新，服务用户是西门子始终秉承的传统，这一点在西门子公司小型可编程序控制器 S7-200 PLC 上表现得淋漓尽致。自 S7-200 PLC 进入中国，立刻受到了用户的广泛欢迎； 随着 1998 年 S7-200 PLC 升级为第二代产品， 2004 年 S7-200 PLC 升级为第三代产品， S7-200 PLC 已经成为小型 PLC 中的佼佼者。每一次升级都是技术和品质的巨大飞跃，每一次升级都是西门子公司强大研发力量的缩影。为了更好地贴近并服务于中国用户，今天，我 们将 S7-200 CN 的生产带到了中国，相信这必将是中国工控领域的又一个里程碑。

S7-200 CN 继承了 S7-200 的优良品质和卓越性能，适用范围可覆盖从替代继电器的简单 控制到复杂的自动化控制，应用领域极为广泛，覆盖所有与自动监测，自动化控制有关的工 业及民用领域，包括各种纺织机械、中央空调、印刷机械、包装机械、工程机械、小型机床、 楼宇自控、民用设施、环境保护设备等等。

S7-200 CN 系列产品在中国制造，并且只限于在中国销售和使用。S7-200 CN 必须和 STEP 7-Micro/WIN V4.0 SP3 以上版配合使用，并且设置界面语言为“中文”。

产地变更声明及 S7-200 CN退市信息

关于产地变更：

S7-200 系列PLC 先后共有3 个生产基地，EWA、SNC 和SEWC。自2015 年4 月起，所有S7-200系列PLC（除6ES72906AA200XA0 外）均已转至成都SEWC 生产。S7-200 Classic 产地从EWA 转
至SEWC，S7-200CN 产地从SNC 转至SEWC。具体详情可参照下表。转产后货期不受影响。产地变更声明如下链接所示：

产地变更声明

关于 S7-200 CN 退市：

2016年10月，发布过"预退市通知"，提及一年后会正式退市。
这里的退市，是指向市场宣告退市（phase out），不是停产（cancellation）。
宣告退市后，价格和产能都是随着市场实际需求动态调整的，这里无法提前确定，客户可结合之前的整体规律自行把握。
真正停产后，常规产品都会维持若干年（不超过10年）的备品备件期，这期间，原有客户的旧件维修是可以进行的（一般都已过保，是需要自付费的），但无法购买新的产品。

时间顺序是：
预退市-->宣告退市-->停产（进入备品备件期）

关于新项目选型及旧项目移植：

原则：根据实际的要求及需要，选择可以满足要求的产品系列，比如可以考虑 S7-200 SMART 或者 S7-1200 系列产品是否可以满足要求

参考：S7-200 移植到 S7-200 SMART

关于 S7-200 CN 的几点说明：

为何在 STEP 7-Micro/WIN V4.0 SP3 中无法选择 S7-200 CN CPU？

如果在 STEP 7-Micro/WIN 中为项目选择 CPU 时找不到 S7-200 CN CPU，这也是正常的。可以选择 CN CPU 对应的产品，在实际连接 CN CPU 通信 、调试时，Micro/WIN 会自动识别 CN CPU。

什么是 S7-200 CN？S7-200 CN 和 SIMATIC S7-200 的共同点是什么？不同之处在哪里？

S7-200 CN 家族系列产品是专供中国低端 PLC 市场的小型 PLC。它与 SIMATIC S7-200 PLC 的技术规格、功能特性、外观尺寸以及编程软件都相同。S7-200 CN 家族系列产品与 SIMATIC S7-200 各 CPU 及模块 100% 兼容。

S7-200 CN 家族系列产品与 SIMATIC S7-200 的不同之处在于 S7-200 CN 在中国制造，并且只限于在中国销售和使用。

S7-200 CN 家族系列在哪里生产？

S7-200 CN 家族系列产品在位于中国南京的西门子（南京）数控有限公司（简称 SNC） 生产。SNC 是 1996 年德国西门子股份公司/西门子（中国）有限公司与中国北方工业集团公司共同成立的合资公司，生产西门子自动化和数控产品，是西门子自动化产品全球三大生产中心之一。有着德国血统的 SNC 实力雄厚，公司研发部人员超过 60 人，测试和工艺开发工程师约 30 人，拥有训练有素的员工和特别邀请的德国专家，专门在生产线 帮助中国员工提高生产技术水平。在生产能力和产品产出的快速增长过程中，SNC 应用西门子的先进制造设备和技术， 严格的质量管理体系以及高效的生产过程控制保证了西门子自动化产品的卓越品质。本地化的生产不仅带来了生产成本优势，更重要的是专业的本地化研发能够更加贴近中国用户，为中国用户的需求提供快速的响应。

S7-200 CN 的 CPU 能否带 SIMATIC S7-200 的扩展模块？SIMATIC S7-200 的 CPU 能否带 S7-200 CN 的扩展模块？

可以。它们之间是 100% 兼容的。

使用 23 版本的新存储卡向 S7-200 CN 中复制程序为何会发生 SF（系统故障）错误？

23 版的存储卡与 S7-200 CN CPU 完全兼容，既可以用在 23 版以上的 SIMATIC S7-200 上，也可以用在 S7-200 CN 上。

为了限制中国以外的用户使用 S7-200 CN CPU，通过存储卡从 SIMATIC CPU 到 CN CPU 的程序转移被限制，即它们之间不能通过存储卡传送程序。

要通过存储卡向 CN CPU 传送程序，存储卡必须在 CN CPU 上编程。

要清除 SF 错误，可以使用菜单命令“PLC > 存储卡擦除”，然后执行“PLC > 上电复位”。

为什么 S7-200 CN 产品中没有通信等模块的订货号？

S7-200 CN 产品系列目前还不包括通信和智能模块。S7-200 CN 可以带 SIMATIC S7-200 的智能模块工作。

S7-200 CN 系列产品是否可以用在出口设备上？

S7-200 CN 系列产品在中国制造，只限于在中国销售和使用。出口设备请使用 SIMATIC S7-200 系列产品。

S7-200 CN 系列产品有没有专门的中文手册？如何获得？

S7-200 CN 系列产品与 SIMATIC S7-200 产品完全兼容，因此没有专门的 “CN 产品手册”。相关事项请参见“资料手册”。

S7-200 CN 系列产品的维修和售后服务有什么变化？

S7-200 CN 和 SIMATIC S7-200 产品在中国国内的维修和售后服务一如既往，没有任何改变。S7-200 CN 的维修流程与 SIMATIC S7-200 相同，均由上海西门子工业自动化有限公司（SIAS）负责。


MLFB - CN EM

S7-200 CN EM 订货号

西门子于 2005 年 12 月 16 日正式发布了 S7-200 CN 系列产品。产品系列中包括 S7-200 CN CPU 和 S7-200 CN EM 扩展模块。

表 1. S7-200 CN EM 订货号

型号 | 规格 | S7-200 CN 订货号 | SIMATIC S7-200 订货号 | CN 模块列表价 （RMB）
EM 221 CN | 数字量输入模块， 8 输入 24V DC | 6ES7 221-1BF22-0XA8 | 6ES7 221-1BF22-0XA0 | 698.99
 | 数字量输入模块， 16 输入 24V DC | 6ES7 221-1BH22-0XA8 | 6ES7 221-1BH22-0XA0 | 1,022.28
EM 222 CN | 数字量输出模块， 8 输出 24V DC | 6ES7 222-1BF22-0XA8 | 6ES7 222-1BF22-0XA0 | 830.05
 | 数字量输出模块， 8 输出继电器 | 6ES7 222-1HF22-0XA8 | 6ES7 222-1HF22-0XA0 | 961.11
EM 223 CN | 数字量输入/输出模块， 4 输入/4 输出 24V DC | 6ES7 223-1BF22-0XA8 | 6ES7 223-1BF22-0XA0 | 847.53
 | 数字量输入/输出模块， 4 输入 24V DC/4 继电器输出 | 6ES7 223-1HF22-0XA8 | 6ES7 223-1HF22-0XA0 | 891.21
 | 数字量输入/输出模块， 8 输入/8 输出 24V DC | 6ES7 223-1BH22-0XA8 | 6ES7 223-1BH22-0XA0 | 1,240.71
 | 数字量输入/输出模块， 8 输入 24V DC/8 继电器输出 | 6ES7 223-1PH22-0XA8 | 6ES7 223-1PH22-0XA0 | 1,328.08
 | 数字量输入/输出模块， 16 输入/16 输出 24V DC | 6ES7 223-1BL22-0XA8 | 6ES7 223-1BL22-0XA0 | 2,420.26
 | 数字量输入/输出模块， 16 输入 24V DC/16 继电器输出 | 6ES7 223-1PL22-0XA8 | 6ES7 223-1PL22-0XA0 | 2,612.48
 | 数字量输入/输出模块， 32 输入/32 输出 24V DC | 6ES7223-1BM22-0XA8 | 6ES7223-1BM22-0XA0 | 5255.40
 | 数字量输入/输出模块， 32 输入 24V DC/32 继电器输出 | 6ES7223-1PM22-0XA8 | 6ES7223-1PM22-0XA0 | 5476.68
EM 231 CN | 模拟量输入模块，4 输入 | 6ES7 231-0HC22-0XA8 | 6ES7 231-0HC22-0XA0 | 1,555.26
 | 2 路输入热电阻 | 6ES7 231-7PB22-0XA8 | 6ES7 231-7PB22-0XA0 | 2,114.45
 | 4 路输入热电偶 | 6ES7 231-7PD22-0XA8 | 6ES7 231-7PD22-0XA0 | 2,114.45
EM 232 CN | 模拟量输出模块，2 输出 | 6ES7 232-0HB22-0XA8 | 6ES7 232-0HB22-0XA0 | 1,695.06
EM 235 CN | 模拟量输入/输出模块， 4 输入/1 输出 | 6ES7 235-0KD22-0XA8 | 6ES7 235-0KD22-0XA0 | 2,062.03

在上表中未列出的扩展模块，目前还没有 S7-200 CN 系列产品。可使用 SIMATIC S7-200 产品代替。您的产品选型或方案确认需求需要结合工艺、应用场合等因素综合考虑，以上是仅从技术角度给您的建议，仅作参考不作为最终的订货依据，最终方案请与西门子销售或经销商确认。


S7-200 CN PIX

S7-200 CN 图片

S7-200 CN 产品上的文字标志与 SIMATIC S7-200 一样都是激光打印的。

图 1. S7-200 CN CPU 正面

图 2. S7-200 CN CPU 侧面

图 3. S7-200 CN EM（扩展模块）正面

图 4. S7-200 CN EM 侧面


STEP 7-Micro/WIN V4.0 SP3

西门子于 2005 年 12 月正式推出 S7-200 新版编程软件 STEP 7-Micro/WIN V4.0 SP3。Micro/WIN V4.0 SP3 配合 S7-200 CN 和 SIMATIC S7-200 REL V2.01 以上固件版本的 CPU 使用。

S7-200 CN CPU 必须配合 STEP 7-Micro/WIN V4.0 SP3 或以上版使用。STEP 7-Micro/WIN V4.0 SP3 配合 S7-200 CN 使用时，必须设置语言环境为中文才能正常工作。

STEP 7-Micro/WIN V4.0 SP3 下载见软件下载链接。

STEP 7-Micro/WIN V4.0 SP3 新功能

STEP 7-Micro/WIN V4.0 SP3 的主要新功能为：

  • 可配合 S7-200 CN CPU 使用
  • 增加了第 4 级（Level 4）密码保护功能

STEP 7-Micro/WIN V4.0 SP3 相关问题

为何在 STEP 7-Micro/WIN V4.0 SP3 中无法选择 S7-200 CN CPU？

如果在 STEP 7-Micro/WIN 中为项目选择 CPU 时找不到 S7-200 CN CPU，这也是正常的。可以选择 CN CPU 对应的产品，在实际连接 CN CPU 通信 、调试时，Micro/WIN 会自动识别 CN CPU。

STEP 7-Micro/WIN V4.0 SP3 与 STEP 7-Micro/WIN V4.0 是什么关系？是否向下兼容？

STEP 7-Micro/WIN V4.0 SP3 是 STEP 7-Micro/WIN V4.0 的升级版，它完全向下兼容。

STEP 7-Micro/WIN V4.0 SP3 是否支持其他 CPU ？

STEP 7-Micro/WIN V4.0 SP3 不但支持最新发布的 S7-200 CN 产品系列，而且完全兼容以前、和新发布的相应版本的 SIMATIC S7-200 系列产品。

STEP 7-Micro/WIN V4.0 SP3 是否可以打开以前版本软件生成的项目文件，并且下载到 S7-200 CN CPU 中？

完全可以，但必须设置工作语言环境为中文。

打开更老版本的项目文件

STEP 7-Micro/WIN V4.0 SP3 为什么必须设置为中文界面才能给 S7-200 CN CPU 编程？

STEP 7-Micro/WIN V4.0 SP3 在英文界面下向 S7-200 CN 下载程序会出现“82 号非致命错误”；这可能并非编程错误。只有切换到中文界面下才能正常使用。

STEP 7-Micro/WIN V4.0 SP3 在离线编程时为什么不能选择到 S7-200 CN CPU？如何处理这种情况？

STEP 7-Micro/WIN V4.0 SP3 离线编程时不能在“PLC > 类型”中选择到 S7-200 CN CPU。用户可以选择相应的 SIMATIC S7-200 CPU，并选择 CPU 固件版本号为 2.01。在线通信时，Micro/WIN 可以自动识别 S7-200 CN CPU。

使用 23 版本的新存储卡向 S7-200 CN 中复制程序为何会发生 SF（系统故障）错误？

23 版的存储卡与 S7-200 CN CPU 完全兼容，既可以用在 23 版以上的 SIMATIC S7-200 上，也可以用在 S7-200 CN 上。

为了限制中国以外的用户使用 S7-200 CN CPU，通过存储卡从 SIMATIC CPU 到 CN CPU 的程序转移被限制，即它们之间不能通过存储卡传送程序。

要通过存储卡向 CN CPU 传送程序，存储卡必须在 CN CPU 上编程。

要清除 SF 错误，可以使用菜单命令“PLC > 存储卡擦除”，然后执行“PLC > 上电复位”。


S7-200

S7-200 CN / SIMATIC S7-200

S7-200 PLC是SMIATIC S7家族中的小型可编程控制器，适用于各行各业、各种应用场合中的检测、监测及控制的自动化。S7-200的使用范围可覆盖从替代继电器的简单控制，到极复杂的自动化控制，应用领域极为广泛。S7-200的应用范围覆盖所有与自动检测、自动化控制有关的工业及民用领域，包括各种机床、机械、电力设施、民用设施、环境保护设备等。S7-200在全世界拥有数以百万计的成功应用案例，无论是单独运行，还是联网应用。

S7-200将高性能与小体积集成一体，运行快速，并且提供了丰富的通信选项，具有极高的性能/价格比。S7-200的系统的硬件、软件都易于使用。S7-200系统坚持一贯的模块化设计，不但能够经济地满足目前的项目要求，也为将来扩展提供了开放的接口。S7-200易于编程，引入了编程工具箱（ToolBox）概念，设计了许多编程向导（Wizard）以方便用户完成一些比较复杂的程序设计工作。

S7-200的出色性能表现在：

  • 极高的可靠性
  • 极丰富的指令集
  • 易于掌握
  • 便捷的操作
  • 丰富的内置集成功能
  • 实时特性
  • 丰富的扩展模块


S7-200退市通知

关于S7-200CN 和TD400C 产品退市的通知

尊敬的客户和合作伙伴：

在2016年10月8日发布的预退市通知基础上，这里正式通知各位，自2017年10月1日起，下方表格所示的S7-200CN产品
以及TD400C文本显示器，正式进入退市阶段。这些产品的价格组也相应地变为2AP。在产品停止生产（会另行通知）之
前，这些退市产品依然可以正常订购。

SIMATIC S7-200 SMART是S7-200CN的升级替代产品。如您在移植过程中需要任何帮助，请联系当地的西门子授权代
理商或S7-200 SMART产品销售经理。

关于S7-200CN的移植指导手册可点击此处，或者点击此处 。

S7-200 SMART的相关技术资料，如样本、编程软件、系统使用手册等资料，可访网址：http://www.siemens.com.cn/s7-200smart

如有任何疑问，请随时与FA BU S7-200CN 产品经理孙洪雷先生联系。邮箱：honglei.sun@siemens.com。

感谢您对SIMATIC S7-200产品业务的支持！

停产通知附件点击下载：关于S7-200CN 和TD400C 产品退市的通知


规格－新一代S7-200 CPU

新一代S7-200产品系列

西门子已经对S7-200的CPU系列进行了改进，增加了新功能。而且还增加了一个新型号CPU224 XP。为了支持新功能，又增加了两种新的存储卡。在新的CPU系列中已经取消了CPU226 XM的型号。

新产品已在2004年8月发布。新产品的价格不变。按老产品订货号订货的用户，可能直接收到新产品（仅限CPU224和CPU226）。

新产品完全向下兼容老产品的功能。新CPU的订货号中间有23的数字，如6ES7 214-1BD23-0XB0

另外，西门子还将推出新的S7-200专用的HMI（人机界面），以及一个新的OPC Server产品。

新的CPU与旧版相比新增了以下特性和功能：

  • 运行速度快了40％
  • 增加了50％的程序存储区
  • 增加了60％的数据区（V存储区）
  • 新的存储卡用于数据记录功能、配方管理及Micro/WIN项目的存储，以及不同文件格式的文档的存储。
  • PID自整定功能
  • 用于诊断/状态显示的LED灯
  • 夏时制的自动切换功能

新的CPU与旧版CPU的性能比较：

表1.

功能 | 旧（22）版CPU |  | 新（23版）CPU
逻辑扫描时间 | .370μs |  | .222μs
逻辑存储区 | CPU221/222 | 4KB | CPU221/222 | 4KB
 | CPU224 | 8KB | CPU224 | 8KB（使能在线编辑功能） 12KB（禁止在线编辑功能）
 |  |  | CPU224 XP | 12KB（使能在线编辑功能） 16KB（禁止在线编辑功能）
 | CPU226
 | CPU226 XM | 16KB | CPU226 | 16KB（使能在线编辑功能） 24KB（禁止在线编辑功能）
数据变量区 | CPU221/222 | 2KB | CPU221/222 | 2KB
 | CPU224 | 5KB | CPU224 | 8KB
 | CPU226 |  | CPU224 XP | 10KB
 | CPU226 XM | 10KB | CPU226
在线编辑功能 | 无 |  | 有（CPU221/222除外）
数据归档指令 | 无 |  | 有
配方指令 | 无 |  | 有
存储卡 项目存储功能 | 无 |  | 有
存储卡 其它文件存储功能 | 无 |  | 有
PID自整定功能 | 无 |  | 有
线性斜坡 脉冲输出指令 | 无 |  | 有
CPU诊断灯 | 只有SF系统故障灯 |  | 两种颜色的SF灯， 并可由用户控制其中一个

S7-200 CPU224 XP增加了哪些新功能？

CPU224 XP除了具有新的CPU224和CPU226的功能外，还具有以下功能：

  1. 带有两个RS-485通信口

  2. 带有集成的模拟量

    新增加的CPU224 XP带有两个模拟量输入（10位，±10 VDC)和一个模拟量输出（10位，0 - 10VDC或0 - 20mA)。

  3. S7-200 CPU内置的位控解决方案增加了以下功能：

    CPU224 XP除了与其他新CPU一样支持线性斜坡脉冲输出功能外，还有如下特点

    • CPU224 XP的内置高速脉冲的输出波特率提高到100K
    • 其输出的电压等级扩展到TTL - 24V的范围

  4. CPU224 XP的高速计数器提高到100KHz

    增加了两个200KHz的高速计数器（单相），它们可以与其他数字量输入点一样，既可以接成源型输入又可以接成漏型输入，并且其输入的电压等级可以是TTL-24V。如果用于双相则相当于增加了一个100K的高速计数。

新CPU的主要特性：

表2.

特性 |  | CPU221 | CPU222 | CPU224 | CPU224 XP | CPU226
类型: (电源 - 输入 - 输出) |  | AC-DC-Rly 和 DC-DC-DC | AC-DC-Rly 和 DC-DC-DC | AC-DC-Rly 和 DC-DC-DC | AC-DC-Rly 和 DC-DC-DC | AC-DC-Rly 和 DC-DC-DC
电源类型: 交流电源 = 85-264 VAC 直流电源 = 20.4-28.8VDC |  | 有
集成的输入/输出 |  | 6 DI / 4DO | 8 DI / 6DO | 14 DI / 10 DO |  | 24 DI / 16 DO
内置模拟量输入 |  | 无 |  |  | 2 AI / 1AO | 无
在线编辑功能 |  | 无 |  | 有
程序逻辑区(L) (Bytes) | 使能在线编辑功能 | 4K |  | 8K | 12K | 16K
 | 禁止在线编辑功能 |  |  | 12K | 16K | 24K
数据区(V) (Bytes) |  | 2K |  | 8K | 10K
执行时间(μs) |  | 0.222
高速计数器 | 最大个数 | 4 |  | 6
 | 单相 | 4 @ 30kHz |  | 6 @ 30 kHz | 4 @ 30 kHz 2 @ 200 kHz | 6 @ 30 kHz
 | 双相 | 2 @ 20kHz |  | 4 @ 20 kHz | 3 @ 20 kHz 1 @ 100 kHz | 4 @ 20 kHz
脉冲输出 |  | 2 @ 20 kHz |  |  | 2 @ 100 kHz | 2 @ 20 kHz
内置通信口 |  | 1 x RS-485 |  |  | 2 x RS-485
自整定PID功能 |  | 有
高级指令 - 数据归档 - 配方管理 |  | 有 有

新存储卡

西门子新推出了两款新存储卡（64K和256K），如果要使用配方功能和数据记录（归档）功能，则必须使用其中一种存储卡。这两种存储卡具有以下功能：

  • 项目文档
    • 可存储bitmap（位图）文件，PDF文件，DOC文件
    • 完整的Micro/Win项目可以方便的传送到存储卡中，也就是说最新的用户文档可以储存在现场

  • 配方处理功能
    • 定义并向存储卡中下装配方：产品数据，设备参数
    • CPU中只储存一个配方，因而可以更好的使用内存：可以实现从存储卡中向CPU中在线更新和修改配方

  • 数据记录
    • 动态存储运行数据、统计数据、以及故障信息
    • 可选的时间标记
    • 记录文件可以通过资源管理器传送到PC机

新、旧版CPU和存储卡的兼容性问题

新编程软件STEP 7-Micro/WIN 4.0

针对改进的CPU，西门子推出了STEP 7-Micro/WIN 4.0软件。该软件功能更强大，使用起来更容易。与V3.2版的Micro/WIN相比，增加了状态表趋势图及以下新的和改进的向导功能：

  • PID控制调试面板
  • PID自整定调试功能
  • 新的PTO/PWM（脉冲输出）向导
  • 数据记录向导
  • 配方管理向导

其它新特性包括：

  • 数据块分页存储
  • 改进的程序归档及命令归档
  • 诊断功能如用户定义的LED（SF）灯，故障历史查询，在线编辑功能

STEP 7-Micro/WIN V4.0版的运行环境为Winows2000或WindowsXP操作系统

要使用新产品的新功能，需要STEP 7-Micro/WIN V4.0；如果使用V3.2版，只能使用一般功能。

STEP 7-Micro/WIN V4.0新功能

新型的HMI

西门子增加或改进了以下几种HMI

  • TD 200C
    在TD 200的基础上，TD 200C做了很大的改进：
    • 用户自定义的用户接口布置
    • 自由选择控制键及表面的颜色与形状
    • 最多可使用20个可配置的控制键
    • 集成自己公司的标识
    • 集成的国际符号
    原来的TD 200仍然继续供应。

  • OP 73micro
    • 拥有3寸显示屏的操作面板
    • 网络连接（PPI，MPI）
    • 可自由定义信号等级的信号系统
    • 5种在线语言，包括亚洲和西里尔字符集

  • TP170micro
    • 拥有5.7寸显示屏的触摸屏
    • 网络连接（PPI，MPI）
    • 可自由定义信号等级的信号系统
    • 5种在线语言，包括亚洲和西里尔字符集（支持中文）
    • 使用WinCC flexible micro可以方便的编程

PC机与S7-200的新的连接访问软件（OPC Server）：PC Access

PC Access 使得S7-200与PC机间的数据交换简单而完美。PC Access 作为S7-200的OPC服务器，也就是说：

  • 使用MS Excel可以读/写S7-200的数据
  • ProToolPro,
    WinCC flexible RT, WinCC,
    WonderWare等
    可以作为OPC客户端访问S7-200
  • 可视化的界面
  • 支持以下任一种连接方式，最多可建立8个通信连接（连接8个CPU）：
    • PPI（智能多主站电缆）
    • Modem（EM241）
    • Ethernet/IT CP（CP243-1，CP243-1 IT）

PC Access将取代老的S7-200 OPC Server。

参见PC Access V1.0。

最新的资料

若要详细了解新产品的情况，请登录S7-200产品主页，下载最新的SIMATIC S7-200 System Manual（英文版）。


编程软件－STEP 7 - Micro/WIN V4.0

STEP 7-Micro/WIN V4.0 新特性

为了支持新推出的新一代S7-200 CPU的新功能，西门子也同时发布了新的编程软件STEP 7-Micro/WIN V4.0。除了支持CPU的新功能外，Micro/WIN本身的功能也得到了增强。

STEP 7-Micro/WIN V4.0的安装、运行环境为：

  • Windows 2000 SP3以上
  • Windows XP Home
  • Windows XP Professional

西门子没有在其他操作系统下测试，不保证能够使用。

STEP 7-Micro/WIN V4.0的主要改进与新功能有：

  • 以“超级树形目录”组织项目文件资源
  • 数据块支持分页存储，并且能够导入/导出
  • 状态趋势图
  • 对新存储卡的支持
  • 支持新的字符串数据格式
  • 新的指令
  • 对整个项目程序的密码保护
  • 其他功能易用性的提高

在新版Micro/WIN中，又改进或新推出了以下编程向导或调试工具：

  • 高速脉冲输出向导
  • 配方配置向导
  • 数据记录（归档）配置向导
  • 新的TD 200配置向导
  • PID调试控制面板及PID自整定功能支持

STEP 7-Micro/WIN V4.0向下兼容老版本的CPU，但不能实现只有新CPU（23版）支持的新功能。

Micro/WIN V4.0生成的项目文件，旧版本的Micro/WIN不能打开或上载。

“超级树”项目资源目录结构

STEP 7-Micro/WIN V4.0以一种“超级树”形的目录结构组织项目文件的资源。与以前相比，4.0版增加了“数据块”、“系统块”、“交叉引用表”的树形访问目录。另外，还把编程向导和调试工具放在指令树中。

图1. “超级树”形目录结构

数据块新功能

  • 新版Micro/WIN现在支持数据块分页存储。用户可以把不同用途的数据分类，分别在不同数据页中定义；新的向导程序生成的数据块也自动分类保存。

图2. 数据块分页

如果在不同的数据分页中定义的数据地址重叠，编译时Micro/WIN会自动指出以避免错误。在消息输出窗口中用鼠标双击错误提示文字会自动跳到相应出错的地址。

  • 定义数据时自动计算地址

输入数据后，保持光标在数据行的末尾，如果按“CTRL+Enter”键，会自动计算出下一个数据的地址。这在输入字符串时特别有用。如图3。

  • 如果在数据分页标签上点击鼠标右键，选择Properties...（属性），可以查看、设置每个数据页的属性，并且可以对它们单独设置密码保护

所谓保护，就是使其他不知道密码的人无法修改此页的数据定义，但是可以查看；要修改它，必须在分页的属性中验证密码。许多编程向导（Wizard）生成的数据块页都是保护的。

图3. 锁的标记表明这是一个“受保护”的数据页

  • 数据块导入/导出

在树形目录中选择Data Block（数据块），在File（文件）菜单中，或者在鼠标右键的快捷菜单中选择Export...（导出）或Import...（导入）。数据块可以导出为文本文件，符合格式的文本文件也可导入成为数据块。

图4. 在数据块的右键快捷菜单中选择导入/导出功能

这些都是Micro/WIN V4.0的新功能，支持新版（23版）和老版的CPU。

分页结构的数据块下载到CPU中后，由其他Micro/WIN V4.0上载后仍保持分页结构；被保护的页其密码仍然有效。

状态趋势图

Micro/WIN V4.0提供了两种PLC变量在线查看方式：传统的状态表形式，以及新提供的状态趋势图形式。图形化的监控方式使用户更容易地观察各变量的变化关系。

在View（查看）菜单中选择View As Trend（查看趋势），或按工具栏按钮 [image] 可以在状态表格形式与状态趋势查看方式之间切换。进入在线监控状态就可以查看实际参数。趋势图可以用Chart Status（表状态）菜单命令或工具栏按钮 [image] 停止移动。

在状态趋势图方式下，Micro/WIN在显示区域中按照一定的刷新速率，以图形显示变量的值，包括最大值、当前值、最小值等信息。在状态趋势图中一样可以执行“强制”、“写入”等命令。

在趋势图中点击鼠标右键，在快捷菜单中可以设置图形更新的时基（速率）。在这里选择的速率仅是Micro/WIN图形刷新的速率，与实际的变量变化无关。

图5. 状态趋势图

对于连续变化的变量，也可能会显示出锯齿图形。这是因为Micro/WIN采样的频率比较慢，在各个采样值之间Micro/WIN会连接直线。趋势图不能记忆，也不能保存。

此功能兼容所有（包括老版本的）CPU。

其他改进

  • 为常数也可以指定符号名
  • 定时器功能块上显示时基
  • 编程时可以用鼠标右键快捷菜单方便地定义和选择符号名
  • 编程向导配置可以打印，并支持打印预览


MLFB - CN CPU

S7-200 CN CPU 订货号

西门子于 2005 年 12 月 16 日正式发布了 S7-200 CN 系列产品。产品系列中包括 S7-200 CN CPU 和 S7-200 CN EM 扩展模块。

表 1. S7-200 CN CPU 订货号

型号 | 规格 | S7-200 CN 订货号 | SIMATIC S7-200 订货号 | 列表价 （RMB）
CPU 222 CN | DC/DC/DC， 8 输入/6 输出 | 6ES7 212-1AB23-0XB8 | 6ES7 212-1AB23-0XB0 | 1,826.12
 | AC/DC/继电器， 8 输入/6 输出 | 6ES7 212-1BB23-0XB8 | 6ES7 212-1BB23-0XB0 | 1,965.92
CPU 224 CN | DC/DC/DC， 14 输入/10 输出 | 6ES7 214-1AD23-0XB8 | 6ES7 214-1AD23-0XB0 | 2,699.86
 | AC/DC/继电器， 14 输入/10 输出 | 6ES7 214-1BD23-0XB8 | 6ES7 214-1BD23-0XB0 | 2,839.66
CPU 224XP CN | DC/DC/DC， 14 输入/10 输出 | 6ES7 214-2AD23-0XB8 | 6ES7 214-2AD23-0XB0 | 4,325.01
 | AC/DC/继电器， 14 输入/10 输出 | 6ES7 214-2BD23-0XB8 | 6ES7 214-2BD23-0XB0 | 4,499.76
CPU 226 CN | DC/DC/DC， 24 输入/16 输出 | 6ES7 216-2AD23-0XB8 | 6ES7 216-2AD23-0XB0 | 4,857.99
 | AC/DC/继电器， 24 输入/16 输出 | 6ES7 216-2BD23-0XB8 | 6ES7 216-2BD23-0XB0 | 5,085.17

S7-200 CN 产品中目前不包括 CPU 221。 您的产品选型或方案确认需求需要结合工艺、应用场合等因素综合考虑，以上是仅从技术角度给您的建议，仅作参考不作为最终的订货依据，最终方案请与西门子销售或经销商确认。


CPU22 订货号

CPU 订货号（6ES7 21x-xxx22-xxxx）

表1. CPU订货号

CPU型号 | 订货号
CPU 221 DC/DC/DC 6输入/4输出 | 6ES7 211-0AA22-0XB0
CPU 221 AC/DC/Relay 6输入/4输出 | 6ES7 211-0BA22-0XB0
CPU 222 DC/DC/DC 8输入/6输出 | 6ES7 212-1AB22-0XB0
CPU 222 AC/DC/Relay 8输入/6输出 | 6ES7 212-1BB22-0XB0
CPU 224 DC/DC/DC 14输入/10输出 | 6ES7 214-1AD22-0XB0
CPU 224 AC/DC/Relay 14输入/10输出 | 6ES7 214-1BD22-0XB0
CPU 226 DC/DC/DC 24输入/16输出 | 6ES7 216-2AD22-0XB0
CPU 226 AC/DC/Relay 24输入/16输出 | 6ES7 216-2BD22-0XB0
CPU 226XM DC/DC/DC 24输入/16输出 | 6ES7 216-2AF22-0XB0
CPU 226XM AC/DC/Relay 24输入/16输出 | 6ES7 216-2BF22-0XB0

DC/DC/DC——直流供电、直流输入、晶体管直流输出；AC/DC/Relay——交流供电、直流输入、继电器接点输出。

您的产品选型或方案确认需求需要结合工艺、应用场合等因素综合考虑，以上是仅从技术角度给您的建议，仅作参考不作为最终的订货依据，最终方案请与西门子销售或经销商确认。


扩展模块订货号

表1. 数字量扩展模块订货号

订货号 | 数字量扩展模块 | 数字量输入 | 数字量输出
6ES7 221-1BF22-0XA0 | EM 221 数字量输入 | 8 x 24VDC | -
6ES7 221-1EF22-0XA0 | EM 221 数字量输入 | 8 x 120/230VAC | -
6ES7 221-1BH22-0XA0 | EM 221 数字量输入 | 16 x 24VDC | -
6ES7 222-1BD22-0XA0 | EM 222 数字量输出 | - | 4 x 24VDC - 5A
6ES7 222-1HD22-0XA0 | EM 222 数字量输出 | - | 4 x 继电器 - 10A
6ES7 222-1BF22-0XA0 | EM 222 数字量输出 | - | 8 x 24VDC - 0.75A
6ES7 222-1HF22-0XA0 | EM 222 数字量输出 | - | 8 x 继电器 - 2A
6ES7 222-1EF22-0XA0 | EM 222 数字量输出 | - | 8 x 120/230VAC/0.5A
6ES7 223-1BF22-0XA0 | EM 223 数字量输入/输出 | 4 x 24VDC | 4 x 24VDC - 0.75A
6ES7 223-1HF22-0XA0 | EM 223 数字量输入/输出 | 4 x 24VDC | 4 x 继电器 - 2A
6ES7 223-1BH22-0XA0 | EM 223 数字量输入/输出 | 8 x 24VDC | 8 x 24VDC - 0.75A
6ES7 223-1PH22-0XA0 | EM 223 数字量输入/输出 | 8 x 24VDC | 8 x 继电器 - 2A
6ES7 223-1BL22-0XA0 | EM 223 数字量输入/输出 | 16 x 24VDC | 16 x 24VDC - 0.75A
6ES7 223-1PL22-0XA0 | EM 223 数字量输入/输出 | 16 x 24VDC | 16 x 继电器 - 2A
6ES7 223-1BM22-0XA0 | EM 223 数字量输入/输出 | 32 x 24VDC | 32 x 24VDC - 0.75A
6ES7 223-1PM22-0XA0 | EM 223 数字量输入/输出 | 32 x 24VDC | 32 x 继电器 - 2A

表2. 模拟量扩展模块

订货号 | 模拟量扩展模块 | 模拟量输入 | 模拟量输出
6ES7 231-0HC22-0XA0 | EM 231 模拟量输入 | 4 x ±10V/0 - 20mA | -
6ES7 231-0HF22-0XA0 | EM 231 模拟量输入 | 8 x ±10V/0 - 20mA | -
6ES7 231-7PB22-0XA0 | EM 231 模拟量输入（热电阻） | 2 x RTD | -
6ES7 231-7PC22-0XA0 | EM 231 模拟量输入（热电阻） | 4 x RTD | -
6ES7 231-7PD22-0XA0 | EM 231 模拟量输入（热电偶） | 4 x TC | -
6ES7 231-7PF22-0XA0 | EM 231 模拟量输入（热电偶） | 8 x TC | -
6ES7 232-0HB22-0XA0 | EM 232 模拟量输出 | - | 2 x ±10V/0 - 20mA
6ES7 232-0HD22-0XA0 | EM 232 模拟量输出 | - | 4 x ±10V/0 - 20mA
6ES7 235-0KD22-0XA0 | EM 235 模拟量输入/ 输出 | 4 x ±10V/0 - 20mA | 1 x ±10V/0 - 20mA

表3. 智能模块

订货号 | 智能扩展模块
6ES7 241-1AA22-0XA0 | EM 241 Modem模块
6ES7 253-1AA22-0XA0 | EM 253 定位模块
6ES7 277-0AA22-0XA0 | EM 277 PROFIBUS-DP模块
6GK7 243-2AX01-0XA0 | CP 243-2 AS Interface 通信处理器
6GK7 243-1GX00-0XE0 | CP 243-1 IT 因特网模块 (带含电子文档的CD)
6GK7 243-1EX00-0XE0 | CP 243-1 以太网模块 (带含电子文档的CD)

表4. 外插卡和电缆

外插卡和电缆型号 | 订货号
存储卡，64K (用户程序、配方和数据记录) | 6ES7 291--8GF23--0XA0
存储卡，256K (用户程序、配方和数据记录) | 6ES7 291--8GH23--0XA0
CC 292, CPU 22x Real–Time Clock with Battery Cartridge | 6ES7 297-1AA23-0XA0
BC 293, CPU 22x Battery Cartridge | 6ES7 291-8BA20-0XA0
总线延长电缆, 0.8 米, CPU 22x/EM | 6ES7 290-6AA20-0XA0
编程电缆, RS-232/PPI 多主站 | 6ES7 901-3CB30-0XA0
编程电缆, USB/PPI 多主站 | 6ES7 901-3DB30-0XA0

表5. 编程软件

编程软件 | 订货号
STEP 7-Micro/WIN 32 (V3.2) 单授权 (CD–ROM) | 6ES7 810-2BC02-0YX0
STEP 7-Micro/WIN 32 (V3.2) 升级授权 (CD–ROM) | 6ES7 810-2BC02-0YX3
S7–200 Toolbox:TP-Designer for TP070, Version 1.0 (CD–ROM) | 6ES7 850-2BC00-0YX0
STEP 7-Micro/WIN Add–on: STEP 7-Micro/WIN 32 Instruction Library, V1.1 (CD–ROM)指令库 | 6ES7 830-2BC00-0YX0

您的产品选型或方案确认需求需要结合工艺、应用场合等因素综合考虑，以上是仅从技术角度给您的建议，仅作参考不作为最终的订货依据，最终方案请与西门子销售或经销商确认。


21/22的区别

CPU22x的版本21和22有什么区别？

第二代S7-200（CPU22x）系列也分几个主要的硬件版本。

6ES721x-xxx21-xxxx是21版；6ES721x-xxx22-xxxx是22版。

22版与21版相比，硬件、软件都有改进。22版向下兼容21版的功能。

22版与21的主要区别是：

  • 21版CPU的自由口通信速率300、600被22版的57600、115200所取代，22版不再支持300和600波特率
  • 22版不再有智能模块位置的限制

相关链接

6ES721x-xxx23-xxxx（23版）新产品


Online - Certificates

S7-200生产工厂变更信息

S7-200CN（6ES7 2xx-xxxx-0Xx8）产品曾在西门子南京有限公司（SNC）制造，从2013年11月起，将在西门子工业自动化产品成都生产及研发基地（苏州西门子电器有限公司成都分公司，简称SEWC）开始生产。
SIMATIC S7-200（6ES7 2xx-xxxx-0Xx0）产品，从2013年2月28日起，将在西门子工业自动化产品成都生产及研发基地（苏州西门子电器有限公司成都分公司，简称SEWC）开始生产。由SEWC生产的SIMATIC S7-200产品将在未来供应全球包括中国市场，SIMATIC S7-200产品的现有服务流程将保持不变。

总结
S7-200 CN系列的产地是中国成都、中国南京、中国苏州和德国。
SIMATIC S7-200系列产品根据生产安排，会是made in china，也有made in German。

SIMATIC S7-200系列产品停产信息

SIMATIC S7-200（6ES7 2xx-xxxx-0Xx0）部分产品自2014年9月30日起停止订货，并进入持续9年备件阶段。
所有退市的SIMATIC S7-200系列产品完全可以使用相同型号的S7-200 CN产品做功能性替代。对于S7-200 CN产品系列中不包含的产品，SIMATIC S7-200的相应产品仍然销售。目前，销售中的SIMATIC S7-200产品如下表所示：

SIPLUS S7-200系列产品停产信息

SIPLUS系列是针对于西门子标准产品的宽温型和耐腐蚀型的一系列产品。
S7-200家族产品的SIPLUS系列已于2014年10月1日全部停产。具体产品信息如下：


CPU外形结构和电源接法

CPU外形结构及电源

CPU输入电压范围

  • 直流DC：20.4-28.8 VDC
  • 交流AC：85-264 VAC(47-63 Hz)

CPU外形结构：

图1. CPU外形结构

  • CPU及其扩展模块安装在标准的35mm的导轨上
  • 模式选择开关：开关拨到RUN，则CPU运行（在上电时，CPU会自动运行）；开关拨到STOP，CPU停止；开关拨到TERM时，不改变当前操作模式。当模式选择开关打在RUN或TERM状态时，可以使用Micro/WIN编程软件来控制CPU的运行停止。
  • CPU226和CPU226XM上有两个通信口；新产品CPU224 XP [image] 也有两个通信端口

电源及传感器电源输出：

直流供电 交流供电
图2. 供电方式

根据CPU的型号不同，上图给出了直流供电（左图）和交流供电（右图）两种供电方式 。CPU的电源都在右上方，而右下方是传感器电源。

每一个CPU模块都有一个24VDC传感器电源，它为本机输入点和扩展模块继电器线圈提供24VDC。如果电源要求超出了CPU模块24VDC电源的定额，你可以增加一个外部24VDC电源来供给扩展模块的24VDC。参见电源计算。

    注意：在给CPU进行供电接线时，一定要特别小心分清是哪一种供电方式，如果把220VAC接到24VDC供电的CPU上，或者不小心接到24VDC传感器输出电源上，都会造成CPU的损坏。


CPU数据长度

S7-200 CPU的数据长度是多少？

S7-200 CPU的中央处理芯片数据长度为32位。

从CPU累加器AC0/AC1/AC2/AC3的数据长度也可以看出。


规格－扩展模块

S7-200的扩展模块

除了CPU221外，S7-200的其他CPU型号都可以附加扩展模块，以增加I/O点数、扩展通信能力和一些特殊功能。

S7-200的扩展模块包括：

  • 数字量I/O扩展模块
  • 模拟量I/O模块
  • 通信模块
  • 功能模块

不同类型的模块可以组合搭配，一起做S7-200 CPU的扩展模块。

数字量I/O扩展模块

数字量I/O扩展模块有：

  • EM221：数字量输入扩展模块。包括
    • 8点 x 24VDC
    • 8 x 120/230VAC
    • 16 x 24VDC
  • EM222： 数字量输出扩展模块
    • 4 x 24VDC/5A
    • 4 x 继电器/10A
    • 8 x 24VDC/0.75A
    • 8 x 继电器/2A
    • 8 x 120/230VAC/0.5A
  • EM223：数字量输入/输出混合模块
    • 4 x 24VDC输入；4 x 24VDC/0.75A输出
    • 4 x 24VDC输入；4 x 继电器/2A输出
    • 8 x 24VDC输入；8 x 24VDC/0.75A输出
    • 8 x 24VDC输入；8 x 继电器/2A输出
    • 16 x 24VDC输入；16 x 24VDC/0.75A输出
    • 16 x 24VDC输入；16 x 继电器/2A输出

不同类型的数字量模块可以同时连接到CPU后面，只要注意各自的电源连接就可以了。

数字量I/O接线

模拟量扩展模块

除了CPU224 XP外有两通道输入/一通道输出的简单模拟量I/O组外，其他CPU都需要加模拟量扩展模块才能获得模拟量I/O能力。

  • EM231：4通道电源/电流模拟量输入
  • EM231 RTD：2通道热电阻温度输入模块
  • EM231 TC：4通道热电偶温度输入模块
  • EM235：4通道电压、电流输入/1通道电压、电流输出模块

模拟量模块

通信模块

除CPU本体上的通信口可以支持PPI/MPI和自由口通信之外，S7-200系列使用扩展模块支持更多的通信模式。

这些通信模块有：

  • EM277：PROFIBUS-DP/MPI通信模块。带DB-9插座，可连接到PROFIBUS-DP和MPI网络上。EM277也可以用于连接西门子的HMI产品
  • EM241：模拟音频调制解调器（Modem）模块，带RJ11电话插口。支持自动电话拨号等功能
  • CP243-1：以太网模块，带RJ45接口，可连接到支持TCP/IP标准的以太网中，与西门子的其他CP243模块、CP343/CP443模块，或西门子软件（OPC Server）通信
  • CP243-1 IT：带因特网功能的以太网模块，除CP243-1的功能外，还支持FTP、HTTP、E-mail等IT功能
  • CP243-2：AS-Interface（执行器－传感器接口）主站模块。AS-Interface从站可以连接到端子上。一个完整的系统还需要AS-Interface电源等设备

S7-200支持的通信协议
S7-200的通信选择

功能模块

S7-200目前有一种特殊功能模块：

  • EM253：定位处理模块，支持开环速度和定位控制。一般用于控制步进电机控制器和伺服电机控制器。支持RS422/RS-485差动输出和漏极开路输出。每个模块可以控制一个轴。使用多个模块的情况下也不能进行复杂的插补计算

详情请参考《S7-200系统手册》。

如何查询西门子产品的技术参数

http://support.automation.siemens.com/CN/view/zh/73906943

S7-200 CPU的扩展模块连接数目


扩展模块个数

S7-200 CPU 附加的模块个数

不同型号的CPU所带的扩展模块数目不同。

表1. 扩展模块连接个数

CPU型号 | 模块连接个数
CPU221 | -
CPU222 | 2
CPU224/224 XP | 7
CPU226 | 7

表2. 智能扩展模块连接个数

CPU型号 | 特殊模块最大连接个数
 | EM241 | EM253 | EM277 | CP243-1 | CP243-2 | SIWAREX MS
CPU221 | - | - | - | - | - | -
CPU222 | 2 | 1 | 2 | 1 | 1 | 2
CPU224/224 XP | 7 | 3 | 4 | 1 | 2 | 4
CPU226 | 7 | 5 | 6 | 1 | 2 | 7

模块的连接个数受电源预算的限制。

CP 243-2 模块要占用两个模块的地址。

模块安装

每个S7-200 模块都自带一根带状I/O总线电缆，如果该电缆满足模块之间的安装宽度需求，可直接将该电缆插接在其它模块上的10针插槽内，如下图：

常问问题

如果 CPU 和扩展模块占用的安装长度超过了设备允许的范围，是否可以在导轨间分开安装？

可以。西门子提供一条长度为 0.8 m 的扩展模块总线延长电缆，订货号为 6ES7 290--6AA20--0XA0。一套 S7-200 系统中只能允许加一条总线延长电缆。

EM 277 等模块是否算在CPU能够附加的扩展模块数目内？

所有的智能模块都占用CPU连接的模块数，与普通模块一起计算个数。

CPU是否计算在扩展模块内？

顾名思义，扩展模块指在CPU本体上加挂的模块，而不包括CPU。

智能模块连接到CPU上是否有特殊位置的要求？

所有的S7-200 CPU从22版之后，任何模块都没有特殊的位置要求。


规格－智能模块地址占用

智能模块的地址占用

S7-200系统中除了数字量和模拟量I/O扩展模块占用输入/输出地址外，一些智能模块（特殊功能模块）也需要在地址范围中占用地址。这些数据地址被模块用来进行功能控制，一般不直接连接到外部信号。

表1. 智能模块占用的地址

模块型号 |  | EM277 | EM241 | EM253 | CP243-1/IT | CP243-2
占用地址 | 输入 | - | - | - | - | 1IB+8AIW
 | 输出 | - | 1QB | 1QB | 1QB | 1QB+8AQW

CP243-2（AS-Interface模块）除了使用IB/QB作为状态和控制字节外，AI和AQ用于AS-Interface从站的地址映射。因此 CP 243-2 模块需要占用两个模块位置。


电源需求与计算

S7-200的电源需求与计算

S7-200 CPU模块提供5VDC和24VDC电源：

  • 当有扩展模块时CPU通过I/O总线为其提供5V电源，所有扩展模块的5V电源消耗之和不能超过该CPU提供的电源额定。若不够用不能外接5V电源。
  • 每个CPU都有一个24VDC传感器电源，它为本机输入点和扩展模块输入点及扩展模块继电器线圈提供24VDC。如果电源要求超出了CPU模块的电源定额，你可以增加一个外部24VDC电源来提供给扩展模块。

所谓电源计算，就是用CPU所能提供的电源容量，减去各模块所需要的电源消耗量。

电源计算的例子可参见《S7-200系统手册》。

以下为S7-200系统电源数据简表。详情请参考最新的《S7-200系统手册》或模块说明书。

表1. CPU的供电能力

CPU型号 | 电流供应
 | ＋5VDC | +24VDC
CPU221 | 0 mA | 180mA
CPU222 | 340 mA | 180mA
CPU224/224 XP | 660 mA | 280mA
CPU226/226 XM | 1000 mA | 400mA

表2. CPU上及扩展模块上的数字量输入所消耗的电流

CPU上及扩展模块上的数字量 | 电流需求
 | ＋5VDC | +24VDC
每点输入 | - | 4mA/每输入

如果数字量输入点使用外接24VDC电源，则不必纳入计算。

表3. 数字扩展模块所消耗的电流

数字扩展模块型号 | 电流需求
 | ＋5VDC | +24VDC
EM 221 DI 8 x 24VDC | 30 mA | 4 mA/输入
EM 221 DI 8 x 120/230VAC | 30 mA | -
EM 221 DI 16 x 24VDC | 70 mA | 4 mA/输入
EM 222 DO4 x 24VDC-5A | 50 mA | -
EM 222 DO 4 x Relays-10A | 40 mA | 20mA/输出
EM 222 DO8 x 24VDC | 30 mA | -
EM 222 DO 8 x Relays | 40 mA | 9mA/输出
EM 222 DO 8 x 120/230VAC | 110 mA | -
EM 223 24VDC 4 In/4 Out | 40 mA | 4 mA/输入
EM 223 24VDC 4 In/4 Relays | 40 mA | 4 mA/输入 9mA/输出
EM 223 24VDC 8 In/8 Out | 80 mA | 4 mA/输入
EM 223 24VDC 8 In/8 Relays | 80 mA | 4 mA/输入 9 mA/输出
EM 223 24VDC 16 In/16 Out | 160 mA | 4 mA/输入
EM 223 24VDC 16 In/16 Relays | 150 mA | 4 mA/输入 9mA/输出
EM 223 24VDC 32 In/32 Out | 240 mA | 4 mA/输入
EM 223 24VDC 32 In/32 Relays | 205 mA | 4 mA/输入 9mA/输出

表4. 模拟扩展模块所消耗的电流

模拟扩展模块订货号 | 电流需求
 | ＋5VDC | +24VDC
EM 231 4 Inputs | 20 mA | 60 mA
EM 231 8 Inputs | 20 mA | 60 mA
EM 232 2 Outputs | 20 mA | 70 mA
EM 232 4 Outputs | 20 mA | 60 mA
EM 235 4 Inputs / 1 Output | 30 mA | 60 mA

表5. TC（热电偶）和RTD（热电阻）模块所消耗的电流

热电偶和热电阻模块型号 | 电流需求
 | ＋5VDC | +24VDC
EM 231 TC, 4 Inputs | 87 mA | 60 mA
EM 231 TC, 8 Inputs | 87mA | 60mA
EM231 RTD, 2 Inputs | 87 mA | 60 mA
EM231 RTD, 4 Inputs | 87 mA | 60 mA

表6. 智能模块所消耗的电流

智能模块订货号 | 电流需求
 | ＋5VDC | +24VDC
EM277 | 150 mA | －
 |  | 30 mA；通信端口激活时
 |  | 60 mA；通信端口加90mA/5V负载时
 |  | 180 mA；通信端口加120mA/24V负载时
EM241 | 80 mA | 70 mA
EM253 | 190mA | 不一定，详见技术数据
CP243-1 | 55 mA | 60 mA
CP243-1 IT | 55 mA | 60 mA
CP243-2 | 220 mA | 100 mA

注意：

  • EM277模块本身不需要24VDC电源，这个电源是专供通信端口用的。24VDC电源需求取决于通信端口上的负载大小。
  • CPU上的通信口，可以连接PC/PPI电缆和TD 200并为它们供电，此电源消耗已经不必再纳入计算。


规格－最大I/O扩展能力

最大I/O扩展能力

S7-200的最大I/O能力取决于以下几个因素，这些因素之间互相影响、制约，必须综合考虑：

  • CPU 的输入/输出过程变量映像区大小：
    128 DI/128 DO；16 AI/16 AO(CPU 221/222)；32 AI/32 AO(CPU 224 以上)
  • CPU本体的I/O点数：
    CPU221（6DI/4DO）；CPU222（8DI/6DO）；CPU224/CPU224 XP（14DI/10DO）；CPU226（24DI/16D）
  • CPU带扩展模块的数目
  • CPU的5VDC电源是否满足所有扩展模块的需要
  • CPU所带智能模块对I/O地址的占用

注意：智能模块（如EM277、CP243-1）占用扩展模块的数量。这就意味着如果用了这些模块，则相应的I/O扩展模块的数量就要减少。

详情可参考《S7-200系统手册》、《S7-200产品目录》。

表 1. S7-200 最大 I/O （纯 I/O 模块时）

模块 |  |  | 5 V 电源/mA | DI | DO | AI | AO
CPU 221 |  |  | 不能扩展
 |  | CPU | 340 | 8 | 6 |  |
CPU 222 | Max. DI/DO | 1 x EM 223 32 DI/32 DO 1 x EM 223 8 DI/8 DO DC/DC | - 320 | 40 | 40 |  |
 |  | 1 x EM 223 32 DI/32 DO 1 x EM 223 8 DI/8 DO DC/Relay | - 285 |  |  |  |
 |  | 总计 | > 0 | 48 | 46 |  |
 | Max. AI | CPU | 340 | 8 | 6 |  |
 |  | 2 x EM 235 4 AI/1 AO | - 60 |  |  | 8 | 2
 |  | 总计 | > 0 | 8 | 6 | 8 | 2
 | Max. AO | CPU | 340 | 8 | 6 |  |
 |  | 2 x EM 232 2AO | - 40 |  |  | 0 | 4
 |  | 总计 | > 0 | 8 | 6 | 0 | 4
CPU 224 /224 XP | Max. DI/Relay OUT | CPU | 660 | 14 | 10 |  |
 |  | 3 x EM 223 32 DI/32 DO | - 615 | 96 | 96 |  |
 |  | 1 x EM 223 4 DI/4 DO | - 40 | 4 | 4 |  |
 |  | 总计 | > 0 | 114 | 110 |  |
 | Max. DI/DC OUT | CPU | 660 | 14 | 10 |  |
 |  | 2 x EM 223 32 DI/32 DO | - 480 | 64 | 64 |  |
 |  | 1 x EM 223 16 DI/16 DO | - 150 | 16 | 16 |  |
 |  | 总计 | > 0 | 94 | 90 |  |
CPU 226 | Max. DI/Relay OUT | CPU | 1000 | 24 | 16 |  |
 |  | 3 x EM 223 32 DI/32 DO | - 615 | 96 | 96 |  |
 |  | 1 x EM 223 16 DI/16 DO | - 150 | 16 | 16 |  |
 |  | 总计 | > 0 | 128 | 128 |  |
 | Max. DI/DC OUT | CPU | 1000 | 24 | 16 |  |
 |  | 3 x EM 223 32 DI/32 DO | - 720 | 96 | 96 |  |
 |  | 1 x EM 223 16 DI/16 DO | - 160 | 16 | 16 |  |
 |  | 总计 | > 0 | 128 | 128 |  |
CPU 224 /(CPU 226) | Max. AI | CPU | > 660 | 14 (24) | 10 (16) |  |
 |  | 7 x EM 235 4 AI/1 AO | - 210 |  |  | 281 | 72
 |  | 总计 | > 0 | 14 (24) | 10 (16) | 281 | 72
 | Max. AO | CPU | > 660 | 14 (24) | 10 (16) |  |
 |  | 7 x EM 232 2 AO | - 140 |  |  | 0 | 143
 |  | 总计 | > 0 | 14 (24) | 10 (16) | 0 | 143

1. CPU 224 XP 为 30
2. CPU 224 XP 为 8
3. CPU 224 XP 为 15

常问问题

有些情况下能够为 S7-200 CPU 配备 I/O 总数超过限制 （如128 DI/128 DO）的输入/输出模块，能否在程序里全部使用它们？

不可以。

S7-200是否有输入、输出点可以复用的模块？

S7-200的数字量、模拟量输入/输出点不能复用（即既能当作输入，又能当作输出）。


DI/DO响应速度

数字量输入/输出（DI/DO）响应速度

  • S7-200的数字量（开关量）输入/输出有多快？
  • 数字量输入能接多大频率的脉冲？
  • 数字量输出点能发高速脉冲么？
  • ……

这些问题都是关于S7-200 PLC在处理开关量（数字量）信号时的快速响应能力。只有在控制任务对数字量信号的处理速度要求很高时才需要考虑。

S7-200可以采用两种方式处理数字量信号：

  • 硬件电路
    S7-200在CPU单元上设有硬件电路（芯片等）处理高速数字量I/O，如高速计数器（输入）、高速脉冲输出。这些硬件电路在用户程序的控制下工作，可以达到很高的频率；但点数受到硬件资源的限制
  • 常规处理
    按照PLC工作原理，以常规方式处理DI/DO

S7-200处理DI/DO的限制因素

典型的数字量信号处理包括从输入信号变化，到S7-200识别、进行逻辑运算得到结果并输出，最后输出信号状态实际改变的整个过程。

S7-200 CPU按照以下机制循环工作：

  1. 读取输入点的状态到输入映像区
  2. 执行用户程序，进行逻辑运算，得到输出信号的新状态
  3. 将输出信号写入到输出映像区

只要CPU处于运行状态，上述步骤就周而复始地执行。在第二步中，CPU也执行通信、自检等工作。

上述三个步骤是S7-200 CPU的软件处理过程，可以认为就是程序扫描时间。

实际上，S7-200对数字量的处理速度受到以下几个因素的限制：

  1. 输入硬件延时（从输入信号状态改变的那一刻开始，到CPU刷新输入映像区时能够识别其改变的时间）
  2. CPU的内部处理时间，包括：
    1. 读取输入点的状态到输入映像区
    2. 执行用户程序，进行逻辑运算，得到输出信号的新状态
    3. 将输出信号写入到输出映像区
  3. 输出硬件延时（从输出缓冲区状态改变到输出点真实电平改变的时间）

上述A,B,C三段时间，就是限制PLC处理数字量响应速度的主要因素。

一个实际的系统可能还需要考虑输入、输出器件的延时，如输出点外接的中间继电器动作时间等，不在这里讨论。

输入硬件延时

表1. 输入点硬件延时

输入点类型 | CPU集成输入点（部分） | 扩展模块输入点
 |  | 24VDC | 120/230VAC
输入延时 | 0.2 - 12.8ms（可选） | 4.5ms | 15ms

以上数据都在《S7-200系统手册》中标明，这里只是列表比较。CPU上的部分输入点延时（滤波）时间可以在编程软件Micro/WIN的“系统块”中设置，其缺省的滤波时间是6.4ms。

如果把容易受到干扰的信号接到CPU上可改变滤波时间的DI点上，调整滤波时间可能改善信号检测的质量。

支持高速计数器功能的输入点在相应功能开通时不受此滤波时间约束。滤波设置对输入映像区的刷新、开关量输入中断、脉冲捕捉功能同样有效。

输出硬件延时

表2. CPU输出硬件延时

输出点类型 |  | 24VDC晶体管 | 24VDC（CPU224 XP [image] ）晶体管 | 继电器
输出延时 | OFF - ON | 2μs（Q0.0, Q0.1）, 15μs（其他） | 0.5μs （Q0.0, Q0.1）, 15μs（其他） | -
 | ON - OFF | 10μs（Q0.0, Q0.1）, 130μs（其他） | 1.5μs（0.0, Q0.1）, 130μs（其他） | -
 | 开关 | - | - | 10ms

有些输出点要比其他点更快些，是因为它们可以用于高速输出功能，在硬件上有特殊设计。没有专门使用硬件高速输出功能时，它们只是和普通点一样处理

继电器输出开关频率为1Hz。

表3. 扩展模块输出硬件延时

输出点类型 |  | 24VDC |  | 继电器 |  | 120/230VAC
 |  | 0.75A | 5A | 2A | 10A
输出延时 | OFF - ON | 50μs | 500μs | - | - | 0.2ms + 1/2AC周期
 | ON - OFF | 200μs
 | 开关 | - | - | 10ms | 15ms | -
最大开关频率 |  | - |  | 1Hz |  | 10Hz

上述数据来自《S7-200系统手册》。

S7-200程序扫描时间

程序扫描时间与用户程序的大小成正比。

《S7-200系统手册》中有每个指令所需执行时间的数据。实际上很难事先预先精确计算出程序扫描时间，特别是还没有开始编程序时。

可以看出，常规的PLC处理模式不适合时间响应要求高的数字量信号。可能需要根据具体任务采用一些特别的方法。

S7-200处理快速响应信号的对策

可以单独或组合使用一些S7-200 CPU的高级功能：

  • 使用CPU内置的高速计数器和高速脉冲发生器处理序列脉冲信号
  • 使用部分CPU数字量输入点的硬件中断功能，在中断服务程序中处理；进入中断的延时可以忽略
  • S7-200拥有“直接读输入”和“直接写输出”指令，可以越过程序扫描周期的时间限制
  • 使用部分CPU数字量输入点的“脉冲捕捉”功能捕捉短暂的脉冲

S7-200系统中最小周期的定时任务为1ms。

所有实现快速信号处理的措施，都要考虑所有限制因素的影响。例如，为一个需要毫秒级响应速度的信号选择 500μs 输出延时的硬件，显然是不合理的。

相关问题

如何知道 S7-200 程序的大小和扫描时间？

参见 Micro/WIN 常问问题。


CPU224 XP 高速I/O

S7-200 CPU支持6路高速数字量输入（CPU224/226）和两路高速数字量输出（用于PTO/PWM）。

新产品CPU224 XP高速输入中的两路支持更加高的速度。用作单相脉冲输入时，可以达到200KHz；用作双相90°正交脉冲输入时，速度可达100KHz。

CPU224 XP的两路高速数字量输出速率可以达到100KHz。

图1. CPU224 XP数字量接线

图中：

  1. 高速输出点Q0.0和Q0.1与Q0.2 - Q0.4成组支持5 - 24VDC电压输出
  2. 特高速输入点I0.3/I0.4/I0.5支持5 - 24VDC电压的源型或漏型输入；同组其他输入点电压可以仍然是24VDC，单要求两者的电源的公共端在1M处连接

CPU224 XP的高速数字量输入

除了其他高速输入端子外，CPU224 XP特有的高速输入端子为I0.3、I0.4、I0.5。

具体位置如图1所示。

这些特高速输入端可用作高速计数器输入端，如表1所示：

表1. CPU224 XP高速输入端子与计数器分配

模式 | 描述 | 输入点
 | HSCO | I0.0 | I0.1 | I0.2 |
 | HSC1 | I0.6 | I0.7 | I1.0 | I1.1
 | HSC2 | I1.2 | I1.3 | I1.4 | I1.5
 | HSC3 | I0.1 |  |  |
 | HSC4 | I0.3 | I0.4 | I0.5 |
 | HSC5 | I0.4 |  |  |
0 | 带有内部方向控制的单相计数器 | 时钟 |  |  |
1 |  | 时钟 |  | 复位 |
2 |  | 时钟 |  | 复位 | 启动
3 | 带有外部方向控制的单相计数器 | 时钟 | 方向 |  |
4 |  | 时钟 | 方向 | 复位 |
5 |  | 时钟 | 方向 | 复位 | 启动
6 | 带有增减计数时钟的双相计数器 | 增时钟 | 减时钟 |  |
7 |  | 增时钟 | 减时钟 | 复位 |
8 |  | 增时钟 | 减时钟 | 复位 | 启动
9 | A/B相正交计数器 | 时钟A | 时钟B |  |
10 |  | 时钟A | 时钟B | 复位 |
11 |  | 时钟A | 时钟B | 复位 | 启动

根据上表可以看出：

  • 要达到单相200KHz高速脉冲输入，可以使用HSC4和HSC5，分别输入到I0.3、I0.4
  • 要实现双相90°正交高速脉冲输入，可以使用HSC4；此时HSC5因为I0.4被HSC4占用而不能使用
  • HSC4可以工作在模式0、1、3、4、6、7、9、10
  • HSC5可以工作在模式0

支持特高速输入的I0.3、I0.4、I0.5可以接受5 - 24VDC信号；它们既可以用于高速脉冲输入，也可以用于普通输入信号。它们与本组输入点（I0.0 - I0.7）一起，支持源型和漏型输入。

CPU224 XP高速脉冲输出

CPU224 XP的高速脉冲输出Q0.0和Q0.1支持高达100KHz的频率。

Q0.0和Q0.1支持5 - 24VDC输出。但是它们必须和Q0.2 - Q0.4一起成组输出相同的电压。

高速输出只能用在CPU224 XP DC/DC/DC型号

常问问题

CPU 224 XP 的高速计数器模式 12，是否可以计数 30 KHz 以上的脉冲？

CPU 224 XP 支持最多 100 KHz 的高速脉冲输出。S7-200 系列 CPU 只有高速计数器 HSC0, HSC3 能够被设置为模式 12，使用的输入端子为I0.0, I0.1，而不是特高速输入端子：I0.3、I0.4、I0.5。非特高速脉冲信号输入端由于硬件电路的限制（如光电耦合等）只能支持最高 30 KHz 的高速脉冲输入。

用户使用高速计数器模式 12 时不需要任何外部连线，Q0.0(Q0.1) 与 I0.0(I0.1) 通过集成电路内部关联，越过了外部信号处理电路，因此 HSC0(HSC1) 可以计 100KHz 或者更高频率的脉冲。用户在使用向导配置 S7-200 内部 PTO/PWM 操作时，勾选“使用高速计数器HSCx（模式12）自动计数线性 PTO 生成的脉冲”即可。

CPU224 XP的高速输入（I0.3/4/5）是5VDC信号，其他输入点是否可以接24VDC信号？

可以。只需将两种信号供电电源的公共端都连接到1M端子。这两种信号必须同时为漏型或源型输入信号。

CPU224 XP的高速输出点Q0.0和Q0.1接5V电源，其他点如Q0.2/3/4是否可以接24V电压？

不可以。必须成组连接相同的电压等级。


模拟量－CPU224 XP

CPU 224 XP的集成模拟量I/O

新产品CPU 224 XP在CPU上集成了两个模拟量输入端口和一个模拟量输出端口。模拟量I/O有自己的一组端子，如果不用，端子可以移走。

表1. CPU 224 XP本体模拟量I/O规格
 | 电压信号 | 电流信号
模拟量输入 x 2 | ±10 V | －
模拟量输出 x 1 | 0 - 10 V | 0 - 20 mA

CPU 224 XP 的模拟量输入/输出通道的精度为 12位。具体参数请看《S7-200系统手册》的附录－CPU224 XP模拟量I/O参数表。 CPU 224 XP上的模拟量输入转换速度比模拟量扩展模块慢，要求高的场合请使用模拟量扩展模块。

CPU 224 XP 集成模拟量I/O接线

CPU 224 XP本体集成的模拟量I/O接线图如下：

图1. 接线图

图中：

  1. 此处表示A+和B+都可以接±10V信号
  2. 电流型负载接在I和M端子之间
  3. 电压型负载接在V和M端子之间

常问问题

CPU 224 XP本体上有没有电流信号模拟量输入？

没有。

CPU 224 XP本体上的模拟量输入为何响应速度是250ms，不同于模拟量扩展模块的数据？

是这样的。CPU 224 XP本体上的模拟量I/O芯片与模拟量模块所用的不同，应用的转换原理不同，因此精度和速度不一样。

CPU 224 XP的本体模拟量I/O如何寻址？

CPU 224 XP本体上的模拟量输入通道的地址为AIW0和AIW2；模拟量输出通道的地址为AQW0。

CPU 224 XP后面挂的模拟量模块的地址如何分配？

S7-200的模拟量I/O地址总是以2个通道/模块的规律增加。所以CPU 224 XP后面的第一个模拟量输入通道的地址为AIW4；第一个输出通道的地址为AQW4，AQW2不能用。

CPU 224 XP上的模拟量输入是否需要在“系统块”中设置滤波？

由于CPU 224 XP本体上的模拟量转换芯片的原理与扩展模拟量模块不同，不需要选择滤波。

怎样使用 S7-224 XP 的模拟量输入通道接收电流信号？

S7-224 XP 的两路模拟量输入通道被出厂设置为电压信号(0－10V)输入。为了能够输入电流信号，必须在 A+ 与 M 端 (或 B+ 与 M 端) 之间并入一个500 欧姆的电阻。

与传感器以及电压源的两线制连接方式如图2 所示：

图2

与传感器以及电压源的 3 线制连接方式如图 3 所示：

图3

与传感器以及电压源的 4 线制连接方式如图 4 所示：

图4

与电压输出的变送器及电流源的 4 线制连接方式如图5所示：

图5

注意：
在所有的连接方式中都必须确保外接电流源具有短路保护以防损坏。

以上所示的各种连接方式同样适用于LOGO！基本型 (LOGO! 24?和 LOGO! 12/24) 的模拟量输入。

因为没有充分隔离，外接电阻也可成为干扰源。
为了得到尽量精确的测量结果，推荐使用公差尽可能小的电阻。

应确保当在500欧电阻两端施加最大 28.8V 的电压时，输出功率为 1.66W。 市面上流通的电阻的功率大都是 0.25W到 0.5W。


S7-200的通讯口

S7-200 CPU的通信口（Port0, Port1）

型号不同的S7-200 CPU具有一到两个RS-485通信口。CPU221、CPU222、CPU224有一个通信口；CPU224 XP [image] 、CPU226有两个通信口。

S7-200 CPU上的通信口各自独立，每个通信口都有自己的网络地址、通信速率等参数设置。通信口的参数在编程软件Micro/WIN的“系统块”中查看、设置，新的设置在系统块下载到CPU中后起作用。

S7-200 CPU上的通信口支持的通信协议有：

  • PPI协议：西门子专为S7-200开发的通信协议
  • MPI协议：不完全支持，只能作从站
  • 自由口模式：由用户自定义的通信协议，用于与其他串行通信设备通信（如串行打印机等）。
    S7-200编程软件Micro/WIN提供了通过自由口模式实现的通信功能：
    • USS指令库：用于S7-200与西门子变频器（MM4系列、SINAMICS G110和老的MM3系列）
    • Modbus RTU指令库：用于与支持Modbus RTU主站协议的设备通信

S7-200 CPU上的两个通信口基本一样，没有什么特殊的区别。它们可以各自在不同的模式、通信速率下工作；它们的口地址甚至也可相同。

分别连接到CPU上两个通信口上的设备，不属于同一个网络。S7-200 CPU不能充当网桥的作用。

CPU通信口的连接

S7-200 CPU上的通信口可用于连接：

  • 安装了编程软件Micro/WIN的编程电脑
  • 其他S7-200 CPU的通信口
  • S7- 300/400的MPI通信口
  • 西门子的HMI设备（如TD 200、TP170micro [image] 、TP170、TP270等）
  • OPC Server（PC Access V1.0 [image] ）
  • 其他串行通信设备
  • 第三方HMI

常问问题

S7-200 CPU上的通信口是否可以扩展？

不能扩展出与CPU通信口功能完全一样的通信口。

在CPU上的通信口不够的情况下，可以考虑：

  • 购买具有更多通信口的CPU
  • 考察连接设备的种类，如果其中有西门子的人机界面（HMI，操作面板），可以考虑增加EM277模块，把面板连接到EM277上

S7-200 CPU上的通信口，通信距离究竟有多远？

《S7-200系统手册》上给出的数据是一个网段50m，这是在符合规范的网络条件下，能够保证的通信距离。凡超出50m的距离，应当加中继器。加一个中继器可以延长通信网络50米。如果加一对中继器，并且它们之间没有S7-200 CPU站存在（可以有EM277），则中继器之间的距离可以达到1000米。符合上述要求就可以做到非常可靠的通信。

实际上，有用户做到了超过50m距离而不加中继器的通信。西门子不能保证这样的通信一定成功。

用户在设计网络时，应当考虑到以下几个因素：

  • S7-200 CPU上的通信口在电气上是RS-485口，RS-485支持的距离是1000m
  • S7-200 CPU上的通信口是非隔离的，需要注意保证网络上的各通信口电位相等
  • 信号传输条件（网络硬件如电缆、连接器，以及外部的电磁环境）对通信成功与否的影响很大

PC/PPI电缆是否可以延长？

参见PC/PPI电缆常问问题。


系统块－扩展程序内存/禁用运行模式编程

扩展程序存储区——禁用运行模式编程功能

23版的CPU与以前版本的CPU相比，程序、数据存储区有了较大扩展。

23版CPU的新功能（运行时编程）需要占用一部分程序存储空间。如果要利用全部的程序存储区，对于特定的一些CPU型号，需要禁止“运行模式编程”功能。

图1. 增加程序存储区

在上图中：

  1. 选中此选择框可以禁止“运行模式编程”并获得更多的程序存储区
  2. 使用或禁用“运行模式编程”的程序存储区大小区别

运行模式编程

在 RUN（运行）模式下执行程序编辑功能允许您不必转换至 STOP（停止）模式即可对程序（仅可对程序块进行修改）作出更改并将改动下载至 PLC。

不必停机即可对当前程序作出较小的改动。例如：更改参数值。

可以利用此一功能更快地调试程序。例如：对常开或常闭开关进行取反逻辑操作。

向真实的控制过程（与调试程序时可能使用的模拟控制过程不同）下载改动时，下载之前务必要仔细考虑可能对机器和机器操作员造成的各种可能的安全问题。

在运行模式下编辑的前提条件

1、硬件需要支持此功能：S7-200 CPU Rel. 2.0及以上型号支持RUN模式下编辑的功能。通过图2. 读取 PLC类型

图2. 读取 PLC类型

2、系统块中增加存储区，没有勾选禁止“运行模式编程”功能
3、在运行 STEP 7-Micro/WIN 的个人计算机与 PLC 之间建立通信
4、PLC 必须处于运行模式，才可以从 CPU 中上传程序
5、在线运行模式编程，将修改后的程序下载之前，必须要保证修改后的程序编译无错误，否则下载失败

警告
当在RUN模式下向S7--200下载修改过的程序时，修改的程序将立即影响过程操作。在RUN模式下修改程序会导致不可预见的系统操作，可能会导致严重的人身伤害和财产损失。
只有了解RUN模式下修改程序对系统运行会造成何种影响的被授权人员，才可以执行在RUN模式下编辑程序。

在运行模式下编辑的步骤

1、选择调试> RUN模式下编辑程序菜单命令。

图3.
2、如果程序中有用 STEP 7-Micro/WIN 编写的尚未保存的材料，会提示您将程序保存至编程设备的硬盘中。您可以使用与 CPU 中的项目名称相同的名称，或者改变名称：例如，将名称更改为 BACKUP.MWP。您可以选择是否将程序编辑保存在编程设备的硬盘中，也可以选择保存时是否采用与项目较早版本相同的名称。采用相同的名称会使较早版本被覆盖。

图4.

3、STEP 7--Micro/WIN对于您将在RUN模式下编辑程序提出警告，提示您是继续下一步还是取消操作。如果您选择继续，STEP 7--Micro/WIN会在S7--200中上传程序。现在您可以在RUN
模式下编辑程序了。编辑中没有严格的限定

图5.
当程序编辑器可以接受更改时，鼠标会变为 CPU 光标 [image] 。 完成所需的改动后，您必须将改动下载，才会在 CPU 中生效。

可能发生的问题

为了帮助您决定是在 RUN（运行）模式还是在 STOP（停止）模式向 PLC 下载程序编辑，请考虑下列有关 RUN（运行）模式编辑的因素：

1、如果在 RUN（运行）模式编辑中删除输出的控制逻辑，输出保持其最后状态，直至下一次上电周期或转换为 STOP（停止）模式。
2、如果在 RUN（运行）模式编辑中删除正在运行的 HSC 或 PTO/PWM 功能，这些功能继续运行，直至下一次上电周期或转换为 STOP（停止）模式。
3、如果在 RUN（运行）模式编辑中删除 ATCH 指令但中断程序本身尚未删除，则中断程序继续执行，直至下一次上电周期或转换为 STOP（停止）模式。与此相似，如果 DTCH指令被删除，则中断程序不会停止执行，直至下一次上电周期或转换为 STOP（停止）模式。
4、如果在 RUN（运行）模式编辑中增加 ATCH 指令，并以遇到首次扫描标志为条件，这些事件不会被激活，直到下一次上电周期或出现 STOP-to-RUN（停止至运行）模式转换。
5、如果在 RUN（运行）模式编辑中删除 ENI 指令，中断程序继续操作，直至下一次上电周期或出现 RUN-to-STOP（运行至停止）模式转换。
6、如果在 RUN（运行）模式编辑中修改接收指令的表格地址，而且接收指令在从旧程序向新程序转换的过程中被激活，则接收的数据被写入旧表地址。只有在（向旧地址的）当前接收请求完成后才开始使用新地址，但因为您已经对程序进行了编辑，程序将在新地址中寻找数据（但却不存在）。NETR 和 NETW 指令功能与此相似。
7、以首次扫描标志为条件的逻辑在因为上电周期或从 STOP-to-RUN（运行至停止）模式转换而进入 RUN（运行）模式后才被执行，因为首次扫描标志不受RUN（运行）模式编辑的影响。

23版CPU规格表


功能－实时时钟及其精度

S7-200的实时时钟

S7-200的硬件实时时钟可以提供年、月、时、分、秒的日期/时间数据。

CPU221、CPU222没有内置的实时时钟，需要外插“时钟/电池卡”才能获得此功能。CPU224、CPU226和CPU226 XM都有内置的实时时钟。

S7-200的时钟精度典型值是2分钟/月（25°C），最大误差7分钟/月（0 - 55°C）。

为了提高运算效率，应当避免每个程序周期都读取实时时钟。实际上可读取的最小时间单位是1秒，可每秒读取一次（使用SM0.5上升沿触发读取指令）。

使用程序读取的实时时钟数据为BCD格式，可在状态图中使用十六进制格式查看。

CPU靠内置超级电容（＋外插电池卡）在失去供电后为实时时钟提供电源缓冲；缓冲电源放电完毕后，再次上电后时钟将停止在缺省值，并不开始走动。

要设置日期、时间值，使之开始走动，可以：

  • 用编程软件（Micro/WIN）的菜单命令PLC > Time of Day Clock...，通过与CPU的在线连接设置，完成后时钟开始走动
  • 编用户程序使用Set_RTC（设置时钟）指令设置

Micro/WIN可以通过任何编程连接实现实时时钟的设置。

用 Micro/WIN 设置时钟

通过编程软件 Micro/WIN 设置 CPU 的时钟，必须先建立编程通信连接。

在 Micro/WIN 菜单中选择“PLC > 实时时钟”命令，打开“PLC 时钟操作”对话框：

图 1. PLC 实时时钟设置界面

图中：

  1. 要设置时钟的 CPU 网络地址，取决于在“通信”界面中的选择
  2. 设置日期：选择需要修改的数据字段，直接输入数字，或者使用输入框右侧的上下按钮调整
  3. 设置时间：选择需要修改的数据字段，直接输入数字，或者使用输入框右侧的上下按钮调整
  4. 读取 PC 时钟：按此按钮可以读取安装 Micro/WIN 的 PC 机的本机时间
  5. 读取 PLC 时钟：按此按钮读取 PLC 内部的实时时钟数据
  6. 根据需要选择夏时制调整选项
  7. 按“设置”按钮，将上面的时钟日期数据写入 PLC

时钟读写指令缓冲区格式

Read_RTC（读时钟）和Set_RTC（设置时钟）指令靠数据缓冲区在用户程序与硬件芯片间交换数据，它们的缓冲区格式相同。

表1. 时钟缓冲区

地址偏移 | T | T+1 | T+2 | T+3 | T+4 | T+5 | T+6 | T+7
数据内容 | 年 | 月 | 日 | 小时 | 分钟 | 秒 | 0 | 星期
数值范围 BCD （16进制） | 00-99 | 01-12 | 01-31 | 00-23 | 00-59 | 00-59 | 0 | 0-7*

* 1 = 星期日，7 = 星期六，0 = 表示禁止计星期

T 就是缓冲区的起始字节地址，可以由用户自由设置（在CPU允许的V存储区范围内）。如果设置T为VB100，那么读取时钟后，“年”的信息就会保存在VB100中，“月”保存在VB101中。

常问问题

实时时钟在 CPU 停电一段时间后停止，如何在停电较长时间时保证实时时钟正常走动？

在 CPU 停电时，实时时钟的走动靠 CPU 的内置超级电容供电。如果停电时间较长，只能在 CPU 上插入电池卡以保持时钟。

电池卡

写时钟指令（TODW）为何不能正常改写时钟内容？

  1. 写时钟指令需要严格按照8个字节的时钟缓冲区格式，设置相应的数据单元，任何不合格的数据都可能造成不能写入的现象。注意数据的格式必须是BCD格式，可以说是将10进制数换成16进制表示，如16#59（59H）就是59（秒/分等）。

    执行写时钟指令要保证缓冲区所有字节都包含合法数据；仅修改某些数据时，其他字节不能包含非法数值，否则会发生错误。

  2. 写时钟指令必须使用一次性的脉冲（沿）触发条件，不能持续激活写时钟指令。

读写的时钟数据如何在十进制（整数）和BCD数据之间转换？

要计算时间需要将BCD格式的时钟数据与十进制的数据之间的转换，使用相应的转换指令就可以实现。

可参考 Clock_Integer 库指令及其使用。

TP170、TP170 micro、K-TP 178 micro 与 S7-200 相连接如何做“时钟同步”？

TP170默认的时钟格式与S7-200时钟指令所读取的时间日期格式有所区别，读出的时钟需要改变格式才能与TP170等做时钟同步。在TP170的配置软件ProTool的在线帮助中有相关的介绍。

HMI 人机操作界面与 S7-200 的时钟同步

参考例程

S7-200 时间设置与读取

本例程需要 Micro/WIN V3.2 SP4 以上版本打开。

注意：此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

Clock_Integer 库指令及其使用


S7-200温度范围

S7-200的工作温度

S7-200的工作环境要求为：

  • 0°C－55°C，水平安装
  • 0°C－45°C，垂直安装
  • 相对湿度95%，不结露

宽温型 S7-200（SIPLUS S7-200）

西门子还提供S7-200的宽温度范围产品（SIPLUS S7-200）：

  • 工作温度范围：-25 °C ... +70 °C
  • 相对湿度：55°C时98%，70°C时45%
  • 其他参数与普通S7-200产品相同

S7-200的宽温型产品，每种都有其单独的订货号，可以到SIPLUS产品主页查询。如果没有找到，则说明目前没有对应的SIPLUS产品。

文本和图形显示面板没有宽温型产品。

国内没有现货，如需要请和当地西门子办事处或经销商联系。

详情请参看西门子 ProDIS 网站页面，或 SIPLUS 产品主页。

SIPLUS 产品主页：http://www.siemens.com/siplus


数字量接线

S7-200数字量接线

数字量输入接线

图1. 漏型输入接法
图2. 源型输入接法
图3. 110/220V交流输入接法

对于大多数输入来讲，都是24VDC输入，因为S7-200的数字量输入点内部为双向二级管，可以接成漏型（图1）或源型（图2），只要每一组接成一样就行。

只有6ES7221-1EF22-0XA0这一种型号可以接成交流输入（图3）

对于数字量输入电路来说，关键是构成电流回路。输入点可以分组接不同的电源，这些电源之间没有联系也可以。

数字量输出接线

图4. 源型输出
图5. 继电器输出
图6. 可控硅输出
  • 晶体管输出只能接成源型输出（图4），不能接成漏型，即输出为24V。
  • 继电器输出是一组共用一个公共端的干节点，可以接交流或直流，电压等级最高到220V。例：可以接24V/110V/220V交直流信号。但要保证一组输出接同样的电压（一组共用一个公共端，如1L、2L）。对于弱小信号，如小于 5V 的信号，需要自己验证其输出的可靠性。
    继电器输出点接直流电源时，公共端接正或负都可以。
  • 只有6ES7222-1EF22-0XA0为可控硅输出（图6），其中L端即可以接成110V也可以接成220V。

对于数字量输出电路来说，关键是构成电流回路。输出点可以分组接不同的电源，这些电源之间没有联系也可以。

常问问题

S7-200的高速输入、输出端子如何接线？

S7-200 CPU上的高速输入、输出端子，其接线与普通数字量I/O相同。但高速脉冲输出必须使用直流晶体管输出型的CPU（即DC/DC/DC型）。

我的NPN/PNP输出的旋转编码器（和其他传感器），能否接到S7-200 CPU上？

都可以。S7-200 CPU和扩展模块上的数字量输入可以连接源型或漏型的传感器输出，连接时只要相应地改变公共端子的接法（是电源L＋连接到输入公共端、还是电源的M连接到公共端）。

S7-200能否使用两线制的数字量（开关量）传感器？

可以，但必须保证传感器的静态工作电流（漏电流）小于1mA。西门子有相关的产品，如用于PLC的接近开关（BERO）等。详情请联系西门子产品的经销商。

S7-200是否有输入、输出点可以复用的模块？

S7-200的数字量、模拟量输入/输出点不能复用（即既能当作输入，又能当作输出）。


模拟量扩展模块

S7-200 CPU要附加模拟量扩展模块才能实现模拟量输入/输出的功能。

普通模拟量模块有：

  • EM231：4通道/8通道电流/电压输入模块；
  • EM232：2通道/4通道电流/电压输出模块；
  • EM235：4通道电流/电压输入，1通道电流/电压输出。

温度测量型模块有：

  • EM231 TC：4通道/8通道热电偶输入模块；
  • EM231 RTD：2通道/4通道热电阻输入模块。

有一款新产品CPU 224 XP在CPU本体上集成了简单的模拟量I/O通道，性能不如模拟量模块。

参见CPU 224 XP CPU本体模拟量I/O


模拟量模块接线

将模拟量传感器信号连接到S7-200 模拟量输入模块（EM231，EM235）

模拟量输入模块可以通过DIP拨码开关设置为不同的测量方法。开关的设置应用于整个模块，一个模块只能设置为一种测量范围。(注:开关设置只有在重新上电后才能生效)

DIP拨码开关的具体设置请参照《S7-200系统手册》。

输入阻抗与连接有关：电压测量时，输入是高阻抗为10 MOhm ；电流测量时，需要将Rx 和 x 短接，阻抗降到250 Ohm 。

下列各图是各种传感器连接到S7-200 模拟量输入模块的示例：

图1. 四线制－外供电－电流型信号接线

图 2. 二线制－电流测量接线

上图中的L+和M属于为模拟量模块供电的 CPU 传感器电源。如果使用其他外接电源，只要用相应电源的输出端取代上图中的L+和M，而且要使其 M 和为模块供电的 M 连接起来，如图 3。

图 3. 三线制电流信号测量接线

注：图 3 中如果传感器电源不是来源于 S7-200 CPU 的 24V DC 传感器电源输出， 则建议将 A- 与传感器电源 M 短接。

图 4. 四线制电压信号测量

图 5. 三线制电压信号测量

一个模拟量输入模块的不同通道，可以同时分别连接两线制信号、三线制信号和四线制信号。

注：图 5 中如果传感器电源不是来源于 S7-200 CPU 的 24V DC 传感器电源输出， 则建议将 A- 与传感器电源 M 短接。

ProDIS网站FAQ14955836


模拟量模块设置

应用模拟量模块时，需要根据输入信号的规格设置右下角的DIP开关（Configuration开关）。DIP开关只对输入信号有效，并且对所有的输入通道都是相同的。

EM231、EM235带模拟量输入通道的模块，还分别有电位器用于对输入信号进行校正。EM231和EM235上的Gain（增益）电位器用于调整输入信号和转换数值的放大关系；EM235上的Offset（偏置）用于对输入信号调零。如果没有精确的信号源，请不要调整。详细调整方法请参照《S7-200系统手册》。

注意：

Gain（增益）和Offset（偏置）电位器不能用于调整0 - 20mA和4 - 20mA输入转换！

S7-200模拟量模块没有0 - 20mA与4 - 20mA电流型输入的选择开关，0/4 - 20mA模拟量信号的DIP开关设置一样，但相应的变换必须用程序实现。

DIP开关设置

表1. EM231 4通道

单极性 |  |  | 满量程输入 | 分辨率
SW1 | SW2 | SW3
ON | OFF | ON | 0 - 10V | 2.5mV
 | ON | OFF | 0 - 5V | 1.25mV
 |  |  | 0 - 20mA | 5μA
双极性 |  |  | 满量程输入 | 分辨率
SW1 | SW2 | SW3
OFF | OFF | ON | ±5V | 2.5mV
 | ON | OFF | ±2.5V | 1.25mV

表2. EM 231 8 通道模拟量模块输入配置开关表

单极性 |  |  |  |  | 满量程输入 | 分辨率
sw1 | sw2 | sw3 | sw4 | sw5
OFF | OFF | ON | OFF | ON | 0至10V | 2.5mV
OFF | OFF | ON | ON | OFF | 0至5V | 1.25mV
X | X | ON | ON | OFF | X可选择第6 、7通道： 0到20mA | 5uA
双极性 |  |  |  |  | 满量程输入 | 分辨率
sw1 | sw2 | sw3 | sw4 | sw5
OFF | OFF | OFF | OFF | ON | ±5V | 2.5mV
OFF | OFF | OFF | ON | OFF | ±2.5V | 1.25mV

EM 231 8 通道模拟量模块使用开关 3， 4，5 来选择模拟量输入范围，使用开关 1，2 来选择电流输入模式（只有通道 6 和 7 可以用作电流输入）。并且当最后两个通道使用电流信号时，前6个通道的电压测量范围必须是0-5V，而不能使用0-10V的信号。所以，当您需要接入8路电流信号时，只能使用两个EM231的4通道的模块。

8输入的EM231模块只有第6、7两通道可以用做电流输入，使用拨码开关1、2对其进行设置：当开关1为“ON”时，通道6用做电流输入；开关2为“ON”时，通道7用做电流输入。反之，当1、2开关为“OFF”时，6、7通道用做电压输入。

表3. EM235

单极性 |  |  |  |  |  | 满量程输入 | 分辨率
SW1 | SW2 | SW3 | SW4 | SW5 | SW6
ON | OFF | OFF | ON | OFF | ON | 0 - 50 mV | 12.5μV
OFF | ON | OFF | ON | OFF | ON | 0 - 100 mV | 25μV
ON | OFF | OFF | OFF | ON | ON | 0 - 500 mV | 125μV
OFF | ON | OFF | OFF | ON | ON | 0 - 1 V | 250μV
ON | OFF | OFF | OFF | OFF | ON | 0 - 5 V | 1.25mV
 |  |  |  |  |  | 0 - 20 mA | 5μA
OFF | ON | OFF | OFF | OFF | ON | 0 - 10 V | 2.5mV
双极性 |  |  |  |  |  | 满量程输入 | 分辨率
SW1 | SW2 | SW3 | SW4 | SW5 | SW6
ON | OFF | OFF | ON | OFF | OFF | ±25 mV | 12.5μV
OFF | ON | OFF | ON | OFF | OFF | ±50 mV | 25μV
OFF | OFF | ON | ON | OFF | OFF | ±100 mV | 50μV
ON | OFF | OFF | OFF | ON | OFF | ±250 mV | 125μV
OFF | ON | OFF | OFF | ON | OFF | ±500 mV | 250μV
OFF | OFF | ON | OFF | ON | OFF | ±1 V | 500μV
ON | OFF | OFF | OFF | OFF | OFF | ±2.5 V | 1.25mV
OFF | ON | OFF | OFF | OFF | OFF | ±5 V | 2.5 mV
OFF | OFF | ON | OFF | OFF | OFF | ±10 V | 5 mV

表4. EM231 RTD 2AI DIP开关设置

RTD Type and Alpha¹ | SW1 | SW2 | SW3 | SW4 | SW5 | RTD Type and Alpha¹ | SW1 | SW2 | SW3 | SW4 | SW5
100Ω Pt 0.003850 (Default) | 0 | 0 | 0 | 0 | 0 | 100Ω Pt 0.003902 | 1 | 0 | 0 | 0 | 0
200Ω Pt 0.003850 | 0 | 0 | 0 | 0 | 1 | 200Ω Pt 0.003902 | 1 | 0 | 0 | 0 | 1
500Ω Pt 0.003850 | 0 | 0 | 0 | 1 | 0 | 500Ω Pt 0.003902 | 1 | 0 | 0 | 1 | 0
1000Ω Pt 0.003850 | 0 | 0 | 0 | 1 | 1 | 1000Ω Pt 0.003902 | 1 | 0 | 0 | 1 | 1
100Ω Pt 0.003920 | 0 | 0 | 1 | 0 | 0 | SPARE | 1 | 0 | 1 | 0 | 0
200Ω Pt 0.003920 | 0 | 0 | 1 | 0 | 1 | 100Ω Ni 0.00672 | 1 | 0 | 1 | 0 | 1
500Ω Pt 0.003920 | 0 | 0 | 1 | 1 | 0 | 120Ω Ni 0.00672 | 1 | 0 | 1 | 1 | 0
1000Ω Pt 0.003920 | 0 | 0 | 1 | 1 | 1 | 1000Ω Ni 0.00672 | 1 | 0 | 1 | 1 | 1
100Ω Pt 0.00385055 | 0 | 1 | 0 | 0 | 0 | 100Ω Ni 0.006178 | 1 | 1 | 0 | 0 | 0
200Ω Pt 0.00385055 | 0 | 1 | 0 | 0 | 1 | 120Ω Ni 0.006178 | 1 | 1 | 0 | 0 | 1
500Ω Pt 0.00385055 | 0 | 1 | 0 | 1 | 0 | 1000Ω Ni 0.006178 | 1 | 1 | 0 | 1 | 0
1000Ω Pt 0.00385055 | 0 | 1 | 0 | 1 | 1 | 10000Ω Pt 0.003850 | 1 | 1 | 0 | 1 | 1
100Ω Pt 0.003916 | 0 | 1 | 1 | 0 | 0 | 10Ω Cu 0.004270 | 1 | 1 | 1 | 0 | 0
200Ω Pt 0.003916 | 0 | 1 | 1 | 0 | 1 | 150Ω FS Resistance | 1 | 1 | 1 | 0 | 1
500Ω Pt 0.003916 | 0 | 1 | 1 | 1 | 0 | 300Ω FS Resistance | 1 | 1 | 1 | 1 | 0
1000Ω Pt 0.003916 | 0 | 1 | 1 | 1 | 1 | 600Ω FS Resistance | 1 | 1 | 1 | 1 | 1
开关6 (仅2通道模块) | 断线检测/ 超出范围 | 设置 | 描述
 | 正向标定 （+3276.7度） | 0 | 指示断线或超出范围的正极
 | 负向标定 (--3276.8度) | 1 | 指示断线或超出范围的负极
开关7 | 温度单位 | 设置 | 描述
 | 摄氏度（°C） | 0 | RTD模块可报告摄氏温度或华氏温度，摄氏温 度与华氏温度的转换在内部进行。
 | 华氏温度（°F） | 1 |
开关8 | 接线方式 | 设置 | 描述
 | 3线 | 0 | RTD模块与传感器的接线有3种方式。精度最高的是4线连接。2线连接精度最低，推荐只用于可忽略接线误差的应用场合。
 | 2线或4线 | 1

表5. EM231 RTD 4AI DIP开关设置

RTD Type and Alpha¹ | SW1 | SW2 | SW3 | SW4 | SW5 | SW6 | RTD Type and Alpha¹ | SW1 | SW2 | SW3 | SW4 | SW5 | SW6
100Ω Pt 0.003850 (Default) | 0 | 0 | 0 | 0 | 0 | 0 | 100Ω Pt 0.003902 | 1 | 0 | 0 | 0 | 0 | 0
200Ω Pt 0.003850 | 0 | 0 | 0 | 0 | 1 | 0 | 200Ω Pt 0.003902 | 1 | 0 | 0 | 0 | 1 | 0
500Ω Pt 0.003850 | 0 | 0 | 0 | 1 | 0 | 0 | 500Ω Pt 0.003902 | 1 | 0 | 0 | 1 | 0 | 0
1000Ω Pt 0.003850 | 0 | 0 | 0 | 1 | 1 | 0 | 1000Ω Pt 0.003902 | 1 | 0 | 0 | 1 | 1 | 0
100Ω Pt 0.003920 | 0 | 0 | 1 | 0 | 0 | 0 | SPARE | 1 | 0 | 1 | 0 | 0 | 0
200Ω Pt 0.003920 | 0 | 0 | 1 | 0 | 1 | 0 | 100Ω Ni 0.00672 | 1 | 0 | 1 | 0 | 1 | 0
500Ω Pt 0.003920 | 0 | 0 | 1 | 1 | 0 | 0 | 120Ω Ni 0.00672 | 1 | 0 | 1 | 1 | 0 | 0
1000Ω Pt 0.003920 | 0 | 0 | 1 | 1 | 1 | 0 | 1000Ω Ni 0.00672 | 1 | 0 | 1 | 1 | 1 | 0
100Ω Pt 0.00385055 | 0 | 1 | 0 | 0 | 0 | 0 | 100Ω Ni 0.006178 | 1 | 1 | 0 | 0 | 0 | 0
200Ω Pt 0.00385055 | 0 | 1 | 0 | 0 | 1 | 0 | 120Ω Ni 0.006178 | 1 | 1 | 0 | 0 | 1 | 0
500Ω Pt 0.00385055 | 0 | 1 | 0 | 1 | 0 | 0 | 1000Ω Ni 0.006178 | 1 | 1 | 0 | 1 | 0 | 0
1000Ω Pt 0.00385055 | 0 | 1 | 0 | 1 | 1 | 0 | 10000Ω Pt 0.003850 | 1 | 1 | 0 | 1 | 1 | 0
100Ω Pt 0.003916 | 0 | 1 | 1 | 0 | 0 | 0 | 10Ω Cu 0.004270 | 1 | 1 | 1 | 0 | 0 | 0
200Ω Pt 0.003916 | 0 | 1 | 1 | 0 | 1 | 0 | 150Ω FS Resistance | 1 | 1 | 1 | 0 | 1 | 0
500Ω Pt 0.003916 | 0 | 1 | 1 | 1 | 0 | 0 | 300Ω FS Resistance | 1 | 1 | 1 | 1 | 0 | 0
1000Ω Pt 0.003916 | 0 | 1 | 1 | 1 | 1 | 0 | 600Ω FS Resistance | 1 | 1 | 1 | 1 | 1 | 0
GOST 50Ω Pt 0.00385055 | 0 | 0 | 0 | 0 | 1 | 1 | GOST Cu 50Ω 0.00426 | 0 | 1 | 0 | 1 | 1 | 1
GOST 100Ω Pt 0.00385055 | 0 | 0 | 0 | 1 | 0 | 1 | GOST Cu 100Ω 0.00426 | 0 | 1 | 1 | 0 | 0 | 1
GOST 500Ω Pt 0.00385055 | 0 | 0 | 0 | 1 | 1 | 1 | GOST Cu 500Ω 0.00426 | 0 | 1 | 1 | 0 | 1 | 1
GOST 10Ω Pt 0.00385055 | 0 | 0 | 1 | 0 | 0 | 1 | GOST Cu 10Ω 0.00428 | 0 | 1 | 1 | 1 | 0 | 1
GOST 50Ω Pt 0.003910 | 0 | 0 | 1 | 0 | 1 | 1 | GOST Cu 50Ω 0.00428 | 0 | 1 | 1 | 1 | 1 | 1
GOST 100Ω Pt 0.003910 | 0 | 0 | 1 | 1 | 0 | 1 | GOST Cu 100Ω 0.00428 | 1 | 0 | 0 | 0 | 0 | 1
GOST 500Ω Pt 0.003910 | 0 | 0 | 1 | 1 | 1 | 1 | GOST Cu 500Ω 0.00428 | 1 | 0 | 0 | 0 | 1 | 1
GOST 10Ω Pt 0.003910 | 0 | 1 | 0 | 0 | 0 | 1 | Spare | 1 | 0 | 0 | 1 | 0 | 1
LG-Ni 1000Ω Pt 0.005000 | 0 | 1 | 0 | 0 | 1 | 1 |  |  |  |  |  |  |

表6.热电偶模块的DIP开关设置参考下表：

RTD Type and Alpha¹ | SW1 | SW2 | SW3 | SW4 | SW5 | SW6 | RTD Type and Alpha¹ | SW1 | SW2 | SW3 | SW4 | SW5 | SW6
100Ω Pt 0.003850 (Default) | 0 | 0 | 0 | 0 | 0 | 0 | 100Ω Pt 0.003902 | 1 | 0 | 0 | 0 | 0 | 0
200Ω Pt 0.003850 | 0 | 0 | 0 | 0 | 1 | 0 | 200Ω Pt 0.003902 | 1 | 0 | 0 | 0 | 1 | 0
500Ω Pt 0.003850 | 0 | 0 | 0 | 1 | 0 | 0 | 500Ω Pt 0.003902 | 1 | 0 | 0 | 1 | 0 | 0
1000Ω Pt 0.003850 | 0 | 0 | 0 | 1 | 1 | 0 | 1000Ω Pt 0.003902 | 1 | 0 | 0 | 1 | 1 | 0
100Ω Pt 0.003920 | 0 | 0 | 1 | 0 | 0 | 0 | SPARE | 1 | 0 | 1 | 0 | 0 | 0
200Ω Pt 0.003920 | 0 | 0 | 1 | 0 | 1 | 0 | 100Ω Ni 0.00672 | 1 | 0 | 1 | 0 | 1 | 0
500Ω Pt 0.003920 | 0 | 0 | 1 | 1 | 0 | 0 | 120Ω Ni 0.00672 | 1 | 0 | 1 | 1 | 0 | 0
1000Ω Pt 0.003920 | 0 | 0 | 1 | 1 | 1 | 0 | 1000Ω Ni 0.00672 | 1 | 0 | 1 | 1 | 1 | 0
100Ω Pt 0.00385055 | 0 | 1 | 0 | 0 | 0 | 0 | 100Ω Ni 0.006178 | 1 | 1 | 0 | 0 | 0 | 0
200Ω Pt 0.00385055 | 0 | 1 | 0 | 0 | 1 | 0 | 120Ω Ni 0.006178 | 1 | 1 | 0 | 0 | 1 | 0
500Ω Pt 0.00385055 | 0 | 1 | 0 | 1 | 0 | 0 | 1000Ω Ni 0.006178 | 1 | 1 | 0 | 1 | 0 | 0
1000Ω Pt 0.00385055 | 0 | 1 | 0 | 1 | 1 | 0 | 10000Ω Pt 0.003850 | 1 | 1 | 0 | 1 | 1 | 0
100Ω Pt 0.003916 | 0 | 1 | 1 | 0 | 0 | 0 | 10Ω Cu 0.004270 | 1 | 1 | 1 | 0 | 0 | 0
200Ω Pt 0.003916 | 0 | 1 | 1 | 0 | 1 | 0 | 150Ω FS Resistance | 1 | 1 | 1 | 0 | 1 | 0
500Ω Pt 0.003916 | 0 | 1 | 1 | 1 | 0 | 0 | 300Ω FS Resistance | 1 | 1 | 1 | 1 | 0 | 0
1000Ω Pt 0.003916 | 0 | 1 | 1 | 1 | 1 | 0 | 600Ω FS Resistance | 1 | 1 | 1 | 1 | 1 | 0
GOST 50Ω Pt 0.00385055 | 0 | 0 | 0 | 0 | 1 | 1 | GOST Cu 50Ω 0.00426 | 0 | 1 | 0 | 1 | 1 | 1
GOST 100Ω Pt 0.00385055 | 0 | 0 | 0 | 1 | 0 | 1 | GOST Cu 100Ω 0.00426 | 0 | 1 | 1 | 0 | 0 | 1
GOST 500Ω Pt 0.00385055 | 0 | 0 | 0 | 1 | 1 | 1 | GOST Cu 500Ω 0.00426 | 0 | 1 | 1 | 0 | 1 | 1
GOST 10Ω Pt 0.00385055 | 0 | 0 | 1 | 0 | 0 | 1 | GOST Cu 10Ω 0.00428 | 0 | 1 | 1 | 1 | 0 | 1
GOST 50Ω Pt 0.003910 | 0 | 0 | 1 | 0 | 1 | 1 | GOST Cu 50Ω 0.00428 | 0 | 1 | 1 | 1 | 1 | 1
GOST 100Ω Pt 0.003910 | 0 | 0 | 1 | 1 | 0 | 1 | GOST Cu 100Ω 0.00428 | 1 | 0 | 0 | 0 | 0 | 1
GOST 500Ω Pt 0.003910 | 0 | 0 | 1 | 1 | 1 | 1 | GOST Cu 500Ω 0.00428 | 1 | 0 | 0 | 0 | 1 | 1
GOST 10Ω Pt 0.003910 | 0 | 1 | 0 | 0 | 0 | 1 | Spare | 1 | 0 | 0 | 1 | 0 | 1
LG-Ni 1000Ω Pt 0.005000 | 0 | 1 | 0 | 0 | 1 | 1 |  |  |  |  |  |  |

常问问题

EM231的最后三位DIP开关有什么作用？

正如表1所示，没有作用。

什么是单极性、双极性？

双极性就是信号在变化的过程中要经过“零”，单极性不过零。由于模拟量转换为数字量是有符号整数，所以双极性信号对应的数值会有负数。

在S7-200中，单极性模拟量输入/输出信号的数值范围是 0 - 32000；双极性模拟量信号的数值范围是 -32000－+32000。

同一个模块的不同通道是否可以分别接电流和电压型输入信号？

可以分别按照电流和电压型信号的要求接线。但是DIP开关设置对整个模块的所有通道有效，在这种情况下，电流、电压信号的规格必须能设置为相同的DIP开关状态。如上面表1、表2中，0 - 5V和0 - 20mA信号具有相同的DIP设置状态，可以接入同一个模拟量模块的不同通道。


模拟量寻址

S7-200模拟量数据格式与寻址

模拟量输入/输出数据是有符号整数，占用一个字长（两个字节），所以地址必须从偶数字节开始。模拟量的转换精度为12位，但在PLC中表示为-32000－+32000之间的整数值（实际上数值可以是整个16位有符号整数的范围，但标准输入信号如10V/20mA被标定为对应32000，模拟量超过标准值一点也因此可以表示）。

在S7-200中，单极性模拟量输入/输出信号的数值范围是 0 - 32000；双极性模拟量信号的数值范围是 -32000－+32000。

格式：

  • 输入：AIW[起始字节地址]——如AIW6
  • 输出：AQW[起始字节地址]——如AQW0

每个模拟量输入模块，按模块的先后顺序和输入通道数目，以固定的递增顺序向后排地址。 例如： AIW0、AIW2、AIW4、AIW6、AIW8等。

对于EM231 RTD（热电阻）两通道输入模块，不再占用空的通道，后面的模拟量输入点是紧接着排地址的。

每个有模拟量输出的模块占两个输出通道。即使第一个模块只有一个输出AQW0，第二个模块的输出地址也应从AQW4开始寻址（AQW2被第一个模块占用），依此类推。

温度模拟量输入模块（EM231 TC、EM231 RTD）也按照上述规律寻址，但是所读取的数据是温度测量值的10倍（摄氏或华氏温度）。如520相当于52.0度。

注意： 每一模块的起始地址都可在STEP 7-Micro/WIN中的菜单“PLC > Information”里在线读到。


模拟量- 换算

模拟量比例换算

因为A/D（模/数）、D/A（数/模）转换之间的对应关系，S7-200 CPU内部用数值表示外部的模拟量信号，两者之间有一定的数学关系。这个关系就是模拟量/数值量的换算关系。

例如，使用一个0 - 20mA的模拟量信号输入，在S7-200 CPU内部，0 - 20mA对应于数值范围0 - 32000；对于4 - 20mA的信号，对应的内部数值为6400 - 32000。

如果有两个传感器，量程都是0 - 16MPa，但是一个是0 - 20mA输出，另一个是4 - 20mA输出。它们在相同的压力下，变送的模拟量电流大小不同，在S7-200内部的数值表示也不同。显然两者之间存在比例换算关系。模拟量输出的情况也大致相同。

上面谈到的是0 - 20mA与4 - 20mA之间换算关系，但模拟量转换的目的显然不是在S7-200 CPU中得到一个0 - 32000之类的数值；对于编程和操作人员来说，得到具体的物理量数值（如压力值、流量值），或者对应物理量占量程的百分比数值要更方便，这是换算的最终目标。

如果使用编程软件Micro/WIN32中的PID Wizard（PID向导）生成PID功能子程序，就不必进行0 - 20mA与4 - 20mA信号之间的换算，只需进行简单的设置。

通用比例换算公式

模拟量的输入/输出都可以用下列的通用换算公式换算：

Ov = [(Osh - Osl)*(Iv - Isl)/(Ish - Isl)] + Osl

其中：

Ov:
换算结果
Iv:
换算对象
Osh:
换算结果的高限
Osl:
换算结果的低限
Ish:
换算对象的高限
Isl:
换算对象的低限

它们之间的关系可以图示如下：

图1. 模拟量比例换算关系

实用指令库

在STEP 7-Micro/WIN Programming Tips（Micro/WIN编程技巧中）的Tip38就是关于如何实现上述转换的例程。

为便于用户使用，现已将其导出成为“自定义指令库”，用户可以添加到自己的Micro/WIN编程软件中应用。

模拟量比例换算指令库和例子

注意：此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

在这个指令库中，子程序Scale_I_to_R可用来进行模拟量输入到S7-200内部数据的转换；子程序Scale_R_I可用于内部数据到模拟量输出的转换。

编程举例：

将4 - 20mA模拟量输入转换为内部百分比值 | 将内部百分比值转换为0.0-300.0工程量输出 | 将内部百分比值转换为4 - 20mA模拟量输出

图2. 编程举例

参考：如何添加自定义指令库


模拟量输入精度

S7-200模拟量输入信号的精度

模拟量输入模块有两个参数容易混淆：

  • 模拟量转换的分辨率
  • 模拟量转换的精度（误差）

分辨率是A/D模拟量转换芯片的转换精度，即用多少位的数值来表示模拟量。S7-200模拟量模块的转换分辨率是12位，能够反映模拟量变化的最小单位是满量程的1/4096。

模拟量转换的精度除了取决于A/D转换的分辨率，还受到转换芯片的外围电路的影响。在实际应用中，输入的模拟量信号会有波动、噪声和干扰，内部模拟电路也会产生噪声、漂移，这些都会对转换的最后精度造成影响。这些因素造成的误差要大于A/D芯片的转换误差。

详细的数据请参考《S7-200系统手册》附录A有关模拟量模块的部分。


系统块－模拟量滤波

模拟量滤波器：

S7-200允许你为每一路模拟量输入选择软件滤波器。一般情况下选用S7-200的模拟量滤波功能就不必再另行编制用户的滤波程序。

如果对某个通道选用了模拟量滤波，CPU将在每一程序扫描周期前自动读取模拟量输入值，这个值就是滤波后的值，是所设置的采样数的平均值。模拟量的参数设置（采样数及死区值）对所有模拟量信号输入通道有效。

如果对某个通道不滤波，则CPU不会在程序扫描周期开始时读取平均滤波值，而只在用户程序访问此模拟量通道时，直接读取当时实际值。

模拟量滤波器使用步骤如下：

  1. 在Micro/Win 中进入View>Component>System Block，并选择Analog Input Filters选项，进入模拟量滤波器。

  2. 设置模拟量滤波器：

    3. 图1. 模拟量通道滤波设置

    1. 设置模拟量采样数，例：此处设置的64表示模拟量滤波后的值为包括当前采样的前64个采样值的平均值。

    2. 死区值，定义了计算模拟量平均值的取值范围
      • 如果采样值都在这个范围内，就计算采样数所设定的平均值；如果当前最新采样的值超过了死区的上限或下限，则该值立刻被采用为当前的新值，并作为以后平均值计算的起始值（如图2所示）
      • 这就允许滤波器对模拟量值的大的变化有一个快速响应
      • 死区值设为0，表示禁止死区功能，即所有的值都进行平均值计算，不管该值有多大的变化
      • 对于快速响应要求，不要把死区值设为0，而把它设为可预期的最大的扰动值（320为满量程32000的1％）

    3. 选择需要滤波的模拟量通道，打钩的为使能的模拟量输入，缺省设置是为所有的模拟量输入使用滤波器

    4. CPU224XP上的AIW0、AIW2（CPU本体上的模拟量输入通道）不必滤波

    图2. 死区示意图

    3. 点击OK并下载修改后的系统块到S7-200中。

注意：

  • 为变化比较缓慢的模拟量输入选用滤波器可以抑制波动
  • 为变化较快的模拟量输入选用较小的采样数和死区值会加快响应速度
  • 对高速变化的模拟量值不要使用滤波器
  • 如果用模拟量传递数字量信号，或者使用热电阻（EM231 RTD）、热电偶（EM231 TC）、AS-Interface（CP243-2）模块时，不能使用滤波器


模拟量－FAQ

模拟量相关常问问题

模拟量输入数值为何不稳定？

EM235能否连接热电阻测温？

S7-200的模拟量输入/输出模块是否带信号隔离？

不带隔离。如果用户的系统中需要隔离，请另行购买信号隔离器件。

模拟量信号的传输距离有多远？

电压型的模拟量信号，由于输入端的内阻很高（S7-200的模拟量模块为10兆欧），极易引入干扰，所以讨论电压信号的传输距离没有什么意义。一般电压信号是用在控制设备柜内电位器设置，或者距离非常近、电磁环境好的场合。

电流型信号不容易受到传输线沿途的电磁干扰，因而在工业现场获得广泛的应用。

电流信号可以传输比电压信号远得多的距离。理论上，电流信号的传输距离受到以下几个因素的制约：

  • 信号输出端的带载能力，以欧姆数值表示（如700Ω）
  • 信号输入端的内阻
  • 传输线的静态电阻值（来回是双线）

信号输出端的负载能力必须大于信号输入端的内阻与传输线电阻之和。当然实际情况不会完全符号理想的计算结果，传输距离过长会造成信号衰减，也会引入干扰。

如果负载能力足够，一个电流信号可以串接多个信号输入端。例如一个4 - 20mA的模拟量转速给定信号可以输出给两台变频器的4 - 20mA模拟量输入端口。

S7-200模拟量模块的输入/输出阻抗指标是多少？

详情可见《S7-200系统手册》的附录A. （模拟量输入/输出规范） 。

模拟量输入阻抗：

  • 电压型信号：≥ 10MΩ
  • 电流型信号：250Ω

模拟量输出阻抗：

  • 电压型信号：≥ 5KΩ
  • 电流型信号：≤ 500Ω

模拟量模块的电源指示灯正常，为何信号输入灯不亮？

模拟量模块的外壳按照通用的形式设计和制造，实际上没有模拟量输入信号指示灯。凡是没有印刷标记的灯窗都是无用空置的。

为何模拟量值的最低三位有非零的数值变化？

模拟量的转换精度为12位，但模块将数模转换后的数值向高位移动了三位。如果将此通道设置为使用模拟量滤波，则当前的数值是若干次采样的平均值，最低三位是计算得出的数值；如果禁用模拟量滤波，则最低三位都是零。

S7-200测量0-20mA和4-20mA的电流信号时需要选择不同的模块吗？设置上有差异吗？

不需要选择不同的模块。选择同一种模块，如EM231（订货号：6ES7 231-0HC22-0XA0）即可实现。对于S7-200模拟量模块而言，量程设定是通过拨码开关来实现的，对于4-20mA和0-20mA两种量程，其拨码设置是完全一样的。二者的区别是4-20mA对应的数字量范围是6400-32000。而0-20mA对应的数字量范围是0-32000。


模拟量输入不稳定

为什么使用S7-200 模拟量输入模块时接收到一个变动很大的不稳定的值？

可能是如下原因：

  1. 你可能使用了一个自供电或隔离的传感器电源，两个电源没有彼此连接，即模拟量输入模块的电源地和传感器的信号地没有连接。这将会产生一个很高的上下振动的共模电压，影响模拟量输入值。
  2. 另一个原因可能是模拟量输入模块接线太长或绝缘不好。

可以用如下方法解决：

  1. 连接传感器输入的负端与模块上的公共M 端以补偿此种波动。（但要注意确保这是两个电源系统之间的唯一联系。）
    背景是：

    • 模拟量输入模块内部是不隔离的；
    • 共模电压不应大于 12V；
    • 对于60Hz干扰信号的共模抑制比为40dB。

  2. 使用模拟量输入滤波器。
    在Micro/Win 中进入“View > System block> Tab: Analog Input Filters”

    • 选择模拟量输入滤波；
    • 选择 “Number of samples”和“Deadband”

    图1. 设置模拟量滤波

    “Number of samples”指定了选中进行滤波的通道进行平均值计算的采样数。滤波得出的数值就是已采样的n个数值的平均值，而n就是“Number of samples”的值。

死区（Deadband）定义了允许偏离于平均值的最大值。

相关链接

模拟量输入模块接线
模拟量寻址
模拟量滤波设置


EM231 RTD

EM231 RTD（热电阻）模块接线

因为热电阻分2线制、3线制、4线制，所以RTD模块与热电阻的接线有3种方式，如图所示。其中，精度最高的是4线连接，精度最低的是2线连接。

EM231 RTD模块占用的模拟量通道，在系统块中设置模拟量通道滤波时，应禁止滤波功能。

常问问题

模块上的SF红灯为何闪烁？

SF红灯闪烁有两个原因：模块内部软件检测出外接热电阻断线，或者输入超出范围。由于上述检测是两个输入通道共用的，所以当只有一个通道外接热电阻时，SF灯必然闪烁。解决方法是将一个100 Ohm的电阻，按照与已用通道相同的接线方式连接到空的通道；或者将已经接好的那一路热电阻的所有引线，一一对应连接到空的通道上。

参见ProDIS网站FAQ19295124。

什么是正向标定、负向标定？

正向标定值是3276.7度（华氏或摄氏），负向标定值是-3276.8度。如果检测到断线、输入超出范围时，相应通道的数值被自动设置为上述标定值。

热电阻的技术参数不是很清楚，如何在DIP开关上设置类型？

应该尽量弄清除热电阻的参数。否则可以使用缺省设置。

EM235是否能用于热电阻测温？

EM235不是用于与热电阻连接测量温度的模块，勉强使用容易带来问题。

建议使用EM231 RTD模块。

相关链接

EM231 RTD模拟量寻址


EM231 TC

EM231 TC（热电偶）模块接线

热电偶模块接线如下图。

EM231 TC 模块占用的模拟量通道，在系统块中设置模拟量通道滤波时，应禁止滤波功能。

常问问题

EM231 TC（热电偶）模块是否支持B型热电偶？

EM231 TC支持J、K、E、N、S、T和R型热电偶，不支持B型热电偶。

EM231 TC是否需要补偿导线？

EM231 TC可以设置为由模块实现冷端补偿，但仍然需要补偿导线进行热电偶的自由端补偿。

EM231 TC模块SF灯为何闪烁？

原因可能是：

  • 如果选择了断线检测，则可能是断线。应当短接未使用的通道，或者并联到旁边的实际接线通道上。
  • 输入超出范围

何谓正向、负向标定？

参见EM231 RTD相关条目。

相关链接

EM231 TC模拟量寻址


STEP 7-Micro/WIN 编程软件

STEP 7-Micro/WIN 软件

S7-200 PLC 系统的编程软件是 STEP 7-Micro/WIN。

目前的最新版本是 STEP 7-Micro/WIN V4.0 SP7

需要的操作系统为：

  • Microsoft WindowsXP Home

  • Microsoft WindowsXP Proffesional

  • Microsoft Vista Home-Basic

  • Microsoft Vista Home-Premium

  • Microsoft Vista Business

  • Microsoft Vista Ultimate

目前常见的上一个版本是 STEP 7-Micro/WIN32 V3.2 SP4，这是 V3.2 版的最高版本。

随着新产品的发布，我们建议不再使用 Micro/WIN V4.0 以前的版本。我们建议尽快升级到最新的版本下工作，以获得最新的功能和更高的稳定性。用户可以联系西门子的代理商，或者从网站上下载相关软件的升级版。

软件下载和升级网址

已经测试 STEP 7-Micro/WIN32 V3.2 SP4 适用的 Windows 操作系统为：

  • Windows 95
  • Windows 98, 2nd Edition
  • Windows NT, Version 4.0,SP6
  • Windows Me Edition
  • Windows 2000, SP2
  • Windows XP Home
  • Windows XP Professional

不同版本的Micro/WIN生成的项目文件不同。高版本的Micro/WIN能够向下兼容低版本软件生成的项目文件；低版本的软件不能打开高版本保存的项目文件。

PG702

PG702是为第一代S7-200 PLC设计的手持编程器，只用于CPU21x系列，不能用于CPU22x系列。

CPU22x只能用安装STEP 7-Micro/WIN的PC机、笔记本电脑和PG（西门子编程器），通过相应的通信介质编程。

以后西门子也不会为S7-200系列提供手持编程器。

仿真软件

西门子不提供S7-200仿真软件。


STEP 7-Micro/WIN V4.0 SP5

STEP 7-Micro/WIN V4.0 SP9

西门子于已经正式推出 S7-200 新版编程软件 STEP 7-Micro/WIN V4.0 SP9。

STEP 7-Micro/WIN V4.0 SP9 的详细版本号为 V4.0.9.25。

安装 STEP 7-Micro/WIN V4.0 SP9 也将同时更新 TD Keypad Designer 和 S7-200 Explorer。安装 Micro/WIN V4.0 SP9 升级版将把先前系统中安装的 V4.0 正式版（包括各 SP 版本）升级到 SP9，安装 SP9升级版也需要先安装有 V4.0 的任何版本；如果已有 STEP 7-Micro/WIN V4.0 + SP9正式版，则可直接安装。

STEP 7-Micro/WIN V4.0 SP9 升级版下载见软件下载链接 。

STEP 7-Micro/WIN V4.0 SP6 软件兼容性

  • STEP 7-Micro/WIN V4.0 SP9 可以完全兼容所有 S7-200 CPU (CPU21x 和 22x)．

  • STEP 7-Micro/WIN V4.0 SP9 可以毫无限制的打开老版本软件 STEP 7-Micro/WIN V3.x 或 V4.x 所编写的程序．

  • 由 STEP 7-Micro/WIN V2.x 或更老的版本创建的项目，要转换成语句表（STL）保存后，再用 STEP 7-Micro/WIN V3.x 或 V4.x 的软件打开． 因此，在STEP 7-Micro/WIN 的安装光盘里都可以找到 STEP 7-Micro/WIN　V2.1 安装软件．

  • STEP 7-Micro/WIN V4.0 SP9 创建的项目不能使用老版本的软件打开或上载．
  • 持的操作系统：
    ? Windows 2000，最高 SP3 Windows XP，最高 SP3 (32 位) Vista，最高 SP2 Windows7 (32 位) Windows7 (64 位)
    STEP7 MicroWIN V4.0 SP8 X X X ?--- ?---
    STEP7 MicroWIN V4.0 SP9 n.t. X n.t. X X

    X = 可执行并经过测试；n.t. = 未经过测试；--- 不可执行

STEP7 MicroWIN V4 SP9 的安装说明

1. 将该文件下载到 PC。
2. 将压缩文件和所需的 Service Pack 解压缩。
3. 打开文件夹“Disk1”，然后执行文件 setup.exe。
4. 按照安装期间的提示操作以完成安装。
5. 安装成功完成后，可在开始菜单的“Simatic”项下看到 STEP7 MicroWIN V4 SP9。
6. 安装之后，请删除含有安装文件的临时子文件夹 。必须手动执行此操作。

同时更改操作系统时的安装说明

1. 在含有可执行的先前版本的 PC 上，将文件 microwin.exe 解压缩。您可在 C 盘中的以下标准安装文件夹中找到该文件：
Program Files\Simatic\STEP 7-MicroWIN V4\bin
2. 将该打包文件复制到安装有新操作系统的 PC 上，然后将该文件解压缩。
3. 按照相关 Service Pack 的安装说明开始安装。


STEP 7-Micro/WIN V4.0 SP5

STEP 7-Micro/WIN V4.0 SP6

西门子于 2007 年 12 月正式推出 S7-200 新版编程软件 STEP 7-Micro/WIN V4.0 SP6。

STEP 7-Micro/WIN V4.0 SP6 的详细版本号为 V4.0.6.08。

安装 STEP 7-Micro/WIN V4.0 SP6 也将同时更新 TD Keypad Designer 和 S7-200 Explorer。安装 Micro/WIN V4.0 SP6 升级版将把先前系统中安装的 V4.0 正式版（包括各 SP 版本）升级到 SP6，安装 SP6 升级版也需要先安装有 V4.0 的任何版本；如果已有 STEP 7-Micro/WIN V4.0 + SP6 正式版，则可直接安装。

STEP 7-Micro/WIN V4.0 SP6 升级版下载见软件下载链接 。

STEP 7-Micro/WIN V4.0 SP6 软件兼容性

  • STEP 7-Micro/WIN V4.0 SP6 可以完全兼容所有 S7-200 CPU (CPU21x 和 22x)．

  • STEP 7-Micro/WIN V4.0 SP6 可以毫无限制的打开老版本软件 STEP 7-Micro/WIN V3.x 或 V4.x 所编写的程序．

  • 由 STEP 7-Micro/WIN V2.x 或更老的版本创建的项目，要转换成语句表（STL）保存后，再用 STEP 7-Micro/WIN V3.x 或 V4.x 的软件打开． 因此，在STEP 7-Micro/WIN 的安装光盘里都可以找到 STEP 7-Micro/WIN　V2.1 安装软件．

  • STEP 7-Micro/WIN V4.0 SP6 创建的项目不能使用老版本的软件打开或上载．

STEP 7-Micro/WIN V4.0 SP6 新功能

STEP 7-Micro/WIN V4.0 SP6 的主要新功能和改进为：

  • 支持新的 TD400 C

  • 支持 TS Adapter IE teleservice adapter

  • 优化了 modem 向导，支持modem 模块 EM241新功能．

STEP 7-Micro/WIN V4.0 SP６支持的操作系统：

  • Microsoft WindowsXP Home

  • Microsoft WindowsXP Proffesional

  • Microsoft Vista Home-Basic

  • Microsoft Vista Home-Premium

  • Microsoft Vista Business

  • Microsoft Vista Ultimate


STEP 7-Micro/WIN V4.0 SP5

西门子于 2007 年 2 月正式推出 S7-200 新版编程软件 STEP 7-Micro/WIN V4.0 SP5。

STEP 7-Micro/WIN V4.0 SP5 的详细版本号为 V4.0.5.08。

安装 STEP 7-Micro/WIN V4.0 SP5 也将同时更新 TD Keypad Designer 和 S7-200 Explorer。安装 Micro/WIN V4.0 SP5 升级版将把先前系统中安装的 V4.0 正式版（包括各 SP 版本）升级到 SP5，安装 SP5 升级版也需要先安装有 V4.0 的任何版本；如果已有 STEP 7-Micro/WIN V4.0 + SP5 正式版，则可直接安装。

STEP 7-Micro/WIN V4.0 SP5 升级版下载见软件下载链接。

STEP 7-Micro/WIN V4.0 SP5 新功能

STEP 7-Micro/WIN V4.0 SP5 的主要新功能和改进为：

  • 改进了 AS-Interface 配置向导

  • 新增西门子标准指令库。包括：

    • USS 协议指令库 V2.3 （Port 0 和 Port 1）

    • Modbus RTU Master （主站）指令库 V1.2 （Port 0 和 Port 1）

图 1. Micro/WIN V4.0 SP5 西门子标准指令库更新

如果仅安装或升级到 Micro/WIN V4.0 SP5 而没有安装西门子 Instruction Library 软件包，将无法显示出更新的库。要使用西门子标准指令库，需要安装西门子的 Instruction Library。指令库可以在 软件下载链接 中找到下载地址。


STEP 7-Micro/WIN V4.0 SP4

西门子于 2006 年 6 月正式推出 S7-200 新版编程软件 STEP 7-Micro/WIN V4.0 SP4。

STEP 7-Micro/WIN V4.0 SP4 的详细版本号为 V4.0.4.16。

安装 STEP 7-Micro/WIN V4.0 SP4 也将同时更新 TD Keypad Designer 和 S7-200 Explorer。

STEP 7-Micro/WIN V4.0 SP4 升级版下载见软件下载链接。

STEP 7-Micro/WIN V4.0 SP4 新功能

STEP 7-Micro/WIN V4.0 SP4 的主要新功能和改进为：

  • 支持全新的文本显示器 TD 400 C
    TD 400 C 配置向导仅在中文界面下才显示并可用
  • 新增符号名编辑自动完成功能
    用户可以在程序编辑器和状态表中使用此功能
  • 符号名拖放操作
    用户可以从符号表、局部变量表或交叉引用表中拖动符号名到程序中操作数输入端，或到另一个表
  • 符号名操作快捷键
    使用： F4 定义符号；F5 编辑符号；F6 选择符号
  • 编程通信设置
    如果 Micro/WIN 第一次启动时检测到了 USB/PPI 电缆，则会自动选择 USB 为编程接口
  • 下载时提示从 STOP 状态转换到 RUN 状态（可选）
  • POU 标签条增加了“转到头、尾”箭头按钮（如同 Excel）
  • 超级树的向导分支可以显示向导配置数据区的起始和结束地址
  • 删除无用的库符号表更加容易：
    在“库存储区分配”对话框中增加了一个“删除库符号表”按钮
  • Micro/WIN 项目文件永久保存密码，而不必每次保存时重新输入
  • 在 STOP 模式下进行监控时提示用户切换到 RUN 模式
  • 建立新状态表时自动转到新建表
  • 可以为 LAD 和 FBD 编辑器指定缺省的符号寻址方式和光标位置


STEP 7-Micro/WIN V4.0 SP2

STEP 7-Micro/WIN V4.0 SP2 的主要改进有：

  • 改进了配方编辑功能
  • 改进了 PID 编辑和调试功能
  • 提高了 USS 库指令性能
  • 全面改善了中文支持

STEP 7-Micro/WIN 安装与升级


编程软件－安装与升级

系列视频：S7-200跟我学/跟我做:

S7-200CN: 软件安装和设置中文界面-跟我学 - 2/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=251
S7-200CN: 软件安装和设置中文界面-跟我做 - 3/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=252

安装编程软件STEP 7-Micro/WIN

如同安装普通 Windows 应用程序一样安装 STEP 7-Micro/WIN。

安装 STEP 7-Micro/WIN 时，如果计算机中已经安装了很多西门子的工程软件，可能会多花一些时间。注意不要随意中断安装，否则会造成无法正常卸载、安装。

中文版选项

新版本编程软件 STEP 7-Micro/WIN V4.0 在安装时不再需要选择语言。V4.0 采用新的机制切换软件界面语言，用户可以在 Tools（工具）菜单的 Options（选项）中，在 General（常用）分支中选择界面语言。

在开始安装 Micro/WIN 时选择的是安装程序的界面语言，其中没有中文也是正常的。选用 Micro/WIN 的中文界面应当按上述方式操作。

安装 Micro/WIN32 V3.2 SP1 以上版本时，可以在安装时选择编程界面语言：

图1. 选择编程软件语言（仅 STEP 7-Micro/WIN V3.2 SP1/2/3/4 版）

安装 Service Pack 软件升级包

在编程软件的同一个版本中，软件升级需要安装 Servcie Pack 软件包。新出的编程软件光盘，可能已经包含了当时的 SP 包，如 Micro/WIN32 V3.2 + SP4。

STEP 7-Micro/WIN V4.0 SPx 和 V4.0 不能共存，安装 SP 时看到提示后，需退出安装程序，卸载 V4.0 版，然后再次安装 SP1（找到解压缩的文件目录，运行 Setup 文件）。

在一个版本系列中，只需要安装最新的 SP 包，而不必按顺序安装所有的 SP。

Service Pack 不能单独安装。如果在本地硬盘上没有安装正式版本，则会退出安装。

主要步骤如下：

  1. 确认已安装的版本。如果不是正式版则不能安装
  2. 运行升级包的可执行文件（.exe）
  3. 在Location to Save Files窗口中指定解压缩文件的文件夹
  4. 自动寻找已在本地硬盘上安装的正式版本，如没有则退出
  5. 找到正式版后，指定安装目标文件夹。如果使用缺省的路径，需要退出安装，卸载已有的正式版软件，然后找到解压缩的文件夹，运行Setup文件；如果指定其他路径则继续安装。多种版本可以并存

卸载 STEP 7-Micro/WIN

免费升级包下载地址

在S7-200产品主页上有链接到免费下载升级软件包的地址（http://support.automation.siemens.com/WW/view/cn/10805397/133100)。

西门子的官方网站只能下载DEMO（演示）版和升级包，不能下载正式版软件。需要正式版软件请咨询西门子的经销商。

常问问题

是否可以通过安装 SP 包从 V3.2 直接升级到 V4.0?

不可以。需要 V4.0 版软件请联系西门子的经销商。

相关链接

  • 安装指令库
  • 使用中文版


Step7 - Micro/WIN版本

STEP 7 - Micor/WIN 的版本

S7-200的编程软件经历了一个长期的发展过程，从STEP 7 - Micro/DOS（DOS下运行）到STEP 7-Micro/WIN16（运行于16位Windows下），一直到现在的STEP 7-Micro/WIN32。

STEP 7-Micro/WIN32运行在32位Windows操作系统下，即从Windows95以后的微软视窗操作系统。Micro/WIN32只是说明它适用于32位Windows，而不是版本号。

现在Micro/WIN32就简称Micro/WIN。

目前常见的Micro/WIN版本有V4.0和V3.2。再老的版本，如V2.1，除了用于转化老项目文件，已经没有继续应用的价值。

不同版本的Micro/WIN生成的项目文件不同。高版本的Micro/WIN能够向下兼容低版本软件生成的项目文件；低版本的软件不能打开高版本保存的项目文件。

我们建议用户总是使用最新的版本，目前最新的版本是 STEP 7-Micro/WIN V4.0 SP7。

在每个版本中，还会有小的升级，以SPx（Service Pack）表示。Service Pack升级包可以在西门子的网站上免费下载；Service Pack包不是能够单独安装的正式版本。

从STEP 7-Micro/WIN32 V3.2 SP1开始，Micro/WIN开始全面支持中文。

Micro/WIN的版本信息

在Micro/WIN的Help（帮助）菜单中，使用About（关于）命令查看详细信息：

图1. 详细的版本信息

在上图中，“V3.2”表示是3.2版，后面的数字“4”就是Service Pack号。所以这个版本的全称是STEP 7-Micro/WIN32 V3.2 SP4。

版本与操作系统兼容性

STEP 7-Micro/WIN的各个版本与Windows操作系统的各个版本之间，有一定的兼容关系。如果您安装的Micro/WIN版本和操作系统不兼容，会发生各种问题，如比较常见的通信不正常的现象。

表1. Micro/WIN与Windows版本兼容表

（注：C = 支持；IC = 不支持；* = 不确定）

注意：

  • 在西门子的官方网站上只能下载演示版和升级软件包，不能下载正式版。演示版有60天的使用日期限制，并且不能升级。如果需要正式版软件，请咨询西门子的产品经销商，或参见软件下载链接。
  • 在Windows NT，Windows2000，Windows XP下安装，需要管理员权限

常问问题

Micro/WIN 是否可以在 Windows Vista 下安装运行？

目前，只有STEP 7 Micro/WIN V4.0 SP6 或 SP7 版本支持 Windows Vista 系统。

Micro/WIN是否可以从V3.2直接升级到V4.0?

不可以。需要V4.0版软件请联系西门子的经销商。或参见软件下载链接。


中文版

STEP 7-Micro/WIN 中文版

STEP 7-Micro/WIN V4.0 以上完全支持中文编程界面和在线帮助。

在开始安装 Micro/WIN 时选择的是安装程序的界面语言，其中没有中文也是正常的。选用 Micro/WIN 的中文界面应当按下述方式操作。

在 Micro/WIN 菜单 Tools（工具）> Options（选项） 中，选择 General（常规）选项卡，设置编程语言环境。

图 1. 在英文状态下选择中文界面

设置后，Micro/WIN 会自动退出。用户可根据需要保存当前编辑的项目再退出。

STEP 7-Micro/WIN 早期版本的“汉化”方案

STEP 7 - Micor/WIN32 V3.2 SP1 以上的版本全面支持中文。

如果已安装 V3.2.0.105（V3.2 正式版），可以通过安装最新的 Service Pack 升级到支持中文的版本。

STEP 7-Micro/WIN32 V3.1 有所谓汉化包，这并非是完全支持中文的版本。我们建议用户使用完全支持中文的新版软件。


STEP 7-Micro/WIN - 卸载

卸载 STEP 7-Micro/WIN

从 Windows 操作系统的“开始” > “设置”打开”控制面板“，在其中运行”添加/删除程序“，选择相应的 STEP 7-Micro/WIN 版本卸载。

图1. 在”添加/删除程序“中选择卸载 STEP 7-Micro/WIN。

卸载完成后，一般需要重新启动 Windows 系统。

常问问题

STEP 7-Micro/WIN 的安装过程因为意外中止，造成不能卸载，也不能再次安装，这种情况如何处理？

出现这种情况，可按如下步骤处理：

  1. 点击 Windows 任务栏的”开始“按钮，选择”运行“命令
  2. 在命令行中输入 regedit，并点击”确认“打开”注册表编辑器“

    图2. 打开注册表编辑器

  3. 备份当前注册表。可以在注册表编辑器中选择“My Computer”，使用菜单命令“文件” > “导出...”保存注册表数据
  4. 打开注册表目录 HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Uninstall
  5. 选中目录 Uninstall，通过菜单命令“编辑” > “查找...”，打开查找对话框
  6. 输入查找项 STEP 7-Micro/WIN
  7. 点击“查找 ”按钮开始搜索

    图3. 查找注册表项
  8. 找到相应的注册表项并删除键值

    图4. 删除相应的注册表键值
  9. 不通版本的STEP 7 Micro/WIN 软件需要被删除的键值文件夹不同，详细请参考下表：
MicroWin 版本 | 需要被删除的文件夹
V4.0.0.81 | {49844738-872E-4348-88DD-63B3C39548C2}
V4.0.1.10 | {91F7EA3B-BB8A-4FA2-B37B-3D076D54C5EE}
V4.0.2.29 | {FDB8663D-AC1C-4390-ADEB-806922AF22F4}
V4.0.3.04 | {65088BA8-DD5C-4EA0-8CDF-C2D2577978AF}
V4.0.4.16 | {D668B8E1-B877-4BDC-B7F6-8C7568297884}
V4.0.5.08 | {B57D2D30-6E6A-11DB-9FE1-0800200C9A66}
V4.0.6.35 | {6E864646-5186-11DC-8314-0800200C9A66}
V4.0.7.10 | {BCC878B0-0EC2-4AE5-875C-C2D5434A8882}
V4.0.8.06 | {EE71A7B2-9A8E-41DD-BF38-16BCD041699D}
表 01

注意选择 STEP 7-Micro/WIN 适当版本的 DisplayName 键值删除。如果在进行此项操作之前，已经对注册表进行了错误的操作，则可能需要把注册表中所有与 Micro/WIN 相关的键值全部删除。如果此方法不能解决问题，建议重新安装 Windows 操作系统。

ProDIS 参考条目 14618173


Win7系统无法显示帮助

为什么在 Windows 7系统下无法显示 STEP 7 Micro/Win SP9的帮助文件？

在Windows 7系统下安装STEP 7 Micro/Win SP9软件过程中出现了需安装WinHlp32.exe的提示（如下图1所示），并且安装完成后无法显示STEP 7 Micro/Win SP9帮助(*.hlp)文件。

图1 需安装WinHlp32.exe的提示

原因：Windows 7系统中帮助文件的版本与STEP 7 Micro/Win SP9 帮助文件版本不一致。
要查看STEP 7 Micro/Win SP9帮助主题，需从Microsoft下载中心直接下载新的WinHlp32.exe文件,并按照说明操作。

更多信息参见如下链接：http://support.microsoft.com/kb/917607。
在该页面中可下载Windows 6.0-KB917607-x64.msu文件(用于64位PC)或Windows 6.0-KB917607-x86.msu (用于32位PC)。


系统块

系统块用来设置S7-200 CPU的系统选项和参数等。系统块更改后需要下载到CPU中，新的设置才能生效。

使用Micro/WIN窗口菜单View（查看）>Component（内容）>System Block（系统块）命令，或者在视窗左侧的浏览条中用鼠标点击System Blocek图标 [image] ，打开系统块设置窗口。

图1. 系统块设置界面

图中：

  1. 系统块设置分类项
  2. 标签分类，同a.
  3. 用鼠标在此点击可以获得与内容关联的帮助
  4. 将当前分类项内容恢复到缺省设置
  5. 将系统块全部内容恢复到缺省设置

如果区域a.中某项出现红叉标记，说明当前类型的CPU不支持此项设置。

系统块设置项

在系统块中可以设置：

  • 通信口地址、通信速率等
  • 数据保持范围
  • CPU的密码保护等级
  • 数字量输入滤波
  • 模拟量输入滤波
  • 数字量/模拟量输出在CPU停止（STOP）时的表现
  • 数字量输入脉冲捕捉功能
  • 通信背景时间
  • 扩展模块配置
  • 用户定义的一个LED指示灯
  • 是否禁用“运行编程模式”以获得更多程序内存


系统块－通讯口

系列视频：S7-200跟我学/跟我做:

S7-200CN: 通讯口设置-跟我学 - 6/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=255
S7-200CN: 通讯口设置-跟我做 - 7/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=256

通信口参数设置

缺省情况下，S7-200 CPU的通信口处于PPI从站模式，地址为2，通信速率为9.6K。

要更改通信口的地址或通信速率，必须在系统块中的Communicaiton Ports（通信端口）选项卡中设置，然后将系统块下载到CPU中，新的设置才能起作用。

图1. CPU通信口属性设置

在上图中：

  1. PLC地址：设定CPU通信口的地址。如果有两个通信口，它们的地址可以相同，因为不属于一个网络
  2. 最高地址：输入通信网络上设备的最高地址
  3. 波特率：设置通信速率。从下拉列表中可以选择9.6K、19.2K、187.5K
  4. 重试次数：输入通信失败时重新尝试的次数
  5. 地址间隙刷新因数：设置本站每隔几次获得网络令牌后，尝试在本站地址和下一个已知（活动）的主站地址的空间内寻找新加入的主站（仅在本站做主站时有效）。一般情况下使用缺省值10就比较合适
  6. 括号中是取值范围

注意在这里设置的通信速率为CPU的PPI/MPI通信速率，与由用户实现的自由口功能所定义的串行通信速率不同。

最高地址和地址间隙刷新因数

设置合适的最高地址和地址间隙刷新因数可以提高网络的运行性能。

假设一个网络中有2号站和10号站作为主站，（10号站的）最高地址设置为15。则对于2号站来说，所谓地址间隙就是3到9的范围；对于10号站来说，地址间隙就是11到最高站址15的范围，同时还包括0号和1号站。

网络通信中的主站之间会传递令牌，分时单独控制整个网络上的通信活动。网络上的所有主站不会同时加入到令牌传递环内，因此必须由某个持有令牌的主站定时查看比自己高的站址是否有新的主站加入。刷新因数指的就是在第几次获得令牌后检查一次高站址。

如果为2号站设置了地址间隙因数3，则在2号站第三次拿到令牌时会检查地址间隙中的一个地址，看是否有新的主站加入。

设置比较大的因数会提高网络的性能（因为无谓的站址检查少了），但会影响新的主站加入的速度。

这说明如下设置会使网络的运行性能提高：

  • 设置最接近实际最高站址的最高地址
  • 使所有主站地址连续排列，这样就不会再进行地址间隙中的新主站检测

以上设置仅对通信主站有效。对于Micro/WIN、一些HMI（人机界面）TD200也有类似的设置。


系统块－数据保持

系统块——数据保持

数据保持设置定义CPU如何处理各数据区的数据保持任务。在数据保持设置区中选中的就是要“保持”其数据内容的数据区。所谓“保持”就是在CPU断电后再上电，数据区域的内容是否保持断电前的状态。

  • 保持：选中的数据区内容会保持断电前状态
  • 不保持：如果某数据区未设置为“保持”，则在CPU重新上电时，V存储区的内容会用EEPROM的内容覆盖（通常都是0），如果EEPROM中保存了数据（如在数据块中设置了V数据区的初始值），这些数据就会自动复制到V区中；其他数据区的内容会清零

在这里设置的数据保持功能靠如下几种方式实现：

  • CPU内置的超级电容
  • 超级电容放电完毕后，如果安装了外插电池（或CPU221/222用的时钟/电池）卡，则电池卡会继续数据保持的电源供电，直到放电完毕
  • 数据在断电前被自动写入相应的EEPROM数据区中（如果设置MB0 - MB13为保持）

图1. 设置数据保持范围

在上图中：

  1. 最多可以设置6个数据保持区域
  2. 选择数据保持区的存储区类型（V、M、T和C的当前值）
  3. 指定数据保持区的起始地址：相对于地址0的偏移值，如14就是起始地址为MB14
  4. 存储单元的个数（在b.中指定的数据单元的个数）
  5. 清除当前的设置（为不保持）

如果将MB0 - MB13共14个字节范围中的存储单元设置为“保持”，则CPU在断电时会自动将其内容写入到EEPROM的相应区域中，在重新上电后用EEPROM的内容覆盖这些存储区。也就是能做到永久保存。如上图蓝圈内所示。

数据区设置为不保持时，可以将CPU断电然后再上电、在Status Chart（状态表）中检查相应地址单元内容是否改变可以检验数据是否正确地存入EEPROM。

以上的“保持”设置（除了MB0 - MB13）都是靠内置超级电容（＋外插电池卡）的方式供电实现。

定时器T和计数器C的当前值可以保持，而它们的位地址状态不能保持。只有TONR定时器数据才能保持。

数据保持设置与EEPROM操作的关系

  • 如果将MB0 - MB13共14个字节范围中的存储单元设置为“保持”，则CPU在断电时会自动将其内容写入到EEPROM的相应区域中，在重新上电后用EEPROM的内容覆盖这些存储区
  • 如果将其他数据区的范围设置为“不保持”，CPU会在重新上电后将EEPROM中数值复制到相应的地址
  • 如果将数据区范围设置为“保持”，如果内置超级电容（＋电池卡）未能成功保持数据，则会将EEPROM的内容覆盖相应的数据区，反之则不覆盖

参见数据保存


系统块－CPU密码

CPU密码

在系统块中设置CPU密码以限制用户对CPU的访问。可以分等级设置密码，给其他人员开放不同等级的权限。

表1. CPU密码保护等级

操作、功能 | Level 1 | Level 2 | Level 3 | Level 4
读写用户数据 | 不限制 | 不限制 | 不限制 | 见说明
启动、停止CPU
读取、设置系统时钟
上载程序、数据块、系统块 | 不限制 | 不限制 | 要密码
下载到CPU | 不限制 | 要密码
监视程序状态
运行模式程序编辑
删除程序、数据块、系统块
在状态表中强制数据
执行单/多周期程序扫描
在PLC>Information中刷新扫描周期数据
复制程序、数据块、系统块到存储卡
在STOP模式下写输出

图1. 系统块－密码

在上图中：

  1. 选择密码保护等级
    “Full”等于没有限制（无密码）
  2. 输入1 - 8个字母、符号或数字作为密码
  3. 再输入一次验证

字母大、小写无关。

Level 4 密码：第 4 级保护密码禁止上载程序，即便有正确的密码也不行。 在没有源程序的情况下，处于第 4 级密码保护下的 CPU 也不支持程序状态监控 、运行模式程序编辑和项目比较。其他功能处于和第 3 级密码相同的保护状态。第 4 级密码只有 STEP 7-Micro/WIN V4.0 SP3 以上版，配合固件版本在 REL 2.01 以上的 SIMATIC S7-200 CPU 和 S7-200 CN CPU 才能设置使用。

密码只有在系统块下载到 CPU 中后才起作用。

通过任何联网方式的编程通信都受制于此 CPU 保护密码。同一时刻只能有一个经过密码验证的用户连接到本 CPU，不会有他人趁机进入的危险。

经过密码验证后的编程连接会一直保持，如果编程计算机的通信意外断开，有效的连接会继续开放约一分钟。为防备他人趁虚而入，请先退出（关闭）Micro/WIN 再断开编程连接。

CPU 密码保护不能限制他人使用 Micro/WIN 对用户数据区的访问。如果在诸如 V 存储区、M 存储区中保持了敏感的数据，要注意这一点。

常问问题

设置了CPU密码后，为何看不出密码已经生效？

在系统块中设置了CPU密码并下载后，因为你仍然保持了Micro/WIN与CPU的通信连接，所以CPU不会对设置密码的Micro/WIN做保护。

要检验密码是否生效，可以：

  • 停止Micro/WIN与CPU的通信一分钟以上
  • 关闭Micro/WIN程序，再打开
  • 停止CPU的供电，再送电

S7-200系统中的密码保护功能


系统块－数字量/模拟量输出表

数字量/模拟量输出表

数字量/模拟量输出表规定的是当CPU处于停机（STOP）状态时，数字量输出点或者模拟量输出通道如何操作。

此功能对于一些必须保持动作、运转的设备非常重要。如抱闸，或者一些关键的阀门等，不允许在调试PLC时停止动作，就必须在系统块的输出表中进行设置。

数字量输出表

图1. 数字量输出表

图中：

  1. 冻结最后的状态：选中此选项，则在CPU进入STOP状态时数字量输出点保持停机前的状态（是1仍然是1，是0保持为0），同时下面的b.表不起作用
  2. 如果未选择a.，选中的输出点会保持ON（1）的状态，未选中的为0。在上图中Q0.7/Q0.6/Q0.5/Q0.4将在CPU进入STOP状态时保持状态为1

模拟量输出表

图2. 模拟量输出表

  1. 冻结最后的状态：选中此选项，则在CPU进入STOP状态时模拟量输出通道保持停机前的状态，同时下面的b.表不起作用
  2. 未选中a.选项时，在表中各个规定模拟量输出通道在CPU进入STOP状态时的输出值。在上图中，如果AQW0通道接成电压输出，它就会保持5V；如果AQW2通道接成电流型输出，它就保持4mA


系统块－数字量滤波器

数字量输入滤波器

可以为 CPU 上的数字量输入点选择不同的输入滤波时间。如果输入信号有干扰、噪音，可调整输入滤波时间，滤除干扰，以免误动作。

滤波时间可在 0.20 ~ 12.8ms 的范围中选择几档 。

如果滤波时间设定为 6.40ms，数字量输入信号的有效电平（高或低）持续时间小于 6.4ms时，CPU 会忽略它；只有持续时间长于 6.4ms 时，才有可能被识别。

图1. 数字量输入滤波

支持高速计数器功能的输入点在相应功能开通时不受此滤波时间约束。滤波设置对输入映像区的刷新、开关量输入中断、脉冲捕捉功能都有效。

DI/DO 的与高频信号处理

常问问题

我设置了数字量滤波，为何不能滤除连续的 50Hz 正弦干扰信号？在实验时却为何能够滤除几个正弦波干扰信号波头，而多了就不行？

数字量滤波是对电压信号的延时滤波。从工作原理和数值设置来看，它相当于一个低通滤波器，只能滤除高频的干扰脉冲，因此从原理上就不能用于滤除低频干扰信号。

数字量输入点的信号检测具有其特定的过渡反应特性。数字量滤波只有在电路检测到输入信号“有效”（激活）时才开始延时；能否达到“有效”的状态，取决于信号（包括干扰信号）在输入电路上的过渡响应。输入电路的过渡反应也可以认为是一种硬件滤波。如果干扰脉冲短暂，很可能达不到“有效”状态；而连续的低频信号波头能够不断补充能量，达到“有效”状态，进而启动滤波延时并为 CPU 识别。


系统块－背景时间

通信背景时间

图1. 设置通信背景时间

背景通信时间规定用于“运行模式编程”和程序、数据监控的Micro/WIN和CPU的通信时间占整个程序扫描周期的百分比。增加这个时间可以增加监控的通信机会，在Micro/WIN中的响应会感觉快一些，但是同时会加长程序扫描时间。


系统块－设置用户定义LED指示灯

用户自定义指示灯

23版CPU的LED指示灯（SF/DIAG）能够显示两种颜色（红/黄）。红色指示SF（系统故障），黄色DIAG指示灯可以由用户自定义。

自定义LED指示灯可以由以下方法控制：

  • 在系统块的“配置LED”选项卡中设置
  • 在用户程序中使用DIAG_LED指令点亮

上述条件之间是或的关系。如果同时出现SF和DIAG两种指示，红色和黄色灯会交替闪烁。

系统块设置

图1. 配置自定义LED灯

图中：

  1. 如果选中此项，当CPU内部有强制的变量时，DIAG灯亮
  2. 如果选中此项，当模块有I/O故障时，DIAG灯亮

缺省情况如图1所示。


Micro/WIN - mnemonics

为什么用户在编程时输入I*.*、Q*.*、AIW*、AQW*，会自动变为E*.*、A*.*、AEW*、AAW*？

因为用户此时选择的助记符集为“SIMATIC” 。将其改为“国际”可以改为大家习惯的显示方式。

操作步骤如下：

  1. 点击“工具”菜单中的“选项”（如图 1)

    图1.

  2. 选择“常规”标签，将“助记符集”改为“国际”

    图2

如此，再编程时输入I*.*、Q*.*、AIW*、AQW*，便不会自动变为E*.*、A*.*、AEW*、AAW*。


Micro/WIN指令库

STEP 7-Micro/WIN32的指令库

为了便于用户的编程，Micro/WIN提供了对指令库的支持。指令库就是独立于具体工程项目文件，而与Micro/WIN集成的子程序集。

Micro/WIN可以集成两种类型的指令库：

  • 西门子提供的标准指令库
  • 用户自定义的指令库

指令库存在于Micro/WIN指令树的Libraries（指令库）分支中：

图1. 指令库

一个子程序中可以包括几个子程序、中断服务程序。可以如同调用子程序一样在用户程序中使用指令库中的子程序；如果调用的子程序中用到了指令库中的中断程序，Micro/WIN会自动调用，不必用户处理。

  • 和子程序一样调用库指令
  • 调用库指令后，可以查看子程序的局部变量表，一般都可以找到参数的意义和格式（除非生成库时没有指定）
  • 如果生成库时指定了密码，库指令的内容无法查看
  • 西门子指令库还可能需要在编程时分配库指令内存区域


Micro/WIN西门子指令库

STEP 7-Micro/WIN 的标准指令库（Modbus/USS）

STEP 7-Micro/WIN V4.0 以上版内部已经带有新的指令库，但在未安装西门子 Instruction Library 软件包的情况下，不能显示出来使用。

要使用西门子的标准指令库，必须先安装西门子的指令库软件包 Instruction Library。安装了 Instruction Library 之后，只要安装的 STEP 7-Micro/WIN 版本是最新的，就能获得相应版本的新指令库。安装 Micro/WIN 的升级包（Service Pack）也会更新指令库的版本。

用户可以直接从下面获得西门子 Instruction Library 软件安装包：

Instruction Library

最新的 STEP 7-Micro/WIN V4.0 SP5 版本支持以下几种西门子标准指令库：

  • USS通信协议库：
    可使CPU通信口 Port0 和 Port 1 支持与Micro-Master 3（MM3系列）和Micro-Master 4（MM4系列，如MM420、MM430、MM440等）、SINAMICS G110系列的USS通信控制，通过一些预先编好的子程序和中断程序，以方便地控制变频器的运行和读写其参数。

    Micro/WIN V4.0的USS指令库现在已经针对西门子的Master Drive做了优化。

  • Modbus RTU Slave（从站）通信协议库：
    可使CPU通信口 Port0 支持Modbus RTU从站通信功能。

  • Modbus RTU Master （主站）通信协议库
    可使 CPU 通信口 Port 0 和 Port 1 支持 Modbus RTU 主站通信功能。

以上通信协议库都是使用了S7-200 CPU的自由口通信功能。

图1. 西门子标准库以浅蓝色图标表示（Micro/WIN V4.0 SP5）

从以下两种途径可以获得STEP 7-Micro/WIN指令库：

  • 安装STEP 7-Micro/WIN32 附加软件包Instruction Library V1.1，订货号6ES7830-2BC00-0YX0。
  • 已安装STEP 7-Micro/WIN32 V3.1和Toolbox V1.0（包括为TP070配置的TP Designer和老的指令库，订货号6ES7810-2TC00-0YX0），再安装正式的STEP 7-Micro/WIN32 V3.2（或V4.0）版，也可自动获得新的指令库。新旧版本的软件及其指令库可以在一台计算机上共存（V4.0 的各升级包不能共存）。

注意：

  • 所有旧的CPU21x不能使用新的指令库
  • 旧版本的指令库不能与新的指令库在同一个项目文件中共存
  • 安装了新版本的指令库后，旧版本的指令库不再能够看到
  • 用户自定义的指令库不能与西门子的库重名

可以到西门子自动化与驱动集团中文网站上下载STEP 7-Micro/WIN32 V3.2附加软件包Instruction Library V1.1（请联系西门子技术支持获得下载地址）。

有时因为系统和软件安装有问题，可能在安装完西门子标准指令库后仍然不能看到西门子标准库。这时可以尝试添加标准库。标准库的文件存在Micro/WIN安装目录下的Standard Libs目录下。

参见：添加指令库


Micro/WIN指令库－用户自定义

系列视频：S7-200跟我学/跟我做:

S7-200CN: 指令库的使用-跟我学 - 135/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=384
S7-200CN: 指令库的使用-跟我做 - 136/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=385

用户自定义指令库

用户可以把自己编制程序集成到编程软件Micro/WIN中。这样可以在编程时调用实现相同功能的库指令，而不必同时打开几个项目文件拷贝。指令库也可以方便地在多个编程计算机之间传递。

图1. 自定义库和西门子标准库以图标的颜色区分

定义库指令

一个已存在的程序项目只有子程序、中断程序可以被创建为指令库。中断程序只能随定义它的主程序、子程序集成到库中。

例如一个项目的的程序结构如下：

图1. 库指令的源项目程序

现欲将子程序My_SUB_a和My_SUB_b间为库指令，其中在My_SUB_b中定义了中断程序My_INT（将某中断事件号与中断服务程序My_INT连接起来——使用ATTACH指令）。

操作步骤：

第一步：在Micro/WIN的File（文件）菜单中，选择Creat Library...（建立库）命令；或者用鼠标右键单击指令树的Libraries（指令库）分支，选择Creat Library...

图2. 在Libraries分支上单击鼠标右键

第二步：在Creat Library对话框中选择哪些子程序要集成为指令库

图3. 使用Add（添加）、Remove（删除）按钮选择要建立成为库指令的子程序

如果定义中断的子程序被制作成库指令，则中断程序也自动集成进去，不必专门指定。

注意：建议您为将建立为库的子程序、中断程序命名时不要采用 Micro/WIN 缺省的、或常见的库指令子程序名，如 SBR_x 等，以免将来调用时发生冲突。

第三步：在Properties（属性）标签中设置

图4. 设置指令库属性

其中：

  1. 指定指令库名称
  2. 指定要生成的库文件的目录路径
  3. 指定版本信息

第四步：在Protection（保护）标签中设置密码

图5. 设置密码

密码设置是可选项。密码须输入两次以验证。保护后不知道密码的人不能查看库指令的程序

第五步：按OK按钮确定，输出指令库文件

图6. Micro/WIN的消息输出窗口显示指令库文件的详细信息

指令库文件扩展名为.mwl，缺省情况下存在Micro/WIN安装目录下的lib文件夹中。库文件可以作为单独的文件拷贝、移动。

添加指令库

注意：添加自定义指令库，需要关闭编辑库指令的项目，新建立一个项目。如果要添加其他来源的库指令自然不需要如此。

第一步：在Micro/WIN的File（文件）菜单中选择Add/Remove Libraries...（添加/删除指令库）命令 ；或者在指令树的Libraries（指令库）分支上单击鼠标右键，选择Add/Remove Libraries...

图7. 选择添加/删除指令库命令

添加/删除对话框中将显示已经在本机的Micro/WIN中集成的用户自定义指令库。

图8. 已安装的库指令

第二步：按Add（添加）按钮，选择新定义的库文件路径。用户自定义库将自动添加到Micro/WIN指令树的Libraries分支下。

图9. 选择库文件

缺省情况下，Micro/WIN到图8中的路径下寻找库指令文件。用户也可以指定其他路径。但要注意库文件应当保持在非移动的介质上，如果指定了一个可移动硬盘，则硬盘不在时会发生找不到库的错误。建议用户使用缺省设置。

删除库指令

第一步：选择添加/删除指令库命令

图10. 选择命令

第二步：选中须卸载的库所对应的库文件，按Remove（删除）按钮

图11. 选中要删除的库指令文件

调用用户定义指令库

指令库的使用方法与子程序基本一样。

常问问题

如何编制一个用户自定义库，使之像西门子的库一样在调用时可以灵活分配库指令内存（V存储区）？

在编程时，凡用到V存储区地址处都使用“符号寻址”，为每个变量指定一个符号。然后按照上述方法生成自定义库。注意此时使用V存储区的绝对寻址，或者定义符号表有误，则不能正常生成库指令。


分配库指令数据区

调用STEP 7 - Mciro/WIN32 V3.2 Instruction Library（指令库）需要分配库指令数据区（Library Memory）。库指令数据区是相应库的子程序和中断程序所要用到的变量存储空间。

如果在编程时不分配库指令数据区，编译时会产生许多相同的错误（错误18）。

操作步骤（以Modbus RTU库指令为例）：

  1. 在指令树的Project（项目）中，以鼠标右键单击Program Block（程序块），在弹出的快捷菜单中选择Library Memory。如图1所示：

    图1.

  2. 在弹出的选项卡中设置库指令数据区，如图2所示：

    图2. 缺省情况下是从VB0开始，但因为与Modbus的保持寄存区冲突，所以手动改为VB2000。按“Suggest Address”按钮也可以自动分配。

参见：Modbus库指令应用

可以使用Suggest Address（推荐地址）设置数据区，但要注意编程软件设置的数据区地址，只考虑到了其他一般寻址，而未考虑到诸如Modbus数据保持寄存器区等的设置。应当确保不与其他任何已使用的数据区重叠、冲突。不应重复按Suggest Address按钮，否则也会造成混乱。

在STEP 7-Micro/WIN32 V3.1中，有分配库指令数据区时有不同的操作方法，需要在Symbol Table（符号表）中设置一个首地址。我们强烈建议使用当时最新的编程版本。


Libraries - add on

附加指令库

此处收集了一些未随西门子指令库安装文件正式发行的附加指令库。这些指令库大多数来自西门子的内部的研发或技术支持工程师。

用户可以根据自己的需要选用这些指令库。使用 Micro/WIN 的“添加指令库”功能把库文件添加到 Micro/WIN 中，以便 编程中使用。

注意：这些指令库的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。


STEP 7 Micro/WIN 指令库下载网址大全

STEP 7 Micro/WIN可以集成两种类型的指令库，西门子提供的标准指令库和用户自定义的指令库。

1 标准指令库—Toolbox_V32-STEP 7-Micro WIN 32 Instruction Library

功能：该标准指令库包括USS通信和Modbus RTU Slave/Master通信协议库。
下载地址：受限下载，需要拨打技术支持热线4008104288 申请临时下载链接。

2 STEP 7 Micro/WIN附加指令库

注意：下面这些库指令安装文件不是标准指令库，大多数来自西门子的内部研发或是技术支持工程师。这些指令库的作者和拥有者对于该软件的功能性和兼容性不负任何责任，使用这些指令的风险完全由用户自行承担。西门子不提供任何担保、错误纠正和热线支持，用户不必为此联系西门子技术支持部门。

2.1 Toggle

功能：使用该库指令可以实现一个输出线圈随输入点接通而不断翻转状态。
下载地址：http://support.automation.siemens.com/CN/view/zh/1032831

2.2 rising_falling_edge

功能：由于S7-200 CPU仅支持256个边沿计算，使用该库指令可以在主程序或子程序中使用无限个上升沿和下降沿。
下载地址：http://support.automation.siemens.com/CN/view/zh/17542200

2.3 Clock_integer

功能：由于S7-200时钟指令的数据格式是BCD码，使用该库指令可以直接读取S7-200 CPU时钟并以整数格式输出所读取的值。
下载地址：http://support.automation.siemens.com/CN/view/zh/19294366

2.4 Logic_operation

功能：使用该库指令可以添加 NEG（一个数字的二进制补码），NAND（是AND 运算符的配对运算符，NAND的输出仅在所有输入都具有状态1时才会具有状态0），NOR（是OR运算符的配对运算符，NOR的输出仅在所有输入都具有状态 0时才会具有状态 1），和NXOR（是XOR 运算符的配对运算符，当输入具有不同状态值时，NXOR的输出具有状态0）指令。
下载地址：http://support.automation.siemens.com/CN/view/zh/18251129.

2.5 modulo

功能：使用该库指令可以实现取模功能，可以检查一个数是否可以被另一个数整除（取模运算中结果是否为0）。
下载地址：http://support.automation.siemens.com/CN/view/zh/18251123

2.6 logo_function

功能：使用该库指令可以实现LOGO!的脉冲继电器功能。
下载地址：http://support.automation.siemens.com/CN/view/zh/19141713

2.7 real_compare

功能：在S7-200中实数精确到6个小数位，在使用包括较大数和很小数的很多数值来计算实数时，可能会生成不精确的结果。该库指令可以准确的进行浮点数比较。
下载地址：http://support.automation.siemens.com/CN/view/zh/17924241

2.8 graycode

功能：使用该哭指令可以实现怎样二进制码和格雷码之间的互转。
下载地址：http://support.automation.siemens.com/CN/view/zh/26485059

2.9 shutter_control

功能：使用该库指令可以实现不使用感光开关，使用S7-200来控制百叶窗的日出而开和日落而关。
下载地址：http://support.automation.siemens.com/CN/view/zh/35146699

2.10 Counter_DINT

功能：使用该库指令可以实现S7-200 CPU计算大于16 位的循环计数。
下载地址：http://support.automation.siemens.com/CN/view/zh/35096610

2.11 Ramp

功能：使用该库指令可以实现S7-200限制浮点数输出阶跃的坡度。
下载地址：http://support.automation.siemens.com/CN/view/zh/34617648

2.12 MAP SERV

功能：使用该库指令可以实现S7-200本体脉冲输出进行伺服驱动轴的定位功能。
下载地址：http://support.automation.siemens.com/CN/view/zh/26513850

2.13 TD200_Bar

功能：使用该库指令可以在TD200或TD200C中显示棒图。
下载地址：http://support.automation.siemens.com/CN/view/zh/29268687

2.14 Frequency

功能：使用该库指令可以测定高速脉冲串的频率和速度。
下载地址：http://support.automation.siemens.com/CN/view/zh/27864874

2.15 scale

功能：使用该库指令可以实现S7-200模拟量值比例换算。
下载地址：http://support.automation.siemens.com/CN/view/zh/27043396

2.16 BCD

功能：使用该库指令可以实现将双整数DINT与BCD码互转。
下载地址：http://support.automation.siemens.com/CN/view/zh/25943079

2.17 Sign operation

功能：使用该库指令可以实现数值求绝对值和求反(反号).
下载地址：http://support.automation.siemens.com/CN/view/zh/25939521

2.18 arc functions

功能：使用该库指令可以实现S7-200反三角函数arcsin，arccosin和arctan功能。
下载地址：http://support.automation.siemens.com/CN/view/zh/19308841

2.19 Three step

功能：使用该库指令可以实现PID回路三步控制。
下载地址：http://support.automation.siemens.com/CN/view/zh/18748232

2.20 store_to_eeprom

功能：使用该库指令可以实现将数据写入EEPROM存储空间。
下载地址：http://support.automation.siemens.com/CN/view/zh/17471561

2.21 gps_time_read_port0/1

功能：使用该库指令可以实现利用GPS 接收器同步S7-200的实时时钟。
下载地址：http://support.automation.siemens.com/CN/view/zh/38657846

2.22 time_connection

功能：使用该库指令可以实现利用SINAUT MICRO SC同步S7-200 CPU的实时时钟。
下载地址：http://support.automation.siemens.com/CN/view/zh/29712594

2.23 Daytime_saving_time_S7-200

功能：使用该库指令可以实现S7-200系统实现的夏令时开始和结束时间的调整。
下载地址：http://support.automation.siemens.com/CN/view/zh/25547955

2.24 SinautMicroSC

功能：使用该库指令可以现实MD720-3通信。
下载地址：http://support.automation.siemens.com/CN/view/zh/24842373

2.25 Set5_S7-200-library_P0/1

功能：使用该库指令可以实现S7-200用MD720-3通过SMS进行无线信号发送和交换。
下载地址：http://support.automation.siemens.com/CN/view/zh/21063345


Library - Clock Integer

Clock_Integer 指令库及其使用

使用 S7-200 的 READ_RTC（读取实时时钟）和 SET_RTC（设置实时时钟）指令时， 读取和设置的数据格式都是 BCD 码的。如果觉得不便计算、处理，可使用 Clock Integer 指令库。

Clock_Integer 指令库用于将 BCD 码格式的 S7-200 日期、时间转换为十进制整数格式，以及将十进制整数格式的日期、时间值设定为 S7-200 时钟。

注意：此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

要使用 Clock_Integer 指令库，须遵循下列步骤：

  1. 取得 Clock_Integer 指令库文件，并添加到编程软件 STEP 7-Micro/WIN 中；
  2. 按照要求编写用户程序调用 Clock_Integer 指令库。

添加 Clock_Integer 指令库

Clock_Integer 指令库

点击上面的链接下载 Clock_Integer 指令库到本地计算机硬盘，建议保存在 Micro/WIN 安装目录的 Lib 文件夹中。以下是一个完整路径的例子：

C:\Program Files\Siemens\STEP 7-Micro/WIN V4.0\Lib

然后将指令库库手动添加到 Micro/WIN 软件中。

参见添加指令库。

成功添加指令库后，用户可以在STEP7 Micro/win的指令树中找到‘Clock_Integer (v1.0)'

图1.Clock_Integer 库

Clock_Integer 指令库编程应用 － 读取系统时钟

1、调用 READ_RTC_I，读取 PLC 时钟 ，并将其转换为十进制整数格式 ：

图 2. READ_RTC_I

表 1. READ_RTC_I参数
参数 | 数据类型 | 注释
EN | BOOL | 信号为‘1’时激活库指令
Address | DWORD | 起始偏移地址，转换为十进制格式的 PLC 时钟被保存在以此地址为起始地址的 8 个字节中

2、分配库存储区：

调用指令 READ_RTC_I 或 SET_RTC_I 后，必须定义 8 位（一个字节）的 V 存储区为库存储区。

参考：分配库指令数据区

表2. 8 字节时间缓冲区的格式
Address | 年
Address＋1 | 月
Address＋2 | 日
Address＋3 | 小时
Address＋4 | 分钟
Address＋5 | 秒
Address＋6 | 保留
Address＋7 | 星期(1)
(1) 1 = 星期天；7 = 星期日；0 = 禁止星期

如图 2 所示，当 V50.0 为 ‘1’ 时，转换后的实时时钟被存储在 VB10 至 VB17 中。

在状态表中用户可以看到：

图3.状态表

可以看出，此时的 PLC 时钟为： 2006 年 4 月 6 日，23 时 48 分 1 秒，星期四。

注意：此指令库读取的整数格式时钟数据以连续字节的形式保存，而后续的整数运算需要一个字（两个字节）长度的数据。编程时要注意这一点。

Clock_Integer 指令库编程应用 － 设置系统时钟

1、调用 SET_RTC_I，将以十进制整数格式存储的日期时间设定为 PLC 时钟

图4.SET_RTC_I

参数 | 数据类型 | 注释
EN | BOOL | 信号为‘1’时激活库指令
Address | DWORD | 起始偏移地址，以此地址为起始地址的 8 个字节中，应已经存储着用户时间数据

表 3. SET_RTC_I 参数

8 字节时间缓冲区的格式同表 2。

2、分配库存储区：

调用指令 READ_RTC_I 或 SET_RTC_I 后，必须定义 8 位（一个字节）的 V 存储区为库存储区。

参考：分配库指令数据区

Clock_Integer 指令库应用例程

Clock_Integer 指令库例子程序

注意：该例程必须使用 Micro/WIN V4.0 SP3 或以上版本软件打开。

注意：此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

注意：

  • CPU221、CPU222 没有内置的实时时钟，需要外插“时钟/电池卡”才能获得此功能。
  • 只有 STEP7 Micro/Win V3.2+SP4 和 V4.0 版本才支持使用该指令库。
  • 在使用 ‘SET_RTC_I’ 设定 PLC 时钟时，被设定的时间必须有实际意义，否则设定操作不能成功完成。例如： 不能将月份设为 13，或者将分钟设为 61 等。
  • Address 端必须输入地址指针，如：&VB10，&VB20；或者为双字地址，如：VD100，MD10，AC0等，在该地址中存有地址。

常问问题：

Clock_Integer 指令库和 Micro/WIN 指令树中的读、写实时时钟指令有什么不同？

Clock_Integer 指令库读出或写入的 PLC 时钟是以十进制整数格式存储；而读、写实时时钟指令读出或写入的 PLC 时钟为 BCD 码格式。

关于读写实时时钟指令，请参考： S7-200 的实时时钟 。


Library - EEPROM

EEPROM 数据写入指令库及其使用

EEPROM（v1.0)指令库用于将连续 V 存储区中的数据（例如：VB200 至 VB205）写入 EEPROM，使其永久保持。

注意：此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

参考：CPU的数据保持功能
参考：使用超级电容和电池卡进行数据保持－系统块数据保持设置

要使用 EEPROM 指令库，须遵循下列步骤：

  1. 取得 EEPROM 指令库文件，并添加到编程软件 STEP 7-Micro/WIN 中；
  2. 按照要求编写用户程序调用 EEPROM 指令库。

添加 EEPROM 指令库

EEPROM 指令库

点击上面的链接下载 EEPROM 指令库到本地计算机硬盘，建议保存在 Micro/WIN 安装目录的 Lib 文件夹中。以下是一个完整路径的例子：

C:\Program Files\Siemens\STEP 7-Micro/WIN V4.0\Lib

然后将指令库库手动添加到 Micro/WIN 软件中。

参见添加指令库。

成功添加指令库后，用户可以在STEP7 Micro/win的指令树中找到‘EEPROM（V1.0)'

图 1. EEPROM 指令库

EEPROM 指令库编程

1、直接寻址方式存储

图2.EEPROOM_Direct

输入/输出 | 数据类型 | 注释
EN | BOOL | 必须持续为1（高电平）
Start | BOOL | 触发位，0->1上升沿变化激活”StoreToEprom”库指令
V_Start | INT | 被保持数据的起始偏移地址 （例如：200=VB200）
Length | INT | 被存储数据的长度（以字节为单位）
Memory | INT | ”StoreToEprom”库指令需要的临时存储区（Word）
Busy | BOOL | ”StoreToEprom”库指令在保存数据的过程中，值为1
Done | BOOL | ”StoreToEprom”库指令数据保存完成后，值为1

表1.EEPROM_Direct 参数

2、间接寻址方式存储

图3.EEPROM_Indirect

输入/输出 | 数据类型 | 注释
EN | BOOL | 必须持续为1（高电平）
Start | BOOL | 触发位，0->1上升沿变化激活”StoreToEprom”库指令
V_Start | INT | 该存储区中存储着被保持数据的起始偏移地址 例如：LD Q0.0 MOVD &VB200, MD20 此时MD20中存储着VB200的地址
Length | INT | 被存储数据的长度（以字节为单位）
Memory | INT | ”StoreToEprom”库指令需要的临时存储区（Word）
Busy | BOOL | ”StoreToEprom”库指令在保存数据的过程中，值为1
Done | BOOL | ”StoreToEprom”库指令数据保存完成后，值为1

表2.EEPROOM_Indirect参数

注意：

  1. 此库指令每个 CPU 循环周期向 EEPROM 备份一个字节数据，因此备份多个数据往往需要多个 CPU 循环周期，必须保证该时间段内使能端（EN ）持续为‘1’。建议用户用 SM0.0 调用库指令。
  2. 如果用户需要永久存储的是实数或双字整数，必须保证保存过程中数据保持不变。
  3. EEPROOM 被刷写次数的典型值为 100,000 次，因此用户不得以较高的频率向 EEPROM 中备份数据。
  4. 只有 STEP7 Micro/Win V3.2+SP4 和 V4.0 版本才支持使用该指令库


Library - Arcusfunctions

Arcusfunctions （反三角函数）指令库及其使用

在 STEP 7 Micro/Win 软件的标准指令集中的浮点数运算指令中，已经提供了 sin（正弦），cos（余弦），tan（正切）三个正三角函数。如果用户需要使用反三角函数运算，可以使用下列“Arcusfunctions指令库”，指令库包含了 ARCTAN(反正切)，ARCCOS(反余弦)，ARCSIN(反正弦)三个运算指令。

添加 Arcusfunctions （反三角函数）指令库

Arcusfunctions 指令库

点击上面的链接下载 反三角函数指令库到本地计算机硬盘，建议保存在 Micro/WIN 安装目录的 Lib 文件夹中。以下是一个完整路径的例子：

C:\Program Files\Siemens\STEP 7-Micro/WIN V4.0\Lib

然后将指令库库手动添加到 Micro/WIN 软件中。

参见添加指令库。

成功添加指令库后，用户可以在 STEP7 Micro/win 的指令树中找到：Arcusfunctions(v1.0)

图 1. 反三角函数指令库

Arcusfunctions 指令库的应用

图 2. 反三角函数库编程举例

库指令 | 功能
ARCTAN | 反正切运算
ARCCOS | 反余弦运算
ARCSIN | 反正弦运算

参数 | 数据类型 | 注释
EN | BOOL | 信号为‘1’时激活库指令
Input | REAL | 反三角函数值(即反正切,反余弦,反正弦值)
Output | REAL | 角度值(以弧度为单位)

常问问题:

弧度与角度如何换算?

π = 180°

常用的三角函数公式

1. 同角三角函数的基本关系式

tanα ·cotα＝1 | sinα/cosα＝tanα＝secα/cscα | sin2α＋cos2α＝1
sinα ·cscα＝1 | cosα/sinα＝cotα＝cscα/secα | 1＋tan2α＝sec2α
cosα ·secα＝1 |  | 1＋cot2α＝csc2α

2. 诱导公式:

sin（－α）＝－sinα | cos（－α）＝cosα | tan（－α）＝－tanα | cot（－α）＝－cotα
sin（π/2－α）＝cosα | cos（π/2－α）＝sinα | tan（π/2－α）＝cotα | cot（π/2－α）＝tanα
sin（π－α）＝sinα | cos（π－α）＝－cosα | tan（π－α）＝－tanα | cot（π－α）＝－cotα
sin（3π/2－α）＝－cosα | cos（3π/2－α）＝－sinα | tan（3π/2－α）＝cotα | cot（3π/2－α）＝tanα
sin（2π－α）＝－sinα | cos（2π－α）＝cosα | tan（2π－α）＝－tanα | cot（2π－α）＝－cotα
sin（π/2＋α）＝cosα | cos（π/2＋α）＝－sinα | tan（π/2＋α）＝－cotα | cot（π/2＋α）＝－tanα
sin（π＋α）＝－sinα | cos（π＋α）＝－cosα | tan（π＋α）＝tanα | cot（π＋α）＝cotα
sin（3π/2＋α）＝－cosα | cos（3π/2＋α）＝sinα | tan（3π/2＋α）＝－cotα | cot（3π/2＋α）＝－tanα
sin（2kπ＋α）＝sinα | cos（2kπ＋α）＝cosα | tan（2kπ＋α）＝tanα | cot（2kπ＋α）＝cotα
 |  |  | 其中k∈Z

3. 两角和差公式:

sin（α＋β）＝sinαcosβ＋cosαsinβ
sin（α－β）＝sinαcosβ－cosαsinβ
cos（α＋β）＝cosαcosβ－sinαsinβ
cos（α－β）＝cosαcosβ＋sinαsinβ
tan（α＋β）=( tanα＋tanβ ) / ( 1－tanα ·tanβ )
tan（α－β）＝( tanα－tanβ ) / ( 1＋tanα ·tanβ )

4.万能公式

以上三角函数公式均为抄录，如有差错，以数学书为准！ 如需更多公式,请自行参考相关书籍。

5. 特殊三角函数值


25943079_76

STEP 7 Micro/WIN 中将双整数(DOUBLE INTEGER) 转换 BCD (或者相反)

STEP 7 Micro/WIN 中，可以使用 I_BCD 和 BCD_I (见Instructions -> Convert) 指令将 16位整数 (INTEGER) 转换为 BCD 码或者相反 （BCD->INT)。使用下面提供的可下载的指令库，可以将32位整数 (DOUBLE INTEGER) 转换为BCD 码或者做相反转换 (BCD->DOUBLE INTEGER)。

注意此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

“BCD” 库的描述

“BCD.mwl” 库包含了功能 DI_BCD ( 双整数到 BCD 码的转换) BCD_DI ( BCD 码到双整数的转换)。

BCD.zip ( 2 KB )

点击上面的链接下载 BCD 指令库到本地计算机硬盘，建议保存 Micro/WIN 安装目录的 Lib 文件夹中。以下是一个完整路径的例子
C:\Program Files\Siemens\STEP 7-Micro/WIN V4.0\Lib

然后将指令库手动添加到 Micro/WIN 软件中。

参见添加指令库

成功添加指令库后，用户可以在STEP7 Micro/win的指令树中找到 “BCD(V1.0)”。

图1. I_BCD 和 BCD_I 指令

双整数转换为 BCD 码 (DI_BCD) :

DI_BCD 功能将 32 位正整数，0 到 9,999,999 之间的数转换为二进制编码的十进制数（BCD）。

图2. DI_BCD 编程

如果输入负数或大于 9,999,999 的数，ENO 使能输出位被复位并且转换结果无效。
参数 | 数据类型 | 操作?/b> | 描述
EN | [BOOL] | E, A, M, L, V | 输入使能
ENO | [BOOL] | E, A, M, L, V | 输出使能
IN | [DWORD] | VD, ED, AD, MD, SD, SMD, LD, T, Z, AED, AC, HC, Constant, *VD, *AC, *LD | 要转为 BCD 码的32 位整数
OUT | [DWORD] | VD, ED, AD, MD, SD, SMD, LD, T, Z, AC, *VD, *LD, *AC | BCD 码
表 1. DI_BCD 参数

BCD 码转换为双整数 (BCD_DI)

BCD_DI 功能将正的 32 位 BCD 码，从 0 到16#99999999 之间的数转换为 32 位双整数。

图 3. BCD_DI 编程

16进制字母 (A-F) 不会被转换。这时 ENO 使能输出位被复位并且转换结果无效。
Parameter | Data type | Operands | Description
EN | [BOOL] | E, A, M, L, V | Enable input
ENO | [BOOL] | E, A, M, L, V | Enable output
IN | [DWORD] | VD, ED, AD, MD, SD, SMD, LD, T, Z, AED, AC, HC, Constant, *VD, *AC, *LD | BCD number
OUT | [DWORD] | VD, ED, AD, MD, SD, SMD, LD, T, Z, AC, *VD, *LD, *AC | Integer value (32-bit) of the BCD number

表 2. BCD_DI 参数


密码保护

S7-200系统提供了强大的密码保护功能，以保护程序开发者的知识产权，防止未经授权的操作等。

密码不能破解，用户不必为此咨询西门子技术支持部门。

在许多场合都可以使用密码，多种密码可以并存，各自发挥作用。

  • CPU加密
    为CPU设置密码以限制对CPU的访问。在Micro/WIN的System Block（系统块）中设置CPU密码。

  • POU加密
    为POU设置密码可以保护主程序、子程序和中断程序。

  • Project（项目文件）加密
    STEP 7-Micro/WIN V4.0版本以上支持对整个程序文件加密。

  • Data Block（数据块）加密
    为数据块加密码保护，以限制随意的改动。

  • TD 200加密
    为TD 200配置时设置密码，可以限制对TD 200设置菜单和嵌入数据的访问、修改。

  • EM241加密
    对Modem模块EM241进行配置时可以设置密码，以限制未经允许的访问，或者验证回拨功能等。


密码－清除CPU密码

如果我忘了密码，如何访问一个带密码的CPU？

即便CPU 有密码保护，你也可以不受限制地使用以下功能：

  • 读写用户数据
  • 启动，停止 CPU
  • 读取和设置实时时钟

如果不知道密码，用户不能读取或修改一个带三级密码保护的CPU中的程序。S7-200CPU没有所谓的“通用密码”可以越过现有的密码保护， 将程序读取的电脑中。

清除密码：

如果你不知道CPU的密码，你必须清除CPU内存，才能重新下装程序。执行清除CPU 指令并不会改变CPU原有的网络地址、波特率和实时时钟；如果有外插程序存储卡，其内容也不会改变。

清除密码后，CPU中原有的程序将不存在。

  1. 要清除密码，可按如下操作：

    • 在Micro/WIN中选择菜单“PLC > Clear”
    • 选择所有三种块并按"OK"确认

      图1. 选择要清除的块

    • 输入“CLEARPLC”

      图2. 输入清除密码

    “CLEARPLC”是所有密码的通用清除口令，但会引起相关程序等的丢失。

  2. 另外一种方法是通过程序“wipeout.exe”来恢复CPU 的缺省设置。这个程序可在STEP 7-Micro/WIN 安装光盘中找到；或者在ProDIS网站上下载，FAQ号2123168。

    执行程序“wipeout.exe”不仅删除用户程序，而且会将CPU恢复成缺省设置，即网络地址：2、波特率：9.6K。

    注意：wipeout.exe软件不能与USB/PPI电缆配合使用。

  3. 另外，还可以在CPU上插入一个含有未加密程序的外插存储卡，上电后此程序会自动装入CPU并且覆盖原有的带密码的程序。然后CPU可以自由访问。

我们建议您保存好程序的备份。而程序注释只存在于离线程序，并没有下载到CPU。

ProDIS的FAQ17551345

对于POU（程序组织单元，包括子程序、中断程序等）的密码，如果忘记则无法打开。

常问问题

S7-200 有没有通用密码以清除已经设置的密码？

清楚密码的通用口令是“clearplc”，但使用此口令的后果是丢失所有受保护的内容。

设置了CPU密码后，为何看不出密码已经生效？

在系统块中设置了CPU密码并下载后，因为你仍然保持了Micro/WIN与CPU的通信连接，所以CPU不会对设置密码的Micro/WIN做保护。

要检验密码是否生效，可以：

  • 停止Micro/WIN与CPU的通信一分钟以上
  • 关闭Micro/WIN程序，再打开
  • 停止CPU的供电，再送电


密码－POU加密

POU加密

POU即程序组织单元，包括S7-200项目文件中的主程序（OB1）、子程序和中断服务程序。

POU可以单独加密，加密后的POU会显示一个锁的标记，不能打开查看程序内容。程序下载到CPU中，再上载后也保持加密状态。

西门子公司随编程软件Micro/WIN提供的库指令、指令向导生成的子程序、中断程序都加了密。加密并不妨碍使用它们。

加密

操作步骤：

  1. 选择查看POU的Properties（属性）：

    1. 在指令树中选择要加密的POU，单击鼠标右键，选择Properties...

      图1. 在指令树中用右键查看属性

    2. 在程序编辑器窗口中，选择要加密的POU的标签，单击鼠标右键，选择Properties...

      图2. 在程序编辑器选择POU标签查看属性

  2. 在属性中选择Protection（保护）标签

    图3. 设置POU密码

    在上图中：

    1. 选择密码保护多选框
    2. 输入密码， 密码最多可以有4个字母或数字，大小写不论
    3. 再次输入密码，确保无误

在程序编辑器和指令树中的POU如果有锁的标记，说明是一个加密的POU，非经密码验证无法查看、编辑。

加密的POU不知道密码也一样使用。虽然看不到程序内容，在程序编辑器中也可以查看其局部变量表的符号名、关数据类型、注释等信息。

验证POU密码

  1. 如上打开POU的属性对话框，选择Protection标签

    图4. 验证POU密码

  2. 在文本输入框中输入密码，然后按Authorize按钮，就可以正常查看POU的内容。前提当然是知道正确的密码。


密码－项目文件加密

Project（项目文件）加密

使用STEP 7-Micro/WIN V4.0以上版本，用户可以为整个Project（项目）文件加密，使不知道密码的人无法打开项目。

行Micro/WIN的File（文件）菜单中的Set Password（设置密码）命令，在弹出的对话框中输入最多16个字符的项目文件密码。

密码可以是字母或数字的组合，区分大小写。


Online - Certificates

系列视频：S7-200跟我学/跟我做:

S7-200CN: 变量符号表-跟我学 - 38/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=287
S7-200CN: 变量符号表-跟我做 - 39/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=288

符号表

在符号表中，允许您定义编辑符号名以及添加变量的注释，如下图 1 所示：

图1. 符号表

在 STEP 7-Micro/WIN 中，可以建立多个符号表，但不允许将相同的符号名多次用作全局符号赋值，在单个符号表中和几个符号表内均不得如此。可以在多个不同局部变量表中多次使用相同的符号名称。

符号名的最大长度为 23 个字符。

在注释栏最多允许键入 79 个字符。

寻址方式

在 STEP 7 Micro/Win 软件中可选择两种不同的寻址方式：绝对地址寻址或符号寻址。

１. 绝对地址寻址

选择“查看”>取消 “符号寻址”菜单命令，所有的变量都将以绝对地址寻址，并且在程序中仅作为绝对地址显示。如下图 2 所示：

图2. 取消符号寻址

绝对地址用存储区加上位或字节地址来标识地址（例如，I0.0），如下图 3 所示：

图3. 绝对地址寻址

２. 符号寻址

在符号表中定义符号名后不仅能用绝对地址访问变量，也能用符号地址访问变量。在 STEP 7 Micro/Win 软件中选择“查看”>打开 “符号寻址”菜单命令。如下图 4 所示：

图4. 打开符号寻址

符号地址用一串字符组合来标识地址（例如，启动），如下图 5 所示：

图5. 符号寻址

符号寻址显示方式

如果打开如上图 4 所示的 “符号寻址”，您可以选择在程序中是否仅查看符号还是查看符号和绝对地址。

在 STEP 7 Micro/Win 软件中通过“工具”> “选项> “程序编辑器”> “符号寻址”来选择在程序中仅显示符号或是显示符号和地址。如下图 6,7 所示：

图6. 选项

图7. 选择符号寻址显示方式

（1）仅显示符号：所有的地址仅显示符号名；

（2）显示符号和地址：所有的地址既显示符号也显示绝对地址。如下图 8 所示：

图8. 显示符号和地址

只有在打开符号寻址视图时，才能在项目中显示符号地址。否则，即使您选择了“显示符号和地址”，也只会显示绝对地址。

常见问题

在符号表中修改变量的符号名后，为何程序中仍然显示为修改前的符号名且该字符显示绿色波浪下划线？如下图 9 所示：

图9. 符号名显示不正确

原因：以上现象是因为在“符号寻址”方式下直接在符号表中修改了变量的符号名。

解决方式：如果要修改变量的符号名，应先按“绝对地址”寻址，修改符号名之后再恢复“符号寻址”方式。具体按照以下步骤操作：

1. 选择“查看”>取消“符号寻址”，如下图 10 所示：

图10. 取消符号寻址

2. 在符号表中修改变量（例如将地址I0.0的符号名由“启动”改为“停止”），如下图 11 所示：

图11. 修改后的符号名

3. 选择“查看”>打开“符号寻址”，如下图 12 所示：

图12. 打开符号寻址

程序中显示为修改后的符号名，如下图 13 所示：

图13. 符号名修改后的程序


Micro/WIN - S7-200资源管理器

S7-200资源管理器

S7-200资源管理器是Windows资源管理器的扩展，支持标准的Windows浏览及其它特性。S7-200资源管理器除了可以读取数据归档记录，还可以自由访问S7-200的存储卡里的其它文件，这些用户文件的类型包括：Word文档、位图文档，JEPG文件或STEP7-Micro/WIN项目。用户可以使用拖拽、拷贝、粘贴、剪切等功能，其操作与Windows资源管理器的操作相同。

图1. S7-200资源管理器

S7-200资源管理器是STEP7 Micro/WIN软件的一部分，随 Micro/WIN软件安装时一同安装在PC机上。为便于维护，用户也可单独安装 S7-200资源管理器，其安装软件可从西门子网站上下载。

如果已经安装了S7-200资源管理器，在Windows资源管理器中可以发现“My S7-200 Network”的文件夹，在这个文件夹下还可以看到所有网上的S7-200设备（如下图）。

图2. S7-200资源管理器文件夹

S7-200资源管理器和S7-200 CPU 的通信接口与Micro/WIN相同。可以支持PPI/MPI/PROFIBUS-DP，也可以支持Modem 或以太网通信。在S7-200资源管理器中，可以通过Set PG/PC Interface 来定义或改变它的通信方式。

S7-200资源管理器用于从存储卡中读取数据归档，生成CSV文件，存储在PC机的数据归档（Data Log）目录下。

若需要上载数据记录，可以直接打开Windows的资源管理器，在My S7-200 Network文件夹中，选择需要上载数据记录的S7-200 CPU的存储卡，并用鼠标右击上载的数据记录文件，其缺省名字为DAT Configuration x（DATx)，然后在右键菜单中选择Upload（上载）即可（如图3）。也可利用Windows的任务进度工具（Scheduling Task）将数据归档记录设定为在某一时刻自动上载到PC机。

常问问题

如何使用Windows的“计划任务”工具（Scheduled Task）将数据归档记录设定为在某一时刻自动上载到PC机？

微软的操作系统提供了任务进度工具，用户可以使用它设置在某一时刻将数据归档自动上载到PC机。其设置步骤如下：

1. 在S7-200资源管理器在线情况下，右键单击存储卡中的数据归档记录文件，在右键菜单中单击“创建快捷方式（Creat Shortcut)”。

图3. 创建数据归档快捷方式

2. 在Windows的控制面板中，双击“Scheduled Task（计划任务）”

图4. 双击控制面板中的“Scheduled Task（计划任务）”

3. 将数据归档记录的快捷方式粘贴在“Scheduled Task（计划任务）”目录下，并双击该快捷方式进行设置。

图4. 粘贴数据归档快捷方式并双击

4. 输入登陆密码

若所使用的PC机设置有操作系统的登录密码，则必须点击图4中的“Set Password”按钮，将该密码正确输入并确认（如图6）

图6. 输入登录密码并确认

5. 进入“Schedule（进度）”进行设置（如图7）

图7. 进度设置

6. 点击图6中的“Advanced（高级）”按钮设置高级选项（如图8）

图8. 设置高级选项

按照以上设置，PC机将每天9点开始，每隔 10 分钟将存储卡中的数据归档自动上载一次，持续一个小时结束。

上载的数据归档文件将自动存储在以下目录下：

C:\Program Files\Siemens\MicroSystems\Data Logs


打开老项目文件

如何打开老版本Micro/Win创建的项目文件

在正版STEP 7-Micro/WIN软件光盘中，都可在Old Realeses文件夹中找到V2.1版本的Micro/WIN安装软件，此版本的Micro/WIN可打开以前老版本创建的项目文件。通过它作为桥梁，另存老版本的软件后，可在最新版本STEP 7-Micro/WIN软件中打开。

具体步骤举例如下：

  1. 安装V2.1版本的Micro/WIN软件
  2. 在V2.1版本的Micro/WIN中打开项目文件，在View中转换成STL（语句表）形式，并另存为一个新文件
  3. 在STEP 7-Micro/WIN32 V3.2+SP4中打开在V2.1版本另存的新文件，打开时在Files of type（文件类型）中选择Micro/WIN 1.x,2.x Projects打开，如下图：

    图1. 选择按老版本文件打开

    注：如果打开后发现有的网络显示为红色的invalid(非法)，则可能是PLC型号太低、版本太旧了，此时可选择高型号或者新版本的CPU。如：在命令菜单的PLC > Type中将CPU222改为CPU224。
  4. 然后再在Micro/WIN32 V3.2+SP4中另存为一个新项目文件，即变成了新版本的应用程序


Micro/WIN常见相关问题

STEP 7-Micro/WIN的相关常问问题

如何知道自己所编程序大小？

Micro/WIN中的命令菜单中执行PLC>Compile后，在Micro/WIN下方的显示窗口（消息输出窗口）可找到你所编程序的大小、占用数据块的大小等。

编译出错怎么办？

在编译后，如果有错，将不能下装程序到CPU。可在Micro/WIN下方的窗口查看错误，双击该错误即进入到程序中该错误所在处，根据系统手册中的指令要求进行修改。

如何知道自己所编程序的扫描时间?

在程序运行过一次以后，可在Micro/WIN中的命令菜单中在线查看PLC>Information可找到CPU中程序的扫描时间。

如何监视程序和数据状态？

如要对程序进行监视，则在命令菜单中进入Debug>Program Status或者点击工具栏上的程序状态Program Status 按钮 [image] 。

如要对某一位或某一数据的值进行监视，则在命令菜单中进入Debug>Chart Status或者点击Micro/WIN中左边View浏览条中的状态表按钮 [image] ；然后在表中Address栏中输入需要监视的数据地址，点击工具栏上Chart Status按钮 [image] ，即可在当前值Current Value一栏中监视数据状态。

如何对数据进行强制？

有两种方式可以对数据进行强制（在数据被强制后，前面会出现一个锁的符号）：

  • 在上述提到的状态表 [image] 中，在New Value一栏中输入所要强制的新数值，对于数字量为0或1，对于模拟量为数值。然后点击工具栏上的相应功能按钮完成所需操作。

    Write All

    写入（此功能与强制的区别为在写入数据后，写入的数据值还会根据程序中的逻辑运算而改变。）
    Force
    强制
    Unforce
    解除单个强制
    Unforce All
    解除所有强制
    Read All Forced
    读取所有已强制的数据

  • 或者可在程序中要强制的结点或线圈地址上点右键，然后在快捷菜单中执行强制，解除强制以及写入命令。

如果指令不会用如何找到帮助？

如果某一指令不会用，除了可参考S7-200系统手册，还可以：

  • 在Micro/WIN中右击该指令后，在快捷菜单中进入Help，便可找到该指令的详细说明。

  • 用鼠标选中相应的指令，然后按“F1”键，会自动弹出相应的帮助文本。

如何查找所使用的程序地址空间是否重复使用？

在对程序进行编译后，可以点击View浏览条中的交叉引用（Cross Reference）按钮 [image] 进入，可以看到程序中所使用元素的详细的交叉引用信息及字节和位的使用情况。

在交叉引用中可直接点击该地址，便进入到程序中该地址所在处。

在编程软件Micro/WIN中打印时，打印的内容为什么会缩得很小？

请在菜单File（文件）> Page Setup（页面设置）中检查Margins（页边距）设置。打印机驱动程序与Micro/WIN所使用的微软打印驱动程序，可能在配合上出现问题造成页边距设置很大，从而没有地方打印程序。

解决这个问题的办法是把页边距的数值改小。

在线监控时，在程序块中为何指令功能块是红色？

如果在程序编辑器中在线监控，发现有红色的指令功能块，说明发生了错误或问题。从系统手册可以查到导致ENO=0的错误。如果是“非致命”故障，可以在菜单PLC > Information对话框中查看错误类型。

对于NetR/NetW（网络读/写）、XMT/RCV（自由口发送/接收） 、PLS等等与PLC操作系统或硬件设置有关的指令，在运行时变红，其最可能的原因是在指令仍然在执行的过程中多次调用，或者当时通信口忙。

在线监控时，在程序块中查看的数据为何都是16进制数值显示？

在程序块中的在线监控，没有地方可以设置Micro/WIN的数据显示格式，而16进制数是显示二进制数据的最简单的方法，数据的很多意义可以从16进制显示的值看出来（对于熟悉的人来说）。

参见：

S7-200中的数据格式


Basic - 数据类型

数据类型

S7-200的数据主要分为：

  • 与实际输入/输出信号相关的输入/输出映象区：

    • I：数字量输入（DI）
    • Q：数字量输出（DO）
    • AI：模拟量输入
    • AQ：模拟量输出

  • 内部数据存储区

    • V：变量存储区，可以按位、字节、字或双字来存取V 区数据
    • M：位存储区，可以按位、字节、字或双字来存取M区数据
    • T：定时器存储区，用于时间累计，分辨率分为1ms、10ms、100ms三种
    • C：计数器存储区，用于累计其输入端脉冲电平由低到高的次数。CPU提供了三种类 型的计数器：一种只能增计数；一种只能减计数；另外一种既可 以增计数，又可以减计数

常问问题

M区数据不够用怎么办？

回答：有些用户习惯使用M 区作为中间地址，但S7-200CPU中M区地址空间很小，只有32个字节，往往不够用。而S7-200CPU中提供了大量的V 区存储空间，即用户数据空间。V存储区相对很大，其用法与M 区相似，可以按位、字节、字或双字来存取V 区数据。例：V10.1， VB20， VW100， VD200等等。

数据寻址


数据格式

S7-200系统中的数据及其格式

S7-200 CPU收集操作指令、现场状况等信息，把这些信息按照用户程序指定的规律进行运算、处理，然后输出控制、显示等信号。

所有这些信息在S7-200 PLC中，都表示为不同格式的数据，作为数据来处理；按照其自身定义，格式不同的数据表示不同含义的信息。

在S7-200中，各种指令对数据格式都有一定要求，指令与数据之间的格式要一致才能正常工作。例如，为一个整数数据使用实数（浮点数）运算指令，显然会得到不正确的结果。

数据有不同的长度（以二进制表示它们时，占据的位数不同），也就决定了数值的大小范围。模拟量信号在进行模/数（A/D）和数/模（D/A）转换时，一定会存在误差；代表模拟量信号的数据，只能以一定的精度表示模拟量信号。

  • 所有的数据在PLC中都是以二进制形式表示的
  • 数据都有其特定的长度和表示方式，称为格式
  • 数据的格式与用于运算、处理它的指令相关
  • 以不同的格式查看一个数据，或是使用不同格式的指令处理它，会得到不同的效果

表1. S7-200支持的数据格式

寻址格式 | 数据长度 （二进制位） | 数据类型 | 取值范围
BOOL（位） | 1（位） | 布尔数 （二进制位） | 真（1）；假（0）
BYTE（字节） | 8 （字节） | 无符号整数 | 0 ~ 255；0 ~ FF（Hex）
INT（整数） | 16 （字） | 有符号整数 | - 32768 ~ 32767； 8000 ~ 7FFF（Hex）
WORD（字） |  | 无符号整数 | 0 ~ 65535； 0 ~ FFFF（Hex）
DINT （双整数） | 32 （双字） | 有符号整数 | - 2147483648 ~ 2147483647 8000 0000 ~ 7FFF FFFF（Hex）
DWORD （双字） |  | 无符号整数 | 0 ~ 4294967295； 0 ~ FFFF FFFF（Hex）
REAL （实数） |  | IEEE 32位 单精度浮点数 | -3.402823E+38 ~ -1.175495E-38（负数）； +1.175495E-38 ~+3.402823E+38（正数）； 0.0※
ASCII | 8/个 （字节） | 字符列表 | ASCII字符、 汉字内码（每个汉字2字节）
STRING （字符串） |  | 字符串 | 1 ~ 254个ASCII字符、 汉字内码（每个汉字2字节）

※ 实数不能绝对准确地表示“零”

二进制、十六进制和十进制

二进制和二进制数： 所有通过S7-200 PLC处理的数据（数值、字符等等）都以二进制形式表示。在S7-200中，特别指出一个数据是二进制数并没有什么意义。

十六进制和十六进制数：在二进制数中，每4个二进制位可以分为一组；这组二进制数值的不同变化可以表示16个状态，正好是16进制数每一位数字的变化范围。因此，可以用十六进制数值方便地表示二进制数。

例如，二进制数1000_1111b分为两组来看，分别是1000b和1111b，正好可以表示16进制数字8h和Fh（0000b对应于0h，...，1111b对应于Fh）；那么这个二进制数就可以表示为8Fh。

十进制和十进制数：十进制是S7-200的数学计算的基础，在S7-200中，一般都使用十进制的体系，除了时间（12/24或60进制）等特殊数据外。

二进制数用于在PLC中表示十进制数值、或者其他（如字符等）数据，而16进制用来比较简单地描述二进制数。

在S7-200中，二进制立即数表示为2#xxxx_xxxx（1字节长度），16进制立即数表示为16#xx（1字节长度）。

二进制位逻辑（bit）

PLC中以二进制“位”的数据形式来表示逻辑“1”、“0”（或者“开”、“关”）。位是最基本的数据单位。

在数据字节（Byte）中，二进制逻辑只用一个位（bit）来表示。每个字节由8个位组成。

  • 在S7-200中，某些类型的数据兼有成组的字节（字）访问形式，也有位的访问形式，如定时器、计数器等
  • 在编程软件Micro/WIN中，对位数据进行运算操作的指令都在指令树的Bit Logic（位逻辑）分支中

“位”的逻辑值为“1”或者“0”，但是在实际应用中，某种状态的“有效值”可以是“1”，也可以是“0”。“有效”就是我们认为某个状态已经“激活”

整数、无符号整数和有符号整数

字节、字、双字都可以用来表示十进制整数，显然它们的数据长度不同，能够表示的数的大小范围也不同。

无符号整数只有0和正整数；有符号整数可以有正数和负数。

有符号整数采用二进制补码的形式来表示负数。

  • 在S7-200中，字节、字、双字都可以按照无符号、有符号整数来查看
  • Micro/WIN中，整数运算指令在指令树的Integer Math分支中
  • 只有字节运算指令（带B符号的指令，如INC_B等）是无符号整数运算指令
  • 凡带有I，或W，DW等（除字节B指令外）的数学运算指令，都是有符号整数运算指令
  • 定时器、计数器的值都是有符号整数
  • HSC（高速计数器）的计数当前值（HCx）和设定值都是32位的有符号整数
  • 在编程软件Micro/WIN中输入立即数据时，如果不输入小数点，则认作整数

在不需要高精度运算的条件下，使用整数可以简化编程，节省处理时间。

实数（浮点数）

在S7-200中，实数（浮点数）是符合IEEE标准的32位实数，即单精度实数。实数格式按照一定的运算规律把32个二进制位分组，表示极小或极大的数。

  • S7-200的实数运算指令都在指令树的Floating-Point Math（实数运算） 分支中
  • 实数当作整数运算的时候会导致数值的错误；而整数当作实数应用可能会使数据非法（不符合标准）
  • 在编程软件Micro/WIN中输入带小数点数据的数据，则认为实数（实数形式的整数值必须输入小数点和一位为零的小数位，如10.0）

ASCII字符和String（字符串）

在S7-200中，ASCII字符是由表示字母、数字和一些特殊符号的ASCII编码组成的二进制数据字节，一个字节存储一个字符。

ASCII（美国信息交换标准码）是一种字符编码格式，在一个字节长度中不同的二进制数值代表不同的字符。如字母A为41h（十六进制数值），以十进制看就是65；而数字5的ASCII值为35h，十进制值为53。

S7-200中新引入了String（字符串）数据格式，其结构是在ASCII字符字节串前面有一个串长度。字符串最长可以有255个数据字节。

字符串中也能包括汉字编码，每个汉字占用两个字节。

这是S7-200内部对ASCII字符串的格式定义，所有与字符串有关的指令都遵照这个格式。

  • 在编程软件中，用单字节（英文）的单引号（'）将作为字符的内容括起来可以在数据块和状态图中输入ASCII数据字节
  • 在单字节的双引号（"）中间输入文本内容可以输入字符串
  • 按上述方法输入的字符串会自动按字符串格式排列（在起始地址中放入字符个数）
  • 使用程序，或人为组合成的ASCII字符串，使用ASCII字符串指令时，必须注意是否符合格式

例如：

图1. 在数据块中输入ASCII数据和字符串

下载项目到S7-200 CPU，使用状态图在线监控可以看到：

图2. 状态图

注意ASCII字节和字符串的区别。D6D0h是汉字“中”的编码。

STEP 7-Micro/WIN V4.0以上版本完全支持字符串数据格式。

BCD

BCD意为“二进制编码的十进制数”。BCD是一种编码方式，是以二进制数对十进制数字的编码，并因为16进制的优势，改用十六进制数字表示。

十进制只有十个数字，所以以16进制表示的BCD码不会出现16进制数字Ah - Fh。

十进制数39用BCD码表示就是39h，或16#39。BCD码数值必须用16进制查看才能得到正确结果。

BCD编码往往在使用BCD编码开关输入数据时用到；S7-200中读出的时钟日期数据也是以BCD编码表示。

《S7-200系统手册》关于PLC概念的一章非常有用，建议初学者必读。


数据寻址

S7-200数据寻址

  • 如何调用开关量或模拟量信号？
  • 怎样读取数据？
  • 怎么使用输入信号？
  • 如何输出控制？
  • ……

上述问题都是关于如何访问、使用数据的问题，也就是所谓“寻址”。

访问S7-200中的数据

S7-200从外部接收信号输入（输入数据），在内部按照用户程序运算、处理后，再输出进行各种控制、显示。

物理的输入/输出信号，在S7-200 CPU内部是以输入/输出映象区的形式对应。除此之外，CPU内部也有各种数据区域，如变量区（V存储区），定时器、计数器数据等。

S7-200中的数据类型

在S7-200 PLC系统中，数据可以被：

  • 从一个地址传送到另一个地址
  • 进行逻辑和数学运算
  • 在编程软件上设置、查看
  • 被其他设备访问，如在HMI（人机界面）上显示
  • 作为通信消息从一个设备传送到另一个设备
  • ……

要进行上述数据处理，需要：

  • 在直接使用数据处理的指令时，指定数据地址。所谓指令的“操作数”基本都是以数据地址的形式给出
  • 在编程软件中查看、设置数据，或者在HMI配置软件中指定变量（Tag）对应的数据时，指定地址

总之，所有数据，在S7-200中都是通过地址访问。

凡S7-200中能够访问的数据都有地址，地址是访问所有数据的依据，访问数据的过程本身就是“寻址”。

《S7-200系统手册》上关于PLC概念的第四章，其中对于S7-200中数据寻址的叙述非常好，建议初学者必读！

几乎所有的指令、功能都与各种形式的寻址有关，不弄清楚数据寻址会给工作带来极大的困难。

S7-200 CPU的集成I/O和扩展I/O寻址

在S7-200中，输入/输出点的地址只与其在系统中的物理位置有关。

各种类型的I/O按照各自的种类，如数字量输入（I）、数字量输出（Q）、模拟量输入（AI）、模拟量输出（AQ）信号，分别排列地址。

S7-200编程时不必配置I/O地址。

S7-200扩展模块上的I/O地址按照离CPU的距离递增排列。离CPU越近，地址号越小。

在模块之间，数字量信号的地址总是以8位（1个字节）为单位递增。如果CPU上的物理输入点没有完全占据一个字节，其中剩余未用的位也不能分配给后续模块的同类信号。

模拟量输出模块总是要占据两个通道的输出地址。即便有些模块（EM235）只有一个实际输出通道，它也要占用两个通道的地址。

在编程计算机和CPU实际联机时，使用Micro/WIN的菜单命令“PLC > Information”，可以查看CPU和扩展模块的实际I/O地址分配。

一个CPU和扩展I/O寻址的例子：

图1. I/O地址排列举例

在 S7-200中如何对于一个项目实例进行间接域寻址（含视频）

https://support.industry.siemens.com/cs/us/en/view/8950920


间接域寻址

在S7-200中如何对于一个项目实例进行间接域寻址

说明:
以下描述了在STEP 7 MicroWIN中可能的一种间接寻址使用.
例子中包含了OB1，一个数据块和一个状态表.

OB1包含4段程序。

图1：在SFC功能块中的4段程序

注意第2段程序:
*AC1 中的 (*)星号意味着正使用AC1所指向的地址内容，而并非AC1本身的值

另一部分是数据块.

图2

需要一个状态表用于测试和监控.

图3

下载程序到控制器中，然后打开状态表，点击 "Table Status" 观察变化.

首先保持监控当前的状态，可以看到VB200 到VB210 的值为1-10.而VB 220 之后全为空白.

当I0.0 为1时，这两点将被创建.
当I0.1为1时，从VB200 开始的连续前4个字节将被传送到VB220-VB223 中.
在第3段程序中将I0.0 置0可以分别增加1个地址字节，通过触发I0.2的上升沿可以增加多个地址字节.
在第4段程序中将I0.0 置0可以分别减少1个地址字节，通过触发I0.3的上升沿可以减少多个地址字节.

从入口条目为1109582.的"S7-200自动化系统" 手册中可以找到关于该主题的进一步信息，另外通过在线帮助输入"直接和间接寻址"也是非常有用的.

STEP 7-Micro/WIN 项目下载:
以下描述下载功能：
拷贝 "indirectadd.zip" 文件到一个单独的文件夹中并解压缩"indirectadd.mwp"文件，之后可以用 3.x版本STEP 7-Micro/WIN打开和编辑该项目文件 .

indirectadd.zip ( 2 KB )

实例程序

用指针访问数据表

Addressing-1.mwp

用指针存储数据表

Addressing-2.mwp

用地址偏移量来访问V存储区数据

Addressing-3.mwp

以上为关于指令使用的例程,仅供参考,使用前请先自行测试！


子程序和中断服务程序

系列视频：S7-200跟我学/跟我做:

S7-200CN: 不带参数子程序-跟我学 - 127/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=376
S7-200CN: 不带参数子程序-跟我做 - 128/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=377
S7-200CN: 局部变量的使用-跟我学 - 129/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=378
S7-200CN: 局部变量的使用-跟我做 - 130/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=379
S7-200CN: 带参数子程序1-跟我学 - 131/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=380
S7-200CN: 带参数子程序1-跟我做 - 132/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=381
S7-200CN: 带参数子程序2-跟我学 - 133/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=382
S7-200CN: 带参数子程序2-跟我做 - 134/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=383

子程序和中断服务程序

子程序和中断服务程序都是程序的组织结构，它们和主程序一起被称为POU（程序组织单元）。

在S7-200中，每个POU可以单独加密，保护作者的知识产权。

子程序

子程序可以把整个用户程序按照功能进行结构化的组织。一个“好”的程序总是把全部的控制功能分为几个符合工艺控制规律的子功能块，每个子功能块可以由一个或多个子程序组成。这样的结构也非常有利于分步调试，以免许多功能综合在一起无法判断问题的所在；而且，几个类似的项目也只需要对同一个程序作不多的修改就能适用。

  • 子程序在调用时会保持当前的逻辑运算结果，但是不保存累加器（ACx）的内容
  • 子程序在执行到末尾时自动返回，不必加返回指令；在子程序中间也可以使用条件返回指令
  • 子程序不能使用跳转语句跳入、跳出
  • 子程序返回时，回到调用子程序的指令后面，继续执行上一级程序
  • S7-200 CPU最多可以调用64个子程序（CPU226为128个）
  • 子程序可以嵌套调用，即子程序中再调用子程序，一共可以嵌套8层
  • 在中断服务程序中不能欠套调用子程序，被中断服务程序调用的子程序中不能再出现子程序调用
  • 子程序可以带参数调用，在子程序的局部变量表中设置参数的类型；一共可以带16个参数（形式参数）

有关子程序的详情，请看《S7-200系统手册》相关部分。

中断服务程序

中断功能是S7-200的重要功能，用及时处理与用户程序的执行时序无关的操作，或者不能事先预测何时发生的“事件”。

S7-200中使用中断服务程序来响应这些内部、外部的中断事件。中断服务程序需要通过用户编程与特定的中断事件联系起来，才能工作。中断程序与子程序最大的不同是，中断服务程序不能由用户程序调用，而只能由特定的事件触发执行。

无法准确预测何时执行中断服务程序。

  • 中断服务程序只有由用户程序把中断服务程序标号（名称）与中断事件联系起来，并且开放系统中断后才能进入等待中断并随时执行的状态
  • 多个中断事件可以连接同一个中断服务程序；一个中断服务程序只能连接一个中断事件
  • 中断服务程序也可由用户程序取消与中断事件的连接；队列中的特定中断事件可以被指令取消；也可用指令禁止全部中断
  • 中断程序只需与中断事件连接一次，除非需要重新连接
  • 进入中断服务程序时，S7-200的操作系统会“保护现场”，从中断程序返回时，仍然恢复当时的程序执行状态
  • 中断事件各有不同的优先级别
  • 中断服务程序不能再被中断。中断程序执行时，如果再有中断事件发生，会按照发生的时间顺序和优先级排队
  • 中断服务程序执行到末尾会自动返回，也可以由逻辑控制中途返回
  • S7-200 CPU最多可以使用128个中断程序，中断程序不能嵌套
  • 在中断程序中只能调用一层子程序，中断程序中的子程序不能嵌套，否则会出错
  • 中断程序应短小而简单，执行时对其他处理不要延时过长，即越短越好

在《S7-200系统手册》中有关中断指令的叙述十分详细，建议初学者仔细阅读。

常问问题

使用子程序时，为何动作只能执行一次，或者某些状态不能结束？

如果发生动作不能重复执行，或者状态不能结束（像锁死了一样），而这些功能都与子程序有关时，请检查是否有条件调用子程序。调用子程序的条件在上述动作执行后，或者进入某个状态后不再有效，无法再次“激活”，而脱离上述状态或复位的指令正好在子程序内，必然造成上述的现象。

另可参见：定时器在条件调用的子程序中

带形式参数的子程序，定义为OUT类型的变量为何会在多次调用子程序时互相干扰？

那是因为定义为 OUT 类型的形式参数并非每次调用子程序时在其内部都有确定的赋值操作。可以将此类参数定义为 IN_OUT 类型，或者确保在每次调用子程序时都有赋值操作。

与中断服务程序有关的计算任务，为何会偶尔得出不正确的结果？

出现这种现象的原因多是在主（子）程序和中断程序之间传递数据的机制不当。

中断程序可能在任何时刻执行，如果此时主程序（或子程序）正在对中断程序使用的数据进行操作，其中间结果可能带入中断程序，造成计算结果的变化；同样地，在中断程序中产生数据也对主（子）程序中的计算有类似影响。

解决办法是保证可能产生中间结果的数据不直接参与计算：

  • 使用STL指令计算单个中断程序使用的数据
  • 在梯形图（LAD）编程时，用MOV（传送）指令准备最后的数据（单个数据）
  • 准备成批的数据时，先禁止中断，完成后再允许中断
  • 简单的数据准备或者结果计算可直接放在中断程序中进行

详情请看《S7-200系统手册》的中断指令相关章节。

中断服务程序看起来没有执行？

可以在中断程序中加一个测试程序段，如使用SM0.0（常为“1”）将一个输出点置位（使用Set指令），观察是否进入中断服务程序。

中断程序不执行，多数原因是初始化（连接中断事件和中断程序）的问题，或者没有“开中断”。

应该使用SM0.1（或沿触发）执行一次初始化，然后开中断。

为什么指令或者子程序的使能（EN）管脚前没有任何条件时，会有编译错误？

当子程序或者指令的使能管脚前面没有编写任何条件时，编译后会出现一个语法错误，如图.无条件调用指令或子程序 所示：

图.无条件调用指令或子程序

?

上面的编程方式是不被允许的。如果用户希望无条件调用子程序或者指令，可以使用SM0.0作为使能条件，如图.SM0.0作为使能条件 所示：

图. SM0.0作为使能条件

为什么子程序已经不激活了，但是子程序的输出没有复位？

以下面一个简单子程序SBR_0为例，SBR_0将一个IN类型的布尔变量IN1直接连接到一个OUT布尔变量OUT1。在主程序中使用M0.0条件调用SBR_0，如图.子程序输出 所示：

????

?????????????????????????????????????????????? 图.子程序输出

当M0.0为‘1’时，子程序执行，CPU_输入0有信号时，CPU_输出0有信号输出。此时将M0.0复位，则子程序不再执行，输出OUT1保持子程序最后一次执行的状态，不会被自动复位。

?

? 在子程序中如果使用了上升沿捕捉时指令，那么此子程序被多次重复调用时，为什么上升沿捕捉逻辑不能正常执行？

??? 举一个简单的例子，在子程序SBR_0中声明一个布尔类型输入变量和一个布尔类型的输出变量，输入变量IN1通过一个常开触点连接一个上升沿捕捉指令，之后再连接一个线圈输出到输出变量OUT1。在主程序中的网络1和网络2中，连续使用SM0.0作为使能条件两次调用子程序SBR_0，子程序的输入输出分别连接M0.0、M0.1、M0.2、和M0.3。如图.子程序和主程序内容 所示：

???

图.子程序和主程序内容

如果将M0.0复位，M0.2置位，单纯按上升沿捕捉的逻辑，由于没有上升沿跳变，子程序的输出都应该是‘0’。但是在线监控可以看到M0.1持续为‘0’， M0.3保持为‘1’。如图.在线监控 所示：

图.在线监控

上升沿捕捉指令的工作原理是将本次左侧能流过来的‘1’、‘0’信号与上次指令执行时的状态比较，如果检测到从0到1的变化，则导通。每条上升沿下降沿指令都隐含一个布尔数据资源来存储上一次输入信号的‘1’、‘0’状态。在程序段1中，M0.0将上升沿捕捉清零，M0.2不输出。程序段2中M0.2为1，上升沿捕捉指令刚好捕捉到一个由0到1的变化，所以M0.3导通。详细请参考表.上升沿变化：

表.上升沿变化

? | 第一个扫描周期 |  | 第二个扫描周期
 | 程序段1 | 程序段2 | 程序段1 | 程序段2
M0.0 | 0 | 0 | 0 | 0
M0.1 | 0 | 0 | 0 | 0
M0.2 | 1 | 1 | 1 | 1
M0.3 | 1 | 1 | 1 | 1
P(上升沿捕捉) | 0 | 1 | 0 | 1

?

为什么子程序中的定时器和计数器不工作或者工作不正常？

如果有下面情况产生：

    • 一个在内部使用了定时器或计数器的子程序，在同一时刻被调用了多次
    • 相同编号的定时器或计数器被多个子程序使用，且同一时刻这些子程序有两个或者以上被调用

则定时器或者计数器资源会因重叠使用而相互影响，造成程序逻辑等方面的错误。

?

为什么子程序的输出不正常？

这里首先举例一个子程序SBR_0，该子程序的接口声明一个INT类型的IN变量‘Pressure’和一个BOOL类型的OUT变量‘OPEN’，子程序中只有一个程序段，在程序段1中编写当输入Pressure数值大于500时将输出OPEN置位，如图4.46 子程序输出不正常 所示。

图 子程序输出不正常

??? 这样的子程序被调用后，当输入Pressure达到过500时，输出OPEN被置位；但当输入Pressure从未达到过500时，输出OPEN一直保持为一个未知的状态，可能是1，也可能是0。由于子程序的局部变量仅在本次调用时有效，且每次获取到的局部变量资源有一定的随机性，有可能已经具有一个随机的数据存储在该局部变量地址中，因此对于OUT类型的接口变量，必须保证每次调用程序都对其进行写操作，否则就是编程逻辑的不严密。当然，用户也可以考虑使用IN_OUT变量类型代替OUT变量类型。


功能－数据保持及存储卡

数据保持功能

应用S7-200时，可以选用以下几种数据保持方法：

  • CPU的内置超级电容，断电时间不太长时，可以为数据和时钟的保持提供电源缓冲
  • CPU上可以附加电池卡，与内置电容配合，长期为时钟和数据保持提供电源
  • 设置系统块，在CPU断电时自动永久保存M区中的前14个字节数据
  • 在数据块中定义不需要更改的数据，下载到CPU内可以永久保存
  • 用户编程使用相应的特殊寄存器功能，将数据写入EEPROM永久保存

上述前三个数据保持功能都是在“系统块－数据保持”中设置。

S7-200的数据保持机制

S7-200系统中用到了三种存储器件：

  • RAM： 易失性的存储器，失去电源供应后，其中保存的数据会丢失。S7-200 CPU中的RAM由超级电容＋外插电池卡提供电源缓冲。RAM保存V、M、T（定时器）、C（计数器）等各数据区的内容，在CPU失电后的表现由用户在系统块“数据保持”页中设置
  • EEPROM：非易失的电可擦除存储器，保存数据不需要供电，并且可以改写其内容。上述RAM数据区中有的部分与EEPROM中的区域一一对应。用户程序也永久保存在程序EEPROM区中
  • 外插存储卡：非易失的存储器。用来保存用户程序、数据记录（归档）、配方数据，以及一些其他文件等

S7-200 CPU的以下数据空间属于RAM存储区：

  • 变量存储区（V）：可以按位、字节、字或双字来存取V 区数据
  • 位存储区（M）：可以按位、字节、字或双字来存取M区数据
  • 定时器存储区（T）：用于时间累计，分辨率分为1ms、10ms、100ms三种
  • 计数器存储区（C）：用于累计其输入端脉冲电平由低到高的次数。CPU提供了三种类 型的计数器：一种只能增计数；一种只能减计数；另外一种既可 以增计数，又可以减计数。

RAM区的数据保持

RAM区的数据保持靠“内置超级电容＋外插电池卡”的机制。

在CPU内部靠一个超级电容，在掉电后为RAM存储器提供电源缓冲，保存时间可达几天之久，具体时间见表1、表2。CPU上电时，超级电容就可以充电。要获得规格表中的数据保持时间，电容必须连续充电24小时。

S7-200还可选用外插电池卡（需单独定货），在超级电容耗尽后为RAM数据区提供电源缓冲。在连续无供电时，它可使用200天（即保持数据达200天）。CPU在不断电的情况下专用电池卡能够使用10年。

电池卡是不可充电的。

表1. S7-200新CPU（23版） [image] 的数据保持范围和时间（内置超级电容）

型号 | CPU221 | CPU222 | CPU224 | CPU224 XP | CPU226
用户程序空间 | 4096字节 |  | 8192(12288)*字节 | 12288(16384)*字节 | 16384(24576)*字节
用户数据 | 2048字节 |  | 8192字节 | 10240字节 | 10240字节
定时器 | TONR定时器
计数器 | 256个
超级电容（内部） | 50小时/典型值（40C°时最少8小时） |  | 100小时/典型值（40C°时最少70小时）
可选电池 | 200天/典型值

*括号内的数值为不使用“在线编程模式”时可以使用的程序空间大小

表2. S7-200 CPU（22版）数据保持范围和时间（内置超级电容）

型号 | CPU221 | CPU222 | CPU224 | CPU226 | CPU226XM
用户程序空间 | 4096字节 |  | 8192字节 | 8192字节 | 16384字节
用户数据 | 2048字节 |  | 5120字节 | 5120字节 | 10240字节
定时器 | TONR定时器
计数器 | 256个
超级电容（内部） | 50小时/典型值（40C°时最少8小时） |  | 190小时/典型值（40C°时最少120小时）
可选电池 | 200天/典型值

RAM区中的数据能被超级电容和电池卡保持的前提是，必须将这些数据在STEP 7-Micro/WIN32编程软件的系统块当中设定V区、M区、T区、C区的掉电保持范围。

超级电容（＋外插电池卡）也同时用于为CPU的实时时钟提供电源缓冲。如果放电完毕，CPU时钟会停止走动。

EEPROM区保持数据

CPU内置的EEPROM存储器用于永久保存数据，包括与RAM数据区一一对应的全部的V存储区、部分M存储区（MB0 - MB13）、定时器（TONR）。

例如V存储区的VW100（RAM）在EEPROM中有其独占的对应地址，数据在从EERPOM中写到V存储区中时，其目标地址就是VW100。

数据可以用如下方式写入EEPROM数据区：

  • 在编程软件Micro/WIN的Data Block（数据块）中定义V数据区存储单元的初始值，下载数据块时，这些数值也被写入到相应的EEPROM单元中。
  • 用特殊存储器SMB31、SMW32，用编程方法将V存储区的数据写入EEPROM
  • 在System Block（系统块）中设置数据保持功能，可将MB0 - MB13的内容在CPU断电时自动写入到EEPROM中

参见：

系统块数据保持设置
S7-200中的数据类型
S7-200数据寻址

从 RAM 建立数据块

要将 CPU V 存储器当前值保存到数据块页面；或者执行下载操作，担心 RAM 区数据当前值丢失，可以在执行下载操作前，先执行从 RAM 建立数据块，备份 V 存储区的当前值。

操作方法如下：

1、备份好源程序，新建空白项目操作

2、选择 PLC > 从 RAM 建立数据块（Create Data Block from RAM）菜单命令。如图1.所示

图1.

3、PLC 处于运行状态，执行操作时，会提示 “ 设置 PLC 为 STOP 模式 ？”，选择是才可以继续执行此功能，如图2. 所示；如果操作前 PLC 已处于 STOP 状态，不会出现此对话框

注意：想要执行从 RAM 建立数据块功能，需要在 PLC 可以切换到 STOP 的情况下才可以操作！

图2.

4、出现对话框，如图3. 所示，选择 “ Yes ” 将执行更新，将 CPU 中 RAM 区的 V 存储区数据当前值上传到数据块的数据页中

如果执行操作时，使用的程序文件是源程序，选择 " Yes " 前，一定要注意源程序的备份！

图3.

5、等待一段上传数据的时间，出现对话框，如图4. 所示，点击" OK "，可以在数据块中查看 V 区数据

图4.

执行从 RAM 建立数据块，上载到数据块中的数据有可能存放的位置

  • 用户定义1：上一次下载数据块时，在数据块中用户自定义过初始值
  • _PLC_DATA1：上一次下载数据块时，未定义初始值，在程序执行过程中修改过的 V 区地址，执行"从 RAM 建立数据块"命令时，这些已修改的地址会被指定给一个新的标签名
  • 向导生成的数据块（例如 PID1_DATA）:上一次下载数据块时，包含配置完向导后自动生成的数据块，比如 配置完 PID 后生成如 PID1_DATA 的数据块，执行"从 RAM 建立数据块"命令时，依然上传到此数据块中

6、将上传的各个数据块页面中的 V 区地址复制，粘贴到要下载的程序文件的数据块页面中，此时，一旦下载，数据块保存到 EEPROM 中，作为 V 存储区数据的初始值生效

常问问题

程序存储在哪里，会不会丢失？

回答：下载的程序存储在EEPROM中，将会永久保存，断电后不会丢失。程序的大小不能超过CPU用户程序空间的大小。

如何验证数据是否正确保存到了EEPROM中？

有两种方法可以验证数据是否正确保存到EEPROM中：

  • 在“系统块－数据保持”设置中取消相应数据区（V存储区）的保持设置，则CPU在上电时会用EEPROM中相应区域的数值覆盖RAM中的数据，可以检查数据是否正确
  • 使用Micro/WIN的Upload（上载）功能，将数据块上载到Micro/WIN项目中；上载的数据来源是EEPROM而不是RAM

实用指令库

EEPROM 数据写入指令库

也可以参考西门子ProDIS网站的FAQ17471561。


附件－外插卡

S7-200 CPU外插卡

S7-200CPU有以下外插卡：

  • 32K存储卡：可用于保存用户程序、数据块和强制值
  • 64K存储卡：可用于保存程序、数据块和强制值、配方、数据记录（归档），以及其他文件
  • 256K存储卡：可用于保存程序、数据块和强制值、配方、数据记录（归档），以及其他文件
  • 时钟电池卡：内部兼有实时时钟和备份电池，专用于CPU221/CPU222
  • BC293：电池卡，为CPU数据保持提供电源。用于CPU224/224 XP/226保持数据和实时时钟数据

CPU224及以上的CPU具有内置的实时时钟，而CPU221及CPU222需要外加时钟电池卡才具有实时时钟功能。

去除CPU通信口上方的塑料盖，就可以将卡插入空槽内。

存储卡的版本

存储卡目前有两个版本：

  • 32K存储卡：仅用于储存和传递程序、数据块和强制值
  • 64K/256K存储卡：可用于新版CPU（23版）保存程序、数据块和强制值、配方、数据记录和其他文件（如项目文件、图片等）

存储卡的内容一旦写入不会丢失。

64K/256K新存储卡只能用于新版CPU（23版）；32K存储卡只可以用于向新版（23版）CPU传递程序，不支持64K/256K存储卡的新功能；新版CPU不能向32K存储卡中写入任何数据。

存储卡操作

用于CPU内的用户程序保存和传递功能时：

  • 在STEP 7 MicroWin32中使用菜单命令PLC>Program Memory Cartridge 来向存储卡中复制程序
  • 为了把存储卡中的程序送到CPU中，必须先插入存储卡，然后给CPU上电，程序将自动复制到RAM及EEPROM中。

存储卡可带电插拔。

CPU进入上电状态时，若存储卡是空白的或者存储的是不同类型CPU的程序，会导致错误。高型号的CPU可以读出用低型号CPU写入的存储卡，反之则不行。

表1. 存储卡与CPU的写入、读取限制

在下列CPU上写入程序的卡 | 可以被以下CPU读取
CPU221 | CPU221, CPU222, CPU224, CPU224 XP, CPU226
CPU222 | CPU222, CPU224, CPU224 XP, CPU226
CPU224 | CPU224, CPU224 XP, CPU226
CPU224 XP | CPU224 XP, CPU226
CPU226 | CPU226

时钟电池卡/电池卡

S7-200的时钟电池卡/电池卡，在连续无供电时，可使用200天（即保持数据达200天）。CPU在不断电的情况下电池卡有效寿命为10年。

注意：时钟电池卡/电池卡均为1次性使用，不可充电。

可通过下表查看保持时间：
S7-200新CPU（23版）的数据保持时间

型号 | CPU221 | CPU222 | CPU224 | CPU224XP | CPU226
无电池，超级电容保持 | 50小时/典型值（40℃时最少8小时） |  | 100小时/典型值（4040℃时最少70小时）
电池卡 | 200天/典型值

S7-200CPU（22版）的数据保持时间

型号 | CPU221 | CPU222 | CPU224 | CPU226 | CPU226XM
无电池，超级电容保持 | 50小时/典型值（40℃时最少8小时） |  | 190小时/典型值（4040℃时最少120小时）
电池卡 | 200天/典型值

存储卡及电池卡订货号

S7-200 CPU存储卡及电池卡的订货号如下表所示：

外插卡和电缆型号 | 订货号
存储卡，64K (用户程序、配方和数据记录) | 6ES7 291--8GF23--0XA0
存储卡，256K (用户程序、配方和数据记录) | 6ES7 291--8GH23--0XA0
CC 292, CPU 22x Real–Time Clock with Battery Cartridge | 6ES7 297-1AA23-0XA0
BC 293, CPU 22x Battery Cartridge | 6ES7 291-8BA20-0XA0

常问问题

使用 23 版本的新存储卡向 S7-200 CN 中复制程序为何会发生 SF（系统故障）错误？

23 版的存储卡与 S7-200 CN CPU 完全兼容，既可以用在 23 版以上的 SIMATIC S7-200 上，也可以用在 S7-200 CN 上。

为了限制中国以外的用户使用 S7-200 CN CPU，通过存储卡从 SIMATIC CPU 到 CN CPU 的程序转移被限制，即它们之间不能通过存储卡传送程序。

要通过存储卡向 CN CPU 传送程序，存储卡必须在 CN CPU 上编程。

要清除 SF 错误，可以使用菜单命令“PLC > 存储卡擦除”，然后执行“PLC > 上电复位”。

存储卡能否扩展CPU的程序存储空间？

回答：存储卡不能扩展程序空间，S7-200CPU的程序空间是不能扩展的。

新的时钟/电池卡（6ES7 297-1AA23-0XA0）能否用在老型号的CPU上？

新的时钟/电池卡只能用在新版本的CPU上（23版），不能用在旧型号的CPU上（如21/22版）；旧版本的时钟/电池卡也不能用在新版CPU上。


定时器

系列视频：S7-200跟我学/跟我做:

S7-200CN: 定时器-跟我学 - 24/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=273
S7-200CN: 定时器-跟我做 - 25/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=274
S7-200CN: 接通延时定时器-跟我学 - 60/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=309
S7-200CN: 接通延时定时器-跟我做 - 61/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=310
S7-200CN: 断开延时定时器-跟我学 - 62/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=311
S7-200CN: 断开延时定时器-跟我做 - 63/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=312
S7-200CN: 保持型接通延时定时器-跟我学 - 64/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=313
S7-200CN: 保持型接通延时定时器-跟我做 - 65/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=314

定时器

S7-200指令提供了下述三种类型的定时器。

  • 接通延时定时器（TON）：用于单一间隔的定时
  • 有记忆的接通延时定时器（TONR)：用于累计许多时间间隔
  • 断开延时定时器（TOF)： 用于关断或者故障事件后的延时

定时器号和分辨率

定时器对时间间隔计数。定时器的分辨率（时基）决定了每个时间间隔的长短。

定时器号决定了定时器的分辨率（时基）。

SIMATIC定时器有三种分辨率：1ms、10ms和100ms。

S7-200提供了256个可供使用的定时器，即用户可用的定时器号为T0-T255，一旦用户选择了定时器号，就意味着定时器的分辨率（时基）已经确定了。定时器号的分辨率（时基）及最大计时时间，如下表：

表1. 定时器号和分辨率

定时器类型 | 分辨率 | 最大定时值 | 定时器值
TONR （可保持） | 1 ms | 32.767s (0.546min.) | T0, T64
 | 10 ms | 327.67s (5.46min.) | T1-T4, T65-T68
 | 100 ms | 3276.7s (54.6min.) | T5-T31, T69-T95
TON,TOF （不保持） | 1 ms | 32.767s (0.546min.) | T32, T96
 | 10 ms | 327.67s (5.46min.) | T33-T36, T97-T100
 | 100 ms | 3276.7s (54.6min.) | T37-T63, T101-T255

不同分辨率的定时器按以下规律刷新：

  • 1ms：1ms分辨率的定时器，定时器位和当前值的更新不与扫描周期同步。对于大于1ms的程序扫描周期，在一个扫描周期内，定时器位和当前值刷新多次。
  • 10ms：10ms分辨率的定时器，定时器位和当前值在每个程序扫描周期的开始刷新。定时器位和当前值在整个扫描周期过程中为常数。在每个扫描周期的开始会将一个扫描累计的时间间隔加到定时器的当前值上。
  • 100ms：100ms分辨率的定时器，定时器位和当前值在指令执行时刷新。因此为了保证正确的定时值，要确保在一个程序扫描周期中，只执行一次100ms定时器指令。

注意：不能将同一个定时器号同时用作TOF和TON。例如，不能既有TON T32又有TOF T32。也不能重复使用同一定时器号定时。

不同定时器的功能

  • 接通延时定时器（TON）： 当使能输入接通时，定时器开始计时，在当前值（TXXX）与预置值（PT）相等时，定时器位接通。使能输入断开后，定时器当前值清零。在定时器到达预置值后，它会继续计时直到计到最大值32767才停止。
  • 有记忆接通延时定时器（TONR）： 当使能输入接通时，定时器开始计时；在当前值（TXXX）大于等于预置值时，定时器位接通。当使能输入断开时，定时器当前值保留。若要将定时器当前值清零，必须执行复位命令。在定时器到达预置值后，它会继续计时直到计到最大值32767才停止。
  • 断开延时定时器（TOF）： 在输入端接通时，定时器位立即接通，当前值置为零；当输入端由接通转为断开时，定时器开始计时，直到预置时间。当定时器到达预置时间时，则定时器位断开，定时器当前值停止计时。当输入断开的时间小于预设值时，定时器位保持接通。下一次输入断开后，定时器从零开始重新计时直到达到预置值。

定时器在子程序中的表现

在条件调用子程序的主程序中，当停止子程序调用时，如果定时器已经激活正在计时，停止调用这个子程序会造成定时器的失控。不管此时定时器前面的激活条件如何变化，定时器（1ms、10ms 时基的）会一直走到最大值，定时器输出也会在达到设定值时接通；（100ms 时基的定时器会在上述情况下停止计时，但在逻辑上处于失控状态）。

如果用 SM0.0 调用子程序；或者在控制逻辑的时序上做到能够保证定时功能完整执行，定时器会正常运行。使用条件调用含有定时器的子程序时，一定要注意时序逻辑，以免造成程序运行错误。

常问问题

使用定时器加自复位做一个不断重复的计时，调用其他功能或子程序时，为何看起来工作不规律？

请注意《S7-200系统手册》中，或者前文关于三种定时器刷新规律的描述。

按这种方法使用定时器时，定时器的置位、复位可能与程序扫描周期不配合，存在造成上述问题的机制。

定时比较短的定时任务应使用“定时中断”功能，这样更为可靠。

编了一个利用定时器的程序，在编译时已经通过，为何下载到CPU中时提示出错？

这种情况往往是调用的定时器号与定时器类型不配合造成的。参见上面的表格，如T7只能用作TONR，而不能用于TON或TOF。

能否在子程序的局部变量中添加定时器类型？

S7-200的子程序不支持添加定时器或计数器的数据类型。


timer

在 STEP 7 Micro/WIN 里怎样优化使用定时器?

描述:
在 STEP 7 Micro/WIN 里定时器的调用总数限制在 256:

接通延时定时器(“TON”) 和断开延时定时器(“TOF”) ：

  • 2 个(“T32” 和“T96”) 时基为 1 ms
  • 8 个(“T33” 到“T36” 以及“T97” 到“T100”) 时基为 10 ms
  • 182 个(“T37” 到“T63”以及“T101”到“T255”) 时基为 100 ms

带记忆的接通延时定时器 (“TONR”) ：

  • 2 个(“T0”和“T64”) 时基为 1 ms
  • 8 个(“T1”到“T4”以及“T65”到“T68”) 时基为 10 ms
  • 54 个(“T5”到“T31”以及“T69”到“T95”) 时基为 100 ms

图1

从 STEP 7 Micro/WIN 版本 4 开始，功能块“BGN_ITIME”和“CAL_ITIME” 也可用于版本 2 开始的 S7-200 CPUs ，定时器可以进行如下仿真而没有限制:

注意：由于输出是双字格式，最大定时时间是49.7天。

接通延时定时器
输入点 I0.0 接通(上升沿) 3 秒后(3000 ms)， 输出点 Q0.0 置位。

图2

带记忆的接通延时定时器
如果输入点 I0.1 的接通时间等于或大于 3 秒 (3000 ms)，输出点 Q0.1 置位。输入点 I0.2 用于复位。

图3

断开延时定时器
输入点 I0.3 断开(下降沿) 3 秒 (3000 ms) 后，输出点 Q0.3 复位。

图4

脉冲发生
通过激活(下降沿)输入点 I0.4，输出点 Q0.4 获取一个持续 3 秒(3000 ms)的脉冲。

图5

下载:
可下载的附件 "TON_TONR_TOF_TP.zip" 是包含上面所示程序的例子项目。

TON_TONR_TOF_TP.zip ( 2 KB )

注意：

  • 关于定时功能的更多的信息可参考STEP 7 Micro/WIN 帮助。


定时中断

S7-200有四个定时中断定时器，两个特殊寄存器（SMB34/SMB35）和两个定时器（ T32/T96）中断。中断定时计时精确，可以用来执行模拟量定时采样等任务。

定时中断使用要点：

1、特殊寄存器SMB34/SMB35 可设置1~255ms，对应中断事件号10、11；

2、定时器T32/T96 可设置1~32767ms，对应中断事件号21、22；

3、定时中断程序的执行时间必须小于设定的间隔时间，如图1：

图1. 中断程序的执行时间必须小于间隔时间

4、若定时中断程序的执行时间大于设定的间隔时间，则将导致看门狗时间错误；如图2和图3：

图2. 中断程序的执行时间大于间隔时间

STEP7 Micro/win编程在线连接PLC，通过菜单栏“PLC”--->“信息”查看到如下图所示的错误：

图3. 看门狗时间错误提示

定时器T32及其中断的使用例程

主程序例程：

注意：必须调用中间变量(如M0.0)来进行自动重新触发定时器，而不能使用T32的常闭点作为其自动触发条件。

中断程序例程：

注：在中断程序中加入累加计数，确认进入中断次数。

常问问题

定时中断（SMB34/SMB35）最长定时为255ms，如何实现更长时间的定时？

可以采用T32/T96中断，最长时间可到32.767s。在定时中断服务程序中对进入中断的次数进行计数，也能实现更长时间的中断延时。

定时中断个数不够怎么办？

每个定时中断服务程序不一定只能处理一项定时任务，可以把几个任务放在一个定时中断服务程序中。

对于定时间隔不同的任务，可以计算出它们的定时长度的最大公约数，以此作为定时中断的时间设置。在中断服务程序内部对中断事件进行计数，据此编程别处理不同的任务。

S7-200中可以定义8个PID回路，PID计算就是在定时中断程序执行的。PID编程向导会自动按以上方法处理。

定时中断为何不工作？

参见中断程序工作不正常的主要原因

如何确认定时中断子程序所需的执行时间？

参见如何查看子程序的执行时间


程序执行时间

系统扫描周期

当工程师编程结束后需要了解整个程序的扫描周期，可通过如下两种方法查询。

方法一：将程序下载到PLC后，进行在线连接，查看PLC信息；路径：菜单“PLC”--->“信息”。

图1. 查看PLC信息

方法二：读取系统状态字SMW22/24/26。

图2. 读取系统状态字

子程序执行时间

使用S7-200 CPU时，若工程师需要了解某个子程序的大约执行时间，可使用定时器指令中的BGN_ITIME 和CAL_ITIME

指令进行编程，如图3和图4：

图3. 测试子程序SBR_0的执行时间

图4. 监控子程序SBR_0的执行时间大约为58ms

注：若需要测试中断程序的执行时间，可在主程序中增加子程序”SBR_0“，并将中断程序拷贝到子程序中测试。

常问问题

为何程序下载完毕后PLC无法运行，PLC信息中出现“致命错误3：看门狗超时错误”？

STEP7 Micro/win编程软件在线连接PLC，通过菜单栏“PLC”--->“信息”查看到如下图5所示的错误：

图5. 致命错误3：看门狗超时错误

可能的原因：

1、程序过长，执行时间超过看门狗时间500ms；

2、程序中有死循环程序导致执行时间超过看门狗时间500ms；

3、定时中断程序的执行时间大于所设定的定时间隔时间； [image] 参见定时中断


指示灯及CPU、SM诊断信息

硬件诊断

通过模块指示灯、CPU信息、读取S7-200 CPU特殊寄存器（SM）的数值这三种方式来诊断S7-200 PLC的硬件故障，这三种方式可以一起使用

模块指示灯

S7-200 CPU有一个SF/DIAG状态指示灯，热电偶/热电阻EM扩展模块有一个SF状态指示灯，智能模板CP243-1有一个SF状态指示灯、EM277有一个CPU_FAULT/DP ERROR状态指示灯。这些指示灯都具有故障报警功能。如下图模块指示灯所示。

图 1.CPU故障指示灯

注意：指示灯仅仅提示用户：模块是否有故障，而不是直接告诉用户模块的故障是什么，因为能导致模块指示灯提示故障的原因不止一个。想要知道故障的详细信息需要查看CPU的信息和特殊寄存器（SM）的数值。

SF/DIAG | 状态
-- | 正常
红色 | 系统错误
黄色 | 1：变量强制 2：模块I/O错误 3：LED指令

表 1.CPU SF/DIAG指示灯状态对应表。（LED指示灯可在系统块内配置）

图 2.EM231 RTD故障指示灯

图 3.EM231 TC故障指示灯

注意：EM231 RTD/TC模块的SF指示灯闪烁所代表含义可参考文档模拟量扩展模块章节RTD/TC常见问题。

图 4.CP243-1故障指示灯

LED | 颜色 | 含义 | 故障
SF | 红色，连续点亮 | 系统错误 | 在出现错误时点亮
 | 红色，闪亮 | 系统错误 | 组态错误，并且么可有找到BOOTP服务器，将闪亮（每秒一次）
LINK | 绿色，连续点亮 | 连接 | 已建立以太网连接
RX/TX | 绿色，闪烁 | 活动 | 数据正在通过以太网进行接收和传输
RUN | 绿色，连续点亮 | 运行 | CP243-1已通讯准备就绪
CFG | 黄色，连续点亮 | 组态 | 在STEP 7 Micro

表 2.CP243-1指示灯信息

图 5.EM277故障模块指示灯

指示灯 | LED状态
 | OFF | 红色 | 红色闪烁 | 绿色
CPU FAULT | 模块良好 | 内部模块错误 | -- | --
POWER | 没有DC24V电源 | -- | -- | DC24V电源良好
DP ERROR | 无错误 | 脱离数据交换模式 | 参数化/组态错误 | --
DX MODE | 不在数据交换模式 | -- | -- | 在数据交换模式

表 3.EM277指示灯信息

S7-200 CPU信息

S7-200 CPU具有一定的自诊断功能，通过查看CPU信息的方式能快速有效地得到CPU的状态信息。

查看方法：在STEP 7-Micro/WIN 软件菜单功能区选择“PLC”选项，在PLC选项中的“信息”部分选择“PLC”，如下图。 PLC信息的查找方法所示。

图 6.查找PLC信息的方法

图 7.PLC信息

在CPU信息中，除了能够得到CPU、模块的硬件信息、运行状态，还可以得到当前程序的扫描周期等其它有用信息，双击模块可进入模块信息，如下图。

图 8.模块信息
注意：
CPU的信息是实际CPU的内部信息，因此需要通过STEP 7-Micro/WIN 软件在线连接到CPU上才可以得到该信息。

读取S7-200 CPU特殊寄存器(SM)的数值

S7-200 CPU内部有特殊寄存器SM，用户可以借以查看或是更改CPU的系统参数。其中有一些SM区域用来表示CPU硬件状态，包括CPU订货号、序列号、硬件版本、CPU故障信息，以及EM扩展模块的订货号、序列号、硬件版本、故障信息等。
根据《S7-200 系统手册》章节D“特殊存储器（SM）和系统符号名称”中关于特殊寄存器的描述，可以得到相应故障的解释和说明。表4,特殊寄存器诊断地址列出了S7-200 CPU、EM扩展模块的SM诊断地址。

诊断 | 特殊寄存器地址 | 信息
I/O状态 | SMB5 | I/O错误
CPU ID寄存器 | SMB6 | CPU类型
I/O模块标识和错误寄存器 | SMB8~SMB21 | 偶数字节:模块标识寄存器；奇数字节:模块错误寄存器
扩展I/O总线错误 | SMW98 | 当扩展总线出现校验错误时，该处每次增加1，当系统得电时或用户程序入零，可进行清零
智能模块状态 | SMB200-SMB549 | 模块名称、S/W修订号、错误代码、与特定模块类型相关

表 4.特殊寄存器诊断地址

注：智能模块包含以下模块

订货号 | 智能扩展模块
6ES7?241-1AA22-0XA0 | EM 241 Modem模块
6ES7?253-1AA22-0XA0 | EM 253 定位模块
6ES7?277-0AA22-0XA0 | EM 277 PROFIBUS-DP模块
6GK7?243-2AX01-0XA0 | CP 243-2 AS Interface 通信处理器
6GK7 243-1GX00-0XE0 | CP 243-1 IT 因特网模块 (带含电子文档的CD)
6GK7 243-1EX01-0XE0 | CP 243-1 以太网模块 (带含电子文档的CD)

表 5. 智能模块

诊断方法介绍

以CP243-1与EM277为例，详细介绍如何通过模块的指示灯状态、CPU信息、特殊寄存器SM数值这三种方式来诊断模块的状态。

CP243-1
指示灯 | PLC信息 | SM读取状态 | 说明
SF闪烁 |  |  | SMB5 | SM5.0 | 当有I/O错误时，将该位置1
 |  |  |  | SM5.1 | 当I/O总线上连接了过多的数字量I/O点，将该位置1
 |  |  |  | SM5.2 | 当I/O总线上连接了过多的模拟量I/O点，将该位置1
 |  |  |  | SM5.3 | 当I/O总线上连接了过多的智能I/O点，将该位置1
 |  |  |  | SM5.4~SM5.7 | 保留
 |  |  | SMB8 | SM8.0~SM8.1 | 输出： 00：无 01：2AQ/8DQ 10：4AQ/16DQ 11：8AQ/32DQ
 |  |  |  | SM8.2~SM8.3 | 输入： 00：无 01：2AI/8DI 10：4AI/16DI 11：8AI/32DI
 |  |  |  | SM8.4 | I/O类型： 0：离散 1：模拟
 |  |  |  | SM8.5~SM8.6 | 模块类型： 00：非智能模块 01：智能模块
 |  |  |  | SM8.7 | 模块存在： 0：存在 1：不存在
 |  |  | SMB9 | SM9.0 | 接线板松动错误
 |  |  |  | SM9.1 | 保险丝熔断错误
 |  |  |  | SM9.2 | 无用户电源错误
 |  |  |  | SM9.3 | 超出范围错误
 |  |  |  | SM9.4 | 总线故障或奇偶校验错误
 |  |  |  | SM9.7 | 组态错误
 |  |  | 模块名 | SMB200~SMB215 | CP243-1 ETHERNET
 |  |  | S/W版本号 | SMB216~SMB219 | 01.00
 |  |  | 错误代码 | SMW220 | 16#3E（配置无效）
 |  |  | 状态 | SM222.0 | 0：CP未安装 1：CP已安装
 |  |  |  | SM222.1 | 0：BOOTP程序还没执行 1：BOOTP 程序正在执行
 |  |  |  | SM222.2 | 0：CP没有运行准备就绪 1：CP 运行准备就绪
 |  |  |  | SM222.3 | 0：STEP 7 Micro/Win 没有启用 1：STEP 7 Micro/Win 启用
 |  |  |  | SM222.4 | 0：根据CDB进行组态 1：CDB中没有有效组态
 |  |  |  | SM222.5 | 预留
 |  |  |  | SM222.6 | 0：没有以太网连接 1：连接以太网
 |  |  |  | SM222.7 | 0：没有错误 1：有错误

表 6.CP243-1诊断

注：以上信息均可在《S7-200 可编程控制器 系统手册》及《SIMATIC NET CP243-1工业以太网通讯处理器 技术手册》中找到

EM277
指示灯 | PLC 信息 | SM 读取状态 | 说明
DP ERROR常亮 |  |  | 模块名 | SMB250~SMB265 | EM277 PROFIBUSDP
 |  |  | S/W版本号 | SMB266~SMB269 | 01.02
 |  |  | 错误代码 | SMW270 | 无错误：16#0000 无用户电源：16#0001；
 |  |  | DP从站地址 | SMB272 | 5
 |  |  | DP标准协议状态字节 | SMB274 |
 |  |  | 主站站地址 | SMB275 | 2（0~126）
 |  |  | 从VB0开始的偏移量 | SMB276 | 0
 |  |  | 输出数据字节数 | SMB278 | 2
 |  |  | 输入数据字节数 | SMB279 | 2

表 7.EM277诊断

注：以上信息均可在《S7-200 可编程控制器 系统手册》


传送指令

系列视频：S7-200跟我学/跟我做:

S7-200CN: 单个数据传送指令-跟我学 - 103/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=352

S7-200CN: 单个数据传送指令-跟我做 - 104/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=353

S7-200CN: 块数据传送指令-跟我学 - 105/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=354

S7-200CN: 块数据传送指令-跟我做 - 106/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=355

S7-200CN: 其它传送指令-跟我学 - 107/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=356

S7-200CN: 其它传送指令-跟我做 - 108/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=357

传送指令

S7-200 传送指令分为单独传送，成块传送，交换，立即传送三大类，前两类传送指令又按传送的数据类型分为字节，字，双字，（实数）型。

下图所示为传送指令：

LAD | STL | 指令名 | 注释
 | MOVB IN，OUT MOVW IN，OUT MOVD IN，OUT MOVR IN，OUT | 移动字节/字/双字/实数 | 指令将输入字节/字/双字/实数（IN）移至输出字节/字/双字/实数（OUT），不改变原来的数值。
 | BMB，IN，OUT，N BMW，IN，OUT，N BMD，IN，OUT，N | 成块移动字节/字/双字 | 指令将字节/字/双字数目（N）从输入地址（IN）移至输出地址（OUT）。N的范围是1至255。
 | SWAP IN | 交换 | 指令交换字（IN）的最高位字节和最低位字节
 | BIR IN，OUT BIW IN，OUT | 移动字节立即读取 移动字节立即写入 | 指令读取实际输入IN（作为字节），并将结果写入OUT，但进程映像寄存器未更新。
注意：移动字节立即读取/写入指令，不支持扩展模块的通道。
如下为一个成块传送指令实例：

BLKMOV_B为将VB0开始的5个字节传送到VB100

传送后数值对应如下：

VB0 | VB1 | VB2 | VB3 | VB4
5 | 4 | 3 | 2 | 1
VB100 | VB101 | VB102 | VB103 | VB104
5 | 4 | 3 | 2 | 1

如下为SWAP交换指令实例：

 | 执行前 | 执行后
交换数据 | D6 C3 | C3 D6
数据地址 | VW50 | VW50


字符串及指令

系列视频：S7-200跟我学/跟我做:

S7-200CN: 字符串转换指令-跟我学 - 89/185：

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=338

S7-200CN: 字符串转换指令-跟我做 - 90/185：

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=339

字符串定义

字符串是一系列字符，每个字符作为一个字节存储。

字符串由变量存储时，字符串长度为0至254个字符，最长为255个字节，其中第一个字符为长度字节。

常数字符串直接输入程序编辑器或数据块时，最长为126个字节； 且常数字符串必须用双引号字符起始和结束 (如:"ABCD", "1234" )

字符串转换

将浮点数/双整/整数转换为字符串，分别为转换指令中的R_S,S_DI,I_S。

字符串转换为浮点数/双整/整数

分别为转换指令中的S_R,S_DI,S_I。只能转换0-9的字符，其他字符均为无效字符。

几点注意事项：

1.无法识别科学计数法或指数形式，但不会设置溢出错误SM1.1；例：“1.234E6”-->"1.234"

2.当达到字符串结束时或当发现第一个无效字符时，转换终止；例：“123A456”--->"123"

另，如“A123”，第一个字符即为无效字符，因此，设置溢出错误SM1.1。

3.S_I指令，当转换产生一个大于32767或小于-32768的值时，则设置溢出错误（SM1.1）

字符串指令

字符串指令如下表所示：

LAD/FBD | 指令名称 | 描述
 | 字符串长度 | IN：字符串变量地址； OUT：字符串长度的存储地址
 | 复制字符串 | 将位于IN处的字符串复制到OUT处的新字符串地址
 | 从字符串复制子字符 | INDX：IN处字符串的有效字符地址 N：复制长度 OUT：复制出的新字符串地址
 | 字符串连接 | 将IN指定的字符串附加至OUT指定的字符串之后
 | 在字符串内查找字符串 | 在字符串IN1中搜索首次出现的字符串IN2。搜索从OUT起始位置开始
 | 在字符串中查找第一个字符 | 在首次出现的字符串IN1中搜索字符串IN2中描述的字符集中的任何字符。搜索从起始位置OUT开始

指令例子如下：

其中，VB0初始状态为

执行程序后，AC0为11， AC1为7；VB0，VB100，VB20状态为：

常问问题

字符串中既含有数字又含有其他字符（字母，特殊字符），如何只转换数字部分？

如数字字符在前，其他字符在后；则可直接转换，转换部分到第一个非数字字符前。

如数字字符在后，其他字符在前；则

1.其他字符长度已知并固定；

如字符串定义如下：

注意：此处INDX处为有效字符的位数，不包含字符串第一位的长度字节

执行程序后，VW100=98；VD200=98；VD300=98.6

2.字符串实际内容未知或其他字符长度不定，则无法直接转换，否则设置溢出错误SM1.1。转换可参考如下程序：

注：CHR_FIND为在首次出现的字符串IN1中搜索字符串IN2中描述的字符集中的任何字符；找到的第一个相符字符的位置，被写入到OUT管脚。

仍以如下字符串为例：

程序执行后，AC0=7；VD100=98.6


表格指令

S7-200表格指令按照使用流程可分为

建表（内存填充FILL）--->填表（增加至表格ATT）--->[查询（表格查找TBL）]--->先入先出（FIFO） 或后入先出（LIFO）

下图所示为表格指令图示:

LAD | STL | 指令名称 | 注释
 | FILL，IN，OUT，N | 内存填充 | 用包含在地址IN中的字值写入N个连续字，从地址OUT开始。 N的范围是1至255。
 | ATT，DATA，TABLE | 增加至表格 | 向表格（TBL）中加入字值（DATA）。 表格中第一个数值为最大条目数，第二个数值为实际条目数。
 | FIND=TBL,PTN,INDX FIND<>TBL,PTN,INDX FIND>TBL,PTN,INDX FIND<TBL,PTN,INDX | 表格查找 | 在表格（TBL）中搜索与某些标准相符的数据。"
 | LIFO TABLE，DATA | 后入先出 先入先出 | 将表格中的最新（或最后）一个条目移至输出内存地址

注意：1.一个表格最多有100个条目（不包含最大条目数和实际条目数）

2.所有的表格读取和写入指令都必须用上升沿或下降沿指令触发激活。

表格指令实例如下：

注： 初始化定义表格最大长度

注： 从VW2开始，赋给”0“值

注：将内存位置VW100数值复制至表格

注：将最后一个表格数值移至位置VW102。这样会减少条目数。
注：将第一个表格数值移至位置VW102。这样会减少条目数。

注：复原索引指针，并查找等于10的表格条目


计数器指令

系列视频：S7-200跟我学/跟我做:

S7-200CN: 加计数-跟我学 - 66/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=315

S7-200CN: 加计数-跟我做 - 67/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=316

S7-200CN: 减计数-跟我学 - 68/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=317

S7-200CN: 减计数-跟我做 - 69/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=318

S7-200CN: 加减计数-跟我学 - 70/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=319

S7-200CN: 加减计数-跟我做 - 71/185

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=320

计数器

S7-200 指令提供了下述三种类型的计数器。

  • CTU：增计数器
  • CTD：减计数器
  • CTUD：增/减计数器

图1.计数器指令

  • CU：增计数信号输入端；
  • CD：减计数信号输入端；
  • PV：预置值；
  • LD：装载预置值；
  • R：复位输入；

计数器指令的有效操作数如下表所示：

表1：计数器指令接收操作数

输入/输出 | 数据类型 | 操作数
Cxx | WORD | 常数（C0到C255）
CU，CD，LD，R | BOOL | I，Q，V，M，SM，S，T，C，L，逻辑流
PV | INT | IW，QW，VW，MW，SMW，SW，LW，T，C，AC，AIW，*VD，*LD，*AC，常数

注意：当子程序在同一周期内被多次调用时，不能使用上升沿，下降沿，定时器和计数器。

注意：由于每个计数器有一个当前值，因此请勿将同一计数器编号分配给多个计数器。（编号相同的加计数器，加/减计数器和减计数器会访问相同的当前值）

计数器按如下表所列的规律工作：

表2.计数器工作规律

类型 | 操作 | 计数器位 | 上电周期/首次扫描
CTU | CU增加当前值。 直至达到32,767。 | 当前值〉=预设值时，计数器位接通 | 计数器位关断。 当前值可保留
CTD | CD减少当前值。 直至达到0 | 当前值=0时，计数器位接通 | 计数器位关断。 当前值可保留
CTUD | CU增加当前值。CD减少当前值。 当前值持续增加或减少，直至计数器复位。 | 当前值〉=预设值时，计数器位接通 | 计数器位关断。 当前值可保留

计数器计数范围为0~32,767。计数器号不能重复使用。计数器有两种寻址类型：Word（字）和Bit（位）。计数器号既可以用来访问 计数器当前值，也可以用来表示计数器位的状态。

增/减计数器指令举例如下图所示：

图2.增/减计数器指令

时序图如下所示：

图3.时序图

其中：

  • I0.0增计数；
  • I0.1减计数
  • I0.2将当前值复位为0；
  • 当前值大于等于5时，增/减计数计数器C48接通C48位。

标准计数器只能实现0-32,767之间数值的计数，如果需要大于32,767的循环计数，可使用如下附加指令库：

Counter_DINT

功能：使用该库指令可以实现S7-200 CPU计算大于16 位的循环计数。
下载地址：http://support.automation.siemens.com/CN/view/zh/35096610


无标题文档

取整指令

ROUND取整指令将实数（IN）转换成双整数，采用四舍五入的原则，将结果置入OUT指定的变量中。

TRUNC取整指令将实数（IN）转换成双整数，采用舍去小数位取整的原则，即将实数的整数部分置入OUT指定的变量中。

应用例程

图 1.程序示例

1）VD10=16.2，ROUND和TRUNC的运算结果都为16。

2）VD10=16.5，ROUND的运算结果为17，TRUNC的运算结果为16。


无标题文档

指数与对数相关概念

在介绍指令之前，首先了解一下指数和对数的相关概念及转换公式。

指数：乘方运算， [image],以 a 为底，x 为指数；其中，当底数为 e ，指数为 x 时，此时指数叫做自然指数

常用对数：以10为底的对数， [image] 记为 lgN

自然对数：以 e 为底的对数， [image] 记为 lnN。（ e 也叫欧拉数，约等于2.71828）

换底公式：

（a,c均大于0且不等于1）

举例：lg5=ln5/ln10 转换之后可以使用 LN 指令

注：以上介绍旨在抛砖引玉，有助于加深指令理解，如有不准确之处，请自行查阅相关资料！

自然指数与自然对数指令

自然指数（EXP）指令进行e 的IN次方指数计算，并将结果置于 OUT 中；也就是说 EXP 指令使用时必须要讲数据转换为以 e 为底的自然指数；IN输 入端填写转换后的指数位置的值。

自然对数（LN）指令对 IN 中的数值进行自然对数计算，并将结果置于 OUT 中。

自然指数（EXP）一般要和自然对数（LN）指令配合使用，即需要通过数学公式将数据转换为 e 的指数幂才可以使用 EXP 指令进行计算

举例：
5的立方 = 5^3=EXP(3*LN(5))=125

125的立方根 = 125^(1/3)=EXP(1/3)*LN(125))=5

5的立方的平方根 = 5^(3/2)=EXP(3/2*LN(5))=11.18034

10的（n-3）次幂=10^(n-3)=EXP((n-3)*LN(10))

以下为关于指令使用的例程,仅供参考,使用前请先自行测试！

EXP-LN.mwp


无标题文档

FOR-NEXT循环指令

1、FOR-NEXT 指令用于重复执行程序段，FOR 指令和 NEXT 指令之间的指令为循环体。

2、每条 FOR 指令需要有一条 NEXT 指令与之成对出现。

3、可以嵌套，嵌套深度为 8 层。

4、启用 FOR-NEXT 指令，首先将 INIT ( 初始值 ) 复制到 INDX（当前循环次数）；每执行一次，INDX (当前循环次数) 加 1； 如果 INDX 大于 FINAL (终止循环次数)，终止循环。

5、如果 INIT 值大于 FINAL 值，则不执行循环。

应用例程

通过 FOR-NEXT 指令，对 5 个变量：VW100、VW102、VW104、VW106、VW108 进行求和,求和结果放到 VW200 中，计算的平均值存放在 VD210 中 。

FOR-NEXT求和及求平均数.mwp

以上为关于指令使用的例程,仅供参考,使用前请先自行测试！

常问问题

FOR-NEXT指令的循环次数如何计算？

答：FOR-NEXT工作过程：启用FOR-NEXT指令，首先将 INIT( 初始值) 复制到 INDX（当前循环次数）；每执行一次，INDX (当前循环次数) 加1； 如 果 INDX 大于 FINAL (终止循环次数)，终止循环。

比如： INIT=1 FINAL=10，则循环体被执行10次，然后退出循环， 退出循环后INDX=11

INIT=0,FINAL=10, 则循环体被执行11次，然后退出循环，退出循环后INDX=11

FOR-NEXT指令执行时，主程序是否执行，对扫描周期的影响？

答：程序自上而下循环扫描，当FOR-NEXT指令启用后，则循环体被循环执行，直至循环次数到达，循环结束，程序继续向下执行。即在一个扫描周期内执行循环完毕后才会向下执行，循环次数越多，会导致扫描周期时间延长越多。如果循环次数过多或者出现死循环，会导致扫描周期时间超过看门狗时间，报出看门狗超时的致命错误，CPU停机并且SF/DIAG灯红灯常亮。

如何在FOR-NEXT执行循环过程中，退出循环？

答：您可以在FOR/NEXT 指令处于循环过程中时，在循环体中修改FINAL (终止循环次数)数值。


功能－数据记录（归档）

系列视频：S7-200跟我学/跟我做

S7-200CN: 使用数据记录向导-跟我学 - 153/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=402

S7-200CN: 使用数据记录向导-跟我做 - 154/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=403

S7-200CN: 数据归档的上载-跟我学 - 155/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=404

S7-200CN: 数据归档的上载-跟我做 - 156/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=405

数据归档

订货号含有23的S7-200 CPU及 Micro/WIN V4.0以上的软件已经支持数据归档功能。

数据归档通常是指按照日期时间排序的一组数据，每条记录都是某些过程事件的一套过程数据。这些记录可以包含时间及日期标签。用户可以通过程序控制永久保存过程数据记录到存储卡中，也就是说要使用数据归档功能，必须在PLC上插入一块64K或256K的存储卡。 数据归档数据存储在存储卡中，可以节约S7-200的V存储区，因为这些数据以前需要存储在V存储区，占用了很大的数据区空间。

  • 数据归档功能通过Micro/WIN软件中的数据归档向导来完成配置
  • 使用数据归档向导可以最多生成4个独立的数据归档 （每个数据归档可以拥有不同的数据结构）
  • 同一数据归档的数据结构相同
  • CPU可以通过编程，将数据写入存储卡；写入存储卡中的数据不能再读回CPU
  • 数据归档在存储卡中可储存的数据记录的数目没有限制（65535条）， 数据归档是一个环形队列，当归档记录满时，一条新的记录将代替第一条记录
  • 数据归档的上载通过S7-200资源管理器完成，上载的文件可以直接用Excel软件打开
  • 也可利用Windows的计划任务工具（Scheduling Task）将数据归档记录设定为在某一时刻自动上载到PC机

数据归档的使用

第一步：进入数据归档并生成新的数据归档

从指令菜单的Tools>Data Log Wizards或指令树下的Project>Wizards>Data Log进入数据归档向导。在使用向导时必须先对项目进行编译，如果已有的程序中存在错误，或者存在没有编完的指令，编译不能通过。

如果已经存在一个数据归档，可以选择修改原有的配置或添加一个新的数据归档

图1.生成新的数据归档

第二步：定义数据归档的可选项

图2. 定义数据归档的可选项

  1. 选择数据记录时加上PLC的时间标签
  2. 选择数据记录时加上PLC的日期标签
  3. 选择数据归档上载的同时清除卡中的归档文件
  4. 定义卡中存储的数据归档记录的最大条数（最多可设为65535）

注：数据归档是一个环形队列，当归档记录满时，一条新的记录将代替第一条记录

第三步：定义数据归档的数据域

图3. 定义数据域

  1. 定义数据的符号名
  2. 定义数据类型，支持的数据类型有BOOL，BYTE，WORD，INT，DWORD，DINT，REAL
  3. 数据的描述

注：在一个数据归档中，数据域最多可定义203字节，其中头信息要占3字节，日期戳要占3字节（如果选择），时间戳要占3字节（如果选择），减去以上9个字节，最多可定义194个字节的数据。

第四步：定义向导所需要的V存储区

图4. 分配向导所需要的V存储区

此区的地址注意在程序其它地方不要重复使用，也可单击“Suggest Address”，让向导自动选择一个正确长度的尚未使用的V存储区。

第五步：向导生成的项目组件

图5. 向导生成的项目组件

  1. 列出向导生成的可供用户使用的项目组件
  2. 数据归档配置的名称，可使用默认名，也可自己定义

第六步：数据归档的符号表

向导会自动生成数据归档的符号表，表中创建了所有数据域的符号名及参数地址，用户用这些符号名或地址直接访问V区的这些参数

图6. 数据归档向导生成的符号表

第七步：调用数据归档子程序，生成用户程序

数据归档向导完成后会在用户程序的项目中生成一个DATx_WRITE子程序，调用这一子程序根据逻辑条件可以将数据域中的当前值写到存储卡中。

图7. 用户程序

注意：EEPROM存储卡的写操作的典型值是一百万次，超出会使EEPROM失效。所以绝对不能在每个程序周期中都执行DATx_WRITE指令。

将数据归档记录上载到PC机后，用Excel打开该文件，便可看到记录的数据及日期戳、时间戳（如图8）。本例中每一条记录都是由I0.1的上升延触发写入的，用户可根据自己的需要用不同的条件来触发记录的写入。

图8. 数据归档记录

自动定时上载归档数据


Data log - disorder

使用 Excel 打开数据归档记录时，为何所有的汉字显示为乱码？

用 Excel 打开数据归档记录，即 *.csv 文件时，只有英文和数字能被正常显示，汉字显示为乱码，如下图所示：

图 1.

发生这个问题的原因在于，数据归档记录必须用 UTF-8 编码解读，而用户的 Excel 程序默认的解码方式是 Windows(ANSI) 或者其他。

这是微软公司产品的问题，而并非 STEP 7-Micro/WIN 或 S7-200 Explorer 的问题。

这一问题有以下两种解决方法：

  • 在配置数据记录时使用英文字符。要求自动上载，或上载后自动打开的项目必须如此设置。
  • 使用 Excel 导入数据的功能打开数据归档文件。

使用 Excel 导入数据的功能打开数据归档文件

用户使用“导入外部数据的方式打开数据归档记录”，详细步骤如下：

1、新建一个Excel表格，点击“数据 --> 导入外部数据 --> 导入数据"

图 2.

2、找到并打开数据归档记录

图 3.

上载的数据记录文件保存在特定文件目录中，如 C:\Program Files\Siemens\MicroSystems\Data Logs 。

3、文件原始格式选择”65001：Unicode(UTF-8)“

图 4.

4、分隔符号选择”逗号“

图 5.

5、点击”完成“

图 6.

6、选择导入数据的放置位置

图 7.

7、所有汉字能被正常显示，如下图所示：

图 8.


配方

系列视频：S7-200跟我学/跟我做

S7-200CN: S7-200CN中的配方功能-跟我学 - 148/185:

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=397

S7-200CN: 使用配方向导-跟我学 - 149/185:

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=398

S7-200CN: 使用配方向导-跟我做 - 150/185:

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=399

S7-200CN: 配方程序的编写-跟我学 - 151/185:

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=400

S7-200CN: 配方程序的编写-跟我做 - 152/185:

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=401

S7-200 配方快速入门

硬件需要：

S7-200 CPU （23系列，订货号为 6ES7 21x-xxx23-0XBx）；存储卡（64K存储卡，订货号为6ES7 291-8GF23-0XA0 或 256K存储卡，订货号为6ES7 291-8GH23-0XA0）；STEP 7-Micro/WIN软件，版本 V4.0 以上（可在西门子下载中心下载）。
STEP 7-Micro/WIN软件中提供了配方向导程序来帮助您组织配方和定义配方。配方存在存储卡中，而不是PLC中。

注：最多可以配置4 个配方集，而每个配方集中的配方个数，只受存储卡容量的限制。

一、配方的概念

为某种物质(如药品、食品、饮料)的配料提供方法和配比的处方。

二、使用配方向导

使用配方向导来创建配方和配方集，配方下载到存储卡中，不占用存储配方数据的V存储区；向导生成RCPx_READ，RCPx_WRITE指令子程序。RCPx_READ子程序用于读取配方数据值保存到PLC V存储区中。如需修改配方，可以再次运行配方向导，并重新下载，或者在程序中调用RCPx_WRITE子程序执行写配方功能。

1、定义配方

用配方向导创建一个配方，可在命令菜单中选择Tools > Recipe Wizard。这时屏幕上将出现配方向导基本操作的一个简单介绍。点击“下一步”，开始配制您的配方。

图1. 选择配方向导

A：为配方集指定域名。
B：选择数据类型。
C：输入缺省值和注释。在该配方集中的所有新配方将使用这些缺省值作为初始值。

图 2. 定义配方数据域

2、创建和编辑配方

A：点击“增加配方”按钮来创建配方。每个配方会将创建配方集时所指定的缺值作为初始值。
B ：每条新配方缺省名称的格式为：DEFx_RCPy，双击配方名称可以修改。
C ：根据需求改变每个配方数据的值。

图3. 定义配方数据值

3、分配存储区

分配存储区用于指定V存储区的起始地址，从该起始地址存储从存储卡中读取的配方。您可以自己选择V存储区地址，也可以使用配方向导建议的地址，配方向导会推荐您使用正确长度的尚未使用的V存储区。

图4.分配存储区

4、项目组件

配方向导为配方(符号表、数据块、子程序、存储卡数据)生成项目组件，点击“完成”来完成配方向导并将这些组件添加到项目中。
向导提示记录的数据最多可能使用存储卡的空间大小，方便用户选择适当的存储卡；

图5.生成项目组件

5、使用向导创建的指令

1)、RCPx_Read子程序

配方向导创建的子程序RCPx_READ，用于将配方从存储卡中读取到V存储区中。将配方数据值从存储卡复制到此向导的"数据块"页 RCP0_DATA中。配方数据值符号名在此向导的"符号表"标记页中RCP0_SYM加以定义。

RCPx_READ指令中的x 指明想读取的配方集编号。
当EN输入为高电平时，允许指令执行。
Rcp输入端决定了从存储卡中读取哪条配方。
Error输出端返回该指令的执行结果。

2)、RCPx_Write子程序

配方向导创建的子程序RCPx_WRITE。该指令用于将配方数据值写入存储卡。该子程序用于在存储卡内永久保存新的或修改后的配方数据值。

RCPx_WRITE指令中的x指明想写入的配方集编号。
当EN输入为高电平时，允许指令执行。
Rcp输入端决定了要写入存储卡中的配方。
Error输出端返回该指令的执行结果。

图6.配方子程序有效操作数

图7. 配方子程序的错误代码

注意：
EEPROM存储卡的写操作是有次数限制的，典型值为一百万次。一旦超出限制，EEPROM将失效。
因此请务必确认不是在每个程序周期中都执行RCPx_WRITE指令否则在很短的时间内，存储卡就会被损坏。

举例说明：

a) 用配方向导生成配方和配方集，生成子程序：

b) 调用子程序RCP0_READ

c) 将从存储卡读取的配方数据初始值存储在数据块“RCP0_DATA”页中

图8. 数据块中配方信息

d) 将从存储卡读取的配方域的符号名存储在符号表“RCP0_SYM”页中；

图9. 符号表中配方信息

e) 根据配方集和调用RCPx_Read的配方地址，在符号表中可以查看从存储卡中读取的配方数据；

DEF0_RCP1 配方地址为0(Rcp)

图10. 读取的配方数据

DEF0_RCP0 配方地址为1（Rcp）

图11. 读取的配方数据

6、下载配方项目

带有配方向导配置的项目下载至S7-200才能使用。如果某项目有配方配置，则下载窗口的默认设置为"配方"选项已被核取。配方下载选项必须得到核取，才能将配方数据载入存储卡。

图12.下载项目

成功下载后，在S7-200 Explorer中可查看配方是否存入存储卡。

图13. 查看S7-200资源管理器

7、编辑已有项目

如需编辑已有的项目，点击配置下拉列表，从中选一个现有或新的配方定义。最多可以有四个不同的配方定义。

图14.编辑已有项目


高速计数器

CPU上的集成高速计数器

S7-200 CPU具有集成的、硬件高速计数器。

CPU221和CPU222可以使用4个30kHz单相高速计数器或2个20kHz的两相高速计数器，而CPU224和CPU226可以使用6个30kHz单相高速计数器或4个20kHz的两相高速计数器。

S7-200的新一代产品CPU224 XP [image] 支持更高的计数速度。

高速计数器可以被配置为12种模式中的任意一种，但并不是所有计数器都能使用每一种模式。 在正交模式下，你可以选择一倍速或者四倍速计数速率。对于操作模式相同的计数器，其计数功能是相同的。

计数器共有四种基本类型：带有内部方向控制的单相计数器，带有外部方向控制的单相计数器，带有两个时钟输入的双相计数器和A/B相正交计数器。

表1. 高速计数器的模式及输入点：

模式 | 描述 | 输入点 |  |  |  | 备注
 | HSCO | I0.0 | I0.1 | I0.2 |  | (1)
 | HSC1 | I0.6 | I0.7 | I1.0 | I1.1 | (2)
 | HSC2 | I1.2 | I1.3 | I1.4 | I1.5 | (2)
 | HSC3 | I0.1 |  |  |  | (1)
 | HSC4 | I0.3 | I0.4 | I0.5 |  |
 | HSC5 | I0.4 |  |  |  |
0 | 带有内部方向控制的单相计数器 | 时钟 |  |  |  |
1 |  | 时钟 |  | 复位 |  |
2 |  | 时钟 |  | 复位 | 启动 |
3 | 带有外部方向控制的单相计数器 | 时钟 | 方向 |  |  |
4 |  | 时钟 | 方向 | 复位 |  |
5 |  | 时钟 | 方向 | 复位 | 启动 |
6 | 带有增减计数时钟的双相计数器 | 增时钟 | 减时钟 |  |  |
7 |  | 增时钟 | 减时钟 | 复位 |  |
8 |  | 增时钟 | 减时钟 | 复位 | 启动 |
9 | A/B相正交计数器 | 时钟A | 时钟B |  |  |
10 |  | 时钟A | 时钟B | 复位 |  |
11 |  | 时钟A | 时钟B | 复位 | 启动 |
12 | 只有 HSC0 和 HSC3 支持模式 12。 HSC0 计数高速脉冲输出 Q0.0； HSC3 计数高速计数脉冲输出 Q0.1。 |  |  |  |  |

(1) 支持模式 12。

  • 高速计数器的实际输入要根据用户选择的高速计数器号和模式来确定，如上表。例：如果你选择了HSC0的模式1，则你的外部高速计数输入点应接在I0.0，外部复位点应接在I0.2。
  • 如果用户使用了多个高速计数器，则被某一高速计数器占用了的输入点，其它高速计数器不能再使用。如HSC0的模式3已经占用了I0.1作为外部方向控制点，那么HSC3高速计数器就不能再使用了，因为它的计数输入点也是I0.1，与之冲突了。

(2) CPU 221/222 没有 HSC1 和 HSC2。

表2. 高速计数器的寻址

高速计数器号 | HSC0 | HSC1 | HSC2 | HSC3 | HSC4 | HSC5
新当前值（仅装入） | SMD38 | SMD48 | SMD58 | SMD138 | SMD148 | SMD158
新预置值（仅装入） | SMD42 | SMD52 | SMD62 | SMD142 | SMD152 | SMD162
当前计数值（仅读出） | HC0 | HC1 | HC2 | HC3 | HC4 | HC5

高速计数器的具体编程及相关的中断和其它参数，请参见《S7-200系统手册》，上面有详细的阐述及例程。

STEP 7-Micro/WIN 提供了一个方便实用的高速计数器指令编程向导，用户可以简单快速地配置自己的高速计数器功能。

高速计数器模式 12

S7-200 CPU 从 23 版以上开始支持高速计数器模式 12。

只有 HSC0 和 HSC3 支持模式 12。 HSC0 计数高速脉冲输出 Q0.0；HSC3 计数高速计数脉冲输出 Q0.1。

用户既可以自己编程使用模式 12，也可以在配置高速脉冲输出功能时，通过简单的设置使能模式 12。

常问问题：

CPU 224 XP 的高速计数器模式 12，是否可以计数 30 KHz 以上的脉冲？

CPU 224 XP 支持最多 100 KHz 的高速脉冲输出。S7-200 系列 CPU 只有高速计数器 HSC0, HSC3 能够被设置为模式 12，使用的输入端子为I0.0, I0.1，而不是特高速输入端子：I0.3、I0.4、I0.5。非特高速脉冲信号输入端由于硬件电路的限制（如光电耦合等）只能支持最高 30 KHz 的高速脉冲输入。

用户使用高速计数器模式 12 时不需要任何外部连线，Q0.0(Q0.1) 与 I0.0(I0.1) 通过集成电路内部关联，越过了外部信号处理电路，因此 HSC0(HSC1) 可以计 100KHz 或者更高频率的脉冲。用户在使用向导配置 S7-200 内部 PTO/PWM 操作时，勾选“使用高速计数器HSCx（模式12）自动计数线性 PTO 生成的脉冲”即可。

高速计数器怎样占用输入点?

高速计数器根据被定义的工作模式，按需要占用CPU上的数字量输入点。每一个计数器都按其工作模式占用固定的输入点。在某个模式下没有用到的输入点，仍然可以用作普通输入点；被计数器占用的输入点（如外部复位），在用户程序中仍然可以访问到。

为什么高速计数器不能正常工作?

在程序中要使用初次扫描存储器位SM0.1来调用HDEF指令，而且只能调用一次。如果用SM0.0调用或者第二次执行HDEF指令会引起运行错误，而且不能改变第一次执行HDEF指令时对计数器的设定。

对高速计数器如何寻址? 为什么从SMDx中读不出当前的计数值？

可以直接用HC0；HC1；HC2；HC3；HC4；HC5对不同的高速计数器进行寻址读取当前值，也可以在状态表中输入上述地址直接监视高速计数器的当前值。SMDx不存储当前值，参见上述表2。

高速计数器的计数值是一个32位的有符号整数。

高速计数器如何复位到0？

  • 选用带外部复位模式的高速计数器，当外部复位输入点信号有效时，高速计数器复位为0
  • 也可使用内部程序复位，即将高速计数器设定为可更新初始值，并将初始值设为0，执行HSC指令后，高数计数器即复位为0

高速计数器的值在复位后是复位到初始值还是“0”值?

外部复位会将当前值复位到0值而不是初始值；内部复位则将当前值复位到初始值。如果你设定了可更新初始值，但在中断中未给初始值特殊寄存器赋新值，则在执行HSC 指令后，它将按初始化时设定的初始值赋值。

为何给高速计数器赋初始值和预置值时后不起作用，或效果出乎意料?

高速计数器可以在初始化或者运行中更改设置，如初始值、预置值。其操作步骤应当是：

  1. 设置控制字节的更新选项。需要更新哪个设置数据，就把控制字节中相应的控制位置位（设置为“1”）；不需要改变的设置，相应的控制位就不能设置
  2. 然后将所需 的值送入初始值和预置值控制寄存器
  3. 执行HSC指令


Wizard - HSC

高速计数器向导

在 Micro/WIN 中的命令菜单中选择 Tools（工具） > Instruction Wizard（指令向导），然后在指令窗口中选择 HSC 向导，

图1.选择 HSC 向导

第一步，项目编译无错误后，选择HSC编号和模式，详细信息请见"表1.高速计数器的模式及输入点 。

图2. 高速计数器及模式选择

第二步，配置初始化信息

图3. HSC 初始化选项

在上图中：

  1. 为初始化子程序命名，或者使用默认名称。
  2. 设置计数器预置值：可以为整数、双字地址或 符号名：如 5000、VD100、PV_HC1。用户可使用全局符号表中双字整数对应的符号名。如果用户输入的符号名尚未定义，点击‘下一步’后会看到：

    点击‘Yes’。

    填入地址和注释，注意：地址必须为双字地址， 注释可以不填。
  3. 设置计数器初始值：可以为整数、双字地址或符号名：5000、VD100、CV_HC1。
  4. 初始化计数方向：增，减。
  5. 对于带外部复位端的高速计数器，可以设定复位信号为高电平有效或者低电平有效。
  6. 对于带外部启动端的高速计数器，可以设定启动信号为高电平有效或者低电平有效。如果使用的高速计数器或工作模式没有外部复位或启动端，则对应选项为虚。
  7. 使用A/B相正交计数器时，可以将计数频率设为1倍速或4倍速。使用非A/B相正交计数器时，此项为虚。

    注意：所谓“高/低电平有效”指的是在物理输入端子上的有效逻辑电平，即可以使 LED 灯点亮的电平。这取决于源型/漏型输入接法，并非指实际电平的高、低。

第三步：配置中断事件及步骤总数：

图 4.配置中断及步骤

如图 4 所示，一个高速计数器最多可以有 3 个中断事件，在白色方框中填写中断服务程序名称或者使用默认名称：

在这里配置的中断事件并非必须，系由用户根据自己的控制工艺要求选用。

  1. 外部复位输入有效值是中断，如果使用的高速计数器模式不具有外部复位端，则此项为虚。
  2. 方向控制输入状态改变时的中断，有以下 3 种情况会产生该中断：

    • 单项计数器的内部或外部方向控制位改变瞬间
    • 双相计数器增、减时钟交替的瞬间
    • A/B相脉冲相对相位（超前或滞后）改变时瞬间

  3. 当前值等于预置值时产生的中断，通过向导，可以在该中断的服务程序中重新设置高速计数器的参数，如预置值、当前值。一个这样的过程称为‘一步‘。
  4. 填写 HSC 的步数，最多可以设置 10 步。

第五步、定义高速计数器每一步中的操作：

图 5. HSC 第 1 步

在这里配置的是当前值等于设定值中断的服务程序中的操作：

  1. 向导会自动为当前值等于预置值匹配一个新的中断服务程序，用户可以对其重新命名，或者使用默认的名称。
  2. 勾选后，用户在右侧输入新的预置值。
  3. 勾选后，用户在右侧输入新的当前值。
  4. 如果选用的高速计数器模式有内部方向控制位。
  5. 点击‘下一步‘，继续配置其余步。

第六步、完成向导：

图 6. 完成向导

第七步、调用子程序：

注意：

  • HSC_INIT 为初始化子程序，请在主程序块中使用 SM0.1 或一条边沿触发指令调用一次此子程序。
  • 向导生成的中断服务程序及子程序都未上锁，用户可以根据自己的控制需要进行修改。


S7-200高速计数器使用前常问问题

S7-200的高速计数器怎样实现，需要加扩展模块吗？

S7-200 CPU具有集成的、硬件高速计数器。仅CPU本体集成的DI点支持 ，没有支持高速计数器的扩展模块

S7-200的高速计数器支持的数目是多少？

CPU221和CPU222可以使用4个30kHz单相高速计数器或2个20kHz的两相高速计数器；
CPU224和CPU226可以使用6个30kHz单相高速计数器或4个20kHz的两相高速计数器；
CPU224 XP高速输入中的两路支持更加高的速度。用作单相脉冲输入时，可以达到200KHz；用作双相90°正交脉冲输入时，速度可达100KHz。

S7-200的高速计数器支持的信号？

计数器共有四种基本类型：带有内部方向控制的单相计数器，带有外部方向控制的单相计数器，带有两个时钟输入的双相计数器和A/B相正交计数器

除224XP以外的CPU支持 24V的信号，源型 漏型均
224XP特高速输入点I0.3/I0.4/I0.5支持5 - 24VDC电压的源型或漏型输入；同组其他输入点电压可以仍然是24VDC，但求两者的电源的公共端在1M处连接

S7-200的高速计是否支持差分信号？

不支持差分信号

怎样判断高速计数器的当前计数方向？
如果启用该计数器的输入方向改变中断 可以直接用SM36.5查看
如果没有启用对应中断 SM36.5无效可以参考下面例程 ：

“如何在S7-200 PLC中判断A/B相正交计数器的方向”

http://www.ad.siemens.com.cn/download/docMessage.aspx?Id=6636

该功能对A/B正交信号也有效

如何用高速输入脉冲测定瞬时流量

请参考下面链接对应的常问问题：

http://www.ad.siemens.com.cn/download/docMessage.aspx?ID=5990&loginID=&srno=&sendtime=

怎样测定高速脉冲串的频率和速度

用户可以使用使用“Frequency”指令库，该指令库的下载和具体步骤参考下面链接：

https://support.industry.siemens.com/cs/document/27864874?dti=0&lc=zh-CN

注意：该库程序只能被调用一次，多次调用会导致频率计算错误。

使用高速计数器功能时，是否组要在系统块中修改高速计数器使用的数字量输入点的滤波参数？

不需要。S7-200高数计数器不受数字量输入滤波器的限制。


高速计数器的当前值的断电保持

如何在S7-200 CPU断电后保持高速计数器的当前值

1 问题描述

S7-200 的断电数据保持不支持高速计数器的范围设置，因此高速计数器的当前值在CPU每次断电后都会复位为数值0。要使S7-200高速计数器的当前值在CPU断电重启后依然保持，可以通过以下的编程来实现。

2 实现方法

在此以高速计数器0的模式1为例来说明如何在S7-200 CPU断电后保持高速计数器的当前值，具体可参考以下三个部分的编程来实现：
首先，在除了第一个扫描周期之外的其它周期，将高速计数器0的当前值HC0传送到寄存器VD1000中，如下图1所示，以保证寄存器VD1000始终存储的是HC0的当前值。

图1 传送当前值到寄存器

其次，在上电的第一周期将寄存器VD1000存储的数值传送到高速计数器的当前值，保证高速计数器以VD1000为初始值开始计数，并初始化高速计数器0，如下图2所示：

图2 初始化HSC0

最后，在系统块的断电数据保持处设置寄存器VD1000为断电保持区域，如下图3所示。需要注意的是CPU224及其以上的型号最多支持100个小时（理论值）的断电保持时间，如果断电时间超过100个小时的话，可以考虑增加电池卡；或者将当前值保存到MB0-MB13这14个字节的存储单元。

图3 设置断电数据保持


如何复位高速计数器

复位高速计数器有以下两种方式：

  • 外部复位 ： 选用带外部复位模式的高速计数器，当外部复位输入点信号有效时，高速计数器复位为0 （外部复位会将当前值复位到0值而不是初始值）
  • 内部复位 ： 也可使用内部程序复位，即将高速计数器设定为可更新初始值，并将初始值设为0，执行HSC指令后，高数计数器即复位为0 （内部复位则将当前值复位到初始值）

外部复位需要有带外部复位模式的高速计数器 通过I点实现 暂不做解释 下面介绍内部复位功能

组态一个高速计数器 例中用HSC0 模式0

1.首先在子程序 HSC_INIT 里编写高速计数器初始化程序

a. 因在子程序内 用SM0.0调用。保证调用该子程序时，该网络有效

b. SMB37 定义控制字节

例中SM37=16#F8=2#11111000 即允许更新当前值，预设值以及计数方向 ，这样 SMD38/42的设置才会有效

c. 装载当前值即初始值

d. 装载预设值

e. 高速计数器号

f. 高速计数器模式

g. 关联中断 如果高速计数器不需要中断 ATCH与ENI 可以省去

h. 中断事件号 HC0输入方向改变

i. 允许中断

j. 启用高速计数器 HSC0

2.其次在主程序用SM0.1或者一条边沿触发指令调用一次此子程序

3.编写复位子程序 RESET_HSC

4.用边沿触发指令调用 RESET_HSC

至此 只要M0.0上升沿触发 HSC0的当前计数值会复位为SMD38的数值 即HC0=SMD38=0 ;如果想要更改当前值为其他数值 同样程序 修改SMD38即可

怎样使用高速计数器中断

S7-200的高速计数器中断每个计数器共三种：

  • CV=PV (当前值=预设值)
  • 输入方向改变
  • 外部复位

当然 输入方向改变与外部复位中断需要与实际的计数器模式有关 例如 模式0 仅仅是脉冲计数 不能有后两种中断

上例中使用的的CV=PV中断 ，当中断事件到以后会去执行g.关联的INT1 实际上例能实现计数值从0~100然后变为50~200又变为0~100依次循环模式 具体可以参考下面的例子程序

高速计数器例程

为了更好地理解 高速计数器的编程，可参考下面的例程

HSC0 MODE0

注意：此指令程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为 此联系西门子技术支持与服务部门


PTO/PWM

S7-200 PLC 运动控制

S7-200 PLC 除具有可编程控制器的基本功能外，其本体的 Q0.0 和 Q0.1 高速脉冲输出点和 EM253 位置控制模块广泛用于控制步进电机和伺服电机运行。

S7-200 CPU 型号不同， 其脉冲输出类型， 电压，频率等参数不同，且 CPU 能扩展的 EM253 位置控制模块的数量也不一样。 如下表 1：

 | CPU221 DC/DC/DC | CPU222 DC/DC/DC | CPU224 DC/DC/DC | CPU224XP DC/DC/DC | CPU224XPSi DC/DC/DC | CPU226 DC/DC/DC | EM253
脉冲输出类型 | 源型 | 源型 | 源型 | 源型 | 漏型 | 源型 | 漏型/差分
脉冲输出电压 | 20.4-28.8 VDC | 20.4-28.8 VDC | 20.4-28.8 VDC | 5-28.8 VDC | 5-28.8 VDC | 20.4-28.8 VDC | 具体见《S7-200 系统手册》EM253 位控模块规范
最大输出频率 | 20 KHZ | 20 KHZ | 20 KHZ | 100 KHZ | 100 KHZ | 20 KHZ | 200 KHZ
集成输出高速脉冲数量 | 2 | 2 | 2 | 2 | 2 | 2 | 1
扩展EM253的最大数量 | - | 1 | 3 | 3 | 3 | 5 | -

表 1. S7-200 PLC 运动控制功能

S7-200 PLC 运动控制实现方式

S7-1200 PLC 可使用以下方式实现运动控制功能：

1. S7-200 CPU 本体的脉冲输出

使用 PLS 指令编程

PTO 向导

MAP 库

2. EM253 位置控制模块

S7-200 PLC 基于以上四种方式实现运动控制功能， 各有优势。 如下表 2：

S7-200 PLC 运动控制特点 | PLS 指令编程 | PTO 向导 | MAP 库 | EM253 位置控制模块
硬件成本 | 低 | 低 | 低 | 高
使用难易程度 | 难 | 易 | 易 | 较易
单速连续旋转 | PLC | Yes | Yes | Yes
双速连续旋转 | PLC | No | No | Yes
相对运动 | PLC | Yes | Yes | Yes
绝对运动 | PLC | No | Yes | Yes
包络运动 | PLC | Yes | 无 | Yes
回原点功能 | PLC | No | Yes | Yes

注：Yes—可立即使用的功能，No--无此功能，PLC--依靠PLC程序实现。

表 2. S7-200 PLC 运动控制实现方式比较

S7-200 PLC 包络运动

S7-200 PLC 仅在使用 PTO 向导和 EM253 位置控制模块时， 可以配置包络运动。

为方便，快速地实现向导配置和编程，用户需要先了解 S7-200 PLC 的包络运动。

包络：包络是一个预定义的移动描述。包络由多段组成，每段包含一个达到目标速度的加速/减速过程和以目标速度匀速运行的一串固定数量的脉冲。S7-200 CPU PTO 向导或 EM253 最多允许 25 个包络。

包络步：一个步是工件运动的一个固定距离，包括加速和减速时间内的距离。注意一步包络只有一个匀速段，两步包络有两个匀速段，依次类推。步的数目与包络中匀速段的数目一致。

S7-200 CPU PTO 向导一个包络表可以包含 1-29 个步，EM253 一个包络表可以包含 1-4 个步。在包络表中的所有周期值必须使用同一个时间基准，而且在包络正在运行时不能改变。

一步包络：

两步包络：

三步包络：

S7-200 PLC 包络操作模式

PTO 向导和 EM253 包络有不同的操作模式。对于 S7-200 PTO 可配置相对位置或单速连续旋转模式，EM253 可配置相对位置，绝对位置，单速连续旋转或双速连续旋转模式。

相对位置：结束位置是相对于起始位置的距离。

绝对位置：结束位置是相对于零点位置的距离。

单速连续旋转：程序控制按照指定目标速度连续运转， 直到发出另一个指令停止旋转。

双速连续旋转：RPS 信号有效时按照指定速度连续旋转， RPS 信号无效时按照另一速度连续旋转。

用 S7-200 和 SINAMICS V80 实现点到点位置控制

《用 S7-200 和 SINAMICS V80 实现点到点位置控制》

介绍：

本文档讲述了由 S7-200 和 SINAMICS V80 组成的位置控制系统的结构和选型，以及实现定位功能的三种方式。

下载网址：http://www.ad.siemens.com.cn/download/docMessage.aspx?Id=316

S7-200 连接 SINAMICS V90 实现位置控制

《S7-200 连接 SINAMICS V90 实现位置控制》

介绍：

文档中介绍了S7-200 控制 V90实现位置控制的方法。

下载网址：https://support.industry.siemens.com/cs/cn/zh/view/8873280

常问问题

S7-200 PLC 能接哪些类型的步进或伺服电机？

S7-200 CPU 除 CPU224 XPSi 以外，都只能接 PNP 输入信号的步进或伺服电机；

CPU224 XPSi 可以接 NPN 输入信号的步进或伺服电机；

EM253 可以接 NPN 或者差分输入信号的步进或伺服电机。

S7-200 PLC 最多能控制几个步进或伺服电机？

S7-200 CPU 本体最多输出 2 路高速脉冲信号， 因此最多控制两个步进或伺服电机；

使用 CPU 222 和 1 个 EM253 位置控制模块， 最多控制 3 个步进或伺服电机；

使用 CPU 224/224XP/224XPSi 和 3 个 EM253 位置控制模块， 最多控制 5 个步进或伺服电机；

使用 CPU226 和 5 个 EM253 位置控制模块， 最多控制 7 个步进或伺服电机；

注意： 用户所选用的 S7-200 CPU 的型号不一样， 因此脉冲输出类型和脉冲输出电压与 EM253 可能不一致。因此，在选型前， 用户务必先确认电机的信号接收类型和电压，使 S7-200 PLC 输出脉冲信号类型和电压与电机能接收的一致。


PTO/PWM

S7-200 CPU 脉冲输出功能

S7200 CPU DC/DC/DC 本体上有两个 PTO 脉冲发生器，它们每个都可以产生一个高速脉冲输出（PTO）。其最高频率可达 20K。

S7-200 的 新一代产品CPU 224 XP [image] 能够输出更高频率的脉冲 100K HZ。新一代产品在 PTO 功能上也得到改进，通过新编程软件 STEP 7-Micro/WIN V4.0 内置的 PTO 编程向导，用户可以实现线性升、降速斜率曲线，以及多段速度包络曲线，或者输出连续脉冲并根据需要按降速曲线停止。

PTO 与数字量输出过程映象寄存器共用输出点 Q0.0 和 Q0.1。当在 Q0.0 或 Q0.1 上激活 PTO 功能时， PTO 发生器对 Q0.0 或 Q0.1 拥有控制权，同时普通输出点功能被禁止。这时 Q0.0/Q0.1 的输出波形不受过程映象区状态、输出点强制值或者立即输出指令执行的影响。

脉冲串输出（PTO）

PTO 功能按照给定的脉冲个数和周期输出一串方波，占空比为 50％。PTO 可以产生单段脉冲或通过使用脉冲包络产生多段脉冲。必须为其设定脉冲个数和周期（以微秒或毫秒为单位）：

  • 脉冲个数：1－4 294 967 295
  • 周期：50μs（20K）到 65535μs 或者 2ms 到 65535ms（注：设定的周期应为偶数，否则会引起占空比失真。CPU224 XP 可以支持最短 10μs 脉冲周期。）

常问问题

使用 PTO 发生器的功能应使用什么类型的 CPU？

应使用 24VDC 晶体管输出的 CPU，继电器输出的绝对不行。

PTO 输出的幅值是多少？

PTO 输出幅值为 24V（高电平有效，共负端连接），若想实现输出其他电压的幅值，需自己加转换器来实现。CPU 224 XP 的高速输出点所在的数字量输出点可以支持 5 － 24V 电压幅值。

为何输出信号的指示灯已亮，却没有良好的电压波形输出，或者有时丢脉冲？

PTO 输出负载最小不能低于额定负载的10％；即在输出为高电平的状态下，负载电流不低于140mA。


PTO/PWM

S7-200 CPU PLS 指令功能

PLS 指令用于 S7-200 CPU 集成点 Q0.0 和 Q0.1 的脉冲输出，具有以下功能：

1. 用户根据实际需求，灵活编程实现脉冲周期和个数的控制

2. 单段管线：输出设定的一个脉冲串，并支持脉冲串排队，以保证脉冲输出的连续运行（队列中只能有一个脉冲串在等待）

3. 多段管线：顺序发送多个脉冲串（ 一个包络表可以包含 1-255 个脉冲串，在包络表中的所有周期值必须使用同一个时间基准，而且在包络正在运行时不能改变。）

PLS 指令位置控制功能使用步骤

1. S7-200 CPU 脉冲和方向输出点接线

2. PLS 控制盒状态字节赋值

3. PLS 指令编程

S7-200 CPU 脉冲和方向输出点接线

使用 PLS 指令用于 S7-200 CPU 脉冲输出和方向控制，用户应按照如下表 1 所示的定义接线：

 | PTO0 | PTO1
脉冲输出点 | Q0.0 | Q0.1
方向点 | 自定义 S7-200 CPU 其它输出点或数字量扩展模块输出点为方向点 | 自定义 S7-200 CPU 其它输出点或数字量扩展模块输出点为方向点

表 1. S7-200 CPU 脉冲和方向输出点

PLS 控制和状态字节

使用 PLS 指令使 S7-200 CPU 输出高速脉冲，需要用户自己编程， 给相应的特殊存储器赋值。

PLS 控制和状态寄存器详细参数和例程请参见《S7-200 系统手册》第 6 章 脉冲输出指令。

PLS 指令编程

PLS 指令单段管线编程步骤：

第一步. 设置 PTO 控制字节： 给 PTO0 寄存器 SMB67 或 PTO1 寄存器 SMB77 赋值

第二步. 写入周期值： 给 PTO0 寄存器 SMW68 或 PTO1 寄存器 SMW78 写入周期值

第三步. 写入脉冲串数值：给 PTO0 寄存器 SMD72 或 PTO1 寄存器 SMD82 写入脉冲数

第四步. 执行 PLS 指令

如果要修改 PTO 的周期， 脉冲数， 可以进一步在子程序或中断程序中按以下步骤编程：

第五步. 根据要修改的内容， 重新写入相应的控制字节

第六步. 写入新的周期， 脉冲数

第七步. 执行 PLS 指令

PLS 指令单段管线例程

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

例程 1：PTO0 以 500 ms 周期发出脉冲串，触发停止位时停止脉冲输出。

PTO0 以 500 ms 周期发出脉冲串例程

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

例程 2：PTO0 以 500 ms 周期发出 100 个脉冲。

PTO0 以 500 ms 周期发出 100 个脉冲例程

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程 修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

例程 3：PTO0 更改周期，不更改脉冲数发出脉冲串。

PTO0 更改周期，不更改脉冲数发出脉冲串例程

PLS 指令多段管线编程步骤：

第一步. 设置 PTO 控制字节， 选择多段管线： 给 PTO 0 寄存器 SMB67 或 PTO 1 寄存器 SMB77 赋值

第二步. 写入包络表起始地址到 PTO 0 寄存器 SMW168 或 PTO 1 寄存器 SMW178

第三步. 准备包络表，求出每段的周期增量

PTO 的段周期增量公式为：段周期增量 = （段终止周期 – 段初始周期） / 脉冲数量

第四步. 写入包络表总段数，每段起始周期，周期增量，脉冲数量到包络表地址

第五步. 执行 PLS 指令

PLS 指令多段管线例程

多段 PTO 应用例程请参考《S7-200 系统手册》第 6 章 脉冲输出指令：

例程 4：启动和最终脉冲频率是 2 kHz，最大脉冲频率是 10 kHz，要求 4000 个脉冲达到期望的电机旋转数。

由于包络表中的值是用周期表示的，而不是用频率，需要把给定的频率值转换成周期值。因此，初始和结束周期时间是 500 μs，相应于最大频率的周期时间是 100 μs。在输出包络的加速部分，要求在 200 个脉冲左右达到最大脉冲频率。也假定包络的减速部分，在 400 个脉冲完成。

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

多段PTO 应用例程

常问问题

如何强制停止 PTO 输出？

可以通过编程将控制字节中的使能位 SM67.7 或 SM77.7 清零，然后执行 PLS 指令，便可立即停止 PTO 输出。 以 PTO0 为例，如下图 1 所示：

图1. 停止 PTO脉冲输出

在 PTO 脉冲串执行过程中，能否通过 PLS 指令改变当前运行时的周期值？

不能在脉冲串输出过程中改变运行周期值，必须 PTO 停止后才能更改。

设置 PTO 的控制寄存器 SMD72=0 或 SMD82=0 ， 为什么执行 PLS 指令仍然有 1 个脉冲输出？

SMD72 或SMD82 设置脉冲范围的最小值是 1。因此，如果给 PTO 控制寄存器 SMW68 或 SMW78 装入了周期值和脉冲数，即使将 SMD72 设置为 0， 仍然会有一个脉冲输出。

如何判断 S7-200 CPU 脉冲已经输出？

可通过以下硬件输出点和软件中指令监视两种方法判断 S7-200 CPU 正在输出脉冲：

方法 1. 观察 S7-200 CPU 脉冲输出点 Q0.0 或 Q0.1 指示灯的状态：

当低频率脉冲输出时，Q0.0 或 Q0.1 的指示灯为闪烁状态。

方法 2. 监视 SM66.7 或 SM77.7 状态：

SMB66 和 SMB77 分别为 Q0.0 和 Q0.1 的状态字节。如果 SM66.7 或 SM76.7 状态为 0， 说明 PTO 执行中。


PTO/PWM

S7-200 CPU PTO 向导功能

使用 PTO 向导控制 S7-200 CPU 集成点 Q0.0 和 Q0.1 的脉冲输出更加容易。PTO 向导具有以下主要功能：

1. 手动运行

2. 包络运动。S7-200 CPU 最多允许 25 个包络，一个包络表可以包含 1-29 个步。包络运动可选以下两种操作模式：

（1）单速连续运转

（2）相对位置

3. 停止当前的连续运动包络，并增加向导包络定义中指定的脉冲数

4. 改变当前位置为指定的新位置

PTO 向导位置控制功能使用步骤

1. S7-200 CPU 脉冲输出和方向输出点接线

2. PTO 向导配置

3. PTO 向导子程序编程

S7-200 CPU 脉冲输出和方向输出点接线

使用 PTO 向导用于 S7-200 CPU 脉冲输出和方向控制，用户应按照如下表 1 所示的定义接线：

 | PTO0 | PTO1
脉冲输出点 | Q0.0 | Q0.1
方向点 | 自定义 S7-200 CPU 其它输出点或数字量扩展模块输出点为方向点 | 自定义 S7-200 CPU 其它输出点或数字量扩展模块输出点为方向点

表 1. S7-200 CPU 脉冲和方向输出点

PTO 向导配置

用户必须先配置 PTO 向导，才能使用 PTO 向导生成的子程序 。

用户可在STEP 7 Micro/Win 编程软件中选择菜单命令工具> 位控向导按照以下步骤执行：

注意：如下是使用西门子 SINAMICS V80 为例，而用户必须根据实际使用的电机参数设置 PTO 向导！

第一步. 为 S7-200 PLC 选择 “配置 S7-200 PLC 内置 PTO/PWM” 操作。如下图 1 所示：

图 1. 配置 S7-200 PLC 内置 PTO/PWM 操作

第二步. 选择 Q0.0 或 Q0.1，组态作为 PTO 的输出。如下图 2 所示：

图 2. 指定脉冲发生器

第三步. 从下拉对话框中选择 “线性脉冲串输出(PTO)” 。若想监视 PTO 产生的脉冲数目，点击复选框选择使用高速计数器。如下图 3 所示：

图 3. 选择 PTO

第四步. 设置最高电机速度 MAX_SPEED 和电机启动/停止速度 SS_SPEED。

为您的应用指定最高速度（MAX_SPEED）和开始／停止速度（SS_SPEED）。

  • MAX_SPEED：在电机扭矩能力范围内输入您的应用的最佳工作速度。驱动负载所需的转矩由摩擦力、惯性和加速／减速时间决定。位置控制向导会计算和显示由位控模块为指定的MAX_SPEED所能够控制的最低速度。?
  • SS_SPEED：在电机的能力范围内输入一个数值，以低速驱动负载。如果SS_SPEED数值过低，电机和负载可能会在运动开始和结束时颤动或跳动。如果SS_SPEED数值过高，电机可能在启动时丧失脉冲，并且在尝试停止时负载可能过度驱动电机。
注释：MIN_SPEED值由计算得出。您不能在此域中输入其他数值。

电机数据单有指定电机和给定负载开始／停止（或拉入／拉出）速度的不同方法。通常，有用的SS_SPEED数值是MAX_SPEED数值的5%至15%。SS_SPEED数值必须大于由您MAX_SPEED的规定所显示的最低速度。

为了帮助您就您的应用选择正确的速度，请参阅电机的数据单。下面的数字显示一条典型的电机扭矩／速度曲线。

计算公式：最高电机速度（Pulses/s）=电机额定转速（r/s）*电机每转一圈所需脉冲数（Pulses/r）

（ [image] 注意：此处设置的是直接与 S7-200 CPU 连接的电机速度，而非负载速度。）

实际应用中，或需考虑负载转速，脉冲与丝杠移动距离的最小长度单位，机械减速比，节距等参数，由此换算成电机速度。

最小长度单位：控制器发出一个脉冲时，丝杠移动的直线距离或旋转轴转动的度数配；
节距：负载每转移动距离或角度；
机械减速比：电机转速/负载转速；

以西门子的 SINAMICS V80 为例，电机的额定转速为 3000 r/min，即 50 r/s，设置 SINAMICS V80 指令脉冲分辨率为 1000（即控制器向 V80 发送 1000 个脉冲会使伺服电机转动一圈）；

因此，设置最高电机速度为电机额定转速即50（ r/s）*1000（Pulses/r）=50000（Pulses/s），启动/停止速度取其10%，即 5000 （Pulses/s）。

如下图 4 所示：

图 4. 设置电机速度

第五步. 设置加速时间 ACCEL_TIME 和减速时间 DECEL_TIME。如下图 5 所示：

以毫秒（ms）为单位指定下列时间：

  • ACCEL_TIME：电机从SS_SPEED加速至MAX_SPEED所需要的时间，默认值 = 1000 ms
  • DECEL_TIME：电机从MAX_SPEED减速至SS_SPEED所需要的时间，默认值 = 1000 ms

加速时间和减速时间的默认设置均为1秒。通常，电机所需时间不到1秒。

电机加速和减速时间由反复试验决定。您应当在开始时用位置控制向导输入一个较大的数值。当测试您的应用时，请根据要求调整有关数值。请通过逐渐减少时间直至电机开始停顿的方法，优化该应用的设置。

图 5. 设置加减速时间

第六步. 运动包络定义

不配置包络

根据具体需求，用户可以在PTO 向导中不配置包络运动，只手动运行 。直接点击 “确认” 按钮，如下图 6 所示：

图 6. 不配置包络

配置包络

用户如需配置包络，则点击 “新包络” 按钮，出现 “运动包络定义” 界面，点击 “Yes” 增加一个新包络运动。如下图 7 所示：

图 7. 配置新包络

针对每个包络，您必须选取下列参数：

  • 操作模式：您根据操作模式（相对位置或单速连续旋转）配置此包络。如果您选择单速连续旋转，您必须输入一个目标速度。请启用PTO_ADV复选框和一个停止距离，为此包络发起一个‘停止’。下图显示了不同的操作模式。

  • 包络的步骤：步骤是工具移动的固定距离，包括在加速时间和减速时间所走过的距离。每个包络最多可有4个单独步骤。您为每个步骤指定目标速度和结束位置。如果您有不止一个步骤，请单击"新步骤"按钮，然后为包络的每个步骤输入此信息。下图显示了四个可能的包络，但还可能有其他组合。

您只需点击"步骤绘图"按钮，即可检视根据位置控制向导的计算做出的此步骤之图形表示。这令您可轻易且互动地查看和编辑每个步骤。

位置控制向导也令您可通过在定义包络时输入一个符号名，为每个包络定义符号名。

在完成包络的配置后，您可以将它保存至配置。您的所有配置和包络信息都存储于数据块V内存赋值的PTOx_data页内。

以下针对两种操作模式举例介绍配置步骤：

（1）单速连续旋转

（2） 相对位置

单速连续旋转

对于单速连续旋转，需要输入目标速度。若想终止单速连续旋转，点击复选框 “编一个子程序（PTOX_ADV）用于此包络启动STOP（停止）操作”，并输入停止事件后的移动脉冲数。

以西门子的 SINAMICS V80 控制为例，如果设置目标速度 8000 脉冲/s，停止移动 0 脉冲，如下图 8 所示：

图 8. 单速连续旋转

相对位置

对于相对位置运动，需要输入目标速度和脉冲数。然后，用户可以单击 “绘制步” 按钮，观察运动的图示。根据移动的需要，您可以定义多个包络和多个步。

以西门子的 SINAMICS V80 控制为例，设置目标速度 8000 脉冲/s，结束位置 20000 脉冲，如下图 9 所示：

图 9. 相对位置

第七步. 分配 PTO 向导建议地址。如下图 10 所示：

注意： 建议地址不能在当前项目程序中再被使用。

图 10. PTO 向导建议地址

第八步. 选择完成 PTO 向导配置。如下图 11 所示：

图 11. 完成 PTO 向导配置

在脉冲输出向导当前界面按 F1 键可获取 PTO 向导配置帮助信息，或参考《S7-200 系统手册》第 9 章 S7-200 开环运动控制。

PTO 向导子程序编程

PTO配置中可能存在下列项目组件。在下面的组件名中，‘x’将用为脉冲发生而选择得输出位取代：‘0’代表Q0.0，‘1’代表Q0.1。此外，向导将通过附加字符‘_Z’，确保这些组件名在用户的项目中是唯一的；在此Z是一个基于零的指标。Z将不断递增，直至生成唯一的名称。请点击组件名，取得详细说明。

PTO配置的项目组件：

  • PTOx_CTRL（初始化和控制PTO操作）应在每次程序扫描时（于EN输入处）启用，并且由子程序调用而在您的程序中只执行一次。
  • PTOx_RUN（运行PTO包络）用于执行特定运动包络。当用户定义了一个或多个运动包络后，此子程序将为PTO向导配置生成。
  • PTOx_MAN（手动PTO模式）子程序可用来在程序控制下指挥脉冲发生。
  • PTOx_LDPOS（载入位置）子程序用于将某当前位置参数载入PTO操作。当用户选取了脉冲计数的高速计数器时，PTO向导会创建此子程序。
  • PTOx_ADV（前进）PTOx_ADV子程序会停止当前的连续运动包络并按照在向导包络定义中规定的脉冲数前进。如果您已在位置控制向导中指定了至少一个启用PTOx_ADV选项的单速连续旋转，此子程序就会得到创建。
  • PTOx_SYM （全局符号表）用于PTO向导配置中使用的变量。
  • PTOx_Data （数据块页）由向导配置使用的V内存数据。此数据包含参数表和运动包络定义。

PWM配置的项目组件：

PTO_CTRL子程序（控制）启用和初始化与步进电机或伺服电机合用的PTO输出，请在您的程序中只使用一次，并且请确定在每次扫描时得到执行。请始终使用SM0.0作为EN的输入。

I_STOP（立即停止）输入是一布尔输入。当此输入为低时，PTO功能会正常工作。当此输入变为高时，PTO立即终止脉冲的发出。

D_STOP（减速停止）输入是一布尔输入。当此输入为低时，PTO功能会正常工作。当此输入变为高时，PTO会产生将电机减速至停止的脉冲串。

Done输出是一布尔输出。当Done位被设置为高时，它表明上一个指令也已执行。

Error当Done位为高时，错误字节Error会报告无错误或有错误代码的正常完成。

C_Pos输出记录当前位置，如果PTO向导的HSC计数器功能已启用，C_Pos参数包含用脉冲数目表示的位置；否则此数值始终为零。

PTOx_CTRL指令的参数数据类型

错误代码表：

  • 0 -- 无错误。
  • 1 -- 在移动中曾发出“立即停止”指令。停止命令成功完成。
  • 2 -- 在移动中曾发出“减速停止”指令。停止命令成功完成。
  • 3 -- 在脉冲发生器中或PTO表的格式中检测到执行错误。
  • 128 -- PTO指令正在忙于执行另一项指令。
  • 129 -- “立即停止”命令和“减速停止”命令被同时启用。
  • 130 -- PTO子程序目前正在被命令“停止”。
  • 131 -- HSC、PLS或PTO子程序导致执行中的ENO错误。

PTOx_RUN子程序（运行包络）命令PLC执行存储于配置／包络表的特定包络中的运动操作。

EN位被开启会启用此子程序。在Done位发出子程序执行已经完成的信号前，请确定EN位保持开启。

START参数用于发起包络的执行。对于在START参数已开启且PTO当前不活动时的每次扫描，此子程序会激活PTO。为了确保仅发送一个命令，请使用边缘探测元素以脉冲方式开启START参数。

Profile（包络）参数包含您为此运动包络指定的编号或符号名。

Abort（终止）参数被开启时将命令位控模块停止当前包络并减速至电机停止。

Done（完成）参数的开启意味着本次包络已经完成。

Error（错误）参数包含本子程序的结果。

C_Profile参数包含位控模块当前执行的包络。

C_Step参数包含目前正在执行的包络步骤。

C_Pos输出记录当前位置，如果PTO向导的HSC计数器功能已启用，C_Pos 参数包含用脉冲数目表示的位置；否则此数值始终为零。

PTOx_RUN指令的参数数据类型:

错误代码表：

  • 0 -- 无错误。
  • 1 -- 在移动中曾发出“立即停止”指令。停止命令成功完成。
  • 2 -- 在移动中曾发出“减速停止”指令。停止命令成功完成。
  • 3 -- 在脉冲发生器中或PTO表的格式中检测到执行错误。
  • 128 -- PTO指令正在忙于执行另一项指令。
  • 129 -- “立即停止”命令和“减速停止”命令被同时启用。
  • 130 -- PTO子程序目前正在被命令“停止”。
  • 131 -- HSC、PLS或PTO子程序导致执行中的ENO错误。

PTOx_MAN子程序（手动模式）将PTO输出置于手动模式。这允许电机启动、停止和按不同的速度运行。当PTOx_MAN子程序已启用时，任何其他PTO子程序都无法执行。

RUN（运行/停止）参数被启用时，PTO将加速至指定速度（Speed）。您可以在电机运行中更改Speed参数的数值。停用RUN参数命令PTO减速至电机停止。

Speed参数确定着速度。速度是一个用每秒脉冲数计算的DINT（双整数）值。您可以在电机运行中更改此参数。

Error（错误）参数包含本子程序的结果。

C_Pos输出记录当前位置，如果PTO向导的HSC计数器功能已启用，C_Pos参数包含用脉冲数目表示的位置；否则此数值始终为零。

PTOx_MAN指令的参数数据类型

错误代码表：

  • 0 --无错误。
  • 1 -- 在移动中曾发出“立即停止”指令。停止命令成功完成。
  • 2 -- 在移动中曾发出“减速停止”指令。停止命令成功完成。
  • 3 -- 在脉冲发生器中或PTO表的格式中检测到执行错误。
  • 128 -- PTO指令正在忙于执行另一项指令。
  • 129 -- “立即停止”命令和“减速停止”命令被同时启用。
  • 130 -- PTO子程序目前正在被命令“停止”。
  • 131 -- HSC、PLS或PTO子程序导致执行中的ENO错误。

PTOx_LDPOS子程序（载入位置）将PTO脉冲计数器的当前位置值更改为一个新数值。您也可以使用本子程序为任何移动命令建立新的零位置。

EN位被开启会启用此子程序。在Done位发出子程序执行已经完成的信号前，请确定EN位保持开启。

START参数的开启会在PTO脉冲计数器中载入一个新位置。对于在START参数已开启且PTO当前不忙时的每次扫描，此子程序会在PTO脉冲计数器中载入一个新位置。为了确保仅发送一个命令，请使用边缘探测元素以脉冲方式开启START参数。

New_Pos参数提供取代现在报告的当前位置值的新值。位置值用脉冲数表示。

Done（完成）参数的开启意味着模块已完成本子程序。

Error（错误）参数包含本子程序的结果。

C_Pos输出记录当前位置，如果PTO向导的HSC计数器功能已启用，C_Pos参数包含用脉冲数目表示的位置；否则此数值始终为零。

PTOx_LDPOS指令的参数数据类型

错误代码表：

  • 0 -- 无错误。
  • 1 -- 在移动中曾发出“立即停止”指令。停止命令成功完成。
  • 2 -- 在移动中曾发出“减速停止”指令。停止命令成功完成。
  • 3 -- 在脉冲发生器中或PTO表的格式中检测到执行错误。
  • 128 -- PTO指令正在忙于执行另一项指令。
  • 129 -- “立即停止”命令和“减速停止”命令被同时启用。
  • 130 -- PTO子程序目前正在被命令“停止”。
  • 131 -- HSC、PLS或PTO子程序导致执行中的ENO错误。
PTOx_ADV子程序会停止当前的连续运动包络并按照在向导包络定义中规定的脉冲数前进。如果您已在位置控制向导中指定了至少一个启用PTOx_ADV选项的单速连续旋转，此子程序就会得到创建。

不配置包络（手动运行）

以 PTO0 为例，如果没有配置包络，则 PTO 向导只生成 PTO0_CTRL 和 PTO0_MAN 两个子程序。因此，只需要在程序中调用这两个子程序并输入相关参数即可。如下图 12 所示：

图 12. 不配置包络子程序

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

例程 1：以西门子 SINAMICS V80 为例，电机最高速度 50000 脉冲/s，启动/停止速度 5000 脉冲/s， 加减速时间1000ms，PTO 0 以 6000 脉冲/s 的速度手动运行。

PTO 0 以 6000 脉冲/s 的速度手动运行例程

配置包络（包络运行）

以 PTO0 为例，如果配置了包络，则 PTO 向导生成PTO0_ADV， PTO0_CTRL，PTO0_MAN，PTO_RUN 子程序。 用户根据具体控制需求在程序中调用以上子程序并输入相关参数。如下图 13 所示：

图 13. PTO 包络运行子程序

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

例程 2：以西门子 SINAMICS V80 为例，电机最高速度 50000 脉冲/s，启动/停止速度 5000 脉冲/s， 加减速时间 1000ms，PTO 0 以 8000 脉冲/s 的目标速度单速连续运行，或者执行相对位置运动以 8000 脉冲/s 目标速度运行 20000 脉冲的距离。

PTO 包络运动

PTO 向导子程序输入输出参数具体定义请参考《S7-200 系统手册》第 9 章 S7-200 开环运动控制。

常问问题

PTO 向导配置生成的数据块数值是否能在程序中或通过上位机修改？

以 PTO0 为例，PTO 向导配置完成后会生成名称为 PTO0_DATA 的数据块，如下图 14 所示：

该数据块数值不能在程序中或通过上位机赋值修改。如果用户有多个不同目标速度或目标位置的控制需求，必须通过建立并执行多个不同运动包络的方法来实现。

图 14. PTO 数据块

如何知道 S7-200 CPU 发送的当前脉冲数以及如何改变当前脉冲数值？

用户必须在 PTO 向导中先启动 “使用高速计数器HSC0（模式12）自动计数线性 PTO 生成的脉冲”， 如下图 15 所示：

图 15. 启动高速计数器模式12

以 PTO0 为例， 当启动了以上选项， 会自动生成子程序 PTO0_LDPOS, 如下图 16 所示：

图 16. PTO0_LDPOS 子程序

在 PTO 向导中启用了高速计数器模式 12，则在 PTO0_CTRL , PTO0_RUN，PTO0_MAN，PTO0_LDPOS 的输出管脚 C_Pos 地址中都存放了 S7-200 CPU 发送的当前脉冲数。

使用 PTO0_LDPOS 子程序不仅可以在线监视到 S7-200 CPU 发送的当前脉冲数，而且在执行该指令时可将 C_Pos 装载为新的脉冲值，如下图 17 所示：

图 17. PTO0_LDPOS 子程序


PTO/PWM

MAP指令库库文件

S7-200系列 PLC 本体 PTO 提供了应用库 MAP SERV Q0.0 和 MAP SERV Q0.1，分别用于 Q0.0 和 Q0.1 的脉冲串输出。

使用前，需要在 STEP7 Micro/Win 软件中添加 MAP 指令库。如下图所示：

库文件

map serv q0.0.mwl

map serv q0.1.mwl

关于如何添加指令库

参见：添加指令库

接线及分配库存储区

为了很好的应用该库，需要在运动轨迹上添加三个限位开关：

  • 一个参考点接近开关（home），用于定义绝对位置 C_Pos 的零点。
  • 两个边界限位开关，一个是正向限位开关(Fwd_Limit)，一个是反向限位开关(Rev_Limit)。
  • 绝对位置? C_Pos 的计数值格式为 DINT ，所以其计数范围为(-2.147.483.648 to +2.147.483.647)。
  • 如果一个限位开关被运动物件触碰，则该运动物件会减速停止，因此，限位开关的安置位置应当留出足够的裕量?Δsmin 以避免物件滑出轨道尽头。

应用这两个库时，一些输入输出点的功能被预先定义，使用时需要按照定义接线，如下表所示：

为了可以使用该库，必须为该库分配 68 BYTE（每个库）的全局变量，如下所示：

下表是使用该库时所用到的最重要的一些变量（以相对地址表示）：

MAP 库可实现功能

MAP 库指令用于 S7-200 CPU 集成点 Q0.0 和 Q0.1 的脉冲输出，MAP 库指令具有以下主要功能：

1. 初始化

2. 脉冲量与工程量转换

3. 按照指定方向和频率运行

4. 相对位置控制

5. 绝对位置控制

6. 回零点

7. 停止当前脉冲输出

8. 改变当前位置为指定的新位置

MAP库的指令块介绍及例程

Q0_x_CTRL

该块用于传递全局参数，每个扫描周期都需要被调用。

Velocity_SS 是最小脉冲频率，设置最小为 1，不能为 0，是加速过程的起点和减速过程的终点。

Velocity_Max 是最大小脉冲频率，受限于电机最大频率和PLC的最大输出频率。

accel_dec_time 是加减速时间，范围被规定为 0.02 ~ 32.0 秒，但最好不要小于0.5秒。

警告：超出 accel_dec_time 范围的值还是可以被写入块中，但是会导致定位过程出错！

Scale_EU_Pulse

该块用于将一个位置量转化为一个脉冲量，因此它可用于将一段位移转化为脉冲数，或将一个速度转化为脉冲频率。

下面是该功能块的计算公式：

Scale_ Pulse_EU

该块用于将一个脉冲量转化为一个位置量，因此它可用于将一段脉冲数转化为位移，或将一个脉冲频率转化为速度。

下面是该功能块的计算公式：

Q0_x_MoveVelocity

该功能块用于让轴按照指定的方向和频率运动，在运动过程中可对频率进行更改。

注意：Q0_x_MoveVelocity 功能块只能通过 Q0_x_Stop block 功能块来停止轴的运动。

Q0_x_MoveRelative

该功能块用于让轴按照指定的方向，以指定的速度，运动指定的距离。

Q0_x_MoveAbsolute

该功能块用于让轴以指定的速度，运动到指定的位置。

Q0_x_Home

该功能块用于寻找参考点，在寻找过程的起始，电机首先以 Start_Dir 的方向，Homing_Fast_Spd 的速度开始寻找；在碰到limit switch (“Fwd_Limit” or “Rev_Limit”)后，减速至停止，然后开始相反方向的寻找；当碰到参考点开关(input I0.0; with Q0_1_Home: I0.1)的上升沿时，开始减速到 “Homing_Slow_Spd”。如果此时的方向与 “Final_Dir” 相同，则在碰到参考点开关下降沿时停止运动，并且将计数器HC0的计数值设为 “Position” 中所定义的值。

如果当前方向与 “Final_Dir” 不同，则必然要改变运动方向，这样就可以保证参考点始终在参考点开关的同一侧（具体是那一侧取决于 “Final_Dir”）。

寻找参考点的状态可以通过全局变量 “Homing_State” 来监测：

Q0_x_Stop

该功能块用于使轴减速直至停止。

Q0_x_LoadPos

该功能块用于将当前位置的绝对位置设置为预置值。

注意：使用该块将使得原参考点失效，为了清晰地定义绝对位置，必须重新寻找参考点。

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

MAP库的应用.mwp

寻找参考点的若干种情况

在寻找参考点的过程中由于起始位置、起始方向和终止方向的不同会出现很多种情况。

一个总的原则就是：从起始位置以起始方向 Start_Dir 开始寻找，碰到参考点之前若碰到限位开关，则立即调头开始反向寻找，找到参考点开关的上升沿（即刚遇到参考点开关）即减速到寻找低速 Homing_Slow_Spd，若在检测到参考点开关的下降沿（即刚离开遇到参考点开关）之前已经减速到 Homing_Slow_Spd，则比较当前方向与终止方向 Final_Dir 是否一致，若一致，则完成参考点寻找过程；若否，则调头找寻另一端的下降沿。若在检测到参考点开关的下降沿（即刚离开遇到参考点开关）之前尚未减速到 Homing_Slow_Spd，则在减速到 Homing_Slow_Spd 后调头加速，直至遇到参考点开关上升沿，重新减速到 Homing_Slow_Spd，最后判断当前方向与终止方向 Final_Dir 是否一致，若一致，则完成参考点寻找过程；若否，则调头找寻另一端的下降沿。（Final_Dir 决定寻找参考点过程结束后，轴停在参考点开关的哪一侧）

下面的图形会反应不同情形下寻找参考点的过程。

Start_Dir=0,Final_Dir=0

Start_Dir=0, Final_Dir=1

Start_Dir=1, Final_Dir=0

Start_Dir=1, Final_Dir=1

S7-200 PLC 脉冲输出 MAP 库文件的使用

《S7-200 PLC 脉冲输出 MAP 库文件的使用》

介绍：

该文档提供了S7-200 PLC 脉冲输出指令库 MAP 的使用说明。该库基于 S7-200 PLC 本体脉冲输出指令，用于帮助用户实现较复杂的定位功能，控制伺服驱动或步进电机。

下载网址：http://support.automation.siemens.com/CN/view/zh/79604545

常问问题

使用 MAP 库指令后还需要创建 PTO 向导吗？

不需要。MAP 指令库与 PTO 向导不能对同一个轴控制同时使用。

以 MAP 库指令 Q0_0_CTRL 指令为例， 最大频率和启动停止频率设置为多少合适？

Q0_0_CTRL 指令输入参数最大频率受限于电机最大频率和 S7-200 CPU Q0.0 最大输出频率；

Q0_0_CTRL 指令输入参数启动/停止频率设置最小为 1，不能为 0。

如下图 1 所示：

图 1. Q0_0_CTRL 指令

注意：如果错误地将启动停止频率设置为 0， 则触发 MAP 库指令的脉冲输出指令也无法使 S7-200 CPU 输出高速脉冲。

当再触发 Q0_0_Stop 指令， CPU 报错停机， SF/DIAG 指示灯红色报警，在 PLC 信息可查看到内部软件错误。

如下图 2，3 所示：

图 2. Q0_0_Stop 指令

图 3. 内部软件错误

使 S7-200 CPU 输出高速脉冲需要使用哪些 MAP 库指令？

以 Q0.0 脉冲输出为例，必须使用 SM0.0 调用 Q0_0_CTRL 指令，而 Q0_0_MoveVelocity，Q0_0_MoveRelative，Q0_0_MoveAbsolute 指令都可以用于使 S7-200 CPU 输出高速脉冲。

以上三条指令分别用于按照指定速度和方向运行，相对位置， 绝对位置的控制， 具体使用哪一条则根据用户的实际需求调用。

如何判断 S7-200 CPU 已经发送出脉冲？

可通过以下硬件输出点和软件中指令监视两种方法判断 S7-200 CPU 正在输出脉冲：

方法 1. 观察 S7-200 CPU 脉冲输出点 Q0.0 或 Q0.1 指示灯的状态：

当低频率脉冲输出时，Q0.0 或 Q0.1 的指示灯为闪烁状态。

方法 2. 在 STEP 7 Micro/Win 编程软件中在线监视 Q0_0_CTRL 或 Q0_1_CTRL 指令输出参数 C_Pos 数值：

S7-200 CPU Q0.0 脉冲输出, Q0.2 方向控制点状态为 0 时，C_Pos 数值不断减小；S7-200 CPU Q0.0 脉冲输出, Q0.2 方向控制点状态为 1 时，C_Pos 数值不断增加。

S7-200 CPU Q0.1 脉冲输出, Q0.3 方向控制点状态为 0 时，C_Pos 数值不断减小；S7-200 CPU Q0.1 脉冲输出, Q0.3 方向控制点状态为 1 时，C_Pos 数值不断增加。

以 Q0_0_CTRL 为例，如下图 4 所示：

图 4. 监视 C_Pos 数值变化

在 MAP 库指令中如何知道 S7-200 CPU 输出脉冲的频率？

可以通过以下两种方法监视到 S7-200 CPU 输出脉冲的频率：

1. MAP 库预先定义了 SMD172 和 SMD 182 分别为Q0.0 和 Q0.1 的脉冲频率值 ，在该特殊存储器地址中可以监视到 S7-200 CPU 输出脉冲的频率。

2. MAP 库预先定义了高速计数器 HC0 和 HC3，可以利用测量高速频率串的频率和速度库指令来计算 S7-200 CPU 输出脉冲的频率。

下载网址：

http://support.automation.siemens.com/CN/view/zh/27864874

以 Q0_0_Stop 指令为例， 使用该指令能否实现S7-200 CPU 立即停止脉冲输出？

不能。触发 Q0_0_Stop 指令只能实现减速停止脉冲输出。

使用 MAP 库指令如何实现急停开关按下时，立即停止？

以 Q0_0_CTRL 为例，当该指令的正向极限或反向极限信号为 1 时，S7-200 CPU立即停止脉冲输出。

因此可将急停开关信号接入正向极限或反向极限信号来实现立即停止脉冲输出。编程方法可参考如下图 5 所示：

图 5. 急停编程

使用 MAP 库指令是否可以在 S7-200 CPU 脉冲输出时修改频率？

以轴 0 为例， Q0_0_MoveRelative，Q0_0_MoveAbsolute 不能在 S7-200 CPU 脉冲输出时修改频率；

使用 Q0_0_MoveVelocity 指令，需要先赋予新的频率值，重新使用上升沿信号触发 Q0_0_MoveVelocity 指令执行位， S7-200 CPU 即可按照修改后的新频率值运行。

如下图 6 所示：

图 6. Q0_0_MoveVelocity 指令修改脉冲输出频率

使用 MAP 库指令回零点，回零点的速度是否可以修改？

可以。以轴 0 为例，回零点高速 Homing_Fast_Spd 默认为 Q0_0_CTRL 指令中输入参数最大频率Velocity_Max/2 ；回零点低速 Homing_Slow_Spd 默认为 Q0_0_CTRL 指令中输入参数启动停止频率 Velocity_SS。

可按照如下步骤修改回零点的速度：

第一步. 如库存储区建议地址为VB0至VB67， 如下图 7 所示：

图 7. 库存储区建议地址

第二步. 在符号表 MAP SERV Q0.0（V1.8）找到回零点高速 Homing_Fast_Spd 和回零点低速 Homing_Slow_Spd 对应的地址。Homing_Fast_Spd 存放地址为VD23，Homing_Slow_Spd 存放地址为VD19，如下图 8 所示：

图 8. 查找回零点速度地址

第三步. 在执行回零点运动前，将修改的回零点高速 Homing_Fast_Spd 和回零点低速 Homing_Slow_Spd 新值通过 MOVE 传送指令传送到 VD23 和 VD19。 如下图 9 所示：

图 9. 修改回零点速度

注意：一旦 Q0_X_CTRL 指令中输入参数最大频率 Velocity_Max 或启动停止频率 Velocity_SS 速度改变，回零点高速 Homing_Fast_Spd 和回零点低速 Homing_Slow_Spd 又自动按照默认值计算出。


PTO/PWM

EM253 在线学习视频

http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=1556
http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=1557
http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=1558
http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=1559

EM253 位置控制功能

EM 253 是 S7-200 PLC 唯一的一款位置控制模块， 用于驱动步进电机和伺服电机， 为用户提供单轴，开环的位置控制。

EM253 位置控制模 块具有以下主要功能：

1. 输出 20 HZ－200 KHZ 的高速脉冲

2. 漏型晶体管或者差分信号脉冲输出

3. 可组态测量系统为工程量或脉冲数

4. 包络运动。提供最多 25 组包络，每组可有4种速度。包络运动可选以下四种模式：

（1）绝对位置

（2）相对位置

（3）单速连续旋转

（4）双速连续旋转

5. 回零点。提供4种不同的参考点寻找模式

6. 支持S曲线或线性的加速、减速功能

7. 提供可组态的螺距补偿功能（螺距误差补偿是在机械运动方向发生变化时，为消除系统中的滞慢(螺距误差)，电机必须移动的距离。螺距误差补偿总是正值。）

注意：以下例程仅为示例程序，请勿直接用于测试！

测试前，用户务必使用晶体管输出的 S7-200 CPU，并根据实际使用的电机参数和机械行程修改程序中的相关数值！

此程序的作者和拥有者对于该程序的功能性和兼容性不负任何责任。使用该程序的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

EM253的应用_脉冲数.mwp

EM253 位控模块使用步骤

1. EM253 输入/输出点接线

2. EM253 向导配置

3. EM253 子程序编程

4. EM253 诊断调试

以上 EM253 输入/输出点接线，向导配置，编程，调试请参考《定位模板 EM253 快速入门》文档或 《S7-200 系统手册》第 9 章 S7-200 开关运动控制 组态位控模块章节。

定位模块 EM253 快速入门

《定位模板 EM253 快速入门》：

介绍：

该文档主要面对初次使用定位模板 EM 253 的用户。内容包括一些调试的步骤，使用经验，等等。但是，该文档无法取代《SIMATIC S7－200 可编程序控制器系统手册》。建议：用户通过此文档掌握了初步调试和使用模板的方法以后，还是要认真、仔细阅读《SIMATIC S7－200 可编程序控制器系统手册》第 9 章，进一步加深对定位模板 EM 253 的理解。通过该文档，希望对初次使用定位模板 EM 253 的用户，可以起到帮助入门的作用。定位模板 EM 253 模板的使用者，应该具有STEP 7-Micro/Win 软件操作的基础知识。

下载网址：http://support.automation.siemens.com/CN/view/zh/7968718

常问问题

一个 EM253 模块能带几个轴？

一个 EM253 模块只能带一个轴。

EM253 模块能实现闭环运动控制吗？

不能。

更换 EM253 模块需要重新组态或编程再下载吗？

使用 STEP 7 Micro/Win 配置 EM253 所使用的全部组态，移动包络信息和程序块一起下载并存储在 S7-200 CPU 中 ，因此更换 EM253 模块后不需要重新组态或编程再下载。

EM253 模块的哪些端子用于输出高速脉冲信号？

用户可以根据电机驱动器/放大器的接口要求来选择使用哪种输出。

EM253 模块的 P0 和 P1 是漏型晶体管输出，分别用以控制电机的运动和方向。

P0+、P0- 以及 P1+、P1- 是差分脉冲输出，与P0和P1的功能一样，但所提供的信号质量更好。

如何设置 EM253 位控模块配置向导中的 “模块位置”？

在 EM253 位控模块配置向导中，需要正确指定模块位置。模块位置的计算遵循紧挨 CPU 放置的模块位置是 0， 以此类推。如果在配置时实际连接了 EM253 硬件模块，则可直接点击”“读取模块”。

如下图 1 所示：

图 1. EM253 模块位置

EM253 命令字节 QB 如何计算？

命令字节是一个 8 位数字量输出的地址，该地址保留在用于访问位控模块的过程影像寄存器中。该命令字节根据 EM253 模块前占用的 QB 决定。

例如 CPU 224 模块占用了 QB0 和 QB1 地址， 如果 EM253 紧挨 CPU 放置， 则 配置 EM253 命令字节为 QB2。如下图 2 所示：

图 2. EM253 命令字节

EM 253 位控模块生成的子程序所有 C_POS， C_SPEED 引脚都一样吗？

是的， 都一样。因此，无论调用几个子程序， 可以将这两个引脚的地址都设置为同一个。

为什么通过 POS0_GOTO 指令执行绝对运动报错， 错误代码为 22？

查看 EM253 位控模块指令错误代码信息， 错误代码 22 含义为零位置未知。因此，无论是使用 POSX_GOTO 还是其它运动控制指令执行绝对运动，必须先执行了 POSX_RSEEK 指令回零点或使用 POSX_LDPOS 指令建立绝对位置零点。

什么是 EM253 的参考点偏移量？

EM 253 参考点偏移量概念：

EM253 的参考点偏移量 RP_OFFSET 是指从 RP 到零位置的距离。如下图 3 所示：

图 3. 参考点偏移量示意图

设置 EM 253 参考点偏移量：

EM253 的参考点偏移量 RP_OFFSET 可以在 “高级 RP 选项” 界面设置，如下图 4 所示：

图 4. 设置参考点偏移量

或者在 EM253 控制面板，启用“允许更新 PLC 中的模块配置”，设置参考点偏移量 RP_OFFSET，点击 “更新配置” 即可。如下图 5 所示：

图 5. 更新 RP_OFFSET

EM 253 参考点偏移量地址：

EM253 的参考点偏移量 RP_OFFSET 地址可在数据块中查看到， 如下图 6 所示 VD1088 ：

图 6. 参考点偏移量地址

在 EM253 向导中修改参考点偏移量与执行 POS0_LDOFF 指令修改参考点偏移量有何区别？

举例说明在 EM253 向导组态中修改参考点偏移量前后数值变化。

在 EM253 向导组态中设置参考点偏移量 0 ，如下图 7 所示：

图 7. 设置参考点偏移量 0

在状态表监视参考点偏移量 0， 执行回零点运动后，当前位置 0，如下图 8 所示：

图 8. 监视参考点偏移量 0

在 EM253 向导组态中设置参考点偏移量 100 ，如下图 9 所示：

图 9. 设置参考点偏移量 100

在状态表监视参考点偏移量 100， 执行回零点运动后，当前位置 100，如下图 10 所示：

图 10. 监视参考点偏移量 100

举例说明执行 POS0_LDOFF 指令修改参考点偏移量前后数值变化。

执行 POS0_LDOFF 指令前，将运动控制对象移动到位置 100。在状态表监视参考点偏移量 0， 当前位置 100，如下图 11 所示：

图 11. 监视参考点偏移量

在当前位置 100 处，执行 POS0_LDOFF 指令。之后，在状态表监视参考点偏移量 -100， 当前位置 0，如下图 12,13 所示：

图 12. 执行 POS0_LDOFF 指令

图 13. 监视参考点偏移量 -100

执行回零点运动后， 当前位置为 -100，如下图 14 所示：

图14. 监视当前位置-100

为什么执行子程序 POSX_LDOFF 报错， 错误代码为 6？

在程序中执行子程序 POSX_LDOFF， 出现错误代码 6，如下图 15 所示：

图 15. 子程序 POS0_LDOFF 出错

查看 EM253 位控模块指令错误代码信息， 错误代码 6 含义是由于没有定义的参考点而放弃。因此， 执行子程序 POSX_LDOFF 前，必须先执行了 POSX_RSEEK 指令，建立了参考点 。

EM 253 位控模块生成的子程序 POS0_LDOFF 与 POS0_LDPOS 有何区别 ？

子程序 POS0_LDOFF 用于装载参考点偏移量。

执行该子程序时，位控模块计算当前位置与参考点之间的偏移量，将该数值存储到 RP_OFFSET，并将当前位置设为 0。如下图 16 所示：

图 16. 子程序 POS0_LDOFF

POS0_LDPOS 指令用于改变模块的当前位置， 也可用于为绝对运动建立一个新的零位置。

例如，执行子程序 POS0_LDPOS 前，当前位置 VD 300 =+100。如下图 17 所示：

图 17. 执行子程序POS0_LDPOS 前

设置新位置 VD 108=0，执行子程序 POS0_LDPOS 后，当前位置 VD 300 =0。如下图 18 所示：

图 18 . 执行子程序 POS0_LDPOS 后

EM 253 位控模块配置好的加减速时间可以修改吗？

可以。而且可通过以下三种方法进行修改：

方法 1. 程序中调用子程序 POS_SRATE 直接修改。

如执行POS0_SRATE 指令，修改加减速时间为 1500 ms ，如下图 19 所示：

图 19. 子程序 POS0_SRATE

方法 2. 找到数据块中相应的 V存储区地址，然后在程序中赋新值 ，并执行 CFG 指令。

第一步：先在 EM253 向导生成的数据块中找到加速时间和减速时间分别对应的地址， 如 VD1062 和 VD1066 ，如下图 20 所示：

图 20. 加减速时间地址

第二步：在程序中通过 MOVE 指令给加减速时间存放地址赋值， 如下图 21 所示：

图 21. 加减速时间赋值

第三步：在程序中执行 CFG 指令， 重新装载组态，如下图 22 所示：

图 22. 子程序 POS0_CFG

方法 3. 在 EM253 配置标签栏修改。

在 EM 253 控制面板的配置标签栏，先勾选 “允许更新 PLC 中的模块配置”，输入新的加速时间 ACCEL_TIME 和减速时间 DECEL_TIME，点击“更新配置” 即可。如下图 23 所示：

图 23. 在 EM253 调试面板修改加减速时间

当观察到 EM253 MF 指示灯红色报警时该如何处理？

出现 EM253 MF 指示灯红色时，表明定位模板 EM 253 发生了致命错误，客户可以按照以下步骤排查问题：

第一步. 查看菜单栏“PLC”/信息，以确定 EM253 模块的总线连接正常。如下图 24 所示：

图 24. PLC 信息

2. 如果在 “PLC”/信息未找到 EM253 模块， 则说明总线连接有问题或模块硬件故障。因此， 需要更换模块测试。

3. 检查前模块与 EM253 之间总线连接。可将 S7-200 CPU 和 EM253 系统先断电，检查总线连接是否松动，总线上的插针是否移位。

4. 考虑现场的 EMC。 可将 S7-200 CPU 和 EM253 系统移出干扰现场测试。

5. 考虑 EM253 是否接地。如果现场接地情况良好， 将 EM253 做接地处理。

怎样配置定位模块 EM253 来控制双方向步进电机？

如果您使用的驱动器需要两个方向的脉冲输出（正向=顺时针/反向=逆时针），可在 EM253 位控模块配置向导中设置，具体请参考以下链接：

https://support.industry.siemens.com/cs/cn/zh/view/31095097

启用“Abort”参数时，EM 253 中为何错过了限位开关？

如果您对当前有效的 EM 253 操作 “POSx_GOTO”或“POSx_RUN” 启用 “Abort” 参数，限位开关可能会被错过。具体问题及解答请参考以下链接：

https://support.industry.siemens.com/cs/cn/zh/view/17576162

当检测 EM253 模块运行路径时需要注意哪些方面？

如果用户希望基于当前运行的路径，通过扩展模块 EM 253 执行操作，需要了解的几点注意事项请参考以下链接：

https://support.industry.siemens.com/cs/cn/zh/view/37229101

为什么 EM 253 在脉冲速度变化和停/启时得到CPU请求之后会偶然出现长时延(S7-200)?

S7-200 CPU上速度变化请求和 EM 253上的脉冲速度变化间的响应时间是由几个因素决定的。具体请参考以下链接：

https://support.industry.siemens.com/cs/cn/zh/view/22629926


PTO/PWM

PWM 输出功能

S7-200 CPU 本体上有两个 PWM 脉冲发生器，它们每个都可以产生一个脉宽调制波形（PWM）。其最高频率可达20K。

S7-200 的新一代产品CPU 224 XP [image] 能够输出更高频率的脉冲。

PWM 与数字量输出过程映象寄存器共用输出点 Q0.0和 Q0.1。当在 Q0.0 或 Q0.1 上激活 PWM 功能时，PWM 发生器对 Q0.0 或 Q0.1 拥有控制权，同时普通输出点功能被禁止。这时 Q0.0/Q0.1 的输出波形不受过程映象区状态、输出点强制值或者立即输出指令执行的影响。

脉宽调制输出（PWM）

PWM 功能产生一个占空比变化周期固定的脉冲输出。你可以为其设定周期和脉宽（以微秒或毫秒为单位）：

  • 周期：50μs 到 65535μs 或者 2ms 到 65535ms（CPU224 XP 可以支持最短 10μs 脉冲周期。）
  • 脉宽：0μs 到 65535μs 或者 0ms 到 65535ms（最低 50μs，设置为 0μs 等于禁止输出；CPU224 XP 可以支持最短 10μs 脉冲周期。）

PWM 发生器的详细参数和例程请参见《S7-200系统手册》。

常问问题

使用 PWM 发生器的功能应使用什么类型的 CPU？

应使用 24VDC 晶体管输出的 CPU，继电器输出的绝对不行。

PWM 输出的幅值是多少？

PWM 输出幅值为 24V（高电平有效，共负端连接），若想实现输出其他电压的幅值，需自己加转换器来实现。CPU 224 XP 的高速输出点所在的数字量输出点可以支持 5 － 24V 电压幅值。

如何强制停止 PWM 输出？

可以通过编程将控制字节中的使能位 SM67.7 或 SM77.7 清零，然后执行 PLS 指令，便可立即停止 PWM 输出。如下图 1 所示：

图 1. 停止 PWM 输出

为何输出信号的指示灯已亮，却没有良好的电压波形输出，或者有时丢脉冲？

PWM 输出负载最小不能低于额定负载的 10％；即在输出为高电平的状态下，负载电流不低于 140mA。

如何改变 PWM 输出的周期/脉冲宽度？

PWM 功能可以在初始化时设置脉冲的周期和宽度，也可以在连续输出脉冲时很快地改变上述参数。其操作步骤为：

  1. 设置控制字节，以允许写入（或者更新）相应的参数
  2. 将相应的特殊存储器写入新的周期/脉宽值
  3. 执行 PLS 指令，对 PTO/PWM 发生器进行硬件设置变更

用户的具体项目也可能要求先中止前一个 PTO 脉冲管道，然后再定义新的管道。

当周期小于 50μs 时为何不能获得满意的波形输出？

因为限制 PWM 输出的因素有两个：

  • 硬件输出电路响应速度的限制，对于 Q0.0 和 Q0.1 从断开到接通为 2 μs，从接通到断开 10 μs ，因此最小脉宽不可能小于10 μs。
  • 最大的频率为 20K，因此最小周期为 50 μs。

所以如果脉宽低于 50 μs 的波形无法保证。

不论是连续脉冲，还是相对较长周期内的单个脉冲，其脉冲宽度限制都是相同的。

新产品 CPU224 XP支持 10μs 的脉冲周期。


PID功能

PID控制

S7-200能够进行PID控制。S7-200 CPU最多可以支持8个PID控制回路（8个PID指令功能块）。

PID是闭环控制系统的比例－积分－微分控制算法。

PID控制器根据设定值（给定）与被控对象的实际值（反馈）的差值，按照PID算法计算出控制器的输出量，控制执行机构去影响被控对象的变化。

PID控制是负反馈闭环控制，能够抑制系统闭环内的各种因素所引起的扰动，使反馈跟随给定变化。

根据具体项目的控制要求，在实际应用中有可能用到其中的一部分，比如常用的是PI（比例－积分）控制，这时没有微分控制部分。

PID算法在S7-200中的实现

PID控制最初在模拟量控制系统中实现，随着离散控制理论的发展，PID也在计算机化控制系统中实现。

为便于实现，S7-200中的PID控制采用了迭代算法。详细的计算方法请参考《S7-200系统手册》中PID指令部分的相关内容。

计算机化的PID控制算法有几个关键的参数Kc（Gain，增益），Ti（积分时间常数），Td（微分时间常数），Ts（采样时间）。

在S7-200中PID功能是通过PID指令功能块实现。通过定时（按照采样时间）执行PID功能块，按照PID运算规律，根据当时的给定、反馈、比例－积分－微分数据，计算出控制量。

PID功能块通过一个PID回路表交换数据，这个表是在V数据存储区中的开辟，长度为36字节。因此每个PID功能块在调用时需要指定两个要素：PID控制回路号，以及控制回路表的起始地址（以VB表示）。

由于PID可以控制温度、压力等等许多对象，它们各自都是由工程量表示，因此有一种通用的数据表示方法才能被PID功能块识别。S7-200中的PID功能使用占调节范围的百分比的方法抽象地表示被控对象的数值大小。在实际工程中，这个调节范围往往被认为与被控对象（反馈）的测量范围（量程）一致。

PID功能块只接受0.0 - 1.0之间的实数（实际上就是百分比）作为反馈、给定与控制输出的有效数值，如果是直接使用PID功能块编程，必须保证数据在这个范围之内，否则会出错。其他如增益、采样时间、积分时间、微分时间都是实数。

因此，必须把外围实际的物理量与PID功能块需要的（或者输出的）数据之间进行转换。这就是所谓输入/输出的转换与标准化处理。《S7-200系统手册》上有详细的介绍。

S7-200的编程软件Micro/WIN提供了PID指令向导，以方便地完成这些转换/标准化处理。除此之外，PID指令也同时会被自动调用。

调试PID控制器

PID控制的效果就是看反馈（也就是控制对象）是否跟随设定值（给定），是否响应快速、稳定，是否能够抑制闭环中的各种扰动而回复稳定。

要衡量PID参数是否合适，必须能够连续观察反馈对于给定变化的响应曲线；而实际上PID的参数也是通过观察反馈波形而调试的。因此，没有能够观察反馈的连续变化波形曲线的有效手段，就谈不上调试PID参数。

观察反馈量的连续波形，可以使用带慢扫描记忆功能的示波器（如数字示波器），波形记录仪，或者在PC机上做的趋势曲线监控画面等。

新版编程软件STEP 7-Micro/WIN V4.0内置了一个PID调试控制面板工具，具有图形化的给定、反馈、调节器输出波形显示，可以用于手动调试PID参数。对于没有“自整定PID”功能的老版CPU，也能实现PID手动调节。

PID参数的取值，以及它们之间的配合，对PID控制是否稳定具有重要的意义。这些主要参数是：

  • 采样时间：
    计算机必须按照一定的时间间隔对反馈进行采样，才能进行PID控制的计算。采样时间就是对反馈进行采样的间隔。短于采样时间间隔的信号变化是不能测量到的。过短的采样时间没有必要，过长的采样间隔显然不能满足扰动变化比较快、或者速度响应要求高的场合。

    编程时指定的PID控制器采样时间必须与实际的采样时间一致。S7-200中PID的采样时间精度用定时中断来保证。

  • 增益（Gain，放大系数，比例常数）
    增益与偏差（给定与反馈的差值）的乘积作为控制器输出中的比例部分。过大的增益会造成反馈的振荡。

  • 积分时间（Integral Time）
    偏差值恒定时，积分时间决定了控制器输出的变化速率。积分时间越短，偏差得到的修正越快。过短的积分时间有可能造成不稳定。
    积分时间的长度相当于在阶跃给定下，增益为“1”的时候，输出的变化量与偏差值相等所需要的时间，也就是输出变化到二倍于初始阶跃偏差的时间。
    如果将积分时间设为最大值，则相当于没有积分作用。

  • 微分时间（Derivative Time）
    偏差值发生改变时，微分作用将增加一个尖峰到输出中，随着时间流逝减小。微分时间越长，输出的变化越大。微分使控制对扰动的敏感度增加，也就是偏差的变化率越大，微分控制作用越强。微分相当于对反馈变化趋势的预测性调整。
    如果将微分时间设置为0就不起作用，控制器将作为PI调节器工作。

常问问题

对于某个具体的PID控制项目，是否可能事先得知比较合适的参数？有没有相关的经验数据？

虽然有理论上计算PID参数的方法，但由于闭环调节的影响因素很多而不能全部在数学上精确地描述，计算出的数值往往没有什么实际意义。因此，除了实际调试获得参数外，没有什么可用的经验参数值存在。甚至对于两套看似一样的系统，都可能通过实际调试得到完全不同的参数值。

PID控制不稳定怎么办？如何调试PID？

闭环系统的调试，首先应当做开环测试。所谓开环，就是在PID调节器不投入工作的时候，观察：

  • 反馈通道的信号是否稳定
  • 输出通道是否动作正常

可以试着给出一些比较保守的PID参数，比如放大倍数（增益）不要太大，可以小于1，积分时间不要太短，以免引起振荡。在这个基础上，可以直接投入运行观察反馈的波形变化。给出一个阶跃给定，观察系统的响应是最好的方法。

如果反馈达到给定值之后，历经多次振荡才能稳定或者根本不稳定，应该考虑是否增益过大、积分时间过短；如果反馈迟迟不能跟随给定，上升速度很慢，应该考虑是否增益过小、积分时间过长……

总之，PID参数的调试是一个综合的、互相影响的过程，实际调试过程中的多次尝试是非常重要的步骤，也是必须的。

S7-200的新一代产品提供了自整定的PID细调功能。

没有采用积分控制时，为何反馈达不到给定？

这是必然的。因为积分控制的作用在于消除纯比例调节系统固有的“静差”。没有积分控制的比例控制系统中，没有偏差就没有输出量，没有输出就不能维持反馈值与给定值相等。所以永远不能做到没有偏差。

如何实现PID反作用调节？

参见PID向导中的常问问题。

S7-200控制变频器，在变频器也有PID控制功能时，应当使用谁的PID功能？

可以根据具体情况使用。一般来说，如果需要控制的变量直接与变频器直接有关，比如变频水泵控制水压等，可以优先考虑使用变频器的PID功能。

《S7-200系统手册》上的附录H.14“用S7-200实现PID控制”的例子，是否可以直接使用？

《S7-200系统手册》中的附录H在英文原版中并不存在。

H.14的PID例子是在第一代产品还不支持PID运算指令时的产物。现在用户可以使用PID指令块，或者PID Wizard（PID向导）编辑PID控制程序。

这个例子可供有兴趣的人学习编程，或者供失眠者消遣。

参考链接

用PID指令向导进行PID编程
PID自整定与PID调试面板
PID 的自动/手动切换


PID向导

系列视频：S7-200跟我学/跟我做

S7-200CN: PID向导编程1-跟我学 - 137/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=386

S7-200CN: PID向导编程1-跟我做 - 138/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=387

S7-200CN: PID向导编程2-跟我学 - 139/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=388

S7-200CN: PID向导编程2-跟我做 - 140/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=389

S7-200CN: PID向导编程3-跟我学 - 141/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=390

S7-200CN: PID向导编程3-跟我做 - 142/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=391

S7-200CN: PID向导编程4-跟我学 - 143/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=392

S7-200CN: PID向导编程4-跟我做 - 144/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=393

PID Wizard - PID向导

Micro/WIN提供了PID Wizard（PID指令向导），可以帮助用户方便地生成一个闭环控制过程的PID算法。此向导可以完成绝大多数PID运算的自动编程，用户只需在主程序中调用PID向导生成的子程序，就可以完成PID控制任务。

PID向导既可以生成模拟量输出PID控制算法，也支持开关量输出；既支持连续自动调节，也支持手动参与控制。建议用户使用此向导对PID编程，以避免不必要的错误。如果用户不能确定中文编程界面的语义，我们建议用户使用英文版本的Micro/WIN，以免对向导中相关概念发生误解。

建议用户使用较新的编程软件版本。在新版本中的PID向导获得了改善。

PID向导编程步骤

在Micro/WIN中的命令菜单中选择Tools > Instruction Wizard，然后在指令向导窗口中选择PID指令：

图1. 选择PID向导

在使用向导时必须先对项目进行编译，在随后弹出的对话框中选择“Yes” ，确认编译。如果已有的程序中存在错误，或者有没有编完的指令，编译不能通过。

如果你的项目中已经配置了一个PID回路，则向导会指出已经存在的PID回路，并让你选择是配置修改已有的回路，还是配置一个新的回路：

图2. 选择需要配置的回路

第一步：定义需要配置的PID回路号

图3. 选择PID回路号

第二步：设定PID回路参数

图4. 设置PID参数

图4中:

  1. 定义回路设定值（SP，即给定）的范围：
    在低限（Low Range）和高限（High Range） 输入域中输入实数，缺省值为0.0和100.0，表示给定值的取值范围占过程反馈量程的百分比。

    这个范围是给定值的取值范围。它也可以用实际的工程单位数值表示。参见：设置给定－反馈的量程范围。

    以下定义PID回路参数，这些参数都应当是实数：

  2. Gain（增益）： 即比例常数。
  3. Integral Time（积分时间）：如果不想要积分作用，可以把积分时间设为无穷大：输入“INF”。
  4. Derivative Time（微分时间）：如果不想要微分回路，可以把微分时间设为0 。
  5. Sample Time（采样时间）：是PID控制回路对反馈采样和重新计算输出值的时间间隔。在向导完成后，若想要修改此数，则必须返回向导中修改，不可在程序中或状态表中修改。

注意：关于具体的PID参数值，每一个项目都不一样，需要现场调试来定，没有所谓经验参数。

第三步：设定回路输入输出值

图5. 设定PID输入输出参数

在图5中，首先 设定过程变量的范围：

  1. 指定输入类型
    • Unipolar： 单极性，即输入的信号为正，如0－10V或0－20mA等
    • Bipolar：双极性，输入信号在从负到正的范围内变化。如输入信号为±10V、±5V等时选用
    • 20% Offset：选用20%偏移。如果输入为4－20mA则选单极性及此项，4mA是0－20mA信号的20%，所以选20% 偏移，即4mA对应6400，20mA对应32000

  2. 反馈输入取值范围
    • 在a.设置为Unipolar时，缺省值为0 - 32000，对应输入量程范围0 - 10V或0 - 20mA等，输入信号为正
    • 在a.设置为Bipolar时，缺省的取值为-32000 - +32000，对应的输入范围根据量程不同可以是±10V、±5V等
    • 在a.选中20% Offset时，取值范围为6400 - 32000，不可改变

    此反馈输入也可以是工程单位数值，参见：设置给定－反馈的量程范围。

    然后定义输出类型

  3. Output Type（输出类型）
    可以选择模拟量输出或数字量输出。模拟量输出用来控制一些需要模拟量给定的设备，如比例阀、变频器等；数字量输出实际上是控制输出点的通、断状态按照一定的占空比变化，可以控制固态继电器（加热棒等）
  4. 选择模拟量则需设定回路输出变量值的范围，可以选择：
    • Unipolar：单极性输出，可为0－10V或0－20mA等
    • Bipolar：双极性输出，可为正负10V或正负5V等
    • 20% Offset：如果选中20% 偏移，使输出为4 - 20mA
  5. 取值范围：
    • d为Unipolar时，缺省值为 0 到 32000
    • d为Bipolar时，取值-32000到32000
    • d为20% Offset时，取值6400 - 32000，不可改变

如果选择了开关量输出，需要设定此占空比的周期。

第四步：设定回路报警选项

图6. 设定回路报警限幅值

向导提供了三个输出来反映过程值(PV)的低值报警、高值报警及过程值模拟量模块错误状态。当报警条件满足时，输出置位为1。这些功能在选中了相应的选择框之后起作用。

  1. 使能低值报警并设定过程值(PV)报警的低值，此值为过程值的百分数，缺省值为0.10，即报警的低值为过程值的10％。此值最低可设为0.01，即满量程的1%
  2. 使能高值报警并设定过程值(PV)报警的高值，此值为过程值的百分数，缺省值为0.90，即报警的高值为过程值的90％。此值最高可设为1.00，即满量程的100%
  3. 使能过程值(PV)模拟量模块错误报警并设定模块于CPU连接时所处的模块位置。“0”就是第一个扩展模块的位置

第五步：指定PID运算数据存储区

图7. 分配运算数据存储区

PID指令（功能块）使用了一个120个字节的V区参数表来进行控制回路的运算工作；除此之外，PID向导生成的输入/输出量的标准化程序也需要运算数据存储区。需要为它们定义一个起始地址，要保证该地址起始的若干字节在程序的其它地方没有被重复使用。如果点击“Suggest Address”，则向导将自动为你设定当前程序中没有用过的V区地址。

自动分配的地址只是在执行PID向导时编译检测到空闲地址。向导将自动为该参数表分配符号名，用户不要再自己为这些参数分配符号名，否则将导致PID控制不执行。

第六步：定义向导所生成的PID初使化子程序和中断程序名及手/自动模式

图8. 指定子程序、中断服务程序名和选择手动控制

向导已经为初使化子程序和中断子程序定义了缺省名，你也可以修改成自己起的名字。

  1. 指定PID初使化子程序的名字。
  2. 指定PID中断子程序的名字

    注意：
    1. 如果你的项目中已经存在一个PID配置，则中断程序名为只读，不可更改。因为一个项目中所有PID共用一个中断程序，它的名字不会被任何新的PID所更改。
    2. PID向导中断用的是SMB34定时中断，在用户使用了PID向导后，注意在其它编程时不要再用此中断，也不要向SMB34中写入新的数值，否则PID将停止工作。

  3. 此处可以选择添加PID 手动控制模式。在PID手动控制模式下，回路输出由手动输出设定控制，此时需要写入手动控制输出参数一个0.0－1.0的实数，代表输出的0％－100％而不是直接去改变输出值。

    PID 控制的自动/手动之间的无扰动切换

第七步：生成PID子程序、中断程序及符号表等

一旦点击完成按钮，将在你的项目中生成上述PID子程序、中断程序及符号表等。

图9. 生成PID子程序、中断程序和符号表等

第八步：配置完PID向导，需要在程序中调用向导生成的PID子程序（如下图）

图10. PID子程序

图11. 调用PID子程序

在用户程序中调用PID子程序时，可在指令树的Program Block（程序块）中用鼠标双击由向导生成的PID子程序，在局部变量表中，可以看到有关形式参数的解释和取值范围。

  1. 必须用SM0.0来使能 PIDx_INIT 子程序，SM0.0 后不能串联任何其他条件，而且也不能有越过它的跳转；如果在子程序中调用 PIDx_INIT 子程序，则调用它的子程序也必须仅使用 SM0.0 调用，以保证它的正常运行
  2. 此处输入过程值（反馈）的模拟量输入地址
  3. 此处输入设定值变量地址（VDxx），或者直接输入设定值常数，根据向导中的设定0.0－100.0，此处应输入一个0.0－100.0的实数，例：若输入20，即为过程值的20％，假设过程值AIW0是量程为0－200度的温度值，则此处的设定值20代表40度（即200度的20％）；如果在向导中设定给定范围为0.0 - 200.0，则此处的20相当于20度
  4. 此处用I0.0控制PID的手/自动方式，当I0.0为1时，为自动，经过PID运算从AQW0输出；当I0.0为0时，PID将停止计算，AQW0输出为ManualOutput（VD4）中的设定值，此时不要另外编程或直接给AQW0赋值。若在向导中没有选择PID手动功能，则此项不会出现
  5. 定义PID手动状态下的输出，从AQW0输出一个满值范围内对应此值的输出量。此处可输入手动设定值的变量地址（VDxx），或直接输入数。数值范围为0.0-1.0之间的一个实数，代表输出范围的百分比。例：如输入0.5，则设定为输出的50％。若在向导中没有选择PID手动功能，则此项不会出现
  6. 此处键入控制量的输出地址
  7. 当高报警条件满足时，相应的输出置位为1，若在向导中没有使能高报警功能，则此项将不会出现
  8. 当低报警条件满足时，相应的输出置位为1，若在向导中没有使能低报警功能，则此项将不会出现
  9. 当模块出错时，相应的输出置位为1，若在向导中没有使能模块错误报警功能，则此项将不会出现

调用PID子程序时，不用考虑中断程序。子程序会自动初始化相关的定时中断处理事项，然后中断程序会自动执行。

第九步：实际运行并调试PID参数

没有一个PID项目的参数不需要修改而能直接运行，因此需要在实际运行时调试PID参数。

查看Data Block（数据块），以及Symbol Table（符号表）相应的PID符号标签的内容，可以找到包括PID核心指令所用的控制回路表，包括比例系数、积分时间等等。将此表的地址复制到Status Chart（状态表）中，可以在监控模式下在线修改PID参数，而不必停机再次做配置。

参数调试合适后，用户可以在数据块中写入，也可以再做一次向导，或者编程向相应的数据区传送参数。

常问问题

做完PID向导后，如何知道向导中设定值，过程值及PID等参数所用的地址？

  • 做完PID向导后可在Symbol Table（符号表） [image] 中，查看PID向导所生成的符号表(上例中为PID0_SYM)，可看到各参数所用的详细地址，及数值范围。
  • 在Data Block（数据块） [image] 中，查看PID指令回路表的相关参数。如图所示：

图12. PID数据块

做完PID向导后，如何在调试中修改PID参数？

可以在Status Chart（状态表） [image] 中， 输入相应的参数地址，然后在线写入用户需要的PID参数数值，这样用户就可根据工艺需要随时对PID参数、设定值等进行调整。

PID已经调整合适，如何正式确定参数？

可以在Data Block（数据块）中直接写入参数。

做完PID向导后，能否查看PID生成的子程序，中断程序？

PID向导生成的子程序，中断程序用户是无法看到的，也不能对其进行修改。没有密码能够打开这些子程序，一般的应用也没有必要打开查看。

PID参数有经验值吗？

每一个项目的PID 参数都不一样，没有经验参数，只能现场调试获得。

我的PID向导生成的程序为何不执行？

  • 必须保证用SM0.0无条件调用PID0_INIT程序
  • 在程序的其它部分不要再使用SMB34定时中断，也不要对SMB34赋值

如何实现PID反作用调节？

在有些控制中需要PID反作用调节。例如：在夏天控制空调制冷时，若反馈温度（过程值）低于设定温度，需要关阀，减小输出控制（减少冷水流量等），这就是PID反作用调节（在PID正作用中若过程值小于设定值，则需要增大输出控制）。

若想实现PID反作用调节，需要把PID回路的增益设为负数。对于增益为0的积分或微分控制来说，如果指定积分时间、微分时间为负值，则是反作用回路。

如何根据工艺要求有选择地投入PID功能？

可使用“手动/自动”切换的功能。PID向导生成的PID功能块只能使用SM0.0的条件调用。

参考链接

PID功能简介


PID给定－反馈量程设置

PID Wizard 中的给定－反馈设置

完成PID Wizard配置后，会为每个PID回路生成一个子程序PIDx_INIT（x = 0 - 7）。在用户程序中，必须使用SM0.0始终调用这个子程序才能实现PID功能。

下图是一个最简单的PID子程序调用程序段：

图1. 调用PID子程序

其中：

  • PV_I： 过程反馈参数值的入口
  • Setpoint： 给定参数值的入口
  • Output： PID调节器的输出值

在这里，给定、反馈的入口参数不是PID指令功能块所需要的0.0 - 1.0之间的实数，而可以是实际的反馈地址，或是其他变量。例如，PV_I可以是模拟量输入地址AIW0，也可以是存储器地址VW100等；Setpoint则往往来自V变量存储区，这样可以从人机操作界面（HMI）设备输入给定值。

注意：

对于PID控制系统来说，必须保证给定与过程反馈的一致性：

  • 给定与反馈的物理意义一致

    这取决于被控制的对象，如果是压力，则给定也必须对应于压力值；如果是温度，则给定也必须对应于温度。

  • 给定与反馈的数值范围对应

    如果给定直接是摄氏温度值，则反馈必须是对应的摄氏温度值；如果反馈直接使用模拟量输入的对应数值，则给定也必须向反馈的数值范围换算。

    如果给定与反馈的换算有特定的比例关系也可以。如给定也可以表示为以反馈的数值范围的百分比数值。

给定与反馈的数值具体是什么数值，其取值范围究竟如何，完全取决于我们在使用“PID向导”编程时指定的给定与反馈的数值范围。其中，反馈量的数值范围不能随便自己定义，而要取决于具体应用的模拟量输入模块。

图2. 在图中a.处设置给定范围

图3. 在图中b.处设置反馈范围

实例

假定一个PID控制系统的控制对象是压力，反馈元件的测量范围为0 - 16MPa。反馈器件的信号经过变换，以0 - 20mA（或4 - 20mA）电流信号的形式输入到EM231模拟量输入模块中。据此，我们可以按下表设置给定、反馈的范围。

表1.

 | 反馈（单极性） |  | 给定
 | 实际物理量 | 模拟量输入数值 | 百分比形式（占0 - 16MPa的百分比） | 物理工程单位形式
高限 | 16 MPa | 32000 | 100.0 | n×16.0
低限 | 0 MPa | 0 （0 - 20mA） | 0.0 | 0.0
 |  | 6400 （4 - 20mA）

n 为比例系数，为了精度高些可以设置n=10等等

又如一个温度控制的PID系统，温度值直接由热电偶测量，输入到EM231 TC（热电偶）模块转换为温度值。热电偶为J型，其测量范围为 -150.0°C - 1200.0 °C。则可按如下设置给定的范围。

表2.

 | 反馈（双极性） |  | 给定
 | 实际物理量 | 模拟量输入数值 | 百分比形式（占-150°C - 1200.0°C的百分比） | 物理工程单位形式
高限 | 1200.0 °C | 12000 | 100.0 | 1200
低限 | -150.0 °C | -1500 | 0.0 | -150

在上面的例子中，反馈和给定可以按照如下方法设置

图4. 反馈范围设置

图5. 给定范围设置


PID－自整定和调节面板

系列视频：S7-200跟我学/跟我做:

S7-200CN: PID自整定与调节控制面板1-跟我学 - 145/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=394

S7-200CN: PID自整定与调节控制面板2-跟我学 - 146/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=395

S7-200CN: PID自整定与调节控制面板2-跟我做 - 147/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=396

PID自整定

新的S7-200 CPU支持PID自整定功能，在STEP 7-Micro/WIN V4.0中也添加了PID调节控制面板。

用户可以使用用户程序或PID调节控制面板来启动自整定功能。在同一时间最多可以有8个PID回路同时进行自整定。PID调节控制面板也可以用来手动调试老版本的（不支持PID自整定）CPU的PID控制回路。

用户可以根据工艺要求为调节回路选择快速响应、中速响应、慢速响应或极慢速响应。PID自整定会根据响应类型而计算出最优化的比例、积分、微分值，并可应用到控制中。

PID调节控制面板

STEP 7-Micro/WIN V4.0中提供了一个PID调节控制面板，可以用图形方式监视PID回路的运行，另外从面板中还可以启动、停止自整定功能。

图1. PID调节控制面板

在图1中：

  1. 过程值指示
    显示过程变量的值及其棒图

  2. 当前的输出值指示
    显示当前使用的设定值、采样时间、PID 参数值及显示当前的输出值和棒图

  3. 可显示过程值、设定值及输出值的PID趋势图

    图2. 图形显示区

    4. 图中：

    1. 过程变量和设定值的取值范围及刻度
    2. PID输出的取值范围及刻度
    3. 实际PC时间
    4. 以不同颜色表示的设定值、过程变量及输出的趋势图

  4. 调节参数
    这里你可以：
    • 选择PID参数的显示：当前参数（Current）、推荐参数（Suggested）、手动输入（Manual)
    • 在Manual模式下，可改变PID参数，并按Update PLC按钮来更新PLC中的参数
    • 启动PID自整定功能
    • 选择Advanced（高级）按钮进入高级参数设定

  5. 当前的PID回路号
    这里你可以选择需要监视或自整定的PID回路

  6. 时间选项设定
    这里你可以设定趋势图的时基，时基以分为单位

  7. 图例颜色
    这里你可以看到趋势图中不同的颜色代表不同的值的趋势

  8. 帮助按钮

  9. PID信息显示窗口

  10. 关闭PID调节面板

要使用PID调节控制面板，PID编程必须使用PID向导完成。

PID自整定步骤

第一步： 在PID Wizard (向导）中完成PID功能配置

要想使用PID自整定功能，PID编程必须用PID向导来完成

第二步：打开PID调节控制面板，设置PID回路调节参数

在Micro/WIN V4.0在线的情况下，从主菜单Tools > PID Tune Control Panel或点击 [image] 进入PID调节控制面板中，如果面板没有被激活（所有地方都是灰色），可点击Configure（配置）按钮运行CPU。

在PID调节面板的e.区选择要调节的PID回路号，在d.区选择Manual（手动），调节PID参数并点击Update（更新），使新参数值起作用，监视其趋势图，根据调节状况改变PID参数直至调节稳定。

为了使PID自整定顺利进行，应当做到：

  • 使PID调节器基本稳定，输出、反馈变化平缓，并且使反馈比较接近给定
  • 设置合适的给定值，使PID调节器的输出远离趋势图的上、下坐标轴，以免PID自整定开始后输出值的变化范围受限制

参见：手动调整PID回路参数

第三步：在d.区点击Advanced（高级）按钮，设定PID自整定选项。如果不是很特殊的系统，也可以不加理会。

图3. 设置PID自整定高级选项

在此允许你设定下列参数：

  1. 你可以选中复选框，让自整定来自动计算死区值和偏移值

    对于一般的PID系统，建议使用自动选择。

  2. Hysteresis（滞回死区）：

    死区值规定了允许过程值偏离设定值的最大（正负）范围，过程反馈在这个范围内的变化不会引起PID自整定调节器改变输出，或者使PID自整定调节器“认为”这个范围内的变化是由于自己改变输出进行自整定调节而引起的。PID自整定开始后，只有过程反馈值超出了该区域，PID自整定调节器才会认为它对输出的改变发生了效果。这个值用来减少过程变量的噪声对自整定的干扰，从而更精确地计算出过程系统的自然振动频率。如果选用自动计算，则缺省值为2％。

    如果过程变量反馈干扰信号较强（噪声大）自然变化范围就大，可能需要人为设置一个较大的值。但这个值的改变要与下面的偏差值保持1:4的关系。

  3. Deviation（偏差）：

    偏差值决定了允许过程变量偏离设定值的峰峰值。如果选择自动计算该值，它将是死区的4倍，即8％。

    有些非常敏感的系统不允许过程量偏离给定值很多，也可以人工设置为比较小的值，但是要和上述“死区”设置保持比例关系。这就是说，一个精度要求高的系统，其反馈信号必须足够稳定。

  4. Initial Output Step（初始步长值）：PID调节的初始输出值

    PID自整定开始后，PID自整定调节器将主动改变PID的输出值，以观察整个系统的反应。初始步长值就是输出的变动第一步变化值，以占实际输出量程的百分比表示。

  5. Watchdog Time（看门狗时间）：过程变量必须在此时间（时基为秒）内达到或穿越给定值，否则会产生看门狗超时错误。

    PID自整定调节器在改变输出后，如果超过此时间还未观察到过程反馈（从下至上或从上至下）穿越给定曲线，则超时。如果能够事先确定实际系统响应非常慢，可以加长这个时间。

  6. 动态响应选项：根据回路过程（工艺）的要求可选择不同的响应类型：快速、中速、慢速、极慢速

    • 快速：可能产生超调，属于欠阻尼响应
    • 中速：在产生超调的边缘，属于临界阻尼响应
    • 慢速：不会产生任何超调，属于过阻尼响应
    • 极慢速：不会产生任何超调，属于严重过阻尼响应

      用户在这里指定需要达到的系统控制效果，而不是对系统本身响应快慢的判断。

  7. 设定完参数点击OK键回到PID调节控制面板的主画面

第四步：在手动将PID调节到稳定状态后，即过程值与设定值接近，且输出没有不规律的变化，并最好处于控制范围中心附近。此时可点击d.区内的Start Auto Tune按钮启动PID自整定功能，这时按钮变为Stop Auto Tune。这时只需耐心等待，系统完成自整定后会自动将计算出的PID参数显示在d.区。当按钮再次变为Start Auto Tune时，表示系统已经完成了PID自整定。

要使用自整定功能，必须保证PID回路处于自动模式。开始自整定后，给定值不能再改变。

第五步：如果用户想将PID自整定的参数应用到当前PLC中，则只需点击Update PLC。

完成PID调整后，最好下载一次整个项目（包括数据块），使新参数保存到CPU的EEPROM中。

PID自整定失败的原因

  1. PID输出在最大值与最小值之间振荡（曲线接触到坐标轴）

    解决方法：降低PID初始输出步长值（initial output step）

  2. 经过一段时间后，PID自整定面板显示如下信息：“ The Auto Tune algorithm was aborted due to a zero-crossing watchdog timeout.” 即自整定计算因为等待反馈穿越给定值的看门狗超时而失败。

    解决方法： 确定在启动PID自整定前，过程变量和输出值已经稳定。并检查Watchdog Time的值，将其适当增大。

    对于其它错误，可参考手册中表15－3中的错误代码的描述。


调整PID至稳定

如何获得一个稳定的PID回路

在开始PID自整定调整前，整个PID控制回路必须工作在相对稳定的状态。

稳定的PID是指过程变量接近设定值，输出不会不规则的变化，且回路的输出值在控制范围中心附近变化。

问题与解决方法：

  1. PID输出总是输出很大的值，并在这一区间内调节变化

    产生原因：

    • 增益（Gain）值太高
    • PID扫描时间（sample time）太长（对于快速响应PID的回路）

    解决方法：降低增益（Gain）值并且/或选择短一些的扫描时间

  2. 过程变量超过设定值很多（超调很大）

    产生原因：积分时间（Integral time)可能太高

    解决方法：降低积分时间

  3. 得到一个非常不稳定的PID

    产生原因：

    • 如果用了微分，可能是微分参数有问题
    • 没有微分，可能是增益（Gain）值太高

    解决方法：

    • 调整微分参数到0－1的范围内
    • 根据回路调节特性将增益值降低，最低可从0.x 开始逐渐增大往上调，直到获得稳定的PID。


PID－自动/手动调节无扰动切换

PID 自动/手动调节的无扰动切换

有些工程项目中可能需要根据工艺要求在不同的时刻投入、或者退出 PID 自动控制；退出 PID 自动控制时，控制器的输出部分可以由操作人员直接手动控制。这就是所谓的 PID 手动/自动切换。

PID 控制处于自动方式时，PID 控制器（S7-200 中的 PID 调节功能）会按照 PID 算法，自动通过输出的作用使过程反馈值跟随给定值变化，并保持稳定。这是一个自动的闭环控制系统。操作人员可以根据现场工艺的要求，改变给定（即设定值）的值。

PID 控制处于手动方式时，PID 控制器不再起自动计算的作用。这时，控制回路的输出是由操作人员手动控制、调整，由操作人员观察现场的控制效果，从而构成人工闭环控制。

所谓 PID 自动/手动控制，就是看控制系统的输出是由 PID 控制器自动控制，还是由操作人员手动控制。

有些控制系统的执行机构不能承受较大的冲击，这就要求在进行 PID 自动/手动切换时，保持控制输出的稳定。这就是要求无扰动切换。

为了达到 PID 自动/手动控制的无扰动切换，需要在编程时注意一些相关事项。下面分别就直接使用 PID 指令编程，和使用 PID 向导编程两种情况作一介绍。

直接使用 PID 指令编程时的 PID 自动/手动无扰切换

直接使用 PID 指令块编写 PID 控制程序时，可以简单地使用“调用/不调用”指令的方式控制自动/手动模式。因为 PID 指令本身已经具有实现无扰动切换的能力，此时在 PID 指令控制环节之外编程没有多大必要。

PID 指令的 EN 输入端使能（为“1”）时，我们认为是自动控制模式；EN 输入端未使能（为“0”）时，我们认为是手动控制模式。

PID 指令本身有一个“能流历史状态位”，以记录指令的状态切换。在 EN 端从“0”变为”“1”时，PID 指令认为这是从“手动”模式向“自动”模式切换。PID 指令此时会自动执行一系列动作，以配合无扰动切换：

  • 使设定值（ SPn） = 当前过程反馈变量（PVn）
  • 设置上次采样过程变量（PVn-1） = 当前过程反馈变量（PVn）
  • 设置积分偏差和（或所谓积分前项）（Mx） = 当前输出值（Mn）

使设定值等于当前反馈值可以避免出现偏差，使之不存在调整的要求；当然如果有工艺要求，也可以后续调整设定值。其他的动作都是为了使 PID 在后续的操作中不改变输出的值。

在编程时要注意：

  • 从自动模式向手动模式切换时，PID 指令的 EN 端不再有能流，计算停止，输出值 Mn 不再变化。此时如果需要操作人员人工观察控制的结果，手动控制输出量，就可以通过用户程序直接改变回路表中的输出值存储单元内容（见数据块或系统手册的相关部分内容）。如果有必要，操作人员的操作可能要进行一些标准化换算。
  • 为保证从手动模式向自动模式的切换无扰动，需要在手动控制时，或在切换过程中，禁止对 PID 回路表中设定值的更新，以便切换时 PID 指令用当前过程反馈值替代设定值。切换完成后，操作人员可以调整设定值。

使用 PID 向导编程时的 PID 自动/手动无扰切换

使用 PID 指令向导编程时，指令向导会自动调用 PID 指令，并且编写外围的控制变量标准化换算、定时采样等功能。用户在使用 PID 指令向导时，需要在用户程序中用 SM0.0 调用指令向导生成的子程序（如 PIDx_INIT 子程序）。PID 向导可以生成带自动/手动切换功能的子程序，这个子程序使用一个数字量点为“1”、“0”的状态来控制是否投入 PID 自动控制。

到目前为止（STEP 7-Micro/WIN V4.0 SP5），使用 PID 向导生成的子程序时，由于用户程序不能直接使用 PID 指令，它的无扰切换能力因为隔了外壳子程序，所以受到了局限。如果对无扰切换要求比较严格，需要另外编一些程序加以处理。

考察如下 PID 控制子程序。

图 1. PID 向导生成的指令

图中：

  1. 过程反馈量
  2. 设定值，实数
  3. 自动/手动控制，“1”=自动，“0”=手动
  4. 手动控制输出值，0.0 - 1.0 之间的一个实数
  5. PID 控制输出值

要实现无扰动切换，必须：

  • 在从自动向手动切换时，使手动输出值（VD2004）等于当前的实际控制输出值；
  • 在从手动向自动切换使，使设定值相当于当前的过程反馈值。

为此，可编写类似下图所示的程序，放在 PID 控制子程序之前：

图 2. 无扰切换处理程序

图中：

  1. 自动/手动切换控制点
  2. 从自动向手动切换时，使手动输出值等于实际当前值
  3. 从手动向自动切换时，把当前反馈量换算为相应的给定值

上述程序中的 Scale_I_to_R 就是量程变换指令库中的子程序。这是为了解决过程反馈与设定值之间的换算问题。用户也可以自己编程换算，或者根据反馈与给定的取值范围决定是否需要换算。

此段程序适用于 STEP 7-Micro/WIN V4.0 SP5 及以前版本，仅供参考，如果在实际项目中使用，上述程序未必一定适用。用户需要根据实际工艺决定自己的编程思路。


怎样在上位机或触摸屏上修改PID参数

一个系统经常不仅仅有PLC，更多时候还会有触摸屏甚至上位，同时用户也会要求在触摸屏或者上位机上修改PID参数,怎样实现呢？具体步骤如下：

1. 通过向导实现PID，在向导完成以后会生成一个对应回路的PID数据块

该数据块里列出PID回路表对应的参数地址，其中回路增益 VD12 ，积分时间VD20以及微分时间VD24可以直接添加到触摸屏、 上位机进行修改，注意数据类型是浮点数

2.在触摸屏建立连接并添加PID参数变量

3.在触摸屏画面上组态并运行 即可显示修改对应参数

其实，即使没有触摸屏、上位机也可以在STEP7 Micro/WIN 软件自带的状态表里修改参数 而不必重新修改向导，调试方便

******************************************************************************************************************************************************************************************

需要注意的是这些参数在数据块有初始值 如果在线修改完后PLC断电或者重新下载后可能被初始值覆盖

*** 如果PLC断电后保持触摸屏修改参数 将对应参数设置为断电保持 但要考虑断电保持的时间

*** PLC重新下载，不希望 触摸屏修改的参数被初始值覆盖? 考虑下载时不要勾选数据块，但是用户要清楚自己的操作

最稳妥的方法是将调整好的参数在向导里写入,重新生成数据块作为初始值,这样不会丢失

******************************************************************************************************************************************************************************************

简单介绍PID回路表 常用参数 【如果需要更详细的内容，请自行翻阅S7-200 系统手册】

根据上例的PID数据块可以看到 PID回路表里的各项参数，通常除 回路增益，积分时间以及微分时间以外 ，还会用到 前三个参数

用户经常对这三个参数值是否需要转换成0.0-1.0之间的数有疑惑，实际上200的PID实现通常有2种方式，PID向导和PID指令块

PID向导：在向导生成的子程序关联的反馈、给定和输出的范围与向导里标定的范围一致 不需要人为转换成0.0-1.0

PID指令块:通过PID回路表设置，必须将反馈、给定和输出的范围转换为0.0-1.0 即使是双极性。例如：给定温度范围是-50.0~200.0℃，也需要转换为0.0-1.0后再写入回路表对应变量

下面看看PID通过向导实现时，对应关系

1.在做PID向导时，首先需要用户设置这三个参数的标定范围，下图能看出 该PID设置的过程变量为0-32000；回路给定值 0-500.0以及回路输出6400-32000 这些是在子程序调用时 对应变量的取值范围 具体范围设置原则可以参考本文档PID向导章节

2.调用PID子程序并分配各参数 实际反馈值PV_I可以直接关联AIWx ，Output 可以直接关联AQWx，这里为了简单查看对应关系，用V区替代，但是子程序关联的反馈、给定和输出的范围与向导里标定的范围一致即

VW500 范围： 0-32000

VD504 范围： 0.0-500.0

VW516 范围： 6400-32000

3.手动输入反馈值VW500与给定值VD504，PID切换到自动模式V508.0=1此时PID输出 见VW516；真正在PID里，是将这些数值转换成0-1.0之间的数运算 这些转换完的数据存储在PID回路表也就是对应的数据块里，由此可以看到下图的转换关系，

上图可以通过VD0，VD4看出给定与反馈之间的差值 比起在向导设定的范围标定更方便 ，工程师可以判断自己在向导里标定的范围是否正确，判断当前的状态到底能不能满足输出条件

为了更好方便用户的学习，可参考下面的例程

PID例子程序

注意：此程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为 此联系西门子技术支持与服务部门。

常问问题

PID的输出都有哪些类型？

用户可以选择模拟量输出或数字量输出。模拟量输出用来控制一些需要模拟量给定的设备，如比例阀、变频器等；数字量输出实际上是控制输出点的通、断状态按照一定的占空比变化，可以控制固态继电器（加热棒等）

S7-200的PID借助相关库文件，可以实现三步控制 例如：使用混合阀门实现水温的三步控制 ，具体参考以下链接：https://support.industry.siemens.com/cs/document/18748232?dti=0&lc=zh-CN

PID各个参数的作用是什么？

比例调节：提高响应速度，减少误差，但不能消除稳态误差，当比例作用过大时，系统的稳定性下降。 (由小到大单独调节）

积分调节：消除稳态误差，使系统的动态响应变慢，积分时间越小，积分作用越大 ，偏差得到的修正越快，过短的积分时间有可能造成不稳定。（将调好的比例增益调整到50%~80%后，由大到小减小积分时间）

微分调节：超前调节，能预测误差变化的趋势，提前抑制误差的控制作用，从而避免了被控量的严重超调。偏差值发生改变时，微分作用将增加一个尖峰到输出中，随着时间流逝减小。微分时间越长，输出的变化越大。微分使控制对扰动的敏感度增加，也就是偏差的变化率越大，微分控制作用越强。微分相当于对反馈变化趋势的预测性调整。

（PID控制器不适用于大滞后环节）

建议PID参数调节步骤：

（1）前提条件：反馈信号是否稳定，执行机构是否正常以及控制器的正反作用。（确保PID在自动模式下）

（2）积分时间设置为无穷大INF（或9999.9），此时积分作用近似为0；将微分时间设置为0.0，此时微分作用为0 。然后开始调节比例作用，逐步增大比例增益

（3）当过程变量达到给定值且在给定值上下波动，将调好的比例系数调整到50%~80%后，由大到小减小积分时间，直到过程值与设定值相等或无限接近

以上是建议步骤，未考虑微分作用，客户依据实际情况灵活调节，同时可以参考'反馈与给定的曲线图'

用户经常会遇到这样的问题：尝试了很多组PID参数，都无法满足控制器的要求， 此时需要考虑PID的采样时间是否适合当前系统。采样时间就是对反馈进行采样的间隔。短于采样时间间隔的信号变化是不能测量到的。采样时间过短，两次实测值的变化量太小，也不合适，而且增加PLC的运算负担；采样间隔过长，将会引起有用信号的丢失，使系统品质变差，不能满足扰动变化比较快、或者速度响应要求高的场合。除此以外，也有可能是系统自身的问题，无法调节到稳定，例如， 不规律的干扰，或者反馈信号不稳定

如何获取一组合适的参数，实现快速并稳定的PID控制？
?PID调节过程中，用户通常需要做多次的参数调节才能获得最优的控制效果。从下面反馈（过程变量）与给定之间的曲线图中，可以看到黄色曲线较理想。用户可以将调节的PID反馈与给定曲线与下图中对比，并修改相关参数（但是因为现场情况不一样，用户还需具体问题具体对待，下图中的建议仅供参考：


SCR－顺序控制指令

顺序控制（SCR）指令

对于通常的应用来说，一般不使用顺序控制指令编程。顺控指令一般用在需要控制的动作具有明确的步骤顺序，并且周而复始地循环的场合。

顺控指令程序可以作功能块（子程序）包含在整个程序中，与其他非顺控控制程序共存。

普通的PLC程序是从头到尾不断扫描执行的。SCR指令的关键是“步”和“转换”，当转换的条件不满足时会一直保持在当前的步中。“转换”就是从一个步，进入另一个步。在一个步的状态中，程序也不是按普通程序运行的模式进行局部的“循环扫描”。

详细情况请参考《S7-200系统手册》。

SCR指令

SCR指令的每一个步的结构，总是以LSCR指令开始，以SCRE结束，SCRT（步转换指令）及其发生的条件在这两者之间。

下面是一个例子：

Network 1

LD SM0.1
S S0.1, 1 //程序运行开始时，进入第一步

Network 2
LSCR S0.1 //装载SCR指令，SCR结构开始

Network 3
LD SM0.0
S Q0.0, 1 //置位Q0.0

Network 4
LD I1.0 //I1.0为“1"时，
SCRT S0.2 //转换到下一步

Network 5
SCRE //步结束

Network 6
LSCR S0.2

Network 7
LD SM0.0
R Q0.0, 1

Network 8
LD I1.1
SCRT S0.3

Network 9
SCRE

Network 10
LSCR S0.3

Network 11
LD SM0.0
S Q0.0, 1

Network 12
LD I1.2
SCRT S0.4

Network 13
SCRE

Network 14
LSCR S0.4

Network 15
LD SM0.0
R Q0.0, 1

Network 16
LD I1.3
SCRT S0.1 //回到第一步

Network 17
SCRE

常问问题

是否可以在不同的步中使用同一个开关量输出点？为何出现不合逻辑的现象？

可以在不同的步中对同一个输出点进行操作。这些逻辑运算不应使用普通编程时的实时状态计算规则，应使用S（置位）和R（复位）指令对输出点操作；或者使用中间状态继电器过渡，最后再综合逻辑，一起输出。

顺控程序停止调用后，整个步进逻辑如何变化，恢复调用后如何表现？

参见：顺控指令停止和恢复实例


SCR－顺控子程序的停止与恢复

步进程序急停与恢复的解决方案

这里提供了一个实例，说明了步进（顺序）控制程序的主要特定和注意事项，提供了一个停止和恢复顺控程序功能的解决方案。

功能描述

系统要求循环执行步进程序，程序启动后，按编制的顺序执行程序：

  1. 第一步输出 Q0.1为10秒的高电平信号；
  2. 10秒后切换到第二步复位Q0.1，同时输出Q0.2为20秒的高电平信号；
  3. 20秒后切换到第三步复位Q0.2，同时输出Q0.3为30秒的高电平信号；
  4. 30秒后返回第一步输出Q0.1为10秒的高电平信号，同时复位Q0.3；

依此循环执行步进程序。

当有意外情况发生或断电后需紧急停止输出，实现系统急停功能；待意外情况排除或恢复供电后继续执行步进程序，继续执行可选择从初始步运行或是从中断处运行。

解决方案

程序控制方式相同，按照急停与恢复控制和控制程序的关系有两种方案。

  1. 急停与恢复控制在步进程序内，

    参见程序： test_scr_1_v3.2.mwp

    具体控制方式和测试方法在主程序中有描述。

  2. 急停与恢复控制在步进程序外，

    参见程序： test_scr_2_v3.2.mwp

    具体控制方式和测试方法在主程序中有描述。

上述程序需STEP 7-Micro/WIN32 V3.2 SP4以上版本打开。

特别说明

程序中用到的VB0 ，VW2，VW4，VW6 必须设置为断电保存，而MB0，MB1不能设置为断电保存。


调试及出错处理

S7-200调试及出错处理

CPU的SF(系统故障) 灯亮?

可能是以下原因：

  • CPU运行错误或硬件元件损坏。此时如果Micro/WIN还能在线，则可在命令菜单中进入PLC>Information在线查看，可看到具体的错误描述。
  • 程序错误，如进入死循环，或编程造成扫描时间过长，“看门狗”超时也会造成SF灯亮。
  • CPU电源电压可能过低，请检查供电电压。

LED灯全部不亮？

可能是以下原因：

  • 电源接线不对，或24V电源接反
  • 保险丝烧断（报修）

可参考《S7-200系统手册》中的 “故障诊断和调试”一章。

西门子维修热线


S7-200通讯

串行通信

在S7-200 PLC系统中的通信一般是指串行通信，即信息（数据字节）以二进制的“0”、“1”比特流的形式传输。

S7-200拥有出色的通信能力，支持多种通信协议、兼容多种硬件，适应各种应用场合。了解并选择合适的通信方式，可以事半功倍，做到既节省硬件投资，也节约编程人力的投入，缩短工程周期，获得最大利益。

《S7-200系统手册》第七章对S7-200系统的通信做了很好的阐述，是极有价值的资料，建议初学者必读。

必须满足下列条件，通信对象之间才能正常通信：

  • 直接连接的通信端口符合相同硬件标准
  • 通信对象支持相同的通信协议

通信的硬件标准

在S7-200系统支持的常见通信硬件标准有：

  • RS-232：微机技术中常见的串口标准；S7-200的编程电缆（RS-232/PPI电缆）的RS-232端连接到PC机的RS-232口
  • RS-485：常用的支持网络功能的串行通信标准；S7-200 CPU和EM277通信模块上的通信口都符合RS-485的电气标准
  • 以太网：S7-200通信模块CP243-1/CP243-1 IT提供了标准的以太网RJ45接口
  • 模拟音频电话：S7-200通过EM241模块支持模拟音频电话网上的数据通信（V.34标准33.6K波特率，RJ-11接口）
  • AS-Interface：通过CP243-2模块支持AS-Interface标准。

通信硬件与通信协议

广义地说，一个完整的通信标准定义了硬件、软件规范。包括通信端口的具体电气性能，接插件的物理规格，以及消息的组织格式等，典型的如AS-Interface。

通信协议主要规定了数据的组织格式（帧格式）。

同一种通信协议可以通过不同的硬件传输；同一种传输介质也可以传输不同的通信协议。例如，PPI、MPI和PROFIBUS-DP协议都可以在RS-485总线上传输；而PROFIBUS-DP也可通过光纤传输。

如果通信对象支持相同的通信协议，但通信口的硬件标准不同，就需要使用接口转换器件。如S7-200编程软件通过PPI协议与CPU通信，计算机上的RS-232串口就需要RS-232/PPI电缆才能与CPU上的RS-485串口通信，RS-232/PPI电缆在这里也起到了RS-232和RS-485之间的转换作用。这也包括光/电传输信号的转换，电信号与无线电信号之间的转换等。

使用何种通信传输方式，决定了通信的速率和距离。通信硬件的通信速率会成为接口转换成功与否的制约因素。如果某种“插入”的传输介质，对讯号传输造成的影响超出此协议所容许的范围，就不能使用。例如，两个CPU之间基本不能通过一对传输速率较慢的数据电台使用PPI协议通信，而必须使用通信速率较低的“自由口协议”；而一个较快的光纤系统可以“插入”到使用PPI协议的RS-485电气网络中。

S7-200支持的通信协议


通讯－S7-200的通讯方式

S7-200的数据通信方式

S7-200拥有出色的通信能力。

图1. S7-200的通信能力

  • S7-200 CPU之间通信
  • S7-200与S7-300/400之间的通信
  • S7-200与西门子变频器间的通信
  • S7-200与其他上位机软件间的通信
  • S7-200与第三方PLC之间的通信
  • S7-200与第三方HMI之间的通信
  • S7-200与第三方变频器之间的通信
  • S7-200与其他串行通信设备之间的通信

S7-200 CPU之间的通信

S7-200 CPU之间最简单易用的通信方式就是PPI通信。近来以太网和Modem通信也获得越来越多的应用。

表1. S7-200 CPU之间的主要通信方式：

通信方式 | 介质 | 本地需用设备 | 通信协议 | 通信距离 | 通信速率 | 数据量 | 本地需做工作 | 远端需做工作 | 远端需用设备 | 特点
PPI | RS-485 | RS-485 网络部件 | PPI | RS-485 | 9.6K 19.2K 187.5K | 较少 | 编程 （或编程向导） | 无 | RS-485 网络部件 | 简单可靠经济
Modem | 音频模拟电话网 | EM241扩展模块、模拟音频电话线（RJ11接口） | PPI | 电话网 | 33.6Kbps | 大 | 编程向导编程 | 编程向导编程 | EM241扩展模块、模拟音频电话线（RJ11接口） | 距离远
Ethernet | 以太网 | CP243-1扩展模块（RJ45接口） | S7 | 以太网 | 10M/100M | 大 | 编程向导编程 | 编程向导编程 | CP243-1扩展模块（RJ45接口） | 速度高
无线电 | 无线电波 | 无线电台 | 自定义（自由口） | 电台通信距离 | 1200 － 115200bps | 中等 | 自由口编程 | 自由口编程 | 无线电台 | 多站联网时编程较复杂

S7-200与S7-300/400之间的通信

S7-200与S7-300/400之间的通信，最常用和最可靠的是PROFIBUS-DP通信，以太网也越来越多地采用，其他不常用。

表2. S7-200与S7-300/400之间的通信方式：

通信方式 | 介质 | 本地需用设备 | 通信协议 | 通信距离 | 通信速率 | 数据量 | 本地需做工作 | 远端需做工作 | 远端需用设备 | 特点
PROFIBUS-DP | RS-485 | EM277扩展模块、RS-485网络部件 | PROFIBUS-DP | RS-485 | 9.6K - 12M | 中等 | 无 | 配置或编程 | PROFIBUS-DP模板/带DP口的CPU | 可靠，速度高；仅作从站
MPI | RS-485 | RS-485硬件 | MPI | RS-485 | 9.6K 19.2K 187.5K | 较少 | 无 | 编程 | CPU上的MPI口 | 少用；仅作从站
Ethernet | 以太网 | CP243-1扩展模块（RJ45接口） | S7 | 以太网 | 10M/100M | 大 | 编程向导配置编程 | 配置和编程 | 以太网模板/带以太网口的CPU | 速度快
Modbus RTU | RS-485 | RS-485网络部件 | Modbus RTU | RS-485 | 1200 -115200bps | 大 | 指令库 | 编程 | 串行通信模块＋Modbus选件 | 仅作从站
无线电 | RS-485/无线电转换 | 无线电台 | 自定义（自由口） | 电台传播距离 | 1200 － 115200bps | 中等 | 自由口编程 | 串行通信编程 | 串行通信模块 |
 |  |  | Modbus RTU |  |  | 大 | 指令库 | 指令库编程 | 串行通信模块＋Modbus选件＋无线电台 | 仅作从站

S7-200与西门子驱动装置之间的通信

S7-200与西门子MicroMaster系列变频器（如MM440、MM420、MM430以及MM3系列、新的SINAMICS G110 ）用USS通信协议通信。

可以使用STEP 7-Micro/WIN32 V3.2以上版本指令库中的USS库指令，简单方便地实现通信。

S7-200与第三方HMI/SCADA软件间的通信

S7-200与第三方HMI/SCADA软件之间的通信，主要有以下几种方法：

  • OPC方式（PC Access V1.0 [image] ）
  • PROFIBUS-DP
  • Modbus RTU（可以直接连接到CPU通信口上，或者连接到EM241模块上，后者需要Modem拨号功能）

如果监控软件是VB/VC应用程序，可以采用如下几种方法：

  • PC上安装西门子的PC Access V1.0 [image] 软件，安装后在目录中提供了连接VB的例子。
  • Modbus RTU通信（可以直接连接到CPU通信口上，或者连接到EM241模块上，后者需要Modem拨号功能）
  • S7-200采用自由口功能，通过确定的通信协议（如Modbus RTU）或其他自定义协议通信
  • 如果VB/VC应用程序能够通过计算机访问PROFIBUS-DP网络，可以使用PROFIBUS-DP方式

S7-200与第三方HMI/SCADA软件（上位机）之间的通信方式，取决于对方的通信硬件和软件能力。有关事宜请咨询第三方提供商。

S7-200与第三方PLC之间的通信

S7-200与第三方的PLC设备通信可以采用以下主要方式：

  • PROFIBUS-DP：如果对方能做PROFIBUS-DP主站，建议采用此方式，最为方便可靠
  • Modbus RTU：如果对方能做Modbus RTU主站，可使用此方式
  • 自定义协议（自由口）

S7-200与第三方HMI（操作面板）之间的通信

如果第三方厂商的操作面板支持PPI、PROFIBUS-DP、MPI、Modbus RTU等S7-200支持的通信方式，也可以和S7-200连接通信。

西门子不测试第三方的HMI与S7-200之间的连接，有相关的问题必须咨询第三方HMI的提供者。

S7-200与第三方变频器之间的通信

S7-200如果和第三方变频器通信，需要按照对方的通信协议，在本地用自由口编程。

如果对方支持Modbus，需要S7-200侧按主站协议用自由口编程。

S7-200与其他串行通信设备之间的通信

S7-200可以与其他支持串行通信的设备，如串行打印机、仪表等通信。如果对方是RS-485接口，可以直接连接；如果是RS-232接口，可能需要转换。

此种通信都需要按照对方的通信协议，使用自由口模式编程。


通讯－S7-200网络通讯协议

S7-200支持的通信协议

表1. S7-200系统支持的通信协议略表

协议类型 | 端口位置 | 接口类型 | 传输介质 | 通信速率 | 备注
PPI | EM241模块 | RJ11 | 模拟电话 | 33.6Kbits/s | 数据传输速率
 | CPU口0/1 | DB-9针 | RS-485 | 9.6K,19.2K,187.5K | 主、从站
MPI |  |  |  | 19.2K,187.5K | 仅从站
 | EM277 | DB-9针 | RS-485 | 19.2K...187.5K...12M | 速率自适应 从站
PROFIBUS-DP |  |  |  | 9.6K,19.2K...187.5K...12M
S7协议 | CP243-1/ CP243-1 IT | RJ45 | 以太网 | 10Mbits/s, 100Mbits/s | 自适应
AS-Interface | CP243-2 | 接线端子 | AS-i网络 | 5/10ms循环周期 | 主站
USS | CPU口0 | DB-9针 | RS-485 | 1200bits/s...9.6K...115.2K | 主站 自由口库指令
Modbus RTU |  |  |  |  | 主站/从站 自由口库指令
 | EM241 | RJ11 | 模拟电话 | 33.6Kbits/s | 数据传输速率
自由口 | CPU口0/1 | DB-9针 | RS-485 | 1200...9.6K...115.2K |

S7-200 CPU上的通信口（Port0，Port1）可以工作在“自由口”模式下。 所谓自由口就是建立在RS-485半双工硬件基础上的串行通信功能，其字节传输格式为：一个起始位、7位或8位数据、一个可选的奇偶校验位、一个停止位。凡支持此格式的通信对象，一般都可以与S7-200通信。在自由口模式下，通信协议完全由通信对象，或者用户决定。

网络通信

一些通信标准只支持一对一的通信方式；另一些支持网络通信。S7-200支持多种网络通信方式。

网络通信协议要比一对一的通信更为复杂。网络通信对网络中的设备也有一定的要求，通信设备能否完全符合网络通信协议的要求会影响、制约实现整个网络通信的完整功能。考察这些网络通信协议的要求，对于项目的规划、设计、调试具有重要的意义。选用适当的设备可以有目的地利用网络通信要求的特点，做到经济合理。

在用户的实际工作中，上述的制约更多地在使用了非西门子的第三方产品时出现。

S7-200的特点就是支持网络通信。连接到S7-200编程口的设备都可以认为是连接到了S7-200通信网络上。一个典型的例子是安装了编程软件Micro/WIN的计算机，通过编程电缆与CPU通信口相连，这也可以认为是一个通信网络。

通信主站和从站

通信协议规定了通信设备在网络中的角色，可分为：

  • 通信从站：从站不能主动发起通信数据交换，只能响应主站的访问，提供或接受数据。从站不能访问其他从站。在多数情况下，S7-200在通信网络中作为从站，响应主站设备的数据请求。
  • 通信主站：可以主动发起数据通信，读写其他站点的数据。
    S7-200 CPU在读写其他S7-200 CPU数据时（使用PPI协议）就作为主站（PPI主站也能接受其他主站的数据访问）；S7-200通过附加扩展的通信模块也可以充当主站。

安装编程软件Micro/WIN的计算机一定是通信主站；所有的HMI（人机操作界面）也是通信主站；与S7-200通信的S7-300/400往往也作为主站。

只有一个主站，其他通信设备都处于从站通信模式的网络就是单主站网络。单主站网络的例子有：

  • 一个S7-200 CPU和Micro/WIN（编程计算机）的通信
  • 一个S7-200 CPU和一个HMI（如TD200）的通信
  • 多个CPU联网（但它们都处于PPI从站模式时），与Micro/WIN的通信
  • 多个CPU联网，网络上只有一个HMI（如TP170B等）
  • 一个CPU使用USS协议与一个或多个西门子驱动装置通信
  • 一个Modbus RTU主站与从站的通信

一个通信网络中，如果有多个通信主站存在，就称为多主站网络。属于多主站网络的情况有：

  • 一个S7-200 CPU连接一个HMI，同时需要Micro/WIN的编程通信
  • S7-200 CPU联网，有CPU做PPI主站访问其他CPU的数据，同时需要Micro/WIN编程、监视
  • CPU联网，有两个以上的CPU做PPI通信主站
  • 一个S7-200 CPU连接多个HMI
  • 联网的多个CPU，连接多个HMI
  • 上述情况的组合

单主站和多主站网络的状态并不总是绝对不变的。例如一个仅包括一个CPU和一个TD200的单主站网络，如果要与Micro/WIN进行编程通信，它就变成了多主站网络。

并不是所有的设备都支持多主站网络通信！在多主站网络中，主站要轮流控制网络上的通信，这就要求它们有交换令牌的能力。不是所有的设备都有这个能力。参见多主站通信能力。

S7-200 CPU使用自由口通信模式时，既可以做主站，又可以做从站。如S7-200用USS协议控制西门子驱动装置时是主站；使用Modbus RTU从站指令库时它就是从站。这说明所谓主、从是由通信协议决定的，用户在编制通信协议时自己定义各通信设备在通信活动中的角色。

服务器和客户端

服务器（Server）与客户端（Client）的关系有些像从站与主站的关系。服务器总是等待客户端发起数据访问。这个概念常常在以太网通信中使用。

一个通信对象是服务器还是客户端取决于它们在通信活动中的具体作用。例如，CP243-1以太网模块既可以配置为服务器等待客户端来访问，也可以配置为客户端访问其他服务器。CP243-1作为服务器时，运行在计算机上的PC Access软件作为客户端通过CP243-1访问CPU的数据；而PC Access软件本身是OPC Server，OPC Client软件（如支持OPC的HMI软件）可以访问它。

CP243-1/CP243-1 IT与S7-300/400的以太网模块一样，既可以做服务器，也可以做客户端；S7-200的OPC Server——PC Access与CP243-1连接时是客户端，同时对上位的监控软件是服务器。

PPI, MPI和PROFIBUS

PPI，MPI和PROFIBUS都是基于OSI（开放系统互联）的七层网络结构模型，符合欧洲标准EN50170所定义的PROFIBUS标准，基于令牌的的网络通信协议。这些协议是非同步的（串行的）基于字符的通信协议，字符格式包括一个起始位、8个数据位、一个偶校验位和一个停止位。其通信帧包括特定的起始和结束字符、源和目的站的地址、帧长度和数据校验和。

在波特率一致、各站地址不同的情况下，PPI，MPI和PROFIBUS可以同时在一个网络上运行，并且互不干扰。

这就是说如果一个网络上有S7-300、S7-200，S7-300之间可以通过MPI或PROFIBUS通信，而在同时在同一个网络上的TP170 micro触摸屏可以与一个S7-200 CPU通信。

编程通信和数据通信

  • 编程通信： 使用编程软件STEP 7-Micro/WIN，通过各种网络，最终对S7-200的CPU进行各种编程操作，如上传、下载程序，监视数据变量，进行诊断等；
  • 数据通信： S7-200 CPU之间，或与其他通信对象之间，进行数据读写、交换。数据可以是二进制位的状态，数值数据，或者字符串等。

一些通信方式既支持编程通信，又支持数据通信；但能进行数据通信的，不一定支持编程通信方式。


通讯协议的具体内容

是否可以得到有关通信协议细节？

S7-200支持的通信协议，有些是公开的标准；有些是西门子公司的内部协议，不公开。

  • PPI协议：
    西门子内部协议，不公开

  • MPI协议：
    西门子内部协议，不公开

  • S7协议：
    西门子内部协议，不公开

  • PROFIBUS-DP协议：
    标准协议，公开
    详情请参考：
    http://www.profibus.com

  • USS协议：
    西门子传动装置的通用串行通信协议，公开
    详情请参考相应传动装置的手册

  • MODBUS RTU：
    公开
    详情请参考：
    http://www.modbus.org


长距离通讯

S7-200的长距离通信

S7-200的通信距离可能是方案设计中的一个重要因素。

S7-200为用户提供了极为丰富的通信选择，在保障通信距离方面也非常出色。虽然如此，许多用户仍会觉得不能回避性价比的矛盾。

下面就S7-200的远距离通信能力作一简介：

RS-485网络通信

在S7-200系统中，PPI、MPI、PROFIBUS-DP协议都可以在RS-485网络上通信。RS-485是S7-200最常用的电气通信基础。

根据具体通信设备的性能，它们支持的通信速率和距离又有所不同。

  • CPU上的通信端口
    CPU通信口的最高速率为187.5K波特，保证的通信距离为50m。
    要获得更长的通信距离，需要增加RS-485中继器；在一个总线型网络上最多加9个中继器，但通信距离不能超过9600m。
    CPU通信口之通信距离

  • EM277上的通信口
    EM277的通信口在波特率为187.5K时可以做到1000m通信距离；要获得长距离的通信需要增加RS-485中继器。通信距离同上。
    EM277模块

  • PC/PPI电缆
    PC/PPI电缆是否可以延长

光纤通信

光纤通信除了抗干扰、速率高之外，通信距离远也是一大优点。

S7-200产品不直接支持光纤通信，但西门子有全线产品满足用户的光通信需求：

  • PROFIBUS-DP
    S7-200的PROFIBUS-DP通信模块EM277，通过连接相应的设备可以转换为光信号通信。具体情况请参照相关资料，或咨询西门子产品经销商。

  • 以太网
    S7-200的以太网模块CP243-1(IT)，通过相应的设备可以连接到光纤以太网。这里指的是工业以太网的局部网络。
    S7-200的以太网连接

    通过现成的企业内部网或互联网，S7-200可以通过以太网进行距离非常远的通信。理论上可以通达全球。

S7-200还可以连接第三方的RS-485/光纤转换器，进行PPI通信、自由口通信等。其通信距离请参照第三方产品的规格数据。

电话网

S7-200通过EM241音频调制解调器模块支持电话网通信。EM241要求通信的末端为标准的音频电话线，而不论局间的通信方式。通过EM241可以进行全球通信。

使用国别开关设置，EM241可以轻松地支持多国电信标准，使用户的设备适用于全球市场。

使用小交换机的局部电话网，通信距离取决于交换机（及中继设备）、电缆的性能。

无线通信

  • S7-200通过无线电台的通信距离取决于电台的频率、功率、天线等因素
  • S7-200通过GSM网络的通信距离取决于网络服务的范围
  • S7-200通过红外设备的通信也取决于它们的规格


STEP 7 Micro/WIN 指令库下载网址大全

S7-200 RS485 接口使用注意事项？

1. 通信线使用屏蔽双绞线，所有通信节点都要接地，并确保接地电阻小于4欧姆，否则冲击可能通过接地点引入到通信线；

2. 等电位处理，RS485参考电压为0V，所有通信节点的0V连接在一起，如果无法实施，例如由于电缆过长，可使用RS485中继器来实现隔离。如果没有进行等电位处理，接口可能被损毁；

注：S7-200 上的M（参考电压0V）与集成的RS485 端口的5脚（逻辑公共端）是内部连接的；

3.通信电缆远离其他电缆，特别是电机电缆；

4.对于长度大于2米的通信电缆，确保两个端点都放置了终端电阻，消除通信电缆中的信号反射，可以使用PROFIBUS电缆和带有终端电阻的PROFIBUS网络连接器；

5. 不允许带电热插拔通信电缆；

6. S7-200 上数字量输出点上的感性负载连接抑制回路。


网络硬件

网络的硬件组成

只有符合标准的设备才能在网络上互相通信。网络标准对通信协议和硬件设备都作了规定。我们在讨论PPI、MPI、PROFIBUS-DP通信的距离、速率等等特点时，要注意到它们的硬件基础。

S7-200系统主要支持以下几种通信的硬件标准：

  • RS-485
  • 以太网
  • 模拟音频电话网
  • AS-Interface

除了这些S7-200 CPU或者通过扩展模块直接支持的网络硬件条件外，还可以通过一些转换器件，实现诸如光纤通信、无线电通信等。


RS-485网络

S7-200系统支持的PPI、MPI和PROFIBUS-DP协议通常以RS-485电气网络为硬件基础。

RS-485串行通信标准采用平衡信号传输方式，或者称为差动模式。平衡传输方式可以有效地抑制传输过程中干扰。

平衡方式采用一对导线，利用两根导线间的电压差传输传输信号。这两根导线被命名为A（TxD/RxD-）和B（TxD/RxD+）。当B的电压比A高时，认为传输的是逻辑“高”电平；当B的电压比A低时，认为传输的是逻辑“低”电平信号。能够有效工作的差动电压范围十分宽广，可以从零点几伏到接近十伏。

RS-485通信端口可以做到很高的通信速率，较长的通信距离，以及并联连接多个端口。

平衡通信方式能否有效工作受到共模电压差的影响。RS-485接口的两根导线相对于通信对象信号地的电压差就是共模电压。非电气隔离的RS-485接口能在一定的范围内抵抗共模电压对通信的干扰。

S7-200 CPU通信口的共模抑制电压是12V。所以对于这类非隔离型的RS-485端口，保证通信口之间的信号地等电位非常重要，最好将它们连接在一起（并不是说一定要接地）。

S7-200系统中的RS-485端口是半双工的，不能同时发送和接收信号。

在S7-200系统中，选择合适的通信设备，可以做到波特率从1200到12M，单段距离1000m，单段站点32个的通信网络。通过中继器，RS-485电气网络还可以扩展通信距离，增加通信站点。详情请参考《S7-200系统手册》关于通信的专门一章。

虽然常见的RS-485通信器件在电气性能上基本一致，但物理接口却五花八门，没有统一的规定。

西门子系统中的 D-Sub 9 针型 RS-485 端口，引脚定义是基本一致的。参看通信口引脚定义。

S7-200系统中的RS-485通信

在S7-200系统中，CPU上的通信口（编程口），以及EM277模块上的通信端口都是符合RS-485电气标准的。但它们也有所不同：

  • S7-200 CPU上的通信口是非隔离型的，最高通信速率187.5K波特
  • EM277上的通信口是隔离的，最高通信速率12M，并且速率自适应

以下三种协议，都可以在RS-485的硬件基础上实现通信：

  • PPI（包括编程通信、S7-200 CPU之间、S7-200 CPU与HMI之间的通信等）
  • MPI（S7-200 CPU与S7-300/400 CPU、S7-200 CPU与HMI之间、EM277与HMI之间的通信等）
  • PROFIBUS-DP（EM277与其他PROFIBUS-DP主站之间的通信）

实际上，如果各通信站点的地址不同，通信波特率相同，上述三个协议可以在一个RS-485网络上同时实现各自的通信。当然，一个站点支持什么协议受到自身条件所限。

因此考察上述电气网络的通信时，我们应注意到它们都受RS-485网络电气基础的制约。上述网络所用的网络硬件基本一样。

参考

RS-485网络的硬件连接

RS-485联网注意事项


通讯口引脚定义

通信口引脚定义

关于S7-200 CPU和模块的通信端口引脚定义，详情请参考《S7-200系统手册》。

在这里只是列出了一些需要注意，或者用户感兴趣的要点。

S7-200 CPU通信口

表1. S7-200 CPU通信口引脚定义：

CPU插座(9针母头) | 引脚号 | PROFIBUS名称 | Port0/Port1（端口0/端口1）引脚定义
 | 1 | 屏蔽 | 机壳接地（与端子PE相同）/屏蔽
 | 2 | 24V返回 | 逻辑地（24V公共端）
 | 3 | RS-485信号 B | RS-485信号 B 或 TxD/RxD +
 | 4 | 发送请求 | RTS（TTL）
 | 5 | 5V返回 | 逻辑地（5V公共端）
 | 6 | ＋5V | ＋5V，通过100 Ohm电阻
 | 7 | ＋24V | ＋24V
 | 8 | RS-485信号 A | RS-485信号 A 或 TxD/RxD -
 | 9 | 不用 | 10位协议选择（输入）
 | 金属壳 | 屏蔽 | 机壳接地（与端子PE相同）/与电缆屏蔽层连通

上表中，3和8为RS-485信号，它们的背景颜色与PROFIBUS电缆、PROFIBUS网络插头上的颜色标记一致。通信端口可以从2和7向外供24V直流电源。

注意：

  • CPU通信口上的2、5针在内部是连通的，并且它们和CPU上的传感器电源（＋24V）的M也是连通的
  • 通信口插座的金属壳、1号针，与CPU接线端子上的电源部分的PE导通，而与上述的M不通
  • 拥有两个通信口的CPU，其Port0、Port1的2、5针相通，也与M连通

EM277通信口

表2. EM277通信口

EM277插座(9针母头) | 引脚号 | PROFIBUS名称 | 引脚定义
 | 1 | 屏蔽 | 机壳接地，连接插头外壳/屏蔽
 | 2 | 24V返回 | 24V返回，与模块端子M相通
 | 3 | RS-485信号 B | 隔离的RS-485信号 B 或 TxD/RxD +
 | 4 | 发送请求 | 隔离的RTS（发送请求，TTL电平）
 | 5 | 5V返回 | 隔离的5V返回
 | 6 | ＋5V | 隔离的＋5V电源（最大电流90mA）
 | 7 | ＋24V | ＋24V电源，来自模块端子L＋（最大电流120mA，带反向保护二极管）
 | 8 | RS-485信号 A | 隔离的RS-485信号 A 或 TxD/RxD -
 | 9 | 不用 | 不用
 | 金属壳 | 屏蔽 | 机壳接地（与引脚1相通）/可与电缆屏蔽层连通

使用PROFIBUS网络插头时，连接器外壳与PROFIBUS电缆的屏蔽层相通。EM277插头上的24V电源从模块端子L+/M来。

EM277通信口具有优异的通信能力，其主要原因是它的RS-485信号是隔离的。在情况复杂通信受到影响时，可以使用EM277连接操作面板（其他品牌的HMI须咨询其生产商）。

PC/PPI电缆

关于PC/PPI电缆的详细情况，请参考相应的《S7-200系统手册》，在附录A中由详细的介绍。这里只提示关于电缆的一些有趣的细节。

目前销售的RS-232/PPI多主站电缆（6ES7 901-3CB30-0XA0）与以前销售的PC/PPI电缆（6ES7 901-3BF21-0XA0）略有区别，比较如下：

表3. RS-232/PPI多主站电缆

RS-485侧插头 | RS-485侧插头引脚定义 | RS-232侧插头引脚定义（本地模式）1 | RS-232侧插头引脚定义（远程模式）1
1 | 未连接 | 数据载波检测（DCD）（不用）
2 | 24V返回（RS-485逻辑地） | 接收数据（RD）（从电缆输出） | 接收数据（RD）（输入到电缆）
3 | RS-485信号B（RxD/TxD+） | 传送数据（TD）（输入到电缆） | 传送数据（TD）（从电缆输出）
4 | RTS（TTL电平） | 数据终端就绪（DTR）
5 | 未连接 | 地（RS-232逻辑地） | 地（RS-232逻辑地）
6 | 未连接 | 数据设置就绪（DSR）
7 | 24V电源 | 发送请求（RTS）（不用） | 发送请求（RTS）（从电缆输出）2
8 | RS-485信号A（RxD/TxD-） | 清除发送（CTS）（不用）
9 | 协议选择 | 振铃指示（RI）（不用）
1. 本地（DCE）与远程（DTE）模式在电缆上用DIP开关6选择，开关位置在“ON”时为DTE模式，在“OFF”时为DCE模式。
2. 这时RTS信号总是为“ON”

此电缆的RS-232端，4针和6针始终连通，即DTR/DSR是短接的。

表4. PC/PPI电缆（3BF21）

RS-485侧插头 | RS-485侧插头引脚定义 | RS-232侧插头引脚定义（DCE模式）1 | RS-232侧插头引脚定义（DTE模式）1
1 | 插头外壳（PE） | 数据载波检测（DCD）（不用）
2 | 24V返回（RS-485逻辑地） | 接收数据（RD）（从电缆输出） | 接收数据（RD）（输入到电缆）
3 | RS-485信号B（RxD/TxD+） | 传送数据（TD）（输入到电缆） | 传送数据（TD）（从电缆输出）
4 | RTS（TTL电平） | 数据终端就绪（DTR）（不用）
5 | ？ | 地（RS-232逻辑地） | 地（RS-232逻辑地）
6 | 未连接 | 数据设置就绪（DSR）（不用）
7 | 24V电源 | 发送请求（RTS）（不用） | 发送请求（RTS）（从电缆输出）2
8 | RS-485信号A（RxD/TxD-） | 清除发送（CTS）（不用）
9 | 协议选择 | 振铃指示（RI）（不用）
1. DCE与DTE模式在电缆上用DIP开关5选择，开关位置在“ON”时为DTE模式，在“OFF”时为DCE模式。
2. RTS信号可以用DIP开关6在两种状态间选择：开关为“ON”时为“发送 时为1 ”；开关为“OFF”时为 “总是为1”。

上述的“本地”模式相当于“DCE”模式；“远程”模式相当于“DTE”模式。

所谓DTE和DCE是RS-232通信中的一对设备，参见PC/PPI电缆的DTE/DCE设置。


RS485网络的硬件连接

RS-485网络的硬件组成

在S7-200系统中，无论是组成PPI、MPI还是RPOFIBUS-DP网络，用到的主要部件都是一样的：

  • PROFIBUS电缆：电缆型号有多种，其中最基本的是PROFIBUS FC（Fast Connect快速连接）Standard电缆（订货号6XV1 830-0EH10）
  • PROFIBUS网络连接器：网络连接器也有多种形式，如出线角度不同等等

连接网络连接器

A. 电缆和剥线器。使用FC技术不用剥出裸露的铜线。

图1. 剥好一端的PROFIBUS电缆与快速剥线器（FCS，订货号6GK1905-6AA00）。

B. 打开PROFIBUS网络连接器。首先打开电缆张力释放压块，然后掀开芯线锁。

图2. 打开的PROFIBUS连接器

C. 去除PROFIBUS电缆芯线外的保护层，将芯线按照相应的颜色标记插入芯线锁，再把锁块用力压下，使内部导体接触。应注意使电缆剥出的屏蔽层与屏蔽连接压片接触。

图3. 插入电缆

由于通信频率比较高，因此通信电缆采用双端接地。电缆两头都要连接屏蔽层。

D. 复位电缆压块，拧紧螺丝，消除外部拉力对内部连接的影响。

网络连接器

网络连接器主要分为两种类型：带和不带编程口的。不带编程口的插头用于一般联网，带编程口的插头可以在联网的同时仍然提供一个编程连接端口，用于编程或者连接HMI等。

图4. 左侧为不带编程口的网络连接器（订货号：6ES7 972-0BA52-0XA0）
右侧的是带编程口的网络连接器（订货号：6ES7 972-0BB52-0XA0）

线型网络结构

通过PROFIBUS电缆连接网络插头，构成总线型网络结构。

图5. 总线型网络连接

在上图中，网络连接器A、B、C分别插到三个通信站点的通信口上；电缆a把插头A和B连接起来，电缆b连接插头B和C。线型结构可以照此扩展。

注意圆圈内的“终端电阻”开关设置。网络终端的插头，其终端电阻开关必须放在“ON”的位置；中间站点的插头其终端电阻开关应放在“OFF”位置。

终端电阻和偏置电阻

一个正规的RS-485网络使用终端电阻和偏置电阻。在网络连接线非常短、临时或实验室测试时也可以不使用终端和偏置电阻。

  • 终端电阻：在线型网络两端（相距最远的两个通信端口上），并联在一对通信线上的电阻。根据传输线理论，终端电阻可以吸收网络上的反射波，有效地增强信号强度。两个终端电阻并联后的值应当基本等于传输线在通信频率上的特性阻抗
  • 偏置电阻：偏置电阻用于在电气情况复杂时确保A、B信号的相对关系，保证“0”、“1”信号的可靠性

西门子的PROFIBUS网络连接器已经内置了终端和偏置电阻，通过一个开关方便地接通或断开。终端和偏置电阻的值完全符合西门子通信端口和PROFIBUS电缆的要求。

合上网络中网络插头的终端电阻开关，可以非常方便地切断插头后面的部分网络的信号传输。

与其他设备通信时（采用PROFIBUS电缆），对方的通信端口可能不是D-SUB9针型的，或者引脚定义完全不同。如西门子的MM4x0变频器，RS-485通信口采用端子接线形式，这种情况下需要另外连接终端电阻，西门子可以提供一个比较规整的外接电阻。对于其他设备，可以参照《S7-200系统手册》上的技术数据制作。

西门子网络插头中的终端电阻、偏置电阻的大小与西门子PROFIBUS电缆的特性阻抗相匹配，强烈建议用户配套使用西门子的PROFIBUS电缆和网络插头。可以避免许多麻烦。

记住联网的格言：你糊弄它，它就糊弄你！


通讯硬件注意事项

通信有关注意事项（硬件）

硬件对能否正常通信有决定性的影响，如果硬件条件不能满足，采取其他措施往往不能从根本上改善通信中的问题。

记住联网的格言：你糊弄它，它就糊弄你！

应当注意：

  • 使用符合要求的硬件（电缆、插头），并按规范制作

    S7-200系统中用到的电缆、插头等都有特定的要求，强烈建议使用西门子的电缆和附件。

    参看通信硬件

  • 保持通信端口（驱动电路）之间的共模电压差在一定范围内

    对于非隔离的通信口（如CPU上的通信口），保证它们之间等电位非常重要。在S7-200 CPU联网时，可以将所有CPU模块的传感器电源输出的L+/M中的M端子，用导线串接起来。在S7-200 CPU与变频器通信时，要将所有变频器通信端口的M（在西门子MM4x0系列是二号端子）连接起来，并与CPU上的传感器电源M连接。

  • 电磁干扰

    电磁环境的好坏及采取的应对措施，对于通信的可靠性非常重要。例如，通信电缆不应与动力电缆平行放置，距离过近；变频器输出动力电缆，如果没有选用屏蔽电缆，对通信的干扰就非常大；220V供电的CPU，如果电源与变频器输入侧电源共用，高频干扰的影响也非常大……

    屏蔽（PE）端的连接。注意所有CPU或者EM277模块上PE（保护接地）端子必须连接到大地、或者柜壳上。否则电缆的屏蔽层等于没有用。

    西门子有一本《西门子自动化与驱动产品符合电磁兼容规则的安装规范手册》，很有价值，如果需要可致电西门子技术支持热线索取其电子版本，或者直接到以下网址下载：

    http://www.ad.siemens.com.cn/service/e-training/micro


PC/PPI电缆相关问题

PC/PPI电缆常问问题

PC/PPI电缆是否可以延长？

PC/PPI电缆的标准长度是5米。PC/PPI电缆的RS-485一端符合RS-485电气标准，有些用户延长了电缆，做到了超过5米距离的通信。

西门子不能保证这种做法一定成功。

在PC/PPI电缆的RS-485端加一个9针插座，通过插座再外加电缆延长。电缆需要从RS-485一侧的插头取得24V电源供应。

参考：PC/PPI电缆插头引脚定义。

新的PC/PPI（RS-232/PPI）电缆（6ES7 901-3CB30-0XA0）与旧电缆（6ES7 901-3BF30-0XA0/6ES7 901-3BF21-0XA0）在引脚定义上有什么区别？

新、旧PC/PPI电缆除了一般的区别外，还有一些细节上的不同：

  • RS-485侧的引脚定义发生了一些无关紧要的变化
  • 老电缆的RTS信号可以通过DIP开关6设置为“总是ON”或者“当发送时为ON”，新电缆上的RTS信号不能设置并且总是为“ON”
  • 旧电缆的DTR信号没有连接；新电缆上的DTR信号与DSR是连通的

参见新、旧电缆引脚定义表。新电缆所做的上述改动是为了更好地与音频调制解调器（Modem）连接。

如何设置PC/PPI电缆的DCE（本地）和DTE（远程）模式？

早期RS-232接口主要用来连接PC机和数据Modem。在这种连接中，计算机被配置为数据终端设备（DTE），Modem作为数据通信设备（DCE）。现在RS-232也用于连接其他设备如串行打印机、数据采集模块、无线数据电台等。一般地，一个RS-232连接总是包括一个DTE和一个DCE。

根据RS-232标准，DTE和DCE接口的数据信号引脚定义不同。信号总是按照DTE设备一侧命名。RS-232的三个基本信号是：

  • TD：从DTE传送到DCE的数据线
  • RD：从DCE传送数据到DTE的数据线
  • GND：信号地

另外还有两对握手信号：

  • DTR/DSR
  • RTS/CTS

新的多主站RS-232/PPI电缆（6ES7 901-3CB30-0XA0）的DTR/DSR信号是内部短接的。

电缆上的DIP开关6用来选择电缆在通信中做DTE，还是DCE设备（旧电缆3BF21使用DIP开关5选择）。参考PC/PPI电缆的RS-232侧引脚定义，可以发现设置DTE和DCE模式时改变了如下几个信号：

  • TD的信号方向（输出还是输入电缆）
  • RD的信号方向（输入还是输出电缆）
  • RTS信号

PC机总是DTE设备，因此在与PC机连接时电缆设置为DCE设备；和其他一些设备的RS-232口连接时，如部分串行打印机、数据电台时，可能需要设置为DTE设备。

最好的测试办法就是尝试改变DTE/DCE开关的设置状态。

旧电缆能与无线Modem连接在自由口模式下正常工作，为何新电缆不能？

如果能够确认新（6ES7 901-3CB30-0XA0）、旧（6ES7 901-3BF21-0XA0）电缆连接S7-200 CPU与某个设备通信时表现不同，则应考虑新、旧电缆在RS-232侧的区别。

可以使用新电缆的DIP开关6尝试设置RTS的工作模式，通信的双方应当一致。

无线Modem和电缆如何操作DTR信号也有关系。往往这些无线Modem的DTR信号被设置为低电平有效，而不是高电平有效或者“忽略DTR”。如果能够改变无线Modem的设置为“忽略DTR信号”，问题应当可以解决。

如果使用一个单独的RS-232接口“中断盒”，在其中断开引脚4的连接线，新电缆就和旧电缆一致了。


通讯－编程方式

S7-200 编程通信方式

S7-200 系统支持多种编程通信方式。

STEP 7-Micro/WIN 可以通过如下几种常见方式与S7-200 CPU通信：

  • 通过 PC/PPI 电缆，与单个或者网络中的 CPU 通信口（或 EM277 通信口）通信
  • 通过 CP（通信处理器）卡，与单个或者网络中的 CPU 通信口（或 EM277 通信口）通信
  • 通过本地计算机上安装的 Modem（调制解调器），经过公用或者内部电话网，与安装了EM 241 模块的 CPU 通信
  • 通过本地计算机上的以太网卡，经过以太网与安装了 CP243-1 以太网模块的 CPU 通信
  • 通过 PC Adapter USB （S7-300/400 USB 口串行编程电缆）与 CPU 通信口（或 EM 277通信口）通信
  • 通过本地计算机上安装的GSM Modem，与远程安装了GSM Modem（如TC35T）的CPU通信（须申请并开通相应SIM卡的数据传输服务）

用于 S7-300/400 编程的 PC 串口电缆（PC-Adapter RS232 ）不能用于S7-200编程通信

Micro/WIN 缺省的编程通信方式是 PC/PPI 电缆（如在安装 Micro/WIN 时所见的 “Set PG/PC Interface” 窗口中确认的）。如果要改变编程通信方式，也需要打开Set PG/PC Interface窗口进行设置。

Set PG/PC Interface 设置


通讯－编程通讯－电缆

系列视频：S7-200跟我学/跟我做:

S7-200CN: 编译和下载，运行和调试-跟我学 - 10/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=259
S7-200CN: 编译和下载，运行和调试-跟我做 - 11/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=260

通过PC/PPI电缆的编程通信

通过PC/PPI电缆的编程通信是最为常见的S7-200编程方式，很多人也在此遇到问题。

影响通信的因素很多，要顺利通信首先需要注意：

  • 检查Micro/WIN和Windows操作系统的版本兼容性

    未经西门子版本兼容测试的往往有通信问题。

  • 使用西门子的原装PC/PPI电缆

    包括用于连接PC机RS232串口的RS232/PPI电缆，和连接USB口的USB/PPI电缆。

    为什么要使用西门子的原装电缆？

编程通信要点

要进行S7-200的编程通信，必须注意使通信双方（即安装了Micro/WIN的PC机和S7-200的CPU或通信模块上的通信口）的通信速率、通信协议符合、兼容。否则不会顺利连通。

在具体工作中，参与编程通信的设备未必一定符合上述要求。例如，它们的通信速率就可能不一致。

注意以下几个通信速率，它们必须一致：

  • S7-200 CPU通信口的速率

    一个新出厂的CPU，它的所有的通信口的速率都是9.6K波特。CPU通信口的速率只能在S7-200项目文件中的“系统块”中设置，新的通信速率在系统块下载到CPU中后才起作用。
    系统块的CPU通信口参数设置

  • 通信电缆的通信速率

    如果使用智能多主站电缆配合Micro/WIN V3.2 SP4以上版， 只需将RS232/PPI电缆的DIP开关5设置为“1”而其他设置为“0”；而USB/PPI电缆不需要设置。老版本的电缆需要按照电缆上的标记设置DIP开关。

  • 由Micro/WIN 决定的PC机通信口（RS232口）的通信速率

    这个速率实际上是去配合编程电缆使用的，在Micro/WIN软件中打开Set PG/PC Interface，设置PC用于同编程电缆通信的速率。USB口使用USB/PPI电缆，不需指定速率。

通信连接举例

以RS232/PPI电缆为例：

第一步：打开Communications（通信）界面

在Micro/WIN主界面的左侧浏览条中用鼠标单击Communications（通信）图标；或者在指令树、View菜单中打开通信设置界面：

图1. 通信设置界面

图中：

  1. 通信设置区
    Local（本地）显示的是运行Micro/WIN的编程器（PC机）的网络地址。默认的地址为0。
    使用Remote（远程）下拉选择框可以选取试图连通的远程CPU地址。缺省的地址为2。
  2. 选中此项可以使通信设置与项目文件一起保存
  3. 显示电缆的属性，以及连接的PC机通信口
  4. 本地（编程器）当前的通信速率
  5. 选中此项会在刷新时分别用多种波特率寻找网络上的通信接点
  6. 显示当前使用的通信设备，鼠标双击可以打开Set PG/PC Interface界面，设置本地通信属性
  7. 鼠标双击可以开始刷新网络地址，寻找通信站点

第二步：设置PC/PPI电缆属性

鼠标双击图1中的f.图标，打开Set PG/PC Interface界面，检查编程通信设备。如果型号不符合，请重新选择。用鼠标单击“Properties...”按钮，打开PC/PPI电缆的属性设置界面：

图2. PC/PPI电缆属性

在PPI选项卡中：

  1. 设置Micro/WIN的本地地址
  2. 设置通信设置超时时间
  3. 这两项是附加设置，如果使用智能多主站电缆和Micro/WIN V3.2 SP4以上版，不必选中
  4. 本地通信速率设置
  5. 本地设置的最高站址
    通信参数设置

第三步：检查本地计算机通信口设置

在Local Connection（本地连接）选项卡中：

图3. 选择本地通信口

  1. 选择PC/PPI电缆连接的通信口
    如果使用USB/PPI电缆，可以选择USB。
  2. 如果使用本地计算机Windows中安装的Modem（调制解调器），须选取此项。这时Micro/WIN只通过Modem与电话网中的S7-200连接（EM241）

第四步：双击图1中的g.图标，开始寻找与计算机连接的S7-200站

找到S7-200站后显示：

图4. 找到S7-200 CPU

其中：

  1. 找到的站点地址
  2. 显示找到的S7-200站点参数。鼠标双击可以打开“PLC Information”界面

按“OK”键，保存通信设置。

修改通信参数

如果要改变通信速率，可以参考上文设置。

PC/PPI电缆连接EM277通信口编程

使用Micor/WIN V3.2 SP4 以上版本和新版编程电缆，无任何特殊设置。只是因为EM277对速率有个自适应的过程，可能需要尝试几次。

通信碰到问题怎么办？


编程电缆

S7-200 CPU有其专用的低成本编程电缆，统称为PC/PPI电缆，用于连接PC机和CPU上的RS-485通信口，可用做STEP 7-Micro/WIN对CPU 的编程调试，或与上位机做监控通信、或与其他具有RS-232端口的设备之间作自由口通信。

西门子提供的所有用于S7-200的编程电缆，长度都是5米。

目前西门子提供两种PC/PPI编程电缆，它们是：

  • RS-232/PPI电缆（订货号6ES7 901-3CB30-0XA0）：智能多主站电缆，连接S7-200 CPU/EM277通信口和计算机RS-232串口，作为编程或数据通信电缆；同时也可以用于连接TP170 micro和安装了WinCC flexible (micro)的计算机RS-232串口，作为配置画面下载电缆
  • USB/PPI电缆（订货号6ES7 901-3DB30-0XA0）：智能多主站电缆，用于连接计算机的USB通信口与S7-200 CPU/EM277通信口做编程或数据通信电缆

用于S7-300/400编程的PC串口电缆（PC-Adapter），不能用于S7-200编程通信

注意：西门子公司的专用PC/PPI电缆是带光电隔离的，不会烧CPU 或PC机的通信口。使用不隔离的自制或假冒的PC/PPI电缆，容易损坏通信口。一般电缆还不支持S7-200 CPU通信端口的最高通信速率（187.5K），而且不能支持S7-200的多主站编程模式。

用计算机串口与CPU通过RS-232/PPI电缆进行编程通信，要求计算机拥有一个UART 16550兼容的串行通信口。有些计算机端口扩展卡上的通信口，Micro/WIN不能直接管理，可能无法通信。

多主站RS-232/PPI电缆（6ES7 901-3CB30-0XA0）

图1. 正版RS-232/PPI电缆及其包装盒

因为此电缆能够管理PPI网络令牌，因而支持多主站PPI网络。

它有三个绿灯用于指示电缆的运行：RS 232 发送指示（Tx）；RS-232 接收指示（Rx）；RS 485 发送指示(PPI)。

图2. 正版电缆细部

此种电缆只能在STEP 7-Micro/WIN32 V3.2 SP4以上版本下才能获得全部的新功能，最高波特率可达187.5K。它有两种工作模式：

  • PPI模式：用于编程时，将DIP开关5设置为“1”，其他开关设置为“0”，其波特率可自适应，此时支持多主站网络通信。
  • 自由口模式：只需设置波特率，开关5及其它开关都设为“0”；此时也可以获得原来普通PC/PPI电缆的功能（不支持多主站）。

RS-232/PPI电缆还用于TP170 micro和TP070配置下载。此时DIP开关5应为“0”。

多主站USB/PPI电缆（6ES7 901-3DB30-0XA0）

图3. 正版USB/PPI电缆及其包装盒

此种电缆能够管理PPI网络令牌，因而支持多主站PPI网络。 它支持USB V1.1。用于连接PC机的USB通信口和S7-200。

它有三个绿灯用于指示电缆的运行：USB 发送指示（Tx）；USB接收指示（Rx）；RS 485 发送指示(PPI)。

图4. 电缆细部

此种电缆只能工作在STEP 7-Micro/WIN32 V3.2 SP4以上版本下，波特率为自适应（最高可达187.5K）。它只有一种工作模式即PPI模式，无开关设置。此种电缆不支持自由口通信。

注意：USB/PPI电缆不能用于TP070（或TP170micro [image] ）配置画面下载（应使用RS-232/PPI电缆并把DIP开关5设置在OFF），也不能用于使用wipeout.exe程序恢复出厂设置，也不能用于S7-200自由口程序，如Modbus RTU协议库的调试。

早期电缆

西门子早期生产的PC/PPI电缆，如6ES7 901-3BF21-0XA0/6ES7 901-3BF30-0XA0，不支持多主站PPI网络，即在连接有PPI通信主站CPU或TD 200文本显示器的网络时，无法通过电缆进行Micro/WIN与CPU的通信。（在CPU执行网络读/写指令时不能用STEP 7 Micro/Win监控也是这个原因）

开关设置：前三个开关按所需波特率进行设置，后三个设为0即可（Micro/WIN编程连接时）。

西门子生产的电缆都有中间的盒子。

如果使用老电缆与新版本的编程软件Micro/WIN，应在PC/PPI Cable的属性中，取消Advanced PPI和Multi Master Network选项（在Set PG/PC Interface中设置）。

使用USB/RS-232串口转换器

当编程计算机只有USB通信口，没有RS-232串口时，我们强烈建议客户使用智能USB/PPI电缆，并将编程软件升级到当前发布的最新版本。

如果坚持使用自己的USB/RS-232串口转换器，再使用串口PC/PPI电缆，由于转换器品牌众多，西门子无法一一测试，不能就遇到的问题提供支持。

遇到这种情况，只有下面的办法：

  • 更换其他USB/RS-232转换器，再做尝试
  • 使用西门子的USB/PPI电缆

常问问题

在Micro/WIN的系统块中为何不能将通信口设置为187.5K波特率？

新的Mciro/WIN会自动检测通信连接是否支持187.5K，如果不支持（如老版电缆），则不能设置为187.5K的通信速率。

新编程电缆支持187.5K速率。

如何设置PPI电缆属性中的Advanced PPI和Multi Master Network选项？

PPI电缆属性中的这两项设置与多主站通信功能有关。

随着计算机技术的发展，仅通过旧型号的PC/PPI电缆已经不能实现多主站通信，因此这两项设置现在已经没有用处。

采用新型号电缆，配合Micro/WIN V3.2 SP4以上版本，可以轻松实现多主站通信。因此应当取消上述两项的选择：

图5. PC/PPI电缆属性

老版本的PC/PPI电缆（6ES7 901-3BF21-0XA0等）是否可以用于为新版本的CPU（23版）编程？

可以。但是受到老版电缆的限制，不能做多主站编程，也只能用到9.6K和19.2K波特率。

使用PC/PPI电缆与S7-200做编程通信实例
使用PC/PPI电缆编程通信遇到问题怎么办？
多主站编程通信
PC/PPI电缆硬件相关问题。
为什么要选用西门子的原装电缆？


通讯－编程通讯－Set PG/PC Interface

Set PG/PC Interface

Set PG/PC Interface是西门子的PLC编程软件共用的编程访问路径设置界面。Micro/WIN也通过Set PG/PC Interface设置计算机与S7-200进行编程通信的访问点。

用Micro/WIN对S7-200编程时，如果需要改变编程通信方式，就需要打开Set PG/PC Interface进行设置。有如下几种方式可以打开Set PG/PC Interface窗口：

  • 打开Windows的Settings（设置）> Control Panel（控制面板），选择Set PG/PC Interface图标
  • 在Micro/WIN主窗口的左侧的View（浏览条）中，用鼠标单击Set PG/PC Interface图标
  • 打开Micro/WIN的Communications（通信）界面，用鼠标按其中的Set PG/PC Interface按钮，或双击当前通信设备的图标
  • 在Micro/WIN的指令树中用鼠标双击相应的图标
  • 在Micro/WIN的菜单View > Components中打开

Set PG/PC Interface简介

Set PG/PC Interface主界面如下：

图1. Set PG/PC Interface

图中：

  1. 显示当前的编程软件使用的编程访问路径及应用的协议

    图中设置为Micro/WIN通过PC/PPI电缆用PPI协议与S7-200通信。其中Micro/WIN不能修改是因为从Micro/WIN中打开的PG/PC Interface。

  2. 显示当前的通信设备及使用的协议

    这里使用PC/PPI电缆并使用PPI协议

  3. 按此按钮设置当前使用的设备的属性
  4. 在此区域内选择要用的设备，如CP5611（PPI）
  5. 如果在d.区中找不到设备，可以按“Select...”按钮进入添加/删除通信硬件的界面

添加/删除通信硬件

用图1中的e.按钮进入“添加/删除通信设备”界面：

图2. 添加/删除通信设备

在a.区显示可以选择的设备，在b.区显示了在系统中已经安装的设备；使用“安装/删除”按钮（c.）改变系统设置。


通讯－西门子编程电缆

为什么要使用SIEMENS的编程电缆？

西门子目前提供两种串口编程电缆，统称为PC/PPI电缆：

  • RS-232/PPI电缆（订货号6ES7 901-3CB30-0XA0）：智能多主站电缆，连接S7-200 CPU/EM277通信口和计算机RS-232串口，作为编程或数据通信电缆；同时也可以用于连接TP170 micro和安装了WinCC flexible (micro)的计算机RS-232串口，作为配置画面下载电缆
  • USB/PPI电缆（订货号6ES7 901-3DB30-0XA0）：智能多主站电缆，用于连接计算机的USB通信口与S7-200 CPU/EM277通信口做编程或数据通信电缆

我们强烈建议用户使用西门子生产的上述两种原装电缆，也有义务告知用户从中所能获得的好处：

  • 安全：西门子原装PC/PPI电缆的两个通信端口在电气上是隔离的。这就意味着编程计算机和PLC通信口之间的共模干扰不会造成双方通信口硬件的损坏，或者通信断续。在必须带电拔插电缆的情况下，原装电缆提供了可靠的保障
  • 稳定：原装电缆针对西门子的通信协议进行了专门设计、优化，其稳定性和抗干扰能力出色
  • 高速：使用原装电缆可以工作在187.5K通信速率下，充分发挥PLC和HMI通信口的潜力，不会制约整个网络的通信速度
  • 完备：原装智能多主站电缆能够完全支持西门子的PPI网络协议，如多主站通信功能，配合西门子的软、硬件使用，不会发生编程、监控时在某些情况下无法通信的问题

编程电缆


通信 - PC Adapter USB

STEP 7-Micro/WIN 如何用 PC Adapter USB 连接 S7-200 CPU 通信

STEP 7-Micro/WIN 也可以使用通常用于 S7-300/400 编程的 PC Adapter USB 对 S7-200 CPU 编程，但要符合一定的条件。

PC Adapter USB 订货号：6ES7 972-0CB20-0XA0

需要满足的软件条件：

  1. 安装 V1.2 版本的 PC Adapter USB 驱动

    该驱动需要操作系统为：

    • Windows 2000
    • Windows XP Professional
    • Windows XP Home

  2. STEP 7-Micro/WIN 必须为 3.2+SP4 或者 4.0 以上版本

    注意：对 CN CPU 编程必须使用 Micro/WIN V4.0 SP3 以上版本的中文界面

注意：用于S7-300/400编程的PC串口电缆（PC- Adapter），不能用于S7-200编程通信

驱动下载网址：http://support.automation.siemens.com/WW/view/en/21226394

操作步骤

用户成功安装驱动后，插上 PC Adapter 到计算机，并且插上 PC Adapter 到 CPU，为其供电。

打开 SET PG/PC Interface：

图1. SET PG/PC Interface 界面

  1. 选择“PC Adapter(PPI)”

    如果在这里找不到此选项 ，说明用户没有安装 V1.2 版本的 USB PC Adapter 驱动，或者安装的是低版本驱动。用户必须从上面的链接下载并安装最高版本的驱动程序。

  2. 点击“Properties”设置 PC Adapter(PPI) 的属性

设置 PC Adapter(PPI) 的属性：

图 2. 设置正确的通信速率

3、端口波特率必须设正确，即与 CPU通信口的波特率设置一致。

检查“Local Connection”标签：

图 3. 查看本地连接端口

4、在“Local Connection”页签可以看到端口已经设定为“USB”。

回到“通信”设置窗口：

图 4. “通信”窗口

5、使用USB接口的PC Adapter 无法使用’搜寻所有波特率’功能。
6、用鼠标双击“双击刷新”搜索所连接网络上的 S7-200 站。

WIN7下使用PC Adapter USB（6ES7 972-0CB20-0XA0）

针对Win7系统，西门子没有为PC Adapter USB（6ES7 972-0CB20-0XA0）提供独立的驱动程序。

因此如果需要在Win7的32bit/64bit下使用，需要先安装Step7 V5.5编程软件或TIA Portal V11/12/13编程软件。这些软件自带适用于Win7下的PC Adapter USB驱动，可以提供给Step7-Micro/WIN连接使用。


PC Adapter USB A2 适配器与S7-200 CPU 的编程通信

PC Adapter USB A2 （订货号：6GK 1571-0BA00-0AA0） 是 PC Adapter USB ( 订货号：6ES7 972-0CB20-0XA0) 的升级替代产品。它也可以与S7-200进行编程通信，完成正常的上载、下载及在线监控操作。

需要满足的软件条件：

1. 安装 PC Adapter USB A2 的驱动

该驱动支持的操作系统为：

  • Windows 7
  • Windows Server 2008 R2
  • Windows XP Professional SP2或更高版本
  • Windows XP Home SP2或更高版本
  • Windows Server 2003 Standard Edition
  • Windows Vista

2. STEP 7-Micro/WIN 必须为 V3.2+SP4 或者 V4.0 以上版本。

驱动下载链接： https://support.industry.siemens.com/cs/cn/en/view/78453460

注意： 如果电脑上同时还安装了STEP 7 软件，且软件版本在STEP 7 V5.5 SP4 （包含SP4）及其以上，那么就不需要安装电缆驱动，直接按照下面的操作步骤进行通信即可。

操作步骤

驱动成功安装后，需要插上电缆，一端连接电脑，另一端与PLC 相连，并且给PLC 供电。

打开"设置PG /PC 接口"：

图1. 设置 PG/ PC 接口界面

1. 选择“ PC Adapter USB A2 PROFIBUS.1"

2. 点击” Properties" 设置 PC Adapter USB A2 PROFIBUS.1 的属性

进入设置属性界面：

图2. 属性设置界面

1. 需要勾选“ PG/PC 为总线上的唯一主站”

2. 端口波特率必须设置正确，即与 CPU 通信口的波特率保持一致

（提示：若在9.6kbps 的波特率下没有搜索到PLC 的站地址，可分别再更换为19.2kbps 或 187.5kbps 进行测试）

选择完成后，点击“OK”退出设置界面，然后回到“通信”界面。

图3. 通信界面

点击“双击刷新”，搜索到S7-200的站地址及类型等信息。


CP卡编程通讯

CP 卡编程通信

可用于S7-200编程的CP卡包括CP5611（用于PCI总线的PC机），CP5511/CP5512（用于笔记本电脑）。以下统称为CP卡。

使用CP卡进行编程通信，应使用MPI电缆，或者PROFIBUS电缆连接CPU上的编程口，或者带编程口的网络连接器上的扩展编程口，或者EM277模块上的通信口。

CP5613不能连接S7-200 CPU通信口编程。

CP5511/CP5512/CP5611不能在Windows XP Home版下使用。

所有的CP卡不支持S7-200的自由口编程调试。

CP卡与S7-200通信时，不能选择“CP卡（auto）”

MPI的最低通信速率为19.2K。

通过CPU的PPI通信口下载程序

在MicroWin 编程软件的Set PG/PC Interface中选择CP5611（PPI）、CP5611（MPI）或CP5611（PROFIBUS），然后在“properties”中选择合适的波特率。

注意：

  • 选择“CP 卡（PPI）”方式时 ， 如果在通信卡的属性中选中“Advanced PPI”，则不能与网络上的 PPI 主站通信。
  • 如果要通过“CP卡（MPI）”方式与S7-200通信，应注意CPU通信口的当前通信速率。S7-200 CPU通信口的缺省速率为9.6 K，而MPI的最低速率为19.2 K。应使两者一致，必要时须重新设置CPU通信口的速率。
  • 选择“CP卡（PROFIBUS）”和“CP卡（MPI）”方式时，必须在通信卡的属性中选中“PG/PC is the only master on the bus”。

通过EM277模块的编程

在Micro/Win 编程软件的Set PG/PC Interface中选择CP5611（PPI）
CP5611（PROFIBUS）或CP5611（MPI）；然后在“properties（属性）”中选择合适的波特率及其它设置。

注意：

  • 选择“CP卡（PPI）”时，必须在属性中选中“Advanced PPI"
  • CP卡连接到EM277模块时，可以使用MPI电缆或者PROFIBUS电缆
  • 注意检查EM277地址设置开关是否到位，如果重新设置了地址开关，必须重新上电一次
  • 一定要注意通信硬件是否符合标准，特别是连接EM277做高速通信时
  • 选择“CP卡（PROFIBUS）”和“CP卡（MPI）”方式时，必须在通信卡的属性中选中“PG/PC is the only master on the bus”

CP 卡编程通信时的常见错误信息

通信方式 | 设置 | 出错信息
CP 卡（PPI） | 波特率等设置不对， 或连接硬件有问题 | 通信超时……
CP 卡（PROFIBUS) CP 卡（MPI） | 波特率等设置不对， 或连接硬件有问题， 但选择了“PG/PC is the only master on the bus”
CP 卡（PROFIBUS) CP 卡（MPI） | 未选择“PG/PC is the only master on the bus” | 错误：端口无法打开或正在由另一个应用程序使用


如何通过CP243-1与STEP 7-Micro/WIN 通信

系列视频：S7-200跟我学/跟我做

S7-200CN: 通过以太网实现远程编程和诊断-跟我学 - 184/185：

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=433

S7-200CN: 通过以太网实现远程编程和诊断-跟我做 - 185/185：

http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=434

通过以太网编程

要实现用以太网对S7-200 CPU编程，你需要有：

  1. 装有以太网卡的PC机，PC机上装有STEP 7-Micro/WIN（V3.2 SP1以上）软件
  2. 能够通过PC/PPI电缆、或CP卡、或EM241与CPU做通信编程
  3. CP243-1以太网模块
  4. 一个HUB（集线器）、或Switch（交换机）和网络电缆，或以太网直连电缆

首先你需要用STEP 7-Micro/WIN 软件，在Tools > Ethernet Wizard（以太网向导）中对CP243-1进行配置，为其设定IP地址、子网掩码等。

1. CP243-1以太网向导配置

CP243-1模块是S7-200系列产品中唯一一款以太网通信模块，它既可以作为西门子以太网S7通信中的客户端，也可作为服务器。那么，如果想通过以太网通信与PC机中的STEP 7-Micro/WIN软件通信，实现编程的上载、下载或在线监控，以太网向导该如何配置呢？下面将对CP243-1的以太网向导配置做详细描述。
首先，通过PC/PPI电缆使PC机与S7-200的通信成功，然后进入工具中的以太网向导配置界面，如图1所示：

图 1 以太网向导配置
进入到向导配置界面中，将会看到如图2所示的界面。点击“读取模块”即可读出CP243-1的模块信息，然后双击模块信息，将模块位置添加成功。

图2 模块位置读取
每个CP243-1模块都需要配置一个IP地址，如图3的界面所示。IP地址的设置需要在指定的对话框中进行设置。

图3 IP地址分配界面
点击图3中标注的选项，进入图4界面。在该界面中的IP地址栏内填入与PC机同一个网段的IP地址，然后点击保存，并退出该界面。

图4 IP地址设定
CP243-1模块需要占用一个QB字节，该字节的地址不能任意填写，需要进行计算（如果通过自动读取模块位置的方式则会自动计算）。计算的规则就是从CPU本体的输出字节开始计算，依次排列到CP243-1的模块位置即可；也可以通过查看PLC菜单中的信息，找到CP243-1模块输出的起始地址。CP243-1模块的连接资源数目为8个S7连接加一个PG资源。该PG资源为S7-200的编程软件，所以在图5中可以不用建立连接数目。

图5 设定QB字节地址及连接数目
图6中会对以太网向导配置分配V存储区地址 ，该V区地址在程序的其它地方不能被再次使用。

图6 分配V存储区地址

2. CP243-1模块的编程与通信

当配置完以太网向导后，在调用子程序中会找到向导生成的子程序，将其调用在主程序中，如图7所示：

图7 以太网初始化程序
全部编译后若没有错误就可以下载到PLC中。下载成功后，需要断电再上电使模块配置生效，此时CP243-1模块上面的指示灯状态为LINK灯与RUN灯常亮，RX/TX灯闪烁。
在设置 PG/PC 接口中，选择相应的TCP/IP协议，再打开通信的对话框，在IP地址栏里选择组态过的IP地址，然后点击双击刷新按钮即可找到对应的CPU地址，如图8所示。

图8 通过以太网方式连接S7-200
至此，CP243-1与PC机上的STEP 7-Micro/WIN软件就连接成功了。这时，CP243-1的CFG灯也会亮橘黄色，代表S7-200编程软件与CP243-1模块以太网连接成功，可以完成上载、下载以及在线监控程序任务。


通讯－编程－多主站通讯

PPI网络上的多主站编程通信

如果在一个通信网络上存在其他主站（如TD 200，或者上位计算机等），同时需要进行Micro/WIN的编程、监控，这就是多主站网络编程。

使用西门子的下列设备可以实现Micro/WIN的多主站编程：

  • 使用智能多主站电缆和Micro/WIN V3.2 SP4以上版本。 新电缆可以在网络上传递令牌，因而自动支持多主站网络编程。
  • 如果使用CP卡，如CP5511/CP5512（笔记本电脑PCMCIA卡）、CP5611（台式机PCI卡），能够支持多主站编程通信。

如果通过CP卡编程时，选择了MPI协议，注意MPI主站不能访问作为PPI主站的CPU。

如果有第三方的产品要连接到多主站网络上，用户需要咨询第三方产品提供商以了解是否支持西门子的S7-200多主站网络。要进行多主站编程，不但编程计算机要支持，网上的其他设备也要有多主站通信能力。

早期的多主站连接依赖于计算机硬件和Windows操作系统。随着计算机技术的发展，多数情况下已经不能做到多主站编程通信。建议用户使用西门子的多主站编程电缆或者CP卡配合Micro/WIN实现多主站编程通信。


编程通讯故障

编程软件STEP 7-Micro/WIN不能与CPU正常通信，如何检查处理？

影响通信的因素很多，需要仔细检查。可用简化连接，替换设备等方法，逐步缩小故障点可能所在的范围。例如，当网络上有一个CPU不能进行编程通信，就要将CPU从网络上脱开，单独进行编程通信检查。

在设备正常的条件下，发生Micro/WIN不能与CPU通信的原因主要有：

  • Micro/WIN中设置的对方通信口地址与CPU的实际口地址不同
  • Micro/WIN中设置的本地（编程电脑）地址与CPU通信口的地址相同了（应当将Micro/WIN的本地地址设置为“0”）
  • Micro/WIN使用的通信波特率与CPU端口的实际通信速率设置不同
  • 有些程序会将CPU上的通信口设置为自由口模式，此时不能进行编程通信。编程通信是PPI模式。而在“STOP”状态下，通信口永远是PPI从站模式。最好把CPU上的模式开关拨到“STOP”的位置

针对上述情况，可以在Micro/WIN左侧的浏览条中点击Communication（通信）图标，在对话框中双击通信设备的图标（如PC/PPI电缆），改变本地的连接属性（本地地址或通信速率设置）；双击Refresh（刷新）图标，并且选中Check all baudrate（检查所有波特率）可以找到地址、速率不明的站点。此时应使用新的RS-232/PPI电缆或者USB/PPI电缆，或CP卡，否则不能覆盖所有的波特率范围。

如果使用CP5511、CP5512、CP5611等通信卡与S7-200 CPU进行编程通信，可以看到CPU通信口的一些状态报告，便于判断是否硬件损坏。

检查编程通信的主要步骤

以下步骤仅仅适合使用“真的”PC机串行通信口（UART16550或兼容的COM口），再连接西门子PC/PPI（RS-232口）电缆的情况

如果有时能够通信但不正常，请检查如下“1－4”项，如果根本不通，请检查全部项目：

  1. 检查STEP 7-Micro/WIN与Windows操作系统是否完全兼容

  2. 检查是否使用西门子的原装编程电缆，以及电缆是否符合编程PC机或笔记本电脑的硬件条件

  3. 检查编程电脑上的COM通信口设置

    1. 鼠标右键单击“我的电脑”，选择“属性”
    2. 打开“设备管理器”标签（对于Windows2000，选择“硬件”标签，按“设备管理器”按钮）
    3. 双击“端口（COM和LPT）”
    4. 双击所使用的通信口，如COM1
    5. 在端口设置标签，选择“高级”
    6. 在对话框中把接收和发送缓冲区都设置为最小值，并保持选中“FIFO”选择框
    7. 重新启动计算机使设置有效

  4. 检查编程电缆的DIP开关设置，是否与Micor/WIN的通信速率设置相同

    在Micro/WIN左边的浏览条中鼠标单击Communication（通信）大图标，检查通信参数设置。鼠标双击PC/PPI电缆图标可以更改通信属性。 CPU出厂的缺省设置是通信口地址为2，波特率为9.6K。

    使用新的SMART（智能）RS-232/PPI电缆的用户，如果配合Micro/WIN32 V3.2 SP4以上版，可以将DIP开关5设置为“1”，选中通信界面的“Search all baudrate”（搜索所有波特率）选择框，可用于搜索网络上所有相关设备。

    对于普通编程电缆，搜索速率最高为19.2，因此如果CPU通信口速率被设置为187.5K，则不能被找到。

  5. 如果仍然不通，请检查CPU右下角的传感器直流电源输出电压（测量L+/M），电压应当高于22V

  6. 使用wipeout.exe程序，恢复CPU的出厂设置。缺省情况下CPU通信口地址为2，通信速率9.6K。

    这个程序可在STEP 7-Micro/WIN的安装光盘中找到；或者到ProDIS网站上FAQ2123168下载。

    使用智能RS-232/PPI电缆时，请将DIP开关5设置为0，通信速率设置为9600bps。USB/PPI电缆不支持DOS下的可执行文件wipeout.exe。

如果还不能通信，应考虑通信口硬件损坏的可能性。请联系西门子的代理商，也可以直接联系西门子的S7-200维修中心。

常问问题

在“Set PG/PC”通信属性时，COM口的符号前为什么会有一个星号“*”？

COM口前面的星号说明它被其他软件占用，Micro/WIN不能使用。

S7-200与上位机做编程通信时通信不上，报错信息为“硬件探测到校验错误”，什么原因？

请检查是否使用的是西门子原装编程电缆。


通讯－网络读写

系列视频：S7-200跟我学/跟我做

S7-200CN: PPI 网络架构-跟我学 - 157/185 http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=406

网络读写（NetR/NetW）- PPI通信

PPI协议是专门为S7-200开发的通信协议。S7-200 CPU的通信口（Port0、Port1）支持PPI通信协议，S7-200的一些通信模块也支持PPI协议。Micro/WIN与CPU进行编程通信也通过PPI协议。

S7-200 CPU的PPI网络通信是建立在RS-485网络的硬件基础上，因此其连接属性和需要的网络硬件设备是与其他RS-485网络一致的。

S7-200 CPU之间的PPI网络通信只需要两条简单的指令，它们是网络读（NetR）和网络写（NetW）指令。

在网络读写通信中，只有主站需要调用NetR/NetW指令，从站只需编程处理数据缓冲区（取用或准备数据）。

PPI网络上的所有站点都应当有各自不同的网络地址。否则通信不会正常进行。

可以用两种方法编程实现PPI网络读写通信：

  • 使用NetR/NetW指令，编程实现
  • 使用Micro/WIN中的Instruction Wizard（指令向导）中的NETR/NETW向导

NetR/NetW指令要点

有关网络读写（NetR/NetW）指令的详细情况必须参考《S7-200系统手册》。

每条网络读写指令最多能够读或者写16个字节的数据；每个CPU内最多只能有8条网络读写指令同时激活，而网络读写指令的数目没有限制。

只有通信主站能够使用网络读写指令。缺省情况下，S7-200 CPU的通信口设置为从站模式。因此在编程时，需要把通信口设置为通信主站模式。

在一个PPI网络中，与一个从站通信的主站的个数并没有限制，但是一个网络中主站的个数不能超过32个。主站既可以读写从站的数据，也可以读写主站的数据。也就是说，S7-200作为PPI主站时，仍然可以作为从站响应其他主站的数据请求。

一个主站CPU可以读写网络中任何其他CPU的数据。

由于串行通信的特点，通信数据的接收（或者发送）是不能与PLC程序的扫描周期配合的。所有的通信活动都需要PLC操作系统的管理，网络读写（包括其他类似的通信指令）指令只是告诉操作系统有需要处理的通信任务。因此，网络读写指令采取通信数据缓冲区的方式，在操作系统的通信管理功能与PLC的用户程序之间交换信息。

网络读写指令（NetR/NetW）的数据缓冲区类似。数据缓冲区除了状态字节和地址、数据长度之外，剩余的部分就是纯数据字节。能够传送到通信对象，或者从对象接收的仅仅是数据字节，不包括数据个数等信息。远程站（通信对象）的数据缓冲区则是纯数据区域。

网络读写指令可以传递V存储区、M存储区、I/Q区的数据。这取决于设定数据地址时，使用间接寻址方式将地址信息写入到缓冲区中的相应位置，地址信息中包括了存储区和数据的类型。

网络读写编程大致有如下几个步骤：

  1. 规划本地和远程通信站的数据缓冲区
  2. 写控制字SMB30（或SMB130）将通信口设置为PPI主站
  3. 装入远程站（通信对象）地址
  4. 装入远程站相应的数据缓冲区（无论是要读入的或者是写出的）地址
  5. 装入数据字节数
  6. 执行网络读写（NetR/NetW）指令

各CPU的通信口地址在各自项目的System Block（系统块）中设置，下载之后起作用。

调用NetR/NetW指令

多数网络读写的不正常现象，除了硬件设备和软件设置的问题外，与在用户程序中调用网络读写指令的方式有关。包括看起来通信正常，但经过一段时间（可能是几天）后也会出现故障的现象。

使用用NetR/NetW时，应当注意：

  • 避免简单地定时激活NetR/NetW：由于串行通信的特点（如上所述），无法得知何时真正结束。如果定时进行网络读写通信，必须判断此次通信是否正常结束
  • 同时有效的NetR/NetW指令不能超过8个，否则通信请求队列会超出操作系统的管理能力
  • 使用SM0.0调用网络读写指令，虽然能长期工作，但不能超过8个指令，而且会出现监控时指令块变为红色的现象，最好还是加上必要的读写状态判断条件。

最简单可靠的方法，是使用Micro/WIN中的NetR/NetW Wizard（网络读写指令向导）。

使用NetR/NetW向导可以编辑最多24条网络读写指令，其核心是使用顺序控制指令，这样在任一时刻只有一条NetR/NetW指令有效。如果要求超出24条网络读写指令，可以自己按照此方法编程。

清除网络读写指令数据缓冲区中的（故障）状态字节可以恢复“死掉”的通信。但还是建议用户采用比较正规的编程方法。

NetR/NetW（网络读写）指令向导


网络读写指令向导

系列视频：S7-200跟我学/跟我做

S7-200CN: PPI 使用通信向导-跟我学 - 158/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=407
S7-200CN: PPI 使用通信向导-跟我做 - 159/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=408

NETR/NETW Wizard - 网络读写指令向导

只有在PPI通信中做主站的CPU才需要用NETR/NETW向导编程。

在Micro/WIN中的命令菜单中选择Tools > Instruction Wizard，然后在指令向导窗口中选择NETR/ NETW指令：

图1. 选择NETR/NETW指令向导

在使用向导时必须先对项目进行编译，在随后弹出的对话框中选择“Yes” ，确认编译。如果已有的程序中存在错误，或者有尚未编完的指令，编译不能通过。

如果你的项目中已经存在一个NETR/ NETW的配置，你必须选择是编辑已经存在的NETR/ NETW的配置还是创建一个新的。

第一步 定义用户所需网络操作的数目

图2. 选择网络读写指令条数

向导允许用户最多配置24个网络操作，程序会自动调配这些通信操作。

第二步 定义通信口和子程序名。

图3. 选择通信端口，指定子程序名称

  1. 选择应用哪个通信口进行PPI通信：port0或port1

    注意：一旦定义选择了通信口，则向导中所有网络操作都将通过该口通信，即通过向导定义的网络操作，只能一直使用一个口与其它CPU进行通信。

  2. 向导为子程序定义了一个缺省名，你也可以修改这个缺省名。

第三步 定义网络操作

图4. 设定网络读写操作细节

每一个网络操作，你都要定义以下信息：

  1. 定义该网络操作是一个NETR 还是一个 NETW。
  2. 定义应该从远程PLC读取多少个数据字节(NETR)或者应该写到远程PLC多少个数据字节(NETW)

    每条网络读写指令最多可以发送或接收 16 个字节的数据

  3. 定义想要通信的远程PLC地址。
  4. 如果定义的是NETR（网络读）操作：
    定义读取的数据应该存在本地PLC的哪个地址区，有效的操作数为VB，IB，QB， MB，LB
    如果定义的是NETW（网络写）操作：
    定义要写入远程PLC的本地PLC数据地址区，有效的操作数为VB，IB，QB， MB， LB。
  5. 如果定义的是NETR（网络读）操作：
    定义应该从远程PLC的哪个地址区读取数据，有效的操作数为VB，IB，QB， MB， LB
    如果定义的是NETW（网络写）操作：
    定义在远程PLC中应该写入哪个地址区，有效的操作数为VB，IB，QB， MB， LB
  6. 操作此按钮可以删除当前定义的操作
  7. 操作此按钮可以进入下一步网络操作的定义

第四步 分配V存储区地址

图5. 分配数据区地址

配置的每一个网络操作需要12字节的V 区地址空间，上例中配置了两个网络操作，因此占用了24个字节的V 区地址空间。向导自动为用户提供了建议地址，用户也可以自己定义V 区地址空间的起始地址。

注意：要保证用户程序中已经占用的地址、及网络操作中读写区所占用的地址以及此处向导所占用的V 区地址空间不能重复使用，否则将导致程序不能正常工作。

第五步 生成子程序及符号表

图6. 生成子程序和符号表

上图显示了NETR/ NETW向导生成的子程序、符号表，一旦点击完成按钮，上述显示的内容将在你的项目中生成。

第六步 配置完NETR/ NETW向导，需要在程序中调用向导生成的NETR/ NETW参数化子程序

图7. 网络读写子程序

调用子程序：

图8. 调用子程序后生成下面的程序

  1. 必须用SM0.0来使能NETR/ NETW，以保证它的正常运行
  2. 超时：0=不启动延时检测；1-36767=以秒为单位的超时延时时间。如果通信有问题的时间超出此延时时间，则报错误
  3. 周期参数，此参数在每次所有网络操作完成时切换其开关量状态
  4. 此处是错误参数，0=无错误；1=错误

NetR/NetW指令向导生成的子程序管理所有的网络读写通信。用户不必再编其他程序进行诸如设置通信口的操作。

网络读写（NetR/NetW）指令


PROFIBUS-DP和EM277

PROFIBUS-DP通信和EM277模块

S7-200 CPU可以通过EM277 PROFIBUS-DP 从站模块连入PROFIBUS-DP网，主站可以通过EM277对S7-200 CPU进行读/写数据。

图1. S7-200 CPU通过EM277模块连接到PROFIBUS-DP网络

作为S7-200的扩展模块，EM277像其它I/O扩展模块一样，通过出厂时就带有的I/O总线与CPU相连。因M277只能作为从站，所以两个EM277之间不能通信。但可以由一台PC机作为主站，访问几个连网的EM277。

通过EM277模块进行的PROFIBUS-DP通信，是最可靠的通信方式。建议在与S7-300/400或其他系统通信时，尽量使用此种通信方式。

EM277是智能模块，其通信速率为自适应。在S7-200 CPU中不用做任何关于PROFIBUS-DP的配置和编程工作，只需对数据进行处理。PROFIBUS-DP的所有配置工作由主站完成，在主站中需配置从站地址及I/O配置。

在主站中完成的与EM277通信的I/O配置共有三种数据一致性类型，即字节、字、缓冲区。所谓数据的一致性，就是在PROFIBUS-DP传输数据时，数据的各个部分不会割裂开来传输，是保证同时更新的。即

  • 字节一致性保证字节作为整个单元传送。
  • 字一致性保证组成字的两个字节总是一起传送
  • 缓冲区一致性保证数据的整个缓冲区作为一个独立单元一起传送。如果数据值是双字或浮点数以及当一组值都与一种计算或项目有关时，也需要采用缓冲区一致性

EM277作为一个特殊的PROFIBUS-DP从站模块，其相关参数（包括上述的数据一致性）是以GSD（或GSE）文件的形式保存的。在主站中配置EM277，需要安装相关的GSD文件。

EM277的GSD文件可以在西门子的中文下载网站，或者ProDIS网站条目113652下载，文件名是EM277.ZIP。

EM 277 GSD 本地下载

如果需要在主站（如S7-300）中如何配置EM277的详细文档，可访问客户支持部网站上的“下载中心”网页，在“通信/网络”目录中下载《S7-200与S7-300之间的通信》 [image] 。

EM277模块同时支持PROFIBUS-DP和MPI两种协议。EM277模块经常发挥路由功能，使CPU支持这两种协议。EM277实际上是通信端口的扩展，这种扩展可以用于连接操作面板（HMI）等。

根据其物理位置的不同（模块连接到CPU的顺序），每个智能模块在S7-200 CPU中都有对应的特殊存储单元（SM）。EM277在工作时的状态信息就保存在这些特殊单元中，用户程序可以通过它们监视通信的状态等等。详情请参考《S7-200系统手册》。

RS-485网络连接
通过EM277的编程连接

EM 277 PROFIBUS-DP 模块LED指示灯含义

EM 277 PROFIBUS-DP模块在前面的面板上有四个状态LED，用来指示DP端口的运行状态：

  • S7-200上电后 ，DX MODE 灯一直熄灭直到DP通讯开始

  • 当DP的通讯成功地初始化后(EM 277 PROFIBUS-DP模块进入和主站交换数据的状态时)，DX MODE LED变绿直到数据交换状态结束

  • 如果DP通讯中断，强制EM 277模块退出数据交换模式，此时，DX MODE LED熄灭而DP ERROR LED变红。此状态一直保持到S7-200 CPU断电或数据交换重新开始

  • 如果主站写入EM 277模块的I/O组态或参数信息错误，则DP ERROR LED将呈红色闪烁

  • 如果没有24 VDC供电，POWER (电源) LED将熄灭

下表总结了EM 277模块上LED灯的各种状态。

LED | OFF | 红色 | 红色闪烁 | 绿色
CPU FAULT | 模块良好 | 内部模块故障 | —— | ——
POWER | 没有24V DC用户电源 | —— | —— | 24V DC用户电源良好
DP ERROR | 没有错误 | 脱离数据交换模式 | 参数化/组态错误 | ——
DX MODE | 不在数据交换模式 | —— | —— | 在数据交换模式

注意：当EM277 PORFIBUS-DP模块专门用作MPI从站时，只有绿色电源LED点亮。

常问问题

是否可以通过EM277模块控制变频器？

不可以。EM277是PROFIBUS-DP从站模块，不能做主站；而变频器需要接受主站的控制。

为什么重新设置EM277地址后不起作用？

对EM277重新设置地址后，需断电后重新上电才起作用。或者检查EM277地址拨码是否到位。

主站中对EM277的I/O配置的数据通信区已经到了最大，而仍不能满足需通信的数据量怎么办？

可以在传送的数据区中设置标志位，分时分批传送。

主站中与从站的通信数据区是如何一一对应的？

假设DP主站已定义了16入/16出的一种I/O配置，V区偏移量为2000，则其对应关系如下：

图2. 通过EM277在S7-200 CPU本地的输入/输出缓冲区分配

在主站上容易分辨输入/输入缓冲区，而通过EM277在S7-200 CPU的V存储区的映射，是本地的输入缓冲区（也就是主站的输出缓冲区）在前（地址低），输出缓冲区（主站的输入缓冲区）在后面（地址高）。

EM277所支持的通信速率和距离是多少？

电缆长度 | 所支持的通信速率
1200m> | 93.75k
1000m | 187.5k
400m | 500k
200m | 1M到1.5M
100m | 3M到12M

EM277的联网能力如何?

联网能力 | 数据
站地址设置 | 0-99(由旋钮开关设定)
每段最大站数 | 32
每个网络最大站数 | 126，最多99个EM277站
MPI连接 | 一共6个，2个保留（1个给PG，一个给OP）

一个网络上只能有最多99个EM277站，是因为其地址设置开关的限制。

S7-300或S7-400的PROFIBUS_DP主站最多可以有多少个EM277从站？

S7-300或S7-400的DP口或DP模板的能力有关，要根据它所支持的DP从站数而定。一个网上最多可以有99个EM277。


与S7-300的Profibus DP通信

系列视频：S7-200跟我学/跟我做:

S7-200CN: PROFIBUS通信效果演示-跟我学 - 173/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=422
S7-200CN: PROFIBUS通信效果演示-跟我做 - 174/185 | http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=423

S7-200和S7-300之间的PROFIBUS通信

S7-300与S7-200通过EM277进行PROFIBUS DP通讯，需要在STEP7中进行S7-300站组态，在S7-200系统中不需要对通讯进行组态和编程，只需要将要进行通讯的数据整理存放在V 存储区，并且S7-300组态EM277从站时设置正确的地址即可。
EM277的地址，在模块本身上的拨码设置分为X0（地址个位）和X10（地址十位）；EM277是波特率自适应的，取决于S7-300的组态。

配置步骤

首先，在STEP 7项目里插入一个S7-300的站：

图1 S7-300组态

选中STEP7的硬件组态窗口中的菜单 Option-install new GSD（GSD 文件下载：113652） ，导入SIEM089D.GSD文件，安装EM277从站配置文件，如下图：

图2 安装GSD

在SIMATIC文件夹中有EM277的GSD文件：

图3 安装GSD

导入GSD文件后，在右侧的设备选择列表中找到EM277从站，PROFIBUS DP-Additional Field Device-PLC-SIMATIC-EM277,并且根据通讯字节数，选择一种配置，本例选择8字节入/8字节出的方式，如下图：

图4 通信区域组态

确定S7-300硬件组态中所设置EM277的地址，如下图红框标注，为DP从站EM277的站地址。

图5 组态DP通信地址

组态完系统的硬件配置后，将编译下载到S7-300的PLC当中。
在S7-200侧断电的情况下，将EM277的拨位开关拨到与S7-300侧硬件组态的设定值一致。
在S7-200中编写程序将进行交换的数据存放在VB0－VB15，对应S7-300的PQB0-PQB7和PIB0-PIB7，打开 STEP7中的变量表和STEP7 MicroWin32的状态表进行监控，它们的数据交换结果如下图：

图6 通信数据监控

图7 通信数据监控

注意：VB0－VB7是S7－300写到S7－200的数据，VB8－VB15是S7－300从S7－200读取的值。EM277上拨位开 关的位置一定要和S7－300中组态的地址值一致。如果使用的S7-200通信区域不从VB0开始，则需要设置地址偏移，在S7-300硬件组态中双击 EM277，修改数值0为实际使用的数值即可，如下图所示：

图8 地址区域偏移设置

常问问题

DP通信所需要传输的数据超过64字节怎么办？

方法1：以64字节通信区为例，若超过最大配置。那么可以将通信区的第一个字节作为标志位，这样需要在S7-200中分时或条件判断，将数据放置或读取通信区域。同理，在S7-300中也需要判断标志位。
方法2:满足扩展要求的前提下，同一个200PLC可以扩展多个EM277，具体可以参考本文中最大I/O扩展能力的要求，那么在同一个S7-300的项目里可以组态多个PROFIBUS从站。
方法1可以增大通信的数据量，但由于通过标志位来分时分次传输的，所以通信数据的刷新会比方法2慢；方法2通过扩展DP从站或者200PLC的通信端口来实现数据扩展的，但增加了成本，且需要考虑是否满足扩展要求。


Simatic NET OPC 与S7-200/EM277的 S7连接

SIMATIC NET OPC Server与S7-200/EM277的 S7连接

完成一个项目的配置需要完成以下五个基本步骤

  1. 系统兼容性检查
  2. 配置PC Station
  3. 组态PC Station
  4. 下载PC Station
  5. 创建S7-200项目
  6. OPC SCOUT测试

1、系统兼容性检查

STEP7与Microsoft Windows操作系统的兼容性
参见链接：http://support.automation.siemens.com/CN/view/zh/8250891
SIMATIC NET与Microsoft Windows的兼容性
参见链接：http://support.automation.siemens.com/CN/view/zh/9859007
STEP7 Micro/Win与Microsoft Windows操作系统的兼容性
参见链接：http://support.automation.siemens.com/CN/view/zh/8675614
SIMATIC软件包同Microsoft Windows操作系统以及STEP7 V5.4兼容性
参见链接：http://support.automation.siemens.com/CN/view/zh/22645302

实验环境

操作系统 | Windows XP Professional SP2
软件 | SIMATIC NET PC Software V6.4
 | STEP7 Professional 2006 SR5 (V5.4+SP4)
 | STEP7-Micro/win V4.0Incl.SP6
硬件 | 订货号
CP5611 | 6GK1561-1AA01
CPU224XP | 6ES7214-2AD23-0XB0
EM277 | 6ES7277-0AA22-0AA0
Profibus 电缆 | 6XV1830-0EH10
DP连接器 | 6ES7972-0BB50-0XA0

2、配置PC Station

打开Station Configration Editor，分别在第一插槽插入OPC Server，第三槽插入 CP5611卡，如图1

图1.为PC Station添加组件设置Station Name

配置PC Station组件CP5611 PROFIBUS参数，如图2

图2.设置CP5611站地址和传输速率

更改Station Name，本例中取名为S7con，如图1。

3、组态 PC Station

新建一个项目，通过 Insert >Station >Simatic PC Station 插入一个PC 站，注意站名要更改成Station Configuration Editor 中所命名的Station Name ，即命名为“S7con”，如图3

图3.创建新项目

打开硬件组态窗口，组态与所安装的SIMATIC NET 软件版本相一致的硬件，插槽结构与在Station Configuration Editor组态的PC 站一致，编译并保存，如图4

图4.在HW Config中组态PC Station

打开NetPro，在OPC Server的连接表的第一行右键选择“Insert New Connection”或Insert >New Connection插入个新的连接，如图5

图5.组态S7连接

为OPC Server定义新连接，连接伙伴选择“Unspecified”，连接类型选择“S7 connection”，如图6

图6.插入新连接

点击“Apply”编辑连接属性，“Partner”地址填写通讯方EM277的地址，如图7

图7.设置站地址

生成的连接名称可更改，地址详情如图8

图8.设置TSAP

注意Partner侧TSAP号03.00不能更改，但EM277可在任意槽位
点击“OK”退出至NetPro窗口，生成连接 S7 connection_1，点击“Save and Compile”编译并保存，如图9

图9.查看新插入的S7连接

4、下载PC Station

打开控制面板，打开“Set PG/PC Interface”窗口，选择“PC internal(local)”,如图10

图10.设置下载通信接口

保存编译无误后，如图11所示的图标会有黄色箭头标识，将正确组态信息下载到PC Station中，如图12

图11.出现黄色箭头

图12.下载进度条

下载完毕后，查看Station Configuration Editor的正确状态，如图13，可以看到图1中紫色标识中的红色“X”已去除

图13.下载完成后PC Station状态

5、生成S7-200项目

打开STEP7-Micro/win软件，生成S7-200项目，双击“通讯”功能图标，配置Micro/win与S7-200CPU的连接 ，如图14

图14.设置与S7-200的通信接口

点击“设置PG/PC接口”设定通讯参数，如图15选择“CP5611(PROFIBUS)”方式，通过EM277访问200CPU, 该接口参数分配方式不影响OPC Server与S7-200的通讯功能

图15.选择接口

点击“Properties”核对网络参数如图16，点击“OK”返回图15

图16.属性选择

双击“刷新”搜索200CPU节点地址，选中该节点，地址栏中的远程地址更改为EM277 地址“4”如图17，点击“OK”退出，通讯配置完成

图17.扫描S7-200站地址

6、OPC Scout测试通讯

打开Start >Simatic > Simatic Net >OPC Scout，点击“OPC.Simatic.NET”，添加一个组，为此组取名为cpu224，如图18、图19

图18.选择OPC服务器

图19.添加Goup

双击生成的连接组“cpu224”打开OPC-Navigator，选择“S7”协议，自动显示已组态的S7 connection_1，点击“objects”显示所有通讯数据区，以I/M/Q/DB为例创建通讯数据，如下图20，图21，图22点击“→”将条目移送到右侧窗口，点击“OK”，如通讯正常，则在如图24 中“Quality”一栏中显示为“good”

图20.定义I区变量

图21.定义Q区变量

图22.定义V区变量

注意：DB数据即为200CPU的数据区V区，通讯所能配置的数据区域为：I、M、Q、DB

在200CPU侧对V变量赋值如图23，VB200和VB0

图23.状态监视

在OPC Scout中对应DB变量接受无误，如图24,DB1.DBB200和DB1.DBB0

图24.OPC Scout监视

在OPC Scout中对Q变量赋值，如图25,QB3

图25.OPC Scout中修改QB3

200CPU中对应Q变量接受无误，如图26,QB3

图26. S7-200监视QB3

总结：
例程中的注意事项可参考每一步骤中的红色字体部分。通讯格式为OPCServer与S7-300/400，所以在设置通讯数据长度时虽然没有字节数目的限定，但要注意不要超过200CPU所允许的范围，如M变量为MB0~MB31,不能建立通讯数据MD30。本例是以一个200CPU与CP5611建一个连接为例，仅为说明其通讯功能的可行性，不能作为配置方案，如果OPC Server建多于8个与EM277的连接，则需要考虑到CP5611的连接资源问题，可以考虑CP5613。


EM277 与 SIMATIC NET OPC Server 进行 S7 通信

硬件：
①CPU226 CN 以及 EM277 模块
②PC 机 ( PCI-E插槽)
③CP 5624卡
软件：
① STEP 7-Micro/WIN V4.0 sp9
② STEP 7 Professional（TIA Portal V13 SP1 Upd 9）
③ SIMATIC NET V13 SP2
④ 操作系统 Windows 7 Professional 64位 SP1

在 TIA Portal 平台中配置 PC station

1. 使用 TIA V13 SP1 Upd 9 软件 Portal 视图中，创建新项目

2. 添加 PC 系统并命名设备名称

进入 “项目视图”，在“项目树” 下双击 “添加新设备”，在对话框中选择 PC 系统>常规 PC，命名为 PC station 如图1 所示

图1. 添加新设备

3. 添加 OPC服务器及 CP 5624 卡

进入设备视图>硬件目录>用户应用程序> OPC 服务器，双击，添加 OPC服务器；

进入设备视图>硬件目录>通信模块> PROFIBUS> CP5624，找到相应的 CP 卡双击，添加 CP 5624 卡 ，结果如图2 所示

图2.添加OPC服务器及CP5624

4. 为 CP 5624 卡通信口分配 DP 地址

在 “设备视图”中点击 CP5624 上代表 PRIBUS 通信口的紫色方块，在下方会出现 PROFIBUS 接口的属性，在 “PROFIBUS 地址” 下，点击“添加新子网”，建立 PRFIBUS_1 网络；分配 CP5624 的接口类型为 PROFIBUS ；地址设置为 3 ，如图3 所示

图3. 添加子网并分配 DP 地址

5.在网络视图中，点击代表 PROFIUBS_1 网络的紫色实线，属性>常规>网络设置，可以设置传输率，此处设定传输率为 1.5 Mbps，如图4所示。

图4. 设置传输率

6.建立 S7 连接并且设置连接参数

打开网络视图，点击连接，选择S7链接，默认连接为HMI连接，需要修改；点击 OPC server ,右键添加新连接；创建新连接对话框选择未指定，本地接口选择 CP5624，点击添加；

属性>常规>常规，伙伴站点及接口设置为未知；伙伴地址设置为 4（为 EM 277 的地址）；

属性>常规>地址详细信息，伙伴 TSAP 设置为 03.00 。

设置步骤如图5 所示。

图5. 建立 S7连接及参数配置

7.生成 XDB 组态文件

网络视图中，点击 PC station 站点，属性> XDB 组态，勾选 “生成 XDB 文件” 然后将项目进行编译。如图6所示。

图6.生成XDB文件

Station Configuration Editor中导入 XDB 组态文件

在计算机“开始”菜单中 ，搜索，输入关键字 Station Configuration ,双击找到的软件，打开;

在打开的 Station Configuration Editor 中点击 “Import Station”，选择XDB存储路径导入

导入过程及结果如图7所示。

图7.导入XDB文件

S7-200 侧设置 EM277 的地址

1、EM277 不需要从软件里进行组态，将EM277本体自带的扁平电缆与前面模块的扩展插槽直接连接，给EM277 供电。

2、设置 EM277 模块地址为4，设置完需要断电重启，如图8 所示。

图8.设置 EM 277 地址

3、使用 DP总线和 DP 总线连接器连接 EM 277 的 RS485口 和电脑上安装的 CP5624 的 RS 485 口， EM 277 模块波特率自适应，不用单独设定。

使用 OPC SCOUT 测试

在计算机“开始”菜单中，搜索 SIMATIC NET 的 OPC Scout V10 ，双击打开，建立变量：MB10，MB11 ，MD20， MD24 ，MD28。

打开STEP 7-MicroWIN ，在状态图表中赋值。

如图9所示

图9.通信结果

常见问题

如何理解建立的变量的起始地址，数据类型及个数

以建立M区变量为例说明，如图10所示

图.10 建立变量举例

S7-200 SMART 要交换V区数据，OPC scout 中无法添加 DB 块的变量怎么办？

S7-200 SMART 要通信 V 区数据，需要在 OPC SCOUT 中建立 DB1 的数据

如果在OPC Scout 中无法建立 DB 块数据，可以先插入M变量，然后进行修改，修改方法如图11：

图.11 无法建立DB使用M区修改

注意！OPC scout 如果无法建立DB块变量，在M区修改以后也只能用于测试 S7 通信是否成功，在客户端需要单独建立变量


COML_S7

通过COML S7方式建立SIMATIC NET OPC服务器与PLC的连接

通常，SIMATIC NET作为OPC服务器建立与S7-200等CPU的连接，是通过在经典STEP7或TIA博图STEP7建立PC站，然后在网络视图建立连接来实现。

但是，如果电脑中安装了CP板卡，并且安装的电脑操作系统以及SIMATIC NET版本的不合适（如图1所示），就会使得在站组态编辑器中看不到该板卡，而导致无法使用上述方法。

图1 CP卡、电脑操作系统的兼容性列表

以最常见的CP5611 A2为例，当操作系统为WIN7 64位，安装的SIMATIC NET版本为V12以上，就会出现站组态编辑器中看不到CP5611 A2的情况，出现这种情况只能使用下面的方法来组态。

注：建议组态之前检查电脑操作系统、STEP 7、WinCC、SIMATIC NET等的兼容性，以免出现不可预知的状况，兼容性参见链接。

本例程软件环境：

PC1：

操作系统：WIN10 pro 1607 64位英文版

CP卡：CP5621

SIMATIC NET 版本：V14

TIA博图 STEP7：V14SP1 UPD2

PC2：

操作系统：WIN7 SP1 64位英文版

CP卡：CP5611

SIMATIC NET 版本：V8.1 SP1

NCM manager：V5.5 SP2

注：之所以出现2个测试环境是因为从SIMATIC NET V8.2开始，"Configuration Console"（组态控制台）变为了"Communication Settings"（通信设置），设置页面发生了变化。

本例程硬件环境：

CP224XP + EM277，将CPU224XP端口0，通过DP线连接CP卡，并如图2所示，将波特率设置为187.5kbps，地址为2。此外，也可以将CP卡连接EM277。

图2 通信端口波特率设置

S7-200编程电缆：USB-PPI（6ES7901-3DB30-0XA0）

PC1组态过程

1. 打开电脑的控制面板，找到"Communication Settings"，如图3所示，并打开该软件。

图3 打开"Communication Settings"

2. 修改CP卡PROFIBUS配置（注意此处CP5621被识别为CP5611，没有关系），如图4所示。

图4 修改CP卡PROFIBUS配置

①点击“模块>CP5611>CP5611.PROFIBUS.1>地址”

②勾选“PG/PC是总线上的唯一主站”

③选择传输速度为187.5Kbps

注：因为CP卡连接的是PLC端口0，而PLC端口0设置187.5Kbps，所以如此设置。如果CP卡连接的是EM277，则波特率可以任意设置。

④点击“应用”按钮。

3. 打开电脑的控制面板，找到"Set PG/PC Interface(32-bit)"，如图5所示，并打开该软件。

图5 打开"Set PG/PC Interface(32-bit)"

4. 访问点选择CP5611.PROFIBUS.1，如图6所示。

图6 访问点选择

5. "Communication Settings"中更新总线节点测试，如图7所示。

图7 总线节点测试

①点击“模块>CP5611>总线节点”

②点击“更新”按钮

③显示的是CP卡为激活状态

④显示的是PLC为被动状态，说明网络正常

6. 建立COML S7连接，如图8所示。

图8 COML S7设置

①点击“模块>CP5611>COML S7”

②点击该按钮“插入”

③接口选择“S7-300/400”

④地址输入“2”，为所连接的PLC端口或者EM277地址

其他使用默认设置

⑤点击“应用”按钮

7.激活COML S7列表，如图9所示。

图9 激活COML S7列表

①点击“模块”

②点击该按钮“启用该COML S7连接列表”

③在弹出对话框选择“是”

最后关闭"Communication Settings"。

8. OPC SCOUT V10测试，如图10所示。

图10 OPC SCOUT V10测试

PC2组态过程

1. 如图5方式打开"Set PG/PC Interface(32-bit)"，访问点选择CP5611.PROFIBUS.1，并修改波特率，如图11所示。

图11 设访问点及波特率

①选择“CP5611.PROFIBUS.1”

②点击该按钮“Properties”（属性）

③激活“PG/PC is the only master on the bus”（PG/PC是总线上的唯一主站）

④选择传输速度为187.5Kbps

注：因为CP卡连接的是PLC端口0，而PLC端口0设置187.5Kbps，所以如此设置。如果CP卡连接的是EM277，则波特率可以任意设置。

2. 打开电脑开始菜单，从“所有程序>Siemens Automation>SIMATIC>SIMATIC NET”中找到"Configuration Console"，如图12所示，并打开。

图12 打开"Configuration Console"

3. 建立COML S7连接，如图13所示。

图13 COML S7设置

①点击“PC Station>SIMATIC NET Configuration>Modules>CP5611>COML S7”

②点击该按钮“Insert”（插入）

③弹出页面，接口选择“S7 CPU”

④地址输入“2”，为所连接的PLC端口或者EM277地址

其他使用默认设置

⑤点击“OK”按钮

4. 应用该连接，如图14所示。

图14 应用COML S7设置

①点击“PC Station>SIMATIC NET Configuration>Modules>CP5611>COML S7”

②点击该按钮“Apply”（应用）

③弹出页面，点击“OK”按钮

5. 激活COML S7列表，如图15所示。

图15 激活COML S7列表

①右键选择“PC Station>SIMATIC NET Configuration>Modules”，在弹出菜单点击“Enable COML S7 connection lists..”（启用该COML S7连接列表）

②在弹出对话框点击“Yes”按钮

最后关闭"Configuration Console"。

6. OPC SCOUT V10测试，如图16所示。

图16 OPC SCOUT V10测试

常见问题

1. PC站的方式能否和COML S7的方式共存？

答：不能。

1）当已经配置了COML S7方式，再在组态站组态编辑器时，会出现如图17和图18的提示。

图17 已配置COML S7，点击站组态编辑器的"Add"按钮

图18 已配置COML S7，点击站组态编辑器的"Import Station.."按钮

2)当已配置PC站方式，再配置COML S7时，会出现如图19的提示。

图19 配置COML S7报错


MPI通讯

MPI通信

MPI (Multipoint interface)是SIMATIC S7多点通信的接口，是一种适用于少数站点间通信的网络，多用于连接上位机和少量PLC之间近距离通信。

通过PROFIBUS电缆和接头，将控制器S7-300或S7-400的CPU自带的MPI编程口及S7-200CPU 自带的PPI通信口相互连接，以及与上位机网卡的编程口（MPI/DP 口）通过PROFIBUS或MPI电缆连接即可实现。 网络中当然也可以不包括PC机而只包括PLC。

MPI的通信速率为19.2K～12Mbit/s ，但直接连接S7-200CPU通信口的MPI网，其最高速率通常为187.5Kbit/s （受S7-200CPU最高通信速率的限制）。

在MPI网络上最多可以有32个站，一个网段的最长通信距离为50米（通信波特率为187.5Kbit/s时），更长的通信距离可以通过RS-485中继器扩展。

MPI允许主－主通信和主－从通信，每个S7-200CPU通信口的连接数为4个。

MPI协议不能与一个作为PPI主站的S7-200CPU通信，即S7-300或S7-400与S7-200通信时必须保证这个S7-200 CPU不能再作PPI主站，Micro/WIN也不能通过MPI协议访问作为PPI主站的S7-200CPU。

S7-200CPU只能做MPI从站，即S7-200CPU之间不能通过MPI网络互相通信，只能通过PPI方式互相通信。

图1. 一个MPI网络例子

如上图STEP 7-Micro/WIN可以与S7-200CPU建立MPI主－从连接。硬件使用CP5611卡加上PROFIBUS或MPI电缆，S7-200 CPU通信口上要使用带编程口的网络连接器。S7-200CPU的通信口最低通信速率可设为19.2K，最高187.5K。

注：CP5613不能通过MPI方式与S7-200 CPU通信口进行编程通信。

S7-300和S7-400 CPU可以作为MPI主站用XGET（SFC67）和XPUT（SFC68）指令读取S7-200数据，S7-300的通信数据包最大为76个字节,S7-400的通信数据包最大为84个字节。S7200 CPU中不需要编写任何与通信有关的程序，只需要将要交换的数据整理到一个连续的V 存储区当中即可。

如果需要在主站中（如S7-300）如何配置S7200 CPU MPI从站的详细文档，可访问客户支持部网站上的“下载中心”网页，在“通信/网络"目录中下载《S7-200与S7-300之间的通信》 [image] 。


Online - Certificates

S7-200和S7-300之间的MPI通信

S7-200 PLC与S7-300 PLC之间采用MPI通讯方式时，S7-200 PLC中不需要编写任何与通讯有关的程序，只需要将要交换的数据整理到一个连续的V 存储区当中即可，而S7-300 PLC中需要在组织块OB1（或是定时中断组织块OB35）当中调用系统功能X_GET（SFC67）和X_PUT(SFC68)，以实现S7-200 PLC与S7-300 PLC之间的通讯。调用SFC67和SFC68时VAR_ADDR参数填写S7-200的数据地址区，由于S7-200的数据区为v区，这里需填写 P#DB1.DBX×× BYTE n 对应的就是S7200 V存储区当中VB××到VB（××＋n）的数据区。例如交换的数据存在S7-200中VB50到VB59这10个字节当中，VAR_ADDR参数应为 P#DB1.DBX50.0 BYTE 10.
首先根据S7-300的硬件配置，在STEP7当中组态S7-300站并且下载，注意S7-200和S7-300出厂默认的MPI地址都是2，所以必须修改其中一个PLC的站地址，例子程序当中将S7-300 MPI地址设定为2，S7-200地址设定3，另外要分别将S7-300和S7-200的通讯速率设定一致，可设为9.6K，19.2K，187.5K三 种波特率，例子程序当中选用了19.2K的速率。

S7-200 PLC中通过系统块定义自身的MPI地址和波特率，参考下图：

图1 S7-200 设置MPI地址

S7-300 PLC修改MPI地址可以参考下图：

图2 S7-300 设置MPI地址

例子程序在OB1当中调用数据读写功能块：SFC67和SFC68，如下图：

图3 程序编写

分别在STEP7 MicroWin32 和STEP7当中监视S7-200和S7-300 PLC当中的数据，数据监视界面如下：

图4 S7-200监控结果

图5 S7-300监控结果

通过CP5611，STEP7 MicroWin32， Set PG/PC Interface可以读取S7200和S7300的站地址，如下图：

图6 CP5611诊断结果（站地址0为进行编程的计算机）

图7 使用STEP7 MicroWin32诊断结果

注意事项

1 虽然MPI的波特率可以达到12M，但是受到S7-200通信能力的限制，所以可设为9.6K，19.2K，187.5K三 种波特率。
2 如果PPI或者MPI的通信距离超过50m，需要加中继器；如果中继器之间没有任何站点的情况下，最远距离可为1000米。
3 MPI不能与作为PPI主站的S7-200PLC通信。


以太网通讯

S7-200的以太网通信 - CP243-1模块

S7-200系统拥有一种智能模块CP243-1，它是以太网通信处理器，可用它将S7-200系统连接到工业以太网（IE）中。

显然也可以将S7-200连接到建筑物的内部以太网体系中。

一台S7-200可以通过CP243-1以太网模块与其它S7-200、S7-300或S7-400控制器进行通信。也可以通过工业以太网和STEP 7-Micro/WIN，实现S7-200系统的远程编程、配置和诊断。CP243-1以太网模块还可提供与S7-OPC的连接。CP243-1既可以作为客户机（Client），也可以作为服务器（Server）。

一个CP243-1可同时与最多8个以太网S7控制器通信，即建立8个S7连接。除此之外，还可以同时支持一个STEP 7-Micro/WIN的编程连接。 一个客户端（Client）可以包含1－32个数据传输操作，一个读写操作最多可以传输212个字节。如果CP243-1作为服务器运行，每个读操作可以传送222个字节。

像S7-300/400系统中的CP343-1和CP443-1一样，S7-200也提供两种以太网模块，它们是CP243-1和CP243-1 IT。CP243-1 IT除了具有CP243-1的 功能外，还支持一些IT功能，如FTP（文件传送）、E-mail、HTML网页等。

CP243-1和CP243-1 IT还各自有其详细的手册。

硬件连接

象S7-200其它扩展模块一样，CP243-1以太网模块通过总线电缆，即可与S7-200简单地连接起来。CP243-1上带有一个RJ45口，可实现通过RJ45的以太网网络连接。

网络配置必须遵守以下条件：

  • 二个（光通信）模块之间的纤维光缆最大长度：3000米，多模光纤
  • 二个模块OSM ITP 62-LD模块之间的纤维光缆的最大长度：26km，单模光纤
  • 二个模块之间或站之间ITP电缆的最大长度：100m
  • TP软线的最大长度：10m；与RJ45引出插座和FC TP电缆（快装双绞电缆）一起使用，最大长度为100m

注意：一个S7-200CPU只能连接一个CP243-1扩展模块。CP243-1模块不能直接连接光缆，必须通过其他模块转换；CP243-1通过RJ45引出插座可以连接FC TP电缆。

编程配置

使用STEP 7-Micro/WIN中的Ethernet Wizard（以太网向导）对其进行编程配置。

如需要详细的《CP243-1快速入门》 [image] 文档，可访问客户支持部网站上的“下载中心”网页，在“通信/网络”目录中下载；有关S7-200和S7-300通过以太网通信的配置步骤，可参考同一目录下的《S7-200与S7-300之间的通信》 [image] 一文。

参考链接

通过以太网编程
通过以太网的 PC Access 通信

《CP243-1 快速入门 （含视频）》下载地址：http://support.automation.siemens.com/CN/view/zh/78393831

常问问题

为什么其它厂家的CPU也支持以太网TCP/IP协议，却不能与西门子的CPU用以太网通信？

一个开放式系统互连是建立在7个协议层上的：应用层、表示层、会话层、传输层、网络层、数据链路层、物理层。一般地，网络中的指定通信任务是由三个类型之间的协议分配负责完成的：应用协议、传输协议和网络协议。

TCP/IP协议中，TCP属于传输协议，IP属于网络协议；而在应用层协议中，西门子使用的是S7协议。其它厂家的CPU虽然能接收到西门子CPU的数据包，却读不懂S7协议的内容，反之亦然。

西门子的以太网模块只允许在西门子的产品间进行工业以太网通信。对于PC机上位监控软件可以安装西门子SIMATIC NET 软件（或PC Access [image] ）后通过OPC SEVER 实现以太网访问。

CP243-1支持TCP/IP意味着它可以在TCP/IP兼容的网络上使用，与其他支持TCP/IP的通信节点共存。例如，一个办公网络中也可以连接西门子的PLC。

CP243-1能否与光纤连接？

CP243-1上只有一个RJ45口，没有BFOC口，不能与光纤电缆直接连接。但可以用一个OMC（单点）模块或OSM（多点）模块来将RJ45口的连接转换成光纤连接。

CP243-1是否能够连接无线以太网？

通过无线交换机等网络设备，CP243-1可以连接无线以太网。

如何配置CP243-1 以太网通信模板连接西门子触摸屏？

配置步骤请参考以下链接：

https://support.industry.siemens.com/cs/cn/zh/view/19724696

一套S7-200系统中最多可以使用几个CP 243-1以太网通信模块？

最多使用1个 CP243-1 以太网通信模块。

如何分配工业以太网 FC 电缆的各导线到 IE FC RJ45 插头的针脚?

请您参考下面链接对应的常问问题：
https://support.industry.siemens.com/cs/cn/zh/view/23067477


以太网编程

在用户程序中修改CP243-1的IP地址

通过程序实现CP243-1IP地址的修改，需要按照如下步骤进行操作：
  1. 打开已配置的以太网向导，双击“CRC保护”。

    1
    图1.打开已配置的以太网向导

  2. 选择“否，请勿为此配置生成CRC保护”，点击“下一步”。

    2
    图2.不生成CRC保护

  3. 以太网向导生成的项目组件将包括子程序“ETHx_CFG”，点击“完成”。

    3
    图3.生成子程序“ETHx_CFG”

  4. 点击数据块，找到以太网向导生成的数据页“ETHx_DATA”,找到存放CP243-1 IP地址信息的数据区，记住其地址。

    4
    图4.存放CP243-1 IP地址信息的数据区

  5. 在程序中有条件调用“ETHx_CFG”，实现CP243-1的IP地址的修改。

    5
    图5.在程序中调用ETHx_CFG修改CP243-1组态

  6. 将程序块，数据块下载到CPU中。在状态表中对存储CP243-1IP地址信息的V区地址进行赋值，IP地址、子网掩码和默认网关地址按照16进制格式进行输入，可参考如下实例：
    例如：IP地址为 192.168.70.206，子网掩码为255.255.255.0, 默认网关为192.168.70.1
    则VD1000=16#C0A846CE，VD1004=16#FFFFFF00，VD1008=16#C0A84601

    6
    图6.在状态表中修改IP地址信息
    修改完毕后将M20.0置1，使能ETH0_CFG指令修改CP243-1的组态。

    注意：
    只有当存储CP243-1组态信息的数据区中包含有效数据时才能够触发ETHx_CFG指令，否则可能导致错误的组态数据被传送到CPU，导致CP243-1出现故障。

  7. 检查IP地址是否设置成功。通过以太网电缆将CP243-1连接至PG/PC的以太网接口，点击“开始”按钮，在搜索框中输入“cmd”，打开命令行编辑器。
    输入以下指令：ping <CP243-1的IP地址>，例如：ping 192.168.70.206,回车，如果出现以下界面说明CP243-1的IP地址设置成功。

    7
    图7.检查IP地址是否设置成功
注意：
如 果 CRC 功能已经关闭，系统只能通过 S7-200 用户程序对系统进行组态。 由于 CRC 校验关闭后的有意和无意修改，CP243-1 不能完全检查组态数据的一致性，因此不能保证这种情况下连接到网络中的 CP 或组件能够正常运行。由此造成的风险由客户自己承担。


以太网使用常见问题

1.CP243-1 SF红灯闪烁

新模块，第一次使用
1、 给CP243-1供电
2、 扁平电缆连接在前一个模块的扩展插槽上
3、 程序做向导配置，下载到CPU中
4、 断电重启
5、CP243-1的配置存储在CPU中，并不是在CP243-1中

以前一直正常，突然不正常（比如断电重启后突然不正常）
1、 打开编程软件，PLC，信息，观察是否有CP243-1，如果没有，总线有问题，更换模块测试；如果有，检查向导配置
2、 向导配置注意2点：模块位置要自动读取，读取后双击读出的模块，通过控制命令字节QB是否是灰色的检查是否自动读取成功;V区分配地址不能与其他地方使用的v区重叠

2.S7-200最多可以扩展几个CP243-1 ? 安装位置是否有要求?

1、S7-200，一个CPU只能扩展一个CP243-1模块
2、CP 243-1 在S7-200 系统中的运行位置，取决于S7-200 CPU 的固件版本。
版本1.20 或以上，可以安装在S7-200 系统中任意一个位置
版本1.20 以下，必须安装在位置 0，除非在位置 0 安装有其它智能模板，此时可安装在位置 1。

3.CP243-1是否可以连接多少个HMI？

西门子的可以和CP243-1通信的，只能连接一个
第三方的hmi，是否可以通信，可以通信连接几个，需要咨询第三方hmi厂家
CP243-1的通信资源：1个编程资源（PG）+8个S7（S7为西门子内部协议并非开放式的协议，不支持TCP、 UDP、 ISO ON TCP）

4.和第三方HMI通信，使用以太网线监控不了程序？

可以进行测试：保证CP243-1只和第三方HMI连接，观察CP243-1的指示灯CFG是否黄色常亮或者闪烁，如果是，说明第三方HMI通信占用CP243-1的编程资源
或者测试：断开CP243-1与第三方HMI连接线缆，将带有编程软件的电脑直接连接到CP243-1的以太网口，断电从新上电，与CP243-1连接测试

5.CP243-1和工控机如何通信?

在工控机上加OPC软件，SIMATIC NET或者 Pc Access
OPC软件和CP243-1 进行S7通信，OPC软件和组态软件进行OPC通信，保证组态软件支持OPC通信
使用第三方组态软件自带驱动，有可能占用CP243-1的编程资源，CP243-1仅有一个编程资源


CP243-1作为客户端与S7-300的以太网通信

S7-200和S7-300的以太网通信

S7-200 PLC本体没有以太网口，需要通过以太网模块CP243-1来扩展以太网通信，且一个S7-200PLC只能扩展一个CP243-1。CP243-1不是即插即用模块，需要通过其他方式对S7-200下载一个包含以太网向导的项目文件才可以使用。
通过以太网向导，最多8个以太网S7控制器通信，每个连接既可以是服务器连接也可以是客户机连接。除此之外，CP243-1还可以同时支持一个STEP 7-Micro/WIN的编程连接。
一个客户端（Client）可以包含1－32个数据传输操作，一个读写操作最多可以传输212个字节。如果CP243-1作为服务器运行，每个读操作可以传送222个字节。

S7-200 可以通过 CP243-1 作为服务器端和客户端建立 S7 连接，这意味着以下可能:
1. 在 S7-200 中配置一个客户端，因此S7-200将主动激活与远程服务器的 S7 连接。
2. 在S7-200中配置服务器连接，因此S7-200可被动的响应建立好的S7连接，远程的客户端将与S7-200建立连接，S7-200作为服务器提供数据。

系列视频：S7-200跟我学/跟我做

S7-200CN: 使用向导配置客户机-跟我学 - 178/185：http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=427

S7-200CN: 使用向导配置客户机-跟我做 - 179/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=428

S7-200CN: 客户机程序的编写-跟我学 - 182/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=431

S7-200CN: 客户机程序的编写-跟我做 - 183/185: http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=432

S7-200作为客户机

可以把S7-200的以太网模块CP243-1配置为CLIENT，使用STEP 7 Micro/WIN中的向导进行通信的配置即可。在命令菜单中选择工具--以太网向导。

图1 打开以太网向导
第一步是对以太网通信的描述，点击下一步开始以太网配置。

图2 向导介绍
在此处选择模块的位置，CPU后的第一个模块位置为0，往后依次类推；或者在线的情况下，点击读取模块搜寻CP243-1模块（在线读取将该模块的命令字节载入模块命令字节向导屏幕）。点击下一步；

图3 读取模块
选择模块相匹配的MLFB版本，本例中的CP243-1模块型号为6GK7243-1EX01-0XE0，如下图所示：

图4 模块版本选择
在此处填写IP地址和子网掩码。点击下一步；

图5 地址设置
下面的对话框将组态CP243-1进行S7连接的连接数量的设置，通过S7连接可以与通信伙伴进行读写数据操作。点击“下一步”按钮继续进行S7连接组态。

图6 模块占用地址设置
选择此为客户机连接，远程属性TSAP （Transport Service Access Point）填写为03.02，输入S7-300侧的IP地址。点击数据传输按钮进入数据交换的定义。
注意：如果连接远程对象是 S7-300，TSAP为03.02；如果连接远程对象是 S7-400，TSAP为03.0x，其中x为CPU模块的槽位，可以从S7-400 站的硬件组态中找出PLC的槽号。

图7 连接设置
选择"数据传输"标记，并单击"新传输"按钮，进行配置：选择是读取数据还是写入数据，填写通讯数据的字节个数，填写发送数据区和接收数据区的起始地址。
本例中为从S7-300的MB200开始读取8个字节到VB1000开始的8个字节的区域中；从S7-200的VB2000开始的8个字节写到S7-300的QB0开始的8个字节的区域中，点击确认按钮：
注意： 本地PLC中的地址必须是V内存字节地址，远程对象中的地址必须代表字节地址。当您为S7-300/ S7-400设备输入远程地址时，若是数据块请使用DBx.DBBy格式。

图8 数据区域设置
选择CRC校验,使用缺省的时间间隔30秒,点击下一步按钮。

图9 使用CRC
填写模块所占用的V存储区的起始地址。你也可以通过“建议地址”按钮来获得系统建议的V存储区的起始地址, 点击下一步按钮。

图10 配置存储区

S7-200 CPU 编程通信

完成以太网向导配置后需要在程序中调用以太网向导所生成的ETHx_CTRL和ETH0_XFR, 然后，将整个项目下载到作客户端的S7-200 CPU上。
1. 调用向导生成的子程序，实现数据传输
对于S7-200的同一个连接的多个数据传输，不能同时激活，必须分时调用。下面的程序就是用前一个数据传输的完成位去激活下一个数据传输，如图11.图12.图13. 所示

图11 S7-200程序段1

图12 S7-200程序段2

图13 S7-200程序段3

如果通信未建立成功，可以对应查询子程序的错误代码。


Online - Certificates

CP243-1 作为服务器端和S7-300/S7-400建立S7连接

本文讲解一个实际的通信案例，S7-200组态为服务器端进行S7通讯，S7-300和S7-400将主动建立与S7-200的S7连接，S7-200将被动响应建立好的S7连接：
本例中, S7-200，S7-300 和 S7-400 各自用一个CPU 和一个通讯模板，其中CP243-1组态的第三、四个连接分别为服务器连接，与S7-300、S7-400进行S7通讯。具体操作步骤如下：

  1. 项目硬件组态和定义通信数据区
  2. 组态S7-200为服务器
  3. 组态S7-300/400为客户端进行S7通讯
  4. STEP7编写PUT/GET程序

1、项目硬件组态和定义通信数据区

本例中使用的硬件配置如下:

网络组态概览图如下：

在本例中, S7-200, S7-300 和 S7-400的下列区域定义为发送和接收缓冲区：

2、组态S7-200为服务器

通过以太网向导将以太网模块CP243-1配置为服务器，使用STEP 7 Micro/WIN中的向导进行通信的配置即可。在命令菜单中选择工具--以太网向导。

第一步是对以太网通信的描述，点击下一步开始以太网配置。

在此处选择模块的位置，CPU后的第一个模块位置为0，往后依次类推；或者点击读取模块搜寻在线的CP243-1模块（且将该模块的命令字节载入模块命令字节向导屏幕）。点击下一步；

选择模块相匹配的MLFB版本，如下图所示：

在此处填写IP地址和子网掩码。本例中将IP地址设置为：140.80.0.60，点击下一步；

下面的对话框将组态CP243-1进行S7连接的连接数量的设置。通过S7连接可以与通信伙伴进行读写数据操作，点击“下一步”按钮继续进行S7连接组态。本例中CP243-1的第三、四个连接分别为服务器连接。

组态一个到S7-300的服务器连接：
本例中第三个S7连接将(S7-200)组态为服务器连接，带CP343-1的S7-300站将作为客户端用于服务器连接。 S7-200和S7-300的S7连接通过TSAP来定义。
注意：分别组态S7-200和S7-300时，本地和远程的TSAP号是必须完全对应的。通常本地TSAP是默认的，所以在组态此步骤时，需要两边确认一下。

本地TSAP为12.00无法更改，远程TSAP设置为10.04（这是在STEP7网络组态得到的参数）。激活“接受所有连接请求”复选框，点击“下一步”按钮继续组态。

组态一个到S7-400的服务器连接：
组态步骤同上，注意远程TSAP的确定，需要与STEP7软件中网络组态里的属性设置保持一致。

选择CRC校验,使用缺省的时间间隔30秒，点击下一步按钮。

填写模块所占用的V存储区的起始地址。你也可以通过建议地址按钮来获得系统建议的V存储区的起始地址, 点击下一步按钮。

点击”完成”按钮完成以太网向导设置。

之后功能块ETHx_CTRL 和 ETHx_XFR将被创建，必须在STEP 7-MicroWIN的主循环块MAIN (OB1)中调用这些功能块。
功能块ETHx_CTRL 用于建立通讯。编写图中的通讯程序，保存组态并下载到S7-200 CPU上。

注意：功能块ETHx_XFR 仅在用于客户端进行数据传送时才被调用。

3、组态S7-300/400为客户端进行S7通讯

S7连接组态
本例中使用S7-300作为样例建立S7连接，对于S7-400的组态步骤是一样的。
在STEP7中打开S7-300项目文件，通过Options--Configure Network或者是相对应的图标打开NetPro对话框。

在NetPro中选中S7-300站的CPU并通过菜单命令，Insert--New Connection添加一个新连接。

选择连接伙伴为“unspecified”及连接类型为“S7 connection”。点击“Apply”按钮，之后S7连接的属性对话框将打开。

由于S7连接是由S7-300创建，因此在S7连接的属性对话框中须激活“Establish an active connection“复选框。输入通信伙伴CP243-1的IP地址，之后点击“Address Details”按钮。

在“Address Details”对话框中，本地的TSAP通常选用默认，输入通信伙伴的TSAP，本例中S7-200的TSAP为12.00。
注意：分别组态S7-200和S7-300时，本地和远程的TSAP号是必须完全对应的。通常本地TSAP是默认的，所以在组态此步骤时，需要两边确认一下。

在NetPro中选中S7-300站，保存及编译后下载到S7-300 中，此处注意需要下载网络组态。

对于S7-400的组态步骤一样，需要对应本地TSAP及伙伴S7-200的TSAP (例子中为13.00)。

接下来，在S7程序中调用功能块，进行编程。

4、STEP7编写PUT/GET程序

需要在S7-300程序中，调用功能块FB14 “GET” 和 FB15 “PUT”。可以在Standard Library--Communication Blocks--Blocks下找到这些功能块。
注意：
1. ID：为Netpro里组态S7连接属性窗口中的Block paramters-Local ID。
2.ADDR_1为伙伴PLC的数据区域，由于通信伙伴是S7-200的V区，V区与S7-300的DB1地址相对应。
3.RD_1为本地PLC的数据接收区；SD_1为本地PLC的数据发送区。

如果通信无法建立，请查看“PUT”和“GET”指令的错误代码，STATUS仅在一个周期内有效，需要在ERROR=1时捕捉错误状态。如下图所示：

对于FB14 “GET” 和 FB15 “PUT”的输入参数'ID"，也可通过鼠标右击功能块ID引脚，可以自动插入本地ID连接。如下图所示：

如果使用S7-400必须调用功能块SFB14 “GET” 和 SFB15 “PUT”。可以在Standard Library--System Function Blocks--Blocks 找到这些功能块.

S7-300中调用功能块FB14 “GET” 和FB15 “PUT”的例子程序
可以通过以下ID号找到S7-300中调用功能块FB14 “GET” 和 FB15 “PUT”的例子程序: 18610307。
S7-400中调用功能块SFB14 “GET”和SFB15 “PUT”的例子程序
可以通过以下ID号找到S7-400中调用功能块SFB14 “GET” 和 SFB15 “PUT”的例子程序:: 1819293。


CP243-1

CP243-1通过SIMATIC NET连接WinCC

CP243-1作为S7-200的以太网模块，除IT功能外，只支持西门子私有的S7协议，理论上只能通过OPC的方式和上位机组态软件通信，OPC服务器可以是S7-200专用的PC ACCESS软件，也可以是SIMATIC NET软件，以下介绍的为CP243-1通过SIMATIC NET连接WinCC。

配置SIMATIC NET需要组态PC站，而PC站可以使用STEP 7（NCM Manager）或者TIA博途STEP 7专业版配置，通常WinCC包括经典WinCC以及TIA博途WinCC专业版，所以本文档分为以下几部分介绍。

  1. CP243-1以太网向导配置
  2. 使用STEP 7（NCM Manager）配置PC站
  3. 使用TIA博途专业版配置PC站
  4. 导入站组态编辑器，及在OPC SCOUT测试
  5. 经典WinCC组态
  6. TIA博途WinCC专业版组态
  7. 常见问题

使用时注意：条目2和条目3只需要其中一种即可。

建议组态之前检查电脑操作系统、STEP 7、WinCC、SIMATIC NET等的兼容性，以免出现不可预知的状况，兼容性参见链接。

本例程软件环境：

PC1：

操作系统：WIN7 SP1 64位英文版

软件：STEP 7-Micro/WIN V4.0 SP9

PC2：

操作系统：WIN7 SP1 64位英文版

软件：STEP 7 V5.5 SP4

WinCC V7.4 SP1

SIMATIC NET V14

IP地址：192.168.1.130

子网掩码：255.255.255.0

PC3：

操作系统：WIN10 pro 1607英文版

软件：TIA 博途 STEP 7 V14SP1 专业版

TIA 博途 WinCC V14 SP1 专业版

SIMATIC NET V14

IP地址：192.168.1.1

子网掩码：255.255.255.0

本例程硬件环境：

CP224XP + EM277 + CP243-1 IT

IP地址：192.168.1.7

子网掩码：255.255.255.0

S7-200编程电缆：USB-PPI（6ES7901-3DB30-0XA0）

CP243-1以太网向导配置

1. 打开STEP 7-Micro/WIN，新建以太网向导，可以通过以下两种方式新建，得到以太网向导的首页，参见图1。

图1 以太网向导

2.设置模块位置，参见图2。

图2 模块位置设置

此时有两种情况：S7-200在线配置与离线配置。

在线配置：

①点击“读取模块”按钮；

②显示搜索到的模块位置，然后双击该部分；

③显示正确的模块位置；

④点击“下一步”按钮；

离线配置：

①、②不相关；

③修改正确的模块位置，紧挨CPU的模块位置为0，以此类推；

④点击“下一步”按钮；

3. 设置模块订货号，参见图3。

图3 选择模块

4. 设置CP243-1IP地址，参见图4。

图4 设置IP地址

①点击该按钮，弹出“IP地址浏览器”页面；

②点击“新地址”按钮；

③输入CP243-1需要设置的IP地址；

④点击“保存”按钮；

⑤显示CP243-1设置的IP地址；

⑥点击“确认”按钮；

⑦显示CP243-1设置的IP地址；

⑧设置子网掩码，如果需要的话，设置网关地址；

⑨点击“下一步”按钮；

5. 设置命令字节和连接个数，参见图5。

图5 设置命令字节和连接个数

S7-200 的命令字节是CPU内部占用QB实现该智能模块的功能，CP243-1、EM253等模块都需要使用命令字节，该地址不能和其它Q区冲突。

①分两种情况：

左边为在线配置，Q点固定，无需设置；

右边为离线配置，Q点可变，需要根据CP243-1前面所有的数字量输出模块计算该数值；

例如硬件为：CPU+EM223 16DI/16DO+EM222 8DO+EM253+CP243-1

CPU占2个QB，EM223占2个QB，EM222占1个QB，EM253占1个QB，因此CP243-1占据的QB点为2+2+1+1=6，如果CP243-1后面还有DO输出（或EM253等智能模块），则后面的DO从QB7开始。

②修改连接数目，CP243-1连接的SIMATIC NET的个数即为连接数目需要增加的数目，此处只和一个SIMATIC NET通信，则连接数目从0变为1；

③点击“下一步”按钮；

6. 设置连接信息，参见图6。

图6 设置连接信息

①选择“此为服务器连接”；

②显示本地TSAP，该值用在PC站建立连接时填写的远程TSAP，见PC站设置（STEP 7的PC站，TIA博途的PC站）；

③可以选择“接受所有连接请求”即不指定客户机的IP地址，也可以在下方地址栏指定客户机的IP地址；此处选择“接受所有连接请求”；

④输入远程TSAP，该值使用PC站建立连接时的本地TSAP，见PC站设置（STEP 7的PC站，TIA博途的PC站）；

⑤如果有多个连接，则可以点击“下一个连接”切换至其他连接设置页面；

⑥点击“下一步”按钮；

7. 设置CRC保护和保持活动时间间隔（keepalive时间），参见图7。

图7 设置CRC保护和保持活动时间间隔

默认设置即可。

8. 分配V区存储，参见图8。

图8 分配V区存储

该区域用于内部使用，绝对不能和其它地址冲突，建议设置V区靠后的地址。

9. 完成设置，参见图9。

图9 完成设置

10. 下载设置，参见图10。

图10 下载设置

通过PPI电缆连接CPU：

①如果此处提示“存在于附加模块不符的向导配置”，属于正常现象；

②一定要选择“数据块”；

③点击“下载”按钮；

④下载完毕CPU断电重启；

11.读取PLC信息，参见图11。

图11 PLC信息

Micro/WIN通过PPI电缆连接CPU成功后：

①选择“PLC菜单>信息”，弹出PLC信息页面；

②在下方找到CP243-1，状态为“无错误”，选中该行；

③点击“EM信息”按钮，得到图12；

图12 PLC信息详细内容

通过切换上方的标签页获得CP243-1的各种信息：

①点击“地址”标签页；

②显示之前设置的CP243-1的IP地址；

③点击“特殊存储区数据”标签页；

④显示之前设置的CP243-1的QB地址；

⑤之前设置的CP243-1的V区指针；

⑥点击“通道”标签页；

⑦通道0为之前设置的CP243-1和OPC服务器的连接，此时显示“未就绪”，即没有和OPC服务器建立连接，如果显示“就绪”，则已和OPC服务器建立连接；

CP243-1设置完毕，此时也可以使用Micro/WIN通过以太网连接CPU。


STEP7_PC

使用STEP 7（NCM Manager）配置PC站

可以使用STEP 7（SIMATIC Manager）配置PC站，也可以使用NCM Manager配置PC站，这两种方法配置过程完全一致，此处使用STEP 7（SIMATIC Manager）配置。

1. 打开STEP 7，新建项目，创建SIMATIC PC站，参见图1。

图1 创建SIMATIC PC站

2. 组态PC站

（1）打开PC站的HW Config（硬件组态）页面，参见图2。

图2 打开硬件组态

①选中创建的PC站；

②在右边工作区双击Configuration（组态），打开PC站的硬件组态页面；

（2）组态OPC Server（OPC服务器），参见图3。

图3 添加OPC Server

①在硬件目录中找到SIMATIC PC Station；

②SIMATIC PC Station中找到User Application；

③User Application中找到OPC Server，根据安装的SIMATIC NET版本选择相同或向下最接近的版本，例子中SIMATIC NET版本为 V14，选择向下最接近的版本V8.2，选中该版本并拖入机架中；

（3）组态网卡，参见图4。

图4 添加网卡

①在硬件目录中找到SIMATIC PC Station；

②SIMATIC PC Station中找到CP Industrial Ethernet；

③CP Industrial Ethernet中找到所用网卡，例子中使用普通网卡IE General（IE 通用），根据安装的SIMATIC NET版本选择相同或向下最接近的版本，例子中SIMATIC NET版本为 V14，选择向下最接近的版本V8.2，双击网卡的该版本后网卡自动插入到机架中；

（4）设置网卡，IE General（IE 通用）插入到机架时，将弹出如图5的设置页面。

图5 设置网卡

①点击“Properties”（属性）按钮，弹出属性页面；

②输入OPC服务器所在电脑的IP地址和子网掩码；注意，例子中的PC站组态和实际OPC服务器使用一台电脑，所以使用的OPC服务器的IP也是PC站组态的IP；如果出现PC站组态和实际OPC服务器不使用一台电脑，组态时一定注意；

③点击“New..”(新建)按钮，新建子网；

④点击“OK”(确认)按钮；

⑤点击“OK”(确认)按钮；

然后关闭PC站的硬件组态页面。

3. 建立连接

（1）打开组态网络页面，参见图6。

图6 组态网络页面

①点击该按钮，弹出NetPro（组态网络）页面；

②找到建立的SIMATIC PC Station(1)，右键选中其中的OPC Server；

③在弹出窗口点击Insert New Connection（插入新连接），弹出Insert New Connection（插入新连接）页面；

（2）插入新连接，参见图7。

图7 插入新连接

①选择“Unspecified”（未指定）；

②选择S7 connection（S7连接）；

③点击“OK”(确认)按钮；

（3）设置连接属性，参见图8

图8 设置连接属性

①输入CP243-1的IP地址；

②点击“Address Details”（地址详细信息）按钮，打开Address Details（地址详细信息）页面；

③④和之前CP243-1以太网向导设置页面对应，远程TSAP与CP243-1的本地TSAP一致，例子中为10.01，即Connection Resource(hex)（连接资源）为10，Rack/Slot（机架/插槽）为01（CP243-1组态）；

⑤本地TSAP自动生成，CP243-1的远程TSAP与该TSAP一致，例子中为10.11，即CP243-1的远程属性TSAP为10.11（CP243-1组态）；

⑥点击“OK”(确认)按钮；

⑦点击“OK”(确认)按钮；

（4）显示连接，参见图9。

图9 显示连接

图中显示已插入的新连接，之后保存编译该PC站，然后关闭项目。


TIA_PC

使用TIA博途配置PC站

1. 打开TIA博途软件，新建项目，添加新设备，参见图1。

图1 添加新设备

①选择“PC系统”；

②在“PC系统>用户应用程序”找到“OPC服务器”；

③选择版本，根据安装的SIMATIC NET版本选择相同或向下最接近的版本，例子中SIMATIC NET版本为 V14，选择相同版本V14；

④点击“确定”按钮，弹出PC站的组态视图页面；

2. 组态PC站

（1）组态网卡，参见图2。

图2 组态网卡

①在硬件目录的“Communications modules>PROFINET/Ethernet”中找到并选中所用网卡，例子中使用普通网卡“常规IE”；

②在硬件目录下方的信息窗口，根据安装的SIMATIC NET版本选择相同或向下最接近的版本，例子中SIMATIC NET版本为 V14，选择向下最接近的版本V8.2；

③双击①选中的网卡，则网卡自动插入机架中；

（2）设置网卡，参见图3。

图3 网卡设置

①设备视图中，选中网卡的网口；

②选择“属性”页面；

③选择“常规”页面；

④选择“以太网地址”；

⑤点击“添加新子网”按钮；

⑥输入OPC服务器所在电脑的IP地址和子网掩码；注意，例子中的PC站组态和实际OPC服务器使用一台电脑，所以使用的OPC服务器的IP也是PC站组态的IP；如果出现PC站组态和实际OPC服务器不使用一台电脑，组态时一定注意；

如有路由器则激活“使用路由器”，并填写路由器地址；

3. 建立连接

（1）建立连接准备工作，参见图4。

图4 建立连接准备工作

①切换到“网络视图”页面；

②激活“连接”；

③下拉框选择“S7连接”；

（2）建立新连接，参见图5。

图5 建立新连接

①在PC站中右键选中OPC Server；

②弹出菜单选择“添加新连接”，弹出窗口“创建新连接”；

③在“创建新连接”窗口选择“未指定”；

④点击“确定”按钮；

（3）连接设置，参见图6。

图6 连接设置

①②如无法在网络视图看到③处的表格，则通过这两个按钮将“连接”表格调出；

③“连接”表格显示已建立的连接，并选中；

④选择“属性”页面；

⑤选择“常规”页面；

⑥选择“常规”；

⑦输入CP243-1的IP地址；

设置伙伴IP后，需要修改TSAP，参见图7。

图7 修改TSAP

①选择“地址详细信息”；

②③和之前CP243-1以太网向导设置页面对应，远程TSAP与CP243-1的本地TSAP一致，例子中为10.01，即Connection Resource(hex)（连接资源）为10，Rack/Slot（机架/插槽）为01（CP243-1组态）；

④本地TSAP自动生成，CP243-1的远程TSAP与该TSAP一致，例子中为10.11，即CP243-1的远程属性TSAP为10.11（CP243-1组态）；

4. 生成XDB文件，参见图8。

图8 生成XDB文件

①网络视图中选择PC站的电脑图标处；

②选择“属性”页面；

③选择“常规”页面；

④选择“XDB组态”；

⑤激活“生成XDB文件”；

⑥显示XDB文件的存储路径，可修改；

之后保存编译该PC站，然后关闭项目。


OPC_SCOUT

导入XDB文件及利用OPC Scout V10测试OPC服务器与CP243-1的连接

使用STEP 7或者TIA博途配置好PC站后，需完成以下操作：

1. 导入XDB文件

（1）打开Station Configuration Editor（站组态编辑器）

在电脑桌面选择图标 [image] 或者在电脑桌面右下角选择图标 [image] ，激活Station Configuration Editor站组态编辑器，参见图1。

图1 站组态编辑器

①点击“Import Station...”按钮；

②在弹出窗口，点击“Yes”按钮；

（2）浏览到生成的XDB文件，并选择打开。

图2为STEP 7中生成的XDB文件的默认地址（XDB文件在STEP 7默认生成，无需设置，默认地址如何修改参见链接），TIA博途的默认地址参见链接。

图2 浏览到生成的XDB文件

打开XDB文件，弹出视图如图3：

图3 XDB文件导入

①如果有该提示说明组态的OPC服务器比实际的版本低，但不影响使用；

②点击“OK”按钮；

最后弹出如图4的页面，点击“OK”按钮关闭。

图4 导入XDB文件成功

2. OPC Scout V10测试

注意：使用OPC Scout V10测试OPC服务器与CP243-1的连接并非必须，只是用于检查前面的配置是否正确，以及方便WinCC或第三方OPC客户端的导入。

测试之前确保CP243-1已组态并连接。

安装好SIMATIC NET后，OPC Scout V10的快捷方式不会出现在桌面，需要按照以下路径寻找：

WIN XP：“开始>所有程序>SIMATIC>SIMATIC NET”找到OPC Scout V10。

WIN7：“开始>所有程序>Siemens Automation>SIMATIC>SIMATIC NET”找到OPC Scout V10。

WIN10：“开始>Siemens Automation”找到OPC Scout V10。

（1）打开OPC Scout V10，在“COM server（SIMATIC NET V14之后新增）>Local COM server>OPC.SimaticNET>\S7>建立的连接名称（例子中为S7 connection_1）”路径下找到“objects”，参见图5。

图5 OPC Scout V10浏览变量

（2）插入变量，参见图6。

图6 新增变量

①在“M”文件夹下，点击“[New Definition]”(新定义)，弹出页面“New item definition”（新项定义）；

②下拉框选择Data Type（数据类型），对于S7-200可以选择的见下表1：

表1 数据类型及其说明

数据类型 | 数据类型说明
B | 字节
CHAR | 有符号短整数
W | 字
INT | 有符号整数
DWORD | 双字
DINT | 有符号双整数
X | 位
REAL | 浮点数
STRING | 字符串
DT | 日期时间

③例子中数据类型选择“B”（字节）；

④Address（起始地址），例子中输入“0”；

⑤Bit number（位号），当数据类型选择“X”使用；

⑥Number of values（值个数），当需要连续多个相同数据类型的数据时使用，例子中输入“1”；

⑦别名，例子为“MB0”，不建议修改；

⑧点击“OK”按钮；

此处注意，“DB”文件夹对应S7-200的V区，但是通常情况下该文件夹无法打开，详情参见常见问题。

以上为在OPC Scout V10中建了地址为MB0，名称也为MB0的这个变量，参见图7。

图7 变量监视

①在“M”文件夹下出现了定义的项“MB0”；

②在Workbook（工作簿）中找到“DA view 1”并点击；

③将定义的项“MB0”拖入右下的“DA view 1”视图；

④点击“Monitoring ON”（监视）按钮；

⑤可见“Quality”（质量）是good，也就是说OPC scout V10已经和OPC服务器建立了连接，并且OPC服务器和CP243-1通讯正常；

此时测试结束，关闭OPC scout V10，关闭时提示保存文件选择不保存。


WINCC

使用经典WinCC通过SIMATIC NET访问CP243-1

1. 创建WinCC项目，打开“变量管理”页面，点击“添加新的驱动程序>OPC”，参见图1。

图1 添加OPC通道

添加后变量管理中出现OPC的通道，以及新的“OPC Groups”（OPC组），参见图2。

图2 添加OPC组

2. 添加连接及变量

（1）添加连接

右键选择新建的“OPC Groups”（OPC组），点击“系统参数”，打开“OPC条目管理器”页面，参见图3。

图3 系统参数

“OPC条目管理器”页面参见图4。

图4 OPC条目管理器

①在\\<LOCAL>下选择“OPC.SimaticNET.1”；

②点击“浏览服务器(B)”按钮，打开“过滤标准”页面；

③点击“下一步”按钮，弹出类似于OPC SCout V10中看到的页面；

（2）添加已有变量，参见图5

图5 添加已有变量

①找到“OPC.SimaticNET>\S7>建立的连接名称（例子中为S7 connection_1）>objects>M”；

②选中“MB0”，为之前在OPC SCout V10添加的变量；

③点击“添加条目”按钮；

④在弹出的“OPCTags”页面，点击“Yes”按钮；

⑤在弹出的“新建连接”页面，点击“确定”按钮，此处可以修改连接名称，例子中使用默认名称；

⑥在弹出的“添加变量”页面，点击“完成”按钮，此处可以在变量名的前后添加前缀和后缀，例子中使用默认的空前缀和空后缀；

关闭上述页面，就可以看到添加变量后的变量管理页面，参见图6。

图6 添加变量

①在OPC通道的新建的“OPC Groups”（OPC组）中，选中上一步新建的连接“OPC_SimaticNET_1”；

②选择“变量”页面；

③显示已添加的变量，包括数据类型、长度、连接、地址等重要信息；

（3）添加其他变量，参见图7

图7 添加其他变量

①复制该地址，例子中为“S7:[S7 connection_1]MB0”；

此处注意：PC站使用STEP 7建立，连接名称默认形如S7 connection_1；PC站使用TIA博途建立，连接名称默认形如S7_Connection_1；

②添加新的变量名；

③选择合适的数据类型；

④点击“属性 - 变量”页面的地址处的按钮；

⑤在弹出页面的条目名称处，将①复制的地址粘贴到此处，并修改，修改原则如下：

以例子中的“S7:[S7 connection_1]MB0”为例，参见图8：

图8 地址修改原则

⑥选择和③相同的数据类型；

⑦点击“OK”按钮

以此方法，添加若干变量，参见图9：

图9 添加变量完成

地址中最后的数字为添加变量后自动添加，不要去改动，数字含义和数据类型对照见表1。

表1 数据类型和Wincc数据类型以及标识等对照

数据类型 | 经典WinCC数据类型 | 标识 | 数字
字节 | 无符号的8位值 | B | 17
字 | 无符号的16位值 | W | 18
双字 | 无符号的32位值 | D | 19
有符号短整数 | 有符号的8位值 | CHAR | 16
有符号整数 | 有符号的16位值 | INT | 2
有符号双整数 | 有符号的32位值 | DINT | 3
浮点数 | 32-位浮点数 IEEE754 | REAL | 4
位 | 二进制变量 | X | 11
字符串 | 文本变量8位字符集 | STRING | 8
日期时间 | 日期/时间 | DT | 7

3. WinCC画面

编制好WinCC画面，运行后参见图10。

图10 WinCC运行结果


TIA_WINCC

使用TIA博途WinCC通过SIMATIC NET访问CP243-1

1. 打开TIA博途，新建项目，添加新设备，参见图1。

图1 添加新设备

①选择“PC系统”；

②在“PC系统>SIMATIC HMI应用软件”找到“WinCC RT Professional”；

③点击“确定”按钮，弹出PC站的组态视图页面；

2. 添加连接及变量

（1）添加连接，参见图2。

图2 添加新连接

①在项目树“PC-System_1>HMI_RT_1”中找到“连接”并双击；

②点击“<添加>”，添加新连接“Connection_1”；

③在新连接的通信驱动程序选择“OPC”；

④在下方参数页面的“OPC服务器>本地服务器”中找到“OPC.SimaticNET”并双击，使其出现在OPC服务器的名称处；

（2）变量表添加变量

打开HMI_RT_1的变量表，参见图3。

图3 变量表添加连接

①点击“<添加>”，添加新变量；

②点击连接处的按钮；

③在弹出页面左侧“PC-System_1>HMI_RT_1”中找到“连接”；

④在弹出页面右侧，选择“Connection_1”；

（3）添加已有变量，参见图4。

图4 变量表添加变量

①点击地址栏的按钮；

②在弹出页面找到“OPC.SimaticNET>\S7>建立的连接名称（例子中为S7 connection_1）>objects>M”，在右侧页面选中“MB0”，为之前在OPC SCout V10添加的变量；

③点击按钮，则该变量出现在默认变量表，数据类型自动修改；

（4）添加其他变量，参见图5。

图5 修改变量

①将第一个变量复制多遍；

②修改地址，原则参见图6：

图6 修改地址原则

③修改数据类型，对应关系见表1：

表1 数据类型和TIA博途Wincc数据类型以及标识等对照

数据类型 | TIA博途WinCC数据类型 | 标识
字节 | VT_UI1 | B
字 | VT_UI2 | W
双字 | VT_UI4 | D
有符号短整数 | VT_I1 | CHAR
有符号整数 | VT_I2 | INT
有符号双整数 | VT_I4 | DINT
浮点数 | VT_R4 | REAL
位 | VT_BOOL | X
字符串 | VT_BSTR | STRING

3. WinCC画面

编制好WinCC画面，运行参见图7。

图7 WinCC运行结果


FAQ

常见问题

1. 使用WinCC通过SIMATIC NET如何显示S7-200的字符串变量?

答：经典WinCC的文本变量8位字符集以及TIA博途WinCC的VT_BSTR是基于S7-300/400的SIMATIC STRING，这种字符串的组成是字符串的最大长度、字符串的实际长度、以及最多254个字符，而S7-200的字符串的组成是字符串的实际长度、以及最多255个字符。

也就是说这两种字符串格式不同，如果需要在WinCC通过SIMATIC NET显示S7-200的字符串变量，可以做如下操作：

例：VB100是S7-200的字符串"1234abcd"，根据S7-200的规则，VB100=8，即字符串的实际长度为8，VB101～VB108是这8个字符，可以定义VB99=8，即字符串的最大长度，在WinCC的变量表定义的地址为S7:[S7 connection_1]DB1,STRING99.8，99为起始地址，8为最大长度，参见图1和图2。

图1 经典WinCC设置

红框长度=8，即为VB99这个字符串最大长度

图2 TIA博途WinCC设置

红框长度=8，即为VB99这个字符串最大长度

S7-200监视和WinCC显示参见图3。

图3 WinCC运行结果

注意：由于S7-300/400的字符串最大只有254个字符，所以显示的S7-200的字符串最大也只有254个字符。

2. 如何使用OPC Scout V10监视V区数据？

答：OPC Scout V10中，“DB”文件夹对应S7-200的V区，但是通常情况下该文件夹无法打开。

要注意OPC Scout V10只是个测试工具，也就是说只要有一个变量（例如M区或者I区或者Q区）测试质量为“good”，即说明通信正常，如果一定需要测试DB块的变量，可以如此操作，参见图4和图5：

图4 添加变量

①点击该按钮；

②打开“Define item”页面，复制该条目；

③点击“OK”按钮；也可以根据该命名原则（链接）自行创建，这样可以跳过前三步；

④点击该按钮；

⑤打开“Define item”页面，将②复制的条目粘贴在这，修改该条目，原则参见链接；例子中“S7:[S7 connection_1]DB1,INT8”对应S7-200的“VW8”；

⑥点击该按钮；

⑦下拉菜单中选择唯一的条目；

⑧点击“OK”按钮；

图5 监视变量

①新建的条目出现在此；

②监视后，质量为“good”；

③该值和S7-200监视的值相同；

这样就实现了使用OPC Scout V10监视V区数据，但是请注意，这种方式加入的条目是不会出现在WinCC中的，所以还是需要使用文中方法在WinCC添加V区变量（WinCC、TIA博途Wincc）

3. 如何查看修改STEP 7的XDB文件的保存位置？

答：打开PC站的硬件组态页面，参见图6。

图6 STEP 7的XDB配置

①双击该位置，打开Properties（属性）页面；

②选择“Configuration”（组态）页面；

③此处显示XDB的保存位置；

④通过“Browse...”（浏览）按钮可以修改为其他位置；


Modbus 通讯

Modbus 通信

S7-200 通过以下方式支持 Modbus 通信协议：

  • S7-200 CPU 上的通信口 0（Port 0）通过指令库支持 Modbus RTU 从站模式
  • S7-200 CPU 上的通讯口 0 和 1 （Port 0 和 Port 1）通过指令库支持 Modbus RTU 主站模式
  • S7-200 CPU 通过 EM241 模块的 Modem 接口支持 Modbus RTU 模式

通过 S7-200 CPU 通信口的自由口模式实现 Modbus 通信协议，可以通过无线数据电台等慢速通信设备传输。 这为组成 S7-200 之间的简单无线通信网络提供了便利。

详细情况请参考《S7-200系统手册》（2002 年 10 月或以后版本）的相应章节。

Modbus 是公开通信协议，其最简单的串行通信部分仅规定了在串行线路的基本数据传输格式，在 OSI 七层协议模型中只到 1，2 层。

Modbus 具有两种串行传输模式，ASCII 和 RTU。它们定义了数据如何打包、解码的不同方式。支持 Modbus 协议的设备一般都支持 RTU 格式。

通信双方必须同时支持上述模式中的一种。

Modbus 是一种单主站的主/从通信模式。Modbus 网络上只能有一个主站存在，主站在 Modbus 网络上没有地址，从站的地址范围为 0 - 247，其中 0 为广播地址，从站的实际地址范围为 1 - 247。

Modbus 通信标准协议可以通过各种传输方式传播，如 RS232C、RS485、光纤、无线电等。 在 S7-200 CPU 通信口上实现的是 RS485 半双工通信，使用的是 S7-200 的自由口功能。

详细的协议和规范，请访问 Modbus 组织的网站：

http://www.modbus.org

S7-200 网络通信协议
RS485 传输

常问问题

S7-200 是否支持 Modbus ASCII 通信模式？

西门子不提供支持上述模式的的现成指令库，需要用户自己用自由口模式编程。


Modbus RTU Master

Modbus RTU 主站指令库

西门子在 Micro/WIN V4.0 SP5 中正式推出 Modbus RTU 主站协议库（西门子标准库指令）。

图 1. 西门子标准指令库（Micro/WIN V4.0 SP5）

注意：

1. Modbus RTU 主站指令库的功能是通过在用户程序中调用预先编好的程序功能块实现的，该库对 Port 0 和 Port 1 有效。该指令库将设置通信口工作在自由口模式下。
2. Modbus RTU 主站指令库使用了一些用户中断功能，编其他程序时不能在用户程序中禁止中断。
3. Modbus RTU 主站库对CPU的版本有要求。CPU 的版本必须为 2.00 或者 2.01（即订货号为 6ES721*－***23-0BA*），1.22版本之前（包括1.22版本）的 S7-200 CPU 不支持。

使用 Modbus RTU 主站指令库，可以读写 Modbus RTU 从站的数字量、模拟量 I/O 以及保持寄存器。

要使用 Modbus RTU 主站指令库，须遵循下列步骤：

  1. 安装西门子标准指令库
  2. 按照要求编写用户程序调用 Modubs RTU 主站指令库

安装西门子标准指令库

Modbus RTU 主站功能编程

1. 调用 Modbus RTU 主站初始化和控制子程序

使用 SM0.0 调用 MBUS_CTRL 完成主站的初始化，并启动其功能控制：

图 2. 用 SM0.0 调用 Modbus RTU 主站初始化与控制子程序

各参数意义如下:

a. | EN | 使能： | 必须保证每一扫描周期都被使能（使用 SM0.0）
b. | Mode | 模式： | 为 1 时，使能 Modbus 协议功能；为 0 时恢复为系统 PPI 协议
c. | Baud | 波特率： | 支持的通讯波特率为1200，2400，4800，9600，19200，38400，57600，115200。
d. | Parity | 校验： | 校验方式选择
 |  |  | 0＝无校验
 |  |  | 1＝奇较验
 |  |  | 2＝偶较验
e. | Timeout | 超时： | 主站等待从站响应的时间，以毫秒为单位，典型的设置值为 1000 毫秒（1 秒），允许设置的范围为 1 - 32767。
 |  |  | 注意： 这个值必须设置足够大以保证从站有时间响应。
f. | Done | 完成位： | 初始化完成，此位会自动置1。可以用该位启动 MBUS_MSG 读写操作（见例程）
g. | Error |  | 初始化错误代码（只有在 Done 位为1时有效）：
 |  |  | 0＝ 无错误
 |  |  | 1＝ 校验选择非法
 |  |  | 2＝ 波特率选择非法
 |  |  | 3＝ 模式选择非法

2. 调用 Modbus RTU 主站读写子程序MBUS_MSG，发送一个Modbus 请求；

图 3. 调用Modbus RTU 主站读写子程序

各参数意义如下:

a. | EN | 使能： | 同一时刻只能有一个读写功能（即 MBUS_MSG）使能
 |  |  | 注意：建议每一个读写功能（即 MBUS_MSG）都用上一个 MBUS_MSG 指令的 Done 完成位来激活，以保证所有读写指令循环进行（见例程）。
b. | First | 读写请求位： | 每一个新的读写请求必须使用脉冲触发
c. | Slave | 从站地址： | 可选择的范围 1 - 247
d. | RW | 从站地址： | 0 ＝ 读， 1 ＝ 写
 |  |  | 注意：
 |  |  | 1. 开关量输出和保持寄存器支持读和写功能
 |  |  | 2. 开关量输入和模拟量输入只支持读功能
e. | Addr | 读写从站的 | 选择读写的数据类型
 |  | 数据地址： | 00001 至 0xxxx - 开关量输出
 |  |  | 10001 至 1xxxx - 开关量输入
 |  |  | 30001 至 3xxxx - 模拟量输入
 |  |  | 40001 至 4xxxx - 保持寄存器
f. | Count | 数据个数 | 通讯的数据个数（位或字的个数）
 |  |  | 注意： Modbus主站可读/写的最大数据量为120个字（是指每一个 MBUS_MSG 指令）
g. | DataPtr | 数据指针： | 1. 如果是读指令，读回的数据放到这个数据区中
 |  |  | 2. 如果是写指令，要写出的数据放到这个数据区中
h. | Done | 完成位 | 读写功能完成位
i. | Error | 错误代码： | 只有在 Done 位为1时，错误代码才有效
 |  |  | 0 ＝ 无错误
 |  |  | 1 ＝ 响应校验错误
 |  |  | 2 ＝ 未用
 |  |  | 3 ＝ 接收超时（从站无响应）
 |  |  | 4 ＝ 请求参数错误（slave address, Modbus address, count, RW）
 |  |  | 5 ＝ Modbus/自由口未使能
 |  |  | 6 ＝ Modbus正在忙于其它请求
 |  |  | 7 ＝ 响应错误（响应不是请求的操作）
 |  |  | 8 ＝ 响应CRC校验和错误
 |  |  | -
 |  |  | 101 ＝ 从站不支持请求的功能
 |  |  | 102 ＝ 从站不支持数据地址
 |  |  | 103 ＝ 从站不支持此种数据类型
 |  |  | 104 ＝ 从站设备故障
 |  |  | 105 ＝ 从站接受了信息，但是响应被延迟
 |  |  | 106 ＝ 从站忙，拒绝了该信息
 |  |  | 107 ＝ 从站拒绝了信息
 |  |  | 108 ＝ 从站存储器奇偶错误

常见的错误：

  • 如果多个 MBUS_MSG 指令同时使能会造成 6 号错误
  • 从站 delay 参数设的时间过长会造成主站 3 号错误
  • 从站掉电或不运行，网络故障都会造成主站 3 号错误

3. 在 CPU 的 V 数据区中为库指令分配存储区（Library Memory）

Modbus Master 指令库需要一个284个字节的全局 V 存储区。

参考：分配库指令数据区

关于 Modbus RTU 主站协议库的补充说明

此为西门子正式推出的标准库指令说明资料。

在 Modbus RTU Master 协议和 PPI 协议之间切换：

Modbus RTU Master 协议指令库使通信口工作在自由口模式下，此时不能与 Micro/WIN 软件通信。要在切换回 PPI 协议，可以：

  • 将 MBUS_CTRL 指令的 Mode 输入端设置为逻辑“0”
  • 将 CPU 的允许模式选择开关置为 STOP 位置

Modbus RTU Master 协议库的执行时间：

Modbus RTU Master 协议库的 MBUS_CTRL 指令不需要很长的执行时间。MBUS_需要 1.11 ms 用于初始化，在后续的每个扫描周期中只占用 0.41 ms。

调用 MBUS_MSG 子程序会加长处理时间。大部分时间都用于 CRC 校验的计算。每读、写一个字的数据就需要 1.85 ms 扫描时间。数据最多的情况下（读、写 120 字的数据），扫描时间大概会扩增加 222 ms。读操作的时间主要消耗在接收数据上；写操作的时间主要消耗在发送数据上。

Modbus 地址

通常 Modbus 地址由 5 位数字组成，包括起始的数据类型代号，以及后面的偏移地址。Modbus Master 协议库把标准的 Modbus 地址映射为所谓 Modbus 功能号，读写从站的数据。Modbus Master 协议库支持如下地址：

  • 00001 - 09999：数字量输出（ 线圈）
  • 10001 - 19999：数字量输入（触点）
  • 30001 - 39999：输入数据寄存器（通常为模拟量输入）
  • 40001 - 49999：数据保持寄存器

Modbus Master 协议库支持的功能

为了支持上述 Modbus 地址的读写，Modbus Master 协议库需要从站支持下列功能：

表 1. 需要从站支持的功能

Modbus 地址 | 读/写 | Modbus 从站须支持的功能
00001 - 09999 数字量输出 | 读 | 功能 1
 | 写 | 功能 5：写单输出点 功能 15：写多输出点
10001 - 19999 数字量输入 | 读 | 功能 2
 | 写 | －
30001 - 39999 输入寄存器 | 读 | 功能 4
 | 写 | －
40001 - 49999 保持寄存器 | 读 | 功能 3
 | 写 | 功能 6：写单寄存器单元 功能 16：写多寄存器单元

Modbus 地址和 S7-200 存储区地址的映射

S7-200 通过 Modbus Master 和 Slave 协议库通信时，Modbus 地址和 S7-200 内存储区地址的 映射关系都类似。

Modbus 保持寄存器地址映射举例：

Modbus 保持寄存器地址

40001 | 12 34
40002 | 56 78
40003 | 9A BC

S7-200 存储区字寻址

VW200 | 12 34
VW202 | 56 78
VW204 | 9A BC

S7-200 存储区字节寻址

VB200 | 12
VB201 | 34
VB202 | 56
VB203 | 78
VB204 | 9A
VB205 | BC

Modbus 数字量地址映射举例：

位地址（0xxxx 和 1xxxx）数据总是以字节为单位打包读写。第一个字节中的最低有效位对应 Modbus 地址的起始地址。如下图所示：

图 4. 数字量地址映射举例

Modbus RTU 主站例程

为了更好地理解 Modbus 主站的编程，可参考下面的例程。

例子程序1: 多个MBUS_MSG指令轮询执行，

注意：

1. 该例程使用 Micro/WIN V4.0 SP5 保存。
2. 该例程仅访问一个从站，若访问不同的从站，可通过改变从站地址来实现。

Modbus RTU 主站指令库应用例程

例子程序2：反复激活单个MBUS_MSG指令：

Modbus RTU 主站变址方式轮询访问应用例程

注意：此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为 此联系西门子技术支持与服务部门。

S7-200做主站S7-300 CP341做从站的Modbus RTU通讯

参考如下链接中介绍：

S7-200做主站S7-300 CP341做从站的Modbus RTU通讯

https://support.industry.siemens.com/cs/cn/zh/view/81012111

常问问题

Modbus RTU 主站库对 CPU 的版本是否有要求，为什么编译例子程序时，会遇到 4 个错误？

Modbus RTU 主站库对 CPU 的版本确实有要求，CPU 的版本必须为 2.00 或者 2.01(即订货号为6ES721*－***23-0BA*)，1.22 版本之前（包括 1.22 版本）的 S7-200 CPU 不支持。

Modbus 指令库启动后，如何通过同一个通信端口进行 CPU 监控？

Modbus 指令库使用的是 CPU 的自由口通信功能，工作在自由口模式下的通讯口不能使用 Micro/WIN 的 PPI 编程通信监控。如果通信口都已经被占用，可以考虑：

  • 加一个通信模块（如 EM 277、CP 243-1、EM 241 等）扩展出一个编程通信口
  • 中止自由口模式，可以将 CPU 上的模式开关从 RUN 拨到 STOP；或者保持处于 RUN 状态，用程序停止指令库的 Modbus 模式（参见指令库应用）

如何理解 Modbus 地址与功能码的区别？

Modbus 地址与 Modbus 的功能码是两个层次的概念。

根据 Modbus 通信协议，Modbus 数据的地址使用 0xxxx、1xxxx、3xxxx 和 4xxxx 的形式，分别表示数字量输出、数字量输入、模拟量输入等数据地址。在使用 S7-200 的指令库时，Modbus 数据地址与 S7-200 的 I/O 和数据存储区地址间有特定的对应关系。

有些设备表明它支持 Modbus RTU 通信协议，但也详细提供了读写数据的详细通信帧格式，其中包括如何指定 Modbus 站的地址，需要读写数据类型、长度等等。数据帧有特定字节指出此指令读写的数据类型和地址，此字节的数据内容即所谓“功能码”，如功能 1 指定读取单个/多个数字量输出点的值。

支持 Modbus 协议的设备或软件，使用时用户直接设置或看到的应当是 Modbus 数据地址。Modbus 地址所访问的数据，是通过各种“功能”读写而来。功能码是 Modbus 地址的底层。如果 Modbus 通信的一方提供的所谓 Modbus 协议只有功能码，则需要注意了解此功能号与 Modbus 地址间的对应关系。

如何访问大于 9999 的保持寄存器地址？

通常 Modbus 协议的保持寄存器地址范围在 40001 - 49999 之间。对于多数应用来说已经够了。但有些 Modbus 从站把地址映射到保持寄存器区的地址超过 9999 的部分。

Modbus Master 协议库支持超过 9999 的保持寄存器地址。地址范围为 400001 - 465536。只需在调用 MBUS_MSG 子程序时给 Addr 参数赋相应的值即可，如 416768。

Modubs Master 扩展地址模式仅支持保持寄存器区，不支持其他地址类型。

S7-200 作为 Modbus 主站方接收上来的数据格式与第三方设备不一样怎么办？

西门子PLC数据的存储格式为高位低存方式。举例：VD200中包含VW200和VW202，其中VW202是低字，VW200是高字。若第三方设备与西门子数据存储格式不同，是低位低存的方式，那么通信上来的数据就会存在错误，需要进行转换才能使用。编程的方式比较多样。例如，针对单个字中高低字节的交换可以使用SWAP(字节交换）指令，若是双字中高低字的交换可以考虑循环移位指令。

S7-200 是否支持如 Modbus TCP 等其它协议？

不支持。S7-200自身的通信端口或其通信扩展模块均不支持 Modbus TCP、CANopen、DeviceNet 以及 BACnet 通信协议。

为什么 S7-200 作 Modbus 主站时 MBUS_MSG 指令报6号错误？

引起6号错误主要有两方面的原因：1.多个 MBUS_MSG 指令同时使能执行；2. Modbus库存储区中分配的建议地址区与编程中已使用的V存储区有重叠。

参考：Modbus RTU 从站指令库


Modbus RTU Slave

CPU 上的通信口（Port0）支持 Modbus RTU 从站通信协议

S7-200 CPU上的通信口Port0可以支持Modbus RTU协议，成为Modbus RTU从站。此功能是通过S7-200的自由口通信模式实现，因此可以通过无线数据电台等慢速通信设备传输。

详情请参考《S7-200系统手册》之相关章节。

要实现Modbus RTU通信，需要STEP 7-Micro/WIN32 V3.2以上版本的编程软件，而且须安装STEP 7-Micro/WIN32 V3.2 Instruction Library（指令库）。Modbus RTU功能是通过指令库中预先编好的程序功能块实现的。

Modbus RTU从站指令库只支持CPU上的通信0口（Port0）。

参考：Modbus RTU 主站指令库

基本步骤：

  1. 检查Micro/WIN的软件版本，应当是STEP 7-Micro/WIN V3.2以上版本。
  2. 检查Micro/WIN的指令树中是否存在Modbus RTU从站指令库（图1），库中应当包括MBUS_INIT和MBUS_SLAVE两个子程序。如果没有，须安装Micro/WIN32 V3.2的Instruction Library（指令库）软件包；

    图1. 指令树中的库指令

  3. 编程时使用SM0.1调用子程序MBUS_INIT进行初始化，使用SM0.0调用MBUS_SLAVE，并指定相应参数。关于参数的详细说明，可在子程序的局部变量表中找到；

    图2. 调用Modbus RTU通信指令库

    图中参数意义如下：

    1. 模式选择：启动/停止Modbus，1=启动；0=停止
    2. 从站地址：Modbus从站地址，取值1~247
    3. 波特率：可选1200，2400，4800，9600，19200，38400，57600，115200
    4. 奇偶校验：0=无校验；1=奇校验；2=偶校验
    5. 延时：附加字符间延时，缺省值为0
    6. 最大I/Q位：参与通信的最大I/O点数，S7-200的I/O映像区为128/128，缺省值为128
    7. 最大AI字数：参与通信的最大AI通道数，可为16或32
    8. 最大保持寄存器区：参与通信的V存储区字（VW）
    9. 保持寄存器区起始地址：以&VBx指定（间接寻址方式）
    10. 初始化完成标志：成功初始化后置1
    11. 初始化错误代码
    12. Modbus执行：通信中时置1，无 Modbus 通信活动时为 0。
    13. 错误代码：0=无错误
      表1.0 从站错误代码
  4. 在CPU的V数据区中分配库指令数据区（Library Memory）；
  5. 如有必要，使用主站软件测试。

注意：由子程序参数HoldStart和MaxHold指定的保持寄存器区，是在S7-200 CPU的V数据存储区中分配，此数据区不能和库指令数据区有任何重叠，否则在运行时会产生错误，不能正常通信。注意Modbus 中的保持寄存器区按“字”寻址，即MaxHold规定的是VW而不是VB的个数。

在图2的例子中，规定了 Modbus 保持寄存器区从 VB0 开始（HoldStart ＝ VB0），并且保持寄存器为1000个字（MaxHold＝1000），因保持寄存器以字（两个字节）为单位，实际上这个通信缓冲区占用了VB0～VB1999共2000个字节。因此分配库指令保留数据区时至少要从VB2000开始。当然保持区不一定要从VB0开始。

注意：你选用的CPU的V存储区大小！CPU型号不同V数据存储区大小不同。应根据需要选择Modbus保持寄存器区域的大小。

包含 Modbus RTU 从站指令库的项目编译、下载到CPU中后，在编程计算机（PG/PC）上运行一些 Modbus 测试软件可以检验S7-200的Modbus RTU通信是否正常，这对查找故障点很有用。测试软件通过计算机串口（RS-232）和PC/PPI电缆连接CPU。如果必要，须将PC/PPI电缆设置在自由口通信方式。

可到一些软件下载网站寻找类似软件，如 ModScan32 等。

一个 Modbus RTU 通信从站例程

Modbus RTU 从站地址与S7-200的地址对应

Modbus地址总是以00001、30004之类的形式出现。S7-200内部的数据存储区与Modbus的0、1、3、4共4类地址的对应关系如下：

表1. Modbus地址对应表
Modbus地址 | S7-200数据区
00001 ~ 00128 | Q0.0 ~ Q15.7
10001 ~ 10128 | I0.0 ~ I15.7
30001 ~ 30032 | AIW0 ~ AIW62
40001 ~ 4xxxx | T ~ T + 2 * (xxxx -1)

其中T为S7-200中的缓冲区起始地址，即 HoldStart。

如果已知S7-200中的V存储区地址，推算Modbus地址的公式如下：

Modbus地址 = 40000 + (T/2+1) ; T为偶数

Modbus RTU 从站指令库支持的 Modbus 功能码

Modbus RTU 从站指令库支持特定的 Modbus 功能。访问使用此指令库的主站必须遵循这个指令库的要求。

表 2. Modbus RTU 从站功能码
功能码 | 主站使用相应功能码作用于此从站的效用
1 | 读取单个/多个线圈（离散量输出点）状态。 功能 1 返回任意个数输出点（Q）的 ON/OFF 状态。
2 | 读取单个/多个触点（离散量输入点）状态。 功能 2 返回任意个数输入点（I）的 ON/OFF 状态。
3 | 读取单个/多个保持寄存器。功能 3 返回 V 存储区的内容。在 Modbus 协议下保持寄存器都是“字”值，在一次请求中可以读取最多 120 个字的数据。
4 | 读取单个/多个输入寄存器。功能 4 返回 S7-200 的模拟量数据值。
5 | 写单个线圈（离散量输出点）。功能 5 用于将离散量输出点设置为指定的值。这个点不是被强制的，用户程序可以覆盖 Modbus 通信请求写入的值。
6 | 写单个保持寄存器。功能 6 写一个值到 S7-200 的 V 存储区的保持寄存器中。
15 | 写多个线圈（离散量输出点）。功能 15 把多个离散量输出点的值写到 S7-200 的输出映像寄存器（Q 区）。输出点的地址必须以字节边界起始（如 Q0.0 或 Q2.0），并且输出点的数目必须是 8 的整数倍。这是此 Modbus RTU 从站指令库的限制。些点不是被强制的，用户程序可以覆盖 Modbus 通信请求写入的值。
16 | 些多个保持寄存器。功能 16 写多个值到 S7-200 的 V 存储区的保持寄存器中。在一次请求中可以写最多 120 个字的数据。

常问问题

Modbus 从站的网络地址与 S7-200 的 CPU 网络地址有什么关系？

没有关系。支持网络通信的通信协议必须有其自己的网络寻址规定。 Modbus 从站的地址只是它在 Modbus 网络上的地址，而通常所说的 S7-200 CPU 地址是 CPU 在西门子的 PPI 网络上的站地址。S7-200 CPU 的大部分通信功能都通过 PPI 网络完成，例如编程、网络读写通信等。

如何理解 Modbus 地址与功能码的区别？

Modbus 地址与 Modbus 的功能码是两个层次的概念。

根据 Modbus 通信协议，Modbus 数据的地址使用 00xxx、10xxx、30xxx 和 40xxx 的形式，分别表示数字量输出、数字量输入、模拟量输入等数据地址。在使用 S7-200 的指令库时，Modbus 数据地址与 S7-200 的 I/O 和数据存储区地址间有特定的对应关系。

有些设备表明它支持 Modbus RTU 通信协议，但也详细提供了读写数据的详细通信帧格式，其中包括如何指定 Modbus 站的地址，需要读写数据类型、长度等等。数据帧有特定字节指出此指令读写的数据类型和地址，此字节的数据内容即所谓“功能码”，如功能 1 指定读取单个/多个数字量输出点的值。

支持 Modbus 协议的设备或软件，使用时用户直接设置或看到的应当是 Modbus 数据地址。Modbus 地址所访问的数据，是通过各种“功能”读写而来。功能码是 Modbus 地址的底层。如果 Modbus 通信的一方提供的所谓 Modbus 协议只有功能码，则需要注意了解此功能号与 Modbus 地址间的对应关系。

Modbus 指令库启动后，如何通过同一个通信端口进行 CPU 监控？

Modbus 指令库使用的是 CPU 的自由口通信功能，工作在自由口模式下的通讯口不能使用 Micro/WIN 的 PPI 编程通信监控。如果通信口都已经被占用，可以考虑：

  • 加一个通信模块（如 EM 277、CP 243-1、EM 241 等）扩展出一个编程通信口
  • 中止自由口模式，可以将 CPU 上的模式开关从 RUN 拨到 STOP；或者保持处于 RUN 状态，用程序停止指令库的 Modbus 模式（参见指令库应用）

为何有些 HMI 软件使用 Modbus RTU 读取S7-200中的实数会出现错误？

有些HMI软件使用Modbus RTU通信协议时，处理存储在数据保持寄存器中的实数（浮点数）的方式与西门子的实数保存格式不同。西门子的PLC遵循“高字节低地址、低字节高地址”的规律。

Modbus RTU的保持寄存器总是以“字（双字节）”为单位，而一个实数需要4个字节（双字）表示。HMI软件在处理时可能会把保持寄存器的两个“字”互换位置，造成不能识别以西门子格式表示的实数。如果HMI软件一方无法处理这种实数，则可在S7-200 CPU中编程将存入数据缓冲区（保持寄存器区）的实数的高字和低字互换。

为何有的HMI软件用Modbus RTU可以读取作为从站的S7-200的内容，但不能写入？

可能此软件使用了Modbus功能15（写多个离散量）或类似功能（功能 16）。S7-200从站协议遵守“以整字节地址边界（如Q0.0、Q2.0）开始、以8的整数倍为位个数”的规约。如果HMI软件未严格执行此规律就可能发生写入错误的情况。

S7-200是否支持 Modbus ASCII 模式？

S7-200可以支持上述模式，但是没有现成的指令库，需要用户自己编程。

项目编译后为何出现很多错误？

使用指令库时，若编译后出现很多错误，一般是因为未指定库指令数据存储区。请参考相关条目。

S7-200 CPU的Port1是否可以支持Modbus RTU协议？

可以。用户可以自己编程实现。

在S7-200的“Tips and Tricks”帮助文档中，Tip041是Modbus RTU从站程序，用户可以参考。

S7-200是否可以组成Modbus RTU通信网络？如何组网？

S7-200可以组成RS-485基础上的Modbus RTU网络。如果通信对象是不同标准的通信口，可能还需要转换。参见：RS-485网络组成

Modbus RTU 从站例程

需要 STEP 7-Micro/WIN V4.0 SP3 以上版打开


自由口通讯

自由口通信

S7-200 CPU的通信口可以设置为自由口模式。选择自由口模式后，用户程序就可以完全控制通信端口的操作，通信协议也完全受用户程序控制。

S7-200 CPU上的通信口在电气上是标准的RS-485半双工串行通信口。此串行字符通信的格式可以包括：

  • 一个起始位
  • 7或8位字符（数据字节）
  • 一个奇/偶校验位，或者没有校验位
  • 一个停止位

自由口通信速波特率可以设置为1200、2400、4800、9600、19200、38400、57600或115200。

凡是符合这些格式的串行通信设备，理论上都可以和S7-200 CPU通信。

自由口模式可以灵活应用。Micro/WIN的两个指令库（USS和Modbus RTU）就是使用自由口模式编程实现的。

在进行自由口通信程序调试时，可以使用PC/PPI电缆（设置到自由口通信模式）连接PC和CPU，在PC上运行串口调试软件（或者Windows的Hyper Terminal－超级终端）调试自由口程序。

USB/PPI电缆和CP卡不支持自由口调试。

自由口通信要点

应用自由口通信首先要把通信口定义为自由口模式，同时设置相应的通信波特率和上述通信格式。用户程序通过特殊存储器SMB30（对端口0）、SMB130（对端口1）控制通信口的工作模式。

CPU通信口工作在自由口模式时，通信口就不支持其他通信协议（比如PPI），此通信口不能再与编程软件Micro/WIN通信。CPU停止时，自由口不能工作，Micro/WIN就可以与CPU通信。

通信口的工作模式，是可以在运行过程中由用户程序重复定义的。

如果调试时需要在自由口模式与PPI模式之间切换，可以使用SM0.7的状态决定通信口的模式；而SM0.7的状态反映的是CPU运行状态开关的位置（在RUN时SM0.7="1"，在STOP时SM0.7="0"）

自由口通信的核心指令是发送（XMT）和接收（RCV）指令。在自由口通信常用的中断有“接收指令结束中断”、“发送指令结束中断”，以及通信端口缓冲区接收中断。

与网络读写指令（NetR/NetW）类似，用户程序不能直接控制通信芯片而必须通过操作系统。用户程序使用通信数据缓冲区和特殊存储器与操作系统交换相关的信息。

XMT和RCV指令的数据缓冲区类似，起始字节为需要发送的或接收的字符个数，随后是数据字节本身。如果接收的消息中包括了起始或结束字符，则它们也算数据字节。

调用XMT和RCV指令时只需要指定通信口和数据缓冲区的起始字节地址。

XMT和RCV指令与NetW/NetR指令不同的是，它们与网络上通信对象的“地址”无关，而仅对本地的通信端口操作。如果网络上有多个设备，消息中必然包含地址信息；这些包含地址信息的消息才是XMT和RCV指令的处理对象。

由于S7-200的通信端口是半双工RS-485芯片，XMT指令和RCV指令不能同时有效。

XMT和RCV指令

XMT（发送）指令的使用比较简单。RCV（接收）指令所需要的控制稍多一些。

RCV指令的基本工作过程为：

  1. 在逻辑条件满足时，启动（一次）RCV指令，进入接收等待状态
  2. 监视通信端口，等待设置的消息起始条件满足，然后进入消息接收状态
  3. 如果满足了设置的消息结束条件，则结束消息，然后退出接收状态

所以，RCV指令启动后并不一定就接收消息，如果没有让它开始消息接收的条件，就一直处于等待接收的状态；如果消息始终没有开始或者结束，通信口就一直处于接收状态。这时如果尝试执行XMT指令，就不会发送任何消息。

所以确保不同时执行XMT和RCV非常重要，可以使用发送完成中断和接收完成中断功能，在中断程序中启动另一个指令。

在《S7-200系统手册》中关于XMT和RCV指令的使用有一个例子。这个例子非常经典，强烈建议学习自由口通信时先做通这个例子。

字符接收中断

S7-200 CPU提供了通信口字符接收中断功能，通信口接收到字符时会产生一个中断，接收到的字符暂存在特殊存储器SMB2中。通信口Port0和Port1共用SMB2，但两个口的字符接收中断号不同。

每接收到一个字符，就会产生一次中断。对于连续发送消息，需要在中断服务程序中将单个的字符排列到用户规定的消息保存区域中。实现这个功能可能使用间接寻址比较好。

对于高通信速率来说，字符中断接受方式需要中断程序的执行速度足够快。

一般情况下，使用结束字符作为RCV指令的结束条件比较可靠。如果通信对象的消息帧中以一个不定的字符（字节）结束（如校验码等），就应当规定消息或字符超时作为结束RCV指令的条件。但是往往通信对象未必具有严格的协议规定、工作也未必可靠，这就可能造成RCV指令不能正常结束。这种情况下可以使用字符接收中断功能。

常问问题

如何人为结束RCV接收状态？

接收指令控制字节（SMB87/SMB187）的en位可以用来允许/禁止接收状态。可以设置en为“0”，然后对此端口执行RCV指令，即可结束RCV指令。

需要定时向通信对象发送消息并等待回复的消息，如果因故消息没有正常接收，下次无法发送消息怎么办？

可以在开始发送消息时加上人为中止RCV指令的程序。

自由口通信中，主站向从站发送数据，为何收到多个从站的混乱响应？

这说明从站没有根据主站的要求发送消息。有多个从站的通信网络中，从站必须能够判断主站的消息是不是给自己的，这需要从站的通信程序中有必要的判断功能。

自由口通信协议是什么？

顾名思义，没有什么标准的自由口协议。用户可以自己规定协议。

新的PC/PPI电缆能否支持自由口通信？

新的RS-232/PPI电缆（6ES7 901-3CB30-0XA0）可以支持自由口通信；但需要将DIP开关5设置为“0”，并且设置相应的通信速率。

新的USB/PPI电缆（6ES7 901-3DB30-0XA0）不能支持自由口通信。

已经用于自由口的通信口，是否可以连接操作面板（HMI）？

不能。

可以使用具有两个通信口的CPU，或者使用EM277扩展HMI连接口。如果是其他厂商的HMI，须咨询他们。

已知一个通信对象需要字符（字节）传送格式有两个停止位，S7-200是否支持？

字符格式是由最基础的硬件（芯片）决定的；S7-200使用的芯片不支持上述格式。

S7-200是否支持《S7-200系统手册》上列明的通信波特率以外的其他特殊通信速率？

通信速率是由最基础的硬件（芯片）决定的；S7-200使用的芯片不支持没有列明在手册上的通信速率。


自由口入门

自由口通讯概述

S7-200PLC的通讯口支持RS485接口标准。采用正负两根信号线作为传输线路。

工作模式采用串行半双工形式，在任意时刻只允许由一方发送数据，另一方接收数据。

数据传输采用异步方式，传输的单位是字符，收发双方以预先约定的传输速率，在时钟的作用下，传送这个字符中的每一位。

传输速率可以设置为1200、2400、4800、9600、19200、38400、57600、115200。

字符帧格式为一个起始位、7或8个数据位、一个奇/偶校验位或者无校验位、一个停止位。

字符传输从最低位开始，空闲线高电平、起始位低电平、停止位高电平。字符传输时间取决于波特率。

数据发送可以是连续的也可以是断续的。所谓连续的数据发送，是指在一个字符格式的停止位之后，立即发送下一个字符的起始位，之间没有空闲线时间。而断续的数据发送，是指当一个字符帧发送后，总线维持空闲的状态，新字符起始位可以在任意时刻开始发送，即上一个字符的停止位和下一个字符的起始位之间有空闲线状态。

示例：用PLC连续的发送两个字符（16#55和16#EE）(程序如图3和图4),通过示波器测量CPU通讯端口管脚3/8之间的电压，波形如下图1.：

图1.两个字符（16#55和16#EE）的波形图

示例说明：

16进制的16#55换算成2进制等于2#01010101，16进制的16#EE换算成2进制等于2#11101110。如图所示，当数据线上没有字符发送时总线处于空闲状态（高电平），当PLC发送第一个字符16#55时，先发送该字符帧的起始位（低电平），再发送它的8个数据位，依次从数据位的最低位开始发送（分别为1、0、1、0、1、0、1、0），接着发送校验位（高电平或低电平或无）和停止位（高电平）。因为本例中PLC连续的发送两个字符，所以第一个字符帧的停止位结束后便立即发送下一个字符帧的起始位，之间数据线没有空闲状态。假如PLC断续的发送这两个字符，那么当PLC发送完第一个字符帧的停止位后，数据线将维持一段时间空闲状态，再发送下一个字符帧。

字符传输的时间取决于波特率，如果设置波特率为9.6k，那么传输一个字符帧中的一位用时等于1/9600*1000000=104us，如果这个字符帧有11位，那么这个字符帧的传输时间等于11/9600*1000=1.145ms.

通讯口初始化

SMB30（对于端口0）和SMB130(对于端口1)被用于选择波特率和校验类型。SMB30和SMB130可读可写。见下图2.

图2.特殊存储器字节SMB30/SMB130

示例：定义端口0为自由口模式，9600波特率，8位数据位，偶校验，程序如下图3.：

图3.通讯口初始化程序

发送数据

发送指令XMT能够发送一个字节或多个字节的缓冲区，最多为255个。使用边沿触发。

发送缓冲区格式：第一个字节为字符个数，其后为发送的信息字符。

示例：如果PLC连续发送2个字符16#55和16#EE,程序如下图4.：

图4.发送指令程序

示例说明：PLC通过数据块写入数据。XMT指令中TBL缓冲区首地址VB200写入发送字符的个数，VB201和VB202分别写入发送字符。通讯口波形图如图1.

判断发送完成的方法：

方法一：发送完成中断。通过连接中断服务程序到发送结束事件上，在发送完缓冲区中的最后一个字符时，则会产生一个中断。对通讯口0为中断事件9，对通讯口1为中断事件26。连接中断程序到中断事件示例如下图5.：

图5.建立发送完成中断的程序

方法二：发送空闲位。当port0发送空闲时，SM4.5=1。当port1发送空闲时，SM4.6=1.

示例：如果PLC断续的发送2个字符16#55和16#EE.

方法一：利用发送完成中断，在主程序中建立中断事件，执行XMT发送16#55,发送完成后，进入发送完成中断程序中，执行XMT发送16#EE。波形图如图6.

图6.字符波形图

方法二：利用发送空闲位。当执行XMT发送完16#55后，利用SM4.5/4.6的上升沿（确保发送的字符帧发送完成），往XMT的TBL缓冲区写入新字符16#EE，并再次触发发送。波形图如图7.

图7.字符波形图

两种方法均断续发送字符，即两个字符之间有空闲状态。注意：由于SM4.5/4.6的使用受程序扫描周期的影响，编程中推荐使用发送完成中断。

Break断点

Break状态：持续以当前波特率传输16位数据，且一直维持“0”状态。

产生方式：把字符数设置为0并执行XMT指令，可以产生一个Break状态。

Break用途：可以作为接收的起始条件。

示例：通过XMT指令发送一个Break断点。偶校验，8个数据位，9.6K。程序如下图8.：

图8.发送一个断点的程序

Break状态的波形图如下图9.

图9.一个断点波形图

如果通过接收方为上位机或者S7-200PLC，那么它们接收到的字符为16#00.

那么通过发送一个Break断点接收到的16#00与发送一个字符帧16#00有什么不同呢？Break状态是传输16位数据一直为0。而发送一个字符16#00（帧格式为1个起始位，8个数据位，偶校验和停止位）则传输11位该字符帧。如下图10.

图10.一个断点和字符0的波形图

接收数据

接收指令RCV能够接收一个字节或多个字节的缓冲区，最多为255个。使用边沿触发或第一个扫描周期触发。

接收缓冲区格式：第一个字节表示接收的字符个数，其后为接收的信息字符。

RCV使能会将TBL缓冲区中的字符个数清零。

示例：如果发送方给PLC发送2个字符16#55和16#EE,PLC的接收程序如下图11.：

图11.接收指令程序

示例说明：RCV指令TBL缓冲区的首地址VB200保存的是接收字符个数，其后是信息字符。

判断接收完成的方法：

方法一：接收完成中断。通过连接中断服务程序到接收信息完成事件上，在接收完缓冲区中的最后一个字符时，则会产生一个中断。对端口0为中断事件23，对端口1为中断事件24。连接中断程序到中断事件示例如下图12.：

图12.建立接收完成中断的程序

方法二：接收状态字节。SMB86(port0)，SMB186（port1）。

当接收状态字节为0，表示接收正在进行。

当接收状态字节不为0，表示接收指令未被激活或者已经被中止。见下图13.

图13.接收状态字节SMB86(port0)/SMB186(port1)

接收指令起始和结束条件

接收指令使用接收信息控制字节(SMB87或SMB187)中的位来定义信息起始和结束条件。必须为接收信息功能操作定义一个起始条件和一个结束条件（最大字符数）。如下图14.

图14.接收控制字节SMB87(port0)/SMB187(port1)

接收指令起始条件

接收指令支持几种起始条件：

1.空闲线检测

定义：在传输线上一段安静或空闲的时间。

当接收指令执行时，接收信息对空闲线时间进行检测。在空闲线时间到之前接收的字符，被忽略且按照SMW90/190给定的时间重新启动空闲线定时器。在空闲线时间到之后，接收的字符存入信息缓冲区。

空闲时间的典型值为在指定波特率下传输3个字符的时间。

示例：PLC接收的起始条件定义为空闲线检测（设置SMB87中的il=1,sc=0,bk=0，空闲线超时时间SMW90=10ms）;接收的结束条件定义为最大字符个数SMB94=10。程序如下图15.

图15.空闲线检测程序

示例说明：

（紫色部分：）当启动接收指令后，PLC对空闲线时间进行检测，如果在SMW90中设定的空闲线时间到之前，已经接收到了字符1，则字符1被忽略，并且按照SMW90中设定的时间重新启动空闲定时器。

（橙色部分：）同样的，如果在SMW90中设定的空闲线时间到之前，已经接收到了字符2，则字符2也被忽略且空闲线定时器重新启动。

（绿色部分：）如果在SMW90中设定的空闲线时间到之后，接收到字符3，则字符3作为第一个信息字符存入接收缓冲区。见下图16.

图16.用空闲时间检测来启动接收指令

2.起始字符检测

当接收到SMB88/188指定起始字符后，接收信息功能将起始字符作为信息的第一个字符存入接收缓冲区。

起始字符之前的字符被忽略，起始字符和其后的所有字符存入接收缓冲区。

示例：PLC接收的起始条件定义为起始字符检测（设置SMB87中的il=0,sc=1,bk=0，起始字符SMB88=16#55);接收的结束条件定义为最大字符个数SMB94=4。程序如下图17.

图17.起始字符检测程序

示例说明：PLC接收总线上传来的一串字符，16#01、16#02、16#03、16#55、16#AA、16#BB、16#CC，当PLC检测到起始字符16#55后，开始接收并将16#55作为第一个信息字符存入接收缓冲区，起始字符之前的3个字符被忽略。如下图18.

图18.用起始字符检测来启动接收指令

3.空闲线和起始字符

接收指令执行时，先检测空闲线条件，在空闲线条件满足后，检测起始字符。如果接收的字符不是起始字符，则重新检测空闲线条件。

在空闲线条件满足和接收到起始字符之前接收的字符被忽略。起始字符和字符串一起存入缓冲区。

适用于通讯连接线上有多个设备的情况。

示例：PLC接收的起始条件定义为空闲线和起始字符（设置SMB87中的il=1，sc=1，bk=0,空闲线检测时间SMW90=10ms，起始字符SMB88=16#55），结束条件为最大字符个数2.

示例说明：PLC接收总线上传来的数据，分几种情况:

当空闲线条件不满足，即使空闲后出现起始字符，PLC也不开始接收。如图19.

图19.

当PLC先检测到起始字符，再检测到空闲线条件满足，PLC不启动接收。或者当PLC检测到空闲线条件满足后，接收到除起始字符之外的任意字符，PLC也不启动接收。如图20.

图20.

只有当PLC检测空闲线条件满足后，接收到起始字符，PLC才启动接收，在空闲线条件满足和接收到起始字符之前接收的字符被忽略。起始字符和字符串一起存入缓冲区，缓冲区首地址VB200。如图21.

图21.用空闲线和起始字符来启动接收指令

4.断点检测

大于一个完整字符传输时间的一段时间内，接收数据一直为0.

在断点之前接收的字符被忽略，在断点之后接收的字符存入信息缓冲区。

示例：PLC接收的起始条件定义为断点检测（设置SMB87中的il=0，sc=0，bk=1），结束条件为最大字符个数8。

示例说明：PLC接收总线上传来的一串字符和断点，依次为16#0016#00(连续的两个字符间没有空闲)、16#0016#00（断续的两个字符间有空闲）、第一个Break断点、16#55、第二个Break断点、16#EE。当PLC检测到第一个断点状态后，启动接收，接收的字符存入信息缓冲区（第二个断点），第一个断点之前的字符被忽略。接收缓冲区起始地址为VB200。如下图22.

图22.用断点检测来启动接收指令

5.断点和起始字符

在断点条件满足后，检测起始字符。

在断点条件满足后，如果收到除起始字符外的任意字符，重新检测新的断点。

在满足断点和起始字符之前接收的字符将被忽略，起始字符和字符串一起存入信息缓冲区。

示例：PLC接收的起始条件定义为断点和起始字符（设置il=0,sc=1,bk=1,起始字符SMB88=16#55)。结束条件为最大字符个数8.

示例说明：PLC接收总线上传来的一串字符和断点，依次为16#55、break、16#AA、16#55、break、16#55、16#EE、16#FF. 分几种情况理解：

当PLC先检测到起始字符再检测到断点，PLC不启动接收。（SC+BK）

当PLC检测到断点后，接收到除起始字符外的任意字符，PLC不启动接收。（BK+Char+SC）

只有当PLC检测到断电后，紧接着检测到起始字符，才启动接收并且将起始字符和字符串一同存入信息缓冲区，断点和起始字符之前接收的字符将被忽略。（BK+SC）

如图23.

图23.用断点和起始字符检测来启动接收指令

6.任意字符。

任意字符接收是空闲线检测的特例。

设置方式：il=1，sc=0,bk=0,空闲线时间SMW90/190=0。

接收指令一执行，立即接收任意字符，并把所有接收字符存入信息缓冲区。

允许使用信息定时器监控接收是否超时。当接收指令执行时，信息定时器启动，如果没有其他终止条件满足，信息定时器超时会接收接收功能。

接收指令结束条件

接收指令支持以下一种或几种组合的结束条件：

1.结束字符检测

在起始条件之后，接收指令检查接收的所有字符，如果检测到结束字符，则将其存入缓冲区，结束接收。

示例：PLC接收的结束条件定义为结束字符检测（设置SMB87中的ec=1，定义结束字符SMB89=16#55），接收起始条件定义为起始字符检测(起始字符16#AA)。

示例说明：PLC接收总线上传来的一串字符，依次为16#AA、16#BB、16#CC、16#55、16#EE、16#FF。当PLC检测到起始字符16#AA后，启动接收，当检测到结束字符16#55后，结束接收并将接收的所有字符存入信息缓冲区。如下图24.

图24.用结束字符检测来结束接收指令

2.字符间隔定时器

字符间隔时间定义：从一个字符的结尾（停止位）到下一个字符的结尾（停止位）之间的时间。

接收到字符后，字符间隔定时器重新启动。

两个字符之间的间隔时间超过SMW92/192则结束接收。

示例：PLC接收的结束条件定义为字符间隔定时器（设置SMB87中的c/m=0，tmr=1,信息超时时间SMW92），接收起始条件定义为起始字符检测。

示例说明：PLC接收总线上传来的一串字符，当PLC满足接收条件后启动接收，接收完一个字符的停止位后，重新启动字符间隔定时器，如果检测到下一个字符帧停止位时SMW92时间未到，则重新启动字符间隔定时器，如果当SMW92时间到时还未检测到下一个字符帧的停止位，则结束接收。如下图25.

图25.用字符间隔定时器来结束接收指令

3.信息定时器

当接收启动条件一满足，信息定时器就启动，当时间超过SMW92/192指定的时间，信息定时器时间到结束接收。

示例：PLC接收的结束条件定义为信息定时器（设置SMB87中的c/m=1，tmr=1,信息超时时间SMW92），接收起始条件定义为起始字符检测。

示例说明：PLC接收总线上传来的一串字符，当PLC满足接收条件后启动接收，信息定时器启动，当SMW92时间到时，结束接收。如图26.

图26.用信息定时器来结束接收指令

4.最大字符计数

当接收字符个数达到或超过最大字符个数(SMB94/SMB194)，接收功能结束。

由于接收指令需要知道接收信息的最大长度，以保证信息缓冲区之后的数据不被覆盖，所以即使不被用作接收结束条件，也必须指定最大字符个数。

如果没有指定最大字符个数，则SM86.6/186.6=1(输入参数错误或丢失启动或结束条件)

5.校验结束

当接收字符的同时出现硬件信号校验错误时，接收指令会自动结束。

只有在SMB30/130中使能校验位，才有可能出现校验错误。没有办法禁止此功能。

6.用户结束。

通过程序结束接收功能：将SM87.7或SM187.7置为0，且需边沿触发RCV接收指令。

以上内容是通过发送和接收指令实现S7-200PLC的自由口通讯。另外，S7-200PLC还提供了通讯口字符接收中断功能。见下文。

字符中断

使用字符中断方式接收数据，接收每个字符时都会产生中断。在执行与接收字符事件相连的中断程序前，接收的字符存入SMB2寄存器中，校验状态存入SM3.0。 SMB2、SM3.0都是只读的。

Port0/Port1共用SMB2/SMB3。Port0对应于中断事件8。Port1对应于中断事件25。

SMB2使用条件：RCV指令不使能，通讯端口为自由口模式，且建立中断事件8/25。

字符中断使用方法：

以端口0接收字符为例：如图27.

图27.字符中断程序

当CPU通过端口0接收到一个字符后，会将该字符存入接收字符缓冲区SMB2，然后进入相连接的中断程序中。

注意：对于这段程序，如果在中断程序中不作任何编程，那么当CPU接收n个字符时，中断程序将被执行n次，SMB2寄存器存储接收到的最后一个字符。

如上位机通过串口调试软件给CPU发送3个字符16#AA、16#BB和16#CC，如下图28.
图28.通过串口调试软件发送字符

那么与接收字符事件相连的中断程序将被执行3次，SMB2中只能保存最后一个接收到的字符16#CC。如下图29.

图29.状态表监控SMB2

自由口通信例程：

为了更好的理解自由口的编程，可参考下面的例程。

该例程涉及到两台S7-200PLC，其中发送方向接收方发送数据，接收方接收到数据后再给发送方发送数据，如此往复。

发送方例程

自由口发送方程序：先发送3个字符'a'、'b'、'c' 到接收方，然后转为接收状态，接收到对方的3个字符'1'、'2'、'3' 后重新启动发送指令，将'd'、'e'、'f' 发送到接收方后再启动接收，随后收到3个字符'4'、'5'、'6'。然后重复上述过程。

接收方例程

自由口接收方程序：先接收3个字符'a'、'b'、'c' ，然后转为发送，给对方发出3个字符'1'、'2'、'3' 后重新启动接收指令，待收到'd'、'e'、'f' 后重新启动发送指令，发出3个字符'4'、'5'、'6'后再次转为接收状态。然后重复上述过程。

注意：此指令库/程序的作者和拥有者对于该软件的功能性和兼容性不负任何责任。使用该软件的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

常问问题：

1、用SMB接收多个字符，如何编程？

由于SMB2只能存储一个字符（一个字节），如果要想接受多个字符，则应当在CPU接收下一个字符之前，在中断程序中通过指针编程将SMB2中存储的字符移出来，以便下一次接收字符。以一个例程说明：如图30.

图30.接收多个字符的程序

VD0作为地址指针指向VB100，当端口0接收到第一个字符，将第一个字符存入SMB2，进入接收中断，将SMB2中的字符复制到指针VD0指向的地址字节VB100中，指针地址加1，VD0指向下一个字节VB101。当接收第二

个字符，将字符存入SMB2，进入接收中断，将SMB2中的第二个字符复制到指针VD0指向的地址字节VB101中，指针地址加1，VD0指向下一个字节VB102。当接收第三个字符时以此类推。

另外，如果需要接收n个字符就结束接收，或者需要接收n个字符后循环接收，可以在中断程序中设置一个标志位，下面我们试举例说明：

例程1，接收到5个字符就结束接收的程序：如图31.

图31.程序

例程2，接收到5个字符后循环接收的程序：如图32.

图32.程序

注意，程序中的的指针不要选择累加器AC，因为累加器不能在主程序和中断程序中传递参数。

2、字符中断和RCV指令之间有什么关系？

简单地说，当RCV指令使能时，接收字符不进入SMB缓冲区。

分析实验如下：

在主程序中我们既定义PLC执行RCV接收指令的起始结束条件（起始条件为起始字符16#AA，结束条件为结束字符16#BB），又建立字符中断事件8，上升沿条件触发RCV指令。

上位机通过串口调试软件给CPU发送字符。如图33.。
图33.通过串口调试软件发送字符

程序如下图34.：

图34.测试程序

状态表监控结果：如下图35.

图35.状态表监控结果

结论：

当RCV指令不触发的话，接收字符只进入SMB2缓冲区，不进入RCV指令的接收缓冲区。

当RCV指令触发后，满足CPU接收的起始和结束条件的字符存入RCV指令对应的TBL缓冲区。起始条件之前的字符既不存入RCV缓冲区，也不存入SMB2缓冲区。结束条件之后接收到的字符，存入SMB2缓冲区。


HMI－PC Access

PC Access

西门子最新推出的PC Access 软件是专用于S7-200 PLCs 的OPC Server（服务器）软件，它向OPC客户端提供数据信息，可以与任何标准的OPC Client（客户端）通信。 PC Access 软件自带OPC 客户测试端，用户可以方便的检测其项目的通信及配置的正确性。

OPC（OLE for Process Control）是嵌入式过程控制标准，是用于服务器/客户端链接的统一而开放的接口标准和技术规范。OLE是微软为Windows系统、应用程序间的数据交换而开发的技术，是Object Linking and Embedding缩写。

不同的供应商的硬件存在不同的标准和协议，OPC作为一种工业标准，提供了工业环境中信息交换的统一标准软件接口 ， 数据用户不用再为不同厂家的数据源开发驱动或服务程序。

OPC将数据来源提供的数据以标准方式传输至任何客户机应用程序。OPC（用于进程控制的OLE）是一种开放式系统接口标准，可允许在自动化/PLC应用、现场设备和基于PC的应用程序（例如HMI或办公室应用程序）之间进行简单的标准化数据交换。 定义工业环境中各种不同应用程序的信息交换，它工作于应用程序的下方。您可以在PC机上监控、调用和处理可编程控制器的数据和事件。

PC Access可以用于连接西门子，或者第三方的支持OPC技术的上位软件。

PC Access的兼容性

  • 支持OPC Data Access（DA）3.0版（Version 3.0）
  • 可以运行在Windows 2000或Windows XP
  • 可以从Micro/WIN项目（V3.x -V4.x）中导入符号表
  • 支持新的S7-200智能电缆（RS-232或USB）
  • 支持多种语言：英语、中文、德语、法语、意大利语、西班牙语

PC Access目前的版本是PC Access V1.0 SP4 。SP升级包可以在S7-200产品主页上免费下载、安装。升级包不能单独安装，安装之前须在本机上安装有正式版本。

下载地址链接：http://support.automation.siemens.com/WW/view/en/18785011/133100

PC Access可以在Microsoft的如下操作系统中安装、使用：

  • Windows 2000 SP3以上
  • Windows XP Home
  • Windows XP Professional（已通过Windows XP SP2下的测试）

PC机的硬件要求：

  • 任何可以安装运行上述操作系统的计算机
  • 最少150M硬盘空间
  • Microsoft Windows支持的鼠标
  • 推荐使用1024×768像素的屏幕分辨率，小字体

PC Access支持的硬件连接

PC Access可以通过如下硬件连接与S7-200通信：

  • 通过PC/PPI电缆（USB/PPI电缆）连接PC机上的USB口和S7-200
  • 通过PC/PPI电缆（RS-232/PPI电缆）连接PC机上的串行COM口和S7-200
  • 通过西门子通信处理器（CP）卡和MPI电缆连接S7-200
  • 通过PC机上安装的调制解调器（Modem）连接S7-200上的EM241模块
  • 通过以太网连接S7-200上的CP243-1或CP243-1 IT模块

上述S7-200的通信口可以是CPU通信口，也可以是EM277的通信口。

不支持CP5613和CP5614通信卡。

PC Access的协议连接

  1. PC Access所支持的协议：
    • PPI（通过RS-232PPI和USB/PPI电缆）
    • MPI（通过相关的CP卡）
    • Profibus-DP（通过CP卡）
    • S7协议（以太网）
    • Modems（内部的或外部的，使用TAPI 驱动器）
  2. 上述协议，除modems外，允许同时有8个PLC连接
  3. 一个PLC通信口允许有4个PC机的连接，其中一个连接预留给Micro/WIN
  4. PC Access与Micro/WIN可以同时访问CPU
  5. 支持S7-200所有内存数据类型

PC Access的特性

  • 内置的OPC测试Client端，直接将Item中的数据标签拖入Test Client窗口中，并点击工具栏中的Test Client Status按钮即可监测数据
  • 可以添加Excel客户端，用于简单的电子表格对S7-200数据的监控
  • 提供任何OPC Client 端的标准接口
  • 针对于每一标签刷新的时间戳

PC Access技术要点

  • 不能直接访问PLC存储卡中的信息（数据归档、配方）
  • 不包含用于创建VB客户端的控件
  • 可以在你的PC机上用Micro/WIN 4.0和PC Access同时访问PLC（必须使用同一种通信方式）
  • 在同一PC机上不能同时使用PC/PPI电缆、Modem或Ethernet访问同一个或不同的PLC，它只支持PG/PC-Interface中所设置的单一的通信方式
  • PC Access中没有打印工具
  • 使用同一通信通道，最多可以同时监控8个PLC
  • Item的个数没有限制
  • PC Access专为S7-200而设计，不能应用于S7-300或S7-400 PLC

使用PC Access 访问S7-200 PLC的具体配置，可在安装PC Access后，参见PC Access 中的相关在线帮助，其中有各种通信方式的详细的使用步骤。

使用PC Access

《PC Access快速入门》下载：http://support.automation.siemens.com/CN/view/zh/80922996


HMI－PC Access应用

PC Access软件概貌

S7-200 PC Access的项目与Windows Explorer相似，以树形结构排列，因此用户使用起来非常简单便捷。OPC客户测试端以列表格式显示。

图1. PC Access概貌

PC Access软件的使用

完成一个项目的配置需要完成以下五个基本步骤：

  1. 设置通信访问通道
  2. 创建PLC
  3. 创建Folder
  4. 创建Item
  5. 测试通信质量

第一步：设置通信访问通道

鼠标右键点击MicroWin进入PG/PC Interface设定通信方式，此处通信硬件以PC/PPI电缆为例。

图2. 设置PC Access的通信通道

PC Access 可与Micro/WIN共享通信路径，共享通信路径需要STEP 7 Micro/WIN V4.0以上版本。通过 CP 卡等的通信设置可参考“S7-200 编程通信”一章。

S7-200 的编程通信

第二步： 添加S7-200 CPU站点

用鼠标右键点击MicroWin，进入New PLC的右键菜单，添加一个新的S7-200 PLC站。最多可添加8个S7-200 PLC。

图3. 添加PLC站

图中：

  1. 定义PLC的名称
  2. 输入CPU的网络地址

第三步：添加Folder

鼠标右键点击所添加的S7-200 PLC的名称，进入New > Folder添加文件夹并命名。

图4. 添加Folder

这一步不是必须的，可以省略。不建立文件夹，也可以直接在PLC下从右键菜单中选择添加条目。

第四步：添加Item（条目）

鼠标右键点击文件夹，进入New > Item添加PLC内存数据的条目并定义内存数据。

图5. 添加Item

图中：

  1. 定义条目的符号名
  2. 定义内存数据地址，支持S7-200 PLC中所有内存数据
  3. 选择数据类型
  4. 选择数据的访问方式，可设为：只读、只写、读/写
  5. 定义数据的上下限
  6. 描述说明

可以从Micro/WIN的项目中直接导入符号表，则条目的符号名与项目中的符号名相对应。

第五步：用测试客户端检测配置及通信的正确性

PC Access软件带有内置的测试客户端，用户可以方便的使用它检测配置及通信的正确性。

将测试的条目拖拽到测试客户端，然后点击在线按钮使之在线，如果配置及通信正确，会显示数据值，并在Quality一栏中显示“good”，否则这一栏会显示“bad”。（如图1.之软件概貌所示）

注意：配置完成后必须保存整个配置文件。这样OPC Client（客户端）软件才能找到S7-200 OPC Server的配置。S7-200 PC Access软件创建的项目的文件扩展名是.pca（p = P，c = C，a = Access） 。

PC Access支持多种通信方式。PC Access是与Micro/WIN共享通信路径，因此凡是Micro/WIN能够访问的通信方式，PC Access都支持。

PC Access的通信方式

常问问题

为什么不能在PC Access的测试客户端中改变PLC变量的值？

PC Access的测试客户端没有这个功能，它只用于测试通信状态的好、坏。但这不影响其他OPC客户端对用PC Access配置的Item的读、写，前提是规定了相应的访问方式。

为何在定义Item时只能选择“byte”和“string”两种数据类型？

这是因为PC Access将VB作为默认的数据长度，选择VB时只支持两种数据类型。如果修改数据长度（如MW、VD等），则可以支持各种类型的数据。


通讯－PC Access

PC Access的通信方式

Pc Access软件支持多种通信方式，用户需要根据自己所使用的通信方式正确配置，才能保证OPC通信的畅通。

PC Access 可与Micro/WIN共享通信路径，因此凡是Micro/WIN能够访问的通信方式，PC Access都支持。因此在设置通信路径时（Set PG/PC Interface），只需要设置Micro/WIN的路径。

共享通信路径需要STEP 7 Micro/WIN V4.0以上版本。

用户需要根据自己所使用的通信方式正确配置，才能保证OPC通信的畅通。

以下举例说明几种通信的设置：

  • 通过PC/PPI电缆和CP卡
  • 通过以太网（CP243-1）
  • 通过MODEM（调制解调器）

PC Access的通信速度

要提高PC Access通信速度，可以从以下几方面考虑：

  1. 提高CPU口（或通信模块EM277）的波特率
  2. 减少主站的数目
  3. 设置CPU200的地址连续
  4. 调整PC Access的刷新速率

    在PC Access中从命令菜单中进入Tools>Options>Status中

    图1. 选择PC Access与S7-200通信的刷新速率

    图中：

    a. 选择手动设置
    b. 设置刷新速率，最快的速率可设置成50ms

网络通信的参数设置和优化


通讯－PC Access PPI通讯

PC Access－通过PC/PPI电缆通信

PC Access可以通过PC/PPI电缆（USB/PPI或RS-232/PPI电缆）用PPI协议与S7-200通信。

第一步：设置通信方式

在PC Access界面右侧中用鼠标右键点击MicroWin访问点，进入Set PG/PC Interface对话框，定义为PPI通信方式。

图1. 设置PC/PPI电缆通道

使用CP卡通过MPI或PROFIBUS方式的通信设置与上面步骤相似，只是在Set PG/PC Interface对话框中选择所使用的CP卡及通信协议即可 （如图2.）

图2. 选择CP卡

第二步：设置PLC的名称和网络地址

新建PLC站时，或者用鼠标右键点击PLC进入Properties（属性）可以改变PLC名称及地址：

图3. PLC站属性

图中：

  1. 命名PLC
  2. 输入CPU的网络地址。如果连接的是EM277模块，此地址应与EM277模块上的地址开关所设置的一致


通讯－PC Access以太网

PC Access－通过以太网通信

要通过以太网与S7-200 PLC通信，S7-200必须使用CP243-1（或CP243-1 IT）以太网模块，PC机上也要安装以太网网卡。

S7-200以太网通信设置

要实现以太网通信，首先要在编程软件Micro/WIN的Ethernet Wizards中完成CP243-1模板的配置：

图1. 为CP243-1模块定义IP地址及子网掩码地址

按“Next”按钮：

图2. 继续CP243-1模块配置

图中：

  1. 设置CP243-1所占用的输出字节地址

    此地址根据计算CP243-1前面的I/O所占用的Q地址字节来决定。如CP243-1安装在紧挨CPU224的0号槽，其前面输出就占用了QB0和QB1两个字节，CP243-1的地址按顺序排，即设为QB2。CP243-1模块占用一个QB输出字节。

  2. 选择连接数

    如果只跟PC Access软件通信，设置连接数为1。

再按“Next”按钮，设置CP243-1的工作模式和TSAP地址。

图3. 设置CP243-1的工作模式和TSAP地址

图中：

  1. 必须将CP243-1以太网模块配置成服务器端
  2. 接受所有客户端的连接请求
  3. 设置TSAP地址：

    TSAP（Transport Service Access Point）地址是通信连接地址，它包括两部分：

    第一部分：通信连接号，如 10
    第二部分：CP243-1模块安装在S7-200的机架/槽号，如 “00” 代表CP243-1安装在0号机架0号槽（即CPU之后的第一个模块）

    L. 本地（CP243-1）TSAP地址，自动生成，无法修改。
    R. 远程TSAP地址，即连接的远程Pc Access 所设置的地址。

TSAP地址很重要。在PC Access中设置以太网连接时也需要规定TSAP地址，而且需要与此对应。

完成以太网向导配置后需要在程序中调用以太网向导所生成的ETHx_CTRL块（如图4.），并将项目程序下装到PLC后，将PLC断电后重新上电使配置生效。

图4. 调用以太网模块控制程序

PC Access的以太网连接设置

在完成S7－200的以太网配置后，进入PC Access软件进行设置。

第一步： 设置通信通道

鼠标右键点击MicroWin访问点，进入Set PG/PC Interface对话框，选择TCP/IP协议的以太网卡。

图5. 选择本机安装的以太网卡，并且选择TCP/IP协议

第二步：设置PC Access本机的IP地址和TSAP地址

鼠标右键点击PLC进入“Properties”进行属性设置，要保证PC Access中所设的IP地址和TSAP地址与上面Micro/WIN以太网向导中所设置的一致，且要特别注意两边远程和本地的TSAP地址设置要交叉过来，才能保证正确的通信。

图6. 设置IP地址和TSAP地址

图中：

a. 设置所访问的CP243-1的IP地址

R. 设置PC Access的本地TSAP地址，与CP243-1设置的远程TSAP地址一致，即两边R.处设置的地址要一样。
L. 设置PC Access 的远程TSAP地址，与CP243-1设置的本地TSAP地址一致，即两边L.处设置的地址要一样。

这就是说两边的Local（本地）和Remote（远程）TSAP地址正好相反对应。


通讯－PC Access调制解调器

PC Access－通过Modem（调制解调器）通信

PC Access通过Modem与S7-200 PLC通信，S7-200必须使用EM241（Modem）模块，PC机上也要安装Modem。

第一步：设置Modem通信连接

鼠标右键点击MicroWin访问点，进入Set PG/PC Interface对话框，选择 PC/PPI cable（PPI），并进入 Properties（属性）/Local Connection， 勾选“Modem connection（调制解调器连接）”。

图1. 设置本地（PC机）的Modem连接

第二步： 配置本地调制解调器

鼠标右键点击MicroWin访问点，进入Modem > Configure进行配置

图3. 进入Modem Configure...

第三步：添加新的Modem连接

图4. 添加新的Modem连接

第四步：选择Modem

图5. 选择本地计算机Windows系统中的Modem

图中：

  1. 命名Modem连接
  2. 选择PC机上所使用的Modem

第五步：输入所连接的远程站电话号码

图6. 输入号码

第六步：完成Modem配置

图7. 完成Modem配置

第七步：关闭Modem连接设置窗口

图8. 已设置完成的Modem连接

第八步：启动Modem连接

PC Access软件不会自动连接Modem，需要用户自己右击MicroWin访问点操作Modem > Connect进行连接，中断连接的操作也相似。

图9. 发起Modem连接


AS-i 通讯

AS-i 通信协议简介

S7-200 通过 CP243-2 支持 AS-i 通信协议，其主站协议版本为V2.1，即可配置31个标准开关量/模拟量从站或62个A/B类开关量从站。如图1所示：

图1. 协议版本

AS-i 通信特点：

1. 通过总线直接与现场传感器/执行器进行连接二进制执行器和传感器；也可以接模拟量信号，占用多个传输周期；

2. 串行的现场总线；优势：减少电缆与而布线成本，费用降低；

3. 一个 AS-i 总线上只能有一个主站；

4. 通过ASI网络( 2芯) 实现主站与最多62个从站进行数据通讯；

5. 数据结构：4bit输入/4bit输出；

6. ASI传输速率 167 kbit/s ，即每传输1bit需要 6us 时间；

7. ASI周期：31个站周期：5ms，62个站周期：10ms；

8. 扩展ASI距离：标准从站100m，使用中继器可扩展100m，扩展插件达到200m； 使用2个中继器和3个扩展插件最多扩展600m；

9. 需要使用 30V 解耦电源；

10. 电缆：非屏蔽两线电缆，同时供电与传送数据。

网络结构

一个完整的 AS-i 网络由 AS-i 电源，AS-i 主站和 AS-i 从站组成，如图2所示：

图2. 网络基本结构

可能的网络结构有总线形、星形和树形，如图3、图4、图5所示：

图3. 总线形结构

图4. 星形结构

图5. 树形结构

扩展距离

ASI网络扩展设备：

1. ASI repeater 功能：再生信号+提供电流，可以扩展100m；因ASI网络循环时间要求：5ms/10ms ，一个串行网络最多仅有 2个 repeater，扩展到300M；

2. 扩展插件：扩展 200m 检测ASI网络电压，无源器件，即终端电阻功能。

3. 使用 2 个 Repeater，3个 扩展插件时，网络最长距离 600m。

可能的扩展长度如图6、图7、图8、图9所示：

图6. 无任何扩展设备

图7. 配置两个中继器

图8. 配置一个扩展插件

图9. 配置两个中继器和三个扩展插件

参考资料

西门子 AS-i 通信系统手册：

http://support.automation.siemens.com/CN/view/zh/26250840

详细的 AS-i 协议和规范，请查看如下网址：

http://www.doc88.com/p-863110118858.html


AS-i 通讯

如何通过 CP243-2 与 AS-i 从站通信

要实现 CP243-2 的 AS-i 通信，需要：

1. PC 机上安装有 STEP7-Micro/WIN(V3.2 以上)软件；

2. 能够通过 PC/PPI 电缆与 CPU 做通信编程；

3. S7-200 CPU，CP243-2 模块，AS-i 从站模块；AS-i 电源。

1. 如何设置 AS-i 从站地址

在 AS-i 总线上每一个AS-i 从站都有一个唯一的地址（新购买的从站模块默认地址为0），则需要对 AS-i 从站设置地址，有以下三种方式。

方法1：使用编址器对每一个从站进行编址，编址器订货号为：3RK1 904-2AB01；外观如图1所示：

图1. 编址器

方法2：使用 CP243-2 配置向导对从站设置地址，通过向导设置从站地址；

方法3：通过编程，使用命令控制字修改从站地址，通过指令编程设置从站地址；

注意：新的 AS-i 从站出厂的默认地址为0，则使用方法2和方法3给新从站设置地址时，每次操作只能设置一个新从站（新从站默认地址为0），并保证新地址在 AS-i 总线上是唯一的。

2. 使用 CP243-2 实现 AS-i 通信向导配置

CP243-2 模块是 S7-200 系列产品中唯一一款 AS-i 主站模块，如果想通过该模块与 AS-i 从站模块实现通信，如何通过向导配置呢？下面将对 CP243-2 模块的向导配置做详细描述。

本例中使用 CP243-2 模块访问一块地址为2的 4DI 模块（订货号：3RK1200-0CE00-0AA2）和一块地址为3的 4AI 模块（订货号：3RK1207-2BQ44-0AA3），具体步骤如下。

首先，通过 PC/PPI 电缆使 PC 机与 S7-200 通信成功，然后进入工具中的“AS-i 向导”配置界面，选择“映射 AS-i 从站“，”如图2所示：

图2. AS-i 向导

点击”读取模块“，根据提示，需将 CPU 设置为 STOP 模式，读取到 AS-i 主站模块位置后，选择模块，点击”下一步“，如图3所示：

图3. 选择AS-i 主站模块位置

AS-i 模块被正确读取信息后，可显示该模块需要占用的 IO 起始地址，如图4所示：

图4. AS-i 主站模块占用的 IO 起始地址

说明：状态字含义请查看 CP243-2 手册章节2.3.3；控制字节含义请查看 CP243-2 手册章节2.3.4。

接着，选择从站类型；本例中连接了一块模拟量模块，如图5所示勾选“模拟量从站”选项。

图5. 选择模拟量从站选项

点击“下一步”，可查看总线上连接的从站类型及其通道的符号名称，同时，在此可修改这些符号名称，如图6所示：

图6. 确认从站各通道的符号名

分配 AS-i 模块运行时需要存储区，该存储区不能被其他用户程序修改，否则导致 AS-i 通信故障，如图7所示：

图7. 为 AS-i 主站模块分配存储区

到此，AS-i 向导配置完毕。

3. 读取 IO 数据

可通过如下两种方法读取 AS-i 从站的 IO 数据。

方法1：通过 AS-i 向导生成的符号表直接访问 IO 数据；只需要调用指令块 “ASIx_CTRL” 即可，如图8所示：

图8. 调用指令块 “ASIx_CTRL”

通过向导生成的符号表查看从站的 IO 符号，再进入状态表中进行监控，如图9所示：

图9. 通过向导生成的变量监控从站 IO 数据

方法2：通过读取 CP243-2 数据记录的方式访问 IO 数据；

CP243-2 模块手册，章节 3.1.1 说明了通过 Bank=0 数据记录区域可以读取开关量信号，“m” 为对应的指针偏移起始地址，如图10所示：

图10. 开关量信号对应的数据记录区域

CP243-2 模块手册，章节 3.2.1 说明了通过 Bank=32~47 数据记录区域可以读取模拟量信号，每一个 Bank 区域包含8个模拟量通道，如图11所示：

图11. 模拟量信号对应的数据记录区域

通过 AS-i 向导生成的指令块 “ASIx_READ” 读取 Bank 数据记录区域，如图12所示：

图12. 调用指令块 “ASIx_READ”

最后，通过状态表监控从站的 IO 数据， 如图13所示：

图13. 监控从站 IO 数据


AS-i 修改从站地址

修改 AS-i 从站地址

1、通过向导设置 AS-i 从站地址

首先，通过 PC/PPI 电缆使 PC 机与 S7-200 通信成功，然后进入工具中的“AS-i 向导”配置界面，选择“改变 AS-i 从站地址“，”如图1所示：

图1. 选择“改变 AS-i 从站地址“

选择需要修改地址的 AS-i 从站，设置新地址，点击“改变”按钮，如图2所示：

图2. 改变 AS-i 从站地址

修改地址成功后，通过 CP243-2 模块上的指示灯可看到2号站指示灯闪烁（因2号站已不存在），按“Display”按钮切换查看，看到10号站指示灯也闪烁（因10号站是新加入的站点）；同时 CP243-2 的 CER 指示灯黄色常亮（配置错误），可将 CPU 置于 stop 模式，按 CP243-2 上的“SET”按钮重新读取 AS-i 从站的配置信息。

待 CP243-2 CER 指示灯熄灭，点击图2中的“上一步”按钮返回，再次点击“下一步”按钮进入修改 AS-i 从站地址的界面，通过“选择从站”的下来按钮可以查看当前在线的从站地址，如图3所示：

图3. 确认2号站已经修改为10号站

也可以通过按“Display”按钮查看当前在线的从站地址；如何通过模块上 LED 指示灯查看在线的从站，请查看 CP243-2 手册章节 1.8.2。

2、通过指令编程设置 AS-i 从站地址

首先，已经使用 CP243-2 配置向导完成模块配置；然后通过指令“ASIx_WRITE”发送命令修改从站地址，每次操作仅能修改一个从站地址，编程如图4所示：

图4. 将2号站修改为4号站

修改地址成功后，通过 CP243-2 模块上的指示灯可看到2号站指示灯闪烁（因2号站已不存在），而4号站指示灯也闪烁（因4号站是新加入的站点）；同时 CP243-2 的 CER 指示灯黄色常亮（配置错误），可将 CPU 置于 stop 模式，按 CP243-2 上的“SET”按钮重新读取 AS-i 从站的配置信息。


EM241调制解调器模块

EM241调制解调器（Modem）模块

EM241是一个支持V.34标准（33.6K）的10位调制解调器，作为扩展模块挂在S7-200 CPU上。EM241必须用在模拟的音频电话系统中，可以是公共电话网，也可以是小交换机系统。EM241上设置了标准的RJ11电话接口。EM241不支持与11位调制解调器通信。

EM241只支持模拟音频电话系统，不支持数字系统（如ISDN）。

EM241需要STEP 7-Micro/WIN32 V3.2 SP1版本以上的编程软件才能支持。Micro/WIN中包括一个Modem Expansion Wizard（Modem调制解调器向导）用来对EM241配置编程。

EM241的主要作用是：

  • 通过电话网进行远程的编程、诊断等工作。编程计算机上必须安装调制解调器
  • 通过电话网进行S7-200 CPU之间的数据通信
  • 通过电话网进行S7-200 CPU与上位计算机软件间的通信

EM241支持两种通信协议：

  • PPI协议：用于远程编程、调试，以及CPU之间的通信
  • Modbus RTU从站协议：支持与上位计算机的通信

如果需要关于EM241的详细应用指导，可访问客户支持部网站上的“下载中心”网页，在“可编程控制器（PLC）”目录中下载《EM241应用快速入门》 [image] 。

EM241 使用入门

EM241 快速入门指南包括：

  • 使用STEP 7-Micro/WIN通过EM241连接至S7-200 CPU

  • EM241与EM241之间进行通信

  • EM241与上位机之间的通信

该篇文档的下载链接：https://support.industry.siemens.com/cs/cn/zh/view/7968454

常问问题

EM241如何设置国家代码？

应该根据设备应用的地点设置EM241上的国家代码。 国家代码设置旋钮设定后，在模块上电后起作用。未在下列代码表中列出的并不是就不能用EM241——许多国家的公共电话系统标准是一样的。

表1. EM241所支持的国家

开关设置 | 国家地区 | 电信标准
00 | 澳大利亚 | ACA TS-002
01 | 奥地利 | CTR21
02 | 比利时 | CTR21
05 | 加拿大 | IC CS03
06 | 中国 | GB3482
08 | 丹麦 | CTR21
09 | 芬兰 | CTR21
10 | 法国 | CTR21
11 | 德国 | CTR21
12 | 希腊 | CTR21
16 | 爱尔兰 | CTR21
18 | 意大利 | CTR21
22 | 卢森堡 | CTR21
25 | 荷兰 | CTR21
26 | 新西兰 | PTC 200
27 | 挪威 | CTR21
30 | 葡萄牙 | CTR21
34 | 西班牙 | CTR21
35 | 瑞典 | CTR21
36 | 瑞士 | CTR21
38 | 英国 | CTR21
39 | 美国 | FCC Part 68

国家代码设置后，必须重新给CPU上电，新的设置才起作用。

使用EM241回拨是什么意思？

回拨的意思就是在进行远程编程、诊断服务时，经过验证后（可以设置密码）EM241自动挂断，然后自动拨通配置中预先设定的电话号码，接通编程计算机。本质上是节省编程方的长途电话费，并且能在安全上增加保障。

回拨功能必须在设备出厂前预先配置并且下载到CPU内。

EM241是否能够发寻呼和SMS短消息？

关键在于国内是否有寻呼与GSM无线网络服务提供商提供此类服务项目。请咨询当地的服务提供商。

EM241是否会自动挂断电话？

执行远程编程、诊断任务时，无论作为被叫还是主叫方（启用回拨功能），EM241都不会主动挂断电话。

如果用作CPU之间通信，主叫方的EM241 会在数据传送完成后立即挂断电话。S7-200之间通过EM241的通信不能长期保持线路连接。

电话系统中没有规范的拨号音，EM241不能接通怎么办？

对于EM241之间的通信，在使用EM241配置向导过程中，选择“允许不等待拨号音拨号”。

图1. 配置向导界面

以上的设置用于EM241之间的通信，即两个（或多个）EM241连接到的电话网没有规范的拨号音。

如果想要实现通过Modem和远程EM241的编程通信，可在编程计算机的调制解调器属性设置的“常规”标签中，取消“拨号前等待拨号音”功能。如图2所示：

图2. Modem属性设置

以上的设置是针对使用PC机上的Modem进行远程编程的情况，本地PC机上的Modem和远程的EM241连接到没有规范的拨号音的电话网上。

如果需要拨分机号码，如何让EM241操作？

用户在使用Modem Expansion Wizard时， 可以按F1键进入向导程序的详细帮助。其中包括在电话号码区域中的字符意义定义。用户可设置等待时间，或者等待拨号音等属性。


MD720_1_getting_start

MD720简介

图1 MD720

订货号： 6NH9720-3AA01-0XX0
SIPLUS订货号：6AG1720-3AA01-7XX0

MD720如图1所示，作为MD720-3（6NH9720-3AA00-0XX0）的替代型号，在国内主要是用来和S7-200连接，实现S7-200收发短消息或者S7-200的远程监视数据。

此外还可以连接S7-200 SMART，ET200 串口CP，S7-1200 串口CP，实现西门子全系列CPU的收发短消息的功能。

以及连接CP340/CP341、ET200S 1SI实现S7-300的远程监视修改数据。

MD720在国内使用，需要配移动或联通的电话卡，不限2G、3G、4G，如果是使用远程监视数据的功能，则需要SIM卡开通GPRS功能。

MD720有2种模式：

1. 终端模式，也是出厂默认模式，主要用于发短消息

2. OPC模式，主要用于远程监视数据

OPC模式时，需要在中心站中安装OPC服务器与作为远程站的MD720通信。OPC 服务器一般选用 TeleControl Server Basic（以下简称TCSB），也可以使用SINAUT ST7cc、SINAUT ST7sc、SINAUT MICRO SC等。

MD720手册链接：https://support.industry.siemens.com/cs/cn/zh/view/102401328

TCSB软件手册链接：https://support.industry.siemens.com/cs/cn/zh/view/107536367

MD720的安装和连接

设备前面和后面图，如图2所示：

图2 MD720的前面和后面视图

1 X3：24 VDC 电源连接器（设备底部）
2 X2：用于连接天线的 SMA 插座
3 LED
4 SET 按钮
5 X1：用于连接本地站点或PC的串行接口 (RS-232)
6，9 用于DIN 导轨/配电柜固定支架
7 带有 SIM 卡卡托的 SIM 卡插槽
8 用于弹出 SIM 卡卡托的按钮

MD720安装：DIN35导轨水平或垂直安装。

SIM卡：联通或移动的SIM卡，插在MD720后面的卡托中。目前市售的SIM卡都是MICRO SIM卡或者NANO SIM卡，而MD720需要使用的原始的SIM卡，俗称的“大卡”，建议到运营商处获取原始的SIM卡。

S7-200和MD720之间的连接线可以是以下任意一种：

  • S7-200的编程电缆（订货号：6ES7901-3CB30-0XA0），长5m。
  • SINAUT PPI MODEM CABLE（订货号：6NH9701-0AD），长1.5m，和编程电缆相比只有长度不同。

电缆RS232端接在MD720 X1；而RS485端接在S7-200集成口，如果是收发短消息，可以接在S7-200集成的0口或者1口，如果是远程监视修改数据，只能接在S7-200集成的0口。
电缆拨码见表1：

表1 PPI电缆拨码

开关编号 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
位置 | 1 | 1 | 1 | 0 | 0 | 1 | 1 | 0

MD720电源：DC24V

天线：可以使用以下天线：ANT794-4MR（订货号：6NH9860-1AA00，电缆长5m，支架安装，图3左边），或ANT794-3M（订货号：6NH9870-1AA00，电缆长1.2m，水平放置，图3右边）。

图3 天线示意图

MD720的指示灯状态

表2 MD720终端模式LED的状态含义

终端模式
LED | 状态 | 含义
全部 | 按顺序闪烁和熄灭（快速） | 设备启动
所有LED同步缓慢闪烁 | 维护模式
按顺序闪烁和熄灭（缓慢） | 加载固件文件
所有LED同步快速闪烁 | 错误
STATUS | 缓慢闪烁 | 等待PIN输入
快速闪烁 | PIN错误/SIM错误
QUALITY | 缓慢闪烁（有规律） | 拨号到GSM网络
暂停后闪烁一次 | 场强不足
暂停后闪烁两次 | 场强适中
暂停后闪烁三次 | 场强良好
点亮 | 场强非常好
熄灭 | 等待PIN
CONNECT | 闪烁（有规律） | 终端模式已激活
  • 缓慢闪烁：1次/秒
  • 快速闪烁：4次/秒

表3 MD720OPC模式LED的状态含义

OPC模式
LED | 状态 | 含义
全部 | 按顺序闪烁和熄灭（快速） | 设备启动
所有LED同步缓慢闪烁 | 维护模式
按顺序闪烁和熄灭（缓慢） | 加载固件文件
所有LED同步快速闪烁 | 错误
STATUS | 缓慢闪烁 | 等待PIN输入
快速闪烁 | PIN错误/SIM错误
熄灭 | 无GPRS连接
点亮 | 存在GPRS连接
QUALITY | 缓慢闪烁（有规律） | 拨号到GSM网络
暂停后闪烁一次 | 场强不足
暂停后闪烁两次 | 场强适中
暂停后闪烁三次 | 场强良好
点亮 | 场强非常好
熄灭 | 等待PIN
CONNECT | 熄灭 | 无服务器连接
缓慢闪烁 | 正在建立与OPC服务器的连接
点亮 | 已建立与OPC服务器的连接
闪烁不规律 | 数据传送（传输数据流的同时LED闪烁）
  • 缓慢闪烁：1次/秒
  • 快速闪烁：4次/秒


MD720_2_tcsb

TCSB软件简介

TCSB 软件通过 Internet 可将最多 5000 个 SIMATIC S7站连接至中心站。
在中心站，TCSB 作为OPC服务器（OPC DA、OPC UA）可连接到 OPC客户端。这意味着广泛分布的远程解决方案可以在各种不同的领域和应用中实施，实现分布式工程设计，一台服务器上管理的功能。
以下 SIMATIC S7站可连接至TCSB软件：

  • S7-200+MD720、S7-200+MD720-3
  • S7-300+MD720
  • S7-1200+CP124x-7、S7-1200+CP1243-1
  • RTU3030C
  • CP1542SP-1

TCSB软件从V3.0版本开始支持S7-200+MD720，截止2017.09最新版本为V3.0+SP3。

V3.0+SP3的软件支持以下操作系统：

  • Windows 7（专业版、旗舰版、企业版） + Service Pack 1（32/64 位）
  • Windows 7 Embedded 32 位
  • Windows 8.1 专业版 64 位
  • Windows 10（专业版、企业版）64 位
  • Windows Server 2008 R2 Standard +Service Pack 1 64 位
  • Windows Server 2012 R2 Standard 64 位

TCSB的订货号根据其所连接的SIMATIC S7站点数确定：

普通授权

  • 8站点 6NH9910-0AA21-0AA0
  • 32站点 6NH9910-0AA21-0AF0
  • 64站点 6NH9910-0AA21-0AB0
  • 256站点 6NH9910-0AA21-0AC0
  • 1000站点 6NH9910-0AA21-0AD0
  • 5000站点 6NH9910-0AA21-0AE0

强化授权

  • 8站点 => 32站点 6NH9910-0AA21-0AB1
  • 32站点 => 64站点 6NH9910-0AA21-0AF1
  • 64站点 => 256站点 6NH9910-0AA21-0AC1
  • 256站点 => 1000站点 6NH9910-0AA21-0AD1
  • 1000站点 => 5000站点 6NH9910-0AA21-0AE1

升级授权：

从 V2 到 V3 6NH9910-0AA21-0GA0

TCSB的安装

TCSB所在的计算机需符合上述操作系统的要求。

安装步骤：

1. 将软件 DVD 插入计算机的 DVD 驱动器。

2. 在 DVD 驱动器的文件管理中，转至"setup.exe"文件。

3. 双击"setup.exe"文件开始安装。将打开安装向导。

4. 选择相应选件：
– Server PC 一般选择此项，如图1所示

图1 安装选件
– Client PC 适用于不在服务器上的附加客户端PC 和 OPC 客户端PC的选件

5. 安装期间，"Database settings and certificates"(数据库设置和证书)对话框将打开，如图2所示。
此时需设置一个数据库密码，要求至少1个小写字母，1个大写字母，1个字符，1个数字，最少8位，该密码仅用于通过微软工具打开数据库时使用，TCSB不使用该密码。

图2 数据库设置

6. 安装完成后，导入授权。

7. 点击“开始>所有程序>Siemens Automation>SIMATIC>TCS Basic>Config and Monitoring Tool”，显示登录对话框，如图3所示。

图3 初次登陆页面

8. 默认用户名为administrator，默认密码为0000。

9. 登录后需要修改该登录密码，如图4所示，之后登录使用修改后的登录密码。

图4 修改密码页面

10. 设置软件语言为中文，如图5所示。

图4 修改软件语言


MD720_3_opc

S7-200远程监视库文件说明

S7-200远程监视库如下：

sinautmicrosc

sinautmicrosc_sec

该库有两种，版本与兼容性见表1：

表1 SINAUT库版本与兼容性

 | 兼容的设备 |  | 程序存储要求 |  | 软件要求
 | MD720-3 | MD720 | 带WDC_INIT | 带WDC_INIT_2
SINAUT MICRO SC V2.0 | 支持 | 支持 | 6566 BYTE | 6571 BYTE | SINAUT MICRO SC与TCSB
SINAUT MICRO SC SEC V2.0 | - | 支持 | - | 6529 BYTE | TCSB V3.0

与 SINAUT MICRO SC 库相比，SINAUT MICRO SC SEC 库可通过加密传输提供更高的安全性。

这两个库添加至STEP 7-Micro/WIN后如图1所示：

图1 S7-200 SINAUT库

这两个库均需要占用657个字节的库存储区，该区域不能和其它区域有冲突。

库中的WDC_CHECKSUM在其余程序块内部使用，在程序中无需专门调用，其余块在程序中需全部调用（SINAUT MICRO SC的初始化只需要调用其中任意一个）。

这两个库从程序的引脚上来看只有初始化块有细微的差别，其余块的引脚完全一样，说明如下：

1.初始化/WDC_INIT和WDC_INIT_2

SINAUT MICRO SC 的初始化包括2个块：WDC_INIT和WDC_INIT_2，使用时只需要调用其中任意一个即可。

SINAUT MICRO SC SEC 的初始化只包括1个块：WDC_INIT_2。

如使用WDC_INIT，初始化只能发生在CPU重启。

初始化块参数见表2，其中底色为黄色的引脚在TCSB中有对应设置，底色为蓝色的引脚与路由器相关，底色为红色的引脚与SIM卡相关。

表2 初始化块参数

引脚 | 类型 | 数据类型 | 说明
EN | INPUT | BOOL | 使能端，通常为SM0.0
INIT_START | INPUT | BOOL | WDC_INIT_2使用的初始化，沿触发
STATION_NUMBER | INPUT | WORD | 本站地址，1-8000
IP_ADDRESS_CE | INPUT | DWORD | 中心站IP或域名，输入为字符串
DESTPORT_CS | INPUT | DWORD | 中心站端口号，输入为字符串
MODEM_NAME | INPUT | DWORD | MD720站名称，格式为“MODEM站地址”，输入为字符串
MODEM_PASSWORD | INPUT | DWORD | MD720遥控密码，输入为字符串
PIN | INPUT | DWORD | SIM卡PIN码，输入为字符串，国内SIM卡默认为1234
APN | INPUT | DWORD | 接入点名称，输入为字符串，移动SIM卡通常为cmnet，联通SIM卡通常为3gnet
AP_USER | INPUT | DWORD | 通过APN登录的用户名，输入为字符串，国内使用通常为空
AP_PASSWORD | INPUT | DWORD | 通过APN登录的密码，输入为字符串，国内使用通常为空
DNS | INPUT | DWORD | DNS地址，输入为字符串，IP_ADDRESS_CE输入域名时使用
CLIP | INPUT | DWORD | 授权拨号到站的电话号码列表，输入为字符串，国内使用为空
BUSY | OUTPUT | BOOL | 状态：忙
DONE | OUTPUT | BOOL | 状态：完成
ABORTED | OUTPUT | BOOL | 状态：放弃
ERROR | OUTPUT | WORD | 错误代码

2.发送/WDC_SEND

表3 发送块参数

引脚 | 类型 | 数据类型 | 说明
EN | INPUT | BOOL | 使能端，通常为SM0.0
START | INPUT | BOOL | 发送命令的触发，沿触发
REMOTESTATIONADDRESS | INPUT | WORD | 发送命令的目标站地址（发送给中心站为0）
DATA_START | INPUT | WORD | 发送命令中读写数据的起始地址
DATA_LENGTH | INPUT | BYTE | 发送命令中读写数据的长度（<=230）
COMMAND | INPUT | WORD | 发送命令：1：写、2：读
CURRENTTIME | INPUT | DWORD | 发送本站时钟时为时钟起始地址，0为不发送时钟
BUSY | OUTPUT | BOOL | 状态：忙
DONE | OUTPUT | BOOL | 状态：完成
ABORTED | OUTPUT | BOOL | 状态：放弃
ERROR | OUTPUT | WORD | 错误代码

3.接收/WDC_RECEIVE

表4 接收块参数

引脚 | 类型 | 数据类型 | 说明
EN | INPUT | BOOL | 使能端，通常为SM0.0
NEWTIME | INPUT | DWORD | 用于写入数据中时钟存储的地址，0为不接收时钟
RECVBUFFER_START | INPUT | WORD | 允许远程站或中心站写入的数据区的起始地址
RECVBUFFER_LENGTH | INPUT | WORD | 允许远程站或中心站写入的数据区的长度
REMOTESTATIONADDRESS | OUTPUT | WORD | 接收到数据的来源的站地址
DATA_START | OUTPUT | WORD | 接收到数据的来源的起始地址
DATA_LENGTH | OUTPUT | BYTE | 接收到数据的来源的数据长度
NEWTIME_RECEIVED | OUTPUT | BOOL | 接收到新时钟

4.模式切换/WDC_CONTROL

一般情况下，只有MD720同时实现短消息与远程监视两种功能才需要修改其中参数。

表5 模式切换块参数

引脚 | 类型 | 数据类型 | 说明
EN | INPUT | BOOL | 使能端，通常为SM0.0
ACT_GPRS_SERVICE | INPUT | BOOL | 切换到OPC模式，沿触发
ACT_AT_MODE | INPUT | BOOL | 切换到终端模式，沿触发
DELAY_TIME_GPRS | INPUT | WORD | 从终端模式切换到OPC模式的延迟时间，单位秒
MAX_TIME_AT | INPUT | WORD | 保持在终端模式的最长时间，0为不自动切换回OPC模式，单位秒
INT_MODE | INPUT | WORD | 模式：1：OPC模式、2：初始化、3：AT命令模式、4：CSD通信
BUSY | OUTPUT | BOOL | 状态：忙
DONE | OUTPUT | BOOL | 状态：完成
ABORTED | OUTPUT | BOOL | 状态：放弃
ERROR | OUTPUT | WORD | 错误代码

S7-200通过MD720实现远程监视数据

如图2所示，需要以下配置可以实现S7-200通过MD720远程监视数据。

图2 S7-200通过MD720远程监视数据硬件配置

远程：

1. S7-200CPU，可以使用CPU224、CPU224XP、CPU226（例子中使用CPU 224XP）

2. MD720+开通GPRS功能的联通/移动 SIM卡（例子中使用移动SIM卡）

3. 连接在MD720上的天线（例子中使用ANT794-4MR）

4. MD720与S7-200CPU之间的连接电缆（例子中使用S7-200的编程电缆）

中心站：

1. 安装TCSB软件及其授权的电脑

2. 该电脑能够上网，有固定外网IP或者域名

3. 该电脑安装OPC客户端的软件（例子中使用TIA博途 WINCC Professional V14 RT）

步骤如下：

1. S7-200CPU编写程序（例子中使用SINAUT MICRO SC SEC库）

库存储区分配为VB0～VB656，程序参见图3

图3 MD720程序

固定IP方式与域名解析方式的数据块，参见图4：

图4 固定IP方式与域名解析方式的数据块

2. TCSB设置

（1）登录，设置端口号，同程序中数据块的参数，参见图5

图5 TCSB端口号

（2）添加站点

1）新建项目，参见图6

图6 TCSB添加新项目

2）定义项目名称、编号、服务器密码，此处的密码可以随意定义，其他地方用不到，参见图7。

图7 TCSB项目名称

3）添加连接，参见图8

图8 TCSB添加连接

①点击添加

②选择S7-200 MD720(Secure)，对应程序使用的SINAUT MICRO SC SEC库

③点击添加连接

④站名称为数据块中的站名称MODEM1

⑤站编号对应初始化指令STATION_NUMBER为1

⑥遥控密码为数据块中密码1234，重复密码处再次输入

⑦点击确定，之后显示图9

图9 TCSB显示已组态的连接

（3）其他设置与激活

1）通信监视设置，参见图10

图10 TCSB通信监视设置

①保持连接超时：单位分钟，当OPC服务器和MD720之间超过该时间没有数据传输，则发送探测帧检测连接是否中断，默认为15分钟；

②容差时间：单位分钟，探测帧的允许返回时间，即探测帧发出后超过该时间没有收到返回帧，即认为连接中断，默认为1分钟；

例子中使用默认设置。

2）周期性服务设置，参见图11

图11 TCSB周期性服务设置

①循环时间，单位分钟，当激活③或④的选项生效，为③或④的循环时间，默认为360分钟；

②开始时间，当激活③或④的选项生效，为③或④循环开始的系统时间，24小时制，默认为00:00；

③激活该选项，则中心站定时读取远程站的数据，默认不激活；

④激活该选项，则中心站定时向远程站发送UTC时钟，默认不激活；

例子中使用默认设置。

3）激活

选择保存并激活，可以在其中继续添加新的站点，参见图12。

图12 TCSB激活

如图13所示，此时该项目已激活，OPC服务器已启动，但是OPC服务器与MD720的连接没有建立，状态为 [image] 。

图13 TCSB没有建立连接

建立连接后如图14所示，状态为 [image] 。

图14 TCSB建立连接

3. 电脑IP地址设置，参见图15

图15 电脑IP设置

4. 路由器设置

以测试所用TP-LINK的路由器为例，不同的路由器设置方式不同，相关设置请咨询路由器厂家：

（1）固定IP与域名：

1）中心站有固定外网IP，参见图16

图16 固定外网IP

该IP地址即对应前面通过固定IP方式的程序中的IP_ADDRESS_CS。

2）中心站有域名，参见图17

图17 路由器登录域名

该域名信息即对应前面通过域名解析方式的程序中的IP_ADDRESS_CS。域名解析的DNS服务器使用前一张图中的DNS服务器地址。

（2）设置端口转发

将26862端口数据包转发至IP地址为192.168.1.100的中心站，参见图18。

图18 路由器设置端口转发

5. OPC客户端设置

（1）中心站TIA博途网络视图中添加WINCC RT Professional，参见图19

图19 TIA博途添加WINCC RT Professional

（2）建立新连接

添加新连接，通信驱动程序选择OPC，OPC服务器的名称选择“OPC服务器>本地服务器>OPC.SimaticNET.TCSB”，参见图20

图20 添加OPC连接

（3）HMI变量表中添加新变量

1）在地址的下拉框中找到所选的变量ID类型后填充，DB1和S7-200的V区一一对应，参见图21。

图21 变量表中浏览到MD720

2）输入变量

图22中为VB1000，VB1001，VW1002，VW1004，VD1006，VD1010，VD1014

图22 变量表中输入变量

（4）将画面下载后运行，参见图23

图23 WINCC和S7-200对照


MD720_4_sms

S7-200通过MD720短消息说明

S7-200 0口和1口的短消息库如下：

set5_s7-200-library_port0

set5_s7-200-library_port1

这两个库添加至STEP 7-Micro/WIN后如图1所示：

图1 MD720 SMS库

该库需要占用227个字节的库存储区，该区域不能和其它区域有冲突。

对于发短消息，无需调用SMS_tele_handle（本文不做介绍）。库中的SMS_xmt_rcv_manage在其它程序块内部使用，在程序中无需调用，SMS_init，SMS_send，SMS_receive在程序中需全部调用。

程序在只调用SMS_init，SMS_send，SMS_receive后，大小为2.6Kbyte。

指令说明如下：

1. 初始化/SMS_init

表1 初始化块参数

引脚 | 类型 | 数据类型 | 说明
EN | INPUT | BOOL | 使能端，通常为SM0.0
SMS_init_start | INPUT | BOOL | 初始化，沿触发
SMS_init_pin | INPUT | DWORD | SIM卡PIN码，输入为字符串，国内SIM卡默认为1234
SMS_init_ssc | INPUT | DWORD | 短消息服务中心号码，输入为字符串，需要咨询SIM卡所在地的运营商
SMS_init_busy | OUTPUT | BOOL | 状态：忙
SMS_init_done | OUTPUT | BOOL | 状态：完成
SMS_init_aborted | OUTPUT | BOOL | 状态：放弃
SMS_init_ststus | OUTPUT | WORD | 状态代码

正常初始化完成后，状态代码SMS_init_ststus=15。如果SMS_init_aborted=True，则要根据SMS_init_status检查错误。

表2 SMS_init_ststus列表

数值 | SMS_init_ststus
1 | 初始化端口
2 | 关闭回显
3 | 关闭回显成功
4 | 关闭回显失败
5 | 查询PIN码状态
6 | PIN码OK
7 | 需要设置PIN码
8 | 设置PIN码
9 | PIN码设置成功
10 | PIN码设置失败
11 | 设置短消息模式
12 | 短消息模式设置成功
13 | 短消息模式设置失败
14 | 输入短消息服务中心号码
15 | 短消息服务中心号码输入成功
16 | 短消息服务中心号码输入失败
17 | 关闭回显成功，但需将波特率设置成9600kbps
18 | 设置MD720波特率为9600kbps
19 | 设置MD720波特率为9600kbps成功
20 | 设置MD720波特率为9600kbps失败
21 | 初始化超时

2. 发送/SMS_send

表3 发送块参数

引脚 | 类型 | 数据类型 | 说明
EN | INPUT | BOOL | 使能端，通常为SM0.0
SMS_send_start | INPUT | BOOL | 发送使能，沿触发
SMS_send_tn | INPUT | DWORD | TXT模式为目的手机号码，PDU模式为消息长度，输入为字符串
SMS_send_msg | INPUT | DWORD | 发送的内容，输入为字符串，不超过160个字符
SMS_send_busy | OUTPUT | BOOL | 发送中
SMS_send_done | OUTPUT | BOOL | 发送完成
SMS_send_aborted | OUTPUT | BOOL | 发送错误
SMS_send_status | OUTPUT | WORD | 发送状态

正常发送完成后，状态代码SMS_send_status=6。 如果SMS_send_aborted=True，则要根据SMS_send_status检查错误。

表4 SMS_send_status列表

数值 | SMS_send_status
1 | 初始化
2 | 发送手机号码或长度中
3 | 发送手机号码或长度成功
4 | 发送手机号码或长度失败
5 | 发送消息中
6 | 发送消息成功
7 | 发送消息失败
8 | 发送超时

发短消息有两种模式，TXT模式和PDU模式：

1. TXT模式（默认）

SMS_send_tn为接收短消息的手机号码。
SMS_send_msg为短消息内容，只能发送有ASCII码的字符（英文字母、数字、部分标点符号），字符个数不超过160。

2. PDU模式

该模式可以发送中文短消息。

SMS_send_tn为短消息字节长度。
SMS_send_msg为短消息内容。可以发送任意有unicode码的字符，字符个数不超过35。

不过需要自行修改库文件，该库程序的密码是1234，打开库后，做如图2和图3的修改：

SMS_init:

图2 初始化块修改

SMS_send：

图3 发送块修改

例子：发送“温度：1.3℃”到指定手机号码“18912345678”，需要编辑SMS_send_msg为：
00 01 00 0D 91 688119325476F8 00 08 0E 6E295EA6FF1A0031002E00332103
00：SCA长度，不计入短消息长度
01：TPDU类型
00：消息基准值MR
0D：号码长度（8618912345678）
91：国际号码
688119325476F8：两两颠倒的8618912345678F，最后一位补F
00：协议标识PID
08：数据编码方案UCS-2
0E：信息长度（十六进制），即后面6E295EA6FF1A0031002E00332103所需字节数14的十六进制表示
6E295EA6FF1A0031002E00332103：“温度：1.3℃”的unicode码
SMS_send_tn：不算开始的SCA长度，一共56个字符，除以2即SMS_send_tn=28

3. 接收/SMS_receive

表5 接收块参数

引脚 | 类型 | 数据类型 | 说明
EN | INPUT | BOOL | 使能端，通常为SM0.0
SMS_rcv_start | INPUT | BOOL | 接收使能，沿触发
SMS_rcv_msg | INPUT | DWORD | 接收缓冲区的地址，接收的短消息从起始地址+15开始，输入为指针
SMS_rcv_busy | OUTPUT | BOOL | 接收中
SMS_rcv_done | OUTPUT | BOOL | 接收完成
SMS_rcv_aborted | OUTPUT | BOOL | 接收错误
SMS_rcv_status | OUTPUT | WORD | 接收状态

正常接收完成后，状态代码SMS_rcv_status=4或者7。如果SMS_rcv_aborted =True，则要根据SMS_rcv_status检查错误。

注意：SMS_rcv_msg指向的区域最长可能需占用指针开始后的255个字节，所以为使短消息收发正常，请在编写其他程序时避开这段区域。

表6 SMS_rcv_status列表

数值 | SMS_rcv_status
1 | 初始化
2 | 接收短消息中
3 | 接收短消息成功
4 | 没有短消息
5 | 提取SIM卡内最远短消息的编号
6 | 删除SIM卡内最远的短消息
7 | 删除SIM卡内最远的短消息成功即收到新的短消息
8 | 删除SIM卡内最远的短消息失败
9 | 接收短消息超时

短消息的接收过程是检查SIM卡中有没有新的短消息，如果有则从SIM卡中读取最远的消息到接收缓冲区，之后提取最远的消息编号，然后将该条消息删除，完成一次接收，如果SIM卡中没有短消息，则直接完成一次接收。也就是说即使不触发SMS_rcv_start，短消息照常接收到SIM卡中，只是不读取到接收缓冲区。
接收短消息通常用于查询S7-200的实时数据，或者对其进行远程控制，但一般不建议远程控制，毕竟无人值守的控制非常危险。
如果需要接收短消息，则通常定时触发SMS_rcv_start。建议即使不使用接收短消息功能，也间隔2、3分钟触发一次SMS_rcv_start，用以删除SIM卡接收到的垃圾短消息。

S7-200通过MD720收发短消息

如图4所示，需要以下配置可以实现S7-200通过MD720收发短消息。

图4 MD720接收短消息配置

远程：

1. S7-200CPU，型号不限（例子中使用CPU 224XP）

2. MD720+联通/移动 SIM卡（例子中使用天津移动SIM卡139XXXXXXXX）

3. 连接在MD720上的天线（例子中使用ANT794-4MR）

4. MD720与S7-200CPU之间的连接电缆（例子中使用S7-200的编程电缆）

手机端：没有限制。（例子中使用北京电信SIM卡189XXXXXXXX）

1.TXT模式，收发英文短消息

步骤如下：

（1）S7-200CPU编写程序（例子中使用Set5_S7-200-library_P0库），参见图5。

库存储区分配为VB0～VB227

图5 MD720程序

（2）数据块，参见图6

图6 数据块

（3）手机收到的短消息，参见图7

图7 手机接收到的短消息

（4）手机发送的短消息，参见图8

图8 手机端发送短消息

S7-200接收，参见图9：

图9 S7-200收到的短消息

从图9中可知，虽然SMS_rcv_msg从VB800开始，但实际接收到的短消息从VB815开始，其中包含短消息来源电话号码，接收时间，以及内容等，如果需要使用短消息内容，需要使用S7-200的字符串处理的指令查找、提取。

2. PDU模式，发中文短消息

步骤如下：

（1）S7-200CPU编写程序（例子中使用Set5_S7-200-library_P0库）

库存储区分配为VB0～VB227，程序参见图5，需如前述修改库程序。

（2）数据块，参见图10

图10 数据块

（3）手机收到的短消息，参见图11

图11 手机接收到的短消息


MD720_5_faq

常见问题

1. MD720如何恢复出厂设置？

答：使用曲别针、工字钉等按下SET按钮超过4s，3个指示灯开始循环闪烁，此时MD720开始恢复出厂设置。

2. 为什么使用MD720发送短消息总是初始化超时？

答：可以做以下检查工作：

（1） MD720指示灯是否正常（CONNECT灯有规律的闪烁，QUALITY灯最好常亮或者闪烁的频繁）

（2） 程序中PIN码是否设置正确

（3） 程序中短消息服务中心号码是否设置正确

（4） 程序中是否有地址冲突，库存储区、SMS_rcv_msg等容易出问题

（5） SMS_receive是否SM0.0调用

（6） MD720和S7-200电缆是否连接正常，拨码是否正确

（7） 短消息库与所接的PORT口是否匹配

（8） 检查SIM卡的安装。

以上都无法解决的话，建议MD720恢复出厂设置，只使用收发短消息的程序重新下载测试。

3. 是否可以实现两个MD720之间的通信？

答：可以，两个MD720需要设置不同的站地址、站名称，通讯的V区地址相同。

建议两个MD720都配置在TCSB的相同项目下；如果配置在TCSB的不同项目下，需要激活项目间通信的功能。

相同项目，参见图1：

图1 相同项目设置

不同项目，参见图2：

图2 不同项目设置

①在2个项目中分别建立站，选择项目间通信

②可用项目选择TEST_1

③站间通信对象选择TEST2

④可用项目选择TEST_2

⑤此时站间通信对象TEST1已激活

在程序中只需在WDC_SEND中的REMOTESTATIONADDRESS引脚指定接收方的站地址，其余和与中心站的通信没有区别。

此时可以读取或写入另一站点数据，例如：

站点1可以通过WDC_SEND的指令COMMAND=1，将VB1000的值写入站点2的VB1000；

站点1也可以通过WDC_SEND的指令COMMAND=2，将站点2的VB1000读入站点1的VB1000。

4. 如何通过电脑RS232串口连接MD720，使用AT指令控制MD720？

答：可以使用西门子电缆6NH7701-4AL连接，也可以如图3所示自行制作

图3 电脑RS232口和MD720的连接电缆

连接前建议将MD720恢复出厂设置。

电脑上的软件可以使用各类串口调试工具，波特率选择19200bps，无校验，数据位8位，停止位1位。

发送指令需要在最后附加CR（回车键）。AT指令需要使得输入为字符输入而不是十六进制输入。

5. MD720-3和MD720有什么区别？

答：除了前面提到的MD720支持SINAUT MICRO SC SEC 库以外，其他方面没有大的区别，只在一些AT指令的系统行为上发生了变化，参见表1

表1 MD720-3和MD720区别

AT指令/功能 | MD720-3 | MD720
MSC/MSC SEC | 只支持MSC协议 | 支持MSC协议与MSC SEC协议
短消息中的"_" | 支持 | "_"将转化为水平制表符
AT+CMGD=1,4 | 删除所有短消息 | 该指令不支持
AT+CMGR=<index> | 如果SIM卡的<index>没有短消息，则响应为+CMGR:ERROR | 如果SIM卡的<index>没有短消息，则响应为+CMGR:0,,0
AT+CPMS="ME","ME","ME" | 可以这样分配 | 固件版本<V2.1：MD720返回错误消息。 固件版本=V2.1 AT+CPMS="ME","ME","ME"等价于AT+CPMS="ME","ME","MT"；接收到短消息保存在SIM卡，当卡存储器满了以后，接收到的短消息保存在设备中而不是删除。

6. 5米天线电缆不够长怎么办？

答：西门子没有专用的天线延长电缆，因此只能使用第三方带SMA接头的天线。但是西门子不建议这样去做，因为这样会显著抑制信号。

7. 如何远程监视S7-200程序？

答：如前所述，通过MD720无法实现S7-200远程监视程序，需要S7-200配置CP243-1才可以实现，主要有以下几种方法：

（1）通过路由器的端口转发功能

网络架构参见图4：

图4 通过路由器的端口转发的配置

设置CP243-1的IP地址，注意设置网关地址，参见图5：

图5 CP243-1网关设置

路由器中设置端口转发（具体方法参见所使用路由器的说明书）:

将102端口数据包转发至IP地址为192.168.1.8的CP243-1。

在Micro/WIN中输入CP243-1前路由器WAN口的固定IP后双击刷新即可，参见图6：

图6 连接设置

①点击该按钮

②点击按钮“新地址”

③输入CP243-1前路由器WAN口的固定IP

④该IP显示在此

⑤点击按钮“保存”

⑥点击按钮“确定”

⑦该IP显示在此

⑧双击刷新即可搜索到，此后即可以实现远程监视S7-200程序

（2）VPN

通过西门子的设备和第三方的设备均可以实现，以下是几种通过西门子的设备实现的方法：

1) S612+S612，参见图7配置

图7 S612+S612配置

参考以下链接

http://www.ad.siemens.com.cn/service/elearning/course/1350.html

http://www.ad.siemens.com.cn/service/elearning/course/1352.html

http://www.ad.siemens.com.cn/service/elearning/course/1354.html

2) S612+M874-3，参见图8配置

图8 S612+M874-3配置

参考以下链接：

https://support.industry.siemens.com/cs/cn/zh/view/91337551

3) M874-3+M874-3，参见图9

图9 M874-3+M874-3配置

配置方式类似与以上两种方式，需要注意的是，通常情况下市售SIM卡没有固定IP。不过购买M874-3时可以同时购买西门子向联通定制的SIM卡，该SIM卡有固定IP，可以在两个M874-3之间搭建VPN，注意：该固定IP不是外网IP，无法和其它外网设备搭建VPN通道。

（3） 利用第三方的设备实现

在此不做介绍。


HMI－人机界面

HMI（人机界面）

顾名思义，HMI提供了机器控制设备（PLC）和操作人员间的联系。HMI可以显示设备的工作状态；而操作人员也可以通过HMI向设备发送指令，控制设备的运行。

比如一个温度控制系统，实际温度可以在HMI上显示，温度控制的设定值也可以通过HMI写入到控制器内，用作PID温度控制的给定。

HMI上的显示、操作元素需要与PLC的内部数据建立对应关系才能工作。建立这种关系需要一些专门的软件来进行，称为Configuring（配置或配置）。

HMI必须支持PLC的CPU或者通信模块上的通信口的硬件标准（有时需要进行转换）和数据通信协议。是否完全支持相应的协议决定了HMI是否能够顺利实现预期的功能。

非西门子的第三方HMI产品往往有通信能力上的限制，请咨询其厂商以了解详细情况。

西门子专为S7-200开发了HMI产品，其中典型的是TP170 micro和TD 200/TD 200C。TP170 micro的配置需要WinCC Flexible；TD 200产品的配置软件包括在S7-200编程软件Micro/WIN中。

除此之外，西门子还有很多HMI产品可以连接到S7-200使用。

计算机也可以作为HMI连接到控制装置充当HMI。典型的包括西门子的ProTool Pro RT（运行版），WinCC Flexible等。西门子还提供了一个OPC Server（服务器）产品PC Access，PC Access安装在作为HMI使用的计算机上，在同一计算机上运行的HMI软件与其连接，达到间接访问PLC的目的。与PC Access连接的HMI软件必须支持OPC。

与S7-200连接的西门子HMI产品


HMI连接数目

S7-200 CPU与HMI（人机界面）的连接数目

S7-200可以连接多种HMI人机操作界面设备。HMI可以连接在CPU通信口上，也可以连接在EM277通信扩展模块上。连接的个数取决于设备的性能，以及所选择的协议。

HMI也可以连接在S7-200 CPU（或EM277）组成的通信网络中。分别连接在CPU两个通信口上的HMI分属于不同的网络。

除了TD 200用S7-200的编程软件自带的“TD 200配置向导”设置，TP070使用STEP 7-Micro/WIN32 Toolbox中的TP Designer配置外， 其他HMI都可以用西门子的HMI配置软件Pro Tool配置。

TD 200、TP070、TP170 micro为S7-200专用，不能用于其他型号的PLC。其他的都可以用于其他系列的西门子PLC。

HMI的连接能力

表1. HMI人机界面所能连接的最大S7-200数目

HIM人机界面 | 连接S7-200数目 PPI协议 | 连接S7-200数目 MPI协议
PP 7 | - | 1 (max. 1.5 Mbaud)
PP 17-1 | - | 1 (max. 1.5 Mbaud)
PP 17-2 | - | 1 (max. 1.5 Mbaud)
TD 17 | 4 | 4
OP 3 | 2 | -
OP 5 | 4 | -
OP 7 | 4 | 4
OP 15 | 4 | -
OP 17 | 4 | 4
OP 25 | 4 | 4 (max. 1.5 Mbaud)
OP 27 | 4 | 4
OP 35 | 6 | 6 (max. 1.5 Mbaud)
OP 37 | 8 | 8
TP 27-6 | 4 | 4
TP 27-10 | 4 | 4
TP 37 | 8 | 8
TP 070 | 1 (max. 19.2 Kbaud) | -
TP 170A (1) | 1 | 1
TP 170B (1) | 1 | 4
OP 170B (1) | 1 | 4
OP77B (3) | 1 | 4
TP 170micro (4) | 1 | 1
TP 177micro (4) | 1 | 1(5)(max. 12 Mbaud)
OP 73micro (4) | 1 | 1(5)(max. 1.5 Mbaud)
K-TP 178micro (4) | 1 | 1(5)(max. 1.5 Mbaud)
MP 270 | 1 | 8
MP 270B/OP 270/TP 270 (1) | 1 | 8
MP 370 (1) | 1 | 8
MP 370 12"/15" Touch (1) | 1 | 8
PC 670/870 | 1 | 8
PCs | 1 | 8
TD 200(2) | 1 | 1 (max. 187.5 Kbaud)
TD 200C (2) | 1 | 1 (max. 187.5 Kbaud)
TD 400C (2) | 1 | 1 (max. 187.5 Kbaud)
（1）配置需要ProTool V6.0 以上版本，或者WinCC flexible
（2）TD 200/TD 200C/TD 400C 能够自动适应协议
（3）配置需要WinCC flexible
（4）配置需要WinCC flexible或WinCC flexible micro
（5）如果需要通信在9.6K速率下，应在配置时选择DP协议

一个S7-200能够连接的HMI数目取决于CPU的型号（版本）以及使用的通信协议。

注意：TP 070与S7-200只能是一对一使用，不能连接其他HMI，不支持多主站网络。一个TP070只能连接到一个S7-200。

S7-200通信口的连接能力

表2. 一个S7-200能够连接的HMI数目（MPI协议）

MPI | HMI连接数 (CPU Port0) | 最大通信波特率 (CPU Port0) | HMI连接数 (CPU Port1) | 最大通信波特率 (CPU Port1) | HMI连接数 (EM277通信口) | HMI 连接数 (通过 CP243-1)
CPU221 | 3 | 187.5 Kbaud | - | - | - | -
CPU222 | 3 | 187.5 Kbaud | - | - | - | 1
CPU224 | 3 | 187.5 Kbaud | - | - | - | 1
CPU224 XP | 3 | 187.5 Kbaud | 3 | 187.5 Kbaud | - | 1
CPU226 | 3 | 187.5 Kbaud | 3 | 187.5 Kbaud | - | 1
EM277 | - | - | - | - | 5 / max. 12 Mbaud | -

根据表1和表2，可以查出TP170A只可以连接一个S7-200，而一个S7-200 CPU224可以连接3个TP170A，一个CPU226可以连接6个（因为两个通信口分属两个网络），如果CPU224加挂了一个EM277，它一共可以连接3+5=8个。

MPI主站不能访问在同一个网络中的PPI主站。这就是说，使用MPI协议的HMI不能读取同一个网络中的做网络读写（PPI）通信的S7-200 CPU通信口。

如果多个PPI主站访问一个从站，可能需要调低主站的数据更新速率，否则会造成在第一个主站与S7-200 CPU通信时，第二个主站不断尝试与S7-200通信，造成效率下降。因此同时使用多个HMI设备时，应设置较长的刷新时间。

任何 CPU 通过 CP243-1 模块的以太网通信口只能连接一个支持以太网的 HMI 设备。

参考：ProDIS网站FAQ14188898。

常问问题

CPU上的通信口已经被占用（如自由口通信等），或者CPU的连接数已经用尽，如何连接HMI？

可以在CPU上附加EM277模块，EM277上的通信口可以连接西门子的HMI。其他品牌的HMI是否能够连接要问其生产厂家。

在PC机上运行的ProTool Pro RT版，可以连接几个S7-200 CPU？一个CPU可以连接几个运行ProTool Pro RT的PC机?

查表1中的PC连接数目，ProTool/Pro RT使用PPI协议可以连接一个CPU，使用MPI协议可以连接8个CPU。

查表2中的HMI连接数目，一个CPU通信口可以连接3个ProTool Pro RT。


HMI－K-TP 178micro

K-TP 178micro

K-TP 178micro是西门子专为S7-200开发的带功能按键的触摸屏。

K-TP 178micro支持S7-200系统的多主站连接。

K-TP 178micro的配置、配置需要WinCC flexible micro或以上版本。下载项目需要串口通信的RS-232/PPI电缆。

K-TP 178micro的订货号为6AV6 640-0DA11-0AX0。

产品特点：

  • 5.7 英寸触摸屏, 蓝色4级灰度显示
  • S7-200 PLC专用触摸屏
  • 友好的操作界面：触摸屏+按键
  • 快速的系统启动时间和操作响应时间
  • 超大存储空间
  • 触摸声音反馈
  • 硬件设计全面更新，无与伦比的高可靠性
  • 5种在线语言切换，32种语言支持，使您的设备能应用于世界各地
  • 强大的密码保护功能，50个用户组
  • 更高的鲁棒性，防冲击和震动，并能防水耐脏
  • 采用32位ARM7处理器，性能优异
  • 集成的LCD控制器，消除了CPU和LCD控制器的之间的传输瓶颈
  • 配置软件：WinCC flexible，编程灵活快捷
  • 为中国用户量身定做，符合中国用户使用习惯

规格参数

表1. 规格

设备参数 |  | K-TP 178micro
显示 | 显示屏 | STN LCD
 | 有效显示区 | 115.18 mm x 86.38 mm (5.7")
 | 分辨率 （宽x高，像素） | 320 x 240
 | 颜色 | 4级蓝色
 | 对比度调节 | 是
 | 背景照明平均 亮度寿命（25℃） | 50 000小时
操作 | 类型 | 触摸屏
 | 可编程功能键 | 6个
 | 操作声音反馈 | 是
 | 数字输入/字母输入 | 是/是
 | LED | 电源、通信指示灯
接口 | RS-485 | x 1
电源 | 电压 | 24 V DC
 | 电流 | 典型240 mA
内存 | 工作（用户）内存 | 1 024K
时钟 | 软件时钟 | 是

表2. 配置能力

设备参数 |  | K-TP 178micro
报警 | 离散量报警数 | 2000
 | 报警文本长度 | 80字符
 | 每条报警内嵌变量数 | 8
 | 单个报警确认 | 是
 | 成组报警确认 | 是
 | 编辑报警 | 是
 | 报警指示器 | 是
报警缓冲区 （易失性） | 报警缓冲区容量 | 256
 | 同时排队能力 | 最大64
 | 查看报警 | 是
 | 清除报警缓冲区 | 是
变量（Tags） | 个数 | 1 000
数值限幅监视 | 输入/输出 | 是
线性比例换算 | 输入/输出 | 是
文本列表 | 数量 | 300
画面 | 个数 | 500
 | 域/画面 | 30
 | 变量/画面 | 30
 | 复杂对象/画面 | 5
 | 模板 | 支持
信息文本 | 长度（字符数） | 320
 | 用于报警 | 是
 | 用于画面 | 是
 | 用于画面对象 （如I/O域） | 是

详细情况请参考相关文档，或到S7-200产品主页上查看。

中文产品手册可在西门子中文网站之下载栏目中找到。


HMI－OP 73micro/TP 177micro

OP 73micro和TP 177micro

OP 73micro和TP 177micro是西门子为S7-200小型PLC开发的新HMI（人机界面）。OP 73micro是3英寸像素显示屏；TP 177micro是5.7英寸单色触摸屏。

OP73micro和TP 177micro支持S7-200系统的多主站连接。TP 177micro已通过2区防爆认证。

OP73micro和TP 177micro的配置、配置需要WinCC flexible micro或以上版本。下载项目需要串口通信的RS-232/PPI电缆。

订货号：

  • OP 73micro： 6AV6 640-0BA11-0AX0
  • TP 177micro： 6AV6 640-0CA11-0AX1

OP 73micro

产品特点

  • 3"象素图形显示屏，可以显示位图、棒图、亚洲字符
  • 高的对比度，具有良好的可视性
  • 可以简便并且迅速地进行配置，起动速度快
  • 可连接S7-200，多主机通信功能， 网络集成
  • 通用消息系统，可任意定义消息类别
  • 灵活的语言支持：能配置32种语言（包括亚洲语言和Cyrillic语），5种在线语言支持
  • 结构紧凑，节省空间：尺寸和OP3、TD200相同
  • 可用WinCC flexible进行配置

TP 177micro

产品特点

  • 5.7"STN象素图形显示屏
  • 性价比高
  • 垂直安装，可以用在许多对安装有限制的地点
  • 低维护设计，背光使用时间长
  • 可连接至S7-200
  • 灵活的语言支持：能配置32种语言（包括亚洲语言和Cyrillic语），5种在线语言支持
  • 2区防爆认证
  • 面板能够防油脂和污物
  • 结构紧凑，尺寸和TP 070/TP170micro相同，可垂直安装
  • 可用WinCC flexible 配置

技术参数

OP 73micro和TP 177micro的主要技术参数如下：

表1. 规格

设备参数 |  | OP 73micro | TP 177micro
显示 | 显示屏 | STN LCD | STN LCD
 | 有效显示区 | 78.98mm x 23.98 mm (3") | 115.18 mm x 86.38 mm (5.7")
 | 分辨率 （宽x高，像素） | 160 x 48 | 320 x 240 240 x 320（垂直安装时）
 | 颜色 | 2 | 4级蓝色
 | 对比度调节 | 是 | 是
 | 背景照明平均 亮度寿命（25℃） | 100 000小时 | 50 000小时
操作 | 类型 | 覆膜按键 | 触摸屏
 | 可编程功能键 | 4 | －
 | 系统键 | 8 | －
 | 数字输入/字母输入 | － | 是/是
接口 | RS-485 | x 1 | x 1
电源 | 电压 | 24 V DC | 24 V DC
 | 电流 | 典型80 mA | 典型240 mA
内存 | 工作（用户）内存 | 128 K | 256 K

表2. 配置能力

设备参数 |  | OP 73micro | TP 177micro
报警 | 离散量报警数 | 250 | 500
 | 报警文本长度（英文） | 80字符 | 80字符
 | 每条报警内嵌变量数 | 4 | 4
 | 单个报警确认 | 是 | 是
 | 成组报警确认 | 是 | 是
 | 编辑报警 | 是 | 是
 | 查看报警 | 是 | 是
 | 报警指示器 | 无 | 是
报警缓冲区 （易失性） | 报警缓冲区容量 | 128 | 128
 | 同时排队能力 | 最大16 | 最大16
 | 清除报警缓冲区 | 是 | 是
变量（Tags） | 个数 | 500 | 250
数值限幅监视 |  | 输入 | 输入/输出
线性比例换算 | 输入/输出 | 是 | 是
文本列表 | 数量 | 150 | 150
画面 | 个数 | 250 | 250
 | 域/画面 | 20 | 20
 | 变量/画面 | 20 | 20
 | 复杂对象/画面 | 5 | 5
 | 模板 | 支持 | 支持
信息文本 | 长度（字符数） | 320 | 320
 | 用于报警 | 是 | 是
 | 用于画面 | 是 | 是
 | 用于画面对象 （如I/O域） | 是 | 是

详细情况请参考相关文档，或到S7-200产品主页上查看。

产品手册下载链接


TD - 文本显示器

S7-200 TD 文本显示器

S7-200 TD 设备是一种低成本的人机界面 (HMI)，是可嵌入数据的文本显示器。可以使用 TD 设备组态层级式用户菜单及信息画面，TD设备可用于查看、监视和改变属于您的应用程序的过程变量。您也可以组态TD 设备，使其显示由 S7-200 CPU 中逻辑使能的报警或信息。

S7-200 文本显示 (TD) 设备简介

S7-200 TD 设备是一个 2 行或 4 行的文本显示设备，可以连接到 S7-200 CPU。TD设备可用于查看、监视和改变属于您的应用程序的过程变量。

S7-200 产品系列提供了四种 TD 设备：

  • TD 100C：具有 4 行文本显示，2 种字体可供选择。显示器每行可显示 16个字符，总共可显示 64 个字符；或者如果使用粗体字体，则每行可显示 12个字符，总共可显示 48 个字符。TD 100C的面板允许用户完全灵活地设计键盘布局和面板。用户可以创建最多包含 14个不同大小的按键的自定义键盘，这些按键可以放到任何背景图片上，并且可以具有不同的形状、颜色或字体

    TD 100C无屏幕背光。

  • TD 200C：具有 2 行文本显示，每行可显示 20 个字符，总共可显示 40 个字符。TD 200C的面板允许用户完全灵活地设计键盘布局和面板。用户可以创建最多包含 20个不同大小的按键的自定义键盘，这些按键可以放到任何背景图片上，并且可以具有不同的形状、颜色或字体。

  • TD 200：具有 2 行文本显示，每行可显示 20 个字符，总共可显示 40 个字符。提供了四个具有预定义的置位功能的按键，如果使用 SHIFT键，则最多可提供八个置位功能。

  • TD 400C：TD400C 具有 2 行或 4 行文本显示，取决于用户选择的字体和字符。

    • 显示器可以是一个 4 行显示器，每行可显示 12 个小的中文字符，总共可显示 48个字符；或者每行可显示24 个小的 ASCII 字符，总共可显示 96 个字符。
    • 显示器可以是一个 2 行显示器，每行可显示 8 个大的中文字符，总共可显示 16个字符；或者每行可显示 16 个大的 ASCII 字符，总共可显示 32 个字符。
    • 可以创建最多包含 15个按键（键）的自定义键盘，这些按键可以放到任何背景图片上，并且可以具有不同的颜色、功能或字体。

您可以使用现存的 TD 组态操作 TD 200C 或 TD 200 设备，而不必修改 S7-200 CPU 中的控制程序。即可以用新的 TD 200 或 TD 200C 替代原有的 TD 200 而不用更改 CPU 中的 TD 200 配置。

TD 100C 和 TD 400C 设备与 TD 200 设备不兼容，需要重新编程组态。原有 TD 200 系列的配置必须使用 Micro/WIN 重新配置。

比较不同型号 TD 设备功能

表1. 比较不同型号 TD 设备

功能 | TD 100C 1.0 版 | TD 200 3.0 版 | TD 200C 1.0 版 | TD 400C 1.0 版
文本显示区域 | 4 行，最多 64个字符（每行最多 16个字符） | 2 行，最多 40个字符（每行最多 20个字符） | 2 行，最多 40个字符（每行最多 20个字符） | 大字体 2 行，最多 16个中文字符或 32 个ASCII 字符（每行最多8 个中文字符或 16 个ASCII 字符）小字体 4 行，最多 24个 ASCII字符（每行最多 12个中文字符）可以组态显示背光灯来延长TD400C设备的使用寿命
键盘选项 | 用户设计的自定义键盘；标准键盘 | 标准键盘 | 用户设计的自定义键盘；标准键盘 | 用户设计的自定义键盘；标准键盘
可组态的按钮 | 自定义键盘：最多 14个（可由用户组态）标准键盘： 2 | 标准键盘：4个（当使 用 SHIFT 键时最多 8 个） | 自定义键盘：最多 20个（可由用户组态） 标准键盘：4（当使用 SHIFT 时最多 8 个） | 自定义键盘：最多 15个（可由用户组态） 标准键盘：8个（当使用 SHIFT 键时最多 16个）
系统按钮 （预先组态） | ENTER、ESC (Escape)、上箭头、下箭头、左箭头、右箭头、F1 和 F2 | ENTER、ESC (Escape)、HIFT、上箭头和下箭头 | ENTER 键、ESC (Escape) 键SHIFT键、上箭头、下箭头、左箭头和右箭头 | ENTER 键、ESC (Escape) 键、SHIFT 键、上箭头、下箭头、左箭头和右箭头
用户定义菜单和用户屏幕 | 最多 32 个屏幕 （最多 4个用户菜单，每个用户菜单最多 8 个屏幕） | 最多 64 个屏幕 （最多 8个用户菜单，每个用户菜单最多 8 个屏幕） | 最多 64 个屏幕 （最多 8个用户菜单，每个用户菜单最多 8 个屏幕） | 最多 64 个屏幕 （最多 8个用户菜单， 每个用户菜单最多 8 个屏幕）
报警指示器（图标） | 是 | 是 | 是 | 是
嵌入到报警或屏幕中的变量 | 每行 1 个（单行的报警变量为 1个；双行的报警变量为2个；对于一个屏幕报警变量为 4 个） | 每个报警或屏幕最多 6个变量 | 每个报警或屏幕最多 6个变量 | 每个报警或画面最多 6 个变量
报警（来自S7-200CPU） | 最多 40 条报警信息 | 最多 80 条报警信息 | 最多 80 条报警信息 | 最多 80 条报警信息
嵌入到信息中的图标（图形） | 否 | 否 | 是 | 是
系统菜单选项 | 释放密码 设置时间和日期 CPU 状态 清理键盘 | 强制 I/O 释放密码 设置时间和日期 CPU 状态 切换语言（如果已组态） 清理键盘 | 强制 I/O 释放密码 设置时间和日期 CPU 状态 切换语言（如果已组态） 改变 CPU 操作模式 清理键盘 编辑 CPU 存储区 对存储卡进行编程 | 强制 I/O 释放密码 设置时间和日期 CPU 状态 切换语言（如果已组态） 改变 CPU 的操作模式 清理键盘 编辑 CPU 存储区 存储卡编程
密码保护 | 是 | 是 | 是 | 是
多个语言集 | 否 | 是 | 是 | 是
支持的字符集（用于显示不同的语言） | 7 个字符集： 拉丁语 1、拉丁语2、中文（简体）1、西里尔字母、波罗的海沿岸语言、希腊语、土耳其语 | 10 个字符集： 拉丁语 1/粗体、拉丁语 2/粗体、中文（简体）、西里尔字母、阿拉伯 语、波罗的海语言、希腊语、希伯来语、土耳其语和标准TD（包括棒图） | 10 个字符集： 拉丁语 1/粗体、拉丁语2/粗体、中文（简体）、西里尔字母、阿拉伯语、波罗的海语言、希腊语、希伯来语、土耳其语和标准TD（包括棒图） | 11个字符集：拉丁语1/粗体、拉丁语2/粗体、中文（简体）、西里尔字母、阿拉伯语、波罗的海语言、希腊语、希伯来语、土耳其语和标准TD（包括棒图）波罗的海沿岸语言
用于系统菜单和错误信息的语言 | 6 种语言： 英语、法语、德语、意大利语、西班牙语和中文 | 6 种语言： 英语、法语、德语、意大利语、西班牙语和中文 | 6 种语言： 英语、法语、德语、意大利语、西班牙语和中文 | 6 种语言： 英语、法语、德语、意大利语、西班牙语和中文
反馈（当按下按键时） | 文本显示区域中的可视指示器 | 键盘组态的触感凸面以及可视指示器 | 文本显示区域中的可视指示器 | 键盘按键的触感凸面、可视指示器以及音频反馈

TD 设备订货号

表2. TD 设备订货号

TD 设备 | 订货号
TD 100C | 6ES7 272-1BA10-0YA1
TD 200 | 6ES7 272-0AA30-0YA1
TD 200C | 6ES7 272-1AA10-0YA1
TD 400C | 6AV6 640-0AA00-0AX1


TD200

TD 200文本显示器

TD 200是S7-200专用的文本显示器，可根据CPU内部的逻辑条件显示信息。在信息中也可内嵌数据，数据既可以显示，也可以由操作人员进行设置。也可以使用TD 200设置CPU实时时钟，访问CPU内存变量，或对开关量输入/输出进行强制。

TD 200可以设置密码，以限制对设备的操作。密码可以防止未经允许改变TD 200系统设置，也可以防止未经许可的对生产数据的改变。

TD 200支持最多8个菜单，每个菜单中最多可以配置8个显示屏，总共64个菜单屏（新产品）。用户可以使用面板上的箭头按键在各菜单屏之间切换。

TD 200还可以显示多达80条消息。消息的显示与否由消息的使能位的状态决定，每次屏幕上最多显示一条或两条消息。多条消息使能位同时置位时，各消息按照编号由小到大的顺序决定显示优先级。

一个S7-200 CPU通信口最多可以连接3个TD 200；一个TD 200只能与一个S7-200CPU建立连接。

TD 200无图形显示功能。TD 200C 和 TD 400C 可以显示一些预先定义好的简单图标。

TD 200配置

在Micro/Win 32 V3.2 SP4 中用TD 200向导（菜单“Tools > TD 200 Wizard”）编程。配置信息将全部存在CPU中，不需对TD 200下装程序。只需在TD 200中设置TD 200地址、所连接的CPU地址及通信速率（注意要与CPU中的一致）。

在新的Micro/WIN V4.0版软件中，TD 200配置向导也做了改进，使其支持以上三种TD 200产品的配置。

具体配置与编程参见《TD 200 操作员界面用户手册》，上面有详细的例程。

TD 200 V3.0配置

常问问题

TD 200/TD 200C的尺寸有多大？盘面开孔尺寸是多少？

TD 200和TD 200C的尺寸为 148mm x 76mm x 28mm（W x H x D）。它们的开孔尺寸都是 138mm x 68mm。


TD200－版本及替代

TD 200的版本

西门子目前提供两种TD 200（TD 200 V3.0和TD 200C V1.0），还可以经常见到以前的TD 200版本（TD 200 V2.1或更早）。

表1. TD 200版本功能对照表

产品 | TD 200 V2.1 或更早 | TD 200 V3.0 | TD 200C V1.0
订货号 | 6ES7 272-0AA30-0YA0（或更早） | 6ES7 272-0AA30-0YA1 | 6ES7 272-1AA10-0YA1
报警（消息） | 80 | 80 | 80
自定义菜单 | - | 64 | 64
按键置位/暂态接触 | 成组选择 | 单个键分别定义 | 单个键分别定义
按键指示显示 | - | 有 | 有
在线语言 | 1 | 5 （需占PLC内存） | 5 （需占PLC内存）
在线语言切换 | - | 支持 | 支持
图形符号 | - | - | 有
嵌入数据 | 作为消息的一部分 | PLC存储单元地址 | PLC存储单元地址
字符串数据类型 | - | 支持 | 支持
键盘布局自定义 | - | - | 支持
功能键 | 5 | 5 | 可选
操作键 | 4/8 | 4/8 | 最多20
自定义形状按键 | - | - | 支持

注意：同一个订货号6ES7 272-0AA30-0YA1下的固件版本（Firmware Version）号并不相同，请检查此一区别。在上电时，TD 200上会显示固件版本号（如“TD 200 RELEASE 2.x.x”）。实际上TD 200 V3.0是普通TD 200的更新版本，而TD 200C是全新的支持用户定义面板的新产品。

TD 200 V3.0和TD 200C V1.0向下兼容老版本。使用旧TD 200的项目文件不用更改也能使用新的TD 200 V3.0和TD 200C V1.0。

以前的TD 200产品只支持消息显示，因此如果用户在编制菜单功能时，会感到消息显示位控制上比较复杂。消息中嵌入数据时，数据是作为消息的一部分，因此改动消息时数据的位置会移动，从而改变嵌入数据的地址，给编程带来不便。

新TD 200产品支持最多64个菜单页面的显示功能，用户可以轻松地使用箭头按键在各屏之间切换。以前的消息被当作报警信息。无论是菜单屏还是报警消息，都可以嵌入CPU数据变量，并且数据是作为地址单元间接访问的，因此数据地址不会随消息的修改（甚至翻译）而改变。

TD 200C的最大特点是可由用户定义按键布局，按键的多少（最多20个键）、大小、位置都可以改变。除此之外，TD 200C还增加了以下新功能：

  • 可选的嵌入符号
  • 可视的按键反馈功能，即在设置此功能后，当按键有效按下后，TD 200C屏幕上会有符号显示
  • 存储卡的操作功能（可将项目文件写入PLC存储卡中）
  • 直接对PLC存储单元的数值进行编辑（写入）
  • 改变PLC的操作模式（运行<=>编程）

详情请参考《TD 200操作员界面用户手册》。

参见ProDIS网站下载链接1087140 ，可以下载本手册的英文版。

TD 200新旧产品的替代问题

TD 200 V3.0或TD 200C V1.0可以完全替代TD 200 V2.1或以前版本，用户既可以直接用Micro/WIN V4.0为其用向导做配置，实现其新功能，也可以使用原来已有的配置，将其当做老的TD 200使用。

  • TD 200 V3.0或TD 200C V1.0可以直接连接含有TD 200 V2.1或以前版本的配置的CPU，其功能也跟原来的配置完全相同，这时就将新的TD 200当作老版本的TD 200使用了。
  • 用Micro/WIN V3.2 或以前版本的软件所做的TD 200配置，可以用Micro/WIN V4.0打开并保存，不必重新编程


TD 200 V3.0

TD 200向导编程步骤：

TD 200 V3.0或TD 200C V1.0使用用户菜单形式编程，最多可定义64个信息画面。所有信息都存在Data Block中，用户可以通过从CPU中Upload（上载）得到TD 200完整的程序，并可直接应用到其它完全相同的项目中。

只有在STEP 7-Micro/WIN V4.0中才能对TD 200 V3.0及TD 200C V1.0的新功能编程。

在STEP 7-Micro/WIN V4.0中的命令菜单中选择Tools > TD 200 Wizard，进入向导。以下主要是针对TD 200 V3.0的编程。TD 200C V1.0的编程如果不选择用户自定义面板，则与以下编程步骤相似。

对于TD 200C V2.1或更早的版本，在以下第一步中选择此型号后，后面的编程与以前相同，可参考《TD 200 操作员界面用户手册》。

在使用向导时必须先对项目进行编译，在随后弹出的对话框中选择“Yes” ，确认编译。如果已有的程序中存在错误，或者存在没有编完的指令，编译不能通过，则不能继续编程。

TD 200 V3.0向导编程步骤：

  1. 配置TD 200
  2. 定义用户菜单
  3. 定义报警消息
  4. 语言切换（翻译）
  5. 完成向导配置
  6. 设置TD200内部参数


TD200－基本配置

第一步：选择TD 200型号及版本

选择TD 200 Version 3.0

注：Micro/WIN V4.0的向导可以对三种型号和版本的TD进行编程。用户可根据自己的TD的型号和版本号来选择。

确定TD型号和版本号有以下两种方法：

  1. 给TD上电，初始画面会显示TD的型号和版本号
  2. 可以在TD的背面发现其型号和版本号，如果没有版本号，则在上图中选择“Version 2.1 and earlier”

第二步： 选择及定义TD的功能和数据更新速率

a. 使能密码保护功能，设置的密码为4个数字，不能设为字符。此密码用来防止未经许可的对TD 200系统菜单的操作，以免随意改变地址、通信速率等设置。

b. 使能TD 200上对PLC中时间的设置功能

c. 使能I/O点的强制功能

d. 选择TD 200 中PLC数据的更新速率

第三步：设定语言及字体：

  1. 设定菜单及提示语言

    2. 这里设定的TD 200本身的系统菜单等界面显示语言

  2. 设定用户定义信息的字符集
    3. 在这里设置用户菜单、报警消息的语言字符集。如果想显示汉语消息，必须在这里设置汉字字符集。

第四步：定义按键功能

加上SHIFT组合键功能，TD上可提供8个功能键直接控制PLC中的数据位。每一个键都可以设置成置位或瞬时接通功能。

注意：TD 200 V3.0或TD 200C V1.0不再需要用户为功能键(F1-F8)分配地址，向导将自动为其分配V区的地址。如果用户重新修改了向导，可能会引起已分配的功能键地址的改变，用户在逻辑编程时需加以注意。

功能键的地址（及其符号名）可以在Micro/WIN的“符号表”中TD_SYM_x标签中查看。

定义用户菜单


TD200－用户菜单

定义用户菜单

第一步：配置完成，可进入用户菜单（User Menu）定义 ，或报警设定

图1. 完成TD基本配置

点击窗口左侧的“User Menu”图标进入用户定义菜单

第二步：定义用户菜单

图2. 用户菜单定义界面

新功能：

  • 使用菜单功能，并不需要S7－200中的程序逻辑，只需使用TD面板上的上下箭头即可访问不同的菜单及画面
  • 新的TD 200 支持8个菜单选项，每个菜单下可带8个信息显示屏，按照第六步的定义，其菜单与屏幕的对应关系如下图：

图3. 菜单－屏的对应关系

  1. 定义用户想使用的菜单及菜单名称
  2. 点击"Add Screen" 按钮添加新的信息显示画面并进入各画面进行信息编辑及数据嵌入
  3. 改变菜单的顺序
  4. 删除当前的菜单选项

第三步：进入画面进行信息编辑

图4. 编辑菜单屏显示

  1. 选中此选项将使当前屏幕成为默认的菜单显示画面。默认画面将在 CPU 上电后，或者使用 ESC 键退回到初始画面时显示。

如果 TD 使用菜单模式为默认显示模式，正常运行时画面将停留在操作人员选择的页面，而不会自动回到默认画面。

第四步：点击“Insert PLC Data”按钮，嵌入并定义PLC数据

图5. 定义嵌入数据

  1. 输入PLC数据单元地址

    • TD 200中只能嵌入V存储区的数据，嵌入的数据可以是VB、VW、VD
    • 此地址一旦设定不会因为其在信息中的位置的改变而改变

  2. 定义数据类型

    • VB（数字字符串、字符串）
    • VW（有符号数、无符号数）
    • VD（有符号数、无符号数、实数即浮点数）

  3. 指定显示几位小数

    • 即便是实数，如果指定显示小数位数为“0”也无法显示小数部分。
    • 对于整数，如果指定小数位数，在显示时看起来就是小数，而PLC内部当作整数来处理，相当于输入数据的若干个10倍数。这实际上是定点数。

  4. 使能数据编辑功能，即可以修改数据。
    注：在TD 200上修改完数据必须按“ENTER”键确认后，改变的数值才能生效，并被写入CPU中。
  5. 使能数据编辑的密码保护功能，即在编辑该数据前必须先输入正确的密码

    • 使用此功能必须在基本配置第二步的a.项使能系统的密码保护功能
    • 编辑数据的密码与系统密码相同

  6. 当切换到该画面后，该数据自动激活编辑状态，用户可以立即修改

  7. 数据编辑通知位的符号名（可在符号表中找到其地址）

    每一数据都有一个对应的数据编辑通知位，该位在用户对此数据进行编辑后（编辑用Enter键结束），会自动置位为1，且不会自动复位。用户可根据此位改变来编程实现一些动作，并且编程将其复位，以便以后继续识别该位的改变。

定义报警（消息）

常问问题

在 TD 200 联机工作于菜单模式时，如何得知当前显示的是哪个菜单的哪个屏幕？

在 TD 200 配置完成后可以在符号表中找到联机显示屏幕的状态字节，如下图中的 TD_CurScreen_0。

图 6. TD 200 符号表


TD200－定义报警

定义报警

第一步：设置报警选项

图1. 报警选项

  1. TD 200 支持两种长度的报警，用户可以选择其中一种长度

  2. 选择屏幕缺省的显示模式

    • 如果选择缺省显示模式为用户屏幕（User screens），则TD 200缺省显示用户屏幕，当有报警激活时，所有用户屏幕会显示一个闪烁的惊叹号，提示有报警。如果画面中有嵌入数据，且在数据编辑状态，画面上不会显示报警提示符，只有退出编辑状态后才会显示。若要查看报警需要按“ESC”键切换到“DISPLAY ALARMS”，并按“Enter”键进入。当报警条件清除后，用户屏幕上的惊叹号会自动消失，此时若切换到“DISPLAY ALARMS”，则会显示“NO ALARMS ACTIVE”。

    • 如果选择缺省显示模式为报警（Alarms），则TD 200缺省显示报警画面，当没有报警画面激活时则显示“NO ALARMS ACTIVE”。若要查看用户屏幕需要按“ESC”键切换到“USER MENU”，这时即使有报警激活，用户屏幕也不会显示惊叹号作为报警提示，因为此时缺省显示即为报警画面。

    • 如果有多个报警画面激活，当前的报警画面右侧会显示上下箭头，上箭头表示有更高优先级的报警画面激活，下箭头表示有更低优先级的报警画面激活，可以用上下箭头翻看其它报警。缺省的报警画面总是显示优先级最高的报警画面，报警画面按优先级顺序显示。优先级是由报警画面的添加顺序决定的。第一个画面具有最高的优先级，最后一个画面具有最低的优先级。

    • 如果有多个报警消息同时触发，停留在一个报警画面中不进行任何操作，TD 会在 10 秒种后回到优先级最高的报警显示画面。

    • 如果TD 200不在缺省显示状态，在用户没有任何操作后，延时一分钟，TD 200 会自动回到缺省设置的显示模式

第二步：定义报警画面及嵌入数据

图2. 定义报警消息和嵌入数据

  1. 输入报警文本及嵌入数据

  2. 当前报警的名字

  3. 选择报警需要确认

    如果报警需要确认，则显示的报警画面在报警使能条件清除后，按“Enter”键确认后，此报警画面才能消失，用户才能接着翻看其它报警画面。需要确认的报警画面，如果报警条件未清除，报警是不能用“Enter”键确认掉的，虽然此时报警确认位已经置1。

  4. 此处定义了报警的确认位，当报警被确认后，此位被置位。如果报警未被确认，即使触发报警的条件已经复位，正在显示的报警画面还会继续闪烁。报警确认位一旦置1，不会自己复位，用户如果想用此位，必须自己在程序中根据条件复位。

    5. 注：报警的确认：需要确认的报警，必须在报警画面中按“ENTER”键确认；普通报警将在触发条件消失后自动清除。

  5. 点击此按键嵌入数据，数据定义方法与菜单画面中嵌入数据相同，而且嵌入数据的地址一旦设定不会因为其在信息中的位置的改变而改变

第三步: 编程，根据逻辑条件触发报警

使用TD 200向导生成的子程序来激活报警消息显示。调用子程序的方法如下图所示，用鼠标双击该子程序或将其拖到相应位置。

图3. 子程序位置

图4. 报警编程

在上图中：

  1. 条件激活报警使TD 200显示该报警画面

  2. 选择报警使能位，即决定了激活哪个报警。Micro/WIN缺省情况下使用符号寻址，报警控制位的符号地址可以手工输入，也可以点击鼠标右键，使用快捷菜单中的Select Symbol命令，选择要激活的报警使能位。当然也可以直接输入绝对地址（绝对地址在Micro/WIN的“符号表”中可以查到）。

    你也可以像以前（TD 200 V2.1或更早版本）一样，使用使能标志位来激活不同的报警画面。

  3. 使用SM0.0调用TD_CTRL_x子程序。此子程序的主要功能是处理报警信息等的显示，只能在（主）程序中调用一次。

    应该注意此子程序调用与报警触发程序的相对位置。为保持报警功能正常运行，应在所有报警触发程序调用之前调用此子程序。如果希望“记忆”关键的报警信息，应把它配置为“需确认”的报警，则不会随触发条件的消失而自动不显示。

多语言配置及切换

常问问题

如何能在报警激活时直接在TD 200显示屏上看到消息，而不是只看到一个闪烁的惊叹号？

如果在报警配置的第一步 b.中选择了菜单模式，就会看到惊叹号。如果想直接显示报警消息，可以设置缺省工作模式为报警模式。

在报警模式下，如果没有报警触发，如何避免显示一个“没有报警”的系统消息？

可以配置一个经常显示的报警消息，其内容可以自定。

配置中既包括菜单，又有报警消息，如何在各显示模式下切换？

按TD 200面板上的ESC键，可以切换菜单/报警显示模式。


TD200－语言切换（翻译）

多语言配置及切换

只有定义了User Menu或Alarms的文本显示内容后，TD 200向导的左侧才会出现语言设置的功能选项。语言设置允许用户在线在两种语言间切换。

点击 [image] 进入语言设置：

注意：当一个配置有多种语言设置时，只有在基本语言设置里才能添加/删除信息和PLC数据。

第一步：选择语言设置

图1. 选择语言

  1. 进入语言设置后，显示的是你配置用户菜单和画面时所使用的语言
  2. 指定配置用户菜单和画面时所使用的语言为画面的基本语言设置

此时需要定义新的语言作为基本语言的切换语言。按Next按钮：

图2. 定义一个新语言集

  1. 打开图1中a.处的下拉菜单，选择创建一个新语言来编辑（翻译）用户菜单/消息，或者选择一个已经存在的语言来重新编辑已存在的用户菜单/消息
  2. 指定你要翻译的语言，即母本。如果目前只有一种语言，就不能改变
  3. 可以根据需要选择将此语言作为基本语言（只能有一种基本语言）

第三步：定义新的语言设置

图3. 选择新语言的种类

  1. 定义哪种语言作为新的语言设置中的菜单及提示语言
  2. 定义信息字符集
  3. TD 200 中显示语言设置的菜单来允许用户改变语言，此处定义该语言设置在菜单中的名称。

    可以改动缺省的语言名称。此处设置的名称将在TD 200中使用系统菜单切换语言时显示。应该使用在当前语言设置下能够正常显示的语言文本。如在基本语言为英文、准备切换为中文时，在此输入英文的“Chinese”为好。

第四步：进入用户菜单或者报警设置翻译已有的信息文本

注意：一定要定义完用户画面中的文本及嵌入数据后，并且确认不再改动后，再做文本的翻译。否则，一旦重新编辑基本语言中的信息或数据后，所有翻译都成为空白，需要重做。

图4. 完成语言集的定义

图5. 选择翻译所使用的语言

图6. 进行显示文本的翻译

在语言设置界面的窗口标题栏将显示正在的编辑的是哪个语言的设置。

完成向导配置


TD200－完成向导配置

完成向导配置：

第一步：分配存储区

图1. 分配数据存储区

根据需要完成向导左侧的所有配置后，点击“Next”（下一步）会进入分配用户存储区画面：

  1. 分配向导所使用的V存储区地址

    • 在画面上方会根据用户的配置显示所需的不同的V存储区的大小。用户的配置不同，所需的存储区大小也不同。
    • 用户可以自己分配一个程序中未用过的V存储区，也可以点击“Suggest Address”按钮让向导自动分配一个程序中未用过的V存储区地址。
    • 为不同的TD 200设置不同的参数块地址，允许你将多个TD 200连接到同一CPU上（它们显示的内容不同）。

      注意：此处设定的参数块起始地址为VB512，VB512即为“TD”参数块地址，则TD 200中的SETUP中的PARM BLOCK ADDRESS设定的地址要与它一致，即为VB512（默认设置为VB0）。且CPU程序中绝对不能占用这个区域的地址，否则会引起无参数块错误或乱码及数据错误。

  2. 如果在a.中设置的数据区不是以VB0开始，按“Next”按钮会出现此消息框。选择是否将参数块的偏移地址放到VW0中
    • 如果选“Yes”，向导会自动将参数块地址（此处是VB512）放到VW0中，也就是VW0成为参数块地址的指针。此时TD 200硬件上，SETUP中的PARM BLOCK ADDRESS既可以设成它的实际参数块地址VB512，也可以设成参数块指针地址VB0，但要保证程序中其它地方不要用到VB0，否则会引起无参数块错误或乱码及数据错误。

      这意味着用户自行更换TD200时， 不必进入TD200的诊断菜单重新设置参数块地址出厂值。
    • 如果选“No”，参数块地址还是a.项设定的参数块起始地址，按照上面的配置，TD 200硬件上，SETUP中的PARM BLOCK ADDRESS设定的地址必须设为VB512。

第二步：项目组成元素

图2. TD 200向导配置名及生成的各项目元素（子程序、符号表、数据块分页等）

  1. 向导根据用户的配置显示项目的组成元素
  2. 在项目树下会显示TD 200 向导配置的名字，用户也可以修改缺省的名字以便用户自己识别
  3. 点击“Finish”（完成）按钮，完成全部的配置

设置TD200内部参数


TD200－数据空间

TD 200 所占数据空间

所有的菜单、报警和语言设置都存储在PLC存储区中。各种配置所占用的数据空间如下：

  • 用户菜单：

    8个菜单，每一菜单带有8个画面的结构
    每个（8画面的）菜单需要 ：2560字节

  • 报警：

    80个报警需要 ：3200字节

  • 语言：

    5种语言总共需要： 28800字节

由此可见，若要使用全部功能，则即使是数据空间最大的CPU226也不够

向导配置完后如何知道各功能键，及使能位的地址

可以在符号表中找到各功能键、数据编辑通知位的地址，以及报警使能位、确认位的地址

图1. TD 200符号表及地址


TD200－操作

TD 200连接S7-200时，显示屏上可以显示：

  • 用户定义的菜单、报警消息
  • TD 200功能菜单

访问TD 200中的菜单及功能使用主要应用“ESC” “ENTER” 及上下箭头按键来实现

ENTER键：选择菜单，确认数据编辑，确认报警

ESC键： 退出当前菜单或取消当前选项

上键：向上翻看菜单或编辑数值时向上增加数值

下键：向下翻看菜单或编辑数值时向下减少数值

用户定义屏的操作

在TD 200上修改PLC中的数据

无论是信息画面还是报警画面中的嵌入数据，只要在嵌入数据时选择了“User is allowed to edit this data”，用户都可以在TD 200 上修改这个数据，操作步骤如下：

  • 用上下键选择数据所在信息画面或报警画面
  • 按“Enter”键进入第一个数据的编辑状态
  • 按“上键”增加数值，按“下键”减小数值
  • 按“Enter”键将数值写入CPU中，并且移到下一个数据

密码操作

如果在TD 200 中使能密码保护功能，用户在访问菜单或编辑数据前需要输入密码。密码的数字用上下键来输入，用“ENTER”键来移位和确认。如果用户未操作TD 200上的任何按键，延时2分钟后，密码保护功能自动重新恢复。

密码恢复：如果用户对TD 200 进行操作后，为保证安全，需要立即恢复密码保护功能，可进入“RELEASE PASSWORD”菜单进行操作，使密码功能立即恢复，不必再等到2分钟后再自动恢复。

TD 200 功能菜单操作

功能菜单的结构如下：

主菜单 | 二级菜单 | 三级菜单
DISPLAY ALARMS （显示报警消息） |  |
OPERATOR MENU （操作员菜单） | VIEW CPU STATUS （查看CPU状态） |
 | SET TIME AND DATE （设置时钟日期） |
 | SELECT LANGUAGE （选择语言） |
 | CLEAN THE KEYPAD （清除键盘） |
DIAGNOSTIC MENU （诊断菜单） | TD 200 SETUP （TD 200设置） | TD 200 ADDRESS （TD 200地址）
 |  | CPU ADDRESS （CPU地址）
 |  | PARM BLOCK ADDRESS （参数块地址）
 |  | BAUD RATE （波特率）
 |  | HIGHEST STATION ADDR （最高站地址）
 |  | GAP FACTOR （间隙参数）
 |  | CONTRAST （对比度）
 | VIEW MESSAGES （查看消息及报警） |
 | FORCE I/O （强制I/O点） |
RELEASE PASSWORD （释放密码） |  |

使用OPERATOR MENU（操作员菜单）

VIEW CPU STATUS（CPU状态）：

显示如下信息：
  • CPU的型号及版本
  • CPU的运行状态及错误信息（如果有错误）

在进入该命令菜单后，会马上显示CPU的型号及版本，按上下键来显示CPU的运行状态及CPU的错误信息（如果有错误）。

SET TIME AND DATE（设定时间和日期）：

如果要使用此功能必须具备以下条件：

  • 使能TD 200上对PLC中时间的设置功能
  • CPU必须支持实时时钟功能

用户可以在这里设定CPU的实时时钟，包括日期、时间、星期。TD 200并不保持时钟，每次进入此画面，TD 200读取CPU中的时间值来显示，用户使用上下键来修改时间，用”Enter“键来确定并移动位置。

LANGUAGE（ 语言切换功能）：

该命令菜单会显示用户已经配置了的语言设置，用上下键选择使用哪种语言。

使用该功能必须已经配置了多语言，参见向导配置中的语言切换部分。

使用DIAGNOSTIC MENU（诊断菜单）

TD 200 SETUP（TD 200设置）：

TD 200成功与CPU200通信并正常工作，必须正确设置TD 200的参数。

  • TD 200 ADDRESS（TD 200地址）：用上下键为TD 200设定地址，该地址在网上必须是唯一的，不能与网上其它CPU或 TD 200 重复。缺省地址为1。
  • CPU ADDRESS（CPU地址）：设定TD 200所连接CPU的地址。缺省地址为2。
  • PARM BLOCK ADDRESS（参数块地址）：设定参数块起始地址，要与CPU向导中设定的参数块起始地址一致（见向导编程中完成向导配置第一步）。如果这里的地址设置不对，否则会引起无参数块错误或乱码及数据错误。缺省设置地址为VB0。
    为不同的TD 200设置不同的参数块地址，允许你将不同的TD 200连接到同一CPU上。
  • BAUD RATE（波特率）：设定通信波特率，必须与CPU的波特率一致，否则会通信不上。缺省波特率为9.6k。
  • HIGHEST STATION ADDR（最高站地址）：设定最高站地址，这个站地址告诉TD 200在寻找其它主站时检查哪些地址。默认最高站地址为31，即TD 200会搜索0－31的地址。除非网路中的站数超过31个，否则不必改变。
  • GAP FACTOR（间隙系数）： 用于设定TD 200查询其它网络主站的频率。缺省设置为10，即每10个令牌检查一次其它主站。如果设置为1，表示每一个令牌查询一次。

    有关网络参数设置的意义
  • CONTRAST（对比度）：TD 200 可以根据不同的光照角度和和光照情况调整屏幕的对比度，默认值为40。设定范围为25（亮）－55（黑）。

VIEW MESSAGES(查看信息画面）：

从这里可以查看用户所配置的所有信息画面和报警画面，以确认所有定义的画面都正确存储在了CPU200中。使用上下键翻看。

注意：在此功能下不能对画面中嵌入的数据进行编辑。

FORCE I/O(强制输入输出点）：

从这里可以分别强制所有的输入、输出点并可解除所有强制。
使用上下键选择要强制的点，按 ”ENTER"键，进入强制状态，然后用上下键选择强制的状态ON或OFF或NO FORCE，按“ENTER"键确认。


TD 200－功能键定义

TD 200的功能键定义

从TD 200 V3.0和 TD 200C V1.0版本开始，在TD 200配置完成后的V数据区中有一个状态字节，其中的某些位的状态对应于TD 200 上的功能键（如上、下、左、右箭头，Enter键）的状态。

STEP 7-Micro/WIN V4.0 SP2在TD 200向导配置完成后，可以在TD 200符号表页中找到个功能键的地址。

TD 200符号表

STEP7 - Micro/WIN升级

使用STEP 7-Micro/WIN V4.0 SP1或V4.0的TD 200向导时可参考以下资料

状态字节的位置在“报警使能位”数据区之后。TD 200配置数据区的V区首地址可以在用TD 200向导配置时指定，所以状态字节的位置不是固定的。

如果指定TD 200数据区起始地址为VB0，则VB46到VB55为“报警使能位”保留。VB56就是状态字节的位置。如图1所示：

图1. 状态字节的位置（图中红色框所标示）

各功能键在状态字节中的位定义如下表所示：

表1. 功能键位

状态字节
VB 56.7 | VB 56.6 | VB 56.5 | VB 56.4 | VB 56.3 | VB 56.2 | VB 56.1 | VB 56.0
X | X | X | 左箭头 | 右箭头 | Enter键 | 下箭头 | 上箭头

注意：上述地址只是一个举例。一个项目中的真实的地址要在TD 200数据块中查看。

注意：TD 200 V3.0或TD 200C V1.0不再需要用户在配置是为功能键(F1-F8)分配地址，向导将自动为其分配V区的地址。如果用户重新修改了向导，可能会引起已分配的功能键地址的改变，用户在逻辑编程时需加以注意。

功能键的地址（及其符号名）可以在Micro/WIN的“符号表”中TD_SYM_x标签中查看。

TD 200 V2.1和更早的版本的功能键位

TD 200 V2.1和更早的版本需要用户在配置中为功能键 (F1至F4以及SHIFT F1至SHIFT F4) 分配地址。该8个TD功能键分别使用8个存储位（M位）。如下图所示2：

图2. TD 200 V2.1和更早的版本功能键配置

例：如果为TD功能键保留M存储区的MB0字节，则功能键位如下表2所示：

功能键 | F1 | F2 | F3 | F4 | SHIFT F1 | SHIFT F2 | SHIFT F3 | SHIFT F14
M存储器位 | M0.0 | M0.1 | M0.2 | M0.3 | M0.4 | M0.5 | M0.6 | M0.7

表2. TD 200 V2.1和更早的版本功能键位


TD - TD 400C

TD 400C

TD 400C 为 S7-200 PLC 专用的新一代文本显示器，能够支持所有 TD 200 的功能。TD 400C 具有极高的性价比，价格极具竞争力。随机附赠通讯电缆（2.5m），无需单独购买通讯和电源电缆（TD 的电源可以通过通讯电缆从 S7-200 PLC 通讯口取得）。 TD 400C 无需 HMI 专用组态软件，使用 STEP7 Micro/WIN V4.0 SP4 以上版中文界面的 TD 向导组态即可。

要将原有的 TD 200 或其他 TD 显示器更换为 TD 400C，必须使用 Micro/WIN 重新配置、编程。

与 TD 200C 相比，TD 400C 既保持了自定义按键功能的特色，也拥有与 TD 200 一致的固定薄膜按键的良好手感。

TD 400C V2.0版本 性能特点

  1. 创新的定制化解决方案，用户可 以自定义面板的背景 颜色，图标及按键功能。

    • 可自定义面板的背景 颜色、图标、文字，所有按键（包括系统功能键 ）功能可自由定义
    • 所有按键有触感，操作有声音、图标显示反馈
    • 随机附送标准胶膜一张
    • 面板具有 3M 高强度粘胶，简单方便粘贴胶膜，粘上 胶膜的前面板完全通过 IP65 测试

  2. 新一代显示屏

    • 更大显示面积，最大显示4行X12个中文字符
    • 亮度高达 350 cd/m2，显示更清晰
    • 时尚蓝色背光
    • 192X64 分辩率，展现完美细节

  3. 完美支持S7-200PLC

    • 使用STEP7 Micro/WIN V4.0 SP4 以上版中文界面 的 TD 向导组态
    • 可用通讯口供电，也支持单独电源口外供电
    • 组态下载到PLC中，显示数据存储于 PLC 数据块，便于更换和维护
    • 支持强制I/O，改变CPU模式，编辑CPU内存变量等功能
    • 与S7-200PLC 最高 PPI 通讯速率可达 187.5K

  4. 更强大的功能

    • 高速16位 CPU ，2M 闪存确保反应速度
    • 多达15个按键，可自由定义功能
    • 支持6 种语言： 英语、法语、德语、意大利语、西班牙语和中文
    • 中英文显示支持
    • 报警功能
    • 密码功能
    • 屏幕保护功能

  5. 更高可靠性

    • 改进的电源电路设计 ，具有反接保护，短路保护，浪涌保护和电子自恢复保险丝
    • 更可靠的通讯电路：通讯口 ESD 保护电路，镀金通讯接口元件
    • 德国进口ABS工程塑料，确保外壳坚固耐冲击
    • 前面板通过欧洲权威实验室IP65防护等级测试
    • 所有按键寿命大于一百万次操作

TD 400C 技术参数

表1. TD 400C 技术参数

 |  | TD 400 C
显示屏尺寸 |  | 4”
中文字符 |  | 小字体 4行 X 12列 大字体 2行 X 8 列
背光 |  | 蓝色
分辩率 |  | 192 X 64
背光亮度 |  | 350 cd/cm2
按键 |  | 15个，所有按键可自由定义功能
按键声音反溃 |  | 有
组态软件 |  | STEP7 Micro/WIN V4.0 SP4 以上版中文界面
通讯 |  | RS 485 PPI 通讯，最高 187.5kb/s
软件功能 |  | 屏幕保护
 |  | 密码保护
 |  | 位图库
 |  | 报警最多 80 条
 |  | 画面最多 64 个
PLC |  | S7-200，S7-200 CN
电源 | 电压范围 | 15VDC－30VDC
 | 工作电流 | 120 mA
防护等级 |  | IP65前面板，IP20背板
外形尺寸 | 前面板尺寸 宽 X高 | 174 mm X 102 mm
 | 开口尺寸 宽X高X深 | 163.5 mm X 93.5 mm X 31mm
重量 |  | 0.33 kg
环境温度 | 工作 | 0 到 +50°C
 | 运输/储存 | -20 到 +60°C
最大相对湿度 | 工作 | 5％－85％（30 度），无凝露
 | 运输/储存 | 5％－85％（40 度），无凝露

TD 400C 包装内容

TD 400C 的完整包装中包括如下产品和附件

  • TD 400C 本体，无面板，粘胶膜由保护纸覆盖
  • 西门子 TD 400C 的标准面板胶膜
  • TD/CPU 通信电缆 x1 2.5m
  • 密封垫圈
  • 安装垫片
  • 硬件说明书，上有安装说明

TD 400C 配置步骤

常问问题

TD 400C 是否可以用在 S7-400/300 上？

TD 400C 是 S7-200 专用的文本显示器，只能配合 S7-200 CN 和 SIMATIC S7-200 产品使用。TD 400C 不能用于其他任何控制器。

TD 400C 对面板透明胶膜的材料有无要求？

没有，但是应该注意材料透光度和厚度，厚度太薄则强度差，透光度太差则会影响整体亮度。

TD 400C 面板粘胶的储存时间多长？

常温下可以保存一年。

TD 400C 的粘胶强度如何？

TD 400C 采用美国 3M 高强度粘胶，粘贴标准胶膜后完全通过 IP65 测试。

在粘贴胶膜后严禁撕下胶膜，否则将损坏键盘电路。

怎样实现选择性的显示想要的画面

文本显示器功能比较简单，单纯用向导里的用户菜单不能实现屏幕之间的切换 ，但是可以借助以下两种来实现：

A.TD Keypad Designer（与STEP7-Micro/WIN软件一起安装的,使用该软件需要先在向导里勾选使用TD Keypad Designer创建自定义键盘） 通过该软件设置TD的功能键 ，将功能选为显示对应菜单的屏幕，但是选项里只能选择菜单的屏幕0，TD400C有8个菜单，也就只能打开8个

例，设置F1 ----显示菜单1的屏幕0 具体现象：按下F1后，画面切换到指定的菜单1屏幕0，如果选择默认画面是报警画面，不操作TD，一段时间后，画面会自动回到默认画面，如果选择默认画面是用户画面，TD会一直一直停留在F1切换的画面

B.通过报警画面实现 前提要求显示的默认画面是报警画面，可以通过触发不同的报警调用不同的画面 （报警选择全屏显示）

以上两种方式 仅仅是参考建议 具体需要用户根据实际情况选择

怎样检测TD的按键是否失效？

上电长按F1后，会进入TD的英文的诊断菜单，选择Keyboard test ，可以坚持按键是否好用，画面会提示用户按下对应的按键序号1-15 从第一行向上光标算起 为1，向下光标为4，F1是5，ESC是9，F5是10，SHIFT是14

其中，Automatic test 可以检测ROM，RAM区，背光灯，蜂鸣器灯检测；Communication tset 专门测试通讯连接

怎样将TD的菜单语言修改为中文？

TD的语言与向导设置有关，在向导里将语言选择为中文，连接TD后，菜单语言会自动切换为中文，此时 操作员菜单里会显示“选择语言”选项

怎样上传文本显示器的组态配置和相关程序？

TD显示器的程序只能通过STEP 7 - Micro/WIN的 向导“文本显示”实现 ，且下载到PLC里，TD上没有程序，所以想要获得TD的程序，只需要上传PLC的程序，文本显示器的组态配置和相关程序

如何使用EM277通讯扩展模块连接TD400C？

如果CPU的通信口已经被占用，或者通讯口的连接资源不够时，可以在S7-200CPU（CPU221除外）右侧添加EM277通信扩展模块用于连接文本显示器。一个EM277模块最多可以同时以5个文本显示器通信。一个文本显示器只能与一个S7-200CPU通信（不论是通过CPU集成口或EM277)。

EM277连接TD400C的组态步骤与使用CPU集成通讯口连接TD400C大致相同，用户首先正常配置文本显示器向导，之后再TD400C上诊断菜单中的CPU站地址设置为与EM277的实际地址相同。EM277的通讯口波特率有自适应功能，因此不需要额外设置波特率。


TD - TD 400C 配置

TD 400C 的自定义属性

TD 400C 中的 C 代表它是可以 Customize（自定义）的。配置与普通的 TD 200 有所不同，与 TD 200C 有些类似。

与 TD 200C 不同，TD 400C 上的按键数目和位置都是固定的，不能像 TD 200C 一样自由定义，但是这些键的功能可以自定义。

如果不需要使用 TD 400C 的自定义键盘功能，您可以使用 TD 400C 默认的一套标准键盘布局。在配置 TD 400C 时，用户可以根据自己的具体要求，决定是否使用自定义的键盘。在这里，键盘的自定义包括两方面的含义：

  1. 自定义 TD 400C 的功能键布局：
    TD 400C 有一套标准的键盘布局，包括最基本的特殊功能键定义；如果用户需要，则可以用 Keypad Designer （键盘设计程序）重新分配这些固定的键的功能。

  2. 自定义 TD 400C 的面板图形：
    TD 400C 的可自定义还体现在可以更换操作面板的图形（包括背景和按钮等元素）。TD 400C 出厂时没有粘贴薄膜图形面板，其空白胶粘面用纸保护。用户可以选择使用随包装提供的 TD 400C 缺省图形，也可以自己制作自定义面板。自定义面板图形可以使用任何第三方的图形编辑软件，过程中也可能用到 Keypad Designer 的一些功能作为辅助。

TD 400C 的上述两种“自定义”特性是完全互相独立的。用户可以自定义面板图形，但不改变其功能键定义；也可以使用缺省的薄膜面板，但重新定义功能键。

TD 400C 配置步骤

根据不同的具体应用要求，TD 400C 的配置步骤也有所不同。一般地，TD 400C 的配置可能包括以下几个步骤：

  1. 使用 Keypad Designer 自定义功能键（可选）
  2. 进入 Micro/WIN 的 TD 文本显示向导配置 TD 400C
  3. 进行 TD 400C 的基本配置
  4. 配置用户菜单（可选）
  5. 配置报警信息（可选）
  6. 完成 TD 400C 向导配置


TD 400C - Wizard

TD 400C 向导配置

TD 400C 的所有配置信息都存在 Data Block 中，用户可以通过从 CPU 中上载得到 TD 400C 完整的程序，并可直接应用到其它完全相同的项目中。

只有在STEP 7 - Micro/WIN V4.0 SP4 以上版的中文界面下才能对TD 400Ｃ进行编程组态。

如何查看软件版本

开始配置 TD 400C

  1. 在STEP 7 - Micro/WIN V4.0 SP4 以上版中文界面的菜单中选择 工具> 文本显示向导，进入向导。

    图1. 启动文本显示向导

  2. 在使用向导时必须先对项目进行编译，在随后弹出的对话框中选择“Yes” ，确认编译。如果已有的程序中存在错误，或者存在没有编完的指令，编译不能通过，则不能继续编程。

  3. 选择TD设备的型号：TD 400C 版本 1.0

    图2. 选择 TD 设备为 TD 400C

如果选择了非中文的 Micro/WIN 界面，则不能看到 TD 400C 选项。

下一步：TD 400C 基本配置


TD 400C - 基本配置

TD 400C 基本用户配置

第一步： 选择及定义TD的功能和数据更新速率

图1. TD 400C 功能定义

  1. 使能密码保护功能，设置的密码为 4 个数字，不能设为字符。此密码用来防止未经许可的对 TD 400C 系统菜单的操作，以免随意改变地址、通信速率等设置。
  2. 使能 TD 400C 上对 PLC 中时间的设置功能
  3. 使能 TD 400C 上对 PLC 中 I/O 点强制功能
  4. 使能＂存储卡编程＂菜单，用户可使用此功能将 PLC 中程序拷贝到外插在 PLC 上的存储卡中
  5. 允许改变 PLC 模式，使能此功能后，用户可以利用 TD 400C 启动或停止 PLC 。
  6. 使能编辑 PLC 存储区功能，使能此功能后，用户可以利用 TD 400C 修改 PLC 的 V 存储区的数据。
  7. 选择 TD 400C 轮循 PLC 的数据及报警的更新时间。

第二步：设定语言及字符集

图2. TD 400C 语言及字符集定义

  1. 设定菜单及提示语言

    这里设定的TD 400C 本身的系统菜单等界面显示语言。

  2. 设定用户定义信息的字符集

    在这里设置用户菜单、报警消息的语言字符集。如果想显示汉语消息，必须在这里设置汉字字符集（也是缺省设置）。

第三步：配置键盘按键

图3. 配置键盘按键

  1. 加上SHIFT组合键功能，TD 400C 上可提供16个系统功能键直接控制PLC中的数据位。每一个键都可以设置成置位或瞬时接通功能。

    注意：    TD 400C 不需要用户为功能键(F1-F8)分配地址，向导将自动为其分配V区的地址。如果用户重新修改了向导，可能会引起已分配的功能键地址的改变，用户在逻辑编程时需加以注意。

    TD 400C 上 的功能键的地址（及其符号名）可以在 Micro/WIN 相关的符号表标签（如 TD_SYM_x ）中查看

  2. 按下按键时在 TD 400C 显示屏上显示响应标志，便于用户确认按键操作。
  3. 用户也可以选择使用 Keypad Designer （键盘设计器）创建的自定义键盘。
  4. 选择自定义键盘文件按钮。

    只有 c. 项使能后，才会出现此按钮。

只有选择了 c. 选项，才是使用了 TD 400C 的“自定义按键”功能。所谓自定义按键，就是改变缺省按键布局的按键功能分配，或者改变缺省情况下的按键名称，或按键符号。对于用户程序来说，缺省情况下的 F1 - F8、Shift+F1 - Shifit+F8 本来就可以由用户分配其在用户程序中的功能，可以说这也是“自定义”。这和没有自定义键盘功能的 TD 200 是一样的。如果项目中不需要改变功能键定义或符号等，自然不必自定义键盘。

使用“自定义键盘功能”

以下为不使用“自定义键盘”功能时的 TD 400C 符号表

图6. TD 400C 符号表


TD 400C - 基本配置（自定义键盘）

TD 400C 基本用户配置（使用自定义键盘）

如果要在 Micro/WIN 的 TD 400C 配置中选用“自定义键盘”功能，在进行下一步之前，必须首先在 Keypad Designer （键盘设计程序）中进行功能键定义。

在 Keypad Designer 中生成自定义键盘设置文件

第一步：导入 Keypad Designer 生成的自定义键盘文件

图 1. 选用“自定义键盘”

选中 c. 然后按 d. 按钮，在弹出的对话框中选择自定义键盘配置文件（扩展名 .td4，由 Keypad Designer 生成）。这里的 TD400C.td4 是已经在 Keypad Designer 中配置好的一个示例文件。

图 2. 选择自定义键盘文件

第二步： 配置 TD 400C 自定义的 “设置位”功能键（相当于F功能键）

图 3. 导入自定义键盘后定义其他按键为置位或脉冲功能

  1. 在 TD400C.td4 这个例子中，已经把缺省的 F1（Shift+F1） - F8（Shift+F8）中的 4 个按键定义为 TD 400C 的系统功能键，因此还剩下 4 个键可供用户程序使用。剩余的 4 个设置位功能键，加上 SHIFT 组合键功能），还可提供 8 个设置位功能键直接控制 PLC 中的数据位。每一个键都可以单独设置成置位或瞬时接通功能。键的符号名可以自己定义，这里沿用了缺省符号名。

    注意：TD 400C 不需要用户为设置位功能键分配地址，向导将自动为其分配 V 区的地址。如果用户重新修改了向导，可能会引起已分配的置位功能键地址的改变，用户在逻辑编程时需加以注意。

    TD 400C 上 的功能键的地址（及其符号名）可以在 Micro/WIN 相关的符号表标签（如 TD_SYM_x ）中查看。

图 4. 使用自定义键盘后的 TD 符号表

可以发现用户程序可用的键要比不使用“自定义键盘”时要少，这是因为在 TD400C.td4 这个例子中，有 4 个键被“自定义”为 TD 功能键了。通过导入 .td4 文件，功能键的定义也被保存在 Micro/WIN 最后生成的数据块中，并将被下载到 CPU 中。


TD 400C - 用户菜单

TD 400C 用户菜单定义

TD 400C 可以配置成使用用户菜单形式，或者报警消息形式，或者同时使用这两种显示模式。

菜单模式下，最多可定义 8 个菜单，每个菜单下可定义 8 个信息画面，总共 64 个信息画面。

注意：

  • 使用菜单功能，并不需要 S7－200中 的程序逻辑，只需使用 TD 面板上的上下箭头即可访问不同的菜单及画面
  • S7-200 中的程序也无法控制某个菜单屏幕的显示

第一步：TD 400C 基本配置完成，可进入用户菜单（User Menu） 定义 ，或报警设定

图 1. 完成 TD 基本配置

第二步：定义用户菜单

图 2. 用户菜单定义界面

  1. 定义用户想使用的菜单及菜单名称
  2. 点击"添加屏幕" 按钮添加新的信息显示画面并进入各画面进行信息编辑及数据嵌入
  3. 改变菜单的顺序
  4. 删除当前的菜单选项

第三步：进入画面进行信息编辑及数据嵌入

图 3. 编辑菜单屏显示

  1. 为 TD 400C 显示屏幕选择字体

    图4. 选择字体

    可以为显示屏幕选择 “大” 或 “小” 两种字体 ，根据选择的字体不同可以显示不同行数的字体：

    • 4 行 （全部选用小字体）
    • 2 行 （全部选用大字体）
    • 3 行 （1 行大字体和 2 行小字体）

  2. 点击 “ 插入 PLC 数据 ” 按钮，嵌入并定义 PLC 数据

  3. 选中此选项后，本屏幕可作为默认显示画面。默认画面将在 CPU 上电后，或者使用 ESC 键退回到初始画面时显示。

    如果 TD 使用菜单模式为默认显示模式，正常运行时画面将停留在操作人员选择的页面，而不会自动回到默认画面。

在图 3 中看不到 TD 400C 的面板图形，这是因为已经选择了用户自定义面板，但在 TDKeypad Designer 中还没有做图形设计，因此生成的 .td4 文件中不包含图形。如果完成的 .td4 文件中包括图形，则可以再次导入以在这里显示。不显示图形不会影响功能键的定义。

第四步：嵌入并定义PLC数据

图 5. 定义嵌入数据

  1. 输入PLC数据单元地址
  • TD 400C 中只能嵌入V存储区的数据，嵌入的数据可以是VB、VW、VD
  • 此地址一旦设定不会因为其在信息中的位置的改变而改变
  2. 定义 TD 嵌入数据的类型
  • VB（数字字符串、字符串）
  • VW（有符号数、无符号数）
  • VD（有符号数、无符号数、实数即浮点数）
  3. 指定显示几位小数
  • 即便是实数，如果指定显示小数位数为 “0” 也无法显示小数部分。
  • 对于整数，如果指定小数位数，在显示时看起来就是小数，而PLC内部当作整数来处理，相当于输入数据的若干个 10 倍数。这实际上是定点数。
  4. 使能数据编辑功能，即可以修改数据。

注：在TD 400C 上修改完数据必须按“ENTER”键确认后，改变的数值才能生效，并被写入 CPU 中。

  5. 使能数据编辑的密码保护功能，即在编辑该数据前必须先输入正确的密码
  • 使用此功能必须在基本配置第一步的 a. 项使能系统的密码保护功能
  • 编辑数据的密码与系统密码相同
  6. 当切换到该画面后，该数据自动激活编辑状态，用户可以立即修改
  7. 数据编辑通知位的符号名（可在符号表中找到其地址）

    每一数据都有一个对应的数据编辑通知位，该位在用户对此数据进行编辑后（编辑用 Enter 键结束），会自动置位为 1，且不会自动复位。用户可根据此位改变来编程实现一些动作，并且编程将其复位，以便以后继续识别该位的改变。

定义报警信息（可选）
完成 TD 向导配置

常问问题：

在 TD 400C 联机工作于菜单模式时，如何得知当前显示的是哪个菜单的哪个屏幕？

在 TD 400C 配置完成后可以在符号表中找到联机显示屏幕的状态字节，如下图中的 TD_CurScreen_0。

图 6. TD 400C 符号表

TD 400C文本显示器菜单屏幕与TD_CurScreen_0对应关系？

TD 400C文本显示器地址中TD_CurScreen_0数值按照定义的菜单和屏幕顺序依次增加；菜单下未添加的屏幕不占用屏幕号。

如下所示例子：

1. 菜单1下添加了8个屏幕，则TD_CurScreen_0数值0至7分别对应于菜单1屏幕0至菜单1屏幕7；

2. 菜单2下添加了2个屏幕，则TD_CurScreen_0数值8至9分别对应于菜单2屏幕0至菜单2屏幕1；

注意：在该菜单下，余下未添加的其余6个屏幕不占用屏幕号！

3. 菜单3下添加了1个屏幕，则TD_CurScreen_0数值10对应于菜单3屏幕0。

如下表1所示：

用户菜单 | 用户屏幕 | TD_CurScreen_0
菜单1 | 屏幕0 | 0
 | 屏幕1 | 1
 | 屏幕2 | 2
 | 屏幕3 | 3
 | 屏幕4 | 4
 | 屏幕5 | 5
 | 屏幕6 | 6
 | 屏幕7 | 7
菜单2 | 屏幕0 | 8
 | 屏幕1 | 9
菜单3 | 屏幕0 | 10

表1. TD 400C文本显示器菜单屏幕与TD_CurScreen_0对应关系

在TD 400C文本显示向导组态中，对（VW）字（无符号或有符号）类型的数据或（VD）双字（无符号或有符号）类型的数据设置“小数点右侧位数”的用途是什么？

图7. TD 400C定义（VW）字（无符号或有符号）类型

图8. TD 400C定义（VD）双字（无符号或有符号）类型

如上图7，8涉及的“小数点右侧位数”设置，用于使TD 400C文本显示器上定义的数据的实际值按照设置的缩小比例显示。
“小数点右侧位数”设置范围为0至7，分别可以使数据实际值在TD 400C文本显示器上按照1至10000000比例缩小显示。 如下表2所示：

小数点位数 | 文本显示器上显示数值的缩小比例
0 | 1
1 | 10
2 | 100
3 | 1000
4 | 10000
5 | 100000
6 | 1000000
7 | 10000000

表2. 小数点位数与显示数值比例关系

例：以实际数据值等于12345为例，小数点位数设置不同，文本显示器上显示数值如下表3的所示：

小数点位数 | 数据实际值 | 文本显示器上显示数值
0 | 12345 | 12345
6 | 12345 | 0.012345
7 | 12345 | 0.0012345

表3. 小数点位数与实际值和显示值关系

如何避免屏幕上的数据显示"eeeeeee"或文本字符被数据覆盖?

随着数据值数量级的增长，它会逐步使用定位点左侧的空间。如果左侧的显示空间不够时，数据会显示"eeeeeee"；如果左侧有文本字符，数据可能会覆盖该文本字符。因此，在文本显示器屏幕上插入PLC数据或输入文本字符时，应考虑预期的数据值范围，始终在文本末尾和定位点之间提供足够的空间。

例：TD 400C文本显示器选择了小字体，每行最多可有24 个ASCII 字符。屏幕上插入PLC数据类型为字（VW），数据格式为“有符号”，此数据类型占用6个字符；因此，该数据左侧空间最多只能输入字符18个字符（如：ABCDEFGHIJKLMNOPQR共18个字母），才能保证左侧的文本字符在数据值数量级增长时不被覆盖。 如下图9所示：

图9.插入PLC数据类型及编辑文本字符

TD 400C 屏幕中插入的数据类型不同，占用的最大字符数不同，具体如下表4所示：

大小 | 类型 | 精度（小数点右侧位数） | 最大字符数
字节 （VB） | 字符串 | 不适用 | 行长度
 | 数字字符串 | 不适用 | 行长度
字 （VW） | 无符号 | 0 | 5
 |  | 1-4 | 6
 |  | 5 | 7
 |  | 6 | 8
 |  | 7 | 9
 | 有符号 | 0 | 6
 |  | 1-4 | 7
 |  | 5 | 8
 |  | 6 | 9
 |  | 7 | 10
双字 （VD） | 无符号 | 0 | 10
 |  | 1-7 | 11
 | 有符号 | 0 | 11
 |  | 1-7 | 12
 | 实数 | 0 | 行长度
 |  | 1-7 | 行长度

表4. 计算屏幕中嵌入变量的字符数

注：行长度（行中的字符数）会随着 TD 型号和字符大小的不同而变化。 对于 TD 400C，行长度取决于所 选的字体。 如果选择了小字体，则每行 24 个 ASCII 字符或 12 个中文字符。 如果选择了大字体，则每行 16 个 ASCII 字符或 8 个中文字符。


TD 400C - 报警消息

TD 400C 报警消息定义

TD 400C 可以配置成使用用户菜单形式，或者报警消息形式，或者同时使用这两种显示模式。

TD 400C 最多支持 80 条报警信息。

报警信息模式可以由用户程序控制它的显示与否。

TD 400C支持以下三种长度的报警信息，用户可自己定义。

图1. 定义报警信息长度

  1. 选择报警信息的长度
  2. 选择 TD 400C 的默认显示模式。这是 TD 400C 上电后开始工作时进入的显示模式。

    • 用户屏幕：即用户菜单模式优先
    • 报警信息：报警显示信息优先

如果有多个报警消息同时触发，停留在一个报警画面中不进行任何操作，TD 会在 10 秒种后回到优先级最高的报警显示画面。如果TD 400C不在缺省显示状态，在用户没有任何操作后，延时一分钟，TD 400C 会自动回到缺省设置的显示模式。

如果 TD 400C 的配置中既有菜单，也有报警，用户也可以使用 TD 400C 的系统菜单，在默认显示模式和次要显示模式之间切换。在默认的菜单显示模式下，如果有报警信息需要显示，在菜单画面上会出现提示符号，而不会直接显示相关的报警信息；在默认的报警显示模式下，报警信息得到优先显示。因此如果由用户程序控制其显示的消息对于工艺操作很重要的话，建议把报警信息模式设置为缺省。

报警消息的配置与 TD 200 基本相同，详情请参见 TD 200 报警配置。


TD 400C - 完成配置

完成向导配置：

第一步：分配存储区

图1. 分配数据存储区

  1. 分配向导所使用的V存储区地址

    • 在画面上方会根据用户的配置显示所需的不同的 V 存储区的大小。用户的配置不同，所需的存储区大小也不同。
    • 用户可以自己分配一个程序中未用过的 V 存储区，也可以点击“建议地址”按钮让向导自动分配一个程序中未用过的 V 存储区地址。
    • 为不同的 TD ４00Ｃ 设置不同的参数块地址，允许你将多个 TD ４00Ｃ 连接到同一 CPU 上（它们显示和控制的内容不同）。
    • 如果为连接到同一个 CPU 上的 TD 400C 的参数块地址设置为相同的，则它们显示和控制的内容相同。

      注意：本例中在此处设定的参数块起始地址为 VB512，则从 VB512 开始的两个字节将保存英文字母 'td' 的 ASCII 码，作为 TD 参数块起始地址的标志。这时如果把 TD ４00Ｃ的设置菜单中中的“参数块偏移地址”设定为 512（TD 的出厂默认设置为 0，即参数块偏移地址为 VB0），TD 就能正常工作。CPU 中的其他用户程序绝对不能占用这个区域的地址，否则会引起无参数块错误、乱码或数据错误。

  2. 如果在 a. 中设置的数据区不是以 VB0 开始（正如本例），按 “下一步” 按钮会出现此消息框。选择是否将参数块的偏移地址放到 VW0 中
    • 如果选“Yes”，向导会自动将参数块偏移地址（此处是 512）放到 VW0 中，也就是 VW0 成为了参数块地址的指针。此时 TD ４00Ｃ 硬件中的设置菜单中的“参数块偏移地址”既可以设成它的实际参数块地址 512（指向 VB512），也可以设成默认的 0（指向 VB0）。一定要保证程序中其它地方不要用到这些数据存储区，包括 VW0，否则会引起无参数块错误、乱码或数据错误。

      这意味着用户自行更换 TD４00Ｃ 时， 不必进入 TD４00Ｃ 的诊断菜单重新设置参数块地址出厂值。

    • 如果选“No”，参数块地址还是设定的存储区起始地址 VB512。按照上面的配置，TD ４00Ｃ 硬件中设置菜单中的“参数块偏移地址必须设为 512（指向 VB512），VW0 中不会保存与 TD 配置有关的信息。

第二步：项目组成元素

图2. TD ４00Ｃ向导配置名及生成的各项目元素（子程序、符号表、数据块分页等）

  1. 向导根据用户的配置显示项目的组成元素
  2. 在项目树下会显示TD ４00Ｃ 向导配置的名字，用户也可以修改缺省的名字以便用户自己识别
  3. 点击“完成”按钮，结束全部的配置


TD 400C - 设置操作

TD 400C 的设置及操作

TD 400C 连接 S7-200 时，显示屏上可以显示：

  • 用户定义的菜单、报警消息
  • TD 400C 功能菜单

访问 TD 400C 中的菜单及功能菜单，主要应用“ESC” “ENTER” 及上下箭头按键来实现

ENTER 键：选择菜单，确认数据编辑，确认报警

ESC 键： 退出当前菜单或取消当前选项

上箭头键：向上翻看菜单或编辑数值时向上增加数值

下箭头键：向下翻看菜单或编辑数值时向下减少数值

TD 400C 的必要设置

在 STEP 7 - Micro/WIN 中使用 TD 向导完成 TD 400C 的组态后，将TD 400C 与 S7－200 连接，为使 TD 400C 能与 S7－200 正常通讯及工作，必须完成 TD 400C 设置：

通过进入 TD 400C 的 "诊断菜单 > TD400C 设置" 进入以下菜单进行参数设置

必要设置：

  • TD 400C ADDRESS（TD 400C地址）：用上下键为 TD 400C 设定地址，该地址在网上必须是唯一的，不能与网上其它CPU或 TD 设备地址重复。缺省地址为1。
  • CPU ADDRESS（CPU地址）：设定TD 400C 所连接CPU的地址。必须与所连CPU的地址一致，否则会造成 “CPU无响应” 。缺省地址为 2。
  • PARM BLOCK ADDRESS（参数块地址）：设定参数块起始地址，要与CPU向导中设定的参数块起始地址一致（见向导编程中完成向导配置第一步）。如果这里的地址设置不对，会引起无参数块错误或乱码及数据错误。缺省设置地址为VB0。

    图 1. Micro/WIN 中文本显示向导配置之一步骤
  1. TD 中设置的参数块地址必须与上面向导中配置的存储区首地址对应。
  2. 如果上面的存储区首地址改为 VB512，则 TD 中的参数块地址也可以改为 512。
  3. 如果存储区中设置的数据区不是以 VB0 开始（如以 VB512 起始），按“Next”按钮会出现 “是否将参数块的偏移地址放到 VW0 中” 的对话框。
  • 如果选“Yes”，向导会自动将参数块地址（此处是VB512）放到VW0中，也就是VW0成为参数块地址的指针。此时 TD 400C 硬件上，TD 400C 设置中的参数块地址既可以设成它的实际参数块地址 VB512，也可以设成参数块指针地址 VB0，但要保证程序中其它地方不要用到VB0，否则会引起无参数块错误或乱码及数据错误。

    这意味着用户自行更换 TD400C 时， 不必进入 TD400C 的诊断菜单重新设置参数块地址出厂值。

  • 如果选“No”，参数块地址还是设定的参数块起始地址，按照上面的配置，TD 400C 硬件上，TD 400C 设置中的参数块地址必须设为 VB512。

    为不同的 TD 400C 设置不同的参数块地址，允许你将多个不同的 TD 400C 连接到同一 CPU 上。
  • 波特率：设定通信波特率，必须与CPU的波特率一致，否则会通信不上，造成“CPU无响应” 。缺省波特率为9.6k。

需要时设置：

  • 最高站地址：设定最高站地址，这个站地址告诉 TD 400C 在寻找其它主站时检查哪些地址。默认最高站地址为 31，即 TD 400C 会搜索 0－31 的地址。除非网路中的站数超过 31 个，否则不必改变。

    波特率为 9600 波特或 19.2 K 波特时，可能需要提高最高站地址（即使网络包含的主站不超过 32 个）。 提高最高站地址将使主站有更多的时间发送消息。
  • 间隙系数： 用于设定 TD 400C 查询其它网络主站的频率。缺省设置为 10，即每 10 个令牌检查一次其它主站。如果设置为 1，表示每一个令牌查询一次。

    有关网络参数设置的意义
  • 键盘蜂鸣器 : 在按键时提供音频反馈。

  • 显示背光灯 : 允许用户选择背光灯开启的时间。缺省设置为 10 分钟。

TD 400C 上的显示背光灯

TD 400C 允许设置显示背光灯的开启时间

以下情况将开启背光灯：

  • 接通 TD400C 的电源。
  • S7-200 CPU 通过 TD 参数块中的 TD_Reset 位强制复位 TD400C。
  • 每按一次按键，背光灯的开启时间都会延长。
  • 读到 S7-200 CPU 中新的报警。

设置 TD 400C 的背光灯

可以按接通时间来设置 TD400C 的显示背光灯：

  • 至 59 分钟，每次增加 1 分钟（默认的接通时间为 10 分钟）
  • 1 小时、2 小时、4 小时和 8 小时
  • 总在开启状态

背光灯的操作注意事项：

  • 开启显示背光灯时，灯光会持续一段时间，该时间可以在 TD 设置菜单中进行组态。
  • 如果当前背光灯是关闭状态并按任一按键，则第一次按键动作将开启背光灯而不会执行该按键的功能。 要执行该按键的功能，必须再按一次按键。
  • 如果 TD400C 中有需要确认的报警（报警信息闪烁）同时该报警已激活，则仅在确认该报警时才开启显示背光灯。
  • 可以通过在不需要显示的时候关闭背光灯，来延长 TD400C 的使用寿命。


用TD400C替换其他TD设备

TD400C和之前版本的文本显示器设备的参数比较：

6AV6640-0AA00-0AX0/6AV6640-0AA00-0AX1
区别：尺寸，用法都一致
0AX0是1.0版本，仅支持英语和中文，
0AX1是2.0版本，除了英语和中文多了德，意，法，西语言

鉴于显示性能和功能升级的需求，就会涉及到不同版本之间的替换，目前仅能购买到 TD400C 应该是2.0版 6AV6 640-0AA00-0AX1 （具体需要找代理商核实），这样S7200的TD设备都会被更换为TD400C，更换注意事项如下所示：

1. 产品性能能否替换：首先新版本的TD在功能上基本都兼容或高于前一版本，产品性能基本会满足要求
2.安装是否修改：TD的安装方式一样，但是不同的版本尺寸可能有变化 具体要查看上表，例如TD400C的开口尺寸以及前面板尺寸都比TD200的大，替换时不仅需要重新开孔，还要考虑安装空间能否满足要求
3. 是否需要重新编程：TD文本显示器的程序在STEP7 Micro/WIN软件的 文本显示 向导里组态，下载到PLC里，TD上没有程序，（如果用户没有源程序，可以上传PLC的程序，就可以得到TD的组态程序）如果要跟换型号一样的模块，程序可以不用修改，但是如果要替换别的版本，需要将原TD的向导组态删除，重新组态新TD的向导并重新下载PLC程序
4. 考虑TD显示器的本身的参数设置 站地址 ，参数块，波特率等

**********************************************************************************************************************************************************************************************************************************************************************************************************************************

举例1，现场使用TD200C及以前的文本显示器 损坏后需要替换成TD400C 需要哪些操作

1. 如果现场的安装条件满足，将安装孔扩大到163.5mm×93.5mm
2. 对照PLC的源程序（如果用户没有源程序，可以上传PLC的程序，就可以得到TD的组态程序），根据之前的TD的组态，将向导修改为TD400C 2.0的，重新组态TD画面（组态TD400C以后，原TD设备所有的组态将会丢失），并根据TD400C的程序要求调用生成的子程序
3. 在新TD400C上设置参数：站地址 ，参数块，波特率等 ，不要用原TD的TD/CPU电缆去连接TD400C，建议使用TD400C的原配电缆

举例2，现场使用TD4001.0或者2.0及以前的文本显示器 损坏后需要替换成TD400C2.0 需要哪些操作

1. 开孔尺寸一致 ，不做修改
2. 可以直接将问题TD更换成TD400C，程序不用修改
3. 在新TD400C上设置参数：站地址 参数块，波特率等


TD 400C - Thrid Party

第三方薄膜开关面板制作

第三方的薄膜开关面板制造商也能为西门子的可自定义文本显示器设计、制造面板。

用户应当向第三方提供自己的按键布局设计的精确尺寸。

TD 400C 的按键尺寸和外观

单位：毫米
允许误差：＋－0.15毫米

图 1. TD 400C 的按键尺寸和外观

第三方薄膜制造厂商

以下是西门子推荐的第三方制造商：

上海格纳德薄膜开关有限公司

n

地址： 上海市徐汇区田林路168号
邮编： 200233
电话： (021) 6495 4317，6495 6071
传真： (021) 6485 7203
联系人：徐德民
手机： 13601692062
网址： http://www.gnad.com

日泰智能科技发展有限公司

地址： 江苏省海门市秀山东路555号
邮编：226100
电话：0513 - 89201650
传真： 0513 - 82380915 - 8004
联系人：龚凯霞
手机： 13912890556
电子邮箱：rt@jshsd.cn
公司主页：http://www.jshsd.cn


TD 400C - Keypad Designer

TD Keypad Designer - TD 键盘设计程序

TD Keypad Designer 是专门用于 TD 100C ， TD 200C ，TD 400C 的键盘设计器。TD Keypad Designer 总是随 STEP 7-Micro/WIN 安装和卸载，因此没有单独的安装程序。

键盘设计器的主要功能是创建设计自定义的键盘布局，以及定义各个键的功能。键盘中可以包含不同大小的按键，这些按键可以具有不同的形状，其功能也可以根据需要自由定义（在相应的 TD 产品的功能范围内）。通过与第三方的图形编辑软件配合，还可以定义面板和按键的颜色、字体，甚至图案。

TD 200C 最多可组态 20 个按键， TD 100C 最多可 组态 14 个按键， TD 400C 最多可组态 15 个按键。用户可以自行定义每个按键的功能。

用户可以为 TD 400C 设计自选图形的背景，以及不同颜色、图案和字体的按键。但与 TD 100C 及 TD 200C 不同的是，TD 400C 按键（键）的位置和大小是固定的。用户能够自定义的只是按键的系统功能。

TD Keypad Designer 的主要功能

TD Keypad Designer 的主要功能为：

  • 自定义按键的布局和功能
  • 辅助设计面板图片、打印、导出面板自定义图片
  • 保存键盘自定义组态文件


TD 400C - Keypad Designer_cfg

自定义 TD 400C 键盘

TD 400C 必须使用 TD Keypad Designer V1.0.4.16 以上版本配置。TD Keypad Designer 将与 STEP 7-Micro/WIN 一起安装；要配置 TD 400C 需要 STEP 7-Micro/WIN V4.0 SP4 以上版本，并设置为中文编程界面。

如何查看软件版本

第一步：启动 TD Keypad Designer

有以下几种方法：

  1. 通过选择“开始” > “SIMATIC” > “TD Keypad Designer”
  2. 在 STEP 7-Micro/WIN 中启动：单击“工具”窗口中的“TD Keypad Designer”图标
  3. 在 STEP 7-Micro/WIN 中启动：单击“工具”菜单中的“TD Keypad Designer”命令

第二步：将 TD Keypad Designer 语言设置成中文（可选）

使用 TD Keypad Designer 为 TD 400C 设计键盘，软件语言必须设置成中文。

TD Keypad Designer 与 STEP 7-Micro/WIN 的语言界面设置一致。如果已经把 Micro/WIN 设置为中文，则不必在此设置。

可以通过进入 “ Tools > Options ” 来将软件设置成中文，如下图：

图 1. 将 TD Keypad Designer 语言设置成中文

第三步：新建 TD 400 C 项目

选择 “ 文件 > 新建 ”

图2. 选择 TD 400C

在对话框中选择 TD 400 C ，出现 TD 400C 键盘模板如下：

图3. TD 400C 键盘模板

第四步：定义按键按钮功能属性

TD 400 C 的按键位置、大小、及数目都是固定的，右侧的键缺省设置为系统键，用户也可以根据需要改变其功能。最多可以组态 15 个按键。

双击选中的键，为该键选择功能属性，输入按键名称并确认。

图4. 定义按键按钮功能属性

您不必定义（或使用）所有按键，某些按键可以为空或保持“无功能”的设置。“无功能”的按键在用户程序中不可以使用。

TD 400C 所支持的按键功能如下：

表1. TD 400C 按键功能列表

类别 | 功能 | 说明
浏览或选择 | Enter | 选择菜单项或确认值
 | Escape | 从菜单退出或取消选择
 | 上箭头 | 向上滚动显示菜单项，或递增可编辑的值
 | 下箭头 | 向下滚动显示菜单项，或递减可编辑的值
 | 左箭头 | 向左移动光标
 | 右箭头 | 向右移动光标
输入数据 | 设置 PLC 位 （相当于F功能键） | 设置 S7-200 CPU 中的存储位，使用文本显示向导分配特定的位地址。 对于 TD 400C，可以通过定义 Shift按键，使用此按键来设置两个不同的位
 | Shift | 允许您使用一个“设置 PLC 位”按键控制 S7-200 CPU 中两个不同的位（TD 200C 和 TD 400C）
 | 数值清零 | 将所输入的值设置为零 (0)
 | 编辑 V 存储区 | 编辑 S7-200 CPU 中的 V 存储区位置。必须在运行时指定 V存储区的地址
用户画面和报警 （用户菜单或报警菜单） | 菜单模式 | 显示标准 TD 菜单
 | 显示报警 | 显示当前报警信息
 | 显示用户菜单 | 显示用户菜单
 | 菜单 1 画面 0 | 显示第一个用户菜单中的第一个用户画面
 | 菜单 2 画面 0 | 显示第二个用户菜单中的第一个用户画面
 | 菜单 3 画面 0 | 显示第三个用户菜单中的第一个用户画面
 | 菜单 4 画面 0 | 显示第四个用户菜单中的第一个用户画面
 | 菜单 5 画面 0 | 显示第五个用户菜单中的第一个用户屏幕
 | 菜单 6 画面 0 | 显示第六个用户菜单中的第一个用户屏幕
 | 菜单 7 画面 0 | 显示第七个用户菜单中的第一个用户屏幕
 | 菜单 8 画面 0 | 显示第八个用户菜单中的第一个用户屏幕
设置 TD 400C （操作员菜单） | CPU 状态 | 显示“查看 CPU 状态”画面 读取并显示 S7-200 的状态
 | 选择语言集 | 显示“设置语言”屏幕，用于在为 TD 200C 和 TD 400C 组态的语言之间切换
 | 设置 PLC 时间和 日期 | 显示“设置时间和日期”画面，用于输入时间和日期
诊断 （诊断菜单） | 改变 PLC 模式 | 显示“改变 CPU 模式”屏幕，用于改变 S7-200 的操作模式
 | 编辑存储区 | 显示“编辑 CPU 存储区”屏幕
 | 强制 I/O | 显示“强制 I/O”屏幕
 | 存储卡编程 | 显示“制作 MC”屏幕，用于将用户程序复制到存储卡
 | TD 设置 | 显示“TD 设置”画面
 | 查看信息 | 显示“查看信息”屏幕
密码 | 释放密码 | 立即恢复 TD 设备的密码保护功能。
无功能 | 无功能 | 允许您将按键标识为“无功能”
表1. TD 400C 所支持的按键功能列表

图5. TD 400C 键盘定义示例

第五步：完成功能键定义，保存功能键定义文件

完成定义后，须使用“文件”菜单中的“保存”命令，将功能键的自定义设置保存为一个 .td4 文件。

至此已经完成了 TD 400C 的功能键自定义任务。在 Micro/WIN 中的文本显示向导中导入此 .td4 文件，就可以完成相应的 TD 400C 配置任务。定义功能键并不需要 TD Keypad Designer 的图形处理功能。 TD Keypad Designer 的另一个功能是辅助第三方的图形编辑软件，完成用户的自定义面板图形设计。

使用 TD Keypad Designer 辅助设计 TD 400C 面板图形


TD 400C - 面板图形 MS Paint

使用图形编辑软件设计 TD 400C 面板图片

设计 TD 面板图片时，可以自定义以下图形元素：

  • 按键图案
  • 背景图片或颜色
  • 文本（用于按键或背景）
  • 标识（和其它图片或文本）

可见图片的自定义功能是非常灵活的。

用户可使用第三方图形处理软件设计 TD 面板。在本示例中，用微软 Windows 的 Paint （ 画图）软件为例简要介绍按键及背景处理过程。 （用户也可以选用其它图形处理软件）

本例中设计面板图形的主要步骤为：

  1. 为面板图片设计背景
  2. 选择按键图案
  3. 添加各种文本
  4. 将图片保存为位图文件

在 MS Paint（微软 Windows 画图）中设计 TD 400C 面板图片

第一步：使用画图软件打开导出的按键布局位图文件

图 1. 用画图软件打开导出的按键布局位图文件

这个按键布局文件可以帮助在图形编辑过程中确定按键和显示屏的位置，以免错乱。

第二步：设计背景图片

在本例中使用了 TD Keypad Designer 自带的按键和背景的示例位图。这些按键和背景的示例位图文件在安装目录的 Images 文件夹下，例如：
C:\Program Files\Siemens\TD Keypad Designer\Images

  1. 再打开一个画图软件，以同时处理两张图片。

  2. 用该软件选择打开一个自带背景图片，例如：

    C:/Program Files/Siemens/TD Keypad Designer/Images/TD 400C /LowRes_96DPI_Backgrounds/template07.bmp

    图 2. 用画图软件打开背景图片

第三步：拷贝按键模板到背景图片中

  1. 在第一步的画图软件中，执行 “ 编辑 ” > “全部选择 ”（Ctrl+A），然后执行拷贝命令（Ctrl+C）。

  2. 回到第二步中打开背景图片的画图软件中，执行 “粘贴”命令（Ctrl+V）。

    注意在前景透明状态时拷贝，如第二步中图 2 中的红圈所示选择“前景透明”，以便添加的元素不致覆盖背景。

    则图片效果如下：

    图 3. 拷贝按键模板到背景图片中

第四步：进行按键图形设计

这里使用 TD Keypad Designer 自带的按键图片，用户也可自行设计。

  1. 再打开一个Paint（画图）软件，并用该软件选择打开一个自带按键图片。
    按键和背景的示例位图在 TD Keypad Designer 的安装目录下，如：
    C:/Program Files/Siemens/TD Keypad Designer/Images

  2. 选择打开

    C:/Program Files/Siemens/TD Keypad Designer/Images/TD 400C/LowRes_96DPI_Buttons/button07.bmp

    图 4. 用画图软件打开按键图片
  3. 拷贝按键并将它粘贴到另一个Paint（画图）软件中（第四步中）的按键位图文件中，并移动到相应位置。

    图 5. 用画图软件打开按键图片

  4. 选择不同的按键，重复以上操作完成所有按键的设计，效果图如下：

    图 6. 选择添加不同的按键

这里选用的都是正方形按键（与面板下的薄膜按键一致）。用户也可以使用合适的图案。

第六步：进行面板文字处理

图 7. 进行面板文字处理

设计完成后即可保存图片文件。图片可以用第三方图形处理软件打印输出到西门子提供的专用面板胶片上，或者送往第三方薄膜开关面板制造厂商。也可以导入回 TD Keypad Designer 再打印输出。导入 TD Keypad Designer 的另一个作用是丰富 TD 配置文件的可视化效果，以便在 Micro/WIN 中的文本显示向导中显示面板图片。

TD 400C空白面板胶片订货号： 6AV6671-0AP00-0AX0， 按包订货，每包10张。

导入图片到 TD Keypad Designer 继续处理


TD200－网络连接

TD 200可通过以下几种方式与S7-200连接：

  1. TD 200单独连接到CPU通信口或EM277通信口

    用与TD 200一起提供的TD/CPU电缆连接，此时TD 200的24V DC电源由CPU（或EM277模块）提供，不要再外接24V DC电源，否则会导致损坏。

  2. TD 200连接到网络中的CPU通信口上

    多个S7-200 CPU联网，如果还需要连接TD 200，可在这个CPU通信口上使用“带编程口”的网络连接器，在与其他CPU组成网络的同时，从TD 200来的电缆连接到扩展出来的编程口上。此时TD 200的24V DC电源由CPU（或EM277模块）提供，不要再外接24V DC电源，否则会导致损坏。

  3. TD 200接入通信网络，或CPU连接多个TD 200

    使用网络连接器（PROFIBUS网络插头），通过PROFIBUS电缆将TD 200接入网络。这时TD 200与其他CPU（或TD 200）等通信站组成了一个线形网络。

    如果CPU上使用“带编程口”的网络连接器，插上编程电缆就是一个多主站编程网络。

    通过PROFIBUS电缆连接TD 200，这时只连接了通信信号线（3和8针），没有连接电源线（2和7针）。要外接24V DC电源为TD 200供电。

图例：

图1. 通过PROFIBUS电缆连接TD 200

在上图中：

  • TD 200通过PROFIBUS网络连接器和电缆连接到S7-200 CPU通信口上的网络连接器，等于接入了网络。CPU通信口上的网络连接器还可以连接到其他通信站点（第三种连接方式）
  • CPU上的PROFIBUS插头是带编程口的，可以用于插编程电缆（如PC/PPI电缆，这时是多主站编程连接），或者连接其他TD 200（第二种连接方式）
  • 红圈内为电源连接器，用于连接外部24V电源（此种连接方式下必须）。
  • 一个CPU连接多个TD 200也必须通过第三种连接方法。
  • 图中CPU的输入端子连接的是输入模拟器

当CPU的通信口被自由口通信所占用时，或TD 200与CPU的距离超过50米时，可用EM277模块连接TD 200与CPU。这时，应当在TD 200设置菜单中将EM277的地址设置为CPU地址。


TD200－文字变量（字符串）

显示文字变量（字符串）

如何用文字显示设备的不同运行状态？

TD 200 V3.0和TD 200C V1.0支持的嵌入数据可以是字符串格式。

在下面的例子中，用户可以根据一个控制信号显示“启动”、“停止”等信号。

第一步：创建画面并输入文本后，再点击“Insert PLC Data”嵌入数据

图1. 编辑菜单并嵌入数据

第二步：定义字符串数据地址

图2. 定义嵌入数据地址

定义字符串数据地址为“VB200”，数据格式为“String”字符串。

第三步：在PLC中编程使TD 200根据输入信号显示不同的字符信息

图3. 编程动态显示字符串

此程序中I0.5代表电机运行状态信号：

  • I0.5为1代表电机启动，将字符串“启动”用指令STR_CPY送到VB2000起始的字符串地址中
  • I0.5为0代表电机停止，将字符串“停止”用指令STR_CPY送到VB2000起始的字符串地址中

注意：在程序中输入字符串须用双引号括起来，双引号须用单字节的（英文标点模式）输入


TD200数据占据长度和范围

TD 200 消息嵌入数据类型、占据的长度和取值范围

TD 200配置时可在消息中内嵌数据，显示CPU内部V存储区的数值内容；嵌入数据可以设置为允许用户编辑，以利操作人员输入一些设定值等；嵌入数据也可以有选择地进行密码保护。

配置时无论选择英文还是中文，每个嵌入数据都要在消息中占据一定的位置（字符长度）。

  • 新版本（TD 200 V3.0和TD 200C V1.0）：嵌入数据总是占据四个字符（单字节文字，如英文）或者2个字符（双字节文字，如中文）的显示位置。被占据的位置变为灰色。在实际的数据块中可以找到它们的配置信息，但这些信息对用户来说没有什么大意义。

  • 旧型号（TD 200 V2.1或更早）：除了选择的数据长度之外（如选择Word字就要占据两个字节，选择Double Word双字就要占据4个字节），还需要附加的字节存储有关信息，如指定数据长度、是否可以编辑等。 在编辑消息中的嵌入数据时，会看到变灰的单元，也就是被占据的单元。

    嵌入数据在消息中占据的上述位置是基本长度。根据数据实际显示的长度，可能需要占据额外的字符长度。如双整数，或者实数（浮点数）可能会需要多个数位。做消息配置时要自己掌握。

新TD 200与旧型号的一个主要不同之处就是在配置后的Data Block（数据块）中不能找到嵌入数据的地址；这些数据的地址只需要在配置时记录下来就可以。

TD 200内所能显示、输入的数据范围

表1. TD 200数据长度

嵌入数据格式 | 符号 | 数值范围
Word（字-整数） | Signed（有符号） | -32768 - 32767
 | Unsigned（无符号） | 0 - 32767
Double Word（双字-整数） | Signed（有符号） | -2147483648 - 2147483647
 | Unsigned（无符号） | 0 - 2147483647
Double Word Real(Floating Point) （双字-浮点数） | Signed（有符号） | +1.175495E-38 至 +3.402823E+38（正数） -1.175495E-38 至 - 3.403823E+38（负数）
String （字符串） | - | 0 - 255（实际受显示字符数的限制）

常问问题

编辑嵌入数据时，“Digits to the right of the decimal”如何应用？

“Digits to the right of the decimal”指定显示几位小数。

即便是实数，如果指定显示小数位数为“0”也无法显示小数部分。

对于整数，如果指定小数位数，在显示时看起来就是小数，而PLC内部当作整数来处理，相当于输入数据的若干个10倍数。这实际上是定点数。

TD 200 是否能对输入数据进行上、下限幅？

不能在嵌入数据时配置，必须在PLC中编程实现，可能要在实际应用的数据前编辑限幅作用程序。这样即便输入了超过限幅，实际有效的数据也不会超出。


TD200 - FAQ

TD 200常问问题

为何TD 200 显示CPU无响应？

原因：

  • 在TD 200中未设置正确的所连接的CPU地址、TD 200地址及通信速率（注意 要与CPU中的一致）
  • 整个网络中的站地址有重复的
  • CPU未上电
  • 电缆连接问题
  • 未保证一个网段内总长度在50米内，总站数在32个内
  • 电磁干扰

为何TD 200 显示无参数块，或时有时无？

原因：

  • CPU中的V存储区（数据块）中为TD 200分配的参数块地址又被其它程序重复使用，改变了TD 200参数块首地址中的信息（ASCII字符'TD'）。
  • CPU存储区中TD 200参数块的首地址，与TD 200中Setup菜单中的设置不同。这种现象常出现在更换TD 200备件时。
报警（消息）不显示或某些信息不显示？

原因：消息的使能位未激活，或者使能位的地址被CPU中其它程序所重复使用。

为何中文显示出现乱码？

原因：文本信息所占用的地址又被其他部分程序所重复使用。

TD 200配置完成后，如何知道所嵌入数据的地址？

在Micro/WIN的Data Block（数据块）中，你可以发现所有嵌入数据的地址。

另可参见TD 200的 功能键和各状态、控制位的符号地址

如何知道TD 200中上下箭头和回车键的地址？

在Micro/WIN的Data Block（数据块）中，你可以发现上下箭头和回车键的位地址。

新型号TD 200（TD 200 V3.1和TD 200C）没有为箭头键提供位地址。

6ES7272-0AA30（TD 200 V2.1）和 6ES7272-0AA20有何区别？

  • 新TD 200（6ES7272-0AA30）是向下兼容的
  • 新的TD 200 应当 使用MicroWin 32 v3.2 SP4对其编程，用低于该版本的MicroWin编程时，不能使用其新功能
  • 新TD 200 功能键可选为脉冲功能，不必再用编程复位
  • 新TD 200 为回车键提供了地址
  • TD 200 用MicroWin 32 v3.2 SP4编程，起始位从VB14开始，用MicroWin 32 v3.2 sp3及以前版本编程，起始位从VB12开始

目前新的TD 200订货号也是6ES7272-0AA30-0YA1，又具有更新的功能。详情请看上述TD 200的版本比较。

为何TD 200中数据无法编辑修改？

原因：
  • 你所看到的信息是在查询状态（即按ESC键后进入功能菜单）中看到的，因而无法编辑
  • 在配置TD 200向导时，在嵌入数据时对该数据选中允许用户编辑数据，则可对其进行设定修改

为什么屏幕上的数据会显示"eeeeeee"?

当CPU里的程序为数据赋值时，该数据可能是与TD 200配置嵌入数据的类型不符，或者数值超出范围，或者嵌入数据时预留的位置不够，数据不能完全显示出来。

一个CPU可以连接几个TD 200？一个TD 200可以连接几个CPU？

CPU通信口可以连接3个TD 200。如果每个TD 200的数据块各不相同，要注意在TD 200中所能设置的数据块起始地址最大为VB999。

如果CPU上的通信口被占用，或者连接数目不够，可以在CPU上附加EM277模块（CPU221除外），EM277的连接数是5个TD 200。

一个TD 200在一个时刻只能与一个CPU通信。

参见：
HMI连接数目
EM277

新TD 200相关的常问问题

进行向导编程前如果出现编译错误，如何处理？

  • 如果是程序逻辑出现错误，则需要改正错误，再进行相应的向导编程
  • 如果是已经完成向导编程，而编译时显示的是向导中的错误，此时由于编译错误，又无法进入向导中改正。这时，在指令树中的数据块（Data Block）里，找到相应的向导的数据块（Data Block > Wizard > TD_DATA_0），并点击右键将其删除，再重新进入向导，将不会显示编译错误，可继续对向导进行修改。有时不进行修改，点击完成，错误会自动消失。

为什么在用户屏幕上显示的报警提示，有的是大的惊叹号，有的是小的惊叹号？

如果在报警画面定义时选择了需要报警确认，则显示的为大的惊叹号；如果在报警画面定义时没有选择需要报警确认，则显示的为小的惊叹号。

使用TD 200 V3.0或TD 200C V1.0时，CPU的程序中是否必须调用TD_CTRL_X？

如果未使用报警或多语言切换功能，则不用调用TD_CTRL_X；如果使用了报警或多语言切换功能，则必须调用TD_CTRL_X。

TD 200的菜单或报警中定义了中文字符、英文字符或数字、变量，为何有时无法正常显示？

定义中文显示字符时，也可以输入单字节的拉丁字符（如英文、阿拉伯数字）。但是在混合使用上述字符集时，要注意是起始的、或双字节的字符后面紧跟的单字节字符的右边，只能输入单字节字符，或者单字节的空格。

TD 200向导在中文状态可以为每行文本输入10个双字节字符。每个双字节字符的位置可以放下列组合中的一种：

  • 一个双字节字符（汉字字符）
  • 两个双字节字符
  • 一个单字节字符，再加一个单字节空格


TD - 屏幕控制

如何通过用户程序逻辑或 TD 按键控制屏幕显示？

新一代 TD 显示器（包括 TD 200 V3.0 以上版、TD 400C V1.0 以上版等）同时支持两种显示模式：菜单模式和报警模式。

其中菜单模式是预定义一个菜单结构，操作者可以用 TD 上的箭头、Enter 等键在菜单体系中浏览；报警模式是定义一系列报警消息，实际上就是文本消息，消息的显示由用户程序驱动，当然也可以由 TD 上的功能键通过用户程序驱动。

TD 可以配置为仅使用菜单模式，也可以仅使用报警模式，或者同时使用这两种模式。如果同时使用菜单和报警模式，还需要预先指定将哪种模式设置为“默认模式”。

如果默认是菜单模式，则上电后 TD 将显示菜单配置中定义的首页，如果此时有报警消息激活则不会直接显示， 而是在屏幕上显示一个标记；如果默认是报警模式，则上电后 TD 将保持在报警显示下，如此时没有报警消息显示，则 TD 会提示无报警信息。

这两种显示模式之间，可以用 TD 上的按键进行切换。

因此，如果需要显示一个能够由用户程序，或者 TD 上的按键控制的“菜单”体系，应该使用报警模式。在这种模式下，所有的消息显示都可以由编程者（或者开放给操作员）控制。

目前在菜单模式下，还没有能够以程序逻辑控制显示的功能。

常问问题

TD 400C文本显示器是否支持触发报警信息时自动从用户屏幕切换到报警屏幕？

不支持。

触发报警信息时，如何不使用功能键切换屏幕查看该报警信息，而在TD 400C文本显示器的同一屏幕上自动显示？

选择默认显示模式为“报警信息”，并且，将用户信息组态在“报警信息”屏幕，使其一直使能。这样，当其它报警信息未被触发时，将显示用户信息；当其它报警信息被触发时，可以不使用功能键切换屏幕，而在TD 400C文本显示器的同一屏幕上自动显示该报警信息。

例子：如果用户信息（如“室内温度”）需要一直显示，当出现“温度高报警”时，不使用功能键切换屏幕，该报警信息在TD 400C文本显示器的同一屏幕上自动显示。关键组态及编程如下所示：

1. 选择使用的信息长度及默认显示模式为“报警信息”，如下图1所示：

图1. 选择显示模式“报警信息”

注：可选择单行文本或双行文本。

如果选择全屏文本，当其它报警信息未被触发时，将显示用户信息；而当其它报警信息被触发时将不能在同一屏幕显示，需通过功能键切换，因此对于此问题没有实用意义。

2. 将用户信息（如“室内温度”）组态在“报警信息”屏幕，并且一直调用，使其可以在默认的“报警信息”屏幕上一直显示。如下图2所示：

图2. 将用户信息组态在“报警信息 ”屏幕

3. 在“新报警”屏幕中，组态其它的报警信息（如“温度高报警”）。如下图3所示：

图3. 组态报警信息

4.报警信息编程

在程序中，除一直调用初始化指令之外，使用SM0.0一直调用组态为“报警信息Alram0_0”的用户信息，使其可以在默认的“报警信息”屏幕上一直显示。

调用报警信息Alram0_1，当报警触发条件满足时（如“温度传感器”接通），可在该屏幕中“报警信息Alram0_0”的下一行显示Alram0_1的报警信息。如下图4所示：

图4. 报警信息编程

注：以上例子Alram0_0及Alram0_1的地址取决于TD 400C组态分配的建议地址！


ProTool/Pro RT连接

西门子HMI与S7-200的连接

西门子的人机操作面板与ProTool/Pro与S7-200的连接具有相似性。

详细的配置设置请参照《面板或ProTool/Pro Runtime与S7-200 PLC的连接》。

可以访问：

http://www.ad.siemens.com.cn/Service/e-training/micro

下载相关的文档。


HMI的多主站连接

HMI与S7-200 CPU的多主站连接

对于HMI（人机操作接口设备）来说，在S7-200系统中的多主站连接包括以下几种情况：

  • 网络上有其他HMI，CPU不做PPI通信主站（无网络读写指令使用）
  • 网络上有CPU做PPI通信主站
  • 网络上有Micro/WIN编程计算机

所谓CPU做主站，就是CPU特定的通信口进行网络读写（NetR/NetW）操作，如果CPU的两个通信口分别连接不同的网络，不做网络读写的通信口在网上不算主站。下文同此。

第三方的HMI是否支持多主站连接请咨询其厂商，西门子不做测试。

ProTool/Pro Runtime等软件HMI不能管理新版多主站电缆，不能使用新版电缆实现多主站通信；只能将新电缆的DIP开关5拨到OFF，实现单主站连接。要进行多主站通信，只能使用CP卡通信（CP5611/CP5613等）。

上述HMI软件要通过新版多主站电缆实现多主站连接，只能通过PC Access（OPC Server）软件。当然它们必须支持OPC连接功能。

网络上有其他HMI

老产品 TP 070 (已淘汰)不允许网络上有其他HMI存在。其他产品无此要求。

网络上有CPU做通信主站

网络上有CPU做通信主站，也就是使用NetR/NetW（网络读写）指令访问其他CPU的数据时，这种多主站连接比较复杂。完全支持此种多主站连接的 HMI 包括西门子提供的：

  • TD 200/TD 200C
  • K-TP 178micro
  • OP 73micro
  • TP 177micro
  • TP170 micro
  • PC Access（OPC Server接口）

其他西门子出产的 HMI 产品，只要能够选择 PPI 通信协议，都可以支持与网络中做 PPI 主站的S7-200 CPU (端口)通信。老产品 TP 070 除外。

网络上有Micro/WIN编程计算机

支持此种多主站连接的 HMI 主要包括西门子提供的：

  • TD 200/TD 200C
  • K-TP 178micro
  • OP 73micro
  • TP 177micro
  • TP170micro
  • TP170A/B/OP170B
  • MP270/MP270B/OP270/TP270
  • MP370
  • HMI与S7-200连接数目表1.中的其他面板
  • ProTool/Pro RT等
  • PC Access（OPC Server接口）

需使用Micro/WIN V3.2 SP4以上版本，和新版多主站编程电缆。


HMI - 实时时钟同步

如何同步操作面板与 S7-200 控制器的日期和时间？

HMI 人机操作界面与 S7-200 的时钟同步功能包括两个方向的时钟同步：

  1. PLC 到面板的时钟同步。

    西门子操作面板可分为硬件时钟面板（TP/OP/MP270，MP370 等）和软件时钟面板（XP170X， XP177X，K-TP178 micro 等）。软件时钟面板和无备份电池的硬件时钟面板， 当断电关机后， 面板的内部时钟就会丢失, 回到出厂时的状态。但面板可以通过设置，来定时读取 PLC 的硬件时钟信息，以保持和 PLC 时钟一致，这就是 PLC 到面板的时钟同步。

  2. 面板到 PLC 的时钟同步。

    与上述相反，即用面板的时钟来校准 PLC 的系统时钟。PLC 实际上是得到面板的时钟信息后，调用相应设置时钟的函数（或者通过用户编制的程序），更改自己的系统时钟，以保持和面板时钟一致。在本文所提供的例程中，实现的是用 PLC 的时间同步面板系统时钟，同时可以在面板上修改 PLC 的时钟，从而间接地修改了面板的系统时钟。

S7-200 系列中 CPU 224 以上的 CPU 都有内置的实时时钟，而 CPU 221/CPU 222 没有内置实时时钟，需要外插“时钟电池卡”才能使用实时时钟和时钟同步功能。

使用 S7-200 CPU 时钟同步面板时钟

用 S7 时间同步面板时间的主要操作步骤如下：

  1. 在 S7-200 中编程读取 CPU 系统时钟。，周期调用 READ_RTC 函数，以读取 S7-200 CPU 的系统时钟，将时钟信息存放在 V 存储区，比如 VB100。

    图1. 读取 S7-200 实时时钟

  2. 在面板上配置时钟同步功能

    • 使用 WinCC Flexible 配置：

      请先设置好通讯参数；然后在“区域指针”页内，建立“日期/时间 PLC”, 指向 S7-200 中存放时间信息的区域 VW100 即可。见下图：

      图 2. 在 WinCC flexible 中配置面板时钟同步

    • 使用 ProTool 配置

      请先设置好控制器的通讯参数；然后插入“日期/时间-PLC” 区域指针, 指向S7-200 中存放时间信息的区域VW100即可。见下图：

      图 3. 在 ProTool 中配置面板时钟同步

在面板上设置 S7-200 实时时钟

通过面板修改 S7-200 的实时时钟，主要有以下几个步骤：

  1. 在面板上建立相应的输入变量

    可以新建一个标志变量（比如：地址为 V20.0）和用于触发 S7-200 CPU 的写实时时钟功能，建立年、月、日、时、分、秒 、星期等 BYTE 变量，按照 S7-200 时钟缓冲区的格式分别连接到 PLC 的连续 V 存储区中，比如：VB70 – VB77。

    因 S7-200 时钟设置指令的要求，这些 BYTE 变量必须是以 BCD 格式存在，在配置时可选用“16进制”数据格式。在面板上设置的数据必须是有效的 BCD 格式的时间、日期数据，包括星期的信息（有如需要，星期信息可能需要进行必要的转换处理），否则会导致时钟同步失败。

  2. 在 S7-200 中编程，用标志变量触发来调用 SET_RTC，将 VB70 起始的缓冲区地址作为时间参数传递给该函数，来实现通过面板修改S7 PLC时间。

    图 4. 编程设置 S7-200 时钟。其中 V20.0 为触发写时钟的标志。

常问问题

如何实现 K-TP 178 micro 面板与 S7-200 的时钟同步？

步骤和方法与上述内容相同。

S7-200 的实时时钟功能


TP7

TP7是240x128象素、4.7英寸的4级灰度液晶显示屏，512KB EPROM/128KB RAM。

TP7的订货号是6AV3 607-1NH00-0AX0。

TP7与PC和S7-200 PLC的连接电缆

表1. TP7与PC机COM1（9针）通信口的配置下载电缆

TP7 | PC | 备注
(RXD) 3 | 3 (TXD) |
(TXD) 2 | 2 (RXD) |
(GND) 7 | 5 (GND) |
(RTS) 4 | 8 (CTS) |
(CTS) 5 | 7 (RTS) |
 | 6 (DSR) | PC侧短接
 | 1 (DCD) | PC侧短接
 | 4 (DTR) | PC侧短接

表2. TP7与PC机COM2（25针）通信口的配置下载电缆

TP7 | PC | 备注
(RXD) 3 | 2 (TXD) |
(TXD) 2 | 3 (RXD) |
(GND) 7 | 7 (GND) |
(RTS) 4 | 5 (CTS) |
(CTS) 5 | 4 (RTS) |
 | 6 (DSR) | PC侧短接
 | 8 (DCD) | PC侧短接
 | 20 (DTR) | PC侧短接

表3. TP7与S7-200 CPU的PPI端口连接电缆

TP7 | CPU | 备注
(TXD+/RXD+) 14 | 3 (TXD+/RXD+) |
(TXD-/RXD-) 15 | 8 (TXD-/RXD-) |
(GND) 7 | 5 (GND) |

TP7的错误代码

TP7与S7-200 PLC连接时，其错误代码的前两位为PLC的站号。

表4. READ ERROR（读错误）

错误代码 | 意义 | 释义
02 02 | Check Sum Error | PLC 02号站，传回Check Sum错误
02 03 | Unknown Message | PLC 02号站，传回错误的码
02 04 | Communication Time Out | PLC 02号站，没有回应
02 05 | Invalid Function | TP7执行的功能无效
02 06 | Invalid Address | TP7元件地址错误
02 07 | Invalid Data Value | TP7元件值错误
02 08 | Invalid Range | TP7元件地址范围错误
02 09 | No Resource | PLC 02号站忙
02 0A | No Service | PLC 02号站忙
02 0B | Hardware Fault |
02 0C | Illegal Object |
02 0D | Invalid Address |
02 0E | No Supported |
02 0F | No Exit |

表5. WRITE ERROR（写错误）

错误代码 | 意义 | 释义
02 82 | Check Sum Error | PLC 02号站，传回Check Sum错误
02 83 | Unknown Message | PLC 02号站，传回错误的码
02 84 | Communication Time Out | PLC 02号站，没有回应
02 85 | Invalid Function | TP7执行的功能无效
02 86 | Invalid Address | TP7元件地址错误
02 87 | Invalid Data Value | TP7元件值错误
02 88 | Invalid Range | TP7元件地址范围错误
02 89 | No Resource | PLC 02号站忙
02 8A | No Service | PLC 02号站忙
02 8B | Hardware Fault |
02 8C | Illegal Object |
02 8D | Invalid Address |
02 8E | No Supported |
02 8F | No Exit |

常见故障检查项目

  1. 没有收到任何消息（Time Out）

    须检查的可能故障

    1. 电缆接错或没接好
    2. 参数设定错误（COM口、波特率、TP7站号、PLC站号...）

  2. 收到无法辨认的消息（Unkonwn Message）

    须检查的可能故障

    1. 电缆接错或没接好
    2. 参数设定错误（COM口、波特率、TP7站号、PLC站号...）

  3. 收到PLC传回的错误代码

    PLC不接受这个指令，传回一个说明原因的错误代码。可能是地址错误、范围错误、资料错误，或无此功能的错误。

    原因是TP7的项目配置与PLC没有配合好，应根据所显示的错误代码检查相关的设定。

    1. 地址错误、范围错误： 所读写的地址，无法识别
    2. 资料错误：所写的值不被接收
    3. 无此功能的错误：执行了一个不能接受的功能
    4. PLC忙：PLC工作量太大，无法正常工作

TP7配置软件和手册

TP7的配置软件、手册可以在西门子中文下载网站上下载：

http://www.ad.siemens.com.cn/download


连接第三方上位机

连接第三方HMI/SCADA软件（上位机）

与第三方HMI/SCADA软件（上位机），请咨询设备/软件提供商。西门子无法提供建议和支持。

需要考虑的问题有：

  • 对方支持何种S7-200的通信协议
  • 对方是何标准的通信接口，是否需要转换

所有这些问题只有第三方HMI供应商才知道。

参考：

连接第三方HMI/SCADA软件（上位机）


S7-200 - Drive

S7-200 与西门子驱动装置

电气驱动（传动）装置用于把电能转换为机械动能，在工业与民用范围内得到了极为广泛的应用。电气传动始终是一个极为重要的自动化控制领域，是基础自动化的重要组成部分。西门子自动化与驱动集团作为全球行业领先者，能够提供电气传动领域内的全线产品和全套解决方案。

驱动装置与其他控制设备组成能够实现具体任务的控制系统。随着自动化技术的发展和推广，驱动装置越来越多地与可编程控制器（PLC）配合应用。

S7-200 是西门子为小型自动化领域提供的极为成功的产品。可扩展性和通信能力是 S7-200 的突出优点。 S7-200 与西门子驱动装置同出一门， 兼容性极好，很容易达成性价比高的应用组合。

驱动装置按照拖动的电动机类型可以分为直流与交流传动两类，按照电动机的电压等级和容量也分成很多类型。西门子的驱动产品也相应地区分为许多系列。其中常见的有标准变频传动装置 MicroMaster 系列、高性能驱动装置 MasterDrive 系列，以及新产品 SINAMICS 系列等。不同的产品系列性能、功能不同。

本章中将主要用西门子 MicroMaster 系列的 MM 440 变频器为例，介绍 S7-200 与驱动装置的连接。

S7-200 与西门子驱动装置的连接形式

PLC 与驱动装置连接配合，主要实现的任务是：

  • 控制驱动装置的启动、停止等运行状态
  • 控制驱动装置的转速等参数
  • 获取驱动装置的状态和参数

根据控制任务的具体要求，并考虑到 S7-200 和驱动装置的性能特点，S7-200 和西门子传动装置主要可以通过以下几种方式连接在一起工作：

  • S7-200 通过数字量（DI/DO）信号控制驱动装置的运行状态和速度
  • S7-200 通过数字量信号控制驱动装置的运行状态；通过模拟量（AI/AO）信号控制转速等参数
  • S7-200 通过串行通信控制驱动装置的运行和各种参数

西门子的驱动装置不是所有的型号都支持串行通信；能够支持通信控制的也可能支持多种通信方式，如 PROFIBUS-DP, CANopen, DeviceNet 等等。


USS - Protocol

S7-200 与西门子驱动装置通过 USS 通信连接

西门子驱动装置支持多种通信方式（有些可能需要加装通信卡）。S7-200 CPU 上的通信口在自由口模式下，可以支持 USS 通信协议。这是因为 S7-200 的自由口模式的（硬件）字符传输格式，可以定义为 USS 通信对象所需要的模式；S7-200 的自由口通信功能又非常灵活。因而可以实现 S7-200 和驱动装置之间的 USS 通信控制。

S7-200 CPU 将在 USS 通信中作为主站。

USS 通信协议简介

USS (Universal Serial Interface, 即通用串行通信接口) 是西门子专为驱动装置开发的通信协议，多年来也经历了一个不断发展、完善的过程。最初 USS 用于对驱动装置进行参数化操作，即更多地面向参数设置。在驱动装置和操作面板、调试软件（如 DriveES/STARTER）的连接中得到广泛的应用。近来 USS 因其协议简单、硬件要求较低，也越来越多地用于和控制器（如 PLC）的通信，实现一般水平的通信控制。

注意： USS 提供了一种低成本的，比较简易的通信控制途径，由于其本身的设计，USS 不能用在对通信速率和数据传输量有较高要求的场合。在这些对通信要求高的场合，应当选择实时性更好的通信方式，如 PROFIBUS-DP 等。在进行系统设计时，必须考虑到 USS 的这一局限性。

例如，如果在一些速度同步要求比较高的应用场合（如造纸生产线），对十几甚至数十台变频器采用 USS 通信控制，其效果可想而知。

USS 协议的基本特点如下：

  • 支持多点通信（因而可以应用在 RS 485 等网络上）
  • 采用单主站的“主－从”访问机制
  • 一个网络上最多可以有 32 个节点（最多 31 个从站）
  • 简单可靠的报文格式，使数据传输灵活高效
  • 容易实现，成本较低

USS 的工作机制是，通信总是由主站发起，USS 主站不断循环轮询各个从站，从站根据收到的指令，决定是否、以及如何响应。从站永远不会主动发送数据。从站在以下条件满足时应答：

  • 接收到的主站报文没有错误，并且
  • 本从站在接收到主站报文中被寻址

上述条件不满足，或者主站发出的是广播报文，从站不会做任何响应。

对于主站来说，从站必须在接收到主站报文之后的一定时间内发回响应。否则主站将视为出错。

USS 字符帧格式

USS 的字符传输格式符合 UART 规范，即使用串行异步传输方式。USS 在串行数据总线上的字符传输帧为 11 位长度，包括：

起始位 | 数据位 |  |  |  |  |  |  |  | 校验位 | 停止位
1 | 0 LSB | 1 | 2 | 3 | 4 | 5 | 6 | 7 MSB | 偶 x 1 | 1

连续的字符帧组成 USS 报文。 在一条报文中，字符帧之间的间隔延时要小于两个字符帧的传输时间（当然这个时间取决于传输速率）。

S7-200 CPU 的自由口通信模式正好能够支持上述字符帧格式。把 S7-200 的自由口定义为以上字符传输模式，就能通过编程，实现 USS 协议报文的发送和接收。主站控制器的所支持的通信模式必须和所要控制的驱动装置所要求的一致，这是实现 S7-200 和西门子驱动装置通信的基础。

USS 报文帧格式

USS 协议的报文简洁可靠，高效灵活。报文由一连串的字符组成，协议中定义了它们的特定功能：

STX | LGE | ADR | 净数据区 |  |  |  |  | BCC
 |  |  | 1. | 2. | 3. | ... | n

以上每小格代表一个字符（字节）。其中：

  • STX： 起始字符，总是 02 h
  • LGE： 报文长度
  • ADR：从站地址及报文类型
  • BCC： BCC 校验符

在 ADR 和 BCC 之间的数据字节，称为 USS 的净数据。主站和从站交换的数据都包括在每条报文的净数据区域内。

净数据区由 PKW 区和 PZD 区组成：

PKW 区 |  |  |  |  |  | PZD 区
PKE | IND | PWE1 | PWE2 | ... | PWEm | PZD1 | PZD2 | ... | PZDn

以上每小格代表一个字（两个字节）。

  • PKW： 此区域用于读写参数值、参数定义或参数描述文本，并可修改和报告参数的改变 。其中：

    • PKE： 参数 ID。包括代表主站指令和从站响应的信息，以及参数号等
    • IND： 参数索引，主要用于与 PKE 配合定位参数
    • PWEm：参数值数据

  • PZD： 此区域用于在主站和从站之间传递控制和过程数据。控制参数按设定好的固定格式在主、从站之间对应往返。如：

    • PZD1：主站发给从站的控制字/从站返回主站的状态字
    • PZD2： 主站发给从站的给定/从站返回主站的实际反馈
    • PZDn： ……

根据传输的数据类型和驱动装置的不同，PKW 和 PZD 区的数据长度都不是固定的，它们可以灵活改变以适应具体的需要。但是，在用于与控制器通信的自动控制任务时，网络上的所有节点都要按相同的设定工作，并且在整个工作过程中不能随意改变。

注意：

  • 对于不同的驱动装置和工作模式，PKW 和 PZD 的长度可以按一定规律定义。 一旦确定就不能在运行中随意改变
  • PKW 可以访问所有对 USS 通信开放的参数；而 PZD 仅能访问特定的控制和过程数据
  • PKW 在许多驱动装置中是作为后台任务处理，因此 PZD 的实时性要比 PKW 好

以上仅是对 USS 协议的简单介绍，以帮助读者更好地理解控制任务和选择对策。如需要了解详细的信息，请参考相应驱动产品的手册。

USS 的复杂性和 S7-200 作为主站的对策

USS 通信的复杂性体现在它在不同的应用场合不是固定不变的。这是因为：

  • USS 经过长期的发展，存在一些子集和变种
  • 驱动装置可能不支持 USS 通信协议中的部分功能
  • 不同的驱动装置的参数定义可能有很大区别

这些原因导致一个实用的 USS 主站必须针对不同的驱动装置做出改动。使用 USS 调试驱动装置的软件就要做到这一点。这就给在 S7-200 上做一个通用的 USS 程序带来了实质的困难。

一个驱动产品，只要它支持 USS 通信，S7-200 就可以通过自由口编程对其控制。通过其手册能够了解它支持 USS 通信的特点，从而编出适合的程序。这种任务往往比较复杂而且耗费时间。西门子为解决这一问题，针对应用比较广泛，产品线比较相配的驱动产品，开发了 S7-200 的 USS 指令库。

S7-200 的 USS 指令库

S7-200 的 USS 指令库最初是针对 MicroMaster 3 系列产品的，经过一段时间的发展，现在以及能够完全支持 MicroMaster 3 系列和 MicroMaster 4 （MM4）系列产品，以及 SINAMICS G110 系列产品；目前此 USS 指令库还能对 MasterDrive 等产品提供有限的支持，这些产品包括 6SE70/6RA70 等。

本章中将用 MM440 变频器与 S7-200 之间的 USS 通信为例。


USS - 接线

S7-200 和驱动装置的 USS 通信接线

支持 USS 通信的驱动装置可能有不止一个 USS 通信端口，以 MicroMaster 系列的 MM 440 为例，它在操作面板 BOP 接口上支持 USS 的 RS 232 连接，在端子上支持 USS 的 RS 485 连接。

S7-200 CPU 的通信端口就是 RS 485 规格的，因此将 S7-200 的通信端口与驱动装置的 RS 485 端口连接，在 RS 485 网络上实现 USS 通信无疑是最方便经济的。

S7-200 系统中的 RS 485 通信

S7-200 CPU 与 MM440 组成的网络无疑需要满足 RS 485 网络的通用要求。但是仍然有一些需要特别注意的地方。

S7-200 CPU 和 MM 440 通信端口都是非隔离型的，故西门子承诺的网络连接距离为 50 米，前提是使用西门子推荐的网络设备。如果有必要，也可以外接通信端口的信号隔离、放大器件。

S7-200 CPU 通信端口

在规划网络时，S7-200 CPU 既可以放在整个总线型网络的一端，也可以放在网络的中间。

我们建议使用西门子的网络插头和 PROFIBUS 电缆。在 S7-200 CPU 通信口上使用西门子网络插头，可以利用插头上的终端和偏置电阻。如果使用带编程口的网络插头，可便于调试程序。

参见 S7-200 CPU 通信口引脚定义，可以发现：PROFIBUS 电缆的红色导线连接到 S7-200 CPU 通信口的 3 针（B 即 RS 485 信号 +），此信号应当连接到 MM 440 通信端口的 P+；绿色导线连接到 S7-200 CPU 通信口的 8 针（A 即 RS 485 信号 -），此信号应当连接到 MM 440 通信端口的 N-。

MM 440 通信端口

图 1. MM 440 的端子

在 MM 440 前面板上的通信端口是 RS 485 端口。与 USS 通信有关的前面板端子有：

表 1. MM 440 的 USS 通信相关端子

端子号 | 名称 | 功能
1 | - | 电源输出 10 V
2 | - | 电源输出 0 V
29 | P+ | RS 485 信号 +
30 | N- | RS 485 信号 -

因 MM 440 通信口是端子连接，故 PROFIBUS 电缆不需要网络插头，而是剥出线头直接压在端子上。如果还要连接下一个驱动装置，则两条电缆的同色芯线可以压在同一个端子内。

PROFIBUS 电缆的红色芯线应当压入端子 29；绿色芯线应当连接到端子 30。

一个示例接线图如下：

图 2. S7-200 与 MM 440 的 USS 通信接线

图中：

  1. 屏蔽/保护接地母排，或可靠的多点接地。此连接对抑制干扰有重要意义。
  2. PROFIBUS 网络插头，内置偏置和终端电阻。
  3. MM 440 端的偏置和终端电阻，随包装提供。
  4. 通信口的等电位连接。可以保护通信口不致因共模电压差损坏或通信中断。M 未必需要和 PE 连接。
  5. 双绞屏蔽电缆（PROFIBUS）电缆，因是高速通信，电缆的屏蔽层须双端接地（接 PE）。

注意：以下几点对网络的性能有极为重要的影响。几乎所有网络通信质量方面的问题都与未考虑到下列事项有关：

  • 偏置电阻用于在复杂的环境下确保通信线上的电平在总线未被驱动时保持稳定；终端电阻用于吸收网络上的反射信号。一个完善的总线型网络必须在两端接偏置和终端电阻。
  • 通信口 M 的等电位连接建议单独采用较粗的导线 ，而不要使用 PROFIBUS 的屏蔽层，因为此连接上可能有较大的电流，以致通信中断。
  • PROFIBUS 电缆的屏蔽层要尽量大面积接 PE。一个实用的做法是在靠近插头、接线端子处环剥外皮，用压箍将裸露的屏蔽层压紧在 PE 接地体上（如 PE 母排或良好接地的裸露金属安装板）。
  • 通信线与动力线分开布线；紧贴金属板安装也能改善抗干扰能力。驱动装置的输入/输出端要尽量采用滤波装置，并使用屏蔽电缆。

在 MM 440 的包装内提供了终端偏置电阻元件，接线时可按说明书直接压在端子上。如果可能，可采用热缩管将此元件包裹，并适当固定。


USS - 编程步骤

S7-200 USS 编程步骤

S7-200 CPU 上的 RS 485 通信口可以编程为工作在自由口模式下，支持 USS 通信协议。S7-200 CPU 的通信口大多直接与驱动装置的 RS 485 通信接口连接。

S7-200 CPU 与驱动装置进行 USS 通信时可以：

  • 根据驱动装置的具体 USS 通信规范，用户自己编程实现 USS 通信。此方式可以保证该驱动装置的所有 USS 通信功能都能得到使用；
  • 使用西门子提供的 USS 通信指令库，实现与 MicroMaster 系列的 MM3/MM4 和 SINAMICS G110 的USS 通信。此指令库只能有限地支持与其他驱动装置的 USS 连接。

使用西门子提供的 USS 指令库，用户就不必自己配置复杂的 PKW/PZD 数据，或者计算校验字节。但是能通信的驱动装置有局限性。

以下介绍通过西门子提供的 USS 指令库与 MM 400 之间的串行通信控制。

STEP 7-Micro/WIN USS 指令库编程

S7-200 的 USS 编程主要包括如下几个步骤：

  1. 安装 USS 指令库
  2. 调用 USS 初始化指令
  3. 调用驱动装置控制指令
  4. 调用驱动装置参数读写指令


USS - 安装指令库

安装 USS 指令库

安装完成后的 USS 指令库在 S7-200 的编程软件 STEP 7-Micro/WIN 指令树中的“库”指令分支。

图 1. 已安装的库指令（Micro/WIN V4.0 SP5）

西门子的标准 USS 协议库以浅蓝色图标表示。如果未找到浅蓝色图标的指令库，说明系统中没有安装西门子标准指令库。必须先安装标准指令库。

指令库的升级：如果 Micro/WIN 中已经安装了西门子标准指令库，以后只要升级编程软件 STEP 7-Micro/WIN ，就能更新指令库到当时最新的版本。安装了当前最新的 STEP 7-Micro/WIN 版本，再安装西门子标准指令库也能获得当前最新的库版本。安装STEP 7-Micro/WIN V4.0 SP5或以上版本后，可以获得最新的版本 USS Protocol 通信协议指令库。

西门子标准指令库及其安装
STEP 7-Micro/WIN 下载

USS 指令库初始化


USS - 初始化指令

西门子的 S7-200 USS 标准指令库包括 14 个子程序和 3 个中断服务程序。但是只有 8 个指令可供用户使用。一些子程序和所有中断服务程序都在调用相关的指令后自动起作用。

每个 USS 库应用都要先进行 USS 通信的初始化。使用 USS_INIT 指令初始化 USS 通信功能。

图 1. 选择 USS_INIT 指令

打开 USS 指令库分支，像调用子程序一样调用 USS_INIT 指令。

图 2. 调用 USS_INIT 指令

图中：

  1. EN： 初始化程序 USS_INIT 只需在程序中执行一个周期就能改变通信口的功能，以及进行其他一些必要的初始设置，因此可以使用 SM0.1 或者沿触发的接点调用 USS_INIT 指令；
  2. Mode： 模式选择，执行 USS_INIT 时 ，Mode 的状态决定 是否在 Port 0 上使用 USS 通信功能；
    = 1
    设置 Port 0 为 USS 通信协议并进行相关初始化
    0
    恢复 Port 0 为 PPI 从站模式
  3. Baud： USS 通信波特率。此参数要和变频器的参数设置一致；
    =
    2400
    2400 bit/s
    4800
    4800 bit/s
    9600
    9600 bit/s
    19200
    19200 bit/s
    38400
    38400 bit/s
    57600
    57600 bit/s
    115200
    115200 bit/s
  4. Active： 此参数决定网络上的哪些 USS 从站在通信中有效。详见下面的说明；
  5. Done： 初始化完成标志
  6. Error： 初始化错误代码

Active 参数

USS_INIT 子程序的 Active 参数用来表示网络上哪些 USS 从站要被主站访问，即在主站的轮询表中激活。网络上作为 USS 从站的驱动装置每个都有不同的 USS 协议地址，主站要访问的驱动装置，其地址必须在主站的轮询表中激活。USS_INIT 指令只用一个 32 位长的双字来映射 USS 从站有效地址表，Active 的无符号整数值就是它在指令输入端的取值。

表 1. 从站地址映射
位号 | MSB 31 | 30 | 29 | 28 | ... | 03 | 02 | 01 | LSB 00
对应从站地址 | 31 | 30 | 29 | 28 | ... | 3 | 2 | 1 | 0
从站激活标志 | 0 | 0 | 0 | 0 | ... | 1 | 0 | 0 | 0
取 16 进制无符号整数值 | 0 |  |  |  | ... | 8
Active = | 16#00000008

在这个 32 位的双字中，每一位的位号表示 USS 从站的地址号；要在网络中激活某地址号的驱动装置，则需要把相应位号的位置设为二进制“1"，不需要激活 USS 从站，相应的位设置为”0"。最后对此双字取无符号整数就可以得出 Active 参数的取值。

在表 1 的例子中，我们将使用站地址为 3 的 MM 440 变频器，则须在位号为 03 的位单元格中填入二进制“1"。其他不需要激活的地址 对应的位设置为”0"。取整数，计算出的 Active 值为 00000008 h，即 16#00000008，也等于十进制数 8（如图 1.中的 d）

建议使用 16 进制数，这样可以每 4 位一组进行加权计算出 16 进制数，并组合成一个整数。当然也可以表示为十进制或二进制数值，但有时会很麻烦，而且不直观。

如果一时难以计算出有多个 USS 从站配置情况下的 Active 值，可以使用 Windows 自带的计算器。将其设置为科学计算器模式，可以方便地转换数制。

分配库存储区地址

USS 指令库需要大概 400 个字节的 V 存储区用于支持其工作。调用 USS_INIT 指令后就可以为 USS 指令库分配库存储区。也可以在编程的稍后阶段分配存储区地址，但这一步是必不可少的，否则程序无法通过编译。

根据 S7-200 中的数据存储区分配原则，分配给库指令的数据区绝对不能与其他程序使用的数据区有任何重叠。否则会造成出错。

参见：库存储区分配

通信端口的重复定义

用户程序调用 USS_INIT 指令可以重复定义通信口的模式，以恢复为 PPI 从站模式，或者再次定义为 USS 主站模式。

对于只有一个通信口的 S7-200 来说，恢复通信口为 PPI 从站模式但仍保持 CPU 为 RUN 状态可以提供程序调试的便利。CPU 上的工作模式选择开关可以用来简单地实现此功能。

特殊存储区位 SM0.7 的值对应于模式选择开关的位置， 开关位置为 RUN 时，SM0.7 = 1；开关位置为 STOP 时，SM0.7 = 0。 开关从 RUN 或者 STOP 位置拨到 TERM 时， CPU 不改变工作模式。

实际编程如下：

图 3. 通信端口的重定义用法


USS - CTRL 指令

USS 驱动装置控制功能块

USS_CTRL 指令用于对单个驱动装置进行运行控制。这个功能块利用了 USS 协议中的 PZD 数据传输，控制和反馈信号更新较快。

网络上的每一个激活的 USS 驱动装置从站，都要在程序中调用一个独占的 USS_CTRL 指令，而且只能调用一次。需要控制的驱动装置必须在 USS 初始化指令运行时定义为“激活”。

图 1. USS_CTRL 指令

在 USS 通信指令库分支中选择 USS_CTRL 指令。

图 2. 调用 USS_CTRL 指令

图中：

  1. EN： 使用 SM0.0 使能 USS_CTRL 指令
  2. RUN： 驱动装置的启动/停止控制
    = 0 停止
    1 运行
    此停车是按照驱动装置中设置的斜坡减速指电机停止
  3. OFF2： 停车信号 2。此信号为“1"时，驱动装置将封锁主回路输出，电机自由停车
  4. OFF3： 停车信号 3。此信号为”1"时，驱动装置将快速停车
  5. F_ACK： 故障确认。当驱动装置发生故障后，将通过状态字向 USS 主站报告；如果造成故障的原因排除，可以使用此输入端清除驱动装置的报警状态，即复位。注意这是针对驱动装置的操作。
  6. DIR： 电机运转方向控制。其“0/1”状态决定运行方向
  7. Drive： 驱动装置在 USS 网络上的站号。从站必须先在初始化时激活才能进行控制
  8. Type： 向 USS_CTRL 功能块指示驱动装置类型
    = 0 MM 3 系列，或更早的产品
    1

    MM 4 系列，SINAMICS G 110
  9. Speed_SP： 速度设定值。速度设定值必须是一个实数，给出的数值是变频器的频率范围百分比还是绝对的频率值取决于变频器中的参数设置（如 MM 440 的 P2009）
  10. Resp_R： 从站应答确认信号。主站从 USS 从站收到有效的数据后，此位将为“1"一个程序扫描周期，表明以下的所有数据都是最新的
  11. Error： 错误代码。0 = 无出错。其他错误代码请参考
  12. Status： 驱动装置的状态字。此状态字直接来自驱动装置的状态字，表示了当时的实际运行状态

    详细的状态字信息意义请参考相应的驱动装置手册。

  13. Speed： 驱动装置返回的实际运转速度值，实数。是否频率值跟随设定值的规格化设定
  14. Run_EN： 运行模式反馈，表示驱动装置是运行（为 1）还是停止（为 0）
  15. D_Dir： 指示驱动装置的运转方向，反馈信号
  16. Inhibit： 驱动装置禁止状态指示（0 - 未禁止，1 - 禁止状态）。禁止状态下驱动装置无法运行。要清除禁止状态，故障位必须复位，并且 RUN, OFF2 和 OFF3 都为 0
  17. Fault： 故障指示位（0 - 无故障，1 - 有故障）。表示驱动装置处于故障状态，驱动装置上会显示故障代码（如果有显示装置）。要复位故障报警状态，必须先消除引起故障的原因，然后用 F_ACK 或者驱动装置的端子、或操作面板复位故障状态。

此 USS_CTRL 功能块使用了 PZD 数据读写机制，传输速度比较快。但由于它还是串行通信，而且还可能有多个从站需要轮询，因此无法做到”实时“响应。要实现高要求的快速通信，应该使用 PROFIBUS-DP 等网络，同时更换主站为更高级的控制器。也由于同样的原因，USS_CTRL 输入的控制信号需要一个合理的作用时间，以等待指令执行完成，过快速的变化可能会导致没有响应。

USS_CTRL 已经能完成基本的驱动装置控制，如果需要有更多的参数控制选项，可以选用 USS 指令库中的参数读写指令实现。


USS - 参数读写指令

USS 指令库中共有 6 种参数读写功能块，分别用于读写驱动装置中不同规格的参数。

图 1. USS 参数读写指令

它们是：

USS_RPM_W | 读取无符号字参数 | U16 格式
USS_RPM_D | 读取无符号双字参数 | U32 格式
USS_RPM_R | 读取实数（浮点数）参数 | Float 格式
USS_WPM_W | 写入无符号字参数 | U16 格式
USS_WPM_D | 写入无符号双字参数 | U32 格式
USS_WPM_R | 写入实数（浮点数）参数 | Float 格式

USS 参数读写指令采用与 USS_CTRL 功能块不同的数据传输方式。由于许多驱动装置把参数读写指令用到的 PKW 数据处理作为后台任务，参数读写的速度要比控制功能块慢一些。因此使用这些指令时需要更多的等待时间，并且在编程时要考虑到，进行相应的处理。

读参数指令

以下的程序段读取实际的电动机电流值（参数 r0068）。由于此参数是一个实数，因此选用实型参数读功能块。

参数读写指令必须与参数的类型配合。

图 2. 调用 USS_RPM_R 指令读取 MM 440 的输出电流

图中：

  1. EN： 要使能读写指令此输入端必须为 1
  2. XMT_REQ： 发送请求。必须使用一个沿检测触点以触发读操作，它前面的触发条件必须与 EN 端输入一致
  3. Drive： 要读写参数的驱动装置在 USS 网络上的地址
  4. Param： 参数号（仅数字）。此处也可以是变量
  5. Index： 参数下标。有些参数由多个带下标的参数组成一个参数组，下标用来指出具体的某个参数。对于没有下标的参数，可设置为 0
  6. DB_Ptr： 读写指令需要一个 16 字节的数据缓冲区，用间接寻址形式给出一个起始地址。此数据缓冲区与“库存储区”不同，是每个指令（功能块）各自独立需要的。
    此数据缓冲区也不能与其他数据区重叠，各指令之间的数据缓冲区也不能冲突
  7. Done： 读写功能完成标志位，读写完成后置 1
  8. Error： 出错代码。0 = 无错误
  9. Value： 读出的数据值。要指定一个单独的数据存储单元

EN 和 XMT_REQ 的触发条件必须同时有效，EN 必须持续到读写功能完成（Done 为 1），否则会出错。

写参数指令

写参数指令的用法与读参数指令类似。与读参数指令的区别是参数是功能块的输入。

读写多个参数

在任一时刻 USS 主站内只能有一个参数读写功能块有效，否则会出错。因此如果需要读写 多个参数（来自一个或多个驱动装置），必须在编程时进行读写指令之间的轮替处理。

下面给出一个简单的例子，其中采取了一种轮替方法。方法不是唯一的。

USS 通信出错代码及常见原因
MM 440 参数设置

一个简单的例程，本地下载：

USS 控制及读参数测试例程

需要 STEP 7-Micro/WIN V4.0 SP4 以上版本打开。


USS - 出错代码

USS 错误代码及常问问题

表 1. USS 库指令错误代码
错误代码 | 错误描述
0 | 无错误
1 | 驱动装置无响应
2 | 来自驱动的响应中检测到校验和错误
3 | 来自驱动的响应中检测到奇偶校验错误
4 | 用户程序干扰引起错误
5 | 尝试执行非法命令
6 | 提供了无效的驱动装置地址
7 | 通信口未定义为 USS 协议
8 | 通信口忙于处理其他指令
9 | 驱动装置速度设定输入值超限
10 | 驱动装置返回的信息长度不正确
11 | 驱动装置返回报文的第一个字符不正确（不是 02 h）
12 | 驱动装置返回的长度信息不被 USS 指令支持
13 | 响应的驱动装置不正确
14 | 提供的 DB_Ptr 地址不正确
15 | 提供的参数号不正确
16 | 选择了错误的协议
17 | USS 已激活，不能改变
18 | 指定了非法的波特率
19 | 无通信活动：驱动装置未激活
20 | 驱动装置返回的参数值不正确或包括错误的代码
21 | 请求一个字长的数据时返回了一个双字数据
22 | 请求一个双字长的数据时返回了一个字数据

调试中的常见错误及原因

表 2. 常见错误
错误代码 | 可导致此错误的原因（未全列出）
1 | 通信线断线或者类似问题，驱动装置未供电
11 | 未正确接收到起始字符 02 h，硬件错误，RS 485 线对接反，或者通信口损坏
12 | 试图读取驱动装置中不存在的参数，或者参数类型不对
19 | 主站中的数据存储区重叠也能导致此错误

常问问题

看 USS 通信主站轮询的时间表，访问一个从站只需要几十毫秒，为何发出运行指令后感觉经过了数百毫秒电机才转动？这是否正常？

USS 通信控制是一种串行通信控制，通信轮询时间不能完全体现全系统中的时间延迟。

从用户发出运行控制信号，到电动机发生人眼可见的转动，中间经过了很多环节。控制信号进入 PLC 数字量输入端，经过主站中的程序运行，通信循环周期，以及从站中的程序处理，特别是驱动装置启动运行还需要很多准备环节，如电容预充电、建立磁场，建立转矩等。等到电机的转动可见，要经过一段时间。这是正常的现象。

采用高性能的控制器和网络系统（如 PROFIBUS-DP 等）可以大大减少串行通信的延时。

成熟的项目程序中包含 USS 通信库指令，为何修改后下载到新 CPU 中工作不正常？

在项目文件和编程软件的版本转换中可能会发生一些难以预见的问题。最简单的解决方法是升级到最新的 STEP 7-Micro/WIN 版本（以获得最新的 USS 指令库），在 Micro/WIN 中打开老项目重新调用 USS 指令，然后下载。

USS 编程，为何编译下载时通过，但 CPU 运行时会出错， PLC 菜单中的“信息”显示数据类型错误？

可能是速度设定值等数据类型不合规格。检查相关参数的类型和格式，必要时可把变量更换为立即数测试，这样容易看出问题。

为何运行一段时间 USS 通信会中断，或者表现为“死机”？

需要检查软件和硬件。正确的硬件连接可以参考 USS 通信接线。


USS - MM 440 参数设置

MM 440 的参数设置

参数集是对驱动装置进行调试和控制的基础，几乎所有的功能都需要对驱动装置的内部参数进行访问、设定和修改。西门子驱动装置的参数功能更为突出，庞大繁多的参数选项，保证了西门子产品的高性能应用和极高的定制能力。

驱动装置的调试和控制都依赖于对参数的设置，与 S7-200 配合使用时也不例外。一个实际的项目，往往把驱动装置和自动控制器（PLC）分为两个相对独立、又有联系的子系统，它们的调试也一般也可以分开进行。这样做不但可以提高效率，而且能够保证控制关系清晰明了。

对于 S7-200 与西门子驱动装置配合的项目，我们建议分为三个阶段调试：

  1. 驱动装置和 PLC 相对独立，调试各自的基本功能；
  2. 调试出驱动装置和 PLC 之间相互控制、反馈功能；
  3. 进行整个系统的综合调试，达成一个完整的控制任务。
驱动装置的基本调试相对比较独立，最好能够在尝试与控制器连接之前完成。

具体驱动装置的调试请参考相关产品的操作手册等资料。

我们假定已经完成了驱动装置的基本参数设置和调试（如电机参数辨识等等），以下只涉及与 S7-200 控制器连接相关的参数。

MM 440 的参数分为几个访问级别，以便于过滤不需要查看的部分。 与 S7-200 连接时，需要设置的主要有“控制源”和“设定源”两组参数。要设置此类参数，需要“专家”参数访问级别，即首先需要把 P0003 参数设置为 3。

控制源参数设置

控制命令控制驱动装置的启动、停止、正/反转等功能。控制源参数设置决定了驱动装置从何种途径接受控制信号。

控制源由参数 P0700 设置：

表 1. 控制源参数
取值 | 功能说明
0 | 工厂缺省设置
1 | BOP（操作键盘）控制
2 | 由端子排输入控制信号
4 | BOP Link 上的 USS 控制
5 | COM Link （端子 USS 接口）上的 USS 控制
6 | COM Link 上的 CB（通信接口板）控制

此参数有分组，在此仅设第一组，即 P0700[0]。

设定源控制参数

设定值控制驱动装置的转速/频率等功能。设定源参数决定了驱动装置从哪里接受设定值（即给定）。

设定源由参数 P1000 设置：

表 2. 设定源参数（部分）
取值 | 功能说明
0 | 无主设定
1 | MOP 设定值
2 | 模拟量输入设定值
3 | 固定频率
4 | BOP Link 上的 USS 设定
5 | COM Link 上的 USS 设定
6 | COM Link 上的 CB 设定
7 | 模拟量输入 2 设定值

此参数有分组，在此仅设第一组，即 P1000[0]。

USS 通信控制的参数设置

控制源和设定源之间可以自由组合，根据工艺要求可以灵活选用。我们以控制源和设定源都来自 COM Link 上的 USS 通信为例，简介 USS 通信的参数设置。

主要参数有：

  1. P0700： 设置 P0700[0] = 5，即控制源来自 COM Link 上的 USS 通信
  2. P1000： 设置 P1000[0] = 5，即设定源来自 COM Link 上的 USS 通信
  3. P2009： 决定是否对 COM Link 上的 USS 通信设定值规格化，即设定值将是运转频率的百分比形式，还是绝对频率值

    = 0
    不规格化 USS 通信设定值，即设定为变频器中的频率设定范围的百分比形式。
    1
    对 USS 通信设定值进行规格化，即设定值为绝对的频率数值。

  4. P2010： 设置 COM Link 上的 USS 通信速率。根据 S7-200 通信口的限制，支持的通信波特率有：

    = 4 2400 bit/s
    5 | 4800 bit/s
    6 | 9600 bit/s
    7 | 19200 bit/s
    8 | 38400 bit/s
    9 | 57600 bit/s
    12 | 115200 bit/s

  5. P2011： 设置 P2011[0] = 0 至 31，即驱动装置 COM Link 上的 USS 通信口在网络上的从站地址。

    USS 网络上不能有任何两个从站的地址相同。

  6. P2012： 设置 P2012[0] = 2，即 USS PZD 区长度为 2 个字长。
  7. P2013： 设置 P2013[0] = 127，即 USS PKW 区的长度可变。
  8. P2014： 设置 P2014[0] = 0 至 65535，即 COM Link 上的 USS 通信控制信号中断超时时间，单位为 ms。如设置为 0，则不进行此端口上的超时检查。
    此通信控制信号中断，指的是接收到的对本装置有效通信报文之间的最大间隔。如果设定了超时时间，报文间隔超过此设定时间还没有接收到下一条信息，则会导致 F0072 错误，变频器将会停止运行。通信恢复后此故障才能被复位。
    根据 USS 网络通信速率和站数的不同，此超时值会不同。如果要设定超时值，请参考相关表格，并选取一个适当的数值。
  9. P0971： 设置 P0971 = 1，上述参数将保存入MM 440 的 EEPROM 中。

USS 通信是由 S7-200 和驱动装置配合，因此相关参数一定要配合设置。如通信速率设置不一样，当然无法通信。

附：USS 通信轮询时间

表 3. USS 主站轮询时间
波特率 | 主站轮询从站的时间间隔 （无参数访问指令）
2400 | 130 ms x 从站数
4800 | 75 ms x 从站数
9600 | 50 ms x 从站数
19200 | 35 ms x 从站数
38400 | 30 ms x 从站数
57600 | 25 ms x 从站数
115200 | 25 ms x 从站数


资料手册下载

资料手册在线下载

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。

LOGO! 控制器 手册

1. 西门子全新一代LOGO！8 产品样本 （2015 年 05 月)

http://www.ad.siemens.com.cn/download/docMessage.aspx?ID=8051&loginID=&srno=&sendtime=

2.《LOGO! 设备手册》 0BA8(FS4) 中文版（2017 年 05 月）

https://support.industry.siemens.com/cs/document/109741041/logo!?dti=0&lc=zh-CN

3.《LOGO! 设备手册》 0BA8(FS4) 英文版（2017 年 05 月）

https://support.industry.siemens.com/cs/document/109741041/logo!?dti=0&lc=en-CN

4.LOGO! 0BA6产品样本（2013 年 03 月）

https://support.industry.siemens.com/cs/document/45164910/logo!?dti=0&lc=zh-CN

5.《LOGO! 设备手册》 0BA6中文版（2009 年 11 月）

https://support.industry.siemens.com/cs/document/45164910/logo!?dti=0&lc=zh-CN

6.《LOGO! 设备手册》 0BA6英文版（2009 年 11 月）

https://support.industry.siemens.com/cs/document/45164910/logo!?dti=0&lc=en-CN

LOGO!Soft Comfort 软件 帮助文档

1.LOGO!Soft Comfort V8.1 在线帮助 中文版

https://support.industry.siemens.com/cs/document/100782807/logo!soft-comfort-%E5%9C%A8%E7%BA%BF%E5%B8%AE%E5%8A%A9?dti=0&pnid=13616&lc=zh-WW

2.LOGO!Soft Comfort V8.1 在线帮助 英文版

https://support.industry.siemens.com/cs/document/100782807/logo!soft-comfort-online-help?dti=0&pnid=13616&lc=en-CN

3.LOGO!Soft Comfort V6.0 在线帮助" 中文版

http://support.automation.siemens.com/WW/view/en/30104177/0/zh

4.LOGO!Soft Comfort V6.0 在线帮助" 英文版

http://support.automation.siemens.com/WW/view/en/30104177

5.LOGO!Soft Comfort V5.0 使用手册" 英文版

http://support.automation.siemens.com/WW/view/en/24891816

LOGO! 网站 常用链接

1.LOGO! 中文主页（内含软件下载，样本，认证等）

http://www.industry.siemens.com.cn/automation/cn/zh/automation-systems/industrial-automation/simatic-controller/logic-module-logo/Pages/logo.aspx

2.中文产品主页入口

http://www.industry.siemens.com.cn/automation/cn/zh/automation-systems/industrial-automation/simatic-controller/Pages/Default.aspx

3.下载中心首页：中、英文资料、软件本地下载

http://www.ad.siemens.com.cn/download

4.Industry Mall -- 西门子自动化与驱动技术产品目录和订购系统

https://mall.industry.siemens.com/goos/WelcomePage.aspx?regionUrl=/CN&language=zh

LOGO!Soft Comfort 软件下载链接

1.LOGO!Soft Comfort V8.0完整版以及8.1升级包下载链接（网页右侧-软件下载）：

http://www.industry.siemens.com.cn/automation/cn/zh/automation-systems/industrial-automation/simatic-controller/logic-module-logo/Pages/logo.aspx

点开以上网站链接后，在网页右侧找到"软件下载"，自行下载即可：

图1 软件下载

2.LOGO!USB电缆驱动下载链接：

http://w3.siemens.com/mcms/programmable-logic-controller/en/logic-module-logo/demo-software/pages/default.aspx#Updates

点开以上网站链接后，在网页内找到下图所示的下载链接，点击即可：

图2 USB驱动下载

LOGO! 宽温产品

1.宽温产品链接(具体查找步骤，请参考：)

https://w3.siemens.com/mcms/siplus/en/siplus-extreme/Pages/Default.aspx

CAX、ePLAN等产品图片下载

1.用户可从SIMATIC产品数据库下载：

http://www.automation.siemens.com/bilddb/index.aspx?lang=en

步骤一：点击以上链接

步骤二：点击页面内的EPLAN图标，见下图

图3 CAx Data

步骤三：如下图所示 ，查找需要的产品的图片即可 。

图4 查找图片

2.如果用户有使用上面网站的问题，请参考FAQ《从哪里获得SIMATIC 产品的图像数据》

http://www.ad.siemens.com.cn/download/searchResult.aspx?searchText=F0507

LOGO!产品维修信息

LOGO!产品只有保内更换业务，没有维修服务。用户可以直接联系西门子的经销商。

产品维修服务热线

电话： ＋86 10 64719990 / 400 810 4288
传真： ＋86 10 64719991
电邮： support.china.automation@siemens.com / 4008104288.cn@siemens.com

热线工作时间：

周一至周五 8:30 - 17:15；按国家规定休假。


产品认证下载

产品认证书在线下载

按住 Shift 键时用鼠标点击下列链接，打开新浏览器窗口。

https://support.industry.siemens.com/cs/cn/en/ps/13617/cert

具体查找步骤：点击该链接可以打开西门子全球技术资源库关于LOGO!产品的所有证书信息，如下图所示。在证书分类搜索里可以按照证书类型、证书名称、审批单位或国家进行进一步筛选。

图1 查找证书


学习视频

系列视频:LOGO!在线学习

系列视频：LOGO!在线学习 | http://www.ad.siemens.com.cn/Service/elearning/cn/SerialVideo.aspx?vsid=130
什么是LOGO!？ - LOGO在线学习1/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=718
LOGO! 产品系列概述 - LOGO在线学习2/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=719
LOGO! 产品的安装和接线 - LOGO在线学习3/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=720
LOGO! 软件安装，升级和特点 - LOGO在线学习4/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=721
LOGO! 存储卡和电池卡介绍 - LOGO在线学习5/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=722
LOGO! 编程指令之常量 - LOGO在线学习6/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=723
LOGO! 编程指令之基本函数 - LOGO在线学习7/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=724
LOGO! 编程指令之定时器函数（1） - LOGO在线学习8/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=725
LOGO! 编程指令之定时器函数（2） - LOGO在线学习9/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=726
LOGO! 编程指令之定时器函数（3） - LOGO在线学习10/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=727
LOGO! 编程指令之定时器函数（4） - LOGO在线学习11/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=728
LOGO! 编程指令之计数器函数 - LOGO在线学习12/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=729
LOGO! 编程指令之模拟量函数（1） - LOGO在线学习13/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=730
LOGO! 编程指令之模拟量函数（2 - LOGO在线学习14/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=731
LOGO! 编程指令之模拟量函数（3） - LOGO在线学习15/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=732
LOGO! 编程指令之其他函数 - LOGO在线学习16/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=733
LOGO! TD & 信息文本函数 - LOGO在线学习17/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=734
LOGO! 面板菜单和功能介绍 - LOGO在线学习18/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=735
LOGO! 0BA7 模块介绍 - LOGO在线学习19/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=736
V7.0 软件新功能介绍- 用户自定义函数 - LOGO在线学习20/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=737
V7.0 软件新功能介绍-数据归档 - LOGO在线学习21/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=738
V7.0 软件新功能介绍-新功能块 - LOGO在线学习22/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=739
V7.0 软件新增特色功能 - LOGO在线学习23/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=740
以太网通讯- LOGO! 之间主主通讯 - LOGO在线学习24/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=741
以太网通讯- LOGO! 之间主从通讯 - LOGO在线学习25/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=742
以太网通讯- LOGO! 与S7-200 - LOGO在线学习26/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=743
以太网通讯- LOGO! 与S7-1200 - LOGO在线学习27/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=744
以太网通讯- LOGO! 与S7-300 - LOGO在线学习28/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=745
以太网通讯- LOGO! 与触摸屏 - LOGO在线学习29/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=746
以太网通讯- LOGO! 与 WinCC - LOGO在线学习30/30 | http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=747
LOGO!8新功能学习教程 – 硬件部分 | http://www.ad.siemens.com.cn/service/elearning/Course/1539.html
LOGO!8新功能学习教程 – 软件部分 | http://www.ad.siemens.com.cn/service/elearning/Course/1540.html
LOGO!8新功能学习教程 – 通讯部分 | http://www.ad.siemens.com.cn/service/elearning/Course/1541.html


MLFB - LOGO! 0BA8

LOGO! 0BA8 版产品订货号

表1. LOGO! 0BA8版产品订货号

类别 | 型号 | 订货号
LOGO! 基本型 | LOGO! 12/24 RC* | 6ED1052-1MD00-0BA8
 | LOGO! 24 CE * | 6ED1052-1CC01-0BA8
 | LOGO! 24RCE（AC/DC） | 6ED1052-1HB00-0BA8
 | LOGO! 230RCE (AC/DC) | 6ED1052-1FB00-0BA8
LOGO! 基本型 （无显示） | LOGO! 12/24RCEo * | 6ED1052-2MD00-0BA8
 | LOGO! 24CEo * | 6ED1052-2CC01-0BA8
 | LOGO! 24RCEo（AC/DC） | 6ED1052-2HB00-0BA8
 | LOGO! 230RCEo（AC/DC） | 6ED1052-2FB00-0BA8
数字量模块 | LOGO! DM 8 12/24R | 6ED1055-1MB00-0BA2
 | LOGO! DM 8 24 | 6ED1055-1CB00-0BA2
 | LOGO! DM 8 24R | 6ED1055-1HB00-0BA2
 | LOGO! DM 8 230R | 6ED1055-1FB00-0BA2
 | LOGO! DM 16 24 | 6ED1055-1CB10-0BA2
 | LOGO! DM 16 24R | 6ED1055-1NB10-0BA2
 | LOGO! DM 16 230R | 6ED1055-1FB10-0BA2
模拟量模块 | LOGO! AM 2 | 6ED1055-1MA00-0BA2
 | LOGO! AM2 RTD | 6ED1055-1MD00-0BA2
 | LOGO! AM 2 AQ | 6ED1055-1MM00-0BA2
文本显示器模块 | LOGO! TDE | 6ED1055-4MH00-0BA1
以太网开关模块 | LOGO! CSM12/24 | 6GK7177-1MA10-0AA0
 | LOGO! CSM230 | 6GK7177-1FA10-0AA0
电源模块 | LOGO!Power 12V/1.9A | 6EP1321-1SH02
 | LOGO!Power 12V/4.5A | 6EP1322-1SH02
 | LOGO!Power 24V/1.3A | 6EP1331-1SH02
 | LOGO!Power 24V/2.5A | 6EP1332-1SH42
 | LOGO!Power 24V/4A | 6EP1332-1SH51
 | LOGO!Power 5V/3A | 6EP1311-1SH02
 | LOGO!Power 5V/6.3A | 6EP1311-1SH12
 | LOGO!Power 15V/1.9A | 6EP1351-1SH02
 | LOGO!Power 15V/4A | 6EP1352-1SH02
开关模块 | LOGO!Contact 24 V | 6ED1057-4CA00-0AA0
 | LOGO!Contact 230 V | 6ED1057-4EA00-0AA0

*：带有简易模拟量输入（电压 0 - 10V）


MLFB - LOGO! 0BA7

LOGO! 0BA7 版产品订货号

表1. LOGO! 0BA7 版产品订货号

类别 | 型号 | 订货号
LOGO! 基本型 | LOGO! 12/24 RC* | 6ED1052-1MD00-0BA6
 | LOGO! 12/24 RCE * | 6ED1052-1MD00-0BA7
 | LOGO! 24 * | 6ED1052-1CC00-0BA6
 | LOGO! 24C * | 6ED1052-1CC01-0BA6
 | LOGO! 24RC (AC/DC) | 6ED1052-1HB00-0BA6
 | LOGO! 230RC (AC/DC) | 6ED1052-1FB00-0BA6
 | LOGO! 230RCE (AC/DC) | 6ED1052-1FB00-0BA7
LOGO! 基本型 （无显示） | LOGO! 12/24RCo * | 6ED1052-2MD00-0BA6
 | LOGO! 24o * | 6ED1052-2CC00-0BA6
 | LOGO! 24Co * | 6ED1052-2CC01-0BA6
 | LOGO! 24RCo (AC/DC) | 6ED1052-2HB00-0BA6
 | LOGO! 230RCo (AC/DC) | 6ED1052-2FB00-0BA6
数字量模块 | LOGO! DM 8 12/24R | 6ED1055-1MB00-0BA1
 | LOGO! DM 8 24 | 6ED1055-1CB00-0BA0
 | LOGO! DM 8 24R | 6ED1055-1HB00-0BA0
 | LOGO! DM 8 230R | 6ED1055-1FB00-0BA1
 | LOGO! DM 16 24 | 6ED1055-1CB10-0BA0
 | LOGO! DM 16 24R | 6ED1055-1NB10-0BA0
 | LOGO! DM 16 230R | 6ED1055-1FB10-0BA0
模拟量模块 | LOGO! AM 2 | 6ED1055-1MA00-0BA0
 | LOGO! AM 2 PT100 | 6ED1055-1MD00-0BA0
 | LOGO! AM2 RTD | 6ED1055-1MD00-0BA1
 | LOGO! AM 2 AQ | 6ED1055-1MM00-0BA1
通信模块 | CM EIB/KNX | 6BK1700-0BA00-0AA1
 | CM AS-i 接口模块 | 3RK1400-0CE10-0AA2
文本显示器模块 | LOGO! TD | 6ED1055-4MH00-0BA0
存储卡 | LOGO! 存储卡 | 6ED1056-1DA00-0BA0
 | SIMATIC 存储卡（2M） | 6ES7954-8LB00-0AA0
 | SIMATIC 存储卡（24M） | 6ES7954-8LF00-0AA0
电池卡 | LOGO! 电池卡 | 6ED1 056-6XA00-0BA0
存储器电池卡 | LOGO! 存储器电池卡 | 6ED1 056-7DA00-0BA0
其它 | PC 电缆 | 6ED1057-1AA00-0BA0
 | USB PC 电缆 | 6ED1057-1AA01-0BA0
 | 调制解调器电缆 | 6ED1057-1CA00-0BA0
电源模块 | LOGO!Power 12V/1.9A | 6EP1321-1SH02
 | LOGO!Power 12V/4.5A | 6EP1322-1SH02
 | LOGO!Power 24V/1.3A | 6EP1331-1SH02
 | LOGO!Power 24V/2.5A | 6EP1332-1SH42
 | LOGO!Power 24V/4A | 6EP1332-1SH51
 | LOGO!Power 5V/3A | 6EP1311-1SH02
 | LOGO!Power 5V/6.3A | 6EP1311-1SH12
 | LOGO!Power 15V/1.9A | 6EP1351-1SH02
 | LOGO!Power 15V/4A | 6EP1352-1SH02
开关模块 | LOGO!Contact 24 V | 6ED1057-4CA00-0AA0
 | LOGO!Contact 230 V | 6ED1057-4EA00-0AA0

*：带有简易模拟量输入（电压 0 - 10V）


MLFB - LOGO! 0BA6

LOGO! 0BA6 版产品订货号

表1. LOGO! 0BA6 版产品订货号

类别 | 型号 | 订货号 | 备注
LOGO! 基本型 | LOGO! 12/24 RC* | 6ED1052-1MD00-0BA6 | *
 | LOGO! 24* | 6ED1052-1CC00-0BA6 | *
 | LOGO! 24 RC(AC) | 6ED1052-1HB00-0BA6 |
 | LOGO! 230 RC | 6ED1052-1FB00-0BA6 |
LOGO! 基本型 （无显示） | LOGO! 12/24 RCo* | 6ED1052-2MD00-0BA6 | *
 | LOGO! 24o* | 6ED1052-2CC00-0BA6 | *
 | LOGO! 24 RCo(AC) | 6ED1052-2HB00-0BA6 |
 | LOGO! 230 RCo | 6ED1052-2FB00-0BA6 |
数字量模块 | LOGO! DM 8 12/24R | 6ED1055-1MB00-0BA1 |
 | LOGO! DM 8 24 | 6ED1055-1CB00-0BA0 |
 | LOGO! DM 8 24R | 6ED1055-1HB00-0BA0 |
 | LOGO! DM 8 230R | 6ED1055-1FB00-0BA1 |
 | LOGO! DM 16 24 | 6ED1055-1CB10-0BA0 |
 | LOGO! DM 16 24R | 6ED1055-1NB10-0BA0 |
 | LOGO! DM 16 230R | 6ED1055-1FB10-0BA0 |
模拟量模块 | LOGO! AM 2 | 6ED1055-1MA00-0BA0 |
 | LOGO! AM 2 PT100 | 6ED1055-1MD00-0BA0 |
 | LOGO! AM 2 AQ | 6ED1055-1MM00-0BA1 |
通信模块 | CM EIB/KNX | 6BK1700-0BA00-0AA1 |
 | CM AS-i 接口模块 | 3RK1400-1DQ00-0AA3 |
文本显示器模块 | LOGO! TD | 6ED1055-4MH00-0BA0 |
存储卡 | LOGO! 存储卡 | 6ED1056-1DA00-0BA0 |
电池卡 | LOGO! 电池卡 | 6ED1 056-6XA00-0BA0 |
存储器电池卡 | LOGO! 存储器电池卡 | 6ED1 056-7DA00-0BA0 |
其它 | RS232 PC 电缆 | 6ED1057-1AA00-0BA0 |
 | USB PC 电缆 | 6ED1057-1AA01-0BA0 |
 | 调制解调器电缆 | 6ED1057-1CA00-0BA0 |
开关模块 （接触器） | LOGO!Contact 24 V | 6ED1057-4CA00-0AA0 |
 | LOGO!Contact 230 V | 6ED1057-4EA00-0AA0 |

*：带有简易模拟量输入（电压 0 - 10V）


MLFB - LOGO! 0BA5

LOGO! 0BA5 版产品订货号

表1. LOGO! 0BA5 版产品订货号

类别 | 型号 | 订货号 | 备注
LOGO! 基本型 | LOGO! 12/24 RC* | 6ED1052-1MD00-0BA5 | *
 | LOGO! 24* | 6ED1052-1CC00-0BA5 | *
 | LOGO! 24 RC(AC) | 6ED1052-1HB00-0BA5 |
 | LOGO! 230 RC | 6ED1052-1FB00-0BA5 |
LOGO! 基本型 （无显示） | LOGO! 12/24 RCo* | 6ED1052-2MD00-0BA5 | *
 | LOGO! 24o* | 6ED1052-2CC00-0BA5 | *
 | LOGO! 24 RCo(AC) | 6ED1052-2HB00-0BA5 |
 | LOGO! 230 RCo | 6ED1052-2FB00-0BA5 |
数字量模块 | LOGO! DM 8 12/24R | 6ED1055-1MB00-0BA1 |
 | LOGO! DM 8 24 | 6ED1055-1CB00-0BA0 |
 | LOGO! DM 8 24R | 6ED1055-1HB00-0BA0 |
 | LOGO! DM 8 230R | 6ED1055-1FB00-0BA1 |
 | LOGO! DM 16 24 | 6ED1055-1CB10-0BA0 |
 | LOGO! DM 16 24R | 6ED1055-1NB10-0BA0 |
 | LOGO! DM 16 230R | 6ED1055-1FB10-0BA0 |
模拟量模块 | LOGO! AM 2 | 6ED1055-1MA00-0BA0 |
 | LOGO! AM 2 PT100 | 6ED1055-1MD00-0BA0 |
 | LOGO! AM 2 AQ | 6ED1055-1MM00-0BA0 |
通信模块 | CM EIB/KNX | 6BK1700-0BA00-0AA1 |
 | CM AS-i 接口模块 | 3RK1400-0CE10-0AA2 |

*：带有简易模拟量输入（电压 0 - 10V）

表 2. LOGO! 产品订货号

类别 | 型号 | 订货号 | 备注
存储卡 | LOGO! Card | 6ED1056-5CA00-0BA0 |
开关模块 （接触器） | LOGO!Contact 24 V | 6ED1057-4CA00-0AA0 |
 | LOGO!Contact 230 V | 6ED1057-4EA00-0AA0 |
电源模块 | LOGO!Power 12V/1.9A | 6EP1321-1SH02 |
 | LOGO!Power 12V/4.5A | 6EP1322-1SH02 |
 | LOGO!Power 24V/1.3A | 6EP1331-1SH02 |
 | LOGO!Power 24V/2.5A | 6EP1332-1SH42 |
 | LOGO!Power 24V/4A | 6EP1332-1SH51 |
 | LOGO!Power 5V/3A | 6EP1311-1SH02 |
 | LOGO!Power 5V/6.3A | 6EP1311-1SH12 |
 | LOGO!Power 15V/1.9A | 6EP1351-1SH02 |
 | LOGO!Power 15V/4A | 6EP1352-1SH02 |
编程软件 | LOGO! Soft Comfort V5.0 完全版 | 6ED1 058-0BA01-0YA0 |
 | LOGO! Soft Comfort 升级版 | 6ED1 058-0CA01-0YE0 |
其他 | LOGO! PC Cable （编程电缆） | 6ED1057-1AA00-0BA0 |


MLFB - LOGO! 0BA4

LOGO! 0BA4 版产品订货号

表1. LOGO! 产品订货号

产品说明 | MLFB（订货号） | 列表价 （欧元） | 备注
LOGO! 12/24 RC | 6ED1052-1MD00-0BA4 | 112 |
LOGO! 24 | 6ED1052-1CC00-0BA4 | 99 |
LOGO! 24 RC(AC/DC) | 6ED1052-1HB00-0BA4 | 112 |
LOGO! 230 RC | 6ED1052-1FB00-0BA4 | 115 |
LOGO! 12/24 RCo | 6ED1052-2MD00-0BA4 | 89 |
LOGO! 24o | 6ED1052-2CC00-0BA4 | 85 |
LOGO! 24 RCo(AC/DC) | 6ED1052-2HB00-0BA4 | 89 |
LOGO! 230 RCo | 6ED1052-2FB00-0BA4 | 91 |
LOGO! DM 8 12/24R | 6ED1055-1MB00-0BA1 | 51 |
LOGO! DM 8 24 | 6ED1055-1CB00-0BA0 | 47 |
LOGO! DM 8 24R | 6ED1055-1HB00-0BA0 | 51 |
LOGO! DM 8 230R | 6ED1055-1FB00-0BA1 | 51 |
LOGO! DM16 24 | 6ED1055-1CB10-0BA0 |  |
LOGO! DM16 24R | 6ED1055-1NB10-0BA0 |  |
LOGO! DM16 230R | 6ED1055-1FB10-0BA0 |  |
LOGO! AM 2 | 6ED1055-1MA00-0BA0 | 74 |
LOGO! AM 2 PT100 | 6ED1055-1MD00-0BA0 | 89 |
LOGO! AS-I | 3RK1400-0CE10-0AA2 | 70.5 |
LOGO! KNX (Instabus EIB) | 6BK1700-0BA00-0AA0 | 149 |
LOGO! Soft Comfort V4.0 | 6ED1058-0BA00-0YA0 | 49 |
LOGO! Soft Comfort V4.0 Upgrade | 6ED1058-0CA00-0YE0 | 19 |
LOGO! 存储卡 | 6ED1056-5CA00-0BA0 | 18 |
LOGO! Contact 24V | 6ED1057-4CA00-0AA0 | 17 |
LOGO! Contact 230V | 6ED1057-4EA00-0AA0 | 14 |
LOGO! PC Cable（编程电缆） | 6ED1057-1AA00-0BA0 | 75 |

表2. LOGO! 电源模块（部分，详情请看SITOP电源订货号）

产品说明 | MLFB（订货号） | 列表价 （欧元） | 备注
LOGO!Power 12V/1.9A | 6EP1321-1SH02 | 72 |
LOGO!Power 12V/4.5A | 6EP1322-1SH02 | 97 |
LOGO!Power 24V/1.3A | 6EP1331-1SH02 | 51 |
LOGO!Power 24V/2.5A | 6EP1332-1SH42 | 77 |
LOGO!Power 24 V | 6EP1 332-1SH51 |  |


LOGO! 0BA5

西门子于 2005 年推出 LOGO! 0BA5 系列产品。

LOGO! 0BA5 系列产品主要有如下改进：

  • 新推出 LOGO! AM2 AQ 模拟量输出模块
  • LOGO! 基本型模块（包括无显示型）增加了三个功能块：

    • PI 控制器
    • 斜坡函数发生器
    • 模拟量多路复用器

  • 可以更改显示屏幕对比度
  • 可以显示模拟量输入和输出的实际值
  • 设置运行模式下的起始显示屏幕
  • 配合 0BA5 版的编程软件 LOGO!Soft Comfort V5.0

LOGO! AM2 AQ 模拟量输出模块

AM2 AQ 是西门子公司于 2005 年 3 月推出的一款 2 路模拟量输出模块。 订货号： 6ED1 055-1MM00-0BA0

  • 2 路模拟量输出 0 – 10V 电压（对应内部数值 0 - 1000）
  • 分辨率：10 bit
  • 模拟量输出精度：±2.5 %
  • 24V DC 电源供电
  • 占 2 个安装槽位，尺寸同 LOGO! DM8

更改显示屏对比度

在 LOGO! 主菜单中选择“Set...”（或 Setup） > “Contrast”，即可用“左”、“右”箭头更改显示屏对比度：

图 1. 改变显示屏对比度

显示模拟量信号实际值

在运行状态下按左、右箭头键显示信号实际状态。可能需要按 ESC 键切换到相应的变量显示模式。

图 2. 显示模拟量值

设置起始显示屏幕

在主菜单中进入“Setup...”（或 Set） > “StartScreen”，用上、下键在显示“时钟”和“数字量输入”之间切换。此起始画面为进入运行状态时的缺省显示画面。

图 3. 设置起始画面


0BA4兼容性

LOGO!新产品（0BA4）与老产品的兼容性

LOGO!的最新版本0BA4与以前的版本相比有了很大的改进：

  • 内存容量增加到130个功能块
  • 几乎每个功能块都经过了优化
  • 新增加了4种功能块
  • 指令执行时间减少到原来的约1/10
  • 液晶显示屏增加了背光，文本显示功能可以直接修改变量

通过与LOGO!Soft Comfort V4.0配合，可以实现FBD（功能块图）和LAD（梯形图）编程，并且除了已有的离线模拟运行功能外，还可以进行在线调试。

兼容性常问问题

新的0BA4模块是否能够和老的扩展模块一起使用？

可以。

如何把老版本LOGO!的程序转移到0BA4模块中运行？

0BA4向下兼容以前版本的程序。转移程序的唯一方法是使用编程软件LOGO!Soft Comfort V4.0，通过编程电缆把老版本LOGO!的程序读取到计算机上，然后变更编程软件中的设备型号，再联机下载到新LOGO!中。

老版本LOGO!的程序存储卡（黄卡和红卡）是否可以与0BA4系列的存储卡（棕色卡）通用？

新、旧版本的存储卡完全不能兼容。棕卡可以按照需求，设置为黄卡（程序拷贝或保存）或者红卡（程序保护）的功能。

0BA4版本的LOGO!是否还有旧版本的“资源”限制？
0BA4的LOGO!版本的“资源”限制比旧版本大为宽松，一个程序只是不能占用超出以下任一个资源范围：

字节 | 功能块 | 可保持的存储器
2000 | 130 | 60

旧版本的资源限制较多，因此造成功能块总数目的限制还未达到，但已无法输入某种功能块（如定时器）的情况。

老版本（0BA2及以前）的LOGO!如何进入编程状态？

老版本的LOGO!（0BA2及以前版本）进入编程状态的方法与新LOGO!（0BA3以后）不同。

新版本只要按“ESC”按钮。老版本需要同时按“向左箭头”、“向右箭头”和“OK”键。


timer

LOGO !0BA8系列产品硬件替代

LOGO! TDE 模块只能配合 0BA8 设备系列使用。LOGO! TDE 完全兼容 LOGO! 0BA8。但不适用于之前的0BA7, 0BA6产品。不能互相替换。

LOGO 0BA8存储卡为微型SD卡不能通用于以前的版本

LOGO 0BA8主机和扩展模块不能兼容之前的0BA7 0BA6版本，也就是说如果0BA6 或0BA7的模块想单独更换CPU或扩展模块，必须整套全部替换0BA8。

LOGO 0BA6与 LOGO 0BA7系列扩展模块可以通用

0BA6，0BA7 ,0BA8的比较信息查看下面(表格1)

表格1

LOGO 0BA6 , 0BA7, 0BA8系列后续替代产品查看下(表.2)。

表.2

LOGO !旧版程序升级

对于之前旧版本0BA6 或0BA7编写的程序升级，在LOGO comfort V8.1内可以直接打开之前版本程序，更改硬件类型，编译后重新下载，

具体步骤如下：

1.双击击软件左下角，（图1）

图1

2.打开LOGO设置，将硬件类型修改为LOGO!8 FS4后点击确定（图2）

图.2

重新编译程序，无错后即可下载程序；（图.3）

图.3

查看输出信息窗口（图4）如有错误，可根据实际的提示信息处理错误。

图.4

如何查看当前设备的硬件类型

工具-传输-显示固件版本(图.5)

图.5

需要连接LOGO CPU后，之后则显示出当前固件版本。(图.6)

图.6


安装尺寸

LOGO!安装尺寸

LOGO!的详细安装尺寸见《LOGO!手册》。

LOGO!符合DIN43880安装标准。LOGO!既可以安装在标准的35mm DIN导轨上，也可以安装在板面上。

  • LOGO!基本型、DM16模块的宽度为72mm，相当于4个单元
  • 其他LOGO!扩展模块的宽度为36mm，相当于2个单元


宽温产品

LOGO!的工作温度

LOGO!的工作环境要求为：

  • 0°C－55°C，水平安装
  • 0°C－55°C，垂直安装
  • 相对湿度：10%－95%，无结露

LOGO! TDE 的工作环境要求为：

  • 0°C－55°C，水平安装
  • 0°C－55°C，垂直安装
  • 相对湿度：10%－95%，无结露

LOGO!的保护等级

LOGO! 主机模块、扩展模块以及 LOGO! TDE（不包括 TDE 前面板）的保护等级均为 IP20。

LOGO! TDE 前面板的保护等级为 IP65 。

宽温型LOGO!（SIPLUS LOGO!）

西门子还提供LOGO!的宽温度范围产品（SIPLUS LOGO!）：

  • 最宽工作温度范围（具体范围以网站数据为准）：-40°C－+70°C
  • 相对湿度：55°C时98%，70°C时45%
  • 其他参数与普通LOGO!产品相同

    • 具体查找步骤如下：

    1.点击SIPLUS产品主页 ：https://w3.siemens.com/mcms/siplus/en/siplus-extreme/Pages/Default.aspx

    2.进入网页后找到Controllers点击more information，如下图：

    图1 选择控制器

    3.选择网页内的LOGO!Logic module：

    图2 选择LOGO!Logic module

  • a.选择网页内的LOGO!Logic module
  • b.可以查看具体的宽温型模块的订货号，以及参数
  • c.进入LOGO!页面，查看LOGO!信息

    • 4.点击上图b.后，可以自行设置条件搜索需要的产品：

    图3 查看宽温产品

    上图中搜索到的产品点击产品订货号前面的+号，可以查看具体的参数信息

    图4 查看宽温产品参数

    LOGO!的宽温型产品，每种都有其单独的订货号，可到SIPLUS产品主页查询。如果没有找到，则说明目前没有对应的SIPLUS产品。

    国内没有现货，如需要请和当地西门子办事处或经销商联系。


实时时钟

设置实时时钟

设置实时时钟的方法两种：通过硬件面板设置或者通过软件设置，下面具体介绍设置步骤

一、通过硬件面板设置有两种方法（以LOGO!8 FS04版本硬件为例）

操作方法一：参数模式下设置时间和日期

1、按 ESC 进入参数模式

图1.进入参数模式

2、LOGO!面板上按“向上"或者"向下"的按钮，将光标移动到"①"然后按下OK键；
按“向上"或者"向下"的按钮，将光标移动到"②",然后按下OK键；
按“向上"或者"向下"的按钮，将光标移动到"③",然后按下OK键；
通过左右按钮移动光标，通过上下按钮修改日期及时间数值，通过OK键确认。

图2.设置时间步骤

操作方法二：编程模式下设置时间和日期

1、将LOGO!切换至编程模式

2、参考操作方法一的步骤2，设置日期及时间

二、通过软件设置

有操作面板的LOGO!可以通过面板设置实时时钟。无面板的只有通过编程软件和电缆与LOGO!模块通信，使用软件的菜单命令设置。

操作方法：

1.在LOGO!Soft Comfort软件菜单工具(Tools )> 传输（Transfer） >设置时钟（ Set Clock）命令设置实时时钟。

图3. 工具栏选择设置时钟

2.软件连接上LOGO!，在LOGO!设置中，在线设置，可以从PC读取时间，然后点击应用于LOGO!将时间设置到LOGO!中

图4.在线设置时钟

备份实时时钟

LOGO! 的内部实时时钟具有备份功能，LOGO!断电后后是靠超级电容保持的。环境温度会影响备份时间。

表2.LOGO!时钟备份时间及断电从新上电行为

设备系列 | 25°C 的环境温度保持时间 | 断电时间超过默认保持时间 | 是否有电池卡 | 加电池卡保持时间
LOGO!0BA8 | 20天 | 重启以后，内部时钟回到电源故障前的状态。 | 无 | 无
LOGO!0BA7 | 20天 | 重启以后，时钟设定为"Sa 00 00 2011-01-01"。该时间停止并闪烁。 | 无 | 无
LOGO!0BA6 | 80小时 | 重新启动后，时钟设定为"1 月 1 号 星期日 00:00"。 该时间停止并闪烁。 | LOGO! 电池卡或者LOGO! 存储器电池卡 | 2年

LOGO! 产品名称中包含字母 C ,表示控制器集成内置时钟，具有时钟备份功能；没有C ，说明控制器没有集成内置时钟，从而没有时钟备份功能。
例如:
产品名称为： LOGO! 12/24RCE *（6ED1052-1MD00-0BA8）

LOGO! 12/24 RC *（6ED1052-1MD00-0BA6）

LOGO! 24 *（6ED1052-1CC00-0BA6）

电池卡及存储器电池卡型号如下表所示：

表3：LOGO! ( 0BA6 ) 电池卡订货号

名称 | 订货号
LOGO! 电池卡 | 6ED1 056-6XA00-0BA0
LOGO! 存储器电池卡 | 6ED1 056-7DA00-0BA0

LOGO!的时间开关精度如何？

LOGO!230RC的时间精度取决于两个因素：

  • 相对误差：手册上给出的时钟精度（±2秒/天）就是相对误差。相对误差会在LOGO!运行过程中累积。这意味着运行30天后，时钟误差可能在±60秒左右。

    老产品（0BA3）的时钟精度为±5秒/天。

  • 绝对误差：绝对误差指计时中每两个小时之间的误差。绝对误差不会累积，所以基本上不用考虑。


LOGO!最大I/O能力

LOGO!I/O配置

最大I/O配置

LOGO！基本模块支持的最大I/O配置如下表所示：

 | 0BA6 | 0BA7 | 0BA8
数字量输入 | 24 | 24 | 24
数字量输出 | 16 | 16 | 20
模拟量输入 | 8 | 8 | 8
模拟量输出 | 2 | 2 | 8
表1 不同系列的LOGO!编程下载时对应的软件

注意：LOGO! 12/24 RCE/RCEo和LOGO! 24CE/24CEo的I1、I2、I7和I8可以用作模拟量信号输入（模拟量触发器等，0 - 10V）最大IO配置举例：

1. 【0BA8】不带模拟量输入的 LOGO! 的最大设置（LOGO! 24RCE/24RCEo 和 LOGO! 230RCE/230RCEo）

图1. LOGO!基本型，4个数字量模块和8个模拟量模块

2.【0BA8】带模拟量输入的 LOGO! 的最大设置 - 两个 （仅LOGO! 12/24 RCE/RCEo和LOGO! 24CE/24CEo支持)，LOGO!的I1、I2不用作模拟量输入,I7,I8用作模拟量输入的情况。其配置如下图：

图2. LOGO!基本型，4个数字量模块和7个模拟量模块

3.【0BA8】带模拟量输入的 LOGO! 的最大设置 - 四个 （LOGO! 12/24 RC/RCo和LOGO! 24/24o)

如果此时LOGO!上的I7、I8、I1、I2用作了模拟量输入AI1、AI2、AI3、AI4 。 其配置如下图：

图3. LOGO!基本型，4个数字量模块和6个模拟量模块

对于 LOGO! 12/24RCE/12/24RCEo 和 LOGO! 24CE/24CEo/24Eo 模块，无论模块使用零个、两个还是四个模拟量输入 （0BA6系列支持模拟量输入的模块无法设置0个模拟量输入） ，您都可以对其进行配置（进入命令菜单 文件 >属性 >I O设置）。您可以根据 LOGO! 主机模块配置的 AI输入数量来对这些输入进行连续编号。如果配置了两个输入，那么它们被编号为 AI1 和AI2，与输入端子 I7 和 I8 相对应。后续的 AI 扩展模块将会以 AI3开始编号。如果配置了四个输入，那么它们被编号为 AI1、AI2、AI3 和AI4，按顺序与输入端子 I7、I8、I1 和 I2 相对应。而后续的 AI 扩展模块将则以 AI5开始编号。

LOGO!设置电压等级不同的模块

将扩展模块连接到 LOGO! 主机模块上时，遵循以下原则：

  • 数字量模块只能直接连接到相同电压等级的设备上。
  • 模拟量模块和通讯模块可以连接到任何电压等级的设备上。

可以通过一个合适的 DM16 扩展模块来替换两个类似的 DM8 扩展模块（反之亦然），而不需要更改电路程序。

将扩展模块连接到 LOGO! 主机模块上 在下面的表格中，“X”表示可以进行连接，“-”表示不能进行连接。

图4. 将扩展模块连接到 LOGO! 主机模块

两个扩展模块的连接，请见下图

图5. 两个扩展模块的连接

模拟量输出

LOGO! 本体上没有集成的模拟量输出通道。LOGO! 通过加模拟量输出扩展模块最多可以支持两个通道（一个 AM2 AQ 模块）的模拟量输出。

AM2 AQ 模块只能用于0BA4 和 0BA5 及以上版本。 AM2 AQ2 在 0BA4 版本产品上只能支持部分功能。0BA4 和 0BA5 以前版本的产品不支持 AQ 模块。

常问问题：

为什么LOGO!第4个扩展模块DM8的输出点不能使用？

回答：因为LOGO!最多能支持16个数字量输出，LOGO!及前3个DM8扩展模块上的输出点加起来已经有16个数字量输出点了，因此最后一个DM8上的输出点已经不支持了，即不能使用了。

数字量输入信号能否用作数字量输出，数字量输出信号能否用作数字量输入？

回答：根据LOGO!的硬件结构，数字量输入、输出点不能混用，即数字量输入信号只能用作输入，而数字量输出信号只能用作输出。


S7-200运行周期

LOGO!的程序扫描循环周期

循环周期就是全部的程序运行时间（包括读输入、执行程序运算、写输出）。根据所应用的程序功能块的不同，循环周期长短不一。

LOGO! 0BA4基本型的典型循环周期为0.6ms - 8.0ms。

LOGO! 0BA3基本型的典型循环周期为7ms - 57ms。

没有数据说明单个的功能块执行需要多少时间。关于0BA4版的LOGO!，每个功能块的执行时间都在0.1ms以内。

《LOGO!手册》的附录B中有段小程序，可以用来测量循环周期。

相关链接

  • LOGO!的时间精度

相关问题

如何知道真正的LOGO!程序扫描时间？

在《LOGO!手册》的附录B中，有一个实际的测试程序。


LOGO! 主机模块接线

LOGO!提供了下图所示的主机模块：

图1 LOGO!主机模块

  • LOGO! 12/24 RCE/RCEo和LOGO! 24CE/24CEo的I3、I4、I5和I6可用作高速计数输入（加/减计数器，阀值触发器），最高频率可达5K
  • LOGO! 12/24 RCE/RCEo和LOGO! 24CE/24CEo的I1、I2、I7和I8可以用作模拟量信号输入（模拟量触发器等，0 - 10V）

LOGO! 12/24 RCE/RCEo

L + = 10.8 ... 28.8 V DC 正常输入最大频率：4Hz/高速输入（I3、I4、I5 和 I6） 最大5KHz 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大10A
模拟量输入4路：4（I1=AI3、I2=AI4、I7=AI1、I8=AI2）仅支持0 VDC 至 10 VDC 输入阻抗 72 kΩ 电缆最大长度：屏蔽 最大10米

图2 LOGO! 12/24 RCE/RCEo

LOGO! 24 CE/CEo

L + = 20.4 VDC 至 28.8 VDC 正常输入最大频率：4Hz/高速输入（I3、I4、I5 和 I6） 最大5KHz 输入电缆：非屏蔽 最大100米 晶体管输出，每个输出最大0.3A
模拟量输入4路：4（I1=AI3、I2=AI4、I7=AI1、I8=AI2）仅支持0 VDC 至 10 VDC 输入阻抗 72 kΩ 电缆最大长度：屏蔽 最大10米

图3 LOGO! 24 CE/CEo

LOGO! 24 RCE/RCEo

L + = 20.4 VAC 至 26.4 VAC 或者 20.4 VDC 至 28.8 VDC 输入最大频率：4Hz 且源型、漏型均支持 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大10A

图4 LOGO! 24 RCE/RCEo

LOGO!24RC和LOGO!24RCo是AC/DC（交、直流）两用模块，其中上图中所示的：

  • a.该接线方式下，输入信号高电平有效
  • b.该接线方式下，输入信号低电平有效

LOGO! 230 RCE/RCEo

L 1 = 85 ... 265 V AC 或者L+ = 100 ... 253 V DC（ 230 V AC 型：分为两组，每组包含 4 个输入，同一组内的每个输入必须连接到相同的相位，相位不同的组之间 可以内部互连）

 输入最大频率：4Hz 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大10A

图5 LOGO! 230 RCE/RCEo

常问问题

1.LOGO! 12/24 RCE/RCEo以及LOGO! 24CE/CEo支持模拟量输入信号0-10V，该如何实现？

首先，通过软件菜单栏 文件---属性，打开LOGO!设置对话框，如下图：

图6 LOGO! 设置

AI3、AI4、AI1、AI2 分别与输入端子I1、I2、I7、I8 对应。

设置上图中需要的模拟量通道数量，设置完毕后确保程序下载到LOGO!。

其次，将电压信号接入到对应的端子上

图7 AIW2接线

2.LOGO! 12/24 RCE/RCEo以及LOGO! 24CE/CEo怎样连接电流输入信号？

不能直接支持，需要将电流信号转换成电压信号，可以考虑并入一个500Ω电阻，具体方法可以参考怎样使用S7-224 XP 的模拟量输入通道接收电流信号?

此种将电流信号通过增加电阻，转换成电压信号，原理可行，但实际使用效果需要用户自行保证。

还有其他问题请查看本章节的 常见问题 页面。


数字量扩展模块接线

LOGO!系统中共提供了7种数字量扩展模块，这些数字量扩展模块均包含数字量输入与输出点，具体接线请看下图 (下文中仅列出常规参数，有具体特殊应用，请查看LOGO!设备手册 )

1.DM8 12/24R (4DI/4DO继电器输出)

L + = 10.8 ... 28.8 V DC 输入最大频率：4Hz 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大5A

图1 DM8 12/24R

2.DM8 24 (4DI/4DO晶体管输出)和DM16 24 (8DI/8DO晶体管输出):

L + = 20.4 ... 28.8 V DC 输入最大频率：4Hz 输入电缆：非屏蔽 最大100米 晶体管输出（24V DC），每个输出最大0.3A

图2 DM8 24 和DM16 24

3.DM8 24R (4DI/4DO继电器输出)和DM16 24R (8DI/8DO继电器输出):

DM8 24R L = 20.4 ... 26.4 V AC 或者L + = 20.4 ... 28.8 V DC 输入最大频率：4Hz（源型漏型都支持） 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大5A
DM16 24R L + = 20.4 ... 28.8 V DC 输入最大频率：4Hz 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大5A

图3 DM8 24R 和 DM16 24R

LOGO! DM8 24R是AC/DC（交、直流）两用模块。

4.DM8 230R (4DI/4DO继电器输出)和DM16 230R (8DI/8DO继电器输出):

DM8 230R L 1 = 85 ... 265 V AC 或者L+ = 100 ... 253 V DC（ 230 V AC 型 ：各输入不允许有不同的相位） 输入最大频率：4Hz（源型漏型都支持） 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大5A
DM16 230R L 1 = 85 ... 265 V AC 或者L+ = 100 ... 253 V DC（ 230 V AC 型：分为两组，每组包含 4 个输入，同一组内的每个输入必须连接到相同的相位，相位不同的组 之间可以内部互连） 输入最大频率：4Hz（源型漏型都支持） 输入电缆：非屏蔽 最大100米 继电器输出，每个输出最大5A

图4 DM8 230R 和 DM16 230R

注意：

输入：

  • LOGO！的数字量输入信号必须与 LOGO！上电源的电压等级相同，也就是说电源为24（12）VDC，则输入也为24（12）VDC；电源为220VAC，则输入也为220VAC
  • LOGO!230这种型号的输入有两个组，不同的组可以接三相交流电的不同相，但同一个组的接线要保证接在同一个相位上。如果附加了扩展模块，也可以分组接不同相位的输入信号。零线必须是同一个

输出：

  • 晶体管输出的LOGO!：
    型号中没有字母“R”的LOGO！为固态晶体管输出的LOGO！。这种型号的LOGO！输出有短路保护和过载保护，它提供负载电源输出，不需要一个辅助的为负载供电的电源
  • 继电器输出的LOGO！：
    型号中有字母“R”的LOGO！为继电器输出的LOGO！。它的输出提供一个干接点，且每一路输出都是相互隔离的，与电源也是隔离的，因此每一路输出都可以接电压等级在0－220V之间的不同的交直流负载。

LOGO!的继电器输出点不能连接380VAC电路！

附加数字量输入/输出模块DM8（DM16）的输入信号电平与其模块供电相同。不同供电类型的LOGO!本体和DM模块，以及DM模块之间未必能够相邻组合。

LOGO!采用一种“机械编码”以防止错误的模块插接，机械编码的结构不能人为破坏，否则会烧毁模块。

还有其他问题请查看本章节的 常见问题 页面。


模拟量扩展模块接线

LOGO!系统中提供了 共3种模拟量扩展模块，其中包括2种输入普通模拟量扩展AM2 和AM2 RTD扩展，一种模拟量输出扩展AM2 AQ 。

AM2 模拟量模块接线

普通模拟量模块可以采集标准电流和电压信号。其中，电流包括：0-20mA、4-20mA两种信号，电压包括：0 -10 VDC。普通模拟量通道值范围是0~1000，精度10位，支持的最大电缆长度：屏蔽线10米。

模拟量电流、电压信号根据模拟量仪表或设备线缆个数分成四线制、三线制、两线制三种类型，不同类型的信号其接线方式不同。 四线制信号指的是模拟量仪表或设备上信号线和电源线加起来有4根线。仪表或设备有单独的供电电源，除了两个电源线还有两个信号线。四线制电流信号的接线方式如下图中的2所示。

四线制信号的接线方式如下图所示。

图1 模拟量模块接线

  • 1. 模块供电 此处有2组L+，M，只接一路即可，两组冗余端子，互为备用
  • 2. 4线制电流信号接线
  • 3. 4线制电压信号

三线制信号是指仪表或设备上信号线和电源线加起来有3根线，负信号线与供电电源M线为公共线。

图2 三线制电流信号接线

两线制信号指的是仪表或设备上信号线和电源线加起来只有两个接线端子。由于LOGO!模拟量模块通道没有供电功能，仪表或设备需要外接24V直流电源。两线制信号的接线方式如下图3 两线制电流接线所示。

图3 两线制电流信号接线

不使用的模拟量通道要将通道的两个信号端短接

AM2 RTD温度模块接线

LOGO!系统中提供了一个AM2 RTD模块，用于连接PT100/PT1000温度传感器。模块最多可以连接两个 PT100 传感器或者两个 PT1000 传感器或者一个 PT100 传感器加上一个 PT1000 传感器，连接方式为2线或者3线亦或2线和3线混用。注意！该模块仅支持默认温度系 数 α= 0.003850 的 PT100 或者 PT1000 传感器。支持的最大电缆长度：屏蔽线10米。

之前老版本提供LOGO!AM2 PT100模块，用于连接PT100温度传感器，接线方法与AM2 RTD一致，下文中以AM2RTD模块为例介绍。

AM2 RTD模块支持2线接法和3线接法。3线接法能够抑制电缆长度（欧姆电阻）对测量结果的影响，精度更高。

图4 热电阻信号接线

  • 1. 模块供电 此处有2组L+，M，只接一路即可，两组冗余端子，互为备用
  • 2. 热电阻信号2线制接法，手动短接IC1与U1-
  • 3. 热电阻信号3线制接法

目前LOGO!仅支持热电阻信号，不支持热电偶模块，如果现场是热电偶模块，请使用变送器将热电偶信号转换成普通的电压或电流信号。

AM2 AQ模拟量输出模块接线

LOGO!系统中提供了一个AM2 AQ模拟量输出模块，可以输出标准电流和电压信号。其中，电流包括：0-20mA、4-20mA两种信号，电压包括：0 -10 VDC。模拟量通道值范围是0~1000，精度10位，支持的最大电缆长度：屏蔽线10米。

LOGO!模块本身需要供电，所以其模拟量输出信号是4线制信号。

AM2 AQ的具体接线方法见下图：

图5 AQ模拟量输出信号接线

  • 1. 模块供电 此处有2组L+，M，只接一路即可，两组冗余端子，互为备用
  • 2. 电压信号接法，其中，R1≥5KΩ
  • 3. 电流信号接法，其中，R2≤250Ω

还有其他问题请查看本章节的 常见问题 页面。


模拟量比例换算

LOGO! 处理物理量需要多个步骤： LOGO! 可以从一个模拟量输入通道读取 0 V 至 10 V 的电压，或者 0 mA 至 20 mA 的电流。

LOGO! 读入电气量，经进一步处理，将其转换为 0 至 1000 范围内的标准化值，然后即可在电路程序中将该值用作模拟量特殊功能块（例如模拟量放大器）的输入。 如果模拟量特殊功能具有模拟量输出，则模拟量值也应用到特殊功能的输出。

图1 模拟量处理

AM2 模拟量输入换算（电压/电流信号）

换算可以由一个单独的“模拟量阈值触发器”功能块完成，其它如“模拟量放大器”、“模拟量比较器”等功能块也能进行。

1.换算功能通过设置模拟量处理功能块的“增益”和“偏置”完成。设置合适的“增益”和“偏置”可以把输入信号换算为实际工程量。

图2 模拟量阈值触发器

在上图中：

  1. 设置传感器类型： 0V 至10V、0mA 至20mA转换为0至1000标准化值；4mA 至20mA标准化值的值范围为200至1000
  2. 量程范围，可以是实际的工程量： (Ax * 增益) + 偏移 = 实际值 Ax
  3. LOGO!Soft Comfort根据量程范围自动计算增益和偏移。
  4. 设置接通、断开的阈值：Ax大于25时，接通输出，Ax小于5时断开输出
  5. 选择在“文本显示”中的小数点位置

2.以图2中设置的参数为例，确认模拟量换算的方法：

图3 模拟量换算例程

在图3中：

  1. AI1转换以后的工程量(因为图中的b.=500)：15（30*1/2=15）
  2. AI1的标准化值（实际电压信号是5V）：500 （500/1000=1/2）
  3. AI1转换以后的工程量 Ax ，可以与其他块参数做逻辑运算
  4. 文本显示的Ax，因设置时选择一位小数位数，所以显示值是实际值除以10即，1.5
  5. 因Ax还未大于25，所以Q点未接通

LOGO!Soft Comfort 以最大精度计算增益和零点偏移，但是 LOGO! 将使用整数值进行内部计算；因此，不是所有参数组合都可以在 LOGO! 上使用。 在这种情况下，在将值传送到 LOGO! 之前，LOGO!Soft Comfort测到存在取整错误，并建议一个可能的替换值范围，因此可能无法设置出用户需要的量程范围，例如上例中量程范围改为1-30，会提示错误，遇到这种情况，可以考虑先将模拟量信号转换为0-10或者10-300，然后利用其他功能块，例如算术指令，将最终的量程转换为1-30，再做后续程序。

AM2 RTD模拟量输入换算

AM2 RTD模块把PT100传感器的量程范围 -50°C - 200°C转换为LOGO!内部的数值。下例中通过“模拟量放大器”功能块完成换算。

换算功能通过设置模拟量处理功能块的“增益”和“偏置”完成。设置合适的“增益”和“偏置”可以把PT100的输入信号换算为摄氏温度值，或者华氏温度值。

图4 设置模拟量放大器参数

在上图中：

  1. 在此用下拉列表选择传感器类型
  2. 根据下面的设置自动生成的增益和偏置值
  3. 选择摄氏和华氏温标：Celsius是摄氏温度，Fahrenheit是华氏温度
  4. 选择精度，即精确到个位数还是小数点后一位
  5. 选择在“文本显示”中的小数点位置

上图显示的设置是选用摄氏温度、精度为0.1度时，编程软件自动设置的增益为2.50，偏置为 -500，放大器输出的实际值Ax的范围是-500-2000，该值除以10 后就是实际的温度值。

手动编程时，需要在功能块上设置相应的参数。

表1. 手动编程时设置增益和偏置取值

温标 | 数值精度 | 增益取值 | 偏置取值
摄氏 | x 1 | 0.25 | -50
 | x 0.1 | 2.5 | -500
华氏 | x 1 | 0.45 | -58
 | x 0.1 | 4.50 | -580

还有其他问题请查看本章节的 常见问题 页面。


常见问题

常问问题

1.LOGO!的模拟量输入信号怎样做滤波？

LOGO!中可以为每一路模拟量输入选择软件滤波器（最多八个模拟量滤波器功能块可用于 LOGO!Soft Comfort V7.0 或 V8.0 中的电路程序。）。在LOGO!Soft Comfort 软件指令树---特殊功能块---模拟量---模拟量滤波器：

该功能在根据所设置的采样数，对模拟量输入信号进行采样后，输出平均值。 该特殊功能块可以对模拟量输入信号进行平滑。

模拟量滤波器使用步骤如下：设置模拟量采样数，例：此处设置的64表示模拟量滤波后的值为包括当前采样的前64个采样值的平均值。

图1 模拟量滤波

Sn （采样数）： 决定在程序周期内所采样的模拟量数值的数量，而程序周期数由所设定的采样数确定。 在每个程序周期内，LOGO! 都会采样一个模拟量数值。 程序周期数与所设定的采样数相同。

注意：

  • 为变化比较缓慢的模拟量输入选用滤波器可以抑制波动
  • 为变化较快的模拟量输入选用较小的采样数和死区值会加快响应速度
  • 对高速变化的模拟量值不要使用滤波器
  • 热电阻信号不建议使用滤波

2.LOGO!扩展模块上的LED灯为何亮红灯？？

扩展模块上的LED灯为红色，说明与其左侧的模块通信不正常。

  • 如果是在产品经过运输后出现这个问题，很可能是剧烈震动造成接触松动。只需按顺序拆装一遍就可以解决。装配时要注意把灰色的模块连接滑块移动到位。
  • 检查扩展模块的供电。
  • 扩展模块必须在LOGO!本体上电之前、或者同时上电。

3.LOGO!的输入/输出和中间点状态如何监视？

用户可以在带显示的LOGO!上直接监视输入（I），输出（Q），以及中间点（M）的状态。

首先必须启动LOGO!，使LOGO!进入启动菜单（此时屏幕上显示系统时间及日期），即要监视各点状态，LOGO!必须在运行状态，然后通过按左右键头在输入输出点及中间点显示屏之间切换。凡是接通的点都会变成黑底白字。

LOGO!在运行状态时，可以通过按ESC键在启动菜单的状态监视与参数赋值状态之间切换。

启动菜单（运行）：

图2 状态监视

4.LOGO!的数字量输入/输出响应速度？

LOGO!对数字量（开关量）处理的速度取决于如下因素：

  1. 输入硬件延时
  2. 程序处理时间
  3. 输出硬件延时

LOGO!新产品（0BA4版本）的程序扫描周期在10ms以内。

部分LOGO!型号提供了由硬件处理的高速脉冲输入点。参见《LOGO!手册》。

表1. LOGO!的数字量硬件响应时间

模块型号 | 输入响应速度 |  | 输出开关频率
 | 0 - 1 | 1 - 0 | 机械触点 | 电气触点 | 阻性负载 | 感性负载
LOGO! 24RC LOGO! 24RCo | 典型 1.5ms |  | 10Hz | - | 2Hz | 0.5Hz
DM8 24R DM16 24R
LOGO! 230RC LOGO! 230RCo DM8 230R DM16 230R | 典型 50ms
LOGO! 12/24RC LOGO! 12/24RCo | 典型 1.5ms（I1-I4） < 1.0ms（I5,I6） 典型 300ms（I7,I8）
LOGO! 24 LOGO! 24o |  |  | - | 10Hz | 10Hz | 0.5Hz
DM8 24 DM16 24 | 典型 1.5ms

有些LOGO!模块的I5,I6速度快是因为本身支持高速输入，硬件不同；I7,I8反应慢是因为具有支持模拟量输入的硬件电路。

继电器输出点的反应时间在10ms级；晶体管输出点的反应时间可以忽略。

5.LOGO!模拟量模块的输入/输出阻抗指标是多少？

详情可见《LOGO!设备手册》的附录A. 技术数据 。手册下载参考资料手册在线下载章节

LOGO!主机模拟量输入阻抗：电压型信号：≥ 72KΩ

扩展模块模拟量输入阻抗：电压型信号：76KΩ ；电流型信号：＜250Ω

模拟量输出阻抗：电压型信号：≥ 5KΩ ；电流型信号：≤ 250Ω

6.LOGO!模拟量模块精度是多少？

LOGO!模拟量模块的转换精度是10位。

7.LOGO!230RC是否能用于380VAC的场合？

不能。380VAC电压不能接到LOGO!230RC的电源输入端；也不能用于它的继电器触点。


LOGO! 轻松软件基本使用介绍

LOGO!Soft Comfort（LOGO! 轻松软件）软件安装

目前 LOGO!Soft Comfort 软件最新版本为V8.1.1

软件链接如下所示：

LOGO!Soft Comfort V8 (Windows) 完整版软件：
http://w2.siemens.com.cn/download/logo/LOGO!%20V8.0%20%E8%BD%AF%E4%BB%B6.7z

LOGO!Soft Comfort V8.1.0软件升级包 (Windows)：
http://w2.siemens.com.cn/download/logo/LOGO!%20V8.1%20%E5%8D%87%E7%BA%A7%E5%8C%85%E8%BD%AF%E4%BB%B6.7z

LOGO! Soft Comfort V8.1.1编程软件升级包 ：
http://w3.siemens.com/mcms/programmable-logic-controller/en/logic-module-logo/demo-software/Pages/Default.aspx

上述链接下载的软件适用于Windows操作系统

软件安装

V8.0版本软件：

1、点击链接下载LOGO!Soft Comfort V8 (Windows) 完整版软件

2、此版软件为绿色版本，解压缩，直接打开完整安装软件包，根据电脑操作系统版本，选择相应文件夹，点击应用程序运行即可

图1.解压缩后选择操作系统

图2.点击可执行文件

V8.1.0版本软件安装

如果V8.0版软件基础上安装：运行V8.1.0版本软件升级包将软件升级至V8.1.0版本。

解压缩V8.1.0版本升级包，为.exe可执行文件，运行，按照安装向导执行即可。

V8.1.1版本软件安装

如果电脑上之前没有LOGO!Soft Comfort软件，可以先安装V8.0完整版软件，然后运行V8.1.1版本软件升级包；

如果电脑LOGO!Soft Comfort已经是V8.1.0版本，在V8.1.0基础上运行v8.1.1版本软件升级包即可；

解压缩V8.1.1版本升级包，为一个.exe可执行文件，运行，按照安装向导执行即可。

LOGO! Soft Comfort V8.1.1编程软件升级包链接，进入网站页面，在如下图片选择相应的系统版本自行下载。

图3.V8.1.1升级包下载

软件兼容性

建议使用的操作系统

LOGO!Soft Comfort V8.1 支持以下操作系统：

  • Windows：Windows XP、Windows 7、Windows 8 或 Windows 10，具体要求如下：

    • 带有奔腾 IV 处理器的 PC

    • 150 MB 空闲硬盘空间

    • 256 MB RAM

    • 最低 800 x 600 分辨率的 SVGA 显卡（最少 256 色）

    • DVD-ROM

  • Mac OSx：Mac OSx 10.6、Mac OSx 10.7、Mac OSx 10.8、Mac OSx 10.9。与下列兼容：Mac OS X 10.6 Snow Leopard、Mac OS X Lion、Mac OS X MOUNTAIN LION、Mac OS X Mavericks。

  • Linux：经过 SUSE Linux 11.3 sp3 内核 3.0.76 测试。与所有兼容 Java 2 的 Linux 发行套件兼容。您可以在相应的 Linux 发行套件中找到必要硬件要求。

软件卸载

点击电脑开始-->控制面板-->程序和功能，选择要卸载的应用程序名称，此处为LOGO!Soft Comfort V8.1.1

图4.控制面板卸载软件

常问问题

是否必须安装或者运行LOGO!SoftComfort V8完整包才能再升级到LOGO!SoftComfort V8.1.0或者V8.1.1?

1、LOGO!SoftComfort V8是绿色版， 无需安装，双击程序运行即可。
2、即使不运行LOGO!SoftComfort V8只要有完整的LOGO!SoftComfort存放于电脑上， 在安装运行LOGO!SoftComfort V8.1或者V8.1SP1升级包时找到旧版本完整包路径即可。
3、按以上方法升级后， 控制面板中只有一个图标LOGO!Soft Comfort V8.1或者V8.1.1。（并不有两个图标LOGO!Soft Comfort V8和LOGO!SoftComfort V8.1）

图5.路径


LOGO! 轻松软件基本使用介绍

LOGO!Soft Comfort（LOGO! 轻松软件）基本使用介绍

LOGO!Soft Comfort （LOGO! 轻松软件）是在计算机上运行的 LOGO! 编程软件。随着 LOGO! 产品系列的发展，LOGO!Soft Comfort 也经历了版本升级，从 V1.0 一直发展到目前的 V8.1。

软件主要实现功能：

1、编写程序：功能块图、梯形图及 UDF 图
2、离线仿真程序
3、生成和打印电路程序的概览图
4、PC 与 LOGO! 间双向传送程序
5、设置 LOGO! 的时间
6、在线测试
7、文档记录

LOGO!Soft Comfort 在线帮助_中文版：https://support.industry.siemens.com/cs/cn/zh/view/100782807

LOGO!Soft Comfort 在线帮助_英文版：https://support.industry.siemens.com/cs/cn/en/view/100782807

V 8.1 软件界面介绍

编程界面：LOGO!Soft Comfort 编程模式以空白电路程序开始。创建电路程序的编程界面占用了绝大部分画面。 电路程序的图标和逻辑链接排列在此编程界面上。
为了帮助您总览大型电路程序，在编程界面的右侧和底部包含滚动条，可以利用它们沿垂直和水平方向滚动电路程序。编程界面如下图所示：

图.1 编程界面

①菜单栏：
②标准工具栏：
③模式栏 ：
④编程工具栏 ：
⑤编程界面 ：
⑥状态栏 ：
⑦电路图树 ：
⑧指令树：

项目界面：LOGO!Soft Comfort 的项目模式以 LOGO!Soft Comfort 的空白用户界面启动。 当选中并添加了项目中的新设备后，LOGO!Soft Comfort 会启用电路图编辑边框。
LOGO!Soft Comfort 在项目界面上显示包含设备及网络连接的网络视图。 电路图编辑器显示电路程序的程序块及逻辑连接。 电路程序起初是空白的。
为了帮助您总览大型电路项目和程序，在网络视图和编程界面的右侧和底部包含滚动条，可以利用它们沿垂直和水平方向滚动电路程序。

图2.项目界面

①菜单栏 ：同上
②标准工具栏：同上
③模式栏 ：同上
④网络工具栏
⑤网络视图
⑥编程工具栏
⑦编程界面
⑧状态栏
⑨设备树
⑩指令树

常问问题

1.如何显在菜单栏下面显示标准工具栏？

在菜单栏中选中查看，勾选电路图模式及工具栏

图3.查看对话框

图4.模式栏显示

如果取消勾选，如下图所示

图5.模式栏显示

2.如何查看/修改 LOGO! 设置？

项目已经编辑好了，如何再修改属性，比如更改设备类型，或者设置密码等操作，有三种操作

方法一：快捷键 Alt+Enter

方法二：点击电路图，右键，点击属性或者消息文本设置都可以出现 LOGO! 设置对话框

图17.属性设置

方法三：在菜单栏，点击文件，选中属性或者消息文本设置都可以出现 LOGO! 设置对话框

图18.属性设置

3.如何切换 LOGO! 编程语言？

默认的编程语言是 FBD(电路图)，可以修改，按照如下操作

1、菜单栏，工具，选项

图19.工具栏对话框

2、选项对话框，常规，默认编辑器，在标准编辑器中可以选择 FBD 或者 LAD。

图20.默认编辑器设置

对于已经使用FBD(电路图)编程，需要切换到LAD 语言如何切换，如下图，点击红色框中的按钮，可以实现FBD(电路图)及 LAD的切换

图21.切换编程语言

注意：
已经编辑好的项目，切换编程语言后，需要测试相应功能是否正常（使用仿真功能，软件进行仿真）后，再下载到设备中，确保安全！

4.如何增加编程页面？

编程过程中，如果发现编程页面不够用，可按照如下操作进行

点击编程工具栏，选中红色框中的按钮，出现对话框中可以设置页面数量，根据实际需求，可以选择填写水平及垂直页面数量。

图22.增加编程页面设置

5.指令操作数引用变量？

组态 LOGO! 0BA8 设备，调用算数指令，参数希望使用变量填写，参考如下操作

图23.算数指令属性设置

点击指令下发出现的+，出现参数框，将参数连线连接，查看指令参数已经引用变量。

图24.展开收起参数框连接参数

注意：指令下方展开收起参数框的功能，仅限0BA8及以上版本支持


LOGO!Soft Comfort 常见问题

1.如何查看LOGO!Soft Comfort软件的版本？

随着 LOGO! 产品系列的发展，LOGO!Soft Comfort 也经历了版本升级，从 V1.0 一直发展到目前的 V8.1。LOGO!Soft Comfort 向下兼容，支持所有老版本的 LOGO! 模块。

目前最新的 LOGO!Sfot Comfort 软件版本为 V8.1.1。

使用 Help （帮助）菜单的 About（关于） 命令查看软件版本号：

图1 查看软件版本号

图2 软件版本信息 4.0.51

图3 软件版本信息8.0.0

“System info（系统信息）”标签内将显示LOGO!Soft Comfort系统组件、运行环境等信息。

注意：

0BA6/7 版本的 LOGO!，必须使用 LOGO!Soft Comfort V7.0或者更高版本。

0BA8 stand版本的 LOGO!，必须使用 LOGO!Soft Comfort V8.0或者更高版本。

0BA8 FS04版本的 LOGO!，必须使用 LOGO!Soft Comfort V8.1或者更高版本。

低版本的软件不支持新模块。

如果软件版本较低 需要升级可以参考： 如何将LOGO!Soft Comfort 软件版本升级(更新)到最新版本

2.LOGO!Soft Comfort软件是否支持仿真测试功能？

支持，具体步骤：

1.用户可以点击LOGO!Soft Comfort 软件里电路图编辑界面的仿真快捷按钮：

图4 仿真快捷按钮

或者在LOGO!Soft Comfort 软件 菜单栏 工具---仿真:

图5 仿真

2.激活仿真后在电路下方有 仿真控制面板，可以由用户自行控制LOGO!启动、停止以及IO点状态等 。

图6 仿真控制面板

另外，信息文本显示器也支持仿真。

图7 仿真信息文本显示器

LOGO!Soft Comfort V7.0的仿真快捷按钮见下图：

图8 0BA6仿真快捷按钮

3.怎样通过LOGO!Soft Comfort编程软件监控LOGO!程序？

将LOGO!程序下载后，LOGO!Soft Comfort 软件里电路图编辑界面的工具栏中找到在线测试快捷按钮：

设置通信端口，连接LOGO!后，可以看到程序内IO点以及各功能块的状态，

图9 在线监控程序

  • a. 鼠标靠近想要监控的块后在该块右下角会显示小眼睛，点击该小眼睛可看到监控的参数
  • b. 点击小眼睛后可以看到定时器的定时时间
  • c. 在线监控的显示面板 Q1黄灯亮表示Q1有输出

4.如何修改编程软件的语言？

点击LOGO!Soft Comfort 软件菜单栏工具---选项，再弹出的基本设置对话框修改：

图10 修改编程语言

  • a. 可以修改编程语言是FBD还是LAD
  • b. 修改编程软件的语言

要设置并应用一种新语言，必须设置完以后关闭 LOGO!Soft Comfort，再重新启动。

5.在网络视图界面下编辑程序，能否使用LAD编程语言？

不支持，只能用FBD语言编程。

6.怎样下载TD/TDE 文本显示的程序？

文本显示的程序由块“信息文本显示器” 组态，所以将组态有信息文本显示器的程序下载至TD要连接的LOGO!即可（LOGO!与文本显示连接成功，还需要考虑IP设置等），不用单独给TD/TDE下载程序。


新建电路图程序

1、启动 LOGO!Soft Comfort,选择电路图模式

2、通过文件 → 新建或在项目模式下点击标准工具栏中的新建按钮。

图1.新建

3、基本设置,设置电路程序名，设置设备的IP地址。

图2.基本设置

4、选择硬件类型，选择的设备类型与使用的设备类型一致。

图3.硬件类型设置

5、进行IO设置，尤其注意机载AI设置

图4.IO设置

6，如果需要可以设置I/Q的符号名称

图5.IO名

7、如果需要密码，可以设置电路程序密码
使用字母A~Z，不区分大小写；
如果后续需要更改密码，需要正确输入旧密码才可以设置新的密码；
只有输入正确的密码，才能在LOGO! 主机模块上编辑受密码保护的电路程序或者通过LOGO!Soft Comfort 更新电路程序。

图6.电路程序密码

8、编程界面，电路图编辑区域进行程序编程即可

图7.电路图编程

9、存储文件：

表1.不同编程语言的存储文件

编程语言 | 存储文件
梯形图-LAD（.lsc） |
功能图-FBD（.lld） |

如何切换 LOGO! 编程语言，请查看

如果存储的程序是.lgo的，还能用编程软件打开吗？

可以，后缀是.lgo的文件，是因为保存文件时选择下图中的格式：

图8.存储格式

存储后，生成文件如下图，

图9.lgo格式文件


新建网络项目

如果需要通信，或者项目中包含多个 LOGO! 设备，可以考虑建立网络项目，步骤如下

1、启动 LOGO!Soft Comfort,选择网络项目

2、项目树点击添加新设备

图1.添加新设备

3、选择设备对话框中选择相应使用设备

图2.选择设备

4、新建项目如下图所示，对设备进行属性设置，可以点击项目树中设置按钮，在电路图编辑器中可以进行程序编辑。

图3.项目配置

5、对项目保存，生成的文件后缀为.mnp,图标如右图

网络项目只支持梯形图-LAD编程语言。


基本指令使用

周定时器

周定时器用来实现最大循环周期为一周的定时任务，也可以用来实现按天循环的定时任务。

只有具内部实时时钟的LOGO!模块（型号后面带有C的模块）支持这个特殊功能块。

每个周定时器实际上是由三个独立的星期－日定时器复合而成。每个星期－日定时器可以设置一个“开/关”时间段，独立对一星期内的某天（可以分别设定）起作用。因此一周内的每天可以设置三个开/关时间段，或者说，每一时刻的输出状态可以受到最多三个时间段设定条件的约束。

三个星期－日定时器输出的综合就是周定时器功能块的输出。一般地，综合输出是三个时间段设置的逻辑“或”的结果；但如果三个时间段的设置有冲突，比如一个时间段设置为“ON”而另一个设置为“OFF”，它们之间按号码的大小为优先级别排队，3优先于2，2优先于1。

每个时间段的设置包括一个起始（开）时间，一个终止（关）时间。它们可以单独设置，可以只有起始时间，也可以只有终止时间，没有任何设置说明此时间段没有起作用。

如果需要设置一整天，只需要将起始时间激活并定时在00:00，而不设置终止时间；如果需要跨天设置，首日和终日只需单独设置起始和终止时间。

特殊标志位

启动标志位：M8在用户程序启动的第一个循环周期会被置位为“1”；在完成第一个循环周期后，会自动复位为“0”，因此M8可作为用户程序的启动标志。

M8在所有其余的循环周期内可用作中间点，其用法和其它的标志位用法相同。

背光标志位：相关标志位置一后，对应的设备会显示标志位代表的颜色，该功能通过显示屏的背景色来显示某种报警状态。

M25（白色）、M28（黄色） 和 M29（红色） 控制 LOGO! 本体显示屏的背光。 M26（白色）、 M30（黄色） 和 M31（红色） 用于控制 LOGO! TDE的背光。 您可以使用定时器、消息文本或其它功能块的输出激活背光标志。 要启用多个条件来控制设备的背光，可以并行或按顺序使用多个功能块 。

M28、M29、M30、M31 从LOGO!0BA8开始支持，0BA6/0BA7版本，仅支持M25、M26，不同版本的LOGO!支持的标志位不一样，具体以设备手册为准。

消息文本字符集标志位：可以使用 M27 启用第一级字符集或第二级字符集的消息文本并禁用另一个字符集的消息文本。 当 M27=0（低）时，LOGO! 只会显示第一级字符集的消息文本；当 M27=1（高）时，LOGO! 只会显示第二级字符集的消息文本。

反向输入

您可以反向各个输入：

要执行该操作，在功能块输入线上单击鼠标右键，然后从快捷菜单中选择反向连接器，此时块输入会有小黑点，见下图：

图1 反向输入

您无法使输出块的输入反向。

功能块之间变量的引用

可以通过其它功能块A的值将参数分配给功能块B。此类参数为引用参数。

具体步骤可以参照下图：

图2 变量引用

  • a. 点击功能块下方的加号，显示参数框的参数，
  • b. 可以通过简单的拖拽在一个功能的参数连接器和另一功能的参数连接器之间创建参考线，
  • c.成功创建参考线后，双击功能块打开属性对话框，
  • d.对应的属性变为灰色，无法修改参数，显示被引用的参数，

注意，不能将一个输出参数连接到另一个输出参数,如果两个变量之间不支持引用，拖拽后无法成功创建参考线。

两个参数之间的参考线表明了他们之间的引用关系。您可以删除参考线来移除引用。

如果是LOGO!Soft Comfort V7按照下面的步骤创建引用：

    1.在块属性窗口中点击参数旁的“引用”按钮。

    2.LOGO!Soft Comfort 显示所有可提供引用参数的功能块。 选择您想要引用的功能块。

周定时器

周定时器用来实现最大循环周期为一周的定时任务，也可以用来实现按天循环的定时任务。

只有具内部实时时钟的LOGO!模块（型号后面带有C的模块）支持这个特殊功能块。

每个周定时器实际上是由三个独立的星期－日定时器复合而成。每个星期－日定时器可以设置一个“开/关”时间段，独立对一星期内的某天（可以分别设定）起作用。因此一周内的每天可以设置三个开/关时间段，或者说，每一时刻的输出状态可以受到最多三个时间段设定条件的约束。

三个星期－日定时器输出的综合就是周定时器功能块的输出。一般地，综合输出是三个时间段设置的逻辑“或”的结果；但如果三个时间段的设置有冲突，比如一个时间段设置为“ON”而另一个设置为“OFF”，它们之间按号码的大小为优先级别排队，3优先于2，2优先于1。

每个时间段的设置包括一个起始（开）时间，一个终止（关）时间。它们可以单独设置，可以只有起始时间，也可以只有终止时间，没有任何设置说明此时间段没有起作用。

如果需要设置一整天，只需要将起始时间激活并定时在00:00，而不设置终止时间；如果需要跨天设置，首日和终日只需单独设置起始和终止时间。

LOGO!的时间开关精度如何？

LOGO!230RC的时间精度取决于两个因素：

  • 相对误差：手册上给出的时钟精度（±2秒/天）就是相对误差。相对误差会在LOGO!运行过程中累积。这意味着运行30天后，时钟误差可能在±60秒左右。

    老产品（0BA3）的时钟精度为±5秒/天。

  • 绝对误差：绝对误差指计时中每两个小时之间的误差。绝对误差不会累积，所以基本上不用考虑。

相关问题

如何知道真正的LOGO!程序扫描时间？

循环周期就是全部的程序运行时间（包括读输入、执行程序运算、写输出）。根据所应用的程序功能块的不同，循环周期长短不一。

LOGO! 0BA4基本型的典型循环周期为0.6ms - 8.0ms。

LOGO! 0BA3基本型的典型循环周期为7ms - 57ms。

没有数据说明单个的功能块执行需要多少时间。每个功能块的执行时间都在0.1ms以内。

在《LOGO!设备手册》的附录B中，有一个实际的测试程序。


存储卡

LOGO! 的存储卡

可以在LOGO!本体上的外插卡连接端口，插入一个存储卡，用于实现，保存程序，程序归档；复制同样的程序到许多产品的LOGO!控制器中；通过邮寄的方式传递程序；保护LOGO!的程序等功能。

 | LOGO!0BA6 | LOGO!0BA7 | LOGO!0BA8
外部存储器 | LOGO!存储卡，LOGO!存储器/电池卡 | 标准SD卡（FAT32） | Micro SD卡 （FAT32）
外部电池 | LOGO!电池卡 | 不支持 | 不支持
编程口 | LOGO! 方形口 | 以太网口 | 以太网口
编程电缆 | LOGO! 编程电缆 | 以太网线 | 以太网线
表1 不同系列的LOGO!的接口对比

注意：

  • 存储卡仅用于保存LOGO!程序，并且一个卡中只能保存一个程序。
  • 对于0BA6的LOGO!这个插口也用于连接编程电缆。存储卡是单独订货的，必须使用西门子的产品。
  • 对于0BA7、0BA8的LOGO!这个插口只用于插存储卡，该存储卡支持商用的FAT32格式的存储卡。

LOGO!存储卡的兼容性（0BA6及以前版本）

LOGO! 0BA6 存储卡（紫色）用于保存电路程序。 LOGO! 电池卡（绿色）可供实时时钟多达两年的电池储备。LOGO! 存储器电池卡（棕色）既可以保存电路程序，也可以用作实时时钟的电池储备

棕色外壳，专门为0BA4配套。棕卡可以在使用时被设置为具有以前红色、或者黄色卡的功能。

棕色卡不能用于老的产品（0BA3及以前）上；老产品系列的红色、黄色、蓝色卡不能用于新产品（0BA4）上。红色、黄色、蓝色的卡都已停产。

因此，老产品的程序不能通过存储卡传递到新系列的LOGO!中，只能使用LOGO!轻松编程软件LOGO!Soft Comfort V4.0才能完成这一转换。

对于0BA6及以前LOGO!存储卡的兼容性，可以参考：：哪些 LOGO! 存储卡/电池卡可与哪些 LOGO! 系列设备配合使用？

LOGO!存储卡的功能

LOGO!的存储卡的功能：

  • 1.普通存储功能：内部存有LOGO!程序的存储卡插到LOGO!上，上电后程序被复制到LOGO!内部；存储卡拔走后，程序依旧保存在LOGO!内。
  • 2.副本保护功能：将程序复制到存储卡中后，在LOGO!菜单中设置存储卡的“副本保护”功能为“Yes”，则只有在存储卡插在LOGO!上时，LOGO!才能执行程序；存储卡拔走后，程序消失。
  • 3.程序下载功能（新增仅0BA7/8支持）：将FBD程序转换为二进制转储文件，直接通过读卡器复制到存储卡，通过该存储卡将程序下载到相同型号的LOGO!，而不通过编程电缆。

鉴于0BA6/0BA7系列产品均已取消，下文中具体功能的描述均以最新的0BA8为例，针对老产品的功能，可以参考以下步骤，如果有疑问，请联系西门子热线技术支持。

1.LOGO!存储卡的普通存储功能

目的：通过存储卡复制硬件1号LOGO!里的程序，然后将存储卡放在2号LOGO！主机模块，将程序传输到2号LOGO!（前提：1号与2号LOGO!订货号和版本均一致）。具体步骤：

具体步骤：

第一步，1号LOGO!断电，将空的micro SD卡插入到LOGO!卡槽（为避免损坏 SD 卡槽，请不要将插座完全拉至模块以外），卡槽复位并将其上电。

第二步，将编辑好的程序通过网线下载到1号 LOGO! 主机（如果下载时勾选 复制到SD卡 [image];选项，可以忽略第三步，尤其是不带显示屏的LOGO!）。

第三步，将1号LOGO!切换到停止状态，手动将micro SD卡里的程序复制到LOGO!:如下图所示，进入到LOGO!菜单，点击LOGO!-->卡。

图1 保存程序->卡

第三步，将1号LOGO!断电，拔出micro SD卡。

第四步，将准备好的另一个2号LOGO!断电，插入已经做好种子程序的micro SD卡，（0BA8 会自动将存储卡里的程序复制到logo！，如果原LOGO!里有程序也会被存储卡的程序覆盖）将其切换到停止状态，手动将程序复制到LOGO!。

图2 载入程序<-卡

第五步，将2LOGO!断电，拨出存储卡，重新上电，即可查看2号LOGO!里是否有程序。

2.副本保护

副本保护能能够将电路程序与某个特定的存储卡绑定在一起。当LOGO!上电执行电路程序，将存储卡的程序复制到LOGO!，但是当移除存储卡时，将LOGO!里的程序清除，所以必须确保存储卡一直插在LOGO主机模块上。如果设置密码＋带“副本保护”的存储卡，可以做到完全的程序保护。

0BA8使用micro SD的存储卡，如果将受保护的电路程序复制到其他存储卡上，当插入该存储卡时 LOGO! 将无法识别程序并拒绝加载程序。

启用副本保护：您可以随时将保护功能禁用更改为保护功能启用

第一步，LOGO!断电将空的存储卡插入卡槽，并上电。

第二步，将LOGO!切换到STOP，进入编程模式，进入副本保护，并选择已保护。

图3 副本保护

图4 已保护

第三步，下载程序（如果LOGO!里已经有程序可以不用下载），并进入LOGO!菜单：卡--保存程序-->卡,见图1。

第四步，LOGO!断电，重新上电，此时点开副本保护应该提示“错误：程序被SD卡保护”，说明副本保护已经设置成功。

第五步，LOGO!断电，将存储卡移除，确认LOGO!内没有程序。

副本保护设置成功后，无法在编程模式编辑程序，设置参数，修改程序密码也无法修改程序名称，会提示“错误：程序被SD卡保护”。

取消副本保护：只有当卡里没有电路程序时才能成功将保护功能由启用更改为禁用。

第一步，LOGO!切换到STOP模式，通过LOGO!操作面板清除LOGO!的程序。

第二步，将LOGO!的空程序复制到存储卡，如图1所示，进入到LOGO!菜单，点击LOGO!-->卡。

第三步，将副本保护改为未保护。

第四步，LOGO!断电重新上电可以发现在编辑模式可以修改程序以及程序名称等，且此时LOGO!里是空白程序。

第五步，LOGO!断电，拔掉存储卡即可。

3.程序下载功能（新增仅0BA7/8支持）

通过LOGO!Soft Comfort软件直接将程序存储到micro SD的存储卡内，然后将存储卡放在LOGO！主机模块，将程序传输到LOGO!模块，不通过编程电缆，具体如何实现，请看下文：

第一步，将编辑好的程序 另存为 文件名是LOGO_U_P的二进制转储文件：

图5 另存程序

  • a. 选择特殊的文件类型“二进制转储文件（*.bin）”
  • b. 设置文件名称，必须是LOGO_U_P,否则LOGO!无法识别该文件

如果将文件名称修改后会弹出下图的提示（点击确定后也能保存好文件，但是LOGO!无法识别，还是要修改正确的名称）：

图6 修改bin文件名后报警提示

第二步，将生成好的LOGO_U_P文件复制到空的micro SD卡里。

第三步，将LOGO!断电，把存储卡插入到LOGO!的卡槽内，LOGO!上电，（0BA8 会自动将存储卡里的程序复制到logo！，如果原LOGO!里有程序也会被存储卡的程序覆盖）。

第四步，将LOGO!切换为STOP模式，请手动通过将存储卡里的程序复制到LOGO!:如下图所示，进入到LOGO!菜单，点击LOGO!<--卡（如果LOGO!没有显示屏，将存储卡插入后会自动将卡里的程序复制到LOGO!）。

图7 载入程序<-卡

注意：

    二进制转储文件仅用于将保存到 SD 卡上的 FBD 程序： （*.bin）

    。

    实际上，存储卡第一种功能：普通存储功能下，在存储卡生成的也是LOGO_U_P.bin的文件 。

还有其他问题请查看本章节的 下载/上传常见问题 页面。


程序和数据保持

断电保持

LOGO! 的相关数据断电保持问题，包含三个内容：程序保持，数据断电保持，实时时钟备份。

LOGO! 包含的存储器区域有两个：程序存储区和可保持存储区

  • 程序存储区：
    LOGO! 电路程序中允许添加的功能块有数量限制。
    LOGO! 电路程序容量有最大字节数限制。 累加相关功能块的字节数便可以计算出总字节数
  • 可保持存储区（Rem)）：
    用于存放断电可保持的数据，电源故障后， LOGO！的当前数据仍可保留，并且功能块在电源恢复后从中断点开始继续运行。只有当实际设置了掉电保持功能时，带掉电保持属性的功能块才会使用该区域。

表1.LOGO! 程序存储区及保持性存储区容量

设备系列 | 电路程序/字节 | 功能块数量/个 | 保持性/字节
LOGO!0BA8 | 8500 | 400 | 250
LOGO!0BA7 | 8400 | 400 | 250
LOGO!0BA6 | 3800 | 200 | 250

如何查看保持性存储区使用情况 :

1、LOGO!显示屏操作，选中停止，按下OK键，向左移动光标选中是，按下确认键，LOGO!切换至停止模式。

图1.切换至停止模式

2、进入编程菜单，移动光标至内存占用，点击OK键，查看内存占用情况。

图2.查看内存占用情况

程序保持

程序通过软件下载至 LOGO! 或者从 LOGO! 集成的显示屏编辑指令，程序均存储在程序存储区，此区域为非易失性存储区 (EEPROM) 。所以，断电从新上电， LOGO! 设备中的程序不会丢失，除非将程序清除。

有一种情况需要考虑：LOGO! 控制器上插有程序卡 / SD 卡，并且启用程序副本保护。
该安全功能能够将电路程序与某个特定的存储卡绑定在一起。则只有在存储卡插在LOGO!上时，LOGO!才能执行程序；存储卡拔走后，程序消失。如果将受保护的电路程序复制到其他存储卡上，当插入该存储卡时LOGO! 将无法识别程序并拒绝加载程序。

关于 LOGO! 存储卡功能介绍，请参考文档介绍：存储卡

数据保持

可断电保持的数据：LOGO! 中某些 SF 功能块，可以通过参数设置，实现断电数据保持；其中，运行小时计数器、周计数器 、年计数器和 PI 控制器始终为掉电保持，必须被激活并且无法更改（处于灰显状态）。

断电数据保持时间：一旦设置为断电保持，即永久保存。

如何设置是否为断电保持：软件设置或者 LOGO! 显示屏编辑设置。

方法一：软件中设置是否为断电保持

1、运行小时计数器、周计数器 、年计数器和 PI 控制器始终为掉电保持 。无法修改设置，参数 MI、MN 和OT 总为掉电保持。

图3. 运行小时计数器断电保持设置

2、 某些功能块需要参数设置，决定数据是否断电保持。下图为加/减计数器指令设置断电保持参数。下载后显示屏上显示初始界面。

图4.加/减计数器断电保持设置及运行显示

以加减计数器为例说明：

加减计数器设置勾选“激活参数保持”，下面两张图从前至后分别为：执行加计数后断电前，断电从新上电后。观察结果，当前值数据数据可以保持。

图5.设置为断电保持断电前后比较

没有设置断电保持，断电前及断电后对比如下图所示，当前值数据无法保持。

图6.未设置断电保持断电前后

方法二：LOGO!显示屏编辑程序，设置断电保持参数。

设置掉电保持， 有两种选择：
R: 数据为掉电保持。
/： 当前数据非掉电保持（默认设置）。

以加/减计数器为例，LOGO! 在停机的模式下，从显示屏进行编程，设置断电保持参数。

图7.LOGO!显示屏编辑加减计数器

图8.LOGO!显示屏设置断电保持参数

SF功能占用程序存储区及保持性存储区的容量概览

SF 功能分为四部分：定时器、计数器、模拟量、其他,下面分别介绍每种 SF 功能占用程序存储及保持性存储的字节数
表4.定时器功能

功能 | LOGO!0BA8 |  | LOGO!0BA7 |  | LOGO!0BA6
 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储
接通延迟 | 12 | 3 | 12 | 3 | 8 | 3
断开延迟 | 16 | 3 | 16 | 3 | 12 | 3
接通/断开延迟 | 16 | 3 | 16 | 3 | 12 | 3
有保持的接通延迟 | 16 | 3 | 16 | 3 | 12 | 3
脉宽触发继电器（脉冲输出） | 12 | 3 | 12 | 3 | 8 | 3
边缘触发的脉冲继电器 | 20 | 4 | 20 | 4 | 16 | 4
异步脉冲发生器 | 16 | 3 | 16 | 3 | 12 | 3
随机发生器 | 16 | - | 16 | - | 12 | -
楼梯照明开关 | 16 | 3 | 16 | 3 | 12 | 3
多功能开关 | 20 | 3 | 20 | 3 | 16 | 3
周定时器 | 24 | - | 22 | - | 20 | -
年定时器 | 12 | - | 12 | - | 12 | -
天文时钟 | 40 | - | 20 | - | 无此指令 | 无此指令
秒表 | 28 | 19 | 28 | 17 | 无此指令 | 无此指令

表5.计数器功能

 | LOGO!8 |  | LOGO!7 |  | LOGO!6
功能 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储
增/减计数器 | 32 | 5 | 32 | 5 | 28 | 5
运行小时计数器 | 36 | 13 | 36 | 9 | 28 | 9
阈值触发器 | 20 | - | 16 | - | 16 | -

表6.模拟量功能

 | LOGO!8 |  | LOGO!7 |  | LOGO!6
功能 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储
模拟量阈值触发器 | 20 | - | 20 | - | 16 | -
模拟量差值触发器 | 20 | - | 20 | - | 16 | -
模拟量比较器 | 24 | - | 24 | - | 24 | -
模拟量监控 | 24 | - | 24 | - | 20 | -
模拟量放大器 | 12 | - | 12 | - | 12 | -
脉宽调制器 (PWM) | 32 | - | 30 | - | 24 | -
算术指令 | 24 | - | 24 | - | 20 | -
算术指令错误检测 | 16 | 1 | 16 | 1 | 12 | 1
模拟量多路复用器 | 20 | - | 20 | - | 20 | -
模拟量斜坡函数发生器 | 40 | - | 40 | - | 36 | -
PI 控制器 | 44 | 2 | 44 | 2 | 40 | 2
模拟量滤波器 | 20 | - | 20 | - | 无此指令 | 无此指令
最大值/最小值 | 20 | 7 | 20 | 6 | 无此指令 | 无此指令
平均值 | 32 | 20 | 32 | 16 | 无此指令 | 无此指令

表7.其他

 | LOGO!8 |  | LOGO!7 |  | LOGO!6
功能 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储 | 程序存储 | 保持性存储
锁存继电器 | 12 | 1 | 12 | 1 | 8 | 1
脉冲继电器 | 12 | 1 | 12 | 1 | 12 | 1
消息文本 | 12 | - | 12 | - | 8 | -
软键 | 12 | 2 | 12 | 2 | 8 | 2
移位寄存器 | 16 | 1 | 16 | 1 | 12 | 1


timer

LOGO 0BA8 断电保持

LOGO程序中可以许多SF 功能块的开关状态、计数器值和时间值设为掉电保持。也就是说，电源故障后 LOGO！
的当前数据仍可保留，并且功能块在电源恢复后从中断点开始继续运行。定时器没有被复
位，继续运行直至设置的时间。

设定方法有两种，任选其一

如下：一.通过软件编程实现

1.双击B001加减计数器功能块(图.1)

2.勾选激活参数保持，点击确定

图.1

勾选激活参数保持，则断电重启后，B001加减计数器的当前值仍然为断电前的值。

二.通过面板编程实现(图.2)

图.2

R:数据为掉电保持。
/：当前数据非掉电保持（默认设置）。

注意：

  1. 运行小时计数器、周计数器 、年计数器和比例积分控制器始终为掉电保持。
  2. 由LOGO定时器由I点输入为条件时，则不能保持当前时间值和输出状态。(图.3)

图.3

LOGO 0BA8 参数保护

LOGO 0BA8可以设置参数保护功能，您可以定义是否在 LOGO! 运行中显示和编辑参数。

设置方法有两种，任选其一

一.通过软件编程实现

1.双击B001加减计数器功能块(图.4)

2.勾选激活参数保护，点击确定

图.4

勾选激活参数保护，则在运行过程中，无法修改设定参数，例如：加减计数器的打开，关闭值。

二.通过面板编程实现

图.5

有两种选择：
+：在参数赋值模式中，允许读写参数（默认设置）
-： 在参数赋值模式中，不允许读写参数，而只能在编程模式下编辑。(图.5)

注意

参数保护功能仅适用于"参数设置"窗口。(图.6)
如果您将受保护的特殊功能的变数插到一个消息文本中，那么您是可以在此消息文本中对
这些变数进行编辑的。 因此为了保护这些变数，您也需激活此消息文本的保护功能。

1.程序内插入加减计数器 B001，和文本显示器B002

2.双击文本显示器功能块，打开文本显示器配置窗口

3.将加减计数器的接通阈值拖入到消息组态文本中

图.6

a:点击B001功能块

b.点击接通阈值

c.将其插入到消息文本内

d.激活参数保护功能

LOGO运行后画面(图.7)

图.7

勾选激活参数保护功能后，logo运行时，长按ESC键修改参数，则出现以下提示(图.8)

图.8


密码保护

LOGO!的密码与程序保护

LOGO!可以为LOGO!程序加上密码，以保护用户的知识产权。LOGO!还提供了程序存储卡，能够更加可靠地保护程序。

密码不会影响修改在编程时设置为“允许在线编辑”的参数。

无论程序是否有密码保护，您均可随时从 LOGO!Soft Comfort 中打开或编辑电路程序。 对于有密码保护的电路程序，您必须在 LOGO! 中输入密码才能查看或更改程序，或者将电路程序从 LOGO! 装载到计算机中。

注意：密码不能破解，用户不必为此咨询西门子技术支持部门。

密码设置

为LOGO!设置密码有两种方法：

  • 1. 直接在LOGO!上操作，进入Password功能项进行设置。
  • 2. 用LOGO!Soft-Comfort软件编程时，进入命令菜单File（文件） > Properties（属性） > Program Password（程序密码）设置密码（ 密码A-Z，最少1个，最多 10 个字符），然后将程序通过LOGO! 编程电缆下载到LOGO!中，密码也一并下载到LOGO!中了。

这两种方法设置的密码功能效果一样，设置完密码后请将LOGO!重新上电，确保密码启用。

LOGO! 密码清除

您可以从 LOGO! 基本型、LOGO!Soft Comfort 或 LOGO! TDE（0BA8） 来设置、更改或取消程序密码。

LOGO!中的密码若忘掉了，不能破解，此时也无法上载程序。只能通过清除程序将密码一起清除。

注意：如果用户没有程序备份，不要执行此操作，否则会造成程序的丢失，如果用户要清除LOGO! 中全部程序，对其重新编程或有程序备份则可执行此操作。

清除密码方法：

1：通过LOGO!上的操作键清除（适合0BA5以及0BA6的早期版本）。

第一步，在LOGO!停止状态，直接在LOGO!上进入Program（程序）> ClearPrg（清除程序）操作。

第二步，当清除程序时,如果有正确密码，输入即可清除，但是如果没有正确密码，分以下几种情况：

0BA6早期版本以及0BA5等之前系列，会要求输入密码，此时只需输入任意字符即可。这样要反复执行3次（（0BA4/5是4次）清除程序的操作并输入任意密码，则程序及密码可全部从LOGO!中清除。

0BA6后期版本以及0BA7，会要求输入密码，但是此时输入错误密码（不论连续输错几次）不可以将程序及密码可全部从LOGO!中清除，想要清除密码，考虑用下文的通过编程软件清除。

0BA8版本，不会提示要求输入密码，直接点击 是 ，则程序及密码可全部从LOGO!中清除。

2： 通过LOGO!Soft-Comfort软件清除（适合0BA6及以后系列）。

第一步，确保能连接LOGO!，

第二步，找到LOGO!Soft-Comfort软件的菜单栏：工具--传输--清除用户程序和密码，

图1 清除用户程序和密码

第三步，设置接口并连接LOGO!。

图1 连接LOGO!

第四步，点击清除。

图3 清除密码

第五步，清除之前需要将LOGO!切换到STOP状态。

图4 LOGO!切换到STOP

第五步，成功清除用户程序。

图5 成功清除密码

0BA6 版本之前的 LOGO! 设备不支持此功能。 如果您在较早版本的设备上尝试此命令，则 LOGO!Soft Comfort 会显示一条消息，表明该设备不支持此功能。

程序密码与LOGO!存储卡保护的关系

有两种保护程序的方法：

  • 编程时为程序设置密码（如上述）
  • 使用程序存储卡并将其设置为“副本保护”状态，具体设置步骤参考：副本保护

这两种方法可以单独，也可以组合使用。它们的关系见《LOGO!设备手册》，手册下载参考资料手册在线下载章节，如下表：

表1. LOGO!程序的密码与存储卡“拷贝保护”之间的关系：

程序 密码 | 存储卡 “副本保护” | 在LOGO!面板上编辑程序 | 拷贝到其他卡 | 在LOGO!上删除程序
－ | － | 可以 | 可以 | 可以
有 | － | 可以，要输入密码 | 可以 | 可以，要输入密码（0BA8 不需要密码）
－ | 有 | 不能 | 不能 | 可以
有 | 有 | 可以，要输入密码 | 可以，要输入密码 | 可以，要输入密码（0BA8不需要密码）

总之：

  • 仅有程序密码保护时，不知道密码的人不能观察、上载、编辑程序，但可以通过LOGO!的操作面板将程序复制到空的存储卡中（密码也同时复制过去），并可以向其他LOGO!中复制
  • 在LOGO!上删除程序，需要密码，连续输入错误的密码也可以同时清除程序与密码（早期版本，0BA6系列如果不能清除，请使用编程软件清除）
  • 存储卡内部如果有程序而同时又设置为“副本保护”时，不能取消“副本保护”的设置，只有清除卡内的程序，才能改变“副本保护”的状态为“No”
  • 要清除卡的内容，可以先清除LOGO!的程序，再使用“card > logo!”菜单命令将空程序写入卡中

对于有操作面板的LOGO!而言，如果设置密码＋带“副本保护”的存储卡，可以做到完全的程序保护。对于无操作面板的LOGO!而言，为程序设置密码就可以做到比较安全。

访问安全

0BA8系列开始，LOGO!提供两个访问级别，管理员和用户，用于在编程模式下限制某些菜单的访问。

在管理员访问级别下，您可访问所有菜单命令；而在用户访问级别下，某些菜单命令是不可见的。

LOGO!的出厂默认设置是管理员，您可以随时切换至用户权限。从用户切换至管理员时，您需要输入有效的密码（默认为“LOGO” 区分大小写）。

LOGO! 始终保存其断电前的访问级别。

LOGO! TDE的默认访问级别是用户，您可以使用密码（默认为“LOGO”）将其切换为管理员。 LOGO! TDE会保存其断电前的访问级别，但前提是其上电后仍连接之前的主机模块。如果连接了不同的主机模块，LOGO! TDE 会在上电后恢复到用户的访问级别。

该访问密码修改步骤：

第一步，在线连接LOGO!，访问控制 设置。

图6 访问控制

第二步，找到“ 通过 LOGO! TD/进行操作”，勾选“启用操作控制密码保护”并更改登录密码 ，一定要注意，设置完毕后点击应用，再点击确定，通过该密码修改用户访问等级，管理员与用户密码在此设置如果忘记密码后重新设置即可，不需要原密码，

图7 访问控制设置密码

第三步，修改密码密码之前需要先将LOGO!停机。

图8 切换到STOP

第四步，密码修改完成后启动LOGO!。

图9 切换到RUN

常问问题

如何辨别LOGO!Soft-Comfort打开的程序有密码？

当软件程序里没有密码时，设置密码界面的旧密码是灰色 ，

图10 程序内无密码

当软件程序里有密码时，设置密码界面的旧密码是不是灰色，如果想要清除或者修改该程序的密码，首先要输入就密码，然后新密码空着（清除密码）或者输入新密码（更改密码）。

图11 程序内有密码

如果要更改密码，必须首先在旧密码文本框中输入现有的密码，并在新密码的两个框中输入新密码，然后点击“确定”确认。

如果要删除已分配的密码，请在旧密码框中输入现有的密码，并将新密码的两个框保留为空。 然后通过“确定”确认。

如果忘记了旧密码，还想要清除程序内的密码，只能考虑将原程序内的电路图复制到空项目。

能否通过LOGO!操作面板修改或者清除密码，而不清除程序？

可以，更改或者删除密码必须知道当前程序的原有密码， 其次LOGO!停止的状态下，在编程菜单中更改。


数据记录

从LOGO!0BA7开始，LOGO!支持数据记录功能，可以记录所配置的过程变量。但是，最多只能配置一个数据记录。下文中以0BA8为例，介绍数据记录。

1.介绍数据记录块：

可以通过 LOGO!Soft Comfort 指令树列表中获得数据记录简档 [image] ，将数据记录拖到电路图编辑器，如下图：

图1 数据记录块

其中，En（启用）处发生上升沿（由 0 跳转到 1）时，数据记录块开始记录数据，也就是说数据记录的频率由En决定。

2.组态数据记录：

图2 组态数据记录

  • a. 支持数据记录的功能块或者参数
  • b. 类似于接通延时定时器，点击后会在b.框内显示具体的参数（类似I.Q参数没有b.的参数）
  • c.选中具体要做记录的数据后点击插入参数，进入d.框
  • d.显示已经选定的记录的参数
  • e.可以移除不需要的数据
  • f.设置完成后点击确定

注意：

1.对于数字量 I/O 和存储区域，您必须以八个位为一组来进行数据记录，例如，I1 至 I8、Q9 至 Q16、M17 至 M24。

2.对于模拟量数据，您可以选择记录一个数值，例如，AI1、AQ2，或者 AM1。

3.在数据记录块中，您最多可以记录 32 条数据（模拟量数值或者八位数字量数值组）。

3.传输数据记录：

配置完数据记录块后，可以将电路程序下载到 LOGO! 0BA7 和 LOGO! 0BA8 设备中，而数据记录就被存储在 LOGO! 设备的内部 EEPROM 中。 您可以将该数据记录以 .CSV 文件格式传输到 PC 上或者 SD 卡中。 您如果要将数据记录从设备的内部 EEPROM 中传送的 PC 上，可使用菜单指令“工具 -> 传输 -> 上传数据记录（仅用于 0BA7 及以上版本）”。

图3 上传数据记录

连接LOGO!打开在线设置---上传数据记录，点击上传，如果LOGO!处于运行状态，会提示切换到STOP，LOGO!必须处于 STOP 模式才能上传数据记录。

图4 上传数据记录切换模式

选择路径，保存上传的数据记录，注意文件类型

图5 保存数据记录

LOGO! 自动创建格式为“XYZ_number.csv”的文件。XYZ代表所连 LOGO!主机模块的四段 IP 地址码的最后一段，number代表所创建数据文件的序号，范围为 1 至 50。以及创建数据记录的时间。LOGO!主机模块无法识别自定义的名称，因此，不要更改文件名。您只能将微型 SD 卡上的最新数据记录文件从 LOGO! 上传到 LOGO!Soft Comfort。

成功上传数据记录

图6 成功上传数据记录

上传完毕，可以将LOGO!切换为RUN。

图7 切换为RUN

4.打开一个上传的数据记录：

将数据记录成功上载到 PC 上后，双击这个 .CSV 文件，该文件会默认以 Microsoft Excel 格式打开。 您也可以使用文本编辑器打开文件。

图8 上传数据记录

上图中B-I列实际是I1~I8，因为作为DI点，需要八个位为一组来进行数据记录，所以能看到该数据记录里I5一直是1。

常见问题

1.为什么创建一个数据记录后，指令树的数据记录的指令块变为灰色？

因为最多只能配置一个数据记录，所以配置完一个后，指令块变为灰色，不允许再添加。

2.LOGO!数据记录存储在什么位置，存储空间有多大？

LOGO! 0BA8 提供了 1024 个字节的缓存空间用于数据记录。 如果缓存中的数据达到了 512 个字节，则 LOGO! 就会自动将数据写入到插在卡槽中的微型 SD 卡中。

2.如果配置一个较大的存储卡，能否增加数据记录的存储空间？

一个微型 SD 卡可为每个 LOGO! 主机模块存储 50 个数据记录文件。 如您将同一个卡插入到另一个 LOGO! 主机模块中，则其能为当前 LOGO! 主机模块存储另 50 个数据记录文件，但一个卡能存储的最大行数受限于其存储器大小。 微型 SD 卡上的一个数据记录文件最多可存储 20000 行记录。 如微型 SD 卡的内存已满，而您想创建一个新的数据文件，则会自动生成一个错误消息。

3.什么情况下会创建新的数据记录文件？

LOGO! 会在下列环境下创建新的数据记录文件：

  • 1. LOGO! 中的电路程序被更改
  • 2. 数据记录文件的行数超过 20000 时所创建文件的名称会带一个递增数字下标

例如，如当前数据文件是“135_1.csv”，则新创建的文件被命名为“135_2.csv”。

4.LOGO!数据记录会出现数据丢失的现象？

可能出现数据丢失有以下几种情况：

1.如果 LOGO! 0BA8 中的数据生成速度超过了向 SD 卡的写入速度，那么就有可能发生数据丢失。 为避免出现数据丢失情况，以不低于 500 ms 的时间间隔施加使能信号到数据记录功能块。

1.如卡槽中未插微型 SD 卡，则 LOGO! 0BA8 的缓存区仅能存储 512 字节的数据记录，其余则会丢失。


timer

LOGO 0BA8菜单访问保护

LOGO!提供两个访问级别，管理员和用户

用在编程模式下限制某些菜单的访问。

在管理员访问级别下，您可访问所有菜单命令；而在用户访问级别下，某些菜单命令是不可见的。L
OGO!的出厂默认设置是，您可以随时切换至用户权限。从用户切换至管理员时，您需要输入有
效的密码（默认为"LOGO"）。LOGO! 始终保存其断电前的访问级别。

将 LOGO! 从管理员切换至用户

1.在编程模式的主菜单中移动光标至"①"：按下 或 上。

2. 确认"①"：按下 OK .键
3. 移动光标到"②"：按下 或上 。

4. 确认"②"：按下 OK . 键
LOGO! 即切换至用户访问级别并返回至主菜单

LOGO! 从用户切换至管理员

按照以下步骤将 LOGO! 的访问级别从用户切换为管理员：
1. 在编程模式的主菜单中移动光标至"①"：按下或上 。

2. 确认"①"：按下 OK . 键
3. 移动光标到"②"：按下或上 。

4. 确认"②"：按下 OK 键。显示如下：

5. 按下 或 移动字母表以选择字母（"LOGO"）。

6. 确认密码：按下 OK . 键
LOGO! 即切换至管理员访问级别并返回至主菜单。

如何修改管理员密码

在项目工具栏中点击电路图右键-属性-打开LOGO设置(图.1)

图.1

点击在线设置，选择连接方式，选择相对应的网卡点击刷新按钮找到CPU，然后测试连接，出现√后点击确定。(图.2)

图.2

在线设置内选择访问控制设置，

下拉找到通过LOGO!TD进行操作

勾选启动操作控制密码保护，输入新密码，设置改变管理员密码。（默认密码为大写：LOGO）(图.3)

图.3

注意：

LOGO! TDE的默认访问级别是用户，您可以使用密码（默认为"LOGO"）将其切换为管理员。

LOGO! TDE会保存其断电前的访问级别，但前提是其上电后仍连接之前的主机模块。如果连接了不同
的主机模块，LOGO! TDE 会在上电后恢复到用户的访问级别


LOGO!编程电缆

0BA6 及以下LOGO!主机模块通过编程电缆与LOGO!Soft Comfort软件连接，实现下载/上载程序、调试等。

目前，LOGO!编程电缆有两种：

  • 1. PC电缆（6ED1057-1AA00-0BA0） 计算机侧是RS-232接口。

  • 2. PC USB 电缆（6ED1057-1AA01-0BA0） 计算机侧是USB接口。（需要安装驱动，映射出COM口）

    • 1. PC电缆

    将计算机上的串行通信口（RS-232）与LOGO!上的编程口连接起来，才能下载/上载程序、调试等不需要单独安装电缆驱动，安装软件后直接可以使用。

    图1 LOGO!RS232 编程电缆

    图2. 电缆插在LOGO!编程口上

    2. PC USB 电缆

    将计算机上的USB通信口与LOGO!上的编程口连接起来，实现下载/上载程序、调试等，需要单独安装驱动。

    图3 LOGO!USB 编程电缆

    LOGO!USB 编程电缆,需要单独安装驱动才能正常使用，驱动的软件在LOGO!Soft Comfort V8.0（看图 驱动存放路径）或8.1里自带（安装时会询问是否需要安装USB电缆驱动）

    图4 LOGO!Soft Comfort V8.0里USB编程电缆驱动

    或者自行去官网上下载http://w3.siemens.com/mcms/programmable-logic-controller/en/logic-module-logo/demo-software/pages/default.aspx#Updates。

    图5 USB编程电缆驱动下载链接

    USB驱动安装成功后会自动映射出一个com 口，通讯过程中，选择映射的com即可。

    图6 安装成功的USB编程电缆驱动

    常问问题

    是否可以自己制作LOGO!编程电缆？

    我们建议用户购买西门子的电缆。

    西门子不提供电缆芯线编号等资料。用户自己制作，风险自担。

    为什么通过设备管理器发现电缆驱动上有黄色叹号？

    可能是驱动未安装成功，注意安装驱动时需要卸载或关闭杀毒软件，如果未安装成功，可以考虑更新或将之前的驱动卸载后重新安装。


LOGO! 0BA6 系列下载/上传程序

LOGO! 0BA6 及以下LOGO!，要通过PC机与LOGO!相连接，上载/下载程序，必须安装编程软件，而且要有专用编程电缆,了解编程电缆的更多信息可以参考编程电缆的介绍。

LOGO!Soft Comfort 软件目前最新版是V8.1.1，该软件可以向下兼容，可以打开之前老版本编辑的项目，也可以给LOGO! 0BA6 及以下LOGO!下载程序，为了避免下载时因为不同版本 需要软件升级，建议使用最新版软件下载，有关软件的升级可以参考：如何将LOGO!Soft Comfort 软件版本升级(更新)到最新版本.

在 LOGO!Soft Comfort V8 中可以为之前版本的 LOGO!设备创建控制程序。但是不能将含有新的特殊功能块或者新的特殊功能参数的程序下载到 0BA8之前的 LOGO! 基本模块系列中哪些系列的LOGO! 可以使用LOGO!Soft Comfort V8创建的程序？。

LOGO!Soft Comfort V7.0 给 LOGO! 0BA6下载程序

准备工作：

首先，如果使用USB的LOGO!编程电缆（6ED1057-1AA01-0BA0 ）下载，确保电缆驱动安装正常，具体可以参考编程电缆的介绍。

其次，将电缆的方形口插入到LOGO!模块右上角的方形口（通常有突起的盖板，请拨出），另外一端连接至电脑。

图1 电缆连接LOGO!编程口

下载程序具体步骤：

1. 首先在LOGO!Soft-Comfort软件的菜单栏：工具---选择硬件，确认所连接的LOGO! 硬件型号以及版本一致。

图2 选择硬件

2.在LOGO!Soft-Comfort软件的菜单栏：工具---选项---通信接口，选择所使用的串口。

图3 设置通信接口

如果不知道连接的是哪个串口，可以点击 自动检测 按钮，自动查找使用的端口。或者打开电脑设备管理器---端口（COM和LPT）可以看到电缆的驱动以及映射的COM口，如下图所示：

图4 核对端口映射

操作时要连接电缆，并且使LOGO!模块上电（如果无法正常连接，请手动将LOGO!硬件切换到STOP模式），否则会报下图错误：

图5 端口连接报错

3.通讯接口设置正确，且程序编辑没问题后，用户可以点击LOGO!Soft Comfort 软件的下载快捷按钮“ [image] ”，或者在菜单栏： 工具---传输---PC-->LOGO!:

图6 下载菜单

4.连接成功后,将LOGO! 切换到STOP模式,如果LOGO!已经处于STOP,这一步忽略，

图7 切换到STOP模式

5.可以看到下载程序的进度条，直到下载结束，询问是否将LOGO!切换为RUN，见下图：

图8 切换到RUN模式

下载完成后，可以通过LOGO! 自带操作面板查看程序是否已经下载到LOGO! 。

LOGO!Soft Comfort V8.1 给 LOGO! 0BA6下载程序

步骤一：，如图1所示，将电缆插入LOGO!编程口，并确认电缆驱动正常，

步骤二：将编辑好的程序打开，确认所选硬件与实际所连LOGO!一致，

图9 选择硬件

步骤三：程序编辑正确后，用户可以点击LOGO!Soft Comfort 软件的下载快捷按钮“ [image] ”，或者在菜单栏 工具---传输---PC-->LOGO!:

图10 下载菜单

步骤四：设置通信接口,连接方式选择“LOGO!电缆”，以及对应的com 口，测试成功，即可连接LOGO! ，最后点击确定,进入下载模式。

如果无法正常连接，请手动将LOGO!硬件切换到STOP模式

图11 测试接口

步骤五：连接成功后,将LOGO! 切换到STOP模式,如果LOGO!已经处于STOP,这一步忽略，

图12 切换到STOP模式

可以看到下载程序的进度条，直到下载结束。

下载完成后，可以通过LOGO! 自带操作面板查看程序是否已经下载到LOGO! 。

LOGO!Soft Comfort V7.0 给 LOGO! 0BA6上传程序

参考上文中“LOGO!Soft Comfort V7.0 给 LOGO! 0BA6下载程序”的准备工作以及步骤1,2，

3.通讯接口设置正确，且程序编辑没问题后，用户可以点击LOGO!Soft Comfort 软件的下载快捷按钮“ [image] ”，或者在菜单栏： 工具---传输---PC-->LOGO!:

图13 下载菜单

4.连接成功后,将LOGO! 切换到STOP模式,如果LOGO!已经处于STOP,这一步忽略，

图14 切换到STOP模式

5.可以看到上传程序的进度条，直到上传结束，

LOGO!Soft Comfort V8.1 给 LOGO! 0BA6上传程序

同上文描述，正常连接LOGO!后，

用户可以点击LOGO!Soft Comfort 软件的上传快捷按钮“ [image] ”，或者在菜单栏 工具---传输---LOGO!-->PC:

图15 下载菜单

2.设置通信接口,连接方式选择“LOGO!电缆”，以及对应的com 口，测试成功，即可连接LOGO! ，最后点击确定,进入上传模式。

如果无法正常连接，请手动将LOGO!硬件切换到STOP模式

图16 设置接口

3.连接成功后,将LOGO! 切换到STOP模式,如果LOGO!已经处于STOP,这一步忽略，

图17 切换到STOP模式

4.可以看到下载程序的进度条，直到上传结束。

至此，上传完成，可以通过LOGO! 自带操作面板查看程序是否已经下载到LOGO! 。

还有其他问题请查看本章节的 下载/上传常见问题 页面。


Soft Comfort V7.0向LOGO!0BA6下载提示更新

为什么LOGO!0BA6不能通过LOGO!Soft Comfort V7.0下载程序

近期当使用LOGO!Soft Comfort V7.0给LOGO!0BA6或者LOGO!0BA7下载程序时可能出现如图1.所示的报错信息，并且导致下载不能完成。

图1. LOGO!Soft Comfort V7.0 下载失败的报错信息

问题产生的原因

由于LOGO！基本模块发布了新的Firmware：0BA6为V1.07.07，0BA7为V01.03.35，详细信息见图2.所示，这些新版本的LOGO！基本模块要求LOGO!Soft Comfort的版本为V7.1.5及以上。

需要注意的是即使是0BA6的LOGO！基本模块，如果Firmware是V1.07.07，也必须使用V7.1.5及以上版本的LOGO!Soft Comfort来下载程序。

这些新版本的LOGO！基本模块可以通过模块上的E-Stand标识来识别，具体E-Stand版本和相应版本所作的更新请参考图2.

图2. 新版本LOGO!基本模块发布信息

如何识别LOGO!基本模块的E-Stand版本

在LOGO!基本模块的下侧有一个“+”，在“+”的左上角写有一个“X”，其他三角有连续的数字，见图3.所示，“X”的值是比这三个连续数字中最小的数字小1，这个“X”表示LOGO！基本模块的E-Stand版本。

图3.所示的LOGO!24RCo基本模块的E-Stand版本是：E-Stand10，这就是一个Firmware为V1.07.07新版本的LOGO!基本模块。这个LOGO!基本模块要求LOGO!Soft Comfort的版本为V7.1.5及以上才能对其下载程序。

图3. LOGO!基本模块的E-Stand版本

如何查看LOGO!Soft Comfort的版本

1、打开LOGO!Soft Comfort软件，在其菜单栏的“帮助”菜单下选择“关于(A)”，见图4.所示。

图4.查看LOGO!Soft Comfort软件版本

2、在其弹出的“关于LOGO!Soft Comfort”窗口内查看LOGO!Soft Comfort的版本，如图5中红框所示。

图5.中所示的LOGO!Soft Comfort版本为V7.0.30，低于V7.1.5。即图5.所示版本的软件不能给图3.所示的LOGO!基本模块下载程序，要想下载则必须把软件版本升级到V7.1.5及以上。

软件在线更新请参考：如何将LOGO!Soft Comfort 软件版本升级(更新)到最新版本

图5.查看LOGO!Soft Comfort版本


LOGO!0BA7/0BA8系列下载上传程序

LOGO! 0BA8 系列下载程序

LOGO! 0BA8 本体只集成一个传输速率为 10/100 Mbit/s 的以太网口，通过这个通信口可以实现LOGO!与编程设备的通信。

首先，通过表1确认不同系列的LOGO!编程下载时所需的软件版本。

LOGO! | 所需软件
LOGO! 0BA7 stand | LOGO!Soft Comfort v7.15及以上
LOGO! 0BA7 ES4 | LOGO!Soft Comfort v7.15及以上
LOGO! 0BA8 stand | LOGO!Soft Comfort v8.0及以上
LOGO! 0BA8 FS:04 | LOGO!Soft Comfort v8.1.0及以上
LOGO! 0BA8 FS:05 | LOGO!Soft Comfort v8.1.1及以上
表1 不同系列的LOGO!编程下载时对应的软件

其次，确认LOGO!硬件的IP地址，其默认IP见下表。

产品 | 默认IP | 子网掩码
LOGO! 0BA7 stand | 192.168.0.1 | 255.255.255.0
LOGO! 0BA8 stand | 192.168.0.1 | 255.255.255.0
LOGO! 0BA8 FS04 | 192.168.0.3 | 255.255.255.0
LOGO! TDE | 192.168.0.2 | 255.255.255.0
表2 不同系列的LOGO!的默认IP

LOGO! 0BA7下载步骤与0BA8步骤一样，以下以0BA8为例。

通过LOGO!Soft Comfort v8.1软件为基本型 LOGO! 0BA8 下载程序

完成项目编辑后，用户可以使用交叉网线直接连接LOGO! 0BA8和电脑网卡，或者使用直连网线将LOGO! 0BA8的通信口、电脑网卡的网口连接到交换机上，构成一个简单的局域网。

下表中为示例IP ，请确保电脑 为固定IP且与LOGO!IP在同一网段：

LOGO! IP | 电脑IP
IP : 192.168.0.3 | IP：192.168.0.23
子网掩码：255.255.255.0 | 子网掩码：255.255.255.0
表3 示例中使用的IP地址

1.用户可以点击LOGO!Soft Comfort 软件的下载快捷按钮“ [image] ”，或者在菜单栏 工具---传输---PC-->LOGO!。

图1 下载菜单

2.设置通信接口,连接LOGO! 。

图2 通信接口

  • a. 选择以太网以及对应的网卡驱动名称
  • b. 点击刷新图标
  • c. 刷新所连接的LOGO! ，如果连接多个LOGO!，可以都显示出
  • d. 点击步骤c.的想要连接的LOGO! IP,该IP自动成为目标IP
  • e. 点击”测试 按钮,测试成功
  • f. 点击确定,进入下载模式

3.连接成功后,将LOGO! 切换到STOP模式,如果LOGO!已经处于STOP,这一步忽略。

图3 切换到STOP模式

4.可以看到下载程序的进度条，下载结束后 将LOGO! 由STOP模式切换到RUN。

图4 切换到RUN模式

至此，下载完成，可以通过LOGO! 自带操作面板查看程序是否已经下载到LOGO! 。

LOGO! 0BA8 系列上传程序

请先确保电脑IP地址是固定IP且与LOGO!IP在同一网段， 如上文中表3所示。

1.用户可以点击LOGO!Soft Comfort 软件的上传快捷按钮“ [image] ”，或者在菜单栏 工具---传输---LOGO!-->PC。

图5 下载菜单

2.设置通信接口,连接LOGO! 。

图6 通信接口

  • a. 选择以太网以及对应的网卡驱动名称
  • b. 点击刷新图标
  • c. 刷新所连接的LOGO! ，如果连接多个LOGO!，可以都显示出
  • d. 点击步骤c.的想要连接的LOGO! IP,该IP自动成为目标IP
  • e. 点击”测试 按钮,测试成功
  • f. 下载时勾选复制到SD卡，可以将程序下载到LGO!同时将程序复制到LOGO!上的存储卡（前提是LOGO!上已经有存储卡）
  • g. 点击确定,进入上传模式

该法尤其适用于不带显示屏的LOGO!使用存储卡

3.连接成功后,将LOGO! 切换到STOP模式,如果LOGO!已经处于STOP,这一步忽略。

图7 切换到STOP模式

4.可以看到上传程序的进度条，上传结束后 将LOGO! 由STOP模式切换到RUN。

至此，上传程序完成 。

还有其他问题请查看本章节的 下载/上传常见问题 页面。


下载/上传常见问题

常问问题

1.为什么新买的LOGO! 0BA8 产品下载时测试正常，但是下载界面一闪而过，查看LOGO!内并没有程序？

可能原因：新买的产品是0BA8 FS04，但是使用的编程软件是 LOGO!Soft Comfort V8.0 。

解决方法：至少要将LOGO!Soft Comfort软件升级到V8.1.0，并且将程序内硬件类型改为0BA8 FS:04（如果硬件是0BA8 FS:05，需要将LOGO!Soft Comfort软件升级到V8.1.1）后下载。

图1 修改硬件类型

2.如何确定LOGO! 0BA8产品是Stand 还是FS04版本？

法一：在 LOGO! 8 基本模块上订货号（MLFB）的旁边。在这里，三个数字之一由一个“X”标记。该标记数字对应生产状态。例如:“X56”——> FS:04，如果X标记小于4的（例如“X34”，X为2），均是stand版本

图2 LOGO!正面

法二：在 LOGO! 8 基本模块左侧二维码下方有FS:04

图3 LOGO!侧面

法三：通过LOGO!Soft Comfort在线查看模块固件版本。

图4 查看固件版本

电脑与LOGO!正常连接后，可以看到模块的固件版本,

图5 显示固件版本

3.下载程序时提示下载失败，如何查看具体失败的原因？

在下载的过程中可能会遇到提示下载失败，见下图：

图6 提示下载失败

可以通过软件右下角的信息窗口快捷键： 或者点击电脑键盘 F2 ，打开信息窗口：

图7 报错信息

可以看到是B001 未连接至输出的块

图8 报错原因

可以完善电路图或者此处如果不需要有输出，可以使用开路连接器X即可。

图9 修改后程序

4.为什么下载程序时提示输入密码，但是实际程序内并没有设置密码或者输入正确密码还是报错“HTTP授权失败.密码错误”？

故障现象：下载程序时提示输入密码，

图10 提示输入密码

不输密码或者输入之前设置的密码，提示“HTTP授权失败。密码错误”。

图11 HTTP授权失败.密码错误

点击确认后，下载中断。

造成这种现象的可能原因：

图12 设置错误的网络接口

1.设置错误的网络接口卡，图12中设置了虚拟机的网络接口驱动，

2.可能使用无效的IP地址，请确保PC机以及LOGO!所使用的静态IP和子网掩码，属于有效IP，如果不确定，请使用常见的IP：192.168.0.10（20），子网掩码：255.255.255.0

如果以上上方法无法解决，请将LOGO!Soft Comfort 软件升级至V8.1.1测试。

5.能否在电脑端使用自动获取IP的方式下载程序？

可以，在下载的过程中会提示添加本地IP，点击 是 ，

图13 添加本地IP

提示添加成功后，点击 确定 下载即可。

当电脑固定IP与实际LOGO!的IP不在同一网段时，也需要图8的步骤在本地添加IP，添加成功后也可以下载，

但是，当所有步骤都正确还是无法测试成功，请使用固定IP并在同一网段的的方式连接

6.如何修改LOGO!主机的IP地址？

法一（只适用于带显示屏的LOGO!）：将LOGO!切换为STOP后，通过以下步骤在LOGO!硬件上修改：

图14 LOGO!0BA8 网络菜单

  • a.设置想要的IP地址

  • b.确认该参数为主站模式

    • 法二（适用于带/不带显示屏的LOGO!）：首先确保能正常连接LOGO!，然后使用LOGO!Soft Comfort 在菜单栏 工具--以太网连接---模块地址 设置IP，具体步骤如下：

    图15 设置IP

    IP设置好以后将该程序下载至LOGO! ，会弹出以下对话框

    图16 覆盖LOGO! IP

    点击确认后 IP修改成功。

    7.为何新LOGO!菜单中没有“PC > LOGO!”和“LOGO! > PC”选项？

    新LOGO!（0BA4版）菜单中不再有上述选项。一般只要正确连接电缆，就可以正常通信。

    8.0BA6系列没有显示面板的LOGO!模块，怎样实现上传，下载？

    0BA6系列：没有操作面板的LOGO!模块，需要先插编程电缆，然后再上电，则自动处于与PC机的连接状态。

    9.为何LOGO!Soft Comfort（轻松编程软件）的“下载/上载”菜单命令和按钮是灰色的？

    这说明使用的LOGO!Soft Comfort软件是DEMO（演示）版。演示版没有通信能力。请连续西门子技术支持以获得正式版本的软件。

    10.电脑上的串口是从USB、IEEE1394等端口转换而来，通信不通有什么办法？

    西门子没有特殊的解决办法。

    可以尝试更换转换器。

    11.0BA6的LOGO!能否将二进制转储文件直接通过存储卡送到LOGO!模块，而不使用编程电缆？

    不可以，0BA6及以下LOGO!的程序另存为二进制转储文件时会提示“另存为*.bin文件失败”，不支持该功能，而且0BA6及以下LOGO! 使用的存储卡是西门子专用的，计算机无法识别该存储卡，无法将将文件复制到存储卡内，但是0BA7和0BA8系列都支持，因为他们使用的存储卡都是市面上的普通FAT32 的存储卡。

    12.生成好的二进制转储文件能否再用LOGO!Soft Comfort打开？

    无法打开，可以实现知识产权保护，可以直接将生成好的二进制转储文件通过邮件发送给现场客户，有现场客户自行准备对应的SD卡，将程序复制后传送给LOGO!。

    13.为什么生成的文件名称，产品类型都没有问题，将存储卡插入到LOGO!后却显示是空白卡，无法将程序复制到LOGO!，？

    可能项目里配置的LOGO!的硬件与实际硬件不一致，需要修改硬件后重新复制。

    14.如何判断LOGO!模块里有程序？

    通过显示屏，进入LOGO!菜单，点击启动，如果没有程序会提示“空白程序”。

    15.LOGO!能否做固件更新？

    截止到0BA8 FS5 所有LOGO!均不支持固件更新。

    16.LOGO! 0BA8放置以存储卡（不论是否有副本保护），通过操作面板，执行清除程序，能否将其存储卡的程序清除？

    不会清除存储卡里的程序，只会把LOGO!里的程序清除，清除完毕后再执行 保存程序<--卡，卡里的程序会复制到LOGO!。

    如果想要清除存储卡里的程序，先执行清除程序，再执行 载入程序-->卡，空白程序就会复制到存储卡。

    17.存储卡能否带电插拔？

    可以带电插拔，但是不推荐，可能会导致LOGO!意外停机或者存储卡无法识别，建议尽量断电后插拔存储卡。

    18.LOGO!0BA8通过以太网通讯时，两个节点之间的通讯距离最大是多少？

    通过 CAT5e 屏蔽网线直接连接两个 LOGO! Base 模块时的最大网线长度为 100 米，可以通过交换机级联或者使用光纤扩展通讯距离。


无标题文档

LOGO! 0BA7通讯功能

最新的LOGO! 0BA7产品增加了集成的RJ45的以太网通讯口。LOGO! 0BA7支持在传输速率为10/100 Mbit/s 的基于TCP/IP的SIMATIC S7的通讯。一台LOGO! 0BA7设备支持最多8+1个网络连接，如下述：

图1.LOGO! 0BA7网络功能总览

8：借助下列设备实现最多8个基于TCP/IP的SIMATIC S7的通讯连接

  • 其它LOGO! 0BA7设备
  • 具备以太网功能的SIMATIC S7 PLC
  • 最多一个SIMATIC HMI(触摸屏)

1：在LOGO! 主机模块与安装有LOGO! Soft Comfort V7.0 的PC之间进行最多一个S7连接。

在不超过链接资源数的前提下，以下的连接可以同时进行

  • LOGO！从站从站（远程I/O)
  • LOGO！主站
  • SIEMENS HMI
  • SIEMENS 控制器
  • PG/PC 通过OPC

LOGO!0BA7之间的通讯

LOGO!之间的通讯可以分为

主从通讯：

  • 只有主站包含程序。
  • 从站不执行自己的程序，只需要设置为从站模式；设置从站和主站的IP地址。

图2.LOGO!之间的主从通讯

S7-通讯：

  • 通讯双方各自执行程序
  • 通讯为服务器-客户端结构，需要在软件中组态
  • 组态交换的数据

图3.LOGO!之间的S7通讯

图4.

LOGO!0BA7和编程器之间的以太网通讯

首先，为LOGO!0BA7 分配IP地址。将LOGO处于停机模式，然后按照图5-9设置IP地址。

图5.选择网络

图6.IP地址

图7.此处设置192.168.0.15

图8.子网掩码：255.255.255.0

图9.路由器IP地址，如果没有使用：0.0.0.0

接下来是软件的设置，LOGO! 0BA7 的以太网功能必须通过 LOGO! Soft Comfort V7.0版本软件实现。

图10.

在V7.0软件中，“工具”-“选项”选择通讯接口，这里选择以太网，如图11。

图11.

点击“添加”，输入希望访问的LOGO!的IP地址信息，如图12。

图12.

输入完成后，选中该IP地址，然后点击“检测”；如果此时与模块的连接正常，则“状态”栏显示“是”。

图13.

接下来下载程序，在编程界面点击下载图标，如图14。

图14.

在弹出来的对话框输入或选择目标IP，点击下载即可，如图15。

图15.


LOGO! 0BA7之间的主从通讯

LOGO! 0BA7之间的主从通讯，作为从站一方的控制器，将不执行自己的程序，只是作为主站的I/O扩展存在，所有的动作受主站程序的控制；但是注意，从站的程序仍然存在， 一旦恢复控制器为主站，原先的程序仍然可以执行。默认情况下，所有的LOGO!都处于主站模式，可以通过LOGO! Soft Comfort V7.0软件，如图1、2；或者通过LOGO! 0BA7面板，将LOGO! 0BA7处于停机状态，通过面板“ESC” → “网络”→ “设置通讯模式”实现从站的组态，如图3、图4 。

图1

图2

图3

图4

本例中将192.168.0.16设置为192.168.0.15的从站。配制完成后，从站将不执行原先的任何程序。LOGO! Soft Comfort V7.0软件提供了特殊的网络指令，用于主从模式下对从站的控制，如图5。

图5

可以在网络指令中设置从站的 IP地址和地址信息（详细内容请参考帮助），如图6

图6

这样，就可以在主站侧编写对从站控制的程序，如图6，当主站I1导通，从站的Q1接通；从站的I1接通，主站的Q1导通。同时，主站每连接一个从站（程序调用网络指令，并指定了从站IP地址）都会默认占用一个连接资源，如图7所示，以LOGO!0BA7的主站最多连接8个从站，并且可使用的网络指令也是有限的（可见手册），如下：

图7

LOGO! Soft Comfort V7.0 中可用的网络输入/输出功能块
网络数字量输入： NI1 到 NI64
网络模拟量输入： NAI1 到 NAI32
网络数字量输出： NQ1 到 NQ64
网络模拟量输出： NAQ1 到 NAQ16


无标题文档

LOGO! 0BA7之间的S7 通讯

将LOGO! 0BA7处于停机状态，通过面板，“ESC” → “网络”→ “IP地址”设置IP地址，本例中分别为192.168.0.16 和192.168.0.15，如图1。

图1

LOGO! 0BA7的网络通讯功能，必须通过LOGO! Soft Comfort V7.0软件实现。首先通过软件为LOGO! 0BA7模块分配连接，如图2。

图2

设置目标模块的IP地址（此处设置的和面板设置的一致），右击以太网连接出现“添加连接”，如图3。S7连接是基于客户端和服务器的一种通讯方式，本例中192.168.0.16作为服务器；192.168.0.15作为客户端。

图3

在192.168.0.16侧，在生成的“连接1” 中设置为服务器。如图4，“连接1”本地TSAP默认20.00开始（TSAP设定范围请看帮助），并且不可更改；远程TSAP设置和通讯对方的本地一致，本例中20.00；填写对方的IP地址，本例中对方IP 192.168.0.15。

图4

在192.168.0.15侧，在生成的“连接1” 中设置为客户端，如图5。“连接1”本地TSAP默认20.00开始（TSAP设定范围请看帮助），并且不可更改；远程TSAP设置和通讯对方的本地一致，本例中20.00；填写对方的IP地址，本例中对方IP 192.168.0.16。在“数据传输”中可以设定通讯的数据区（详细信息请参考帮助）。本例中，客户端从服务器侧读取VB0~1 两个字节，放到本地的VB0~1中；客户端把本地VB2-3 两个字节传送到服务器侧的VB2~3。

图5

分别下载LOGO!项目，如图6。点击“选择”，添加需要下载的IP地址，如图7，在这里可以使用“检测”去检查此时是否可以检测到该IP地址；然后点击确定，系统会提示需要处于“STOP”模式，如图8；点击“YES”后，开始下载，如图9。

图6

图7

图8

图9

下载完成后，软件会出现图10所示提示，点击“Y”后，软件的信息窗口会有显示，如图11。到这里就完成了所有设置。

图10

图11

测试结果，分别在客户端和服务器侧，打开在线测试功能，如图12，激活操作员监控后，选择数据表；在数据表中输入需要监控的数据，如图13和14。可以看到数据传输正常。

图12.

图13.客户端侧数据表

图14.服务器侧数据表

LOGO! Soft Comfort V7.0软件，提供了“参数映射”的功能，可以把程序中使用到的块的参数和V区建立起映射的关系。在客户端建立简单的程序，打开“工具”→“参数VM映射”，如图15。在这里可以选择程序中使用到的块，并且选择这些块中可以访问的参数，如图16、17（详细说明请点击帮助查询）。本例中，把接通延时定时器的当前时间映射到VW2。

图15

图16

图17

如图18所示，因为客户端接通延时定时器的参数已经和V区建立映射，所以当I1导通后，定时器开始工作，在服务器侧建立的参数表中就可以看到客户端的参数变化，通讯正常。

图18


timer

LOGO ! 0BA8 FS4 以太网通讯概述

LOGO! 0BA8 支持在传输速率为 10/100 Mbit/s 的 TCP/IP 以太网上的 SIMATICS7/Modbus 通讯。

网络电缆要求:

将屏蔽以太网电缆连接至以太网接口。 为了最大限度地减少电磁干扰，请确保使用两端均带有屏蔽 RJ45 连接器的标准 5 类屏蔽双绞线以太网电缆。

LOGO最大的连接资源

LOGO! 0BA8 设备可支持以下网络连接（如图1）：
借助下列设备实现最多 16 个基于 TCP/IP 协议的 S7/Modbus 通讯连接（不包含TDE和PC）：

– 其他 LOGO! 0BA8 设备

– 具备以太网功能的 SIMATIC S7 PLC

– 经过 TCP/IP 兼容设备的 Modbus

– 最多支持一个与 S7 PLC 进行以太网通讯的 SIMATIC HMI

图1.以太网连接资源

① 物理以太网连接

② LOGO! 与 PC 之间通讯（通过基于 TCP/IP 协议的以太网）的逻辑连接

③ SIMATIC 设备之间 S7 和 Modbus 通讯（使用基于 TCP/IP 的 S7 协议）的逻辑连接

LOGO以太网通讯的连接方式

S7/Modbus 通讯有两种连接方式，静态连接和动态连接。在静态连接方式下，服务器会为所连接的客户端保留所需的资源以确保稳定的数据传输。在动态连接方式下，服务器只有在资源空闲的情况下才会响应通讯请求。用户可以根据需要配置静态/动态连接，可配置 n 个静态连接以及 16-n 个动态连接。LOGO! 最多支持八个静态连接。

● 最多一个基于 TCP/IP 以太网连接的 LOGO! TDE。通过 IP 地址选择，LOGO! TDE模块可以连接不同的主机模块，但是一次只能与一个主机模块进行通讯。

● 在 LOGO! 主机模块与安装有 LOGO!Soft Comfort V8.1 的 PC 之间最多有一个TCP/IP 以太网连接。

静态连接

静态链接：指的是建立的指定客户机或服务器连接，具体设置方法如下图（图2）

新建项目客户端和服务器的连接都是指定了固定的连接IP。

以太网连接内双击连接5,输入远程服务器的TSAP号码和IP地址，点击确定，常见静态客户端连接完成。

图.2

动态连接

动态链接：指的是建立的服务器端接收所有的连接请求，设置方法如下图：（图.3）

图.3

a.双击打开新建服务器连接

b.勾选所有的连接请求

c.至少填写一个远程客户端的TSAP号码。指定的TASP号码客户端则占用静态服务器连接，其他再连接此服务器则占用动态连接。

通讯诊断

我们可以通过LOGO的面板来诊断以太网通讯的连接状态，

诊断功能可以查看当前的连接状态，连接模式，远程IP,本地IP,远程TSAP,本地TSAP,数据包传输数量。

具体诊断操作菜单如下：

按下ESC键后，按向下按钮，找到诊断菜单，按右键进入软件，再按右键进入数据连接菜单。（图.4）

图.4

进入数据连接后可通过显示的诊断信息查看当前连接状态

1.连接ID1，静态客户端连接，状态：已连接（图.5）

图.5

2.连接ID2，静态服务器连接,连接错误，未连接(图.6)

图.6

3.连接ID3，动态服务器连接,已连接(图.7)

图.7


timer

LOGO ! 0BA8 之间以太网S7通讯

LOGO 从0BA7始支持S7以太网通讯，

LOGO! 设备可作为客户机来与一或多台服务器模式下的 0BA8 设备进行通讯。一台服务器同样允许一台或多台客户机访问。

LOGO主从站编程包含电路图模式和网络模式两种方法实现

LOGO 0BA8之间以太网S7协议LOGO客户机编程(电路图模式)

编程环境

硬件：主站LOGO! 0BA8 FS04，从站LOGO!0BA8 standard

软件：LOGO Soft Comfort V8.1.1

1.新建项目，右键点击项目名称，打开以太网连接（图.1）

图.1

2.新建项目，右键点击项目名称，打开以太网连接（图.2）

图.2

a.设置本地IP地址和子网掩码

b.右键单击以太网连接，添加客户端连接

c.添加S7连接

3.添加传输的数据（图.3）

图.3

a.双击打开连接1

b.设置远程服务器的TSAP号码和IP地址（TSAP参考服务器端设置）

c. 您可在此定义数据传输连接的属性。（读取：客户端 <- 服务器，写入：客户端 -> 服务器）

您在客户端连接中最多可创建 32 个数据传输。

在读取过程中，本地主机模块读取并存储来自远程服务器的信息；在写的过程中，本地主机模块将数据写入远程服务器。您可通过定义对应的列在本地主机模块或远程服务器上存储数据。每一数据传输的最大传输数据长度为 212 字节

点击下列下拉菜单选择要传输的数据VB,MB,QB,IB(图.4)

图.4

LOGO 0BA8之间以太网S7协议LOGO服务器编程(电路图模式)

1新建项目，(图.5)

图.5

a.右键点击项目名称，打开以太网连接

b.添加本地IP地址和子网掩码

c.添加服务器S7连接

2.设置连接1的服务器参数(图.6)

图.6

a.设置本地的TSAP号码，勾选接受所有的连接请求。

b.设置远程的TSAP号码。点击确定。

下载程序 ，测试结果。

服务器端(图.7)

图.7

客户机端(图.8)

图.8

网络视图S7协议通讯编程

1.新建项目，添加两台新设备，LOGO8 FS4与 LOGO8!standard(图.9)

图.9

a.把两个CPU使用连线拖动连接，左侧CPU为客户机，右侧为服务器，如需调整服务器和客户机（拖动CPU位置即可）

b.双击该连接线，打开数据配置页(图.10)

图.10

a.自动默认分配相互的TSAP号码

b.分配数据传输的地址和数量

将程序分别下载到对应的CPU，监控测试。


timer

LOGO ! 0BA8 FS4与S7-200SMART以太网S7通讯

S7通信是S7系列PLC基于MPI、PROFIBUS、ETHERNET网络的一种优化的通信协议，

注意：
1.S7-200 SMART CPU 与LOGO之间的S7通信未经西门子官方测试，本文档仅供客户测试使用，使用该种通信方式所产生的任何危险需要有客户自己承担！
2.LOGO!从 0BA7版本才开始支持PUT/GET通信，0BA6及以前版本的LOGO不支持以太网通讯
3.本文仅介绍LOGO!与S7-200 SMART CPU S7通信

LOGO可以作为客户机或服务器与S7-200smartPLC通讯

LOGO与S7-200SMART通讯主从站编程包含电路图模式和网络模式两种方法实现

编程环境：

软件版本: LOGO soft comfort V8.1.1 ，STEP 7-Micro/WIN SMARTV2.3

固件版本：LOGO 0BA8 FS04。,CR60 V2.3

以太网S7通讯：S7-200SMART作为客户机,LOGO作为服务器（电路图模式）

1.使用logo软件新建一个项目（图.1）

图.1

a.在项目的名称处点击右键选择“以太网连接”

b.在模块地址处输入LOGO的IP地址和子网掩码

c.在以太网连接处添加S7连接

2.设置连接1的服务器参数(图.2)

图.2

a.设置本地的TSAP号码，勾选接受所有的连接请求。

b.设置远程的TSAP号码。点击确定。

二.S7-200SMART侧编程

1.新建项目，选择工具-PUT/GET向导，打开配置页面(图.3)

图.3

a.创建两个连接一个名称为GET一个名称为PUT

b.选择类型为发送（PUT）或接收(GET)

c.选择传送的数据大小字节（最大200个字节）

d.传输区本地起始字节地址

e.远程的LOGO的IP地址

f.传输区远程的起始地址

g.点击下一个，可以设置PUT的数据传输属性

h.点击生成PUT/GET通讯向导程序

注意：由于PUT/GET向导没有设置TSAP号码选项，则不需要设置远程服务器的TSAP号码。

注意：分配的存储器地址必须是唯一，任何地方及其他程序都不能占用这段地址区域。（图.4）

图.4

2.主程序内常一调用向导生成子程序（图.5）

图.5

三.下载双方CPU程序后监控状态表如下（图.6）

图.6

以太网S7通讯：S7-200SMART作为客户机,LOGO作为服务器（电路图模式）

1.新建网络项目，添加新设备-选择设备LOGO8!FS04-设置LOGO的设备名，IP地址和子网掩码（图.7）

图.7

2.再次添加新设备，选择S7兼容设备（图.8）

图.8

a.添加好S7兼容性设备后，将此设备拖拽到左侧，使用鼠标将两个设备连接到一起。

b.双击该连接线打开连接配置。

3.配置远程连接数据（图.9）

图.9

a.配置远程TSAP号码，S7-200SMART默认设置为，02.00 ，02.01，03.00，03.01

b.此处不勾选数据连接，忽略此设置。


timer

LOGO ! 0BA8 FS4与S7-200SMART以太网S7通讯(LOGO做客户机）

S7通信是S7系列PLC基于MPI、PROFIBUS、ETHERNET网络的一种优化的通信协议，

注意：
1.S7-200 SMART CPU 与LOGO之间的S7通信未经西门子官方测试，本文档仅供客户测试使用，使用该种通信方式所产生的任何危险需要有客户自己承担！
2.LOGO!从 0BA7版本才开始支持PUT/GET通信，0BA6及以前版本的LOGO不支持以太网通讯
3.本文仅介绍LOGO!与S7-200 SMART CPU S7通信

LOGO可以作为客户机或服务器与S7-200smartPLC通讯

LOGO与S7-200SMART通讯主从站编程包含电路图模式和网络模式两种方法实现

编程环境：

软件版本: LOGO soft comfort V8.1.1 ，STEP 7-Micro/WIN SMARTV2.3

固件版本：LOGO 0BA8 FS04。,CR60 V2.3

以太网S7通讯：S7-200SMART作为服务器,LOGO作为客户机（电路图模式）

1.使用logo软件新建一个项目（图.1）

图.1

a.设置本地IP地址和子网掩码

b.右键单击以太网连接，添加客户端连接

c.添加S7连接

2.添加传输的数据（图.2）

图.2

a.设置远程服务器的TSAP号码和IP地址，S7-200SMART默认的TSAP号码为02.00 ，02.01，03.00，03.01

b.设置数据传输区域，

可以配置传输变量类型VB, MB, QB, IB

可在此定义数据传输连接的属性。（读取：客户端 <- 服务器，写入：客户端 -> 服务器）

在客户端连接中最多可创建 32 个数据传输。

在读取过程中，本地主机模块读取并存储来自远程服务器的信息；在写的过程中，本地主机模块将数据写入远程服务器。

可通过定义对应的列在本地主机模块或远程服务器上存储数据。每一数据传输的最大传输数据长度为 212 字节。

3.设置好直接下载程序，

smart作为服务器侧不需要编写程序，留出对应的存储区直接监控通讯状态。（图.3）

图.3

以太网S7通讯：S7-200SMART作为服务器,LOGO作为客户机（网络视图模式）

1.新建项目，添加两台新设备，LOGO 0BA8 FS04与S7兼容性设备（图.4）

图.4

a.添加两台新设备，LOGO8 FS4与 LOGO8!standard(

b.把两个CPU使用连线拖动连接，左侧CPU为客户机，右侧为服务器，如需调整服务器和客户机（拖动CPU位置即可）

c.双击该连接线，打开数据配置页(图.4)配置数据传输参数方式与电路图模式相同。(图.5)

图.5

2.下载程序后监控PLC与LOGO状态。（S7-200SMART侧不需要编程）


timer

LOGO 0BA8 FS4 Modbus TCP通讯

描述:

LOGO 0BA8 FS4版本开始支持 Modbus TCP通讯

固件版本：FS4

软件版本：LOGO Comfort V8.1 (8.0不支持ModbusTCP)

Client具体设置方法：

LOGO作为Client(图.1)

图.1

1.添加新设备，一台FS4和一台Modbus兼容性设

2.使用鼠标连接两台设备（黄色线）

3.双击黄色线配置连接数据(图.2)

图.2

Ø自定义 LOGO! 主机模块与服务器进行数据同步的时间间隔\

Ø 客户端连接中最多可创建 32 个数据传输

Ø 每个连接最大的数据传输为123个字或2000个位(图.3)

图.3

Server具体设置方法：

1.添加新设备LOGO! 8 FS04,单机右键添加服务器连接。(图.4)

图.4

下一步,可以设置指定的客户机连接或者服务器端接收所有的连接请求，其他参数不需设置。（图.5）

图.5

LOGO 0BA8 FS4 Modbus Tcp地址映射：

FS4地址映射：参考(图.6)

DI1-I24 对应Modbus地址 10001- 10024

DQ1-DQ20 对应Modbus地址08193-08212

M1-M64 对应Modbus地址 08257-08320

V0.0-V850.7 对应Modbus地址 00001-06800

AI1-AI8 对应Modbus地址30001-30008

VW0-VW850 对应Modbus地址40001-40425

AQ1-AQ8 对应Modbus地址40513-40520

AM1-AM64 对应Modbus地址40529-40592

图.6

测试结果：使用modbus测试工具可以读取写入数据(图.7)

(图.7)


timer

LOGO ! 0BA8 FS4 以太网主从站通讯

LOGO 从0BA7开始支持主从以太网通讯，（主站占用静态连接资源）

LOGO! 设备可作为主站来与一或多台从站模式下的 0BA8 设备进行通讯。

当 LOGO! 处于从站模式下时，您不可以通过该 LOGO! 对电路程序进行编辑。在参数赋值模式下不能将 LOGO! 变更为主站/从站模式。

将LOGO设置为从站方法

logo设置为从站有两种方法，

1.通过LOGO操作面板来修改LOGO主从站模式(图.1)

图.1

2.通过软件设置从站模式(图.2)

图.2

a:项目名称处单机右键打开属性

b.搜索并连接好PLC后选择在线设置内的操作模式

c.将操作模式设置为从站，并输入主站的IP地址

d.点击应用，从站模式即生效

LOGO主从站编程

编程环境

硬件：主站LOGO! 0BA8 FS04，从站LOGO!0BA8 standard

软件：LOGO Soft Comfort V8.1.1

图.3

a.新建项目，从左侧指令块中调取网络输出指令。双击打开(图.3)

b.选择远程设备

c.远程设备地址设置 ：

①远程从站设备的IP地址，

②设备的类型选择LOGO!0BA8从站或FS04从站，

③功能块的类型选择Q

④Q功能块的编号，比如：Q1

设置完成后下载程序，接通主站I4则从站Q1接通(图.4)

图.4


timer

LOGO 信息文本显示器

使用消息文本功能块，可以配置一个包含文本和其他参数的信息，它可以在 LOGO! 处于 RUN 模式时显示。

LOGO!Soft Comfort 为消息文本提供一系列的扩展特性：数据的条形图、数字量 I/O 状态名称和更多信息。

LOGO支持最多的消息文本画面

在您可以配置的 50 个可能的消息文本中，可以选择它们中的一部分消息文本来自第一种语言，而另一部分消息文本来自第二种语言。例如，您可以为字符集 1 配置 50 个具有单消息文本的消息文本功能块。也可以配置二十五个消息文本功能块，每个功能块具有两个消息文本：一个属于字符集 1，一个属于字符集 2。总和不超过 50 的任何组合都是有效的。

如超过50个或25个双字符集的文本则会报错（图.1）

图.1

LOGO消息文本参数设置

1.双击打开消息文本功能块（图.2）

图.2

2.设置消息文本内参数（图.3）

图.3

a. 消息文本的的优先级设置，数值范围：0 至 127，0 = 最低优先级，127 = 最高优先级。这也表明，仅当某新消息文本的优先级高于先前启用的消息文本的优先级时，LOGO! 才显示该新消息文本。

禁用或确认消息文本后，该功能会自动显示先前激活的消息文本中具有最高优先级的消息文本.可以按上 和下 键来访问多个激活的消息文本。

b. 如果禁用了确认消息（Ack = No），则当输入 En 信号从 1 跳转为 0 时，消息文本隐藏。如果启用了确认消息（Ack = Yes），则当输入 En 信号从 1 跳转至 0 时，消息文本被输出，直至按下 OK 键应答。

如果 En = 1不能应答该消息文本。

c.您可以将消息文本配置为滚动或不滚动。可以单独配置每条消息的滚动。存在两种消息滚动类型：
● 逐字符
● 逐行

d.消息显示的位置，可分别设置，仅LOGO显示屏，仅LOGO TDE,两者都显示以及，WEB服务器，

e.显示消息信息详情，则在软件编程画面可以看到详细信息。（如下图.4）

图.4

f.参数：当选中左侧映射出来的电路图功能块，参数内则显示出来当前可以拖拽到显示文本中的变量， [image] 为只读数据， [image] 为可写入的数据。

g. 删除按钮：用于从消息区域删除条目

插入特殊符号

用于将一个水平或者垂直的柱状图放入到消息区域中（如下图.5）

图.5

  • 柱状图中表示的电路程序中的块[如算数指令]

  • 柱状图的最大和最小数值：LOGO! 将通过测量最小值和最大值之间的实际值来计算柱状图的长度或高度。

  • 柱状图的方向：水平或者垂直

  • 柱状图的宽度或者高度

用于将一个模拟量输入数值放入到消息区域中

用于指定一个数字量数值，该数字量数值将通过状态 0 或者状态 1 所对应的两个字符串（例如：“OFF”和“ON”）中的一个表示出来。

用于引用一个实际值，并以特定的时间格式将其显示出来（图.6）

、

图.6

通过这个对话框，您可以为一个功能块的数值配置时间换算的时基。选择功能块、实际值以及时基，然后点击“OK”，确认您所做的设置。

有关根据所配置的时基在消息文本中显示时间值的计算方法，请参见下表，其中，C 表示实际值：表格1

消息文本的时基 | 时间格式 | 时间值的计算
小时 | xx | C
分钟 | xx :xx | C / 60 :C % 60
秒 | xx :xx :xx | (C / 60) / 60 :(C / 60) % 60 :C % 60
10 毫秒 | xx :xx :xx :xx | C / 100 / 60 / 60 : ((C / 100 / 60) % 60 :(C / 100) % 60 :C % 100
/:取整 %:取余

表格1

用于使用静态编辑器来添加、移动或者删除消息文本元素而无需变更任何其他元素的位置

例如，其具有一个回收站区域，您可以将消息文本元素暂时移动至该区域从而在显示区域上对元素的位置进行再排列。您可以向上、向下、向左或者向右移动一些元素而无需变动任何其他元素位置 (图.7)

图.7


timer

LOGO TDE功能

LOGO! 0BA8起开始支持以太网接口的 TDE功能，通过RJ45网线与LOGO主机连接

TDE模块带有两个以太网接口。这两个以太网接口还可以用作双端口转换开关。您可以
通过以太网接口将 LOGO! TDE 连接至主机模块、PC 或其他 LOGO! TDE
模块。通过选择不同的 IP 地址，您可以将 LOGO! TDE 连接至不同的主机模块

LOGO! TDE 共有三个主菜单命令:（图1）

1.分别用于主机模块的 IP地址选择

2.所连主机模块的远程设置

3.LOGO! TDE 的独立设置

图1.LOGO TDE的三个主命令菜单

LOGO! 自带的显示屏以及 LOGO! TDE 均支持 6行字符显示以及三种背光灯颜色（白色/琥珀色/红色）。

LOGO!自带的显示器每行最多可显示 16 个西欧字符或 8 个亚洲字符。

LOGO! TDE每行最多可显示 20 个西欧字符或 10 个亚洲字符。

注意：TDE可以连接5个主机模块，但一次只能与一个LOGO主机模块通讯,一个LOGO只能连接一个TDE.

LOGO !&TDE背光选择

可通过执行不同的M标志位点亮LOGO或TDE的背光（图2）

双击M30功能块

图2.M标志位所对应的不同颜色及功能

1.LOGO选择

主菜单内，光标移动到LOGO选择，按OK键，进去LOGO选择菜单在XXX.XXX.XXX.XXX位置可以输入对应的LOGO主机的IP地址(图.3)

图.3

选中右侧的箭头可以预输入多个不同的IP地址。移动光标到所选的IP,然后点击ENTER。则可以连接至LOGO主机(图.4)

图.4

2.TDE设置

可通过 LOGO! TDE 查看并配置其自身设置。（图.5）
以下 LOGO! TDE 设置菜单结构在所连 LOGO! 基本型处于 RUN 或 STOP
模式时均适用。

图5.TDE设置菜单

A: TD的菜单设置（图6）

可以设置TDE的模拟刷新时间：该时间确定了消息文本中 LOGO!刷新模拟量值的频率。数值单位为毫秒

TDE屏幕组态消息文本时文字滚动的时间，以及当前TDE的字符集，以及屏幕的对比度,和菜单语言等、

图.6TDE设置菜单内容

B: TD的网络设置（图.7）

设置TDE的IP地址，子网掩码，网关、

图.7设置TDE的网络

C: TDE的诊断功能（图.8）

查看LOGOTDE的固件版本集MAC地址

图.8TDE的诊断菜单图

F键的使用

可以使用TDE的F键来执行程序的输出控制，或者来切换画面显示。

举例如下：当按下F1键则画面切换到B001，当按下F2则执行输出Q1 (图.10)

图.10

常见问题

LOGO及TDE可以通过存储卡固件升级吗？

*不可以，LOGO CPU及TDE不能通过任何方式进行固件版本升级，若需要新版本的LOGO固件产品，只能购买新产品。


timer

LOGO 0BA8 操作面板

描述:

LOGO 包含带面板产品与不带面板产品，区别可从订货号来判断，LOGO! 12/24RCE */LOGO! 12/24RCEo *带o符号则是没有面板产品。

LOGO的操作面板可提供以下功能：

  • 启动停止LOGO,(没有面板产品下载完程序后自动到RUN模式)
  • 编辑程序，修改程序密码，清除程序，查看内存等
  • 设置参数
  • IP地址设置
  • 诊断设备状态
  • 程序卡上传下载传递功能

LOGO修改面板显示语言

LOGO面板修改显示菜单语言可根据以下方式修改：(图.1)

图.1

LOGO通过屏幕面板修改参数

LOGO参数赋值指配置功能块参数。

可以设置时间功能的延迟时间、定时器的接通时间、计数器阈值、运行小时计数器的监
控间隔、触发器的接通和断开阈值等.

您可以配置参数：

● 在编程模式中(停止LOGO修改参数 )

● 在参数赋值模式中（LOGO运行中修改参数）

在参数赋值模式中，允许编辑参数，而不需要修改电路程序。
从而可以无需切换到编程模式，即可编辑参数。
此功能的优点是，用户可以编辑程序参数，但是电路程序始终受到保护。

修改方法举例：

按下 ESC 键进入参数赋值模式:如下图

在参数赋值菜单上移动光标到"①"：如下图

移动光标到"②"： 按下或上，如下图

按下 OK 键确认"②"。
LOGO! 显示所有可用的功能块列表，例如：如下图

如果没有参数可用设置，LOGO! 显示如下，您可以按下 ESC
键返回到参数赋值菜单中。：如下图

按上 或下 键将光标移动到您想要修改参数的功能块，且功能块有可修改的参数，按下 OK 键确认（如下图）

将光标移动到想对应的的参数处可修改对应的时间，修改完成后按OK键确认参数（如下图）

注意：

在系统处于RUN模式时，修改时间参数时也可修改时基.但是不适用于时间参数作为其他功能块的条件引用情况，

在这种情况下您既不能更改数值也不能变更时基，当您更改时基时，当前时间被复位为零。

查看LOGO的IO运行状态

当LOGO运行中，我们可以通过LOGO的面板查看实际的IO状态和模拟量输入输出的当前值。

查看方法如下：(图.2)

图.2

运行状态下按左右键查看I区Q区M区AI/AQ区状态，(图.3,图.4)

图.3

、

图.4

程序中使用光标键或F1功能键来实现程序控制

使用光标键来控制程序的输出

下面为控制程序：由光标键控制Q1输出(图.5)

图.5

下载程序后，出现运行画面，连续按左键或右键直至出现下面画面，在使用ESC+↑、ESC+↓、ESC+←、ESC+→、来实现光标键控制(图.6)

图.6


timer

LOGO TD信息文本内修改当前字符集

LOGO!Soft Comfort、LOGO! 机载显示屏以及 LOGO! TDE 支持下列几种字符集：(表格1)

LOGO! 中的字符集 | 通用名称 | 支持语言 | 互联网参考
ISO-8859-1 | 拉丁文-1 | 英语 德语 意大利语 西班牙语（部分） 荷兰语（部分） | http://en.wikipedia.org/wiki/ISO/IEC_8859-1
ISO-8859-5 | 西里尔字母 | 俄语 | http://en.wikipedia.org/wiki/ISO/IEC_8859-5
ISO-8859-9 | 拉丁文-5 | 土耳其语 | http://en.wikipedia.org/wiki/ISO/IEC_8859-9
ISO-8859-16 | 拉丁文-10 | 法语 | http://en.wikipedia.org/wiki/ISO/IEC_8859-16
GB-2312/GBK | 中文 | 中文 | http://en.wikipedia.org/wiki/GB2312
Shift-JIS | 日语 | 日语 | http://en.wikipedia.org/wiki/Shift-jis

表格1

消息文本中最多支持两种字符集语言切换，可以通过以下设置来挑选任意的两种字符集语言。(图.1)

图.1

a:点击右键属性，打开LOGO设置

b.选择默认显示的字符集

c.该时间确定了消息文本中 LOGO!刷新模拟量值的频率。数值单位为毫秒

d.对于滚动的消息，滚动定时器会设置消息文本在 LOGO! 机载显示屏或者 LOGO! TD/LOGO! TDE上滚动的速度。数值单位为毫秒

修改当前字符集语言，相当于切换信息文本内的组态语言，举例如下：

一 、设置字符集1为中文，在栏内输入“博大精深 同心致远”勾选字符集1，勾选使能。（图2）

1.双击文本显示器功能块，打开文本显示器

2.选择字符集1：GBK,勾选已使能

3.在文本框内输入文字：博大精深，同心致远。

图2.改为字符集1，GBK,

二、设置字符集2为英文，在栏内输入 ingenuity for life勾选字符集2，勾选使能。（图3）

1.双击文本显示器功能块，打开文本显示器

2.选择字符集2：ISO8859_1,勾选已使能

3..在文本框内输入文字：Ingenuity for life

图3.字符集2选择

三、设置完成后下载程序，按下FI键则显示以下字符集1画面(图.4)

图4.按下F1后显示字符集1画面

修改字符集语言有两种方法

1.执行M27置位为1来切换字符集语言。（下图）

2.按下面的菜单顺序修改字符集（图.5 ）

图.5

再次按下F1后画面显示字符集2(图.6)

图.6

常见问题

Q:LOGO菜单的语言修改字符集语言会跟着变化吗？

A:语言以及消息文本的字符集与 LOGO! 自带的显示屏上的菜单语言设置无关。它们可以不同。


Web Server简介

Web 服务器

借助 LOGO! 的 Web 服务器，用户可使用所连设备（传统 PC，平板电脑或带网络浏览功能的智能手机）输入 IP 地址来访问 LOGO! 主机模块或 LOGO! TDE。

网络服务器允许您使用鼠标或触摸屏（取决于您所使用的设备）在可视化的 LOGO! 主机模块和 LOGO! TDE 上执行快速、简单的操作。

Web 浏览器要求

Web 服务器支持以下 网络 浏览器

  • Microsoft Internet Explorer 8.0 及以上版本
  • Mozilla Firefox 11.0 及以上版本
  • Google Chrome 16.0 及以上版本
  • Apple Safari 5.0 及以上版本
  • Opera 12.0 及以上版本

请确保未禁用浏览器上的信息记录程序。

Web 支持的设备

如您使用以上任一浏览器，则 LOGO! 网络服务器可支持以下通讯设备：

  • 传统 PC
  • Apple iPhone 系列
  • Apple iPad 系列
  • 带 Android 系统 2.0 及以上版本的智能手机和平板电脑

Web 支持的网页语言

LOGO! 网络服务器支持以下网页语言：

  • 德语
  • 英语
  • 意大利语
  • 法语
  • 西班牙语
  • 简体中文
  • 日语


Web Server快速入门

启用Web 服务器

1.点击LOGO!Soft Comfort v8.1中：菜单栏工具---传输---访问控制，如下图：

图1 访问控制

2.设置通信接口,连接LOGO! 并将LOGO!切换到STOP状态，

图2 设置通讯端口

图3 LOGO!切换为STOP

3.打开访问控制界面，找到 网络服务器访问 ，勾选“允许网络服务器访问” ，见下图中a.

图4 设置网络服务器

勾选上图中a.后，会弹出b.的提示，点击 是，继续设置密码c.，点击应用d.，设置完毕后点击确定e.，到此，已经成功启用访问控制。

只能通过 LOGO!Soft Comfort 启用网络服务器的权限或更改登录密码。如您不想更改密码来启用网络用户访问，可使用默认密码“LOGO”登录。

通过PC端访问 Web 页面

要通过 PC 访问 LOGO! 的Web 页面，请按以下步骤操作：

1.请确保 LOGO!和 PC 位于同一个局域网中，或二者之间直接使用标准以太网电 缆进行连接。

2. 打开 Web 浏览器，在IP地址栏输入 "http://ww.xx.yy.zz"，其中"ww.xx.yy.zz"是LOGO! 主机的 IP 地址，然后点击回车键。

图5 设置IP，访问LOGO!

如果是远程访问需要设置路由器的端口映射（确保启用8080端口的TCP进行远程访问），PC端在IP 地址栏需输入"http://ww.xx.yy.zz：8080"。

图6 远程访问LOGO!

3. 连接成功后进入LOGO!登录界面：

图7 登录界面

  • a. 选择网页语言，选择“中文”后，登录界面会切换为中文
  • b. 输入在访问控制(见图4 )设置的密码
  • c. 登录 如果不想在下一次登录时输入用户名及密码，可以勾选复选框“keep me logged on（保持登录状态）”

4. 进入Web访问界面，查看LOGO!系统页面。

图8 登录界面

  • a. 点击注销可以退出Web 访问
  • b. LOGO!系统可以查看主机模块的系统信息，包括模块版本、模块类型、固件（FW）版本、IP地址以及模块状态

5. LOGO!变量页面，可以查看并修改变量存储器表格。

图8 登录界面

  • a. 点击添加变量 增加需要监控的变量
  • b. 设置变量类型，监控状态 支持的变量范围参见图 9
  • c. 可修改的变量可以在此修改数值， [image] 表示变量可修改
  • d. 如果需要修改的变量较多可以一起修改

图9 变量取值范围

6.LOGO!BM页面：LOGO! 网络服务器可使您在虚拟 LOGO! 主机模块上通过 LOGO! BM 菜单或在虚拟LOGO! TDE 上通过 LOGO! TD 菜单进行以下操作：

(1). 查看消息文本，如果设置消息文本滚动，可以查看到消息文本逐行或逐字符滚动
  • 如果在LOGO!程序里编辑“信息文本显示器”;，勾选网络服务器： ，则可以在Web 服务器的LOGO!BM/TD里看到组态的信息文本画面，如图10,/11：
(2). 设置可配置参数
  • 双击或轻触两下所显示的参数（见图10中a.），可激活参数修改对话框（见图10 中b.）。如某个参数不可编辑，则其灰显（见图10 中c.）
(3).在虚拟模块上操作执行键，（见图10中d.）如已在电路程序中为光标键和功能键编程，则可在虚拟 LOGO! 主机模块或 LOGO!TDE 上使用这些键进行以下基本操作：
  • 欲启用已编程光标的功能，可点击或轻触 ESC 键。 功能键总为启用状态。
  • 欲启用脉冲输入，可点击或轻触相关光标键或功能键。
  • 欲使能连续的高电平信号输入，可双击或轻触两次相关光标键或功能键。
  • 欲禁用已编程光标键或功能键，可再次点击或轻触 ESC 键。
  • 只要某消息已在 LOGO!Soft Comfort中配置，要禁用此已激活消息的显示，可点击或轻触 OK 键。
(4). 查看背光颜色的状态
  • 可在虚拟 LOGO! 主机模块或 LOGO!TDE 上看到相同的背光效果。

图10 LOGO!主机界面

7. 查看LOGO!TD：

图11 LOGO!TDE界面

虚拟 LOGO! TDE 上操作与虚拟 LOGO! BM类似：

  • a. 可修改参数
  • b. 修改参数值
  • c. 不可修改参数
  • d. 可操作执行键（点击或轻触 ESC 键。 功能键总为启用状态）
  • e.可操作功能键

常问问题

1.为什么浏览器无法连接LOGO!提示“找不到服务器或DNS错误”？

如下图所示，设置军正确，确无法连接LOGO!，

图12 修改硬件类型

可能原因：在IP地址栏输入https:ww.xx.yy.zz，正确的格式应该是http://ww.xx.yy.zz。

2.多个 LOGO! 网络服务器客户端能否同时访问一个 LOGO!主机模块？

可从多个 LOGO! 网络服务器客户端访问一个 LOGO!主机模块。但由于内存限制，此操作可能影响所连主机模块的性能。


SITOP电源

SITOP直流稳压电源

SITOP稳压电源是西门子自动化与驱动集团生产的高性能开关型稳压电源。SITOP电源系列提供了工业稳压直流电源的完整解决方案，是用户的最佳选择。

SITOP揭开了一个电源新时代。秉承多年领域内的领先地位所积累的技术，以及用户的宝贵建议，SITOP电源已经超出了当前市场的要求。新系列的SITOP电源可以应付最严格的要求，易于安装调试、多样的适用性、低价格。SITOP完全能够满足用户的期望：

  • 灵活和低费用的扩展能力，模块化的设计
  • 规格系列完整，从5A到40A，在电源供电和容量上经过了最优化的设计
  • 安全标准高，从电源电路到硬件安装的设计都经过了充分的考虑
  • 体积小，新产品比以往产品安装尺寸更小，而且支持DIN35mm导轨安装
  • 保证24V电源电压，输出电压调整可达20%，避免任何长线造成的压降
  • 电源过载（短路）对策：关闭和恒流自动恢复
  • 提供增容、冗余的全套解决方案
  • 状态和启、停的远程控制
  • 低价格的电源缓冲能力
  • 外围电路的诊断能力


SITOP 产品订货号

SITOP直流稳压电源产品订货号

SITOP 电源产品目录2016.06（中文版）
https://www.industry.siemens.com.cn/automation/cn/zh/power-supplies/power-supplysitop/Documents/8501.5.26.pdf

表1. SITOP产品订货号

产品说明 | MLFB（订货号） | 备注
基本单元 24V/5A （单相） | 6EP1333-3BA00 |
基本单元 24V/10A （单相） | 6EP1334-3BA00 |
基本单元 24V/20A （单相） | 6EP1336-3BA00 |
基本单元 24V/40A （单相） | 6EP1337-3BA00 |
基本单元 48V/20A （三相） | 6EP1457-3BA00 |
基本单元 24V/20A （三相） | 6EP1436-3BA00 |
基本单元 24V/40A （三相） | 6EP1437-3BA00 |
信号模块 | 6EP1961-3BA10 |
缓冲模块 | 6EP1961-3BA00 |
冗余模块 | 6EP1961-3BA20 |
诊断模块 | 6EP1961-2BA00 |
小型电源 24V/0.5A （单相） | 6EP1331-2BA10 |
小型电源 24V/2A （单相） | 6EP1331-2BA00 |
S7-300户外型 24V/2A （24VDC输入） | 6ES7305-1BA80-0AA0 | 允许结露
S7-300户外型 24V/5A （单相） | 6ES7307-1EA80-0AA0 | 允许结露
可调输出电压 3 ... 52V/10A （单相） | 6EP1353-2BA00 |
高电压输入型 24V/20A （两相） | 6EP1536-2AA00 |
DC UPS模块 24V/6A | 6EP1931-2DC21 |
 | 6EP1931-2DC31 | 带RS-232接口
 | 6EP1931-2DC41 | 带USB接口
DC UPS电池模块 24V/1.2Ah | 6EP1935-6MC01 |
DC UPS模块 24V/15A | 6EP1931-2EC21 |
 | 6EP1931-2EC31 | 带RS-232接口
 | 6EP1931-2EC41 | 带USB接口
DC UPS电池模块 24V/3.2Ah | 6EP1935-6MD11 |
DC UPS模块 24V/40A | 6EP1931-2FC01 |
DC UPS电池模块 24V/7Ah | 6EP1935-6ME01 |

表2. LOGO! Power（LOGO!电源）产品订货号：

产品型号 | 额定电流 | 订货号 | 备注
LOGO!Power 5 V | 3.0 A | 6EP1 311-1SH02 |
LOGO!Power 12 V | 1.9 A | 6EP1 321-1SH02 |
LOGO!Power 15 V | 1.9 A | 6EP1 351-1SH02 |
LOGO!Power 24 V | 1.3 A | 6EP1 331-1SH02 |
LOGO!Power 5 V | 6.3 A | 6EP1 311-1SH12 |
LOGO!Power 12 V | 4.5 A | 6EP1 322-1SH02 |
LOGO!Power 15 V | 4.0 A | 6EP1 352-1SH02 |
LOGO!Power 24 V | 2.5 A | 6EP1 332-1SH42 |
LOGO!Power 24 V | 4 A | 6EP1 332-1SH51 |

相关链接

SITOP电源规格参数


SITOP规格参数

SITOP直流稳压电源产品规格参数

  • 用户如果需要SITOP电源的详细产品资料，请查阅《SITOP电源产品目录KT10.1 2004》。可以联系西门子的代理商，或致电西门子自动化与驱动集团索取免费资料。

    KT10.1下载链接

  • 每个SITOP电源模块随包装提供一份《操作指南》，内有全部规格指标及接线、调整等指示。如果此文档丢失，用户可访问SITOP产品主页，下载相应型号（订货号）产品的《操作指南》。

    如果已经知道SITOP电源的订货号，在主页链接“Support > Technical Documentation”中可以找到SITOP系列产品的Operation Instruction《操作指南》，内有关于各型号电源规格、接线和使用的详细说明。

    还可以在SIEMENS自动化与驱动集团的ProDIS网站上用适当的关键词（如订货号）搜索相关条目。

常问问题

新电源模块（3BA00）与以前其他型号的产品有什么区别？是否可以用新型号电源替换其他型号的模块？安装尺寸是否有变化？

西门子新开发的SITOP稳压电源系列产品（3BA00）在各方面都比老产品有改进，并且增加了许多老产品没有的功能。如果要详细考察新产品与旧型号的差别，可以找《SITOP电源新产品目录》与相应老产品的《操作指南》中的规格指标对比。

一般情况下，新型号产品完全可以替代旧型号产品。但安装尺寸会发生改变。

新产品的安装尺寸普遍比旧型号产品为小，而且都支持35mm标准DIN导轨安装。详情请参考《SITOP电源新产品目录》。

是否有中文的SITOP产品目录？

目前还没有。


开关和保护

SITOP直流稳压电源输入侧的开关和保护

SITOP电源的输入侧（通常情况下是交流侧）需要开关以投入或者关闭电源，并且需要保护线路和电源模块的能力。一般选用小型断路器（空气开关）。

当SITOP电源加电时，电源模块会因内部电容的充电而造成一个输入浪涌电流，此电流将在数毫秒内下降到额定输入电流。除了电源模块内部的阻抗外，输入浪涌电流在很大程度上取决于供电电压、供电系统的阻抗以及电缆的阻抗的大小。各SITOP电源的最大输入浪涌电流已经在电源规格表上列出。这对于线路侧的保护设计取值非常重要。

单相交流电输入的SITOP电源和LOGO!电源（SITOP的一类）已经具有内部保护（一个熔断器）。对于交流侧而言，仅需要为线路提供保护设备（熔断器或者断路器），其参数取决于所使用的电缆的额定值。SITOP电源参数表和操作手册中推荐的断路器规格，保证了在最不理想的情况下，所可能产生的最大浪涌电流也不会使断路器分断。

三相交流电输入的SITOP电源没有内部保护电路。必须有线路侧的保护设备（三相联动的断路器或者马达断路器）提供电缆和设备保护。参数表和操作手册中指定的保护设备，与相应电源模块的特性极为相合，因而非常适用。

注意： 直接并联的SITOP电源必须同时开、关。

常问问题

SITOP电源的交流侧额定电流比较小，为何手册中指定了额定电流较大的断路器，而且有分断特性的要求？

是有这样的现象。比如6EP1436-3BA00是三相交流输入的20A/24V模块，额定线路侧电流是1.1A（Vin=400V），参数表中推荐的断路器为6 - 16A，特性C。

这样选择的原因是同时考虑到了电源模块的输入浪涌电流，以及过载能力。所谓过载能力，是电源模块在一定时间内或持续输出超过额定值的电流的能力。SITOP电源的理论和实际过载能力均相当出色。

上述电源的最大输入浪涌电流为35A，而其过载特性也只有分断特性为C的开关符合。所谓分断特性，就是根据电流的大小和作用时间，决定什么时刻分断的关系曲线。空气开关（微型断路器）都是按照某种特性制造的，详细信息请参考西门子的电气安装技术的相关资料。

选用规格过大的开关可能起不到保护作用；选用规格过小的开关会无法发挥SITOP电源的潜力，甚至不能正常上电合闸。


SITOP电源并联

SITOP直流稳压电源的冗余、增容及并联连接

关键的控制系统需要保障直流电源供应，这就需要实现直流电源的冗余配置；有些应用场合所需要的直流电源的容量（输出电流的能力）超出了单个电源所能经济地提供的能力。这就需要所采用的直流电源模块支持冗余和扩容两种能力。

冗余和扩容两种配置都是通过直流电源模块的并联功能实现的。西门子的SITOP模块化电源提供了完整的电源冗余、扩容解决方案，如表1所示。

表1. SITOP电源的冗余和扩容能力

 | 冗余功能 | 扩容功能
解耦并联 | 支持 | 支持
直接并联 | 支持 | 支持

解耦并联

参与并联的电源模块的直流输出端不直接连接，而是通过SITOP冗余模块，或解耦二极管之后再并联。解耦并联可以用于冗余和扩容应用。

这种配置的最大特点是每个电源模块都可以单独开启/关闭，并且某个电源模块输出侧的短路故障不会影响其他电源。这就意味着可以实现100%的冗余。

一个解耦并联的例子如图1所示：

图1. 通过SITOP冗余模块的并联

不同型号的电源模块可以通过冗余模块并联起来。它们可以分别开关。

直接并联

直接并联就是将各电源的直流输出端直接并联。直接并联可用于电源系统的增容和冗余，但不能做到100%的冗余。

直接并联SITOP电源可以省去电源冗余模块或者解耦二极管。外接解耦二极管会带来布置和接线上的麻烦，并且有散热。

所有能够在输出端直接并联的SITOP电源，都在SITOP电源产品目录（KT10.1）中相应型号（订货号）的“Output”参数栏的“Parallel connection for increased output”条目下标明了“Yes”。如果是“Not permissible”，则此型号电源不能直接并联使用。

对于能够直接并联使用的SITOP稳压电源来说，只在理论上有可能发生输出端内部短路的故障。西门子的特别设计使这种故障几乎不可能实际发生。

SITOP电源直接并联能够实现几乎100%的电源冗余，也能安全有效地增加电源系统容量。

直接并联注意事项

  • 只有订货号相同的SITOP电源模块能够直接并联，并且在产品目录（KT10.1）中相应型号的“Output”参数栏中的“Parallel connection for incereased output”参数必须标明为“Yes”
  • 从每个SITOP电源输出端子L+和M连接到负载电流输出节点的导线长度和横截面积（或者说阻抗）须尽量相等。以下是正确和错误接线的例子：

    图2. 正确的接线

    图3. 错误的接线

  • 所有直接并联的SITOP电源模块必须同时开关。即在主供电电路上要有一个共用的开关

    图4. 错误的连接

    由于SITOP电源性能优良，上述错误的接法未必立即产生可见的损坏，但绝对不允许。

  • 各并联SITOP模块的空载输出电压之差，不能超过50mV（越小越好）。这个电压是在各SITOP电源模块的输出端子M连接起来而L+保持空置时，上电稳定一段时间后测量得出。可以微调SITOP电源的输出电压。一般情况下模块在出厂时就符合要求，建议在调试时检查
  • 新一代SITOP电源，即订货号为6EP1xxx-3BA00的模块，提供了一个开关（开关A）设置并联和非并联两种工作状态。并联时必须将所有模块的此开关拨动到ON位置

订货号为6EP1xxx-3BA00的SITOP电源，当开关A拨到ON时会改变输出特性，自动在两个电源之间分配负载电流。这时各电源的空载输出电压调整得不很一致也没关系。

新型号（3BA00）电源的并联连接

新一代SITOP电源，即订货号为6EP1xxx-3BA00的模块，提供了一个开关（开关A）设置并联运行和独立运行两种工作状态。并联运行时，不论是解耦并联，还是直接并联的情况，必须将所有电源模块的此开关拨动到ON位置。

当开关A拨到ON时，新型SITOP电源会改变输出特性，自动在两个电源之间分配负载电流。

常问问题

型号不同的SITOP电源是否可以直接并联？

不能。型号不同的SITOP电源并联必须使用SITOP电源冗余模块。

3BA00电源与其他型号的电源并联，如何设置开关A？

3BA00电源与其他型号的电源不能直接并联，只能通过SITOP电源冗余模块。这种情况下开关A必须在OFF状态。


SITOP电源冗余

SITOP直流稳压电源的冗余

SITOP电源的冗余配置可分为两种情形：

  • 完全（100%的）冗余：
    设计系统时不但考虑到直流电源模块的备份，而且考虑到电源模块输入侧电源的备份
  • 不完全冗余：
    设计系统时只考虑到电源模块的冗余备份

完全冗余（100%冗余）

完全冗余的电源系统必须是：

  • 部分电源模块不工作时，其他电源模块仍能供应负载电流
  • 部分电源模块失去输入侧电源供应时，其他电源模块仍能得到供电

电源模块的供电冗余需要使各电源模块的供电来自不同的电源母线，并分别配备输入断路器。

因此，所谓完全冗余是要在系统设计时考虑，使直流电源模块的供电来自不同的电源母线。如果只有一条电源母线，就做不到100%的冗余。

完全冗余必须使用SITOP电源冗余模块，或者外加解耦二极管。

一个完全冗余的例子如图1所示：

图1. 完全冗余配置

任何SITOP电源通过SITOP电源并联模块，或者外接的解耦二极管（具体接线和参数计算方法可参见SITOP电源产品目录KT10.1），都可以实现100%冗余。通过并联模块或解耦二极管并联时，不要求电源型号的一致性，而且电源模块可以分别开、关。

选用新型号的SITOP电源（3BA00），配合SITOP电源冗余模块，能够充分发挥彼此的高级功能，将获得性能最高、最可靠的完全冗余配备。

不完全冗余（电源模块冗余）

电源模块冗余的系统仅要求在部分电源模块不工作时，其他电源模块仍能供应负载电流。

模块冗余仅考虑到电源模块意外不工作的情况，而没有考虑电源模块失去输入侧电源供应的情况。一个高标准要求的系统应使用完全冗余配置。

针对这种情况，可以使用SITOP电源的直接并联功能。

SITOP电源的新产品（3BA00系列）都支持直接并联；部分老型号的产品也支持直接并联功能。

由于SITOP电源非常可靠，它的直接并联功能往往用于扩大电源系统的容量——增容。

不支持直接并联的SITOP电源模块，只能按完全冗余的方案配置。


电源冗余模块

SITOP电源冗余模块

SIEMENS新开发了一个电源冗余模块（订货号：6EP1961-3BA21）可以十分方便地实现100%的电源冗余，并且性能更高、更加可靠。电源冗余模块上有LED指示灯显示电源状况，也有相应的继电器干触点可提供远程监控信号，并且电源电压监测的门限值可调。

电源冗余模块对参与并联的SITOP电源模块没有特殊的要求。每个电源冗余模块有两路输入、一路输出，可用于并联两个最大电流为20A的SITOP电源；如果SITOP电源容量是30A或40A，则每个参与并联的电源必须在输出端单独连接一个电源冗余模块。这时电源冗余模块的两个24VDC输入端必须先并联，再将冗余模块的输出端并联。如图1所示：

图1. 通过冗余模块后的并联

常问问题

当采用上述图 1. 冗余接法时，只有一个电源上电时为何两个冗余模块的 LED 指示灯都亮了，这是否正常？

这是正常现象。两个电源都工作正常时，两个冗余模块的绿色 LED 亮；如果有一路电源失效，则对应的绿色 LED 灭，红色 LED 亮。


A/B开关的作用

SITOP电源模块上的A/B开关有什么用？

订货号尾为3BA00的新SITOP电源上都有两个拨动开关（A和B）。

每个SITOP电源的包装中都有“操作指南”，其中有关于A、B开关的功能说明。

选择开关 | 功能
A | 决定是否使用负载分配功能。在电源并联使用时，将开关A拨到ON位置，这时参与并联的电源之间会自动分配负载电流；单独使用时，开关A应当为OFF
B | 决定电源输出过负载时的状态。如果外围电路发生短路或者过载，当开关B为OFF时，电源持续输出电流，大小为额定值的1.15倍；开关B为ON时，如果过载持续100ms以上，电源就关闭输出，这种状态在断电至少5s后再上电的情况下可以解除

并联运行时，不论是解耦并联，还是直接并联的情况，必须将所有电源模块的A开关拨动到ON位置。

某些电源的开关室用1、2标示的，入下图所示，与A/B开关的对应关系是：A－2，B－1。

图. SITOP 开关

常问问题

3BA00电源与其他型号的电源并联，如何设置开关A？

3BA00电源与其他型号的电源不能直接并联，只能通过SITOP电源冗余模块做冗余。这种情况下开关A必须在OFF状态。


SITOP_select_fuse

SITOP select 诊断模块

SITOP select 是与 SITOP 电源一起使用的诊断模块，（订货号为：6EP1961-2BA00）。用于把输入模块的 24VDC 电源分为几个分支，并且进行独立的监控。某一路分支电源发生过载、短路故障时，模块可以立刻检测并且断开它，而其他电源分支不受影响。这有利于快速定位故障，减少停机时间，并保证最小停电范围。

SITOP select 可以把一路电源分为 4 个通道，每通道最大电流为 10A，最大电流且可以使用电位器在 2 A 和 10 A 之间调整。每通道有两个 LED 指示此路电源的状态，绿色表示通状态，红色表示断开。还有一个总的继电器信号触点表示电源状态。

SITOP select 的每个电源直路都是按照各自的“额定”电流设定进行监控。 通道正常工作时绿色 LED 指示灯亮；过流发生时红色 LED 指示灯亮；过流或短路大约 20s 后红色 LED 变为闪烁，表示可以尝试用 RESET 按钮复位故障。信号继电器的干触点闭合代表工作正常；打开表示至少一路电源断开，或者熔断器熔断。

诊断模块的每个分支有一个独立的熔断器，缺省情况下它的容量是 15A。根据用户选择的分支额定电流，可以换装其他规格的熔断器。

常问问题

如何选择 SITOP select 诊断模块的保险丝（熔断器），可否选择额定电流低于 15 A 的保险？

SITOP select 使用的标准保险是 15A FK2 插刀型熔断器，19mm长。如果保险损坏，用户可以依据模块原装保险外形及上述参数去电子市场选购。

用户可以依据实际的输出容量，选择低额定电流的保险。具体对应关系如下 :

表1. 熔断器规格选择
设定的最大输出电流 | 最小保险容量
2A | 3A
3A | 4A
4A | 5A
6A | 7.5A
8A | 10A
10A | 15A

注意：如果使用额定电流低于15A的保险，上电之前，用户必须确认模块输出通道的电位计旋钮设定在对应最大电流值处。

保险制造商举例：Wickmann, FK2 系列，19mm长
网址：www.wickmann.com.


电话热线服务

西门子自动化与驱动集团热线服务

信息咨询热线

    提供有关西门子自动化与驱动集团产品及业务等任何问题的咨询服务。如售前咨询、产品选购、产品培训及手册、工程咨询、市场宣传等方面的问题。

    电话： ＋86 10 64731919
    传真： ＋86 10 64719991
    电邮： ad.calldesk@siemens.com

    信息咨询电话热线工作时间：

    周一至周五 8:30 - 17:15；按国家规定休假。

技术支持与服务热线

提供西门子自动化与驱动集团相关产品的售后技术支持及产品维修服务。

电话： ＋86 400-810-4288
传真： ＋86 10 64719991
电邮： support.china.automation@siemens.com

技术支持与服务电话热线工作时间：

周一至周五 8:30 - 17:15；按国家规定休假。

技术支持与服务网站

您也可以登录技术支持与服务网站在线提交技术问题：

http://www.ad.siemens.com.cn/service


LOGO!

LOGO!是西门子生产的小型通用逻辑控制模块。

LOGO!把输入输出接点，可灵活编辑的控制逻辑、功能丰富的内部定时器，以及操作面板、带背光的显示器和电源集成一体。LOGO!还支持各种扩展模块。LOGO!Soft Comfort软件使编程工作分外轻松。

LOGO!为用户提供了友好的界面和极容易的操作。在数百万成功的应用案例中，LOGO!表现了它一贯良好的质量。多年来LOGO!一直在商业和工业的小型自动化领域执行得到广泛的应用。

LOGO!具有如下主要特点：

  • 用于取代传统的（继电）控制
  • 占据很小的空间
  • 附件较少
  • 需要的维护很少
  • 标准DIN35mm导轨安装
  • 用户友好的配置
  • 最简单的接线
  • 可在面板和计算机软件中编程
  • 自动夏时制切换
  • 防震设计
  • 符合严格的电磁兼容（EMC）标准


如何将LOGO!Soft Comfort 软件版本升级(更新)到最新版本

本文以升级到LOGO!Soft Comfort V7.1.5为例做介绍，目前有两种方式可以将LOGO!Soft Comfort软件成为最新版本。（所有以前的正式版轻松软件都可以免费升级到目前的版本。例外的是DEMO版（演示版）软件不能升级）

1、通过安装官方发布的Upgrades升级包升级软件。

2、通过LOGO!Soft Comfort自带的“更新中心”更新软件。

1、通过安装官方发布的Upgrades升级包升级软件

如果您的PC上装有 LOGO! Soft Comfort: V1.0 / V2.0 / V3.x / V4.0 / V5.0 / V6.x/ V7.0，您可以通过到LOGO!官方网站下载Upgrades升级包将软件升级到最新。

下面以操作系统为Windows 32 Bit为例，将LOGO! Soft Comfort软件版本由V7.0.3升级到V7.1.5，具体操作步骤如下：

1.1、打开 LOGO! Soft Comfort：演示软件，升级软件，驱动程序网站，进入“Demo software , upgrades/updates, drivers”页面，链接如下：

http://www.automation.siemens.com/mcms/programmable-logic-controller/en/logic-module-logo/demo-software/Pages/Default.aspx

1.2、在网页中找到如图1.所示的Upgrades升级包所在的位置，并根据自己的操作系统类型选择相应的版本下载。

图1.Upgrades升级包图示

1.3、下载完成后可得到如图2.所示的可执行文件，双击按提示安装见图3.

图2.下载后得到Upgrades升级包

图3.安装Upgrades升级包

1.4、按照安装提示选择语言，见图4.

图4.安装Upgrades升级包选择语言

1.5、为Upgrades安装选择目标路径并进行下一步，见图5.

图5.为Upgrades安装选择目标路径

1.6、选择快捷方式创建路径并点击安装，见图6.

图6.选择快捷方式创建路径

1.7、根据需要选择是否需要安装USB电缆驱动，见图7.。

如果您使用的是0BA6及以下版本的LOGO！且之前没有安装过USB电缆驱动，请您点击“YES”安装，否则您需要寻找单独的驱动文件安装，然后才能通过USB电缆下载。

如果需要单独安装USB电缆驱动，可以在1.1节的网站上找到图8.所示的USB驱动程序，请下载并安装。

如果您使用的是0BA7及以上版本的LOGO！，由于0BA7及以上版本的LOGO！只能通过以太网下载程序，是否安装USB电缆驱动都不会影响下载，您可以点击“NO”进入下一步继续软件升级。

图7.选择是否需要安装USB电缆驱动

图8.USB驱动下载图示

1.8、点击“完成”并启动LOGO!Soft Comfort软件，见图9.。启动软件后查看软件版本，见图10.，软件版本已经升级到V7.1.5。

图9.完成软件Upgrades

图10.Upgrades后软件版本

2、通过LOGO!Soft Comfort自带的“更新中心”更新

LOGO!Soft Comfort自带的“更新中心”可以通过“因特网”或者“文件系统”两种方式对软件进行更新。需要注意的是，这种方式只能在同版本软件之间进行更新，例如：V6.x版本的软件只能更新到V6.y而不能更新到V7.0及以上版本。

具体步骤如下：

2.1、打开LOGO!Soft Comfort自带的“更新中心”，见图11.。

图11.启动LOGO!Soft Comfort自带的“更新中心”

2.2、进入“Update - 步1”并选择下一步，见图12.。

图13.进入LOGO!Soft Comfort自带的“更新中心”

2.3、进入“Update - 步1”并选择更新源见图14.所示。

更新源有两种：“因特网”和“文件系统”。

如果选择“因特网”，则需要更新LOGO!Soft Comfort软件的计算机必须要连入互联网，本例以此种方法为例将LOGO!Soft Comfort软件由V7.0.3升级到V7.1.5。

如果选择“文件系统”，则需要更新LOGO!Soft Comfort软件的计算机无须要连入互联网，可以由能联网的计算机到1.1节的网站下载更新文件，见图15.。将下载到的*.luf文件拷贝到要升级的计算机，按照提示对软件进行更新。

图14.选择更新源

图14.网站上更新文件位置

2.4、设置联网方式，窗口中，自动填写了服务器的地址，见图15.，如果使用代理服务器的话就需要填写代理服务器地址和代理端口，否则直接进入下一步。

图15.设置联网方式

2.6选择需要更新的语言包或者服务包，进入下一步，见图16.。

图16.选择更新包

2.7、下载更新文件见，见图17.。

图17.下载更新文件

2.7确定下载完成，并进入下一步，见图18.。

图18.确定下载完成

2.8、解压文件安装

窗口显示“更新文件下载完毕，未发现错误，现在开始解压缩”，见图19.，点击“下一步”，更新文件开始安装，直到结束，完成更新。

图19.解压文件安装

2.9、关闭LOGO!Soft Comfort并重启，使更新生效，可以查到软件版本已经被更新到V7.1.5。


以太网编程

通过以太网编程

要实现用以太网对S7-200 CPU编程，你需要有：

  1. 装有以太网卡的PC机，PC机上装有STEP 7-Micro/WIN（V3.2 SP1以上）软件
  2. 能够通过PC/PPI电缆、或CP卡、或EM241与CPU做通信编程
  3. CP243-1以太网模块
  4. 一个HUB（集线器）、或Switch（交换机）和网络电缆，或以太网直连电缆

首先你需要用STEP 7-Micro/WIN 软件，在Tools > Ethernet Wizard（以太网向导）中对CP243-1进行配置，为其设定IP地址、子网掩码等。

注意：要保证CP243-1和PC机的IP地址在一个网段上 。CP243-1模块不会自动适应电缆的接线方式，因此直接连接PC机网卡和CP243-1模块时，需要注意网线的类型。

在完成以太网向导后，会生成一个子程序，如下图：

图1. 以太网控制子程序

在程序中用SM0.0调用这个子程序，生成如下程序：

图2. 调用以太网控制程序

上图中的状态字VW0、VW2地址由用户指定，要注意不能与Ethernet Wizard（CP243-1）、Internet Wizard（CP243-1 IT）做配置时指定的V存储区重复。

将此程序下装到CPU中，然后将CPU重新上电，并运行，此时对以太网的配置开始生效。

最后在MICRO/WIN软件中，进入Set PG/PC Interface，设定为TCP/IP通信接口，即可进入Communications（通信）中与CPU编程通信。

参考链接

S7-200的以太网通信


TD 400C - 面板图形 Keypad Designer

使用 TD Keypad Designer 辅助设计 TD 400C 面板图形

TD Keypad Designer 的另一个功能是辅助第三方的图形编辑软件（如 Windows 中的 “画图”，或者 Photoshop 等）完成 TD 400C 的面板图形设计。

TD Keypad Designer 的图形设计功能有：

  • 导出键盘布局，以便第三方图形编辑软件准确定位键的位置
  • 导入设计完成的面板图形，与功能键自定义数据一同保存为 .td4 文件，提高在 Micro/WIN 的文本显示向导中的可视性
  • 打印翻转的面板图片到专用透明面板胶片，导出原图或翻转的图片

自定义 TD 的功能键必须使用 TD Keypad Designer；自定义 TD 面板图形未必一定要使用 TD Keypad Designer，用户可以根据TD 面板的精确尺寸，脱离 TD Keypad Designer 独立设计面板图片，也可以找第三方的薄膜按键面板厂商定制自己的面板贴面。

将键盘布局导出到图形应用程序中

使用 “文件 ”> “导出” > “按键模板到文件” 菜单命令来创建键盘布局图片的位图文件 (*.bmp)，以便第三方图形应用程序用它作为定位模版。

图1. 将按键的布局导出到图形应用程序中

使用第三方图形编辑软件处理 TD 面板图片

导入第三方图形编辑软件设计完成的面板图片

在 TD Keypad Designer 的“文件” > “导入”菜单中，选择“面板图片来自文件...”，就可以将第三方图形编辑软件保存的图片文件（.bmp文件）。

图9. 导入面板图片

在设计面板时，创建的位图可采用任意分辨率。但是，TD 400C 设备的背景图片的大小必须完全符合以下尺寸：
宽度：91.5 (+/- 0.1 mm)（3.6 英寸）
高度：163.5 (+/- 0.1mm)（6.44 英寸）
如果面板设计与这些尺寸不相符，键盘设计器会在导入面板图片前提醒您。如果导入尺寸不正确的面板图片，键盘设计器将调整面板图片的大小，这可能会导致面板设计的外观变形。

导入面板图片后，再保存面板组态文件（.td4 文件）。此文件包含键盘按键的以下信息：

  • 按键数
  • 按键的位置和大小
  • 按键的名称
  • 分配给按键的功能
  • 面板图片（如果导入了一个面板图片）

包含上述信息的 .td4 文件已经是一个完整的 TD 自定义面板配置文件。

使用 TD Keypad Designer 导出、打印面板图片

使用 TD Keypad Designer 可以对导入的面板图片进行如下后续处理：

  • 导出自定义面板图片
  • 打印自定义面板图片

导出自定义面板图片：

在 TD Keypad Designer 的“文件” > “导出”菜单中，选择“ 面板图片到文件”，可以将面板图片导出为 .bmp 文件。

导出图片时，可以选择原图片导出和翻转原图导出。翻转图片也是为了在其他软件中方便打印到专用透明面板胶片的反面。

在 Keypad Designer 中使用“文件” > “导出” > “翻转面板图片”菜单命令来选择此功能。选中标记表明您选中了“翻转面板图片”功能。

  • “翻转面板图片”选项仅在使用 “文件” > “导出” > “面板图片到文件” 菜单命令时起作用。导出的位图文件随后就可以插入到 Microsoft Word 模板中。“翻转面板图片”选项不会改变键盘的布局。
  • 通过打印翻转的图片，可以使面板在打印过程中印上墨水的一面朝向 TD 设备。这样，在按下按键时，操作员就只会接触到塑料隔膜，而不会接触到墨水。
  • 在纸上打印面板进行检查时，请使用非翻转的面板图片。通过打印非翻转的面板图片，可以在打印时看到正确的元素。

打印自定义面板图片：

使用 TD Keypad Designer 中的 “文件” > “打印”菜单命令，将自定义面板图片打印到专用的透明面板胶片上。使用“打印预览”功能可以检查打印效果。

在 TD Keypad Designer 中打印的面板图片始终是翻转的。

要将自定义设计的面板图片打印到空白面板材料上，可以使用可在透明材料上进行打印并且支持彩色打印的激光打印机。

请使用西门子的经特殊处理透明胶片。

  • 面板材料经过了特殊处理，适合用激光打印机进行打印。
  • 确保材料已正确插入到激光打印机中，使面板图片打印到处理过的材料表面上。打印到面板材料上的必须是翻转的面板图片。
  • 在将面板图片打印到空白面板薄片上之前，请先在普通纸上打印面板图片，对您的设计进行测试。可以临时使用纸面板，在 TD 设备上测试设计的功能。

要打印多个面板图片，可使用 Microsoft Word 模板（TD 400C），以确保面板图片设计的大小合适。可将多个面板图片打印到空白面板薄片上。

从字处理应用程序打印面板

使用字处理应用程序（例如 Microsoft Word）将多个面板打印到空白面板材料上。将面板的图片导出到文档中之后，可以调整面板图片的位置，然后打印该文档。TD Keypad Designer 安装目录中已经一个 TD 400C 的打印模版文件，在一张透明面板上可以打印三张。这需要配合专门订货的专用打印胶片使用。

  1. 打开 TD Keypad Designer
  2. 选择“文件” > “导出” > “面板图片到文件”菜单命令来创建可插入到字处理应用程序中的位图文件。
  3. 使用字处理应用程序，插入使用 TD Keypad Designer 创建的位图文件(*.bmp)，从而将面板图片插入到文档中。
  4. 按照模板文件中的指令放置面板并调整其大小。
  5. 将面板图片插入到文档中之后，使用字处理应用程序的“文件” > “另存为”菜单命令保存该文档。

在文档中保存了面板图片之后，就可以使用激光打印机打印该文档。

在将面板图片打印到空白面板材料上之前，请先在普通纸上打印面板，对您的设计进行测试。

第三方厂商制作的自定义面板

世面上有很多薄膜开关面板的制造商，也能为西门子的 TD 提供自定义面板的设计、制作。

薄膜开关面板制作