使用说明

说明

本合集作为S7-1200 Easy Plus文档的姊妹篇，提供了S7-1200的指令、通讯、高级功能等的例程。
本例程仅供参考，程序中的CPU版本、类型可能与用户实际使用不同，用户可能需要先对例子程序做修改和调整，才能将其用于测试。本例程的作者和拥有者对于该例程的功能性和兼容性不负任何责任，使用该例程的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。

每个例程中将注明所使用的软件版本，请使用合适版本的软件打开例程。

使用

SIMATIC S7-1200 例程合集是HTML Help格式的文档。

SIMATIC S7-1200 例程合集以便于查阅为目的设计，没有一定的阅读顺序。各篇技术资料在窗口左侧的目录中归类。读者可以直接进入树型目录，寻找感兴趣的标题。

  • 代表这是一个分类目录，同时其中有文字说明
  • 鼠标单击目录树的 [image] 可打开下一级目录
  • 文章中没有回退链接，可以用窗口工具栏上的“后退”、“前进”按钮
  • 按住Shift键再用鼠标点击文档中的链接，可在新的浏览器窗口中打开链接
  • 用工具栏“打印”按钮可以打印文章
  • 在窗口左侧的“搜索”标签中，可以进行全文范围内的文本检索

下载

SIMATIC S7-1200 例程合集 将会根据情况更新。读者可以从西门子（中国）自动化与驱动集团技术支持与服务首页，进入“下载中心”下载。

http://www.ad.siemens.com.cn/download 文档编号 A1200


What's New?

V1.0 ......2017.10.13

环境：S7-1200 V4.2版本、TIA 博途STEP 7V14SP1

1.指令：
（1）基本指令：
定时器操作：
定时器多重背景
计数器操作：
计数器多重背景
移动操作：
移动块和存储区移动：MOVE_BLK、MOVE_BLK_VARIANT
数组间接寻址
AT和片段访问
PEEK、POKE
转换操作：
缩放和标准化：SCALE_X、NORM_X
程序控制指令：
测量程序运行时间：RUNTIME
（2）扩展指令：
日期和时间：
设置时间及时间相加减：WR_LOC_T、RD_LOC_T、WR_SYS_T、RD_SYS_T、SET_TIMEZONE、T_DIFF、T_ADD、T_CONV
字符串+字符：
字符串和浮点数之间的相互转化：S_CONV、STRG_VAL、VAL_STRG
ASCII字符串和十六进制数的相互转化：HTA、ATH

2.功能：
修改IP地址：T_CONFIG
组态控制
TRACE

3.通讯：
（1）以太网：
PNIO：S7-1200 与 S7-1200 Profinet 通信、S7-1200 与 S7-300 PN Profinet 通信
S7：S7-1200 与 S7-1200 S7 通信、S7-1200 与 S7-300 PN S7 通信、S7-1200 与 S7-300 CP343-1 S7 通信、S7-1200 与 CP243-1 S7 通信
TCP：S7-1200与S7-1200的 TCP 通讯、S7-1200 与 S7-300 PN TCP 通信、S7-1200 与 S7-300 CP343-1 TCP 通信、S7-1200与S7-1200的 Modbus TCP 通讯
（2）PROFIBUS：
S7-1200与S7-300集成口的PROFIBUS DP主从通信
S7-1200与S7-300 CP342-5的PROFIBUS DP主从通信
（3）串口：
MODBUS：S7-1200与S7-1200的MODBUS通信
USS：S7-1200 与西门子传动设备之间通信

4.高级功能：
（1）运动控制：
1.通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为"脉冲"；
2.通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为"mm"；
3.使用命令表功能将多个单独的轴控制命令组合到一个运动顺序中；
4.通过模拟量输出控制伺服进行闭环控制；
5.通过基于PROFINET的PROFIdrive方式与V90 PN连接；
（2）高速计数器
1. 高速计数器基本指令CTRL_HSC使用例程
2. 高速计数器扩展指令CTRL_HSC_EXT使用例程；
3. 高速计数器断电数据保持例程；


如何打开项目归档文件

例程中的TIA博途项目文件与STEP 7项目文件均为归档文件，需要按如下方式打开：

TIA博途项目文件

1. 打开TIA博途软件，通过软件左下方“项目视图”按钮切换至项目视图：

2. 在打开的项目视图中，点击“项目>恢复”

3. 浏览到下载的TIA项目归档文件

4. 打开并恢复，在OB1的块标题有程序的整体说明，每一程序段均有该段的说明

STEP 7项目文件:

1. 打开STEP 7软件，点击“文件>恢复”

2. 浏览到下载的STEP 7项目归档文件

3. 打开并恢复，在OB1的块标题有程序的整体说明，每一程序段均有该段的说明


定时器

如何打开项目归档文件

参考：如何打开归档项目文件

S7-1200 定时器多重背景使用

1.使用环境：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能：
用于演示S7-1200定时器多重背景如何使用。

S7-1200_定时器多重背景.zap14

免责声明

本例程仅供参考，程序中的CPU版本、类型可能与用户实际使用不同，用户可能需要先对例子程序做修改和调整，才能将其用于测试。本例程的作者和拥有者对于该例程的功能性和兼容性不负任何责任，使用该例程的风险完全由用户自行承担。由于它是免费的，所以不提供任何担保，错误纠正和热线支持，用户不必为此联系西门子技术支持与服务部门。


计数器

如何打开项目归档文件

S7-1200 计数器多重背景使用

1.使用环境：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能：
用于演示S7-1200计数器多重背景如何使用。

S7-1200_计数器多重背景.zap14

免责声明


移动操作

如何打开项目归档文件

S7-1200的移动块和存储区移动的例程

1. 使用环境：
① S7-1215C V4.2
② TIA 博途 STEP 7 V14SP1

2. 实现功能：
① 通过MOVE_BLK实现相同基本数据类型数组间的部分移动
② 通过MOVE_BLK_VARIANT实现相同复杂数据类型数组间的部分移动
③ 通过MOVE_BLK_VARIANT实现非优化块（或M区、I区、Q区）之间的任意移动

MOVE

S7-1200数组间接寻址的例程

1.使用硬件和软件：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能：
用于演示S7-1200 数组间接寻址如何使用。
① 把src.src1数组里的数据循环传送到dest.dest1;
② 把src.src2数组里的数据循环传送到dest.dest2;
③ 把src.src3数组里的数据循环传送到dest.dest3;

S7-1200_数组间接寻址.zap14

S7-1200 AT覆盖和片段访问使用的例程

1.使用硬件和软件：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能：
用于演示S7-1200AT覆盖和片段访问如何使用。
① 使用AT覆盖拆分一个DWord数据;
② 使用片段访问拆分一个DWord数据;

S7-1200_AT覆盖和片段访问.zap14

S7-1200 peek和poke指令使用

1.使用硬件和软件：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能：
用于演示S7-1200peek和poke指令如何使用。
① 使用PEEK WORD指令把IW0传送到peek_db.peek_d;
② 使用POKE指令把poke_db.poke_d传送到QB1;
③ 使用POKE_BLK把db3.dbb1开始的5个字节传送到db3.dbb10开始的5个字节里;
④ 使用PEEK_BOOL把I0.0传送到peek_bool_db.peek_e;
⑤ 使用POKE_BOOL把poke_bool_db.poke_e传送到Q1.1

S7-1200_peek和poke.zap14


转换操作

如何打开项目归档文件

S7-1200 NORM_X和SCALE_X指令使用

1.使用环境：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能：
用于演示S7-1200 NORM_X和SCALE_X如何使用。
①使用NORM_X和SCALE_X指令把模拟量输入信号转换为工程单位；
②使用NORM_X和SCALE_X指令把工程单位转换为模拟量输出信号；

S7-1200_NORM_X和SCALE_X.zap14


程序控制指令

如何打开项目归档文件

RUNTIME例程

1.使用硬件和软件：
① S7-1211C V4.2
② TIA 博途 STEP7 V14 SP1

2.实现功能：
① 测量整个程序的运行时间
② 测量单个块的运行时间
③ 测量某个开关量上升沿的时间间隔

RUNTIME.zap14


日期和时间

如何打开项目归档文件

S7-1200 设置时间及时间相加减

1.使用环境：
① S7-1215C V4.2
② TIA 博途 STEP 7 V14SP1

2.实现功能：
（1）从 HMI 上修改年、月、日、时、分、秒，数据类型为整型，通过某个开关接通，实现本地时间的修改设定，同时读取本地时间。
（2）设置和读取系统时间
（3）修改时区
（4）实现时间相加减，计算累计运行时间

TIME_example_test.zap14


字符串+字符

如何打开项目归档文件

S7-1200的字符串和浮点数之间的相互转化的例程

1. 使用环境：
① S7-1215C V4.2
② TIA 博途 STEP 7 V14SP1

2. 实现功能：
（1）字符串通过S_CONV转化为浮点数
（2）字符串通过STRG_VAL转化为浮点数
（3）浮点数通过S_CONV转化为字符串
（4）浮点数通过VAL_STRG转化为字符串

STRING

S7-1200的ASCII字符串和十六进制数的相互转化的例程

1.使用硬件和软件：
① S7-1200 V4.2
② TIA 博途 STEP 7 V14SP1

2.实现功能：
① 使用指令"ATH"将 IN 输入参数中指定的 ASCII 字符串转换为十六进制数
② 使用指令"HTA"将 IN 输入中指定的十六进制数转换为 ASCII 字符串。

HTA_AND_ATH.zap14


通过程序修改IP地址

如何打开项目归档文件

S7-1200通过程序修改IP地址的例程

1. 使用环境：
① S7-1215C V4.2
② TIA 博途 STEP 7 V14SP1

2. 实现功能：
S7-1200通过程序修改IP地址

T_CONFIG.zap14


组态控制

如何打开项目归档文件

S7-1200 组态控制例程

1. 使用环境：
① S7-1215C V4.2
② TIA 博途 STEP 7 V14SP1

2. 实现功能：
实现S7-1215C 两种组态控制，
（1）S7-1200上电之前I0.0接通：实际IO模块安装CPU+SM1223，TIA软件配置 CPU+SM1234+SM1223
（2）S7-1200上电之前I0.0不接通：实际IO模块安装CPU+SM1234+SM1223，TIA软件配置 CP+SM1234+SM1223

Configuration_Control.zap14


Trace

如何打开项目归档文件

S7-1200 Trace 例程

1.使用环境
① S7-1215C V4.2
② TIA 博途 STEP 7 V14SP1

2.实现功能
编程实现 MB0的计数值 以10HZ 的频率自加 1，直到 MB0 增加到数值 255 后又循环从 1 开始累加， Trace 记录信号 M0.0 脉冲和 MB0 数值的状态。

Trace 配置说明如下：

信号：添加 M0.0 和 MB0 作为Trace对象

记录条件：

采样：CPU 每个循环OB时间为测量点，记录时长10000 个测量点。

触发器：添加 M1.0=TRUE 作为触发器条件；预触发：10 测量点。当 M1.0=TRUE 时，满足触发条件前 10 个测量点， 开始记录 10000 个时长的测量点，达到该测量点数据数值后，Trace 记录停止。

在Trace配置界面， 点击工具栏的"在设备上安装轨迹"按钮，点击"观察开/关"按钮，然后点击"激活记录"按钮。Trace记录结束后，点击"添加到轨迹测量"按钮。

在该例程项目中设备下的 Traces 下拉菜单>测量>Trace 可查看到保存的Trace图。

Trace.zap14


如何打开项目归档文件

S7-1200 与 S7-1200 Profinet 通信例程

本文为S7-1200 与 S7-1200 之间 Profinet 通信的两种可能情况分别提供了例程：
1. 同一项目中S7-1200 与 S7-1200 之间 Profinet 通信；
2. 不同项目中S7-1200 与 S7-1200 之间 Profinet 通信；

1.同一项目中S7-1200 与 S7-1200 之间 Profinet 通信

1. 使用环境：
（1）S7-1215C V4.2与S7-1217C V4.2
（2）TIA 博途V14SP1组态

2. 实现功能：
S7-1217C作为PROFINET IO控制器，S7-1215C作为PROFINET IO智能设备
S7-1217C Q 100...199映射至S7-1215C I 100...199
S7-1215C Q 200...299映射至S7-1217C I 200...299

I-Device_Same.zap14

2.不同项目中S7-1200 与 S7-1200 PN 口之间 Profinet 通信

1. 使用环境：
（1）S7-1215C V4.2与S7-1217C V4.2
（2）TIA 博途V14SP1组态

2. 实现功能：
S7-1217C作为PROFINET IO控制器，S7-1215C作为PROFINET IO智能设备
S7-1217C Q 100...199映射至S7-1215C I 100...199
S7-1215C Q 200...299映射至S7-1217C I 200...299

PROFINET IO控制器：
I-Device_Master.zap14

PROFINET IO智能设备：
I-Device_Slave.zap14


如何打开项目归档文件

S7-1200 与 S7-300 PN Profinet 通信例程

本文为S7-1200 与 S7-300 PN 之间 Profinet 通信的几种可能情况分别提供了例程：
1. 同一项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信，S7-1200 作为 I-Device，S7-300 PN 作为 IO-Controller；
2. 同一项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信，S7-1200 作为 IO-Controller，S7-300 PN 作为 I-Device；
3. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 I-Device，S7-300 PN 作为 IO-Controller，双方 CPU 都采用 TIA V14 SP1 编程组态；
4. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 IO-Controller，S7-300 PN 作为 I-Device，双方 CPU 都采用 TIA V14 SP1 编程组态；
5. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 I-Device，S7-300 PN 作为 IO-Controller，S7-1200 使用STEP7 V14 SP1 编程组态，S7-300 PN 使用 STEP 7 V5.6 编程组态；
6. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 IO-Controller，S7-300 PN 作为 I-Device，S7-1200 使用STEP7 V14 SP1 编程组态，S7-300 PN 使用 STEP 7 V5.6 编程组态。

1.同一项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信（S7-1200 作为 I-Device，S7-300 PN 作为 IO-Controller）

1.使用环境：
① S7-1211C V4.2
② S7-315-2PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 PN 口之间的 Profinet 通信，项目中 S7-1200 CPU 作为 I-Device，S7-300 PN 作为 IO-Controller。
S7-1200 CPU设置为 I-Device，建立两个传输区分别为：
① 传输区_1: 从S7-300 PN CPU发送QB100开始，到S7-1200 CPU接收IB100，长度为10个字节；
② 传输区_2: 从S7-1200 CPU发送QB100，到S7-300 PN CPU接收IB100开始，长度为10个字节；

S7-1200 Profinet I-Device SameProj.zap14

2.同一项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信（S7-1200 作为 IO-Controller，S7-300 PN 作为 I-Device）

1.使用环境：
① S7-1211C V4.2
② S7-315-2PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 PN 口之间的 Profinet 通信，项目中 S7-1200 CPU 作为 IO-Controller，S7-300 PN 作为 I-Device。
S7-1200 CPU设置为 I-Device，建立两个传输区分别为：
① 传输区_1: 从S7-1200 CPU发送QB100开始，到S7-300 PN CPU接收IB100，长度为10个字节；
② 传输区_2: 从S7-300 PN CPU发送QB100开始，到S7-1200 CPU接收IB100，长度为10个字节；

S7-1200 Profinet IO-Controller SameProj.zap14

3.不同项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信（S7-1200 作为 I-Device，S7-300 PN 作为 IO-Controller）

1.使用环境：
① S7-1211C V4.2
② S7-315-2PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的 Profinet 通信，项目中 S7-1200 CPU 作为 I-Device，S7-300 PN 作为 IO-Controller。
S7-1200 CPU设置为 I-Device，建立两个传输区，并导出S7-1200 CPU的GSD文件：
① 传输区_1: S7-1200 CPU接收从IB100开始，长度为10个字节；
② 传输区_2: S7-1200 CPU发送从QB100开始，长度为10个字节；

S7-300 PN CPU设置为 IO-Controller，并导入S7-1200 CPU的GSD文件
① 传输区_1: S7-300 PN CPU发送从QB100开始，长度为10个字节；
② 传输区_2: S7-300 PN CPU接收从IB100开始，长度为10个字节；

S7-1200 项目：S7-1200 Profinet I-Device DiffProj.zap14

S7-300PN项目：S7-300 Profinet IO-Controller DiffProj.zap14

4.不同项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信（S7-1200 作为 IO-Controller，S7-300 PN 作为 I-Device）

1.使用环境：
① S7-1211C V4.2
② S7-315-2PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的 Profinet 通信，项目中 S7-1200 CPU 作为 IO-Controller，S7-300 PN 作为 I-Device。
S7-300 CPU设置为 I-Device，建立两个传输区，并导出S7-300 CPU的GSD文件：
① 传输区_1: S7-300 CPU接收从IB100开始，长度为10个字节；
② 传输区_2: S7-300 CPU发送从QB100开始，长度为10个字节；

S7-1200 PN CPU设置为 IO-Controller，并导入S7-300 CPU的GSD文件
① 传输区_1: S7-1200 PN CPU发送从QB100开始，长度为10个字节；
② 传输区_2: S7-1200 PN CPU接收从IB100开始，长度为10个字节；

S7-1200 项目：S7-1200 Profinet IO-Controller DiffProj_TIA V14.zap14

S7-300PN项目：S7-300 I-Device DiffProj.zap14

5.不同项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信（S7-1200 作为 I-Device，S7-300 PN 作为 IO-Controller）

1.使用环境：
① S7-1211C V4.2
② S7-315-2PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1
④ STEP 7 V5.6

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的 Profinet 通信，项目中 S7-1200 CPU 作为 I-Device，S7-300 PN 作为 IO-Controller。
S7-1200 CPU设置为 I-Device，建立两个传输区，并导出S7-1200 CPU的GSD文件：
① 传输区_1: S7-1200 CPU接收从IB100开始，长度为10个字节；
② 传输区_2: S7-1200 CPU发送从QB100开始，长度为10个字节；

S7-300 PN CPU设置为 IO-Controller，并导入S7-1200 CPU的GSD文件
① 传输区_1: S7-300 PN CPU发送从QB100开始，长度为10个字节；
② 传输区_2: S7-300 PN CPU接收从IB100开始，长度为10个字节；

S7-1200 项目：S7-1200 Profinet I-Device DiffProj.zap14

S7-300PN项目：S7-300_IO-Controller

6.不同项目中S7-1200 与 S7-300 PN 口之间 Profinet 通信（S7-1200 作为 IO-Controller，S7-300 PN 作为 I-Device）

1.使用环境：
① S7-1211C V4.2
② S7-315-2PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1
④ STEP 7 V5.6

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的 Profinet 通信，项目中 S7-1200 CPU 作为 IO-Controller，S7-300 PN 作为 I-Device。
S7-300 CPU设置为 I-Device，建立两个传输区，并导出S7-300 CPU的GSD文件：
① 传输区_1: S7-300 CPU接收从IB100开始，长度为10个字节；
② 传输区_2: S7-300 CPU发送从QB100开始，长度为10个字节；

S7-1200 PN CPU设置为 IO-Controller，并导入S7-300 CPU的GSD文件
① 传输区_1: S7-1200 PN CPU发送从QB100开始，长度为10个字节；
② 传输区_2: S7-1200 PN CPU接收从IB100开始，长度为10个字节；

S7-1200 项目：S7-1200 Profinet IO-Controller DiffProj_Step v5.6.zap14

S7-300PN项目：S7-300_I-Device


如何打开项目归档文件

S7-1200 与 S7-1200 S7 通信例程

本文为 S7-1200 与 S7-1200 进行 S7 通信的两种可能情况分别提供了例程：
1. S7-1200 与 S7-1200 在同一项目下进行 S7 通信；
2. S7-1200 与 S7-1200 在不同项目下进行 S7 通信；

1.S7-1200 与 S7-1200 S7 通信 同一项目（ 一个 S7-1200 为客户端，一个 S7-1200 为服务器）

1. 使用环境：
（1）S7-1215C V4.2与S7-1217C V4.2
（2）TIA 博途V14SP1组态

2. 实现功能：
S7-1215C作为客户端，S7-1217C作为服务器，S7-1215C读取S7-1217C的IB100～IB199，写入S7-1217C的QB100～QB199

S7_PUT_GET_Two_Side.zap14

2.S7-1200 与 S7-1200 S7 通信 不同项目（ 一个 S7-1200 为客户端，一个 S7-1200 为服务器）

1. 使用环境：
（1）S7-1215C V4.2与S7-1217C V4.2
（2）TIA 博途V14SP1组态

2. 实现功能：
S7-1215C作为客户端，S7-1217C作为服务器，S7-1215C读取S7-1217C的IB100～IB199，写入S7-1217C的QB100～QB199

客户端程序：
S7_PUT_GET_Client.zap14

服务器程序：

S7_PUT_GET_Server.zap14


如何打开项目归档文件

S7-1200 与 S7-300 PN S7 通信例程

本文为S7-1200 与 S7-300 PN 之间 S7 通信的几种可能情况分别提供了例程：
1. 同一项目中S7-1200 与 S7-300 PN 口之间 S7 通信，S7-1200 作为 S7 通信客户端，S7-300 PN 作为服务器；
2. 同一项目中S7-1200 与 S7-300 PN 口之间 S7 通信，S7-1200 作为 S7 通信服务器，S7-300 PN 作为客户端；
3. 不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信，S7-1200 作为 S7 通信客户端，S7-300 PN 作为服务器，双方 CPU 都采用 TIA V14 SP1 编程组态；
4. 不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信，S7-1200 作为 S7 通信服务器，S7-300 PN 作为客户端，双方 CPU 都采用 TIA V14 SP1 编程组态；
5. 不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信，S7-1200 作为 S7 通信客户端，S7-300 PN 作为服务器，S7-1200 使用STEP7 V14 SP1 编程组态，S7-300PN 使用 STEP 7 V5.6 编程组态；
6. 不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信，S7-1200 作为 S7 通信服务器，S7-300 PN 作为客户端，S7-1200 使用STEP7 V14 SP1 编程组态，S7-300PN 使用 STEP 7 V5.6 编程组态。

1.同一项目中S7-1200 与 S7-300 PN 口之间 S7 通信（S7-1200 作为 S7 通信客户端，S7-300 PN 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
例程用于演示同一项目中S7-1200 与 S7-300 PN 口之间的S7通信，项目中 S7-1200 CPU 作为 S7 通信的客户端，S7-300PN 作为 S7 通信的服务器。
① S7-1200 CPU调用 PUT 指令将本地数据区 DB10 块中的 10 个字节的数据传送到 S7-300 CPU的数据区 DB10 块中。
② S7-1200 CPU调用 GET 指令读取S7-300 CPU的数据区 DB11 块中10 个字节的数据存储到本地数据区 DB 11 块中。

S7 通信服务器设置：
S7-300PN 作为 S7 通信的服务器无需编写 S7 通信程序。

S7-1200_S7_Communication_With_S7-300PN_S7-1200_As_Client.zap14

2.同一项目中S7-1200 与 S7-300 PN 口之间 S7 通信（S7-1200 作为 S7 通信服务器，S7-300 PN 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
例程用于演示同一项目中S7-1200 与 S7-300 PN 口之间的S7通信，项目中 S7-1200 CPU 作为 S7 通信的服务器，S7-300PN 作为 S7 通信的客户端。
① S7-300PN CPU调用 PUT 指令将本地数据区 DB11 块中的 10 个字节的数据传送到 S7-1200 CPU的数据区 DB11 块中。
② S7-300PN CPU调用 GET 指令读取S7-1200 CPU的数据区 DB10 块中10 个字节的数据存储到本地数据区 DB 10 块中。

S7 通信服务器设置：
S7-1200 作为 S7 通信的服务器无需编写 S7 通信程序，但是需要在 CPU 属性"防护与安全 > 连接机制"中激活"允许来自远程对象的 PUT/GET 通信访问"。

S7-1200_S7_Communication_With_S7-300PN_S7-1200_As_Server.zap14

3.不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信（S7-1200 作为 S7 通信客户端，S7-300 PN 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
例程用于演示不同项目中S7-1200 与 S7-300 PN 口之间的S7通信，项目中 S7-1200 CPU 作为 S7 通信的客户端，S7-300PN 作为 S7 通信的服务器。
① S7-1200 CPU调用 PUT 指令将本地数据区 DB10 块中的 10 个字节的数据传送到 S7-300 CPU的数据区 DB10 块中。
② S7-1200 CPU调用 GET 指令读取S7-300 CPU的数据区 DB11 块中10 个字节的数据存储到本地数据区 DB 11 块中。

S7 通信服务器设置：
S7-300PN 作为 S7 通信的服务器无需编写 S7 通信程序。

注意：
S7-1200 项目中创建 S7 连接时，需要在网络视图中为"S7_连接"的属性"常规 > 地址详细信息"中将伙伴 CPU 的 TSAP 设置为 03.02 。

S7-1200 项目：Different_Projects_S7-1200_As_Client.zap14

S7-300PN项目：Different_Projects_S7-300_As_Server.zap14

4.不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信（S7-1200 作为 S7 通信服务器，S7-300 PN 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
例程用于演示不同项目中S7-1200 与 S7-300 PN 口之间的S7通信，项目中 S7-1200 CPU 作为 S7 通信的服务器，S7-300PN 作为 S7 通信的客户端。
① S7-300PN CPU调用 PUT 指令将本地数据区 DB11 块中的 10 个字节的数据传送到 S7-1200 CPU的数据区 DB11 块中。
② S7-300PN CPU调用 GET 指令读取S7-1200 CPU的数据区 DB10 块中10 个字节的数据存储到本地数据区 DB 10 块中。

S7 通信服务器设置：
S7-1200 作为 S7 通信的服务器无需编写 S7 通信程序，但是需要在 CPU 属性"防护与安全 > 连接机制"中激活"允许来自远程对象的 PUT/GET 通信访问"。

S7-1200 项目：Different_Projects_S7-1200_As_Server.zap14

S7-300PN项目：Different_Projects_S7-300_As_Client.zap14

5.不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信（S7-1200 作为 S7 通信客户端，S7-300 PN 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300PN V3.2 使用 STEP 7 V5.6 编程组态。

2.实现功能：
例程用于演示不同项目中S7-1200 与 S7-300 PN 口之间的S7通信，项目中 S7-1200 CPU 作为 S7 通信的客户端，S7-300PN 作为 S7 通信的服务器。
① S7-1200 CPU调用 PUT 指令将本地数据区 DB10 块中的 10 个字节的数据传送到 S7-300 CPU的数据区 DB10 块中。
② S7-1200 CPU调用 GET 指令读取S7-300 CPU的数据区 DB11 块中10 个字节的数据存储到本地数据区 DB 11 块中。

S7 通信服务器设置：
S7-300PN 作为 S7 通信的服务器无需编写 S7 通信程序。

注意：
S7-1200 项目中创建 S7 连接时，需要在网络视图中为"S7_连接"的属性"常规 > 地址详细信息"中将伙伴 CPU 的 TSAP 设置为 03.02 。

S7-1200 项目：S7-1200_As_Client.zap14

S7-300PN项目：S7-300_As_Server.zip

6.不同项目中S7-1200 与 S7-300 PN 口之间 S7 通信（S7-1200 作为 S7 通信服务器，S7-300 PN 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300PN V3.2 使用 STEP 7 V5.6 编程组态。

2.实现功能：
例程用于演示不同项目中S7-1200 与 S7-300 PN 口之间的S7通信，项目中 S7-1200 CPU 作为 S7 通信的服务器，S7-300PN 作为 S7 通信的客户端。
① S7-300PN CPU调用 PUT 指令将本地数据区 DB11 块中的 10 个字节的数据传送到 S7-1200 CPU的数据区 DB11 块中。
② S7-300PN CPU调用 GET 指令读取S7-1200 CPU的数据区 DB10 块中10 个字节的数据存储到本地数据区 DB 10 块中。

S7 通信服务器设置：
S7-1200 作为 S7 通信的服务器无需编写 S7 通信程序，但是需要在 CPU 属性"防护与安全 > 连接机制"中激活"允许来自远程对象的 PUT/GET 通信访问"。

S7-1200 项目：S7-1200_As_Server.zap14

S7-300PN项目：S7-300_As_Client.zip


如何打开项目归档文件

S7-1200 与 S7-300 CP343-1 S7 通信例程

本文为S7-1200 与 S7-300 CP343之间 S7 通信的几种可能情况分别提供了例程：
1. 同一项目中S7-1200 与 S7-300 CP343-1之间 S7 通信，S7-1200 作为 S7 客户端，S7-300 作为服务器；
2. 同一项目中S7-1200 与 S7-300 CP343-1之间 S7 通信，S7-1200 作为 S7 服务器，S7-300 作为客户端；
3. 不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信，S7-1200 作为 S7 客户端，S7-300 作为服务器，双方 CPU 都采用 TIA V14 SP1编程组态；
4. 不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信，S7-1200 作为 S7 服务器，S7-300 作为客户端，双方 CPU 都采用 TIA V14 SP1编程组态；
5. 不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信，S7-1200 作为 S7 客户端，S7-300 作为服务器，S7-1200 使用STEP7 V14 SP1编程组态，S7-300使用 STEP 7 V5.6 编程组态；
6. 不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信，S7-1200 作为 S7 服务器，S7-300 作为客户端，S7-1200 使用STEP7 V14 SP1编程组态，S7-300使用 STEP 7 V5.6 编程组态。

注：例程中为标准版的 CP343-1，如果为CP343-1 lean，则S7-300只能作为服务器。

1.同一项目中S7-1200 与 S7-300 CP343-1 之间 S7 通信（S7-1200 作为 S7 客户端，S7-300 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 S7 通信的客户端，S7-300 作为 S7 通信的服务器。
① S7-1200 CPU将 本地 DB10块中的 10 个字节的数据发送到 S7-300 CPU的DB11 块中。
② S7-1200 CPU将 S7-300 CPU的 DB10块中 10 个字节的数据读取到 本地DB11 块中。

1_Same_Projects_S7-1200_As_Client.zap14

2.同一项目中S7-1200 与 S7-300 CP343-1之间 S7 通信（S7-1200 作为 S7 服务器，S7-300 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 S7 通信的服务器，S7-300 作为 S7 通信的客户端。
① S7-300 CPU将 本地 DB10块中的 10 个字节的数据发送到 S7-1200 CPU的DB11 块中。
② S7-300 CPU将 S7-1200 CPU的 DB10块中 10 个字节的数据读取到 本地DB11 块中。

2_Same_Projects_S7-300_As_Client.zap14

3.不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信（S7-1200 作为 S7 客户端，S7-300 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 S7 通信的客户端，S7-300 作为 S7 通信的服务器。
① S7-1200 CPU将 本地 DB10块中的 10 个字节的数据发送到 S7-300 CPU的DB11 块中。
② S7-1200 CPU将 S7-300 CPU的 DB10块中 10 个字节的数据读取到 本地DB11 块中。

S7-1200 项目：3_Different_Projects_S7-1200_As_Client.zap14

S7-300项目：3_Different_Projects_S7-300_As_Server.zap14

4.不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信（S7-1200 作为 S7 服务器，S7-300 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 S7 通信的服务器，S7-300 作为 S7 通信的客户端。
① S7-300 CPU将 本地 DB10块中的 10 个字节的数据发送到 S7-1200 CPU的DB11 块中。
② S7-300 CPU将 S7-1200 CPU的 DB10块中 10 个字节的数据读取到 本地DB11 块中。

S7-1200 项目：4_Different_Projects_S7-1200_As_Server.zap14

S7-300项目：4_Different_Projects_S7-300_As_Client.zap14

5.不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信（S7-1200 作为 S7 客户端，S7-300 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300 V3.3 使用 STEP 7 V5.6 编程组态。

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 S7 通信的客户端，S7-300 作为 S7 通信的服务器。
① S7-1200 CPU将 本地 DB10块中的 10 个字节的数据发送到 S7-300 CPU的DB11 块中。
② S7-1200 CPU将 S7-300 CPU的 DB10块中 10 个字节的数据读取到 本地DB11 块中。

S7-1200 项目：5_Different_Projects_S7-1200_As_Client.zap14

S7-300项目：5_Different_Projects_S7-300_As_Server.zip

6.不同项目中S7-1200 与 S7-300 CP343-1之间 S7 通信（S7-1200 作为 S7 服务器，S7-300 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300 V3.3 使用 STEP 7 V5.6 编程组态。

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 S7 通信的服务器，S7-300 作为 S7 通信的客户端。
① S7-300 CPU将 本地 DB10块中的 10 个字节的数据发送到 S7-1200 CPU的DB11 块中。
② S7-300 CPU将 S7-1200 CPU的 DB10块中 10 个字节的数据读取到 本地DB11 块中。

S7-1200 项目：6_Different_Projects_S7-1200_As_Server.zap14

S7-300项目：6_Different_Projects_S7-300_As_Client.zip


如何打开项目归档文件

S7-1200 与 CP243-1 S7 通信例程

本文为 S7-1200 与 CP243-1 进行 S7 通信的两种可能情况分别提供了例程：
1. S7-1200 与 CP243-1 进行 S7 通信，S7-1200 作为 S7 客户端，CP243-1 作为服务器；
2. S7-1200 与 CP243-1 进行 S7 通信，S7-1200 作为 S7 服务器，CP243-1 作为客户端；

1.S7-1200 与 CP 243-1 S7 通信（S7-1200 作为客户端，CP243-1 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-200 和 CP243-1
③ S7-1200 编程软件（STEP7 V14 SP1 ）和 S7-200 编程软件（ STEP 7 MicroWIN V4.0 SP9）

2.实现功能：
用于演示S7-1200 与 CP243-1 进行 S7 通信，项目中S7-1200 作为客户端，CP243-1 作为服务器。
S7-1200 侧组态连接，调用程序块
①PUT 指令用于客户端给服务器发送数据，客户端将 DB3 块中的 10 个字节的数据发送到服务器的接收数据区 VB100 开始的10个字节中。 S7-200 的 V 存储区对应 S7-1200 DB1 数据块。
②GET 指令用于客户端从服务器接收数据，服务器将 VB200 开始的10 个字节的数据发送到客户端的接收数据区 DB4 块中。 S7-200 的 V 存储区对应 S7-1200 DB1 数据块。

S7Comm_S7-1200_VS_CP243_1_S.zap14

CP243-1_SERVER.mwp

2.S7-1200 与 CP 243-1 S7 通信（S7-1200 作为服务器，CP243-1 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-200 和 CP243-1
③ S7-1200 编程软件（STEP7 V14 SP1 ）和 S7-200 编程软件（ STEP 7 MicroWIN V4.0 SP9）

2.实现功能：
用于演示S7-1200 与 CP243-1 进行 S7 通信，项目中S7-1200 作为服务器 ，CP243-1 作为客户端。
CP243-1 向导配置一个S7 连接，调用 ETHx_XFR指令
①第一个 ETH0_XFR 指令用于客户端给服务器发送数据，客户端将 VB200 开始的 10 个字节的数据，发送到服务器的接收数据区 DB4 数据块中。
②第二个 ETH0_XFR 指令用于客户端从服务器接收数据，服务器将 DB3 数据块的10 个字节的数据，发送到客户端的接收数据区 VB100 开始的 10 个字节。

S7Comm_S7-1200_VS_CP243_1_C.zap14

CP243-1_CLIENT.mwp


S7-1200 与 S7-1200 TCP 通信例程

如何打开项目归档文件

S7-1200 之间在相同项目下的 TCP 通信例程

1. 使用环境：
软件：TIA 博途 STEP 7 V14 SP1
硬件：S7-1211C V4.2，S7-1217C V4.2

2. 实现功能：
项目中S7-1211C 作为 TCP 通信的客户端（主动建立连接），S7-1217C 作为 TCP 通信的服务器（被动建立连接）。
① S7-1211C 将发送数据 DB1 块中的 3 个字节的数据发送到 S7-1217C 的接收数据区 DB2 块中。
② S7-1217C 将发送数据 DB1 块中的 2 个字节的数据发送到 S7-1211C 的接收数据区 DB2 块中。

S7-1200_TCP_Same_Project.zap14

S7-1200 之间在不同项目下的 TCP 通信例程

1. 使用环境：
软件：TIA 博途 STEP 7 V14 SP1
硬件：S7-1211C V4.2，S7-1217C V4.2

2. 实现功能：
项目中S7-1211C 作为 TCP 通信的客户端（主动建立连接），S7-1217C 作为 TCP 通信的服务器（被动建立连接）。
① S7-1211C 将发送数据 DB1 块中的 3 个字节的数据发送到 S7-1217C 的接收数据区 DB2 块中。
② S7-1217C 将发送数据 DB1 块中的 2 个字节的数据发送到 S7-1211C 的接收数据区 DB2 块中。

客户端：

S7-1200_TCP_CLIENT.zap14

服务器：

S7-1200_TCP_SERVER.zap14


如何打开项目归档文件

S7-1200 与 S7-300 PN TCP 通信例程

本文为S7-1200 与 S7-300 PN 之间 TCP 通信的几种可能情况分别提供了例程：
1. 同一项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 TCP 客户端，S7-300 PN 作为服务器；
2. 同一项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 TCP 服务器，S7-300 PN 作为客户端；
3. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 TCP 客户端，S7-300 PN 作为服务器，双方 CPU 都采用 TIA V14 SP1 编程组态；
4. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 TCP 服务器，S7-300 PN 作为客户端，双方 CPU 都采用 TIA V14 SP1 编程组态；
5. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 TCP 客户端，S7-300 PN 作为服务器，S7-1200 使用STEP7 V14 SP1 编程组态，S7-300PN 使用 STEP 7 V5.6 编程组态；
6. 不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信，S7-1200 作为 TCP 服务器，S7-300 PN 作为客户端，S7-1200 使用STEP7 V14 SP1 编程组态，S7-300PN 使用 STEP 7 V5.6 编程组态。

1.同一项目中S7-1200 与 S7-300 PN 口之间 TCP 通信（S7-1200 作为 TCP 客户端，S7-300 PN 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 PN 口之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的客户端，S7-300PN 作为 TCP 通信的服务器。
① S7-1200 CPU将通讯数据区 DB10 块中的 10 个字节的数据发送到 S7-300PN CPU的接收数据区 DB10 块中。
② S7-300PN CPU将通讯数据区 DB11 块中的 10 个字节的数据发送到 S7-1200 CPU的接收数据区 DB11 块中。

S7-1200_TCP_Communication_With_S7-300PN_S7-1200_As_Client.zap14

2.同一项目中S7-1200 与 S7-300 PN 口之间 TCP 通信（S7-1200 作为 TCP 服务器，S7-300 PN 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 PN 口之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的服务器，S7-300PN 作为 TCP 通信的客户端。
① S7-1200 CPU将通讯数据区 DB10 块中的 10 个字节的数据发送到 S7-300PN CPU的接收数据区 DB10 块中。
② S7-300PN CPU将通讯数据区 DB11 块中的 10 个字节的数据发送到 S7-1200 CPU的接收数据区 DB11 块中。

S7-1200_TCP_Communication_With_S7-300PN_S7-1200_As_Server.zap14

3.不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信（S7-1200 作为 TCP 客户端，S7-300 PN 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的客户端，S7-300PN 作为 TCP 通信的服务器。
① S7-1200 CPU将通讯数据区 DB10 块中的 10 个字节的数据发送到 S7-300PN CPU的接收数据区 DB10 块中。
② S7-300PN CPU将通讯数据区 DB11 块中的 10 个字节的数据发送到 S7-1200 CPU的接收数据区 DB11 块中。

S7-1200 项目：Different_Projects_S7-1200_As_Client.zap14

S7-300PN项目：Different_Projects_S7-300_As_Server.zap14

4.不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信（S7-1200 作为 TCP 服务器，S7-300 PN 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的服务器，S7-300PN 作为 TCP 通信的客户端。
① S7-1200 CPU将通讯数据区 DB10 块中的 10 个字节的数据发送到 S7-300PN CPU的接收数据区 DB10 块中。
② S7-300PN CPU将通讯数据区 DB11 块中的 10 个字节的数据发送到 S7-1200 CPU的接收数据区 DB11 块中。

S7-1200 项目：Different_Projects_S7-1200_As_Server.zap14

S7-300PN项目：Different_Projects_S7-300_As_Client.zap14

5.不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信（S7-1200 作为 TCP 客户端，S7-300 PN 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300PN V3.2 使用 STEP 7 V5.6 编程组态。

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的客户端，S7-300PN 作为 TCP 通信的服务器。
① S7-1200 CPU将通讯数据区 DB10 块中的 10 个字节的数据发送到 S7-300PN CPU的接收数据区 DB10 块中。
② S7-300PN CPU将通讯数据区 DB11 块中的 10 个字节的数据发送到 S7-1200 CPU的接收数据区 DB11 块中。

S7-1200 项目：S7-1200_As_Client.zap14

S7-300PN项目：S7-300_As_Server.zip

6.不同项目中S7-1200 与 S7-300 PN 口之间 TCP 通信（S7-1200 作为 TCP 服务器，S7-300 PN 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300PN V3.2
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300PN V3.2 使用 STEP 7 V5.6 编程组态。

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 PN 口之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的服务器，S7-300PN 作为 TCP 通信的客户端。
① S7-1200 CPU将通讯数据区 DB10 块中的 10 个字节的数据发送到 S7-300PN CPU的接收数据区 DB10 块中。
② S7-300PN CPU将通讯数据区 DB11 块中的 10 个字节的数据发送到 S7-1200 CPU的接收数据区 DB11 块中。

S7-1200 项目：S7-1200_As_Server.zap14

S7-300PN项目：S7-300_As_Client.zip


如何打开项目归档文件

S7-1200 与 S7-300 CP343-1 TCP 通信例程

本文为S7-1200 与 S7-300 CP343-1 之间 TCP 通信的几种可能情况分别提供了例程：
1. 同一项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信，S7-1200 作为 TCP 客户端，S7-300 CP343-1 作为服务器；
2. 同一项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信，S7-1200 作为 TCP 服务器，S7-300 CP343-1 作为客户端；
3. 不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信，S7-1200 作为 TCP 客户端，S7-300 CP343-1 作为服务器，双方 CPU 都采用 TIA V14 SP 编程组态；
4. 不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信，S7-1200 作为 TCP 服务器，S7-300 CP343-1 作为客户端，双方 CPU 都采用 TIA V14 SP 编程组态；
5. 不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信，S7-1200 作为 TCP 客户端，S7-300 CP343-1 作为服务器，S7-1200 使用STEP7 V14 SP1编程组态，S7-300PN 使用 STEP 7 V5.6 编程组态；
6. 不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信，S7-1200 作为 TCP 服务器，S7-300 CP343-1 作为客户端，S7-1200 使用STEP7 V14 SP1编程组态，S7-300PN 使用 STEP 7 V5.6 编程组态。

1.同一项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信（S7-1200 作为 TCP 客户端，S7-300 CP343-1 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的客户端，S7-300 作为 TCP 通信的服务器。
① S7-1200 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-300 CPU的 DB11 块中。
② S7-300 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-1200 CPU的 DB11 块中。

1_Same_Projects_S7-1200_As_Client.zap14

2.同一项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信（S7-1200 作为 TCP 服务器，S7-300 CP343-1 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示同一项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的服务器，S7-300 作为 TCP 通信的客户端。
① S7-1200 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-300 CPU的 DB11 块中。
② S7-300 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-1200 CPU的 DB11 块中。

2_Same_Projects_S7-300_As_Client.zap14

3.不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信（S7-1200 作为 TCP 客户端，S7-300 CP343-1 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的客户端，S7-300 作为 TCP 通信的服务器。
① S7-1200 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-300 CPU的 DB11 块中。
② S7-300 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-1200 CPU的 DB11 块中。

S7-1200 项目：3_Different_Projects_S7-1200_As_Client_1.zap14

S7-300项目： 3_Different_Projects_S7-300_As_Server.zap14

4.不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信（S7-1200 作为 TCP 服务器，S7-300 CP343-1 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ STEP7 V14 SP1

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的服务器，S7-300 作为 TCP 通信的客户端。
① S7-1200 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-300 CPU的 DB11 块中。
② S7-300 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-1200 CPU的 DB11 块中。

S7-1200 项目：4_Different_Projects_S7-1200_As_Server.zap14

S7-300项目：4_Different_Projects_S7-300_As_Client.zap14

5.不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信（S7-1200 作为 TCP 客户端，S7-300 CP343-1 作为服务器）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300 V3.3 使用 STEP 7 V5.6 编程组态。

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的客户端，S7-300 作为 TCP 通信的服务器。
① S7-1200 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-300 CPU的 DB11 块中。
② S7-300 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-1200 CPU的 DB11 块中。

S7-1200 项目：5_Different_Projects_S7-1200_As_Client.zap14

S7-300项目：5_Different_Projects_S7-300_As_Server.zip

6.不同项目中S7-1200 与 S7-300 CP343-1之间 TCP 通信（S7-1200 作为 TCP 服务器，S7-300 CP343-1 作为客户端）

1.使用环境：
① S7-1200 V4.2
② S7-300 V3.3 ; CP343-1 V3.0
③ S7-1200 V4.2 使用STEP7 V14 SP1编程组态；S7-300 V3.3 使用 STEP 7 V5.6 编程组态。

2.实现功能：
用于演示不同项目中S7-1200 与 S7-300 CP343-1之间的以太网通信，项目中 S7-1200 CPU 作为 TCP 通信的服务器，S7-300 作为 TCP 通信的客户端。
① S7-1200 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-300 CPU的 DB11 块中。
② S7-300 CPU将本地 DB10 块中的 10 个字节的数据发送到 S7-1200 CPU的 DB11 块中。

S7-1200 项目：6_Different_Projects_S7-1200_As_Server_1.zap14

S7-300项目：6_Different_Projects_S7-300_As_Client.zip


如何打开项目归档文件

S7-1200 与 S7-1200 Modbus TCP 通信例程

1. 使用环境：
（1）S7-1215C V4.2与S7-1217C V4.2
（2）TIA 博途V14SP1组态

2. 实现功能：
S7-1215C作为客户端，S7-1217C作为服务器，S7-1215C读取S7-1217C的40001~40008的数据并存储到MW100 ~ MW114， 将MW116 ~ MW130 的数据写入到S7-1217C的 40009~40016

Modbus TCP.zap14


S7-1200 与 S7-300 PROFIBUS DP主从通信

如何打开项目归档文件

S7-1200 和 S7-300 PROFIBUS DP主从通信例程

本文为S7-1200 与 S7-300 之间 PROFIBUS DP主从通信的几种可能情况分别提供了例程：
1. 同一项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站；
2. 不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站，双方 CPU 都采用 TIA V14 SP1 编程组态；
3. 不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态；

4. 同一项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站；
5. 不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站，双方 CPU 都采用 TIA V14 SP1 编程组态；
6. 不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态；

1.同一项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站

1.使用环境：
① S7-1212C V4.2 CM1243-5 V1.3
② S7-315-2 PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现同一项目中 S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站。

1_1200M_300S.zap14

2.不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站，双方 CPU 都采用 TIA V14 SP1 编程组态

1.使用环境：
① S7-1212C V4.2 CM1243-5 V1.3
② S7-315-2 PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现不同项目中 S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站。

2_1200M.zap14

2_300S.zap14

3.不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态

1.使用环境：
① S7-1212C V4.2 CM1243-5 V1.3
② S7-315-2 PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1
④ STEP 7 V5.6

2.实现功能：
用于实现不同项目中 S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，S7-300 集成 DP 口作为 DP 从站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态。

3_1200M.zap14

3_300S.zip

4.同一项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站

1.使用环境：
① S7-1212C V4.2 CM1242-5 V1.0
② S7-315-2 PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现同一项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站。

1_300M_1200S.zap14

5.不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站，双方 CPU 都采用 TIA V14 SP1 编程组态

1.使用环境：
① S7-1212C V4.2 CM1242-5 V1.0
② S7-315-2 PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站。

 2_1200S.zap14

2_300M.zap14

6.不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态

1.使用环境：
① S7-1212C V4.2 CM1242-5 V1.0
② S7-315-2 PN/DP V3.2
③ TIA 博途 STEP7 V14 SP1
④ STEP 7 V5.6

2.实现功能：
用于实现不同项目中S7-1200 与 S7-300 集成 DP 口之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，S7-300 集成 DP 口作为 DP 主站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态。
3_1200S.zap14

3_300M.zip


S7-1200 与 CP342-5 PROFIBUS DP主从通信

如何打开项目归档文件

S7-1200 和 CP342-5 PROFIBUS DP主从通信例程

本文为S7-1200 与 CP342-5 之间 PROFIBUS DP主从通信的几种可能情况分别提供了例程：

1. 同一项目中S7-1200 与 S7-300 CP342-5 之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，CP342-5作为 DP 从站；
2. 不同项目中S7-1200 与 S7-300 CP342-5 之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，CP342-5作为 DP 从站，双方 CPU 都采用 TIA V14 SP1 编程组态；
3. 不同项目中S7-1200 与 S7-300 CP342-5 之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站，CP342-5作为 DP 从站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态；

4. 同一项目中S7-1200 与 S7-300 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，CP342-5作为 DP 主站；
5. 不同项目中S7-1200 与 S7-300 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，CP342-5作为 DP 主站，双方 CPU 都采用 TIA V14 SP1 编程组态；
6. 不同项目中S7-1200 与 S7-300 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站，CP342-5作为 DP 主站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态。

1.同一项目中S7-1200 与 S7-300 CP342-5 之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站， CP342-5 作为 DP 从站

1.使用环境：
① S7-1212C V4.2 CM1243-5 V1.3
② S7-315-2 PN/DP V3.2 CP342-5 V5.0
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现同一项目中 S7-1200 与 CP342-5 之间 DP 主从通信，项目中 S7-1200 通过CM1243-5作为 DP 主站， S7-300通过CP342-5 作为 DP 从站。

 1_1200M_CP342-5S.zap14

2.不同项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站， CP342-5 作为 DP 从站，双方 CPU 都采用 TIA V14 SP1 编程组态

1.使用环境：
① S7-1212C V4.2 CM1243-5 V1.3
② S7-315-2 PN/DP V3.2 CP342-5 V5.0
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现不同项目中 S7-1200 与 CP342-5 之间 DP 主从通信，项目中 S7-1200 通过CM1243-5作为 DP 主站， S7-300通过CP342-5 作为 DP 从站。

2_1200M.zap14

2_CP342-5S.zap14

3.不同项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1243-5作为 DP 主站， CP342-5 作为 DP 从站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态

1.使用环境：
① S7-1212C V4.2 CM1243-5 V1.3
② S7-315-2 PN/DP V3.2 CP342-5 V5.0
③ TIA 博途 STEP7 V14 SP1
④ STEP 7 V5.6

2.实现功能：
用于实现不同项目中 S7-1200 与 CP342-5 DP 主从通信，项目中 S7-1200 通过CM1243-5作为 DP 主站， S7-300通过CP342-5 作为 DP 从站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态。

3_1200M.zap14

3_CP342-5S.zip

4.同一项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站， CP342-5 作为 DP 主站

1.使用环境：
① S7-1212C V4.2 CM1242-5 V1.0
② S7-315-2 PN/DP V3.2 CP342-5 V5.0
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现同一项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站， S7-300通过CP342-5 作为 DP 主站。

1_CP342-5M_1200S.zap14

5.不同项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站， CP342-5 作为 DP 主站，双方 CPU 都采用 TIA V14 SP1 编程组态

1.使用环境：
① S7-1212C V4.2 CM1242-5 V1.0
② S7-315-2 PN/DP V3.2 CP342-5 V5.0
③ TIA 博途 STEP7 V14 SP1

2.实现功能：
用于实现不同项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站， S7-300通过CP342-5 作为 DP 主站。

 2_1200S.zap14

2_CP342-5M.zap14

6.不同项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站， CP342-5 作为 DP 主站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态

1.使用环境：
① S7-1212C V4.2 CM1242-5 V1.0
② S7-315-2 PN/DP V3.2 CP342-5 V5.0
③ TIA 博途 STEP7 V14 SP1
④ STEP 7 V5.6

2.实现功能：
用于实现不同项目中S7-1200 与 CP342-5 之间 DP 主从通信，S7-1200 通过CM1242-5作为 DP 从站， S7-300通过CP342-5 作为 DP 主站，S7-1200 使用STEP7 V14 SP1编程组态，S7-300 使用 STEP 7 V5.6 编程组态。

3_1200S.zap14

3_CP342-5M.zip


S7-1200 与 S7-1200 Modbus RTU 通信例程

如何打开项目归档文件

S7-1200 与S7-1200 Modbus RTU 通信例程

1.使用环境
① S7-1217C V4.2、S7-1215C V4.2、CM1241 RS422/RS485 V2.2
② TIA 博途 STEP 7 V14SP1

2.实现功能
CPU 1217 作为 Modbus RTU 主站， CPU 1215 作为 Modbus RTU 从站，实现 S7-1200 PLC 两个串口通信模块 CM1241 RS422/485 之间的 Modbus RTU 通信，主站轮询读写从站数据。
① CPU 1217 Modbus RTU 主站读取 CPU1215 Modbus RTU 从站保持寄存器 40001 地址开始的两个字长的数据并存储到 DB3.DBW0 和 DB3.DBW2。
② CPU 1217 Modbus RTU 主站将 DB3.DBW20～DB3.DBW26 四个字长的数据写入到 CPU1215 Modbus RTU 从站 40003 开始的保持寄存器。
③ CPU 1217 Modbus RTU 主站将 DB3.DBX40.0～DB3.DBX40.7 八个位的数据写入到 CPU1215 Modbus RTU 从站 Q0.0～Q0.7。

S7-1200 PLC 的 Modbus RTU 有两类指令"MODBUS (RTU) "和"MODBUS"，如图1所示。指令区别和适用范围参考以下的各指令编程例程介绍。

图1.S7-1200 PLC 的 Modbus RTU 通信指令

1. MODBUS (RTU) 指令编程例程

“MODBUS (RTU) ”指令集指令适用于S7-1200 中央机架的 CM1241 V2.1 或 CB1241 且 S7-1200 CPU V4.1以上和分布式 IO PROFINET 或 PROFIBUS 的 ET200MP、ET200SP 串口通信模块。

S7-1200 Modbus RTU.zap14

2. MODBUS 指令编程例程

“MODBUS” 指令集指令只适用于 S7-1200 中央机架的 CM1241 或 CB1241。

S7-1200 Modbus.zap14


S7-1200 与 西门子传动设备 USS 通信例程

如何打开项目归档文件

S7-1200 与西门子传动设备之间USS 通信例程

1.使用环境：
① S7-1215C V4.2、CM1241 RS422/RS485 V2.2
② TIA 博途 STEP 7 V14SP1

2.实现功能：
S7-1200 与西门子传动设备之间USS 通信

S7-1200 PLC 的 USS 有两类指令"USS通信"和"USS"，如图1所示。指令区别和适用范围参考以下的各指令编程例程介绍。

图1.S7-1200 PLC 的 USS 通信指令

1."USS通信"指令集编程例程

“USS通信”指令集指令适用于S7-1200 中央机架的 CM1241 V2.1 或 CB1241 且 S7-1200 CPU V4.1以上和分布式 IO PROFINET 或 PROFIBUS 的 ET200MP、ET200SP 串口通信模块。

USS通信.zap14

2."USS"指令集编程例程

“USS”指令集指令只适用于 S7-1200 中央机架的 CM1241 或 CB1241。

USS.zap14


运动控制

如何打开项目归档文件

S7-1200运动控制例程

本文为S7-1200 运动控制的几种可能情况分别提供了例程：
1. 通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为"脉冲"；
2. 通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为“mm”；
3. 使用命令表功能将多个单独的轴控制命令组合到一个运动顺序中；
4. 通过模拟量输出控制伺服进行闭环控制；
5. 通过基于PROFINET的PROFIdrive方式与V90 PN连接；

1.通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为"脉冲"

1.使用环境
S7-1217C V4.2使用TIA博途V14 SP1组态。

2.实现功能
通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为"脉冲"，忽略"电机每转的脉冲数"和"电机每转的负载位移"参数。运控指令的速度单位为"脉冲/s",位置单位为"脉冲"。
实现如下功能：轴的点动，轴按指定速度运行，轴执行相对定位，轴执行绝对定位，轴停止，读写轴的参数。

S7-1200 _MotionControl_1.zap14

2.通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为“mm”

1.使用环境
S7-1217C V4.2使用TIA博途V14 SP1组态。

2.实现功能
通过发送PTO脉冲的方式控制驱动器，工艺对象组态的测量单位为mm，根据系统的实际情况设置"电机每转的脉冲数"和"电机每转的负载位移"参数。运控指令的速度单位为"mm/s"，位置单位为"mm"。
实现如下功能：轴的点动，轴按指定速度运行，轴执行相对定位，轴执行绝对定位，轴停止，读写轴的参数。

S7-1200 _MotionControl_2.zap14

3.使用命令表功能将多个单独的轴控制命令组合到一个运动顺序中

1.使用环境
S7-1217C V4.2使用TIA博途V14 SP1组态。

2.实现功能
通过发送PTO脉冲的方式控制驱动器.使用命令表功能将多个单独的轴控制命令组合到一个运动顺序中。
工艺对象组态的测量单位为mm，根据系统的实际情况设置"电机每转的脉冲数"和"电机每转的负载位移"参数。运控指令的速度单位为"mm/s"，位置单位为"mm"。
实现如下功能：轴的点动，轴按指定速度运行，轴执行相对定位，轴执行绝对定位，轴停止，读写轴的参数。

S7-1200 _MotionControl_3.zap14

4.通过模拟量输出控制伺服进行闭环控制

1.使用环境
S7-1217C V4.2使用TIA博途V14 SP1组态。

2.实现功能
通过模拟量输出控制伺服进行闭环控制，控制对象为V90。V90 PTO位置反馈信号为5V差分信号，S7-1200 CPU只有CPU 1217C才支持5V差分输入信号。工艺对象组态的测量单位为mm，根据系统的实际情况设置"编码器"和"机械"参数。运控指令的速度单位为"mm/s"，位置单位为"mm"。在运动轴调试初期，可以将"随动误差"设置为较大值以避免运动轴频繁出现随动误差错误。
实现如下功能：轴的点动，轴按指定速度运行，轴执行相对定位，轴执行绝对定位，轴停止，读写轴的参数。

S7-1200 _MotionControl_4.zap14

5. 通过基于PROFINET的PROFIdrive方式与V90 PN连接

1.使用环境
S7-1217C V4.2使用TIA博途V14 SP1组态。

2.实现功能
通过基于PROFINET的PROFIdrive方式与V90 PN连接，工艺对象组态的测量单位为mm，根据系统的实际情况设置"电机每转的负载位移"参数。运控指令的速度单位为"mm/s"，位置单位为"mm"。在运动轴调试初期，可以将"随动误差"设置为较大值以避免运动轴频繁出现随动误差错误。
实现如下功能：轴的点动，轴按指定速度运行，轴执行相对定位，轴执行绝对定位，轴停止，读写轴的参数。

S7-1200 _MotionControl_5.zap14


高速计数器

如何打开项目归档文件

S7-1200 高速计数器例程

本文为S7-1200 高速计数器提供了三个例程：
1. 高速计数器基本指令CTRL_HSC使用例程
2. 高速计数器扩展指令CTRL_HSC_EXT使用例程；
3. 高速计数器断电数据保持例程；

1.高速计数器基本指令CTRL_HSC使用

1.使用环境：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能： 使用高速计数器基本指令更改初始值、参考值及方向。

CTRL_HSC

2.高速计数器扩展指令CTRL_HSC_EXT使用

1.使用环境：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能：
① 使用高速计数器扩展指令实现同步功能。
② 使用高速计数器扩展指令实现捕获功能。
③ 使用高速计数器扩展指令实现频率测量功能。
④ 使用高速计数器扩展指令实现周期测量功能。

CTRL_HSC_EXT

3.高速计数器断电数据保持例程

1.使用环境：
① S7-1200 V4.2
② STEP7 V14 SP1

2.实现功能： 高速计数器断电或停机后实现数据保持。

CurrentCount_Retain